<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="pingback" href="https://www.rosehosting.com/blog/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://www.rosehosting.com/blog/wp-content/themes/Extra/scripts/ext/html5.js' defer " type="text/javascript"></script>
	<![endif]-->

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P4FHJW');</script>

<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<script>var et_site_url='https://www.rosehosting.com/blog';var et_post_id='27029';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>How to Fix the 502 Bad Gateway Error in WordPress | RoseHosting Blog</title>

<link rel="author" href="https://plus.google.com/+RoseHosting" />
<meta name="description" content="Have you ever seen the very annoying and frustrating 502 bad gateway error on a WordPress site? Yes, I think we all have encountered the issue. Do you know what 502 bad gateway error means? Do you know how to solve the issue? In this blog post, we will provide you with detailed information about the 502 Bad Gateway" />
<meta name="keywords" content="502 bad gateway,wordpress" />
<link rel="canonical" href="https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/" />
<meta property="og:title" content="How to Fix the 502 Bad Gateway Error in WordPress" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/" />
<meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/How-to-Fix-the-502-Bad-Gateway-Error-in-WordPress-1.jpg" />
<meta property="og:site_name" content="RoseHosting.com Blog" />
<meta property="og:description" content="Have you ever seen the very annoying and frustrating 502 bad gateway error on a WordPress site? Yes, I think we all have encountered the issue. Do you know what 502 bad gateway error means? Do you know how to solve the issue? In this blog post, we will provide you with detailed information about the 502 Bad Gateway Error in WordPress, and tell you how to troubleshoot the 502 Bad Gateway Error in WordPress as well. What does 502 Bad Gateway Error means? The 502 Bad Gateway error is an HTTP status code that means that one server on the internet received an invalid response from another server. In more technical words, A 502 Bad Gateway means that the proxy (gateway) server wasn&#039;t able to get a valid or any response from the upstream server. The official documentation from W3.org, states that HTTP status codes starting with 5 (5xxx) relate to errors that occur when there&#039;s a miscommunication between several servers. If you are seeing a 502 bad gateway error on a website, it means that" />
<meta property="article:tag" content="502 bad gateway" />
<meta property="article:tag" content="wordpress" />
<meta property="article:tag" content="cms" />
<meta property="article:tag" content="networking and domains" />
<meta property="article:publisher" content="https://www.facebook.com/RoseHosting/" />
<meta property="article:author" content="https://www.facebook.com/RoseHosting/" />
<meta property="article:published_time" content="2018-06-05T07:42:33Z" />
<meta property="article:modified_time" content="2018-06-05T07:42:33Z" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@RoseHosting" />
<meta name="twitter:creator" content="@rosehosting" />
<meta name="twitter:title" content="How to Fix the 502 Bad Gateway Error in WordPress" />
<meta name="twitter:description" content="Have you ever seen the very annoying and frustrating 502 bad gateway error on a WordPress site? Yes, I think we all have encountered the issue. Do you know what 502 bad gateway error means? Do you know how to solve the issue? In this blog post, we will provide you with detailed information about the 502 Bad Gateway Error in WordPress, and tell you how to troubleshoot the 502 Bad Gateway Error in WordPress as well. What does 502 Bad Gateway Error means? The 502 Bad Gateway error is an HTTP status code that means that one server on the internet received an invalid response from another server. In more technical words, A 502 Bad Gateway means that the proxy (gateway) server wasn&#039;t able to get a valid or any response from the upstream server. The official documentation from W3.org, states that HTTP status codes starting with 5 (5xxx) relate to errors that occur when there&#039;s a miscommunication between several servers. If you are seeing a 502 bad gateway error on a website, it means that" />
<meta name="twitter:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/How-to-Fix-the-502-Bad-Gateway-Error-in-WordPress-1.jpg" />

<link rel="amphtml" href="https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/amp/" /><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="RoseHosting Blog &raquo; Feed" href="https://www.rosehosting.com/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting Blog &raquo; Comments Feed" href="https://www.rosehosting.com/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting Blog &raquo; How to Fix the 502 Bad Gateway Error in WordPress Comments Feed" href="https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.rosehosting.com\/blog\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><meta content="rh2018 v.1.0.0" name="generator" /><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='parent-style-css' href='https://www.rosehosting.com/blog/wp-content/themes/Extra/style.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css' href='https://www.rosehosting.com/blog/wp-content/themes/rh2018/css/bootstrap.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='theme-style-css' href='https://www.rosehosting.com/blog/wp-content/themes/rh2018/css/theme.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css' href='https://www.rosehosting.com/blog/wp-content/themes/rh2018/style.css?ver=2.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='et-builder-googlefonts-cached-css' href='https://fonts.googleapis.com/css?family=Cabin%3Aregular%2Citalic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic&#038;ver=4.9.6#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://www.rosehosting.com/blog/wp-includes/css/dashicons.min.css?ver=4.9.6' type='text/css' media='all' />
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1' defer '></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/popper.js/1.11.0/umd/popper.min.js?ver=1.11' defer '></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2018/js/bootstrap.js?ver=4' defer '></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2018/js/cookieconsent.min.js?ver=1' defer '></script>
<link rel='https://api.w.org/' href='https://www.rosehosting.com/blog/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rosehosting.com/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rosehosting.com/blog/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='How to Install Matomo on Ubuntu 16.04' href='https://www.rosehosting.com/blog/how-to-install-matomo-on-ubuntu-16-04/' />
<link rel='next' title='How To Set Up SSH Keys on Ubuntu 16.04' href='https://www.rosehosting.com/blog/how-to-set-up-ssh-keys-on-ubuntu-16-04/' />
<meta name="generator" content="WordPress 4.9.6" />
<link rel='shortlink' href='https://www.rosehosting.com/blog/?p=27029' />
<link rel="alternate" type="application/json+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-fix-the-502-bad-gateway-error-in-wordpress%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-fix-the-502-bad-gateway-error-in-wordpress%2F&#038;format=xml" />
<meta property="fb:pages" content="195648843783690" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" />
<script type="text/javascript">var essb_settings = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","essb3_nonce":"062458f8d1","essb3_plugin_url":"https:\/\/www.rosehosting.com\/blog\/wp-content\/plugins\/easy-social-share-buttons3","essb3_stats":false,"essb3_ga":false,"essb3_ga_mode":"simple","blog_url":"https:\/\/www.rosehosting.com\/blog\/","essb3_postfloat_stay":false,"post_id":27029};var essb_buttons_exist = !!document.getElementsByClassName("essb_links"); if(essb_buttons_exist == true) { document.addEventListener("DOMContentLoaded", function(event) { var ESSB_CACHE_URL = "https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/"; if(ESSB_CACHE_URL.indexOf("?") > -1) { ESSB_CACHE_URL += "&essb_counter_cache=rebuild"; } else { ESSB_CACHE_URL += "?essb_counter_cache=rebuild"; }; var xhr = new XMLHttpRequest(); xhr.open("GET",ESSB_CACHE_URL,true); xhr.send(); });}</script><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-270x270.png" />
<link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://www.rosehosting.com/blog/wp-content/cache/et/global/et-extra-customizer-global-1528278185268.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /></head>
<body class="post-template-default single single-post postid-27029 single-format-standard et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et_minified_js et_minified_css">

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-P4FHJW"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="page-container" class="page-container">
<nav class="navbar yamm navbar-expand-lg navbar-dark" role="navigation">
<div class="container no-override">
<a class="navbar-brand" href="https://www.rosehosting.com/">
<img alt="RoseHosting.com" width="186" height="37" class="d-lg-inline mr-2" src="https://www.rosehosting.com/blog/wp-content/themes/rh2018/img/rh-logo.svg" />
</a>
<button class="navbar-toggler" data-toggle="collapse" data-target="#navbar-collapse">
<span class="navbar-toggler-icon"></span>
</button>
<div class="collapse navbar-collapse justify-content-end" id="navbar-collapse">
<ul class="navbar-nav">
<li class="nav-item active dropdown">
<a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
Hosting Solutions
<i class="fa fa-chevron-down"></i>
</a>
<div class="dropdown-menu" role="menu">
<div class="yamm-content">
<div class="row">
<div class="col-sm-6">
<span class="text-primary  dropdown-header"><strong>Managed SSD Hosting</strong></span>
<div class="dropdown-divider"></div>
<a class="dropdown-item" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
<a class="dropdown-item" href="https://www.rosehosting.com/vps-hosting.html">VPS Hosting</a>
<a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom VPS</a>
<a class="dropdown-item" href="https://www.rosehosting.com/cloud-hosting.html">Cloud Hosting</a>
<a class="dropdown-item" href="https://www.rosehosting.com/dedicated-servers.html">Cloud Dedicated Servers</a>
</div>
<div class="col-sm-6">
<span class="text-primary dropdown-header"><strong>Managed Solutions</strong></span>
<div class="dropdown-divider"></div>
<a class="dropdown-item" href="https://www.rosehosting.com/wordpress-hosting.html">
Wordpress Hosting
<small class="d-block text-muted"><i>The best blogging platform</i></small>
</a>
<a class="dropdown-item" href="https://www.rosehosting.com/magento-hosting.html">
Magento Hosting
<small class="d-block text-muted"><i>The best e-commerce platform</i></small>
</a>
<a class="dropdown-item" href="https://www.rosehosting.com/odoo-hosting.html">
Odoo Hosting
<small class="d-block text-muted"><i>The best CRM/ERP platform</i></small>
</a>
<span class="dropdown-item"><a class="btn-shadow btn-shadow-primary btn-shadow-sm" target="_blank" href="#">Other Solutions</a></span>
</div>
</div>
</div>
</div>
</li>
<li class="nav-item dropdown">
<a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
SSL / Domains
<i class="fa fa-chevron-down"></i>
</a>
<div class="dropdown-menu" role="menu">
<div class="yamm-content">
<div class="row">
<div class="col-sm-3">
<span class="text-primary  dropdown-header"><strong>SSL by brand</strong></span>
<div class="dropdown-divider"></div>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#geotrust">GeoTrust</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#comodo">Comodo</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#rapidssl">RapidSSL</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#thawte">Thawte</a>
</div>
<div class="col-sm-4">
<span class="text-primary  dropdown-header"><strong>SSL by Type</strong></span>
<div class="dropdown-divider"></div>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#domain_validation">Domain Validation</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#organization_validation">Organization Validation</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#extended_validation">Extended Validation</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#wildcard_ssl">Wildcard SSL</a>
</div>
<div class="col-sm-3">
<span class="text-primary dropdown-header"><strong>Domains</strong></span>
<div class="dropdown-divider"></div>
<a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Register Domains</a>
<a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Transfer Domains</a>
</div>
</div>
</div>
</div>
<li class="nav-item dropdown">
<a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
Support
<i class="fa fa-chevron-down"></i>
</a>
<div class="dropdown-menu" role="menu">
<a class="dropdown-item" href="https://www.rosehosting.com/support.html">24/7 Managed Support</a>
<a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Open a Support Ticket</a>
<a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>
<a class="dropdown-item" href="https://status.rosehosting.com">Systems Status</a>
</div>
</li>
<li class="nav-item dropdown">
<a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
About Us
<i class="fa fa-chevron-down"></i>
</a>
<div class="dropdown-menu" role="menu">
<a class="dropdown-item" href="https://www.rosehosting.com/about-us.html">Our Company</a>
<a class="dropdown-item" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
<a class="dropdown-item" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
<a class="dropdown-item" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
<a class="dropdown-item" href="https://www.rosehosting.com/policies.html">Our Policies</a>
</div>
</li>
<li class="nav-item">
<a class="nav-link" href="https://www.rosehosting.com/blog/">Blog</a>
</li>
<li class="nav-item">
<a class="nav-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Affiliates</a>
</li>
<li class="nav-item">
<a class="nav-link nav-link--rounded" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Login</a>
</li>
</ul>
</div>
</div>
</nav>
<nav class="navbar navbar-expand-md navbar-light bg-faded navbar-blog">
<div class="container no-override">
<a href="https://www.rosehosting.com/blog" class="navbar-brand">Blog Home</a>
<div class="navbar-collapse collapse d-flex justify-content-between" id="navbar5-blog">
<ul class="navbar-nav categories">
<li class="nav-item dropdown">
<a class="nav-link dropdown-toggle" data-toggle="dropdown" href="#" role="button" aria-haspopup="true" aria-expanded="false">
Categories
<i class="fa fa-chevron-down"></i>
</a>
<div class="dropdown-menu">
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/centos/">CentOS</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/cms/">CMS</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/control-panels/">Control Panels</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/databases/">Databases</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/debian/">Debian</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/e-commerce/">E-Commerce</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/email-servers/">Email Servers</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/guides/">Guides</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/miscellaneous/">Miscellaneous</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/networking-and-domains/">Networking and Domains</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/news/">News</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/optimization/">Optimization</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/rosehosting/">RoseHosting Platform</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/scripts/">Scripts</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/security/">Security</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/seo/">SEO</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tips-and-tricks/">Tips and Tricks</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tutorials/">Tutorials</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/ubuntu/">Ubuntu</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-frameworks/">Web Frameworks</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-servers/">Web Servers</a>
</div>
</li>
</ul>
<form class="mx-2 my-auto d-inline" method="get" id="searchform" action="https://www.rosehosting.com/blog/">
<div class="input-group">
<input type="search" class="field" name="s" id="s" class="form-control border border-right-0" placeholder="Search...">
<span class="input-group-append">
<button name="submit" id="searchsubmit" class="btn btn-outline-secondary border border-left-0" type="submit">
<i class="fa fa-search"></i>
</button>
</span>
</div>
</form>
</div>
</div>
</nav>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<article id="post-27029" class="module single-post-module post-27029 post type-post status-publish format-standard has-post-thumbnail hentry category-cms category-networking-and-domains tag-502-bad-gateway tag-wordpress et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">How to Fix the 502 Bad Gateway Error in WordPress</h1>
<div class="post-meta vcard">
<p><span class="updated">Jun 5, 2018</span> | <a href="https://www.rosehosting.com/blog/category/cms/" rel="tag">CMS</a>, <a href="https://www.rosehosting.com/blog/category/networking-and-domains/" rel="tag">Networking and Domains</a> | <a class="comments-link" href="https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a></p>
</div>
</div>
<div class="post-thumbnail header">
<img src="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/How-to-Fix-the-502-Bad-Gateway-Error-in-WordPress-1.jpg" alt="How to Fix the 502 Bad Gateway Error in WordPress" /> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<div class="roseh-before-content" style="text-align: center; " id="roseh-173461100"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="1066282313"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><p><img class="alignnone size-full wp-image-27082" src="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/How-to-Fix-the-502-Bad-Gateway-Error-in-WordPress.jpg" alt="How to Fix the 502 Bad Gateway Error in WordPress" width="742" height="371" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/How-to-Fix-the-502-Bad-Gateway-Error-in-WordPress.jpg 742w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/How-to-Fix-the-502-Bad-Gateway-Error-in-WordPress-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/How-to-Fix-the-502-Bad-Gateway-Error-in-WordPress-300x150.jpg 300w" sizes="(max-width: 742px) 100vw, 742px"></p>
<div class="roseh-after-first-image" style="float: right; " id="roseh-2031487815"><div style="float: right; margin-left: 10px; " id="roseh-1953244093"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="2385735863"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><p>Have you ever seen the very annoying and frustrating 502 bad gateway error on a WordPress site? Yes, I think we all have encountered the issue. Do you know what 502 bad gateway error means? Do you know how to solve the issue? In this blog post, we will provide you with detailed information about the 502 Bad Gateway Error in WordPress, and tell you how to troubleshoot the 502 Bad Gateway Error in WordPress as well. <span id="more-27029"></span></p>
<h2>What does 502 Bad Gateway Error means?</h2>
<p><span style="font-weight: 400;">The 502 Bad Gateway error is an </span><a href="https://en.wikipedia.org/wiki/List_of_HTTP_status_codes" target="_blank" rel="noopener"><span style="font-weight: 400;">HTTP status code</span></a><span style="font-weight: 400;"> that means that one server on the internet received an invalid response from another server. In more technical words, </span><span style="font-weight: 400;">A 502 Bad Gateway means that the proxy (gateway) server wasn’t able to get a valid or any response from the upstream server.</span></p>
<p><a href="tps://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html" target="_blank" rel="noopener">The official documentation from W3.org,</a> states that HTTP status codes starting with 5 (5xxx) relate to errors that occur when there’s a miscommunication between several servers.</p>
<p>If you are seeing a 502 bad gateway error on a website, it means that the origin server sent out an invalid response to another server that acted as a gateway or proxy. It can be a tricky investigation to locate what and where is the process which caused the issue. However, there are some general troubleshooting steps that you can follow to get it solved.</p>
<h2>502 Bad Gateway Error Variations</h2>
<p>A 502 Bad Gateway Error has several different variations due to the various internet browsers and various web servers and operating systems. Bellow are some of the most popular variations of the 502 Bad Gateway Error.</p>
<ul><li>“502 Bad Gateway”</li>
<li>“Error 502”</li>
<li>“HTTP Error 502 – Bad Gateway”</li>
<li>“502 Proxy Error”</li>
<li>“HTTP 502”</li>
<li>“502 Service Temporarily Overloaded</li>
<li>“502 Server Error: The server encountered a temporary error and could not complete your request”</li>
<li>“502. That’s an error. The server encountered a temporary error and could not complete your request. Please try again in 30 seconds. That’s all we know.”</li>
<li>A blank white screen</li>
</ul><h2>How to Fix the 502 Bad Gateway Error (3 Possible Solutions)</h2>
<p>A 502 bad gateway error is usually an issue with the network or server. But, it can also be a client side issue. So we will troubleshoot the error within the server, and the client side as well. The following are some steps to check and solve the issues.</p>
<h3>1. Check your server</h3>
<p><img class="aligncenter size-full wp-image-27075" src="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway.jpg" alt="502 bad gateway" width="674" height="269" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway.jpg 674w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-150x60.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-300x120.jpg 300w" sizes="(max-width: 674px) 100vw, 674px"></p>
<p>If you are seeing the error as shown in the picture, most probably the error is within your webserver.<br>
Let’s check your webserver configuration, in this case the server is running Nginx. WordPress is running on PHP and MySQL. So, in nginx we need to check how PHP files are processed. Find the “location ~ \.php$” in your nginx server block.</p>
<pre><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="8efdfde6cef7e1fbfc">[email&#160;protected]</a>_ip -p7022</pre>
<p><img class="size-full wp-image-27076 alignnone" src="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error.png" alt="502 bad gateway error502 bad gateway error" width="626" height="144" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error.png 626w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-150x35.png 150w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-300x69.png 300w" sizes="(max-width: 626px) 100vw, 626px"></p>
<p>According to the nginx configuration as shown in the picture, the PHP files are processed by fastcgi that is running on port 9000.<br>
Let’s check what is running on the port</p><div class="roseh-in-content" style="text-align: center; " id="roseh-2075731629"><script data-cfasync="false" src="/cdn-cgi/scripts/f2bf09f8/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="1066282313"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<pre>netstat -pltn | grep 9000</pre>
<p>If you don’t see any result after issuing the command, then the process is died. This is why you see the 502 bad gateway error.</p>
<p>In latest CentOS and Ubuntu, you can invoke this command to see where the process should be ran from:</p>
<pre>systemctl list-unit-files | grep fpm</pre>
<p><img class="size-full wp-image-27077 alignnone" src="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-1.png" alt="502 bad gateway error" width="601" height="48" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-1.png 601w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-1-150x12.png 150w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-1-300x24.png 300w" sizes="(max-width: 601px) 100vw, 601px"></p>
<p>Issue this command to run the service:</p>
<pre>systemctl start php7.0-fpm</pre>
<p>Now, go to your web browser and check your website.</p>
<p>If you use CloudFlare and see the 502 bad gateway error as shown in the picture below, most likely your web server is down. You can try restarting apache or nginx, depends on which web server you use.</p>
<p><img class="alignnone size-full wp-image-27078" src="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-cloudflare.png" alt="502 bad gateway error in cloudflare" width="809" height="164" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-cloudflare.png 809w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-cloudflare-150x30.png 150w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-cloudflare-300x61.png 300w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-cloudflare-768x156.png 768w" sizes="(max-width: 809px) 100vw, 809px"></p>
<h3>2. Clear your cache.</h3>
<p>If the first solution has been done, but you still see the 502 bad gateway error, then your web browser is still relying on its cache. We have to tell the web browser to load the latest version from the site. We can do this by pressing Ctrl + F5 on the keyboard (Windows/Linux), or Shift + Reload button in the toolbar (Safari browser), or CMD + Shift + R (Chrome and Firefox for Mac users).</p>
<h3>3. Disable CDN</h3>
<p>If you are using CloudFlare, you can try disabling CDN for a while.</p>
<p><img class="alignnone size-full wp-image-27079" src="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-disable-CDN.png" alt="502 bad gateway error - disable CDN" width="1026" height="450" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-disable-CDN.png 1026w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-disable-CDN-150x66.png 150w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-disable-CDN-300x132.png 300w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-disable-CDN-768x337.png 768w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/502-bad-gateway-error-disable-CDN-1024x449.png 1024w" sizes="(max-width: 1026px) 100vw, 1026px"></p>
<h3>4. Check your scripts</h3>
<p>As previously said, a 502 bad gateway error is due to an issue with the web server. Sometime, the php processes are killed by the server due to high memory usage, for example. This killing process will terminate requests after a certain of time, this will also cause the website down. But, usually the website will be automatically accessible because php processes is respawned at that time. To solve this issue permanently, you need to check which php script is consuming high memory.</p>
<h3>5. Check Plugins and Themes</h3>
<p>To troubleshoot which plugin is causing the error is very simple. Even we don’t have access to our WordPress backend, we can disable all plugins at once by renaming the plugins directory. To do it, please connect to your server using SSH. Note that you can also do this using an FTP client, like FileZilla.</p>
<p><img class="alignnone size-full wp-image-27080" src="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/fixing-502-bad-gateway-error.png" alt="fixing 502 bad gateway error " width="570" height="98" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/fixing-502-bad-gateway-error.png 570w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/fixing-502-bad-gateway-error-150x26.png 150w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/fixing-502-bad-gateway-error-300x52.png 300w" sizes="(max-width: 570px) 100vw, 570px"><br>
You can enable plugins one by one, please follow these steps:<br>
Go to your wp-content directory, we can see that there is no plugins directory, we renamed it already.<br>
Let’s create a plugins directory and move a plugin over. This will automatically enable the plugin.</p>
<p><img class="alignnone size-full wp-image-27081" src="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/fixing-502-bad-gateway-error-in-wordpress.png" alt="fixing 502 bad gateway error in wordpress" width="666" height="206" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2018/06/fixing-502-bad-gateway-error-in-wordpress.png 666w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/fixing-502-bad-gateway-error-in-wordpress-150x46.png 150w, https://www.rosehosting.com/blog/wp-content/uploads/2018/06/fixing-502-bad-gateway-error-in-wordpress-300x93.png 300w" sizes="(max-width: 666px) 100vw, 666px"></p>
<p>Sometimes, troubleshooting WordPress errors is easier than we might think. But, also it could be very hard to solve at some point.</p>
<hr><p>Of course, you don’t need to get troubled with your server if you have a <a href="https://www.rosehosting.com/wordpress-hosting.html">WordPress VPS</a> hosted with us – in which case, our technical support team will help you investigating and solving this 502 Bad Gateway issue immediately. They are available 24/7, and can cater to any questions or requests.</p>
<p><strong>PS.</strong> If you liked this post, feel free to share it with your friends by using the social media share shortcuts below, or simply leave a comment. Thanks.</p>
<p> </p>
<div class="essb_links essb_counters essb_displayed_followme essb_share essb_template_metro-bold-retina essb_1488894568 essb_links_center essb_nospace print-no" id="essb_displayed_followme_1488894568" data-essb-postid="27029" data-essb-position="followme" data-essb-button-style="button_name" data-essb-template="metro-bold-retina" data-essb-counter-pos="insidename" data-essb-url="https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/" data-essb-twitter-url="https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/" data-essb-instance="1488894568"><ul class="essb_links_list essb_hide_icon"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-counter-pos="insidename"><span class="essb_totalcount essb_t_l" title="Total: "><span class="essb_total_text">Total: </span><span class="essb_t_nb">1</span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/&amp;t=How+to+Fix+the+502+Bad+Gateway+Error+in+WordPress" title="" onclick="essb.window('https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/&amp;t=How+to+Fix+the+502+Bad+Gateway+Error+in+WordPress','facebook','1488894568'); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook<span class="essb_counter_insidename" data-cnt="1" style="display: none;" data-cnt-short="1">1</span></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window('https://twitter.com/intent/tweet?text=How+to+Fix+the+502+Bad+Gateway+Error+in+WordPress&amp;url=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/&amp;counturl=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/','twitter','1488894568'); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_google nolightbox"> <a href="https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/" title="" onclick="essb.window('https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/','google','1488894568'); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_google"></span><span class="essb_network_name">Google+<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+to+Fix+the+502+Bad+Gateway+Error+in+WordPress&amp;url=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/" title="" onclick="essb.window('https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+to+Fix+the+502+Bad+Gateway+Error+in+WordPress&amp;url=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/','linkedin','1488894568'); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li></ul></div><div class="roseh-after-content" style="text-align: center; " id="roseh-1279910169"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="1066282313"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
<a href="https://www.facebook.com/sharer.php?u=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/&#038;t=How%20to%20Fix%20the%20502%20Bad%20Gateway%20Error%20in%20WordPress" class="social-share-link" title="Share &quot;How to Fix the 502 Bad Gateway Error in WordPress&quot; via Facebook" data-network-name="facebook" data-share-title="How to Fix the 502 Bad Gateway Error in WordPress" data-share-url="https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/">
<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span>
</a><a href="https://twitter.com/home?status=How%20to%20Fix%20the%20502%20Bad%20Gateway%20Error%20in%20WordPress%20https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/" class="social-share-link" title="Share &quot;How to Fix the 502 Bad Gateway Error in WordPress&quot; via Twitter" data-network-name="twitter" data-share-title="How to Fix the 502 Bad Gateway Error in WordPress" data-share-url="https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/">
<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span>
</a><a href="https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/&#038;t=How%20to%20Fix%20the%20502%20Bad%20Gateway%20Error%20in%20WordPress" class="social-share-link" title="Share &quot;How to Fix the 502 Bad Gateway Error in WordPress&quot; via Google +" data-network-name="googleplus" data-share-title="How to Fix the 502 Bad Gateway Error in WordPress" data-share-url="https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/">
<span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover"></span>
</a><a href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/&#038;title=How%20to%20Fix%20the%20502%20Bad%20Gateway%20Error%20in%20WordPress" class="social-share-link" title="Share &quot;How to Fix the 502 Bad Gateway Error in WordPress&quot; via LinkedIn" data-network-name="linkedin" data-share-title="How to Fix the 502 Bad Gateway Error in WordPress" data-share-url="https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/">
<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;How to Fix the 502 Bad Gateway Error in WordPress&quot; via Email" data-network-name="basic_email" data-share-title="How to Fix the 502 Bad Gateway Error in WordPress" data-share-url="https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/">
<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;How to Fix the 502 Bad Gateway Error in WordPress&quot; via Print" data-network-name="basic_print" data-share-title="How to Fix the 502 Bad Gateway Error in WordPress" data-share-url="https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/">
<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span>
</a> </div>
<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #00a8ff;
									}
								</style>
</div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="https://www.rosehosting.com/blog/how-to-install-matomo-on-ubuntu-16-04/" rel="prev"><span class="button">Previous</span><span class="title">How to Install Matomo on Ubuntu 16.04</span></a> </div>
<div class="nav-link nav-link-next">
<a href="https://www.rosehosting.com/blog/how-to-set-up-ssh-keys-on-ubuntu-16-04/" rel="next"><span class="button">Next</span><span class="title">How To Set Up SSH Keys on Ubuntu 16.04</span></a> </div>
</div>
</nav>
<div class="et_extra_other_module related-posts">
<div class="related-posts-header">
<h3>Related Posts</h3>
</div>
<div class="related-posts-content clearfix">
<div class="related-post">
<div class="featured-image"><a href="https://www.rosehosting.com/blog/how-to-fix-503-service-unavailable-error-in-wordpress/" title="How to Fix 503 Service Unavailable Error in WordPress" class="post-thumbnail">
<img src="https://www.rosehosting.com/blog/wp-content/uploads/2018/05/How-to-Fix-503-Service-Unavailable-Error-in-WordPress-440x264.jpg" alt="How to Fix 503 Service Unavailable Error in WordPress" /><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="https://www.rosehosting.com/blog/how-to-fix-503-service-unavailable-error-in-wordpress/">How to Fix 503 Service Unavailable Error in WordPress</a></h4>
<p class="date"><span class="updated">May 11, 2018</span></p>
</div>
<div class="related-post">
<div class="featured-image"><a href="https://www.rosehosting.com/blog/install-wordpress-on-debian-vps/" title="Install WordPress on Debian VPS" class="post-thumbnail">
<img src="https://www.rosehosting.com/blog/wp-content/uploads/2012/09/wordpress-logo-200.png" alt="Install WordPress on Debian VPS" /><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="https://www.rosehosting.com/blog/install-wordpress-on-debian-vps/">Install WordPress on Debian VPS</a></h4>
<p class="date"><span class="updated">October 6, 2012</span></p>
</div>
<div class="related-post">
<div class="featured-image"><a href="https://www.rosehosting.com/blog/how-to-install-piwik-on-a-centos-vps/" title="How to install Piwik on a CentOS VPS" class="post-thumbnail">
<img src="https://www.rosehosting.com/blog/wp-content/uploads/2012/11/piwik.jpg" alt="How to install Piwik on a CentOS VPS" /><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="https://www.rosehosting.com/blog/how-to-install-piwik-on-a-centos-vps/">How to install Piwik on a CentOS VPS</a></h4>
<p class="date"><span class="updated">June 11, 2013</span></p>
</div>
<div class="related-post">
<div class="featured-image"><a href="https://www.rosehosting.com/blog/6-essential-wordpress-performance-optimization-tips/" title="6 Essential WordPress Performance Optimization Tips" class="post-thumbnail">
<img src="https://www.rosehosting.com/blog/wp-content/uploads/2012/10/wordpress-performance-optimization.jpg" alt="6 Essential WordPress Performance Optimization Tips" /><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="https://www.rosehosting.com/blog/6-essential-wordpress-performance-optimization-tips/">6 Essential WordPress Performance Optimization Tips</a></h4>
<p class="date"><span class="updated">November 12, 2012</span></p>
</div>
</div>
</div>

<section id="comment-wrap">
<div id="comments" class="nocomments">

</div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/#respond" style="display:none;">Cancel reply</a></small></h3> <form action="https://www.rosehosting.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form">
<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea autocomplete="nope" id="301e02f4da" name="182f4f0d0a" cols="45" rows="8" aria-required="true"></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="nope" style="padding:0;clip:rect(1px, 1px, 1px, 1px);position:absolute !important;white-space:nowrap;height:1px;width:1px;overflow:hidden;" tabindex="-1"></textarea><script type="text/javascript">document.getElementById("comment").setAttribute( "id", "0ffd4aa5dbb62652a3b16739c56cf39e" );document.getElementById("301e02f4da").setAttribute( "id", "comment" );</script></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='27029' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><div class="g-recaptcha" data-sitekey="6LfY7_4SAAAAAE2DEhMo9U4ZS1XLXf1qGXL9uzZC" data-theme="standard"></div><script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en"></script> <div id="recaptcha-submit-btn-area">&nbsp;</div>
<noscript>
            <style type='text/css'>#submit {display:none;}</style>
            <input name="submit" type="submit" id="submit-alt" tabindex="6"
                value="Submit Comment"/> 
            </noscript> </form>
</div>
</section>
</div>
<div class="et_pb_extra_column_sidebar">
<div class="et_pb_widget roseh-widget"><h4 class="widgettitle"> </h4><div style="text-align: center; " id="roseh-1420697264"><center><a target="_blank" href="https://www.rosehosting.com/cloud-vps-hosting.html"><img src="https://media.rosehosting.com/img/blogads/blue.png"></a></center></div></div> <div class="et_pb_widget roseh-widget"><h4 class="widgettitle"> </h4><div style="text-align: center; " id="roseh-880167459"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="6446601501"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div> <div class="et_pb_widget roseh-widget"><h4 class="widgettitle"> </h4><div style="text-align: center; " id="roseh-1383240724"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="2385735863"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div> <div class="et_pb_widget roseh-widget"><h4 class="widgettitle"> </h4><div style="text-align: center; " id="roseh-819661085"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="2385735863"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div> <div id="text-31" class="et_pb_widget widget_text"><h4 class="widgettitle"> </h4> <div class="textwidget"><p><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<br />
<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="8927217199"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center></p>
</div>
</div> </div>
</div> 
</div> 
</div> 

<footer class="footer-big-menu">
<div class="container">
<div class="row menu">
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title mb-2">Company</h3>
<a class="menu-link" href="https://rosehosting.com/about-us.html">About us</a>
<a class="menu-link" href="https://rosehosting.com/policies.html">Our Policies</a>
<a class="menu-link" href="https://rosehosting.com/contact-us.html">Contact Us</a>
<a class="menu-link" href="https://rosehosting.com/blog/">Blog</a>
<a class="menu-link" href="https://rosehosting.com/why-rosehosting.html">Why RoseHosting</a>
<a class="menu-link" href="https://rosehosting.com/compare-to-competition.html">Compare Us</a>
<a class="menu-link" href="https://rosehosting.com/reviews.html">Customer Reviews</a>
<a class="menu-link" href="https://rosehosting.com/awards.html">Awards &amp; Recognition</a>
</div>
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title  mb-2">Support</h3>
<a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Helpdesk System</a>
<a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>
<a class="menu-link" href="https://status.rosehosting.com">Systems Status</a>
<h3 class="menu-title  mb-2 mt-4">Other Services</h3>
<a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Domain Registration</a>
<a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Domain Transfer</a>
<a class="menu-link" href="https://rosehosting.com/ssl-certificates.html">SSL Certificates</a>
</div>
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title  mb-2">Hosting</h3>
<a class="menu-link" href="https://rosehosting.com/web-hosting.html">Web Hosting</a>
<a class="menu-link" href="https://rosehosting.com/vps-hosting.html">VPS Hosting</a>
<a class="menu-link" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom SSD VPS</a>
<a class="menu-link" href="https://rosehosting.com/cloud-hosting.html">Cloud Hosting</a>
<a class="menu-link" href="https://rosehosting.com/dedicated-servers.html">Cloud Dedicated Servers</a>
<a class="menu-link" href="https://rosehosting.com/hosting-solutions.html">Hosting Solutions</a>
<a class="menu-link" href="https://rosehosting.com/vps-affiliate-program.html">Affiliate Program</a>
</div>
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title  mb-2">Linux VPS Hosting</h3>
<a class="menu-link" href="https://rosehosting.com/centos-hosting.html">CentOS Hosting</a>
<a class="menu-link" href="https://rosehosting.com/ubuntu-hosting.html">Ubuntu Hosting</a>
<a class="menu-link" href="https://rosehosting.com/debian-hosting.html">Debian Hosting</a>
<a class="menu-link" href="https://rosehosting.com/opensuse-hosting.html">OpenSUSE Hosting</a>
<a class="menu-link" href="https://rosehosting.com/arch-linux-hosting.html">Arch-Linux Hosting</a>
<a class="menu-link" href="https://rosehosting.com/scientific-linux-hosting.html">Scientific Linux Hosting</a>
</div>
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title  mb-2">Apps Hosting</h3>
<a class="menu-link" href="https://rosehosting.com/wordpress-hosting.html">WordPress Hosting</a>
<a class="menu-link" href="https://rosehosting.com/magento-hosting.html">Magento Hosting</a>
<a class="menu-link" href="https://rosehosting.com/odoo-hosting.html">Odoo Hosting</a>
<a class="menu-link" href="https://rosehosting.com/joomla-hosting.html">Joomla Hosting</a>
<a class="menu-link" href="https://rosehosting.com/drupal-hosting.html">Drupal Hosting</a>
<a class="menu-link" href="https://rosehosting.com/laravel-hosting.html">Laravel Hosting</a>
<a class="menu-link" href="https://rosehosting.com/nextcloud-hosting.html">NextCloud Hosting</a>
<a class="menu-link" href="https://rosehosting.com/prestashop-hosting.html">PrestaShop Hosting</a>
<a class="menu-link" href="https://rosehosting.com/ghost-hosting.html">Ghost Hosting</a>
<a class="menu-link" href="https://rosehosting.com/mediawiki-hosting.html">MediaWiki Hosting</a>
<a class="menu-link" href="https://rosehosting.com/tomcat-hosting.html">Tomcat Hosting</a>
</div>
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title mb-2">Contact Us</h3>
<a class="menu-link" href="tel:+18887673467">(888) ROSE-HOST</a>
<a class="menu-link" href="tel:+18887673467">(888) 767-3467</a>
<a class="menu-link" href="tel:+16465197201">(314) 275-0414</a>
<a class="menu-link" href="/cdn-cgi/l/email-protection#80a5b7b3a5b7b5a5b7b0a5b7b0a5b6e6a5b7b2a5b7b4a5b4b0a5b7b2a5b6e6a5b7b3a5b6b5a5b6b8a5b6e6a5b7b3a5b7b4a5b6b9a5b6e5a5b6b7a5b2e5a5b6b3a5b6e6a5b6e4">Email us</a>
<h3 class="menu-title mb-2 mt-4">Connect</h3>
<a class="menu-link" href="https://twitter.com/rosehosting" target="_blank"><i class="fa fa-twitter fa-fw"></i> Twitter</a>
<a class="menu-link" href="https://www.facebook.com/RoseHosting" target="_blank"><i class="fa fa-facebook fa-fw"></i> Facebook</a>
<a class="menu-link" href="https://plus.google.com/+Rosehosting" target="_blank"><i class="fa fa-google-plus fa-fw"></i> Google+</a>
<a class="menu-link" href="https://www.linkedin.com/company/rose-web-services-l-l-c-" target="_blank"><i class="fa fa-linkedin fa-fw"></i> LinkedIn</a>
<a class="menu-link" href="https://rosehosting.com/blog/feed/" target="_blank"><i class="fa fa-rss fa-fw"></i> RSS Feed</a>
</div>
</div>
</div>
<div class="bottom">
<div class="container">
<div class="row">
<div class="col-md-12 col-lg-6">
<p class="text-sm-left"><a class="inline-link footer-policy" href="/tos.html">Terms of Service</a> and <a class="inline-link footer-policy" href="/policies.html">other policies</a></p>
</div>
<div class="col-md-12 col-lg-6">
<p class="text-sm-right">&copy; 2001-2018 <a class="inline-link footer-policy" href="https://www.rosewebservices.com/">Rose Web Services LLC</a>.</p>
</div>
</div>
</div>
</div>

<script data-cfasync="false" src="/cdn-cgi/scripts/f2bf09f8/cloudflare-static/email-decode.min.js"></script><script type="text/javascript" id="aff1f81b02f303eea5f87a3a065f153a" src="https://linuxhostsupport.com/chat//script.php?id=aff1f81b02f303eea5f87a3a065f153a"></script>

<div class="essb-followme essb-followme-bottom" data-full="" data-top="" data-background="rgba(255,255,255,0)" data-position="" data-avoid-left="true" data-hide="1"><div class="essb_links essb_counters essb_displayed_followme essb_share essb_template_metro-bold-retina essb_1556499416 essb_links_center essb_nospace print-no" id="essb_displayed_followme_1556499416" data-essb-postid="27029" data-essb-position="followme" data-essb-button-style="button_name" data-essb-template="metro-bold-retina" data-essb-counter-pos="insidename" data-essb-url="https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/" data-essb-twitter-url="https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/" data-essb-instance="1556499416"><ul class="essb_links_list essb_hide_icon"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-counter-pos="insidename"><span class="essb_totalcount essb_t_l" title="Total: "><span class="essb_total_text">Total: </span><span class="essb_t_nb">1</span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/&t=How+to+Fix+the+502+Bad+Gateway+Error+in+WordPress" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/&t=How+to+Fix+the+502+Bad+Gateway+Error+in+WordPress&#39;,&#39;facebook&#39;,&#39;1556499416&#39;); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook<span class="essb_counter_insidename" data-cnt="1" style="display: none;" data-cnt-short="1">1</span></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=How+to+Fix+the+502+Bad+Gateway+Error+in+WordPress&amp;url=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/&amp;counturl=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/&#39;,&#39;twitter&#39;,&#39;1556499416&#39;); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_google nolightbox"> <a href="https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/" title="" onclick="essb.window(&#39;https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/&#39;,&#39;google&#39;,&#39;1556499416&#39;); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_google"></span><span class="essb_network_name">Google+<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+to+Fix+the+502+Bad+Gateway+Error+in+WordPress&amp;url=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+to+Fix+the+502+Bad+Gateway+Error+in+WordPress&amp;url=https://www.rosehosting.com/blog/how-to-fix-the-502-bad-gateway-error-in-wordpress/&#39;,&#39;linkedin&#39;,&#39;1556499416&#39;); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li></ul></div></div>

<script type="application/ld+json">{
    "@context": "http://schema.org",
    "@type": "Organization",
    "additionalType": "WebHosting",
    "name": "RoseHosting.com",
    "logo": "https://www.rosehosting.com/blog/wp-content/uploads/2018/03/RoseHosting-Logo.png",
    "url": "https://www.rosehosting.com/blog",
    "sameAs": [
        "https://twitter.com/rosehosting",
        "https://www.facebook.com/RoseHosting",
        "https://www.google.com/+Rosehosting",
        "https://www.linkedin.com/in/rosehosting"
    ],
    "contactPoint": {
        "@type": "ContactPoint",
        "telephone": "+1-888-767-3467",
        "contactType": "Customer Service",
        "email": "support@rosehosting.com",
        "contactOption": "TollFree",
        "areaServed": "Canada,Mexico,United States",
        "availableLanguage": "English"
    },
    "address": {
        "@type": "PostalAddress",
        "addressCountry": "United States",
        "addressLocality": "Saint Louis",
        "addressRegion": "MO",
        "postalCode": "63368",
        "streetAddress": "2977 Hwy K #252"
    }
}</script>

<script>
		var advanced_ads_ga_UID = '';
		var advanced_ads_ga_anonymIP = true;
advanced_ads_check_adblocker=function(t){function e(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}var n=[],a=null;return e(function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),e(function(){var e=window.getComputedStyle&&window.getComputedStyle(t),o=e&&e.getPropertyValue("-moz-binding");a=e&&"none"===e.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0;i<n.length;i++)n[i](a);n=[]})}),function(t){if(null===a)return void n.push(t);t(a)}}(),function(){var t=function(t,e){this.name=t,this.UID=e,this.analyticsObject=null;var n=this,a={hitType:"event",eventCategory:"Advanced Ads",eventAction:"AdBlock",eventLabel:"Yes",nonInteraction:!0,transport:"beacon"};this.analyticsObject="string"==typeof GoogleAnalyticsObject&&"function"==typeof window[GoogleAnalyticsObject]&&window[GoogleAnalyticsObject],!1===this.analyticsObject?(!function(t,e,n,a,o,i,d){t.GoogleAnalyticsObject=o,t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)},t[o].l=1*new Date,i=e.createElement(n),d=e.getElementsByTagName(n)[0],i.async=1,i.src="https://www.google-analytics.com/analytics.js",d.parentNode.insertBefore(i,d)}(window,document,"script",0,"_advads_ga"),_advads_ga("create",n.UID,"auto",this.name),advanced_ads_ga_anonymIP&&_advads_ga("set","anonymizeIp",!0),_advads_ga(n.name+".send",a)):(window.console&&window.console.log("Advanced Ads Analytics >> using other's variable named `"+GoogleAnalyticsObject+"`"),window[GoogleAnalyticsObject]("create",n.UID,"auto",this.name),window[GoogleAnalyticsObject]("set","anonymizeIp",!0),window[GoogleAnalyticsObject](n.name+".send",a))};advanced_ads_check_adblocker(function(e){e&&"string"==typeof advanced_ads_ga_UID&&advanced_ads_ga_UID&&new t("advadsTracker",advanced_ads_ga_UID)})}();		
		</script> <script type="text/javascript">
		var et_animation_data = [];
	</script>
<script type="text/javascript">
            var sub = document.getElementById('submit');
            document.getElementById('recaptcha-submit-btn-area').appendChild (sub);
            document.getElementById('submit').tabIndex = 6;
            if ( typeof _recaptcha_wordpress_savedcomment != 'undefined') {
                document.getElementById('comment').value = 
                    _recaptcha_wordpress_savedcomment;
            }
            </script><script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2018/js/theme.js?ver=1' defer '></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/masonry.min.js?ver=3.3.2' defer '></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/www.rosehosting.com\/blog\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"8a1071a5c9","timeline_nonce":"02e5e5bf39","blog_feed_nonce":"c6e284a8c7","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/www.rosehosting.com\/blog\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/www.rosehosting.com\/blog\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"9e0578b99b","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"303f29e104","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","is_builder_plugin_used":"","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"27029","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/Extra/scripts/scripts.min.js?ver=2.3.1' defer '></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/comment-reply.min.js?ver=4.9.6' defer '></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.1.4' defer '></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/Extra/core/admin/js/common.js?ver=3.3.1' defer '></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/wp-embed.min.js?ver=4.9.6' defer '></script>
<link rel='stylesheet' id='essb-compiled-css' href='https://www.rosehosting.com/blog/wp-content/easysocialsharebuttons-assets/compiled/2566c291e59e185c12a331fef1e235f3.css' type='text/css' media='all' /><script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/easysocialsharebuttons-assets/compiled/2566c291e59e185c12a331fef1e235f3.js' async></script></body>
</html>
