<!DOCTYPE html> <!--[if IE 6]>
<html id="ie6" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]--> <!--[if IE 7]>
<html id="ie7" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]--> <!--[if IE 8]>
<html id="ie8" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]--> <!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<!--<![endif]--><head><meta charset="UTF-8" /><link rel="pingback" href="https://www.rosehosting.com/blog/xmlrpc.php" /> <!--[if lt IE 9]>
	<script src="https://www.rosehosting.com/blog/wp-content/themes/generatepress/scripts/ext/html5.js' defer='defer" type="text/javascript"></script>
	<![endif]--> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KVJ4PJ');</script> <title>How to Install Docker Compose on Ubuntu 18.04 | RoseHosting</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://www.rosehosting.com/blog/wp-content/cache/min/1/f7a80910a0fb8ae418e6d35cef561502.css" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /><meta name="description" content="In this tutorial, we will cover the steps needed for installing Docker Compose on an Ubuntu 18.04 VPS. Docker Compose is used to run multi-container Docker" /> <script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.rosehosting.com/blog/#organization","url":"https://www.rosehosting.com/blog/","name":"RoseHosting.com","sameAs":["https://twitter.com/rosehosting","https://www.facebook.com/RoseHosting/","https://www.linkedin.com/in/rosehosting"],"logo":{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/#logo","url":"https://www.rosehosting.com/blog/wp-content/uploads/2016/02/rhlogo-final-500x500.png","caption":""},"image":{"@id":"https://www.rosehosting.com/blog/#logo"},"contactPoint":{"@type":"ContactPoint","telephone":"+888-767-3467","contactType":"sales"}},{"@type":"WebSite","@id":"https://www.rosehosting.com/blog/#website","url":"https://www.rosehosting.com/blog/","name":"RoseHosting","publisher":{"@id":"https://www.rosehosting.com/blog/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.rosehosting.com/blog/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/#webpage","url":"https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/","inLanguage":"en-US","name":"How to Install Docker Compose on Ubuntu 18.04","isPartOf":{"@id":"https://www.rosehosting.com/blog/#website"},"breadcrumb":{"@id":"https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/#breadcrumblist"},"image":{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/#primaryimage","url":"https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-docker-compose-on-ubuntu18.04.jpg","width":742,"height":372},"primaryImageOfPage":{"@id":"https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/#primaryimage"},"datePublished":"2020-05-27T20:22:38-05:00","dateModified":"2020-05-27T20:22:38-05:00"},{"@type":"Article","@id":"https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/#article","isPartOf":{"@id":"https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/#webpage"},"author":{"@id":"https://www.rosehosting.com/blog/author/jwilson/#author"},"headline":"How to Install Docker Compose on Ubuntu 18.04","datePublished":"2020-05-27T20:22:38-05:00","dateModified":"2020-05-27T20:22:38-05:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/#webpage"},"publisher":{"@id":"https://www.rosehosting.com/blog/#organization"},"articleSection":"Tutorials, Ubuntu, docker-compose, ubuntu","image":{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/#primaryimage","url":"https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-docker-compose-on-ubuntu18.04.jpg","width":742,"height":372}},{"@type":"Person","@id":"https://www.rosehosting.com/blog/author/jwilson/#author","name":"Jeff Wilson","sameAs":["https://www.facebook.com/rosehosting.helpdesk"],"image":{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/#personlogo","url":"https://secure.gravatar.com/avatar/09271207587f897ab46faaed9b355252?s=96&r=g","width":96,"height":96,"caption":"Jeff Wilson"}},{"@type":"BreadcrumbList","@id":"https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/#breadcrumblist","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.rosehosting.com/blog/","url":"https://www.rosehosting.com/blog/","name":"RoseHosting Blog"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/","url":"https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/","name":"How to Install Docker Compose on Ubuntu 18.04"}}]}]}</script> <link rel="canonical" href="https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/" /><meta property="og:type" content="article" /><meta property="og:title" content="How to Install Docker Compose on Ubuntu 18.04 | RoseHosting" /><meta property="og:description" content="In this tutorial, we will cover the steps needed for installing Docker Compose on an Ubuntu 18.04 VPS. Docker Compose is used to run multi-container Docker applications. This means that each container" /><meta property="og:url" content="https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/" /><meta property="og:site_name" content="RoseHosting.com Blog" /><meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-docker-compose-on-ubuntu18.04.jpg" /><meta property="article:tag" content="tutorials" /><meta property="article:tag" content="ubuntu" /><meta property="article:tag" content="docker-compose" /><meta property="article:published_time" content="2020-05-27T20:22:38Z" /><meta property="article:modified_time" content="2020-05-27T20:22:38Z" /><meta property="article:publisher" content="https://www.facebook.com/RoseHosting/" /><meta property="article:author" content="https://www.facebook.com/rosehosting.helpdesk" /><meta property="og:image:secure_url" content="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-docker-compose-on-ubuntu18.04.jpg" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@RoseHosting" /><meta name="twitter:title" content="How to Install Docker Compose on Ubuntu 18.04 | RoseHosting" /><meta name="twitter:description" content="In this tutorial, we will cover the steps needed for installing Docker Compose on an Ubuntu 18.04 VPS. Docker Compose is used to run multi-container Docker applications. This means that each container" /><meta name="twitter:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-docker-compose-on-ubuntu18.04.jpg" /><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Feed" href="https://www.rosehosting.com/blog/feed/" /><link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Comments Feed" href="https://www.rosehosting.com/blog/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; How to Install Docker Compose on Ubuntu 18.04 Comments Feed" href="https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='preload' id='generate-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans:300,300italic,regular,italic,600,600italic,700,700italic,800,800italic&#038;display=swap' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><style id='ez-toc-inline-css' type='text/css'>div#ez-toc-container p.ez-toc-title{font-size:22px}div#ez-toc-container p.ez-toc-title{font-weight:500}div#ez-toc-container ul li{font-size:95%}div#ez-toc-container{width:95%}</style><link rel='preload' id='font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><style id='generate-style-inline-css' type='text/css'>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</style> <link rel='https://api.w.org/' href='https://www.rosehosting.com/blog/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rosehosting.com/blog/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rosehosting.com/blog/wp-includes/wlwmanifest.xml" /><link rel='prev' title='How to Install Go on CentOS 7' href='https://www.rosehosting.com/blog/how-to-install-go-on-centos-7/' /><meta name="generator" content="WordPress 5.4.1" /><link rel='shortlink' href='https://www.rosehosting.com/blog/?p=30905' /><link rel="alternate" type="application/json+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-install-docker-compose-on-ubuntu-18-04%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-install-docker-compose-on-ubuntu-18-04%2F&#038;format=xml" /><meta name="viewport" content="width=device-width, initial-scale=1"><style type="text/css">.broken_link,a.broken_link{text-decoration:line-through}</style><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-180x180.png" /><meta name="msapplication-TileImage" content="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-270x270.png" /><style type="text/css" id="wp-custom-css">.entry-content pre{font-family:monospace;color:#3a3a3a;border:none;overflow-wrap:break-word}.inside-article,.sidebar .widget{border:1px solid #e3e3e3}.page-container{max-width:1100px;align-items:center;justify-content:space-between;margin-left:auto;margin-right:auto}.footer-big-menu{max-width:1100px;margin-left:auto;margin-right:auto}.col6,.col-md-3,.col-lg-2{padding-left:10px;padding-right:10px}</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script></head><body class="post-template-default single single-post postid-30905 single-format-standard wp-embed-responsive post-image-above-header post-image-aligned-center sticky-menu-fade right-sidebar nav-below-header contained-header separate-containers active-footer-widgets-1 nav-aligned-left header-aligned-left dropdown-hover featured-image-active"><nav class="navbar yamm navbar-expand-lg navbar-dark" role="navigation"><div class="container no-override navbar-dark"> <a class="navbar-brand" href="https://www.rosehosting.com/"> <img alt="RoseHosting.com" width="186" height="37" class="d-lg-inline mr-2" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20186%2037'%3E%3C/svg%3E" data-lazy-src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/rh-logo.svg" /><noscript><img alt="RoseHosting.com" width="186" height="37" class="d-lg-inline mr-2" src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/rh-logo.svg" /></noscript> </a> <button class="navbar-toggler" data-toggle="collapse" data-target="#navbar-collapse"> <span class="navbar-toggler-icon"></span> </button><div class="collapse navbar-collapse justify-content-end" id="navbar-collapse"><ul class="navbar-nav"><li class="nav-item active dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> Hosting Solutions <i class="fa fa-chevron-down"></i> </a><div class="dropdown-menu" role="menu"><div class="yamm-content"><div class="row"><div class="col-sm-6"> <span class="text-primary dropdown-header"><strong>Managed SSD Hosting</strong></span><div class="dropdown-divider"></div> <a class="dropdown-item" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a> <a class="dropdown-item" href="https://www.rosehosting.com/linux-vps-hosting.html">Linux VPS Hosting</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom VPS</a> <a class="dropdown-item" href="https://www.rosehosting.com/dedicated-servers.html">Cloud Dedicated Servers</a> <a class="dropdown-item" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting <span class="ml-2 badge badge-success">new</span></a></div><div class="col-sm-6"> <span class="text-primary dropdown-header"><strong>Managed Solutions</strong></span><div class="dropdown-divider"></div> <a class="dropdown-item" href="https://www.rosehosting.com/wordpress-hosting.html"> Wordpress Hosting <small class="d-block text-muted"><i>The best blogging platform</i></small> </a> <a class="dropdown-item" href="https://www.rosehosting.com/magento-hosting.html"> Magento Hosting <small class="d-block text-muted"><i>The best e-commerce platform</i></small> </a> <a class="dropdown-item" href="https://www.rosehosting.com/odoo-hosting.html"> Odoo Hosting <small class="d-block text-muted"><i>The best CRM/ERP platform</i></small> </a> <span class="dropdown-item"><a class="btn-shadow btn-shadow-primary btn-shadow-sm" target="_blank" href="https://www.rosehosting.com/hosting-solutions.html">Other Solutions</a></span></div></div></div></div></li><li class="nav-item dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> SSL / Domains <i class="fa fa-chevron-down"></i> </a><div class="dropdown-menu" role="menu"><div class="yamm-content"><div class="row"><div class="col-sm-3"> <span class="text-primary dropdown-header"><strong>SSL by brand</strong></span><div class="dropdown-divider"></div> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#geotrust">GeoTrust</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#comodo">Comodo</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#rapidssl">RapidSSL</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#thawte">Thawte</a></div><div class="col-sm-4"> <span class="text-primary dropdown-header"><strong>SSL by Type</strong></span><div class="dropdown-divider"></div> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#domain_validation">Domain Validation</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#organization_validation">Organization Validation</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#extended_validation">Extended Validation</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#wildcard_ssl">Wildcard SSL</a></div><div class="col-sm-3"> <span class="text-primary dropdown-header"><strong>Domains</strong></span><div class="dropdown-divider"></div> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Register Domains</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Transfer Domains</a></div></div></div></div><li class="nav-item dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> Support <i class="fa fa-chevron-down"></i> </a><div class="dropdown-menu" role="menu"> <a class="dropdown-item" href="https://www.rosehosting.com/support.html">24/7 Managed Support</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Open a Support Ticket</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a> <a class="dropdown-item" href="https://status.rosehosting.com">Systems Status</a></div></li><li class="nav-item dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> About Us <i class="fa fa-chevron-down"></i> </a><div class="dropdown-menu" role="menu"> <a class="dropdown-item" href="https://www.rosehosting.com/about-us.html">Our Company</a> <a class="dropdown-item" href="https://www.rosehosting.com/contact-us.html">Contact Us</a> <a class="dropdown-item" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a> <a class="dropdown-item" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a> <a class="dropdown-item" href="https://www.rosehosting.com/policies.html">Our Policies</a></div></li><li class="nav-item dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> Affiliates <i class="fa fa-chevron-down"></i> </a><div class="dropdown-menu" role="menu"> <a class="dropdown-item" href="https://www.rosehosting.com/cpa-hosting-affiliate-program.html">Flat-Rate CPA Affiliate Program</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Flat-Rate CPA Affiliate Program Login</a> <a class="dropdown-item" href="https://www.rosehosting.com/vps-affiliate-program.html">Recurring Commission Affiliate Program</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/aff/">Recurring Commission Affiliate Program Login</a></div></li><li class="nav-item"> <a class="nav-link" href="https://www.rosehosting.com/blog/">Blog</a></li><li class="nav-item"> <a class="nav-link nav-link--rounded" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Login</a></li></ul></div></div></nav><nav class="navbar navbar-expand-lg navbar-light bg-faded navbar-blog"><div class="container no-override"> <a href="https://www.rosehosting.com/blog/" class="navbar-brand">Blog Home</a><div class="navbar-collapse collapse d-flex justify-content-between" id="navbar5-blog"><ul class="navbar-nav categories"><li class="nav-item dropdown"> <a class="nav-link dropdown-toggle" data-toggle="dropdown" href="#" role="button" aria-haspopup="true" aria-expanded="false"> Categories <i class="fa fa-chevron-down"></i> </a><div class="dropdown-menu" style="z-index:9999990;"> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/caching/">Caching</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/centos/">CentOS</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/cms-crm-erp/">CMS, CRM, ERP</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/control-panels/">Control Panels</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/databases/">Databases</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/debian/">Debian</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/e-commerce/">E-Commerce</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/email-servers/">Email Servers</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/guides/">Guides</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/load-balancing/">Load Balancing</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/miscellaneous/">Miscellaneous</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/networking-and-domains/">Networking and Domains</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/news/">News</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/optimization/">Optimization</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/other/">Other</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/rosehosting/">RoseHosting Platform</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/scripts/">Scripts</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/security/">Security</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/seo/">SEO</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tips-and-tricks/">Tips and Tricks</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tutorials/">Tutorials</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/ubuntu/">Ubuntu</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-frameworks/">Web Frameworks</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-servers/">Web Servers</a></div></li></ul><form class="mx-2 my-auto d-inline" method="get" id="searchform" action="https://www.rosehosting.com/blog/"><div class="input-group"> <input type="search" class="field" name="s" id="s" class="form-control border border-right-0" placeholder="Search..."> <span class="input-group-append"> <button name="submit" id="searchsubmit" class="btn btn-outline-secondary border border-left-0" type="submit"> <i class="fa fa-search"></i> </button> </span></div></form></div></div></nav><div id="page-container" class="page-container"><div id="primary" class="content-area grid-parent mobile-grid-100 grid-70 tablet-grid-70"><main id="main" class="site-main"><article id="post-30905" class="post-30905 post type-post status-publish format-standard has-post-thumbnail hentry category-tutorials category-ubuntu tag-docker-compose tag-ubuntu" itemtype="https://schema.org/CreativeWork" itemscope><div class="inside-article"><header class="entry-header"><h1 class="entry-title" itemprop="headline">How to Install Docker Compose on Ubuntu 18.04</h1><div class="entry-meta"> <span class="posted-on"><a href="https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/" title="15:22" rel="bookmark"><time class="entry-date published" datetime="2020-05-27T15:22:38-05:00" itemprop="datePublished">May 27, 2020</time></a></span> <span class="byline">by <span class="author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope><a class="url fn n" href="https://www.rosehosting.com/blog/author/jwilson/" title="View all posts by Jeff Wilson" rel="author" itemprop="url"><span class="author-name" itemprop="name">Jeff Wilson</span></a></span></span></div></header><div class="entry-content" itemprop="text"><p><img class="alignnone size-full wp-image-32319" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20742%20372'%3E%3C/svg%3E" alt="" width="742" height="372" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-docker-compose-on-ubuntu18.04.jpg 742w, https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-docker-compose-on-ubuntu18.04-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-docker-compose-on-ubuntu18.04-150x75.jpg 150w" data-lazy-sizes="(max-width: 742px) 100vw, 742px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-docker-compose-on-ubuntu18.04.jpg" /><noscript><img class="alignnone size-full wp-image-32319" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-docker-compose-on-ubuntu18.04.jpg" alt="" width="742" height="372" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-docker-compose-on-ubuntu18.04.jpg 742w, https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-docker-compose-on-ubuntu18.04-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-docker-compose-on-ubuntu18.04-150x75.jpg 150w" sizes="(max-width: 742px) 100vw, 742px" /></noscript></p><p>In this tutorial, we will cover the steps needed for installing Docker Compose on an <a href="https://www.rosehosting.com/ubuntu-hosting.html" target="_blank" rel="noopener noreferrer">Ubuntu 18.04 VPS</a>.</p><p><img class="alignright size-full wp-image-32320" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20120%20152'%3E%3C/svg%3E" alt="" width="120" height="152" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/setup-docker-compose-container-platform-on-ubuntu18.04-vps.jpg 120w, https://www.rosehosting.com/blog/wp-content/uploads/2020/02/setup-docker-compose-container-platform-on-ubuntu18.04-vps-118x150.jpg 118w" data-lazy-sizes="(max-width: 120px) 100vw, 120px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/setup-docker-compose-container-platform-on-ubuntu18.04-vps.jpg" /><noscript><img class="alignright size-full wp-image-32320" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/setup-docker-compose-container-platform-on-ubuntu18.04-vps.jpg" alt="" width="120" height="152" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/setup-docker-compose-container-platform-on-ubuntu18.04-vps.jpg 120w, https://www.rosehosting.com/blog/wp-content/uploads/2020/02/setup-docker-compose-container-platform-on-ubuntu18.04-vps-118x150.jpg 118w" sizes="(max-width: 120px) 100vw, 120px" /></noscript>Docker Compose is used to run multi-container Docker applications. This means that each container will run a standalone application which can also communicate with the other containers present in the same host. Docker Compose uses YAML files to configure all of your Docker containers and configurations. This makes Docker excellent for deploying and testing quickly and easily. Let&#8217;s get started with the installation.</p><p><span id="more-30905"></span></p><div id="ez-toc-container" class="ez-toc-v2_0_11 counter-hierarchy ez-toc-transparent"><div class="ez-toc-title-container"><p class="ez-toc-title">Table of Contents</p> <span class="ez-toc-title-toggle"><a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a></span></div><nav><ul class="ez-toc-list ez-toc-list-level-1"><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-1" href="#Requirements" title="Requirements:">Requirements:</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-2" href="#Step-1-Connect-via-SSH" title="Step 1: Connect via SSH">Step 1: Connect via SSH</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-3" href="#Step-2-Install-Docker-Compose-on-Ubuntu-18-04" title="Step 2: Install Docker Compose on Ubuntu 18.04">Step 2: Install Docker Compose on Ubuntu 18.04</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-4" href="#Step-3-Using-the-Docker-Compose-Command" title="Step 3: Using the Docker Compose Command">Step 3: Using the Docker Compose Command</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-5" href="#Step-4-Running-a-Container-with-Docker-Compose" title="Step 4: Running a Container with Docker Compose">Step 4: Running a Container with Docker Compose</a></li></ul></nav></div><h2><span class="ez-toc-section" id="Requirements"></span><strong>Requirements:</strong><span class="ez-toc-section-end"></span></h2><ul><li>For the purposes of this tutorial, we will use an Ubuntu 18.04 VPS.</li><li>Full SSH root access or a user with sudo privileges is also required.</li></ul><h2><span class="ez-toc-section" id="Step-1-Connect-via-SSH"></span><span id="1-Connect-via-SSH" class="ez-toc-section">Step 1: Connect via SSH</span><span class="ez-toc-section-end"></span></h2><p>Connect to your server via SSH as the root user using the following command:</p><pre>ssh <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="c1b3aeaeb581">[email&#160;protected]</a><span style="color: #ff0000;">IP_ADDRESS</span> -p <span style="color: #ff0000;">PORT_NUMBER</span></pre><p>and replace “<span style="color: #ff0000;">IP_ADDRESS</span>” and “<span style="color: #ff0000;">PORT_NUMBER</span>” with your actual server IP address and SSH port number.</p><p>Before starting with the installation you will need to update your system packages to their latest version.</p><p>You can do this by running the following command:</p><pre>apt-get update 
apt-get upgrade</pre><p>Once the upgrade is completed we can move on, to the installation step.</p><h2><span class="ez-toc-section" id="Step-2-Install-Docker-Compose-on-Ubuntu-18-04"></span><span id="2-Install-Redis-on-Ubuntu-1604" class="ez-toc-section">Step 2: Install Docker Compose on Ubuntu 18.04</span><span class="ez-toc-section-end"></span></h2><p>To get the latest version of Docker Compose, we will install it from the official Docker&#8217;s GitHub repository. To install Docker Compose on Ubuntu 18.04, please follow these steps:</p><p>First, we will download the Docker Compose with the following command:</p><pre>sudo curl -L "https://github.com/docker/compose/releases/download/1.25.0/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose</pre><p>Once the download is completed, we will set the permissions for the Compose binary:</p><pre>sudo chmod +x /usr/local/bin/docker-compose</pre><p>We will then verify the installation by checking the Compose version:</p><pre>docker-compose --version</pre><p>The output should be similar to this:</p><pre>docker-compose version 1.25.0, build c16347m</pre><p>Docker Compose has been installed successfully. Now in the next steps, we will show you some useful Docker Compose commands.</p><h2><span class="ez-toc-section" id="Step-3-Using-the-Docker-Compose-Command"></span><span id="2-Install-Redis-on-Ubuntu-1604" class="ez-toc-section">Step 3: Using the Docker Compose Command</span><span class="ez-toc-section-end"></span></h2><p>In this section, we will show you how to use Docker Compose command to create a container with Docker Compose.</p><p>If you want to see the options available to a specific command execute the following command:</p><pre>docker-compose <em>docker-subcommand</em> --help</pre><p>If we execute the following command:</p><pre>docker-compose up  --help</pre><p>The output should be similar to this:</p><pre>Usage: up [options] [--scale SERVICE=NUM...] [SERVICE...]

Options:
-d, --detach                                  Detached mode: Run containers in the background, print new container names. Incompatible with
                                              --abort-on-container-exit.
--no-color                                    Produce monochrome output.
--quiet-pull                                  Pull without printing progress information
--no-deps                                     Don't start linked services.
--force-recreate                              Recreate containers even if their configuration
                                              and image haven't changed.
--always-recreate-deps                        Recreate dependent containers.
                                              Incompatible with --no-recreate.
--no-recreate                                 If containers already exist, don't recreate
                                              them. Incompatible with --force-recreate and -V.
--no-build                                    Don't build an image, even if it's missing.
--no-start                                    Don't start the services after creating them.
--build                                       Build images before starting containers.
--abort-on-container-exit                     Stops all containers if any container was
                                              stopped. Incompatible with -d.
-t, --timeout TIMEOUT                         Use this timeout in seconds for container
                                              shutdown when attached or when containers are
                                              already running. (default: 10)
-V, --renew-anon-volumes                      Recreate anonymous volumes instead of retrieving
                                              data from the previous containers.
--remove-orphans                              Remove containers for services not defined
                                              in the Compose file.
--exit-code-from SERVICE                      Return the exit code of the selected service
                                              container. Implies --abort-on-container-exit.
--scale                                       SERVICE=NUM Scale SERVICE to NUM instances. Overrides the
                                              `scale` setting in the Compose file if present.</pre><h2><span class="ez-toc-section" id="Step-4-Running-a-Container-with-Docker-Compose"></span><span id="2-Install-Redis-on-Ubuntu-1604" class="ez-toc-section">Step 4: Running a Container with Docker Compose</span><span class="ez-toc-section-end"></span></h2><p>Docker Hub is a public Docker registry in which Docker users can create, test, store, and distribute container images.  In this tutorial, we will use a <em>Hello World </em>image for testing purposes.</p><p>First, we need to create a directory for the YAML file with the following commands:</p><pre>mkdir hello_world
cd hello_world</pre><p>Now we need to create the YAML file:</p><pre>nano docker-compose.yml</pre><p>We need to put the following content into the file, then save and close it.</p><pre>test:
   image: hello-world</pre><p>The first line is showing the container name and the second line specifies which image to use.</p><p>If you need to look manually at images on your system you can use the following command:</p><pre>docker images</pre><p>If there are no local images it will show only the headings.</p><pre>REPOSITORY               TAG               IMAGE                ID               CREATED SIZE</pre><p>Now we will run the <em>Hello World</em> image by executing the following command:</p><pre>docker-compose up</pre><p>If there is no local image for <em>Hello World, </em>Docker Compose will pull it from the Docker Hub repository.</p><pre>Pulling test (hello-world:)...
latest: Pulling from library/hello-world
1b930d010525: Pull complete
Creating hello_test_1_428dc80bd6e3 ... done
Attaching to hello_test_1_cf248cd9e35e</pre><p>After downloading the image, docker compose creates a container and runs the <em>hello-world</em> program.</p><p>If you want to see the container information, you can use the following command:</p><pre>docker ps -a</pre><p>The output should be similar to this:</p><pre>CONTAINER ID IMAGE        COMMAND CREATED            STATUS                        PORTS      NAMES
451001d43d47 hello-world "/hello" About a minute ago Exited (0)About a minute ago             hello_test_1_cf248cd9e35e</pre><p>If you need to remove the container for some reason you can run the following command:</p><pre>docker rm 451001d43d47</pre><p>Once the container has been removed, we can then remove the image:</p><pre>docker rmi hello-world</pre><p>In this tutorial, we learned how to install Docker Compose on Ubuntu 18.04 as well as the basics on how to use it.</p><hr /><p><img class="alignleft size-full wp-image-32321" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20120%20152'%3E%3C/svg%3E" alt="" width="120" height="152" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/managed-docker-compose-support-from-expert-admins-on-ubuntu-vps.jpg 120w, https://www.rosehosting.com/blog/wp-content/uploads/2020/02/managed-docker-compose-support-from-expert-admins-on-ubuntu-vps-118x150.jpg 118w" data-lazy-sizes="(max-width: 120px) 100vw, 120px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/managed-docker-compose-support-from-expert-admins-on-ubuntu-vps.jpg" /><noscript><img class="alignleft size-full wp-image-32321" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/managed-docker-compose-support-from-expert-admins-on-ubuntu-vps.jpg" alt="" width="120" height="152" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/managed-docker-compose-support-from-expert-admins-on-ubuntu-vps.jpg 120w, https://www.rosehosting.com/blog/wp-content/uploads/2020/02/managed-docker-compose-support-from-expert-admins-on-ubuntu-vps-118x150.jpg 118w" sizes="(max-width: 120px) 100vw, 120px" /></noscript>Of course, you don’t have to install Docker Compose on Ubuntu 18.04 if you use one of our <a href="https://www.rosehosting.com/ubuntu-hosting.html" target="_blank" rel="noopener noreferrer">Managed Ubuntu Hosting</a> services, in which case you can simply ask our expert system administrators to install Docker Compose on Ubuntu 18.04 for you. They are available 24×7 and will take care of your request immediately.</p><p><span class="amp-wp-inline-f146f9bb819d875bbe5cf83e36368b44" style="color: #ff0000;"><strong>PS.</strong></span> If you liked this post on <strong>how to install Docker Compose on Ubuntu 18.04</strong>, please share it with your friends on the social networks by using the share shortcuts below, or simply leave a comment in the comments section. Thanks.</p></div><footer class="entry-meta"> <span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://www.rosehosting.com/blog/category/tutorials/" rel="category tag">Tutorials</a>, <a href="https://www.rosehosting.com/blog/category/ubuntu/" rel="category tag">Ubuntu</a></span><nav id="nav-below" class="post-navigation"> <span class="screen-reader-text">Post navigation</span><div class="nav-previous"><span class="prev" title="Previous"><a href="https://www.rosehosting.com/blog/how-to-install-go-on-centos-7/" rel="prev">How to Install Go on CentOS 7</a></span></div></nav></footer></div></article><div class="comments-area"><div id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/how-to-install-docker-compose-on-ubuntu-18-04/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.rosehosting.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea autocomplete="new-password" id="e8bfb06dad" name="e8bfb06dad" cols="45" rows="8" aria-required="true"></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0;clip:rect(1px, 1px, 1px, 1px);position:absolute !important;white-space:nowrap;height:1px;width:1px;overflow:hidden;" tabindex="-1"></textarea><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-noptimize type="text/javascript">document.getElementById("comment").setAttribute( "id", "a651a54b6f8bd8424ee1decd9595c544" );document.getElementById("e8bfb06dad").setAttribute( "id", "comment" );</script></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" /> <label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" /> <label for="url" class="screen-reader-text">Website</label><input placeholder="Website" id="url" name="url" type="url" value="" size="30" /><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='30905' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div></div></div></main></div><div id="right-sidebar" class="widget-area grid-30 tablet-grid-30 grid-parent sidebar" itemtype="https://schema.org/WPSideBar" itemscope><div class="inside-right-sidebar"><aside id="custom_html-6" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a target="_blank" href="https://www.rosehosting.com/linux-vps-hosting.html" rel="noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Cloud VPS Hosting" data-lazy-src="https://media.rosehosting.com/images/blogads/orange.jpg"><noscript><img src="https://media.rosehosting.com/images/blogads/orange.jpg" alt="Cloud VPS Hosting"></noscript></a></div></aside><aside id="custom_html-8" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a target="_blank" href="https://www.rosehosting.com/about-us.html" rel="noopener noreferrer">About RoseHosting</a><br> <a target="_blank" href="https://www.rosehosting.com/linux-vps-hosting.html" rel="noopener noreferrer">Buy a Managed VPS - 25% OFF</a><br> <a target="_blank" href="https://www.rosehosting.com/reviews.html" rel="noopener noreferrer">Customer Reviews</a><br> <a target="_blank" href="https://www.rosehosting.com/nvme-hosting.html" rel="noopener noreferrer">Managed NVMe VPSes</a><br> <a target="_blank" href="https://www.rosehosting.com/dedicated-servers.html" rel="noopener noreferrer">Managed NVMe Dedicated Servers</a></div></aside><aside id="custom_html-5" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a target="_blank" href="https://linuxhostsupport.com/" rel="noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Server Management Services" data-lazy-src="https://media.rosehosting.com/img/blogads/24.jpg"><noscript><img src="https://media.rosehosting.com/img/blogads/24.jpg" alt="Server Management Services"></noscript></a></div></aside><aside id="recent-posts-widget-with-thumbnails-2" class="widget inner-padding recent-posts-widget-with-thumbnails"><div id="rpwwt-recent-posts-widget-with-thumbnails-2" class="rpwwt-widget"><ul><li><a href="https://www.rosehosting.com/blog/how-to-install-docker-compose-on-ubuntu-18-04/"><img width="75" height="75" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2075'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-docker-compose-on-ubuntu18.04-150x150.jpg" /><noscript><img width="75" height="75" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-docker-compose-on-ubuntu18.04-150x150.jpg" class="attachment-75x75 size-75x75" alt="" /></noscript><span class="rpwwt-post-title">How to Install Docker Compose on Ubuntu 18.04</span></a></li><li><a href="https://www.rosehosting.com/blog/how-to-install-go-on-centos-7/"><img width="75" height="75" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2075'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="How to Install Go on CentOS 7" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-go-on-centos7-150x150.jpg" /><noscript><img width="75" height="75" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-go-on-centos7-150x150.jpg" class="attachment-75x75 size-75x75" alt="How to Install Go on CentOS 7" /></noscript><span class="rpwwt-post-title">How to Install Go on CentOS 7</span></a></li><li><a href="https://www.rosehosting.com/blog/what-are-the-key-advantages-of-managed-hosting-for-small-businesses/"><img width="75" height="75" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2075'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/what-are-key-advantages-of-managed-hosting-for-small-businesses-150x150.jpg" /><noscript><img width="75" height="75" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/what-are-key-advantages-of-managed-hosting-for-small-businesses-150x150.jpg" class="attachment-75x75 size-75x75" alt="" /></noscript><span class="rpwwt-post-title">What are the Key Advantages of Managed Hosting for Small Businesses?</span></a></li><li><a href="https://www.rosehosting.com/blog/how-to-install-odoo-12-on-debian-10-with-nginx-as-a-reverse-proxy/"><img width="75" height="75" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2075'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-odoo12-on-debian10-with-nginx-as-reverse-proxy-150x150.jpg" /><noscript><img width="75" height="75" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/how-to-install-odoo12-on-debian10-with-nginx-as-reverse-proxy-150x150.jpg" class="attachment-75x75 size-75x75" alt="" /></noscript><span class="rpwwt-post-title">How to Install Odoo 12 on Debian 10 with Nginx as a Reverse Proxy</span></a></li><li><a href="https://www.rosehosting.com/blog/why-are-fully-managed-hosting-services-the-best-option-for-small-businesses/"><img width="75" height="75" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2075'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/why-are-fully-managed-hosting-services-the-best-option-for-small-businesses-150x150.jpg" /><noscript><img width="75" height="75" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/02/why-are-fully-managed-hosting-services-the-best-option-for-small-businesses-150x150.jpg" class="attachment-75x75 size-75x75" alt="" /></noscript><span class="rpwwt-post-title">Why are Fully Managed Hosting Services the Best Option for Small Businesses?</span></a></li></ul></div></aside></div></div></div><footer class="footer-big-menu"><div class="container" style="max-width: 1100px;"><div class="row menu"><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title mb-2">Company</h3> <a class="menu-link" href="https://www.rosehosting.com/about-us.html">About us</a> <a class="menu-link" href="https://www.rosehosting.com/policies.html">Our Policies</a> <a class="menu-link" href="https://www.rosehosting.com/contact-us.html">Contact Us</a> <a class="menu-link" href="https://www.rosehosting.com/blog/">Blog</a> <a class="menu-link" href="https://www.rosehosting.com/why-rosehosting.html">Why RoseHosting</a> <a class="menu-link" href="https://www.rosehosting.com/compare-to-competition.html">Compare Us</a> <a class="menu-link" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a> <a class="menu-link" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a></div><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title mb-2">Support</h3> <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Helpdesk System</a> <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a> <a class="menu-link" href="https://status.rosehosting.com">Systems Status</a><h3 class="menu-title mb-2 mt-4">Other Services</h3> <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Domain Registration</a> <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Domain Transfer</a> <a class="menu-link" href="https://www.rosehosting.com/ssl-certificates.html">SSL Certificates</a></div><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title mb-2">Hosting</h3> <a class="menu-link" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/linux-vps-hosting.html">Linux VPS Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting</a> <a class="menu-link" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom SSD VPS</a> <a class="menu-link" href="https://www.rosehosting.com/dedicated-servers.html">Cloud Dedicated Servers</a> <a class="menu-link" href="https://www.rosehosting.com/hosting-solutions.html">Hosting Solutions</a> <a class="menu-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Recurr. Affiliate Program</a> <a class="menu-link" href="https://www.rosehosting.com/cpa-hosting-affiliate-program.html">CPA Affiliate Program</a></div><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title mb-2">Linux VPS Hosting</h3> <a class="menu-link" href="https://www.rosehosting.com/centos-hosting.html">CentOS Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/ubuntu-hosting.html">Ubuntu Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/debian-hosting.html">Debian Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/opensuse-hosting.html">OpenSUSE Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/arch-linux-hosting.html">Arch-Linux Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/scientific-linux-hosting.html">Scientific Linux Hosting</a></div><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title mb-2">Apps Hosting</h3> <a class="menu-link" href="https://www.rosehosting.com/wordpress-hosting.html">WordPress Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/magento-hosting.html">Magento Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/odoo-hosting.html">Odoo Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/joomla-hosting.html">Joomla Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/drupal-hosting.html">Drupal Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/laravel-hosting.html">Laravel Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/nextcloud-hosting.html">NextCloud Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/prestashop-hosting.html">PrestaShop Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/ghost-hosting.html">Ghost Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/mediawiki-hosting.html">MediaWiki Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/tomcat-hosting.html">Tomcat Hosting</a></div><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title mb-2">Contact Us</h3> <a class="menu-link" href="tel:+18887673467">(888) ROSE-HOST</a> <a class="menu-link" href="tel:+18887673467">(888) 767-3467</a> <a class="menu-link" href="tel:+16465197201">(314) 275-0414</a> <a class="menu-link" href="/cdn-cgi/l/email-protection#fadfcdc9dfcdcfdfcdcadfcdcadfcc9cdfcdc8dfcdcedfcecadfcdc8dfcc9cdfcdc9dfcccfdfccc2dfcc9cdfcdc9dfcdcedfccc3dfcc9fdfcccddfc89fdfccc9dfcc9cdfcc9e">Email us</a><h3 class="menu-title mb-2 mt-4">Connect</h3> <a class="menu-link" href="https://twitter.com/rosehosting" target="_blank"><i class="fa fa-twitter fa-fw"></i> Twitter</a> <a class="menu-link" href="https://www.facebook.com/RoseHosting" target="_blank"><i class="fa fa-facebook fa-fw"></i> Facebook</a> <a class="menu-link" href="https://www.linkedin.com/company/rose-web-services-l-l-c-" target="_blank"><i class="fa fa-linkedin fa-fw"></i> LinkedIn</a> <a class="menu-link" href="https://www.rosehosting.com/blog/feed/" target="_blank"><i class="fa fa-rss fa-fw"></i> RSS Feed</a></div></div></div><div class="bottom"><div class="container" style="max-width: 1100px;"><div class="row"><div class="col col-md-12"> <img class="privacy-shield d-block mb-4" width="175" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20175%200'%3E%3C/svg%3E" alt="privacy shield" data-lazy-src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/privacy_shield.png"><noscript><img class="privacy-shield d-block mb-4" width="175" src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/privacy_shield.png" alt="privacy shield"></noscript></div><div class="col-md-12 col-lg-6"><p class="text-sm-left"><a class="inline-link footer-policy" href="/tos.html">Terms of Service</a> and <a class="inline-link footer-policy" href="/policies.html">other policies</a></p></div><div class="col-md-12 col-lg-6"><p class="text-sm-right">&copy; 2001-2020 <a class="inline-link footer-policy" href="https://www.rosewebservices.com/">Rose Web Services LLC</a>.</p></div></div></div></div> <!--[if lte IE 11]>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/generatepress/js/classList.min.js' defer='defer'></script>
<![endif]--> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>/* <![CDATA[ */ var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"","width":"95%","scroll_offset":"30"}; /* ]]> */</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.rosehosting.com/blog/wp-content/plugins/wp-rocket/assets/js/lazyload/12.0/lazyload.min.js"></script> <script src="https://www.rosehosting.com/blog/wp-content/cache/min/1/ae0ccf9dc45e30d06bcdf2b7d6148c7d.js' defer='defer" data-minify="1"></script><noscript><link rel="stylesheet" href="https://www.rosehosting.com/blog/wp-content/cache/min/1/f7a80910a0fb8ae418e6d35cef561502.css" data-minify="1" /></noscript><noscript><link rel='stylesheet' id='generate-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans:300,300italic,regular,italic,600,600italic,700,700italic,800,800italic&#038;display=swap' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' /></noscript></body></html>
