<!DOCTYPE html><!--[if IE 6]><html id="ie6" lang="en-US"><![endif]--><!--[if IE 7]><html id="ie7" lang="en-US"><![endif]--><!--[if IE 8]><html id="ie8" lang="en-US"><![endif]--><!--[if !(IE 6) | !(IE 7) | !(IE 8) ]><!--><html lang="en-US"><!--<![endif]--><head><meta charset="UTF-8" /><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script><link rel="pingback" href="https://www.rosehosting.com/blog/xmlrpc.php" /><!--[if lt IE 9]><script src="https://www.rosehosting.com/blog/wp-content/themes/generatepress/scripts/ext/html5.js" type="text/javascript"></script><![endif]--><!--<script type="rocketlazyloadscript" async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script>--><script type="rocketlazyloadscript" data-rocket-type="text/javascript">document.documentElement.className = 'js';</script><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><meta name="viewport" content="width=device-width, initial-scale=1"><title>How to Install Neos CMS on Ubuntu 22.04 - RoseHosting</title><meta name="description" content="In this tutorial, we are going to install Neos CMS on Ubuntu 22.04 OS. Join us and let&#039;s get things done!" /><link rel="canonical" href="https://www.rosehosting.com/blog/how-to-install-neos-cms-on-ubuntu-22-04/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How to Install Neos CMS on Ubuntu 22.04" /><meta property="og:description" content="In this tutorial, we are going to install Neos CMS on Ubuntu 22.04 OS. Join us and let&#039;s get things done!" /><meta property="og:url" content="https://www.rosehosting.com/blog/how-to-install-neos-cms-on-ubuntu-22-04/" /><meta property="og:site_name" content="RoseHosting" /><meta property="article:publisher" content="https://www.facebook.com/RoseHosting" /><meta property="article:author" content="https://www.facebook.com/rosehosting.helpdesk" /><meta property="article:published_time" content="2022-08-01T17:30:49+00:00" /><meta property="article:modified_time" content="2022-07-22T14:30:00+00:00" /><meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2022/07/how-to-install-neos-cms-on-ubuntu-22.04.webp" /><meta property="og:image:width" content="742" /><meta property="og:image:height" content="372" /><meta property="og:image:type" content="image/webp" /><meta name="author" content="Jeff Wilson" /><meta name="twitter:card" content="summary" /><meta name="twitter:title" content="How to Install Neos CMS on Ubuntu 22.04" /><meta name="twitter:description" content="In this tutorial, we are going to install Neos CMS on Ubuntu 22.04 OS. Join us and let&#039;s get things done!" /><meta name="twitter:creator" content="@rosehosting" /><meta name="twitter:site" content="@rosehosting" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Jeff Wilson" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="6 minutes" /><script type="application/ld+json" class="yoast-schema-graph">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</script><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Feed" href="https://www.rosehosting.com/blog/feed/" /><link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Comments Feed" href="https://www.rosehosting.com/blog/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; How to Install Neos CMS on Ubuntu 22.04 Comments Feed" href="https://www.rosehosting.com/blog/how-to-install-neos-cms-on-ubuntu-22-04/feed/" /><script id="rhbl-ready">window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];</script><style>img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0 0.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0 !important}</style><link rel='stylesheet' id='wp-block-library-css' href='https://www.rosehosting.com/blog/wp-includes/css/dist/block-library/style.min.css' media='all' /><style id='global-styles-inline-css'>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</style><link data-minify="1" rel='stylesheet' id='cptch_stylesheet-css' href='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/captcha-bws/css/front_end_style.css?ver=1657917293' media='all' /><link data-minify="1" rel='stylesheet' id='cptch_desktop_style-css' href='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/captcha-bws/css/desktop_style.css?ver=1657917293' media='all' /><link data-minify="1" rel='stylesheet' id='ez-icomoon-css' href='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/easy-table-of-contents/vendor/icomoon/style.min.css?ver=1657917293' media='all' /><link rel='stylesheet' id='ez-toc-css' href='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/assets/css/screen.min.css' media='all' /><style id='ez-toc-inline-css'>div#ez-toc-container p.ez-toc-title{font-size:22px}div#ez-toc-container p.ez-toc-title{font-weight:500}div#ez-toc-container ul li{font-size:95%}div#ez-toc-container nav ul ul li ul li{font-size:%!important}div#ez-toc-container{width:95%}</style><link rel='stylesheet' id='parent-style-css' href='https://www.rosehosting.com/blog/wp-content/themes/generatepress/style.css' media='all' /><link data-minify="1" rel='stylesheet' id='font-awesome-css' href='https://www.rosehosting.com/blog/wp-content/cache/min/1/font-awesome/4.7.0/css/font-awesome.min.css?ver=1657917293' media='all' /><link data-minify="1" rel='stylesheet' id='bootstrap-css' href='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/themes/rh2022/css/bootstrap.css?ver=1657917294' media='all' /><link data-minify="1" rel='stylesheet' id='theme-style-css' href='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/themes/rh2022/css/theme.css?ver=1657917294' media='all' /><link rel='stylesheet' id='generate-comments-css' href='https://www.rosehosting.com/blog/wp-content/themes/generatepress/assets/css/components/comments.min.css' media='all' /><link rel='stylesheet' id='generate-style-css' href='https://www.rosehosting.com/blog/wp-content/themes/generatepress/assets/css/main.min.css' media='all' /><style id='generate-style-inline-css'>.is-right-sidebar{width:30%}.is-left-sidebar{width:25%}.site-content .content-area{width:70%}@media (max-width:768px){.main-navigation .menu-toggle,.sidebar-nav-mobile:not(#sticky-placeholder){display:block}.main-navigation ul,.gen-sidebar-nav,.main-navigation:not(.slideout-navigation):not(.toggled) .main-nav > ul,.has-inline-mobile-toggle #site-navigation .inside-navigation > *:not(.navigation-search):not(.main-nav){display:none}.nav-align-right .inside-navigation,.nav-align-center .inside-navigation{justify-content:space-between}}.dynamic-author-image-rounded{border-radius:100%}.dynamic-featured-image,.dynamic-author-image{vertical-align:middle}.one-container.blog .dynamic-content-template:not(:last-child),.one-container.archive .dynamic-content-template:not(:last-child){padding-bottom:0px}.dynamic-entry-excerpt > p:last-child{margin-bottom:0px}</style><link rel='stylesheet' id='generatepress-dynamic-css' href='https://www.rosehosting.com/blog/wp-content/uploads/generatepress/style.min.css' media='all' /><link data-minify="1" rel='stylesheet' id='generate-child-css' href='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/themes/rh2022/style.css?ver=1657917294' media='all' /><script src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script><script src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script><script id='advanced-ads-advanced-js-js-extra'>var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};</script><script src='https://www.rosehosting.com/blog/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js?ver=1.34.0' id='advanced-ads-advanced-js-js' defer></script><script id='advanced_ads_pro/visitor_conditions-js-extra'>var advanced_ads_pro_visitor_conditions = {"referrer_cookie_name":"advanced_ads_pro_visitor_referrer","referrer_exdays":"365","page_impr_cookie_name":"advanced_ads_page_impressions","page_impr_exdays":"3650"};</script><script src='https://www.rosehosting.com/blog/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.min.js?ver=2.17.2' id='advanced_ads_pro/visitor_conditions-js' defer></script><script data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/ajax/libs/popper.js/1.11.0/umd/popper.min.js?ver=1657917294' id='popper-js' defer></script><script data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/themes/rh2022/js/bootstrap.js?ver=1657917294' id='bootstrap-js' defer></script><script src='https://www.rosehosting.com/blog/wp-content/themes/rh2022/js/cookieconsent.min.js?ver=1' id='cookieconsent-js' defer></script><link rel="https://api.w.org/" href="https://www.rosehosting.com/blog/wp-json/" /><link rel="alternate" type="application/json" href="https://www.rosehosting.com/blog/wp-json/wp/v2/posts/42429" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rosehosting.com/blog/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rosehosting.com/blog/wp-includes/wlwmanifest.xml" /> <meta name="generator" content="WordPress 6.0.1" /><link rel='shortlink' href='https://www.rosehosting.com/blog/?p=42429' /><link rel="alternate" type="application/json+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-install-neos-cms-on-ubuntu-22-04%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-install-neos-cms-on-ubuntu-22-04%2F&#038;format=xml" /><script type="rocketlazyloadscript" data-rocket-type="text/javascript">var advadsCfpQueue = [];var advadsCfpAd = function( adID ){if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }};</script><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2022/03/cropped-favicon-1-32x32.png?v=1647725505" sizes="32x32" /><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2022/03/cropped-favicon-1-192x192.png?v=1647725505" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2022/03/cropped-favicon-1-180x180.png?v=1647725505" /><meta name="msapplication-TileImage" content="https://www.rosehosting.com/blog/wp-content/uploads/2022/03/cropped-favicon-1-270x270.png?v=1647725505" /><style id="wp-custom-css">.widget-title{display:none}.widget .search-field{border-radius:5px 0 0 5px;height:117%}.widget .search-form button.search-submit{border-radius:0 5px 5px 0;background-color:#ff5700 !important}</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none !important}</style></noscript><script type="rocketlazyloadscript" data-rocket-type="text/javascript">var _paq = window._paq = window._paq || [];
_paq.push(["setCookieDomain", "*.rosehosting.com"]);_paq.push(['trackPageView']);_paq.push(['enableLinkTracking']);_paq.push(['enableHeartBeatTimer', 15]);(function() {var u="//n.rosehosting.com/";
_paq.push(['setTrackerUrl', u+'rosea.php']);_paq.push(['setSiteId', '1']);var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];g.type='text/javascript'; g.async=true; g.src='https://www.rosehosting.com/dist/rosea.js'; s.parentNode.insertBefore(g,s);
})();</script><script type="rocketlazyloadscript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P4FHJW');</script></head><body class="post-template-default single single-post postid-42429 single-format-standard wp-embed-responsive post-image-above-header post-image-aligned-center sticky-menu-fade right-sidebar nav-below-header separate-containers header-aligned-left dropdown-hover aa-prefix-rhbl-"><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-P4FHJW"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><nav class="navbar yamm navbar-expand-lg navbar-dark" role="navigation"> <div class="container no-override navbar-dark"> <a class="navbar-brand" href="https://www.rosehosting.com/"> <img alt="RoseHosting.com" width="186" height="37" class="d-lg-inline mr-2" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20186%2037'%3E%3C/svg%3E" data-lazy-src="https://www.rosehosting.com/blog/wp-content/themes/rh2022/img/rh-logo.svg" /><noscript><img alt="RoseHosting.com" width="186" height="37" class="d-lg-inline mr-2" src="https://www.rosehosting.com/blog/wp-content/themes/rh2022/img/rh-logo.svg" /></noscript> </a> <button class="navbar-toggler" data-toggle="collapse" data-target="#navbar-collapse"> <span class="navbar-toggler-icon"></span> </button> <div class="collapse navbar-collapse justify-content-end" id="navbar-collapse"> <ul class="navbar-nav"> <li class="nav-item active dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> Hosting Solutions <i class="fa fa-chevron-down"></i> </a> <div class="dropdown-menu" role="menu"> <div class="yamm-content"> <div class="row"> <div class="col-sm-6"> <span class="text-primary dropdown-header"><strong>Managed NVMe Hosting</strong></span> <div class="dropdown-divider"></div> <a class="dropdown-item" href="https://www.rosehosting.com/linux-vps-hosting/">Linux VPS Hosting</a> <a class="dropdown-item" href="https://www.rosehosting.com/managed-cloud-hosting/">Cloud Hosting</a> <a class="dropdown-item" href="https://www.rosehosting.com/dedicated-servers/">Dedicated Servers</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/?cmd=cart&action=add&id=82">Custom VPS</a> <a class="dropdown-item" href="https://www.rosehosting.com/linux-shared-hosting/">Shared Web Hosting</a> </div> <div class="col-sm-6"> <span class="text-primary dropdown-header"><strong>Managed Solutions</strong></span> <div class="dropdown-divider"></div> <a class="dropdown-item" href="https://www.rosehosting.com/wordpress-hosting/"> Wordpress Hosting </a> <a class="dropdown-item" href="https://www.rosehosting.com/magento-hosting/"> Magento Hosting </a> <a class="dropdown-item" href="https://www.rosehosting.com/odoo-hosting/"> Odoo Hosting </a> <a class="dropdown-item" href="https://www.rosehosting.com/nextcloud-hosting/"> Nextcloud Hosting </a> <a class="dropdown-item" href="https://www.rosehosting.com/woocommerce-hosting/"> WooCommerce Hosting </a> <a class="dropdown-item" href="https://www.rosehosting.com/prestashop-hosting/"> Prestashop Hosting </a> <span class="dropdown-item mt-4"><a class="btn-shadow btn-shadow-primary btn-shadow-sm" style="margin-bottom: 10px;" target="_blank" href="https://www.rosehosting.com/hosting-solutions/">Other Solutions</a></span> </div> </div> </div> </div> </li> <li class="nav-item dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> SSL / Domains <i class="fa fa-chevron-down"></i> </a> <div class="dropdown-menu" role="menu"> <div class="yamm-content"> <div class="row"> <div class="col-sm-6"> <span class="text-primary dropdown-header"><strong>SSL Certificates</strong></span> <div class="dropdown-divider"></div> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificate-brands/">Grouped By Brand</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificate-types/">Grouped By Type</a> </div> <div class="col-sm-6"> <span class="text-primary dropdown-header"><strong>Domains</strong></span> <div class="dropdown-divider"></div> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Register Domains</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Transfer Domains</a> </div> </div> </div> </div> <li class="nav-item dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> Support <i class="fa fa-chevron-down"></i> </a> <div class="dropdown-menu" role="menu"> <a class="dropdown-item" href="https://www.rosehosting.com/support/">24/7 Managed Support</a> <a class="dropdown-item" href="https://www.rosehosting.com/support/server-migration/">Managed Migration</a> <a class="dropdown-item" href="https://www.rosehosting.com/support/managed-hosting/">Fully-Managed Hosting</a> <a class="dropdown-item" rel=”nofollow” href="https://status.rosehosting.com">Systems Status</a> </div> </li> <li class="nav-item dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> About Us <i class="fa fa-chevron-down"></i> </a> <div class="dropdown-menu" role="menu"> <a class="dropdown-item" href="https://www.rosehosting.com/about-us/">Our Company</a> <a class="dropdown-item" href="https://www.rosehosting.com/about-us/contact-us/">Contact Us</a> <a class="dropdown-item" href="https://www.rosehosting.com/about-us/awards-and-recognition/">Awards &amp; Recognition</a> <a class="dropdown-item" href="https://www.rosehosting.com/about-us/hosting-customer-reviews/">Customer Reviews</a> <a class="dropdown-item" href="https://www.rosehosting.com/legal/">Our Policies</a> <a class="dropdown-item" href="https://www.rosehosting.com/about-us/why-choose-rosehosting/">Why RoseHosting</a> <a class="dropdown-item" href="https://www.rosehosting.com/about-us/compare-rosehosting/">Compare Us</a> </div> </li> <li class="nav-item dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> Affiliates <i class="fa fa-chevron-down"></i> </a> <div class="dropdown-menu" role="menu"> <a class="dropdown-item" href="https://www.rosehosting.com/affiliate-program/">Affiliate Programs</a> <a class="dropdown-item" href="https://www.rosehosting.com/affiliate-program/cpa-affiliate-program/">Flat-Rate CPA Affiliate Plan</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Flat-Rate CPA Affiliate Login</a> <a class="dropdown-item" href="https://www.rosehosting.com/affiliate-program/vps-affiliate-program/">Recurring Affiliate Plan</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/aff/">Recurring Affiliate Login</a> </div> </li> <li class="nav-item"> <a class="nav-link" href="https://www.rosehosting.com/blog/">Blog</a> </li> <li class="nav-item"> <a class="nav-link nav-link--rounded" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Login</a> </li> </ul> </div> </div></nav><div id="page-container" class="page-container"><div class="site grid-container container hfeed" id="page"><div class="site-content" id="content"><div class="content-area" id="primary"><main class="site-main" id="main"><article id="post-42429" class="post-42429 post type-post status-publish format-standard has-post-thumbnail hentry category-cms-crm-erp category-tutorials category-ubuntu tag-neos-cms tag-ubuntu-22-04" itemtype="https://schema.org/CreativeWork" itemscope><div class="inside-article"><header class="entry-header" aria-label="Content"><h1 class="entry-title" itemprop="headline">How to Install Neos CMS on Ubuntu 22.04</h1><div class="entry-meta"><span class="posted-on"><time class="entry-date published" datetime="2022-08-01T12:30:49-05:00" itemprop="datePublished">August 1, 2022</time></span> <span class="byline">by <span class="author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope><a class="url fn n" href="https://www.rosehosting.com/blog/author/jwilson/" title="View all posts by Jeff Wilson" rel="author" itemprop="url"><span class="author-name" itemprop="name">Jeff Wilson</span></a></span></span> </div></header><div class="entry-content" itemprop="text"><p><img class="alignnone size-full wp-image-42743" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20742%20372'%3E%3C/svg%3E" alt="how to install neos cms on ubuntu 22.04" width="742" height="372" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/07/how-to-install-neos-cms-on-ubuntu-22.04.webp 742w, https://www.rosehosting.com/blog/wp-content/uploads/2022/07/how-to-install-neos-cms-on-ubuntu-22.04-300x150.webp 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/07/how-to-install-neos-cms-on-ubuntu-22.04-150x75.webp 150w" data-lazy-sizes="(max-width: 742px) 100vw, 742px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/07/how-to-install-neos-cms-on-ubuntu-22.04.webp" /><noscript><img class="alignnone size-full wp-image-42743" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/07/how-to-install-neos-cms-on-ubuntu-22.04.webp" alt="how to install neos cms on ubuntu 22.04" width="742" height="372" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/07/how-to-install-neos-cms-on-ubuntu-22.04.webp 742w, https://www.rosehosting.com/blog/wp-content/uploads/2022/07/how-to-install-neos-cms-on-ubuntu-22.04-300x150.webp 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/07/how-to-install-neos-cms-on-ubuntu-22.04-150x75.webp 150w" sizes="(max-width: 742px) 100vw, 742px" /></noscript></p><p>In this tutorial, we are going to install Neos CMS on Ubuntu 22.04 OS.</p><p>Neos CMS is an open-source Content Management System that allows developers and users to build their websites in a couple of steps quickly. Neos CMS is written in PHP and javascript and uses SQL. In this blog post, we will install Neos CMS with the LAMP stack so you can easily access it via a domain name.</p><p>Installing Neos CMS with LAMP stack on <a href="https://www.rosehosting.com/ubuntu-hosting/">Ubuntu 22.04</a> may take up to 30 minutes. Let&#8217;s get things done!</p><p><span id="more-42429"></span></p><div id="ez-toc-container" class="ez-toc-v2_0_31_1 counter-hierarchy ez-toc-transparent"><p class="ez-toc-title">Table of Contents</p><label for="item" class="cssicon"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></label><label for="item" class="cssiconcheckbox">1</label><input type="checkbox" id="item" ><nav><ul class="ez-toc-list ez-toc-list-level-1"><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-1" href="#Prerequisites" title="Prerequisites">Prerequisites</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-2" href="#Step-1-Update-the-System" title="Step 1. Update the System">Step 1. Update the System</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-3" href="#Step-2-Install-Apache-Web-Server" title="Step 2. Install Apache Web Server">Step 2. Install Apache Web Server</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-4" href="#Step-3-Install-MariaDB-database-server" title="Step 3. Install MariaDB database server">Step 3. Install MariaDB database server</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-5" href="#Step-4-Create-Neos-CMS-database-and-user" title="Step 4. Create Neos CMS database and user">Step 4. Create Neos CMS database and user</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-6" href="#Step-5-Install-PHP8-with-extensions" title="Step 5. Install PHP8 with extensions">Step 5. Install PHP8 with extensions</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-7" href="#Step-6-Install-Composer" title="Step 6. Install Composer">Step 6. Install Composer</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-8" href="#Step-7-Install-Neos-CMS" title="Step 7. Install Neos CMS">Step 7. Install Neos CMS</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-9" href="#Step-8-Create-Apache-Virtual-Host-file" title="Step 8. Create Apache Virtual Host file">Step 8. Create Apache Virtual Host file</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-10" href="#Step-9-Finish-Neos-CMS-Installation" title="Step 9. Finish Neos CMS Installation">Step 9. Finish Neos CMS Installation</a></li></ul></nav></div><h2><span class="ez-toc-section" id="Prerequisites"></span>Prerequisites<span class="ez-toc-section-end"></span></h2><ul><li>A server with Ubuntu 22.04 as OS</li><li>A valid domain name pointed to the server IP address</li><li>User privileges: root or non-root user with sudo privileges</li></ul><h2><span class="ez-toc-section" id="Step-1-Update-the-System"></span>Step 1. Update the System<span class="ez-toc-section-end"></span></h2><p>Since we have a fresh installation of Ubuntu 22.04 we need to update the package to the latest versions available.</p><pre>sudo apt-get update -y &amp;&amp; sudo apt-get upgrade -y</pre><h2><span class="ez-toc-section" id="Step-2-Install-Apache-Web-Server"></span>Step 2. Install Apache Web Server<span class="ez-toc-section-end"></span></h2><p>Apache Web server can be installed with the following command:</p><pre>sudo apt install apache2 -y</pre><p>Once installed, start and enable the service.</p><pre>sudo systemctl enable apache2.service &amp;&amp; sudo systemctl start apache2.service</pre><p>Check if the service is up and running:</p><pre>sudo systemctl status apache2.service</pre><p>You should receive the following output:</p><pre>root@host:~# sudo systemctl status apache2.service
● apache2.service - The Apache HTTP Server
     Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2022-06-21 11:04:28 UTC; 1h 2min ago
       Docs: https://httpd.apache.org/docs/2.4/
   Main PID: 8106 (apache2)
      Tasks: 8 (limit: 4579)
     Memory: 13.3M
        CPU: 958ms
     CGroup: /system.slice/apache2.service</pre><h2><span class="ez-toc-section" id="Step-3-Install-MariaDB-database-server"></span>Step 3. Install MariaDB database server<span class="ez-toc-section-end"></span></h2><p>MariaDB database server can be installed with the following command:</p><pre>sudo apt install mariadb-server -y</pre><p>Start and enable the MariaDB.service with the following commands:</p><pre>sudo systemctl start mariadb.service &amp;&amp; sudo systemctl enable mariadb.service</pre><p>Check the status of the mariadb.service</p><pre>sudo systemctl status mariadb</pre><p>You should receive the following output:</p><pre>root@host:~# sudo systemctl status mariadb
● mariadb.service - MariaDB 10.6.7 database server
     Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2022-06-21 11:09:23 UTC; 41s ago
       Docs: man:mariadbd(8)
             https://mariadb.com/kb/en/library/systemd/
   Main PID: 21540 (mariadbd)
     Status: "Taking your SQL requests now..."
      Tasks: 15 (limit: 4579)
     Memory: 57.1M
        CPU: 3.472s
     CGroup: /system.slice/mariadb.service
             └─21540 /usr/sbin/mariadbd

</pre><h2><span class="ez-toc-section" id="Step-4-Create-Neos-CMS-database-and-user"></span>Step 4. Create Neos CMS database and user<span class="ez-toc-section-end"></span></h2><p>To create a database, user and assign permission to that database, execute the following commands:</p><pre> CREATE DATABASE neosdb;
 CREATE USER 'neosdb'@'localhost';
 GRANT ALL PRIVILEGES ON neosdb.* TO 'neosdb'@'localhost' IDENTIFIED BY 'YourStrongPasswordHere';
 FLUSH PRIVILEGES;
 EXIT;
</pre><h2><span class="ez-toc-section" id="Step-5-Install-PHP8-with-extensions"></span>Step 5. Install PHP8 with extensions<span class="ez-toc-section-end"></span></h2><p>PHP8 with extensions and can be installed with the following commands:</p><pre>sudo apt-get install php8.1 php8.1-cli php8.1-common php8.1-imap php8.1-redis php8.1-snmp php8.1-xml php8.1-zip php8.1-mbstring php8.1-curl libapache2-mod-php php8.1-mysql -y
</pre><h2><span class="ez-toc-section" id="Step-6-Install-Composer"></span>Step 6. Install Composer<span class="ez-toc-section-end"></span></h2><p>We need Composer to install the Neos CMS requirements. Composer can be installed with the following command:</p><pre>curl -sS https://getcomposer.org/installer | php -- --install-dir=/usr/bin --filename=composer</pre><p>Check the Composer installation:</p><pre>composer</pre><p>You should receive the following output:</p><p>root@host:~# composer<br />Do not run Composer as root/super user! See https://getcomposer.org/root for details<br />Continue as root/super user [yes]? yes<br />______<br />/ ____/___ ____ ___ ____ ____ ________ _____<br />/ / / __ \/ __ `__ \/ __ \/ __ \/ ___/ _ \/ ___/<br />/ /___/ /_/ / / / / / / /_/ / /_/ (__ ) __/ /<br />\____/\____/_/ /_/ /_/ .___/\____/____/\___/_/<br />/_/<br />Composer version 2.3.7 2022-06-06 11:43:28</p><h2><span class="ez-toc-section" id="Step-7-Install-Neos-CMS"></span>Step 7. Install Neos CMS<span class="ez-toc-section-end"></span></h2><p>Once the composer is installed, go into the default Apache document root and execute the command below:</p><pre>cd /var/www/html/

git clone https://github.com/neos/neos-base-distribution.git .

composer install
</pre><p>Once the installation is completed, set the right permissions:</p><pre>chown -R www-data:www-data /var/www/html/

find . -type d -exec chmod 755 {} \; 

find . -type f -exec chmod 644 {} \;
</pre><p>The next step is to enter the database credentials into two files, one for Production and one for Development, just in case.</p><p>First we need to go into the <b>/var/www/html/Configuration/Development</b> directory and rename the file <b>Settings.yaml.example</b> to <b>Settings.yaml.example</b></p><pre>cd /var/www/html/Configuration/Development

mv Settings.yaml.example Settings.yaml
</pre><p>Open the file, enter the database name, database user, and database password, save it and close the file.</p><pre>backendOptions:
        dbname: 'neosdb'       # adjust to your database name
        user: 'neosdb'             # adjust to your database user
        password: 'YourStrongPasswordHere'         # adjust to your database password
</pre><p>Repeat the same procedure for the <b>Production</b> directory.</p><pre>cd /var/www/html/Configuration/Production

mv Settings.yaml.example Settings.yaml</pre><p>Open the <b>Settings.yaml</b> file and paste the database credentials. Save the file and close it.</p><h2><span class="ez-toc-section" id="Step-8-Create-Apache-Virtual-Host-file"></span>Step 8. Create Apache Virtual Host file<span class="ez-toc-section-end"></span></h2><p>Go into the Apache directory and create a configuration file for the Neos CMS.</p><pre>cd /etc/apache2/sites-available/

touch neos.conf
</pre><p>Open the file, paste the following lines of code, save the file and close it.</p><pre>&lt;VirtualHost *:80&gt;
ServerName <b>yourdomain.com</b>
DocumentRoot /var/www/html/Web

&lt;Directory /var/www/html/Web&gt;
AllowOverride All
&lt;/Directory&gt;

ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

&lt;Directory /var/www/html/Web/&gt;
            RewriteEngine on
            RewriteBase /
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteRule ^(.*) index.php [PT,L]
&lt;/Directory&gt;

&lt;/VirtualHost&gt;

</pre><p>Enable the Apache configuration for Neos CMS and rewrite the module.</p><pre>sudo a2enmod rewrite

sudo a2ensite neos.conf
</pre><p>Check the syntax:</p><pre>apachectl -t</pre><p>You should receive the following output:</p><pre>root@vps:~# apachectl -t
Syntax OK
</pre><p>If the syntax is OK, restart the Apache service.</p><pre>systemctl reload apache2.service
</pre><p>Once the Apache service is restarted, you can finish the Neos CMS installation at <b>http://yourdomain.com.</b></p><h2><span class="ez-toc-section" id="Step-9-Finish-Neos-CMS-Installation"></span>Step 9. Finish Neos CMS Installation<span class="ez-toc-section-end"></span></h2><p>On the first window, click on the &#8220;Go to setup&#8221; button.</p><p><img class="aligncenter size-full wp-image-42430" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20464%20600'%3E%3C/svg%3E" alt="" width="464" height="600" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos1.jpg?v=1655836183 464w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos1-232x300.jpg?v=1655836183 232w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos1-116x150.jpg?v=1655836183 116w" data-lazy-sizes="(max-width: 464px) 100vw, 464px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos1.jpg" /><noscript><img class="aligncenter size-full wp-image-42430" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos1.jpg" alt="" width="464" height="600" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos1.jpg?v=1655836183 464w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos1-232x300.jpg?v=1655836183 232w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos1-116x150.jpg?v=1655836183 116w" sizes="(max-width: 464px) 100vw, 464px" /></noscript></p><p>The setup will start with initializing.</p><p><img class="aligncenter size-full wp-image-42431" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20825%20233'%3E%3C/svg%3E" alt="" width="825" height="233" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos2.jpg?v=1655836199 825w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos2-300x85.jpg?v=1655836199 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos2-150x42.jpg?v=1655836199 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos2-768x217.jpg?v=1655836199 768w" data-lazy-sizes="(max-width: 825px) 100vw, 825px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos2.jpg" /><noscript><img class="aligncenter size-full wp-image-42431" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos2.jpg" alt="" width="825" height="233" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos2.jpg?v=1655836199 825w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos2-300x85.jpg?v=1655836199 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos2-150x42.jpg?v=1655836199 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos2-768x217.jpg?v=1655836199 768w" sizes="(max-width: 825px) 100vw, 825px" /></noscript></p><p>Enter the password only one time, which is located in the directory explained in the picture.</p><p><img class="aligncenter size-full wp-image-42432" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20860%20486'%3E%3C/svg%3E" alt="" width="860" height="486" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos3.jpg?v=1655836221 860w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos3-300x170.jpg?v=1655836221 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos3-150x85.jpg?v=1655836221 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos3-768x434.jpg?v=1655836221 768w" data-lazy-sizes="(max-width: 860px) 100vw, 860px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos3.jpg" /><noscript><img class="aligncenter size-full wp-image-42432" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos3.jpg" alt="" width="860" height="486" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos3.jpg?v=1655836221 860w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos3-300x170.jpg?v=1655836221 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos3-150x85.jpg?v=1655836221 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos3-768x434.jpg?v=1655836221 768w" sizes="(max-width: 860px) 100vw, 860px" /></noscript></p><p>You need to execute the following command on your server:<br /><b>cat /var/www/html/Data/SetupPassword.txt</b></p><p><img class="aligncenter size-full wp-image-42433" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20730%20131'%3E%3C/svg%3E" alt="" width="730" height="131" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos4.jpg?v=1655836241 730w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos4-300x54.jpg?v=1655836241 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos4-150x27.jpg?v=1655836241 150w" data-lazy-sizes="(max-width: 730px) 100vw, 730px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos4.jpg" /><noscript><img class="aligncenter size-full wp-image-42433" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos4.jpg" alt="" width="730" height="131" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos4.jpg?v=1655836241 730w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos4-300x54.jpg?v=1655836241 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos4-150x27.jpg?v=1655836241 150w" sizes="(max-width: 730px) 100vw, 730px" /></noscript></p><p>In the next window, you need to check for the installed extensions. If everything is OK, it will be in green.</p><p><img class="aligncenter size-full wp-image-42434" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20838%20594'%3E%3C/svg%3E" alt="" width="838" height="594" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos5.jpg?v=1655836264 838w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos5-300x213.jpg?v=1655836264 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos5-150x106.jpg?v=1655836264 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos5-768x544.jpg?v=1655836264 768w" data-lazy-sizes="(max-width: 838px) 100vw, 838px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos5.jpg" /><noscript><img class="aligncenter size-full wp-image-42434" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos5.jpg" alt="" width="838" height="594" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos5.jpg?v=1655836264 838w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos5-300x213.jpg?v=1655836264 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos5-150x106.jpg?v=1655836264 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos5-768x544.jpg?v=1655836264 768w" sizes="(max-width: 838px) 100vw, 838px" /></noscript></p><p>In the next window, you need to enter the database credentials.</p><p><img class="aligncenter size-full wp-image-42435" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20606%20628'%3E%3C/svg%3E" alt="" width="606" height="628" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos6.jpg?v=1655836282 606w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos6-289x300.jpg?v=1655836282 289w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos6-145x150.jpg?v=1655836282 145w" data-lazy-sizes="(max-width: 606px) 100vw, 606px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos6.jpg" /><noscript><img class="aligncenter size-full wp-image-42435" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos6.jpg" alt="" width="606" height="628" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos6.jpg?v=1655836282 606w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos6-289x300.jpg?v=1655836282 289w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos6-145x150.jpg?v=1655836282 145w" sizes="(max-width: 606px) 100vw, 606px" /></noscript></p><p>In the next window, you need to set up the Administrator account.</p><p><img class="aligncenter size-full wp-image-42436" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20633%20619'%3E%3C/svg%3E" alt="" width="633" height="619" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos7.jpg?v=1655836299 633w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos7-300x293.jpg?v=1655836299 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos7-150x147.jpg?v=1655836299 150w" data-lazy-sizes="(max-width: 633px) 100vw, 633px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos7.jpg" /><noscript><img class="aligncenter size-full wp-image-42436" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos7.jpg" alt="" width="633" height="619" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos7.jpg?v=1655836299 633w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos7-300x293.jpg?v=1655836299 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos7-150x147.jpg?v=1655836299 150w" sizes="(max-width: 633px) 100vw, 633px" /></noscript></p><p>Next is to enter your website name and choose Neos.Demo package.</p><p><img class="aligncenter size-full wp-image-42438" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20683%20413'%3E%3C/svg%3E" alt="" width="683" height="413" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos8.jpg?v=1655836336 683w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos8-300x181.jpg?v=1655836336 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos8-150x91.jpg?v=1655836336 150w" data-lazy-sizes="(max-width: 683px) 100vw, 683px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos8.jpg" /><noscript><img class="aligncenter size-full wp-image-42438" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos8.jpg" alt="" width="683" height="413" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos8.jpg?v=1655836336 683w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos8-300x181.jpg?v=1655836336 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos8-150x91.jpg?v=1655836336 150w" sizes="(max-width: 683px) 100vw, 683px" /></noscript></p><p>Once the setup is complete, go to the backend.</p><p><img class="aligncenter size-full wp-image-42439" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20616%20586'%3E%3C/svg%3E" alt="" width="616" height="586" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos9-1.jpg?v=1655836352 616w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos9-1-300x285.jpg?v=1655836352 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos9-1-150x143.jpg?v=1655836352 150w" data-lazy-sizes="(max-width: 616px) 100vw, 616px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos9-1.jpg" /><noscript><img class="aligncenter size-full wp-image-42439" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos9-1.jpg" alt="" width="616" height="586" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos9-1.jpg?v=1655836352 616w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos9-1-300x285.jpg?v=1655836352 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos9-1-150x143.jpg?v=1655836352 150w" sizes="(max-width: 616px) 100vw, 616px" /></noscript></p><p>Enter the Admin credentials you set before and click on the<b> Login</b> button.</p><p><img class="aligncenter size-full wp-image-42440" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20546%20498'%3E%3C/svg%3E" alt="" width="546" height="498" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos10.jpg?v=1655836405 546w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos10-300x274.jpg?v=1655836405 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos10-150x137.jpg?v=1655836405 150w" data-lazy-sizes="(max-width: 546px) 100vw, 546px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos10.jpg" /><noscript><img class="aligncenter size-full wp-image-42440" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos10.jpg" alt="" width="546" height="498" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos10.jpg?v=1655836405 546w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos10-300x274.jpg?v=1655836405 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos10-150x137.jpg?v=1655836405 150w" sizes="(max-width: 546px) 100vw, 546px" /></noscript></p><p>You will be redirected to the following screen.</p><p><img class="aligncenter size-large wp-image-42441" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20470'%3E%3C/svg%3E" alt="" width="1024" height="470" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos11-1024x470.jpg?v=1655836421 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos11-300x138.jpg?v=1655836421 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos11-150x69.jpg?v=1655836421 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos11-768x353.jpg?v=1655836421 768w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos11-1320x606.jpg?v=1655836421 1320w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos11.jpg?v=1655836421 1365w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos11-1024x470.jpg" /><noscript><img class="aligncenter size-large wp-image-42441" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos11-1024x470.jpg" alt="" width="1024" height="470" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos11-1024x470.jpg?v=1655836421 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos11-300x138.jpg?v=1655836421 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos11-150x69.jpg?v=1655836421 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos11-768x353.jpg?v=1655836421 768w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos11-1320x606.jpg?v=1655836421 1320w, https://www.rosehosting.com/blog/wp-content/uploads/2022/06/neos11.jpg?v=1655836421 1365w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></p><p>That&#8217;s it. You successfully installed and configured Neos CMS with LAMP stack on Ubuntu 22.04</p><p>If you find it difficult to install this CMS on your own, you can always contact our technical support. They are available 24/7 and will start work on your request immediately.</p><p>If you liked this post on installing Neos CMS on Ubuntu 22.04 OS, please share it with your friends on the social networks using the buttons on the left or simply leave a reply below. Thanks.</p></div><footer class="entry-meta" aria-label="Entry meta"><span class="cat-links"><span class="gp-icon icon-categories"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path d="M0 112c0-26.51 21.49-48 48-48h110.014a48 48 0 0143.592 27.907l12.349 26.791A16 16 0 00228.486 128H464c26.51 0 48 21.49 48 48v224c0 26.51-21.49 48-48 48H48c-26.51 0-48-21.49-48-48V112z" /></svg></span><span class="screen-reader-text">Categories </span><a href="https://www.rosehosting.com/blog/category/cms-crm-erp/" rel="category tag">CMS, CRM, ERP</a>, <a href="https://www.rosehosting.com/blog/category/tutorials/" rel="category tag">Tutorials</a>, <a href="https://www.rosehosting.com/blog/category/ubuntu/" rel="category tag">Ubuntu</a></span> <nav id="nav-below" class="post-navigation" aria-label="Single Post"><span class="screen-reader-text">Post navigation</span><div class="nav-previous"><span class="gp-icon icon-arrow-left"><svg viewBox="0 0 192 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em" fill-rule="evenodd" clip-rule="evenodd" stroke-linejoin="round" stroke-miterlimit="1.414"><path d="M178.425 138.212c0 2.265-1.133 4.813-2.832 6.512L64.276 256.001l111.317 111.277c1.7 1.7 2.832 4.247 2.832 6.513 0 2.265-1.133 4.813-2.832 6.512L161.43 394.46c-1.7 1.7-4.249 2.832-6.514 2.832-2.266 0-4.816-1.133-6.515-2.832L16.407 262.514c-1.699-1.7-2.832-4.248-2.832-6.513 0-2.265 1.133-4.813 2.832-6.512l131.994-131.947c1.7-1.699 4.249-2.831 6.515-2.831 2.265 0 4.815 1.132 6.514 2.831l14.163 14.157c1.7 1.7 2.832 3.965 2.832 6.513z" fill-rule="nonzero" /></svg></span><span class="prev" title="Previous"><a href="https://www.rosehosting.com/blog/how-to-install-lamp-stack-on-ubuntu-22-04/" rel="prev">How to Install LAMP stack on Ubuntu 22.04</a></span></div></nav></footer></div></article><div class="comments-area"><div id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/how-to-install-neos-cms-on-ubuntu-22-04/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.rosehosting.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea autocomplete="new-password"  id="e42af3c480"  name="e42af3c480"   cols="45" rows="8" required></textarea><textarea id="comment" aria-label="hp-comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0 !important;clip:rect(1px, 1px, 1px, 1px) !important;position:absolute !important;white-space:nowrap !important;height:1px !important;width:1px !important;overflow:hidden !important;" tabindex="-1"></textarea><script type="rocketlazyloadscript" data-noptimize>document.getElementById("comment").setAttribute( "id", "af2cc154a72dcb47377024c3f5fa3608" );document.getElementById("e42af3c480").setAttribute( "id", "comment" );</script></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" required /><label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" required /><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="cptch_block"><span class="cptch_title cptch_to_remove">To prove you are human please solve the following<span class="required"> *</span></span><span class="cptch_wrap cptch_math_actions"><label class="cptch_label" for="cptch_input_80"><span class="cptch_span">se&#118;en</span><span class="cptch_span">&nbsp;&minus;&nbsp;</span><span class="cptch_span"><input id="cptch_input_80" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span><span class="cptch_span">&nbsp;=&nbsp;</span><span class="cptch_span">fo&#117;&#114;</span><input type="hidden" name="cptch_result" value="ZK0=" /><input type="hidden" name="cptch_time" value="1659593943" /><input type="hidden" name="cptch_form" value="wp_comments" /></label><span class="cptch_reload_button_wrap hide-if-no-js"><noscript><style type="text/css">.hide-if-no-js{display:none !important}</style></noscript><span class="cptch_reload_button dashicons dashicons-update"></span></span></span></p><p class="comment-form-mailpoet"> <label for="mailpoet_subscribe_on_comment"> <input type="checkbox" id="mailpoet_subscribe_on_comment" value="1" name="mailpoet[subscribe_on_comment]" />&nbsp;Yes, add me to your new blog post notifications list </label> </p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='42429' id='comment_post_ID' /><input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div></div></div></main></div><div class="widget-area sidebar is-right-sidebar" id="right-sidebar"><div class="inside-right-sidebar"><aside id="categories-3" class="widget inner-padding widget_categories"><h2 class="widget-title">Categories</h2><form action="https://www.rosehosting.com/blog" method="get"><label class="screen-reader-text" for="cat">Categories</label><select name='cat' id='cat' class='postform' ><option value='-1'>Select Category</option><option class="level-0" value="1709">Caching&nbsp;&nbsp;(23)</option><option class="level-0" value="1699">CentOS&nbsp;&nbsp;(305)</option><option class="level-0" value="1710">CMS, CRM, ERP&nbsp;&nbsp;(236)</option><option class="level-0" value="1708">Control Panels&nbsp;&nbsp;(48)</option><option class="level-0" value="1702">Databases&nbsp;&nbsp;(107)</option><option class="level-0" value="1700">Debian&nbsp;&nbsp;(169)</option><option class="level-0" value="1711">E-Commerce&nbsp;&nbsp;(63)</option><option class="level-0" value="1706">Email Servers&nbsp;&nbsp;(37)</option><option class="level-0" value="1236">Guides&nbsp;&nbsp;(67)</option><option class="level-0" value="1705">Load Balancing&nbsp;&nbsp;(5)</option><option class="level-0" value="1">Miscellaneous&nbsp;&nbsp;(55)</option><option class="level-0" value="1701">Networking and Domains&nbsp;&nbsp;(43)</option><option class="level-0" value="3">News&nbsp;&nbsp;(12)</option><option class="level-0" value="1704">Optimization&nbsp;&nbsp;(21)</option><option class="level-0" value="1713">Other&nbsp;&nbsp;(6)</option><option class="level-0" value="4">RoseHosting Platform&nbsp;&nbsp;(48)</option><option class="level-0" value="5">Scripts&nbsp;&nbsp;(11)</option><option class="level-0" value="1703">Security&nbsp;&nbsp;(105)</option><option class="level-0" value="606">SEO&nbsp;&nbsp;(3)</option><option class="level-0" value="21">Tips and Tricks&nbsp;&nbsp;(78)</option><option class="level-0" value="13">Tutorials&nbsp;&nbsp;(869)</option><option class="level-0" value="1698">Ubuntu&nbsp;&nbsp;(422)</option><option class="level-0" value="1712">Web Frameworks&nbsp;&nbsp;(116)</option><option class="level-0" value="1707">Web Servers&nbsp;&nbsp;(142)</option></select></form><script type="rocketlazyloadscript">
(function() {var dropdown = document.getElementById( "cat" );function onCatChange() {if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {dropdown.parentNode.submit();}}dropdown.onchange = onCatChange;})();
</script></aside><aside id="custom_html-8" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a target="_blank" href="https://www.rosehosting.com/linux-vps-hosting/?mtm_campaign=blogs&mtm_source=rh&mtm_medium=blog&mtm_content=button-vps&mtm_group=buttons&mtm_placement=sidebar" style="margin-bottom:6px; color: #fff;
background-color: #ff5700 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 18px;
display: inline-block;
padding: 10px;
margin-top: 5px;
margin-bottom: 5px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener"><strong>Managed VPS - 30% OFF</strong></a><br><a target="_blank" href="https://www.rosehosting.com/dedicated-servers/?mtm_campaign=blogs&mtm_source=rh&mtm_medium=blog&mtm_content=button-dedicated&mtm_group=buttons&mtm_placement=sidebar" style="margin-bottom:6px; color: #fff;
background-color: #ff5700 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 18px;
display: inline-block;
padding: 10px;
margin-top: 5px;
margin-bottom: 5px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener"><strong>Managed Dedicated Servers</strong></a><br><a target="_blank" href="https://www.rosehosting.com/affiliate-program/?mtm_campaign=blogs&mtm_source=rh&mtm_medium=blog&mtm_content=button-affiliate&mtm_group=buttons&mtm_placement=sidebar" style="margin-bottom:6px; color: #fff;
background-color: #ff5700 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 18px;
display: inline-block;
padding: 10px;
margin-top: 5px;
margin-bottom: 5px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener"><strong>Upto $500 Affiliate Programs</strong></a><br><a target="_blank" href="https://www.rosehosting.com/about-us/hosting-customer-reviews/?mtm_campaign=blogs&mtm_source=rh&mtm_medium=blog&mtm_content=button-reviews&mtm_group=buttons&mtm_placement=sidebar" style="margin-bottom:6px; color: #fff;
background-color: #ff5700 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 18px;
display: inline-block;
padding: 10px;
margin-top: 5px;
margin-bottom: 5px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener"><strong>RoseHosting Reviews</strong></a><br></div></aside><aside id="rhbl-widget-12" class="widget inner-padding rhbl-widget"><div class="rhbl-cc2f930c6959b5d828a43bfada91c939 rhbl-sidebar-ad-group" id="rhbl-cc2f930c6959b5d828a43bfada91c939"></div></aside><aside id="search-2" class="widget inner-padding widget_search"><form method="get" class="search-form" action="https://www.rosehosting.com/blog/"><label><span class="screen-reader-text">Search for:</span><input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:"></label><button class="search-submit" aria-label="Search"><span class="gp-icon icon-search"><svg viewBox="0 0 512 512" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="1em" height="1em"><path fill-rule="evenodd" clip-rule="evenodd" d="M208 48c-88.366 0-160 71.634-160 160s71.634 160 160 160 160-71.634 160-160S296.366 48 208 48zM0 208C0 93.125 93.125 0 208 0s208 93.125 208 208c0 48.741-16.765 93.566-44.843 129.024l133.826 134.018c9.366 9.379 9.355 24.575-.025 33.941-9.379 9.366-24.575 9.355-33.941-.025L337.238 370.987C301.747 399.167 256.839 416 208 416 93.125 416 0 322.875 0 208z" /></svg></span></button></form></aside></div></div></div>  <footer class="footer-big-menu"> <div class="container" style="max-width: 1200px;"> <div class="row menu"> <div class="col-6 col-md-3 col-lg-2 mb-3"> <h3 class="menu-title mb-3">About Us</h3> <a class="menu-link mb-3" href="https://www.rosehosting.com/about-us/">Our Company</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/legal/">Our Policies</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/about-us/contact-us/">Contact Us</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/about-us/why-choose-rosehosting/">Why RoseHosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/about-us/compare-rosehosting/">Compare Us</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/about-us/hosting-customer-reviews/">Customer Reviews</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/about-us/awards-and-recognition/">Awards &amp; Recognition</a> <h3 class="menu-title mt-4 mb-3">Content Hub</h3> <a class="menu-link mb-3" href="https://www.rosehosting.com/fastest-web-hosting/">Fastest Web Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/support/managed-hosting/">Fully-Managed Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/business-website/">Business Website Guide</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/nvme-vs-ssd/">NVMe vs. SSD</a> </div> <div class="col-6 col-md-3 col-lg-2 mb-3"> <h3 class="menu-title mb-3">Support</h3> <a class="menu-link mb-3" href="https://www.rosehosting.com/support/managed-hosting/">24/7 Managed Support</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/support/server-migration/">Managed Migration</a> <a class="menu-link mb-3" href="https://status.rosehosting.com/">Systems Status</a> <h3 class="menu-title mb-3 mt-4 mb-3">Other Services</h3> <a class="menu-link mb-3" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Domain Registration</a> <a class="menu-link mb-3" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Domain Transfer</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/ssl-certificate-brands/">SSL Certificates</a> </div> <div class="col-6 col-md-3 col-lg-2 mb-3"> <h3 class="menu-title mb-3">Managed Hosting</h3> <a class="menu-link mb-3" href="https://www.rosehosting.com/linux-vps-hosting/">Linux VPS Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/managed-cloud-hosting/">Cloud Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/dedicated-servers/">Dedicated Servers</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/high-availability-hosting/">High-Availability Hosting</a> <a class="menu-link mb-3" href="https://secure.rosehosting.com/clientarea/?cmd=cart&action=add&id=82">Custom VPS</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/linux-shared-hosting/">Shared Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/hosting-solutions/">Hosting Solutions</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/affiliate-program/vps-affiliate-program/">Recurr. Affiliate Program</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/affiliate-program/cpa-affiliate-program/">CPA Affiliate Program</a> </div> <div class="col-6 col-md-3 col-lg-2 mb-3"> <h3 class="menu-title mb-3">Linux VPS Hosting</h3> <a class="menu-link mb-3" href="https://www.rosehosting.com/almalinux-hosting/">AlmaLinux Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/ubuntu-hosting/">Ubuntu Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/debian-hosting/">Debian Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/managed-docker-cloud-hosting/">Docker Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/managed-kubernetes-cloud-hosting/">Kubernetes Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/whm-hosting/">WHM Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/cpanel-hosting/">cPanel Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/directadmin-hosting/">DirectAdmin Hosting</a> </div> <div class="col-6 col-md-3 col-lg-2 mb-3"> <h3 class="menu-title mb-3">Apps Hosting</h3> <a class="menu-link mb-3" href="https://www.rosehosting.com/wordpress-hosting/">WordPress Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/magento-hosting/">Magento Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/odoo-hosting/">Odoo Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/joomla-hosting/">Joomla Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/drupal-hosting/">Drupal Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/laravel-hosting/">Laravel Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/nextcloud-hosting/">NextCloud Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/prestashop-hosting/">PrestaShop Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/ghost-hosting/">Ghost Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/mediawiki-hosting/">MediaWiki Hosting</a> <a class="menu-link mb-3" href="https://www.rosehosting.com/java-hosting/">Java Hosting</a> </div> <div class="col-6 col-md-3 col-lg-2 mb-3"> <h3 class="menu-title mb-3">Contact Us</h3> <a class="menu-link mb-3" href="tel:+18887673467">(888) ROSE-HOST</a> <a class="menu-link mb-3" href="tel:+18887673467">(888) 767-3467</a> <a class="menu-link mb-3" href="tel:+13142750414">(314) 275-0414</a> <a class="menu-link mb-3" href="mailto:%73%75%70%70%6f%72%74%40%72%6f%73%65%68%6f%73%74%69%6e%67%2e%63%6f%6d">Email us</a> <h3 class="menu-title mb-3 mt-4 mb-3">Connect</h3> <a class="menu-link mb-3" href="https://twitter.com/rosehosting" target="_blank"><i class="fa fa-twitter fa-fw"></i> Twitter</a> <a class="menu-link mb-3" href="https://www.facebook.com/RoseHosting" target="_blank"><i class="fa fa-facebook fa-fw"></i> Facebook</a> <a class="menu-link mb-3" href="https://www.linkedin.com/in/rosehosting/" target="_blank"><i class="fa fa-linkedin fa-fw"></i> LinkedIn</a> </div> </div> </div><br> <div class="bottom"> <div class="container" style="max-width: 1100px;"> <div class="row"> <div class="col-md-12 col-lg-6 mb-3"> <p class="text-sm-left mb-3"><a class="inline-link footer-policy" href="/legal/terms-of-service/">Terms of Service</a> and <a class="inline-link footer-policy" href="/legal/">other policies</a> <br><br>Residents of California: <a class="inline-link footer-policy" href="/legal/cookies-policy/">Do not sell my personal information</a></p> </div> <div class="col-md-12 col-lg-6"> <p class="text-sm-right">&copy; 2001-2022 Rose Web Services LLC.</p> </div> </div> </div> </div><script type="rocketlazyloadscript">window.advanced_ads_check_adblocker=function(t){var n=[],e=null;function i(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}return i((function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),i((function(){var i=window.getComputedStyle&&window.getComputedStyle(t),o=i&&i.getPropertyValue("-moz-binding");e=i&&"none"===i.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var a=0,r=n.length;a<r;a++)n[a](e);n=[]}))})),function(t){null!==e?t(e):n.push(t)}}();</script><script type="rocketlazyloadscript" id="generate-a11y">!function(){"use strict";if("querySelector"in document&&"addEventListener"in window){var e=document.body;e.addEventListener("mousedown",function(){e.classList.add("using-mouse")}),e.addEventListener("keydown",function(){e.classList.remove("using-mouse")})}}();</script><script id='rocket-browser-checker-js-after'>"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();</script><script id='rocket-preload-links-js-extra'>var RocketPreloadLinksConfig = {"excludeUris":"\/blog(\/quiz\/github\/|\/(?:.+\/)?feed(?:\/(?:.+\/?)?)?$|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$))|\/refer\/|\/go\/|\/recommend\/|\/recommends\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php|html|htm","siteUrl":"https:\/\/www.rosehosting.com\/blog","onHoverDelay":"100","rateThrottle":"3"};</script><script id='rocket-preload-links-js-after'>(function() {"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();}());</script><script src='https://www.rosehosting.com/blog/wp-content/plugins/advanced-ads-pro/assets/js/advanced-ads-pro.min.js?ver=2.17.2' id='advanced-ads-pro/front-js' defer></script><script data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/themes/rh2022/js/theme.js?ver=1657917294' id='theme-js' defer></script><!--[if lte IE 11]><script src='https://www.rosehosting.com/blog/wp-content/themes/generatepress/assets/js/classList.min.js?ver=3.1.3' id='generate-classlist-js'></script><![endif]--><script id='generate-menu-js-extra'>var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};</script><script src='https://www.rosehosting.com/blog/wp-content/themes/generatepress/assets/js/menu.min.js?ver=3.1.3' id='generate-menu-js' defer></script><script src='https://www.rosehosting.com/blog/wp-includes/js/comment-reply.min.js?ver=6.0.1' id='comment-reply-js' defer></script><script id='q2w3_fixed_widget-js-extra'>var q2w3_sidebar_options = [{"sidebar":"sidebar-1","use_sticky_position":true,"margin_top":0,"margin_bottom":0,"stop_elements_selectors":".footer-big-menu","screen_max_width":0,"screen_max_height":1000,"widgets":["#custom_html-8","#rhbl-widget-17","#rhbl-widget-19","#rhbl-widget-20","#rhbl-widget-8","#rhbl-widget-21","#rhbl-widget-24","#rhbl-widget-26","#rhbl-widget-18","#rhbl-widget-12","#search-2"]}];</script><script src='https://www.rosehosting.com/blog/wp-content/plugins/q2w3-fixed-widget/js/frontend.min.js?ver=6.1.0' id='q2w3_fixed_widget-js' defer></script><script id='advanced-ads-pro/cache_busting-js-extra'>var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":"","wp_timezone_offset":"-18000"};</script><script src='https://www.rosehosting.com/blog/wp-content/plugins/advanced-ads-pro/assets/js/base.min.js?ver=2.17.2' id='advanced-ads-pro/cache_busting-js' defer></script><script id='cptch_front_end_script-js-extra'>var cptch_vars = {"nonce":"c6937460de","ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","enlarge":"","time_limit":"120"};</script><script data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/captcha-bws/js/front_end_script.js?ver=1657917294' id='cptch_front_end_script-js' defer></script><script type="rocketlazyloadscript">window.advads_admin_bar_items = [{"title":"erpnext placement","type":"placement"},{"title":"erpnext group","type":"group"},{"title":"invoiceninja placement","type":"placement"},{"title":"invoiceninja group","type":"group"},{"title":"magento placement","type":"placement"},{"title":"magento group","type":"group"},{"title":"nextcloud placement","type":"placement"},{"title":"nextcloud group","type":"group"},{"title":"nodejs placement","type":"placement"},{"title":"nodejs group","type":"group"},{"title":"odoo placement","type":"placement"},{"title":"odoo group","type":"group"},{"title":"whm placement","type":"placement"},{"title":"whm group","type":"group"},{"title":"wp placement","type":"placement"},{"title":"WP Group","type":"group"}];</script><script type="rocketlazyloadscript">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</script><script type="rocketlazyloadscript">!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><script>window.lazyLoadOptions=[{elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}},{elements_selector:".rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,}];window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.rosehosting.com/blog/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script></body></html>
<!-- Cached for great performance - Debug: cached@1659593944 -->