<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head><meta charset="UTF-8" /><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
	


	<link rel="pingback" href="https://www.rosehosting.com/blog/xmlrpc.php" />


		<!--[if lt IE 9]>
	<script src="https://www.rosehosting.com/blog/wp-content/themes/generatepress/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->

<!--<script type="rocketlazyloadscript" async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script>-->

<!-- Google Tag Manager -->
<script type="rocketlazyloadscript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KVJ4PJ');</script>
<!-- End Google Tag Manager -->

	<script type="rocketlazyloadscript" data-rocket-type="text/javascript">
		document.documentElement.className = 'js';
	</script>

	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<meta name="viewport" content="width=device-width, initial-scale=1">
	<!-- This site is optimized with the Yoast SEO Premium plugin v17.0 (Yoast SEO v17.6) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>How to Install Discourse on Ubuntu 20.04 | RoseHosting</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2Cregular%2Citalic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CAbril%20FatFace%3A400%2C400i%2C700%2C700i%7CAlegreya%3A400%2C400i%2C700%2C700i%7CAlegreya%20Sans%3A400%2C400i%2C700%2C700i%7CAmatic%20SC%3A400%2C400i%2C700%2C700i%7CAnonymous%20Pro%3A400%2C400i%2C700%2C700i%7CArchitects%20Daughter%3A400%2C400i%2C700%2C700i%7CArchivo%3A400%2C400i%2C700%2C700i%7CArchivo%20Narrow%3A400%2C400i%2C700%2C700i%7CAsap%3A400%2C400i%2C700%2C700i%7CBarlow%3A400%2C400i%2C700%2C700i%7CBioRhyme%3A400%2C400i%2C700%2C700i%7CBonbon%3A400%2C400i%2C700%2C700i%7CCabin%3A400%2C400i%2C700%2C700i%7CCairo%3A400%2C400i%2C700%2C700i%7CCardo%3A400%2C400i%2C700%2C700i%7CChivo%3A400%2C400i%2C700%2C700i%7CConcert%20One%3A400%2C400i%2C700%2C700i%7CCormorant%3A400%2C400i%2C700%2C700i%7CCrimson%20Text%3A400%2C400i%2C700%2C700i%7CEczar%3A400%2C400i%2C700%2C700i%7CExo%202%3A400%2C400i%2C700%2C700i%7CFira%20Sans%3A400%2C400i%2C700%2C700i%7CFjalla%20One%3A400%2C400i%2C700%2C700i%7CFrank%20Ruhl%20Libre%3A400%2C400i%2C700%2C700i%7CGreat%20Vibes%3A400%2C400i%2C700%2C700i%7CHeebo%3A400%2C400i%2C700%2C700i%7CIBM%20Plex%3A400%2C400i%2C700%2C700i%7CInconsolata%3A400%2C400i%2C700%2C700i%7CIndie%20Flower%3A400%2C400i%2C700%2C700i%7CInknut%20Antiqua%3A400%2C400i%2C700%2C700i%7CInter%3A400%2C400i%2C700%2C700i%7CKarla%3A400%2C400i%2C700%2C700i%7CLibre%20Baskerville%3A400%2C400i%2C700%2C700i%7CLibre%20Franklin%3A400%2C400i%2C700%2C700i%7CMontserrat%3A400%2C400i%2C700%2C700i%7CNeuton%3A400%2C400i%2C700%2C700i%7CNotable%3A400%2C400i%2C700%2C700i%7CNothing%20You%20Could%20Do%3A400%2C400i%2C700%2C700i%7CNoto%20Sans%3A400%2C400i%2C700%2C700i%7CNunito%3A400%2C400i%2C700%2C700i%7COld%20Standard%20TT%3A400%2C400i%2C700%2C700i%7COxygen%3A400%2C400i%2C700%2C700i%7CPacifico%3A400%2C400i%2C700%2C700i%7CPoppins%3A400%2C400i%2C700%2C700i%7CProza%20Libre%3A400%2C400i%2C700%2C700i%7CPT%20Sans%3A400%2C400i%2C700%2C700i%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CRakkas%3A400%2C400i%2C700%2C700i%7CReenie%20Beanie%3A400%2C400i%2C700%2C700i%7CRoboto%20Slab%3A400%2C400i%2C700%2C700i%7CRopa%20Sans%3A400%2C400i%2C700%2C700i%7CRubik%3A400%2C400i%2C700%2C700i%7CShadows%20Into%20Light%3A400%2C400i%2C700%2C700i%7CSpace%20Mono%3A400%2C400i%2C700%2C700i%7CSpectral%3A400%2C400i%2C700%2C700i%7CSue%20Ellen%20Francisco%3A400%2C400i%2C700%2C700i%7CTitillium%20Web%3A400%2C400i%2C700%2C700i%7CUbuntu%3A400%2C400i%2C700%2C700i%7CVarela%3A400%2C400i%2C700%2C700i%7CVollkorn%3A400%2C400i%2C700%2C700i%7CWork%20Sans%3A400%2C400i%2C700%2C700i%7CYatra%20One%3A400%2C400i%2C700%2C700i&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2Cregular%2Citalic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CAbril%20FatFace%3A400%2C400i%2C700%2C700i%7CAlegreya%3A400%2C400i%2C700%2C700i%7CAlegreya%20Sans%3A400%2C400i%2C700%2C700i%7CAmatic%20SC%3A400%2C400i%2C700%2C700i%7CAnonymous%20Pro%3A400%2C400i%2C700%2C700i%7CArchitects%20Daughter%3A400%2C400i%2C700%2C700i%7CArchivo%3A400%2C400i%2C700%2C700i%7CArchivo%20Narrow%3A400%2C400i%2C700%2C700i%7CAsap%3A400%2C400i%2C700%2C700i%7CBarlow%3A400%2C400i%2C700%2C700i%7CBioRhyme%3A400%2C400i%2C700%2C700i%7CBonbon%3A400%2C400i%2C700%2C700i%7CCabin%3A400%2C400i%2C700%2C700i%7CCairo%3A400%2C400i%2C700%2C700i%7CCardo%3A400%2C400i%2C700%2C700i%7CChivo%3A400%2C400i%2C700%2C700i%7CConcert%20One%3A400%2C400i%2C700%2C700i%7CCormorant%3A400%2C400i%2C700%2C700i%7CCrimson%20Text%3A400%2C400i%2C700%2C700i%7CEczar%3A400%2C400i%2C700%2C700i%7CExo%202%3A400%2C400i%2C700%2C700i%7CFira%20Sans%3A400%2C400i%2C700%2C700i%7CFjalla%20One%3A400%2C400i%2C700%2C700i%7CFrank%20Ruhl%20Libre%3A400%2C400i%2C700%2C700i%7CGreat%20Vibes%3A400%2C400i%2C700%2C700i%7CHeebo%3A400%2C400i%2C700%2C700i%7CIBM%20Plex%3A400%2C400i%2C700%2C700i%7CInconsolata%3A400%2C400i%2C700%2C700i%7CIndie%20Flower%3A400%2C400i%2C700%2C700i%7CInknut%20Antiqua%3A400%2C400i%2C700%2C700i%7CInter%3A400%2C400i%2C700%2C700i%7CKarla%3A400%2C400i%2C700%2C700i%7CLibre%20Baskerville%3A400%2C400i%2C700%2C700i%7CLibre%20Franklin%3A400%2C400i%2C700%2C700i%7CMontserrat%3A400%2C400i%2C700%2C700i%7CNeuton%3A400%2C400i%2C700%2C700i%7CNotable%3A400%2C400i%2C700%2C700i%7CNothing%20You%20Could%20Do%3A400%2C400i%2C700%2C700i%7CNoto%20Sans%3A400%2C400i%2C700%2C700i%7CNunito%3A400%2C400i%2C700%2C700i%7COld%20Standard%20TT%3A400%2C400i%2C700%2C700i%7COxygen%3A400%2C400i%2C700%2C700i%7CPacifico%3A400%2C400i%2C700%2C700i%7CPoppins%3A400%2C400i%2C700%2C700i%7CProza%20Libre%3A400%2C400i%2C700%2C700i%7CPT%20Sans%3A400%2C400i%2C700%2C700i%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CRakkas%3A400%2C400i%2C700%2C700i%7CReenie%20Beanie%3A400%2C400i%2C700%2C700i%7CRoboto%20Slab%3A400%2C400i%2C700%2C700i%7CRopa%20Sans%3A400%2C400i%2C700%2C700i%7CRubik%3A400%2C400i%2C700%2C700i%7CShadows%20Into%20Light%3A400%2C400i%2C700%2C700i%7CSpace%20Mono%3A400%2C400i%2C700%2C700i%7CSpectral%3A400%2C400i%2C700%2C700i%7CSue%20Ellen%20Francisco%3A400%2C400i%2C700%2C700i%7CTitillium%20Web%3A400%2C400i%2C700%2C700i%7CUbuntu%3A400%2C400i%2C700%2C700i%7CVarela%3A400%2C400i%2C700%2C700i%7CVollkorn%3A400%2C400i%2C700%2C700i%7CWork%20Sans%3A400%2C400i%2C700%2C700i%7CYatra%20One%3A400%2C400i%2C700%2C700i&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2Cregular%2Citalic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CAbril%20FatFace%3A400%2C400i%2C700%2C700i%7CAlegreya%3A400%2C400i%2C700%2C700i%7CAlegreya%20Sans%3A400%2C400i%2C700%2C700i%7CAmatic%20SC%3A400%2C400i%2C700%2C700i%7CAnonymous%20Pro%3A400%2C400i%2C700%2C700i%7CArchitects%20Daughter%3A400%2C400i%2C700%2C700i%7CArchivo%3A400%2C400i%2C700%2C700i%7CArchivo%20Narrow%3A400%2C400i%2C700%2C700i%7CAsap%3A400%2C400i%2C700%2C700i%7CBarlow%3A400%2C400i%2C700%2C700i%7CBioRhyme%3A400%2C400i%2C700%2C700i%7CBonbon%3A400%2C400i%2C700%2C700i%7CCabin%3A400%2C400i%2C700%2C700i%7CCairo%3A400%2C400i%2C700%2C700i%7CCardo%3A400%2C400i%2C700%2C700i%7CChivo%3A400%2C400i%2C700%2C700i%7CConcert%20One%3A400%2C400i%2C700%2C700i%7CCormorant%3A400%2C400i%2C700%2C700i%7CCrimson%20Text%3A400%2C400i%2C700%2C700i%7CEczar%3A400%2C400i%2C700%2C700i%7CExo%202%3A400%2C400i%2C700%2C700i%7CFira%20Sans%3A400%2C400i%2C700%2C700i%7CFjalla%20One%3A400%2C400i%2C700%2C700i%7CFrank%20Ruhl%20Libre%3A400%2C400i%2C700%2C700i%7CGreat%20Vibes%3A400%2C400i%2C700%2C700i%7CHeebo%3A400%2C400i%2C700%2C700i%7CIBM%20Plex%3A400%2C400i%2C700%2C700i%7CInconsolata%3A400%2C400i%2C700%2C700i%7CIndie%20Flower%3A400%2C400i%2C700%2C700i%7CInknut%20Antiqua%3A400%2C400i%2C700%2C700i%7CInter%3A400%2C400i%2C700%2C700i%7CKarla%3A400%2C400i%2C700%2C700i%7CLibre%20Baskerville%3A400%2C400i%2C700%2C700i%7CLibre%20Franklin%3A400%2C400i%2C700%2C700i%7CMontserrat%3A400%2C400i%2C700%2C700i%7CNeuton%3A400%2C400i%2C700%2C700i%7CNotable%3A400%2C400i%2C700%2C700i%7CNothing%20You%20Could%20Do%3A400%2C400i%2C700%2C700i%7CNoto%20Sans%3A400%2C400i%2C700%2C700i%7CNunito%3A400%2C400i%2C700%2C700i%7COld%20Standard%20TT%3A400%2C400i%2C700%2C700i%7COxygen%3A400%2C400i%2C700%2C700i%7CPacifico%3A400%2C400i%2C700%2C700i%7CPoppins%3A400%2C400i%2C700%2C700i%7CProza%20Libre%3A400%2C400i%2C700%2C700i%7CPT%20Sans%3A400%2C400i%2C700%2C700i%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CRakkas%3A400%2C400i%2C700%2C700i%7CReenie%20Beanie%3A400%2C400i%2C700%2C700i%7CRoboto%20Slab%3A400%2C400i%2C700%2C700i%7CRopa%20Sans%3A400%2C400i%2C700%2C700i%7CRubik%3A400%2C400i%2C700%2C700i%7CShadows%20Into%20Light%3A400%2C400i%2C700%2C700i%7CSpace%20Mono%3A400%2C400i%2C700%2C700i%7CSpectral%3A400%2C400i%2C700%2C700i%7CSue%20Ellen%20Francisco%3A400%2C400i%2C700%2C700i%7CTitillium%20Web%3A400%2C400i%2C700%2C700i%7CUbuntu%3A400%2C400i%2C700%2C700i%7CVarela%3A400%2C400i%2C700%2C700i%7CVollkorn%3A400%2C400i%2C700%2C700i%7CWork%20Sans%3A400%2C400i%2C700%2C700i%7CYatra%20One%3A400%2C400i%2C700%2C700i&#038;display=swap" /></noscript><link rel="stylesheet" href="https://www.rosehosting.com/blog/wp-content/cache/min/1/f241736c23a725a03a65f02fbb0cc7e8.css" media="all" data-minify="1" />
	<meta name="description" content="Are you looking to install Discourse on Ubuntu 20.04? We have it all explained step-by-step in this tutorial." />
	<link rel="canonical" href="https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="How to Install Discourse on Ubuntu 20.04 | RoseHosting" />
	<meta property="og:description" content="Are you looking to install Discourse on Ubuntu 20.04? We have it all explained step-by-step in this tutorial." />
	<meta property="og:url" content="https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/" />
	<meta property="og:site_name" content="RoseHosting" />
	<meta property="article:publisher" content="https://www.facebook.com/RoseHosting" />
	<meta property="article:author" content="https://www.facebook.com/rosehosting.helpdesk" />
	<meta property="article:published_time" content="2021-11-22T18:30:00+00:00" />
	<meta property="article:modified_time" content="2021-10-29T09:05:51+00:00" />
	<meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04.jpg?v=1635497255" />
	<meta property="og:image:width" content="742" />
	<meta property="og:image:height" content="372" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:title" content="How to Install Discourse on Ubuntu 20.04 | RoseHosting" />
	<meta name="twitter:description" content="Are you looking to install Discourse on Ubuntu 20.04? We have it all explained step-by-step in this tutorial." />
	<meta name="twitter:creator" content="@rosehosting" />
	<meta name="twitter:site" content="@rosehosting" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Jeff Wilson" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="5 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.rosehosting.com/blog/#organization","name":"RoseHosting","url":"https://www.rosehosting.com/blog/","sameAs":["https://www.facebook.com/RoseHosting","https://www.linkedin.com/in/rosehosting/","https://twitter.com/rosehosting"],"logo":{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/#logo","inLanguage":"en-US","url":"https://www.rosehosting.com/blog/wp-content/uploads/2016/02/rhlogo-final-500x500.png","contentUrl":"https://www.rosehosting.com/blog/wp-content/uploads/2016/02/rhlogo-final-500x500.png","width":500,"height":500,"caption":"RoseHosting"},"image":{"@id":"https://www.rosehosting.com/blog/#logo"}},{"@type":"WebSite","@id":"https://www.rosehosting.com/blog/#website","url":"https://www.rosehosting.com/blog/","name":"RoseHosting","description":"Premium Linux Tutorials Since 2001","publisher":{"@id":"https://www.rosehosting.com/blog/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.rosehosting.com/blog/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/#primaryimage","inLanguage":"en-US","url":"https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04.jpg?v=1635497255","contentUrl":"https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04.jpg?v=1635497255","width":742,"height":372,"caption":"how to install discourse on ubuntu 20.04"},{"@type":"WebPage","@id":"https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/#webpage","url":"https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/","name":"How to Install Discourse on Ubuntu 20.04 | RoseHosting","isPartOf":{"@id":"https://www.rosehosting.com/blog/#website"},"primaryImageOfPage":{"@id":"https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/#primaryimage"},"datePublished":"2021-11-22T18:30:00+00:00","dateModified":"2021-10-29T09:05:51+00:00","description":"Are you looking to install Discourse on Ubuntu 20.04? We have it all explained step-by-step in this tutorial.","breadcrumb":{"@id":"https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/"]}]},{"@type":"BreadcrumbList","@id":"https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.rosehosting.com/blog/"},{"@type":"ListItem","position":2,"name":"How To Install Discourse on Ubuntu 20.04"}]},{"@type":"Article","@id":"https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/#article","isPartOf":{"@id":"https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/#webpage"},"author":{"@id":"https://www.rosehosting.com/blog/#/schema/person/7ce77a842fa6a9a7f8efa186f2353713"},"headline":"How To Install Discourse on Ubuntu 20.04","datePublished":"2021-11-22T18:30:00+00:00","dateModified":"2021-10-29T09:05:51+00:00","mainEntityOfPage":{"@id":"https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/#webpage"},"wordCount":587,"commentCount":0,"publisher":{"@id":"https://www.rosehosting.com/blog/#organization"},"image":{"@id":"https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/#primaryimage"},"thumbnailUrl":"https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04.jpg?v=1635497255","keywords":["Discourse","how to install","Ubuntu 20.04"],"articleSection":["Tutorials","Ubuntu"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/#respond"]}]},{"@type":"Person","@id":"https://www.rosehosting.com/blog/#/schema/person/7ce77a842fa6a9a7f8efa186f2353713","name":"Jeff Wilson","image":{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/09271207587f897ab46faaed9b355252?s=96&r=g","contentUrl":"https://secure.gravatar.com/avatar/09271207587f897ab46faaed9b355252?s=96&r=g","caption":"Jeff Wilson"},"description":"An experienced Linux veteran with many years of experience. Helping other Linux admins with frequent Linux and business-related blog posts on the RoseHosting blog. Techie by choice. Loving nature and travel. Happily married and father of two lovely children.","sameAs":["https://www.rosehosting.com","https://www.facebook.com/rosehosting.helpdesk"]}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Feed" href="https://www.rosehosting.com/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Comments Feed" href="https://www.rosehosting.com/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; How To Install Discourse on Ubuntu 20.04 Comments Feed" href="https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/feed/" />
<!-- rosehosting.com/blog is managing ads with Advanced Ads --><!--noptimize--><script id="rhad-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
		<!--/noptimize--><style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	








<style id='ez-toc-inline-css'>
div#ez-toc-container p.ez-toc-title {font-size: 22px;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}div#ez-toc-container {width: 95%;}
</style>






<style id='generate-style-inline-css'>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</style>









<link rel='preload' as='font'  id='wpzoom-social-icons-font-academicons-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.ttf?v=1.8.6' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-academicons-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.woff?v=1.8.6' type='font/woff' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-fontawesome-3-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.ttf?v=4.7.0' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-fontawesome-3-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff?v=4.7.0' type='font/woff' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-fontawesome-3-woff2-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff2?v=4.7.0' type='font/woff2' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-genericons-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-genericons-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type='font/woff' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-socicon-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.ttf?v=4.2.2' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-socicon-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.woff?v=4.2.2' type='font/woff' crossorigin />
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js' defer></script>
<script id='topbar_frontjs-js-extra'>
var tpbr_settings = {"fixed":"fixed","user_who":"notloggedin","guests_or_users":"all","message":"20th Anniversary Sale!!! 20% OFF on all hosting services. Use coupon RH20YEARS     *new customers only, while supplies last","status":"inactive","yn_button":"button","color":"#ba004a","button_text":"GET THE DEAL","button_url":"https:\/\/www.rosehosting.com\/20th-anniversary-sale.html","button_behavior":"newwindow","is_admin_bar":"no","detect_sticky":"0"};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/top-bar/inc/../js/tpbr_front.min.js' id='topbar_frontjs-js' defer></script>
<script id='advanced-ads-advanced-js-js-extra'>
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js' id='advanced-ads-advanced-js-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/ajax/libs/popper.js/1.11.0/umd/popper.min.js?ver=1635278974' id='popper-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/themes/rh2020/js/bootstrap.js?ver=1635278974' id='bootstrap-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/themes/rh2020/js/cookieconsent.min.js' id='cookieconsent-js' defer></script>
<link rel="https://api.w.org/" href="https://www.rosehosting.com/blog/wp-json/" /><link rel="alternate" type="application/json" href="https://www.rosehosting.com/blog/wp-json/wp/v2/posts/39599" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rosehosting.com/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rosehosting.com/blog/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.2" />
<link rel='shortlink' href='https://www.rosehosting.com/blog/?p=39599' />
<link rel="alternate" type="application/json+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-install-discourse-on-ubuntu-20-04%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-install-discourse-on-ubuntu-20-04%2F&#038;format=xml" />
<script type="rocketlazyloadscript">advads_items = { conditions: {}, display_callbacks: {}, display_effect_callbacks: {}, hide_callbacks: {}, backgrounds: {}, effect_durations: {}, close_functions: {}, showed: [] };</script><style type="text/css" id="rhad-layer-custom-css"></style><script type="rocketlazyloadscript" data-rocket-type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
		<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-270x270.png" />
		<style id="wp-custom-css">
			/* Change background color and font of pre-formatted text */
.entry-content pre {
font-family: monospace;
color: #3a3a3a;
border: none;
overflow-wrap: break-word;
}
.inside-article,
.sidebar .widget {
    border: 1px solid #e3e3e3;
}
.page-container {
    max-width: 1100px;
		align-items: center;
		justify-content: space-between;
		margin-left: auto;
		margin-right: auto;
}
.footer-big-menu {
		max-width: 1100px;
		margin-left: auto;
		margin-right: auto;
}
.col6, .col-md-3, .col-lg-2 {
		padding-left: 10px;
		padding-right: 10px;
}
.masonry-load-more {
		padding-left: 20px;
}
@media (max-width:576px) {
	.nav-item {
  	margin-top: 10px;
	}
	.menu-link, .menu-title {
  	margin-top: 10px;
	}
	.comment-content {
		overflow-wrap: break-word;
	}
}		</style>
		<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script type="rocketlazyloadscript" data-rocket-type="text/javascript">
  var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(["setCookieDomain", "*.rosehosting.com"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.rosehosting.com/";
    _paq.push(['setTrackerUrl', u+'rosea.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.src='https://www.rosehosting.com/dist/rosea.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
</head>
<body class="post-template-default single single-post postid-39599 single-format-standard wp-embed-responsive post-image-above-header post-image-aligned-center sticky-menu-fade right-sidebar nav-below-header separate-containers contained-header active-footer-widgets-1 nav-aligned-left header-aligned-left dropdown-hover featured-image-active aa-prefix-rhad-">



<nav class="navbar yamm navbar-expand-lg navbar-dark" role="navigation">
  <div class="container no-override navbar-dark">

    <a class="navbar-brand" href="https://www.rosehosting.com/">
      <img alt="RoseHosting.com" width="186" height="37"  class="d-lg-inline mr-2" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20186%2037'%3E%3C/svg%3E" data-lazy-src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/rh-logo.svg" /><noscript><img alt="RoseHosting.com" width="186" height="37"  class="d-lg-inline mr-2" src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/rh-logo.svg" /></noscript>
    </a>

    <button class="navbar-toggler" data-toggle="collapse" data-target="#navbar-collapse">
      <span class="navbar-toggler-icon"></span>
    </button>

    <div class="collapse navbar-collapse justify-content-end" id="navbar-collapse">
      <ul class="navbar-nav">

        <li class="nav-item active dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Hosting Solutions
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">

            <div class="yamm-content">
              <div class="row">
                <div class="col-sm-6">
                   <span class="text-primary  dropdown-header"><strong>Managed SSD Hosting</strong></span>
                   <div class="dropdown-divider"></div>
                   <a class="dropdown-item" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/linux-vps-hosting/">Linux VPS Hosting</a>
                   <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom VPS</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/managed-cloud-hosting.html">Cloud Hosting</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/dedicated-servers.html">Dedicated Servers</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting <span class="ml-2 badge badge-success">new</span></a>
                </div>
                <div class="col-sm-6">
                  <span class="text-primary dropdown-header"><strong>Managed Solutions</strong></span>
                  <div class="dropdown-divider"></div>
                  <a class="dropdown-item" href="https://www.rosehosting.com/wordpress-hosting.html">
                    Wordpress Hosting
                    <small class="d-block text-muted"><i>The best blogging platform</i></small>
                  </a>
                  <a class="dropdown-item" href="https://www.rosehosting.com/magento-hosting.html">
                    Magento Hosting
                    <small class="d-block text-muted"><i>The best e-commerce platform</i></small>
                  </a>
                  <a class="dropdown-item" href="https://www.rosehosting.com/odoo-hosting.html">
                    Odoo Hosting
                    <small class="d-block text-muted"><i>The best CRM/ERP platform</i></small>
                  </a>
                  <span class="dropdown-item"><a class="btn-shadow btn-shadow-primary btn-shadow-sm" target="_blank" href="https://www.rosehosting.com/hosting-solutions.html">Other Solutions</a></span>

                </div>
              </div>
            </div>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            SSL / Domains
            <i class="fa fa-chevron-down"></i>
          </a>

          <div class="dropdown-menu" role="menu">

            <div class="yamm-content">
              <div class="row">
                <div class="col-sm-3">
                    <span class="text-primary  dropdown-header"><strong>SSL by brand</strong></span>
                    <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#geotrust">GeoTrust</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#comodo">Comodo</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#rapidssl">RapidSSL</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#thawte">Thawte</a>
                </div>
                <div class="col-sm-4">

                    <span class="text-primary  dropdown-header"><strong>SSL by Type</strong></span>
                    <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#domain_validation">Domain Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#organization_validation">Organization Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#extended_validation">Extended Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#wildcard_ssl">Wildcard SSL</a>
                </div>
                <div class="col-sm-3">
                  <span class="text-primary dropdown-header"><strong>Domains</strong></span>
                  <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Register Domains</a>
                    <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Transfer Domains</a>
                </div>
              </div>
            </div>
          </div>


        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Support
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
              <a class="dropdown-item" href="https://www.rosehosting.com/support.html">24/7 Managed Support</a>
              <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Open a Support Ticket</a>
              <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>
	      <a class="dropdown-item" rel=”nofollow” href="https://status.rosehosting.net">Systems Status</a>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            About Us
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
            <a class="dropdown-item" href="https://www.rosehosting.com/about-us.html">Our Company</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/policies.html">Our Policies</a>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Affiliates
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
            <a class="dropdown-item" href="https://www.rosehosting.com/cpa-hosting-affiliate-program.html">Flat-Rate CPA Affiliate Plan</a>
            <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Flat-Rate CPA Affiliate Login</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/vps-affiliate-program.html">Recurring Affiliate Plan</a>
            <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/aff/">Recurring Affiliate Login</a>
          </div>
        </li>

        <li class="nav-item">
          <a class="nav-link" href="https://www.rosehosting.com/blog/">Blog</a>
        </li>

        <li class="nav-item">
          <a class="nav-link nav-link--rounded" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Login</a>
        </li>

      </ul>
    </div>

  </div>
</nav>


<!--
<nav class="navbar navbar-expand-lg navbar-light bg-faded navbar-blog">
   <div class="container no-override">
    <a href="https://www.rosehosting.com/blog/" class="navbar-brand">Blog Home</a>
    <div class="navbar-collapse collapse d-flex justify-content-between" id="navbar5-blog">
        <ul class="navbar-nav categories">
            <li class="nav-item dropdown">
              <a class="nav-link dropdown-toggle" data-toggle="dropdown" href="#" role="button" aria-haspopup="true" aria-expanded="false">
                Categories
                <i class="fa fa-chevron-down"></i>
              </a>
              <div class="dropdown-menu" style="z-index:0;">
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/caching/">Caching</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/centos/">CentOS</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/cms-crm-erp/">CMS, CRM, ERP</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/control-panels/">Control Panels</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/databases/">Databases</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/debian/">Debian</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/e-commerce/">E-Commerce</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/email-servers/">Email Servers</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/guides/">Guides</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/load-balancing/">Load Balancing</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/miscellaneous/">Miscellaneous</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/networking-and-domains/">Networking and Domains</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/news/">News</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/optimization/">Optimization</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/other/">Other</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/rosehosting/">RoseHosting Platform</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/scripts/">Scripts</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/security/">Security</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/seo/">SEO</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tips-and-tricks/">Tips and Tricks</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tutorials/">Tutorials</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/ubuntu/">Ubuntu</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-frameworks/">Web Frameworks</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-servers/">Web Servers</a>
                              </div>
            </li>
        </ul>
        <form class="mx-2 my-auto d-inline" method="get" id="searchform" action="https://www.rosehosting.com/blog/">
            <div class="input-group">
                <input type="search" class="field" name="s" id="s" class="form-control border border-right-0" placeholder="Search...">
                <span class="input-group-append">
                <button name="submit" id="searchsubmit" class="btn btn-outline-secondary border border-left-0" type="submit">
                    <i class="fa fa-search"></i>
                </button>
              </span>
            </div>
        </form>
    </div>
  </div>
</nav> -->

	<div id="page-container" class="page-container">

	<div class="content-area grid-parent mobile-grid-100 grid-70 tablet-grid-70" id="primary">
		<main class="site-main" id="main">
			
<article id="post-39599" class="post-39599 post type-post status-publish format-standard has-post-thumbnail hentry category-tutorials category-ubuntu tag-discourse tag-how-to-install tag-ubuntu-20-04" itemtype="https://schema.org/CreativeWork" itemscope>
	<div class="inside-article">
					<header class="entry-header" aria-label="Content">
				<h1 class="entry-title" itemprop="headline">How To Install Discourse on Ubuntu 20.04</h1>		<div class="entry-meta">
			<span class="posted-on"><time class="entry-date published" datetime="2021-11-22T12:30:00-06:00" itemprop="datePublished">November 22, 2021</time></span> <span class="byline">by <span class="author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope><a class="url fn n" href="https://www.rosehosting.com/blog/author/jwilson/" title="View all posts by Jeff Wilson" rel="author" itemprop="url"><span class="author-name" itemprop="name">Jeff Wilson</span></a></span></span> 		</div>
					</header>
			
		<div class="entry-content" itemprop="text">
			<div  class="rhad-b757c1f118f702f322aa9ff657d560b1 rhad-before-content" id="rhad-b757c1f118f702f322aa9ff657d560b1"></div>
<figure class="wp-block-image size-full"><img width="742" height="372" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20742%20372'%3E%3C/svg%3E" alt="how to install discourse on ubuntu 20.04" class="wp-image-39626" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04.jpg?v=1635497255 742w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04-300x150.jpg?v=1635497255 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04-150x75.jpg?v=1635497255 150w" data-lazy-sizes="(max-width: 742px) 100vw, 742px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04.jpg" /><noscript><img width="742" height="372" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04.jpg" alt="how to install discourse on ubuntu 20.04" class="wp-image-39626" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04.jpg?v=1635497255 742w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04-300x150.jpg?v=1635497255 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04-150x75.jpg?v=1635497255 150w" sizes="(max-width: 742px) 100vw, 742px" /></noscript></figure>



<p>In this tutorial we are going to explain step-by-step instructions on How to install Discourse on Ubuntu 20.04 Also, we will provide you with some useful information about its usage.</p>



<p>Discourse is an open-source platform used for discussions forum, chat rooms, or as a mailing list management software. It is written in <b>Ruby on Rails</b> as a backend language, <b>Ember.js</b> as a frontend, and uses <b>PostgreSQL</b> for data storage. It offers many features such as 2FA (Two-factor authentication), Spam blocking, Comprehensive API, Social Login and etc. Installing Discourse can be done manually with a couple of steps or in an isolated environment with Docker.</p>



<div class="wp-block-image"><figure class="alignright size-large is-resized"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20206%20170'%3E%3C/svg%3E" alt="setting up discourse on ubuntu 20.04" class="wp-image-39631" width="206" height="170" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/setting-up-discourse-on-ubuntu-20.04-1024x851.png?v=1635498158 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/setting-up-discourse-on-ubuntu-20.04-300x249.png?v=1635498158 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/setting-up-discourse-on-ubuntu-20.04-150x125.png?v=1635498158 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/setting-up-discourse-on-ubuntu-20.04-768x639.png?v=1635498158 768w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/setting-up-discourse-on-ubuntu-20.04-1320x1098.png?v=1635498158 1320w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/setting-up-discourse-on-ubuntu-20.04.png?v=1635498158 1323w" data-lazy-sizes="(max-width: 206px) 100vw, 206px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/setting-up-discourse-on-ubuntu-20.04-1024x851.png?v=1635498158" /><noscript><img src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/setting-up-discourse-on-ubuntu-20.04-1024x851.png?v=1635498158" alt="setting up discourse on ubuntu 20.04" class="wp-image-39631" width="206" height="170" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/setting-up-discourse-on-ubuntu-20.04-1024x851.png?v=1635498158 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/setting-up-discourse-on-ubuntu-20.04-300x249.png?v=1635498158 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/setting-up-discourse-on-ubuntu-20.04-150x125.png?v=1635498158 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/setting-up-discourse-on-ubuntu-20.04-768x639.png?v=1635498158 768w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/setting-up-discourse-on-ubuntu-20.04-1320x1098.png?v=1635498158 1320w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/setting-up-discourse-on-ubuntu-20.04.png?v=1635498158 1323w" sizes="(max-width: 206px) 100vw, 206px" /></noscript></figure></div>



<p>In this blog post, we will use docker as an easier and faster solution and the estimated time for the installation should be a few minutes, depending on your network speed. Let&#8217;s get started!</p>



<span id="more-39599"></span>



<div id="ez-toc-container" class="ez-toc-v2_0_17 counter-hierarchy ez-toc-transparent">
<div class="ez-toc-title-container">
<p class="ez-toc-title">Table of Contents</p>
<span class="ez-toc-title-toggle"><a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle" style="display: none;"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a></span></div>
<nav><ul class="ez-toc-list ez-toc-list-level-1"><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-1" href="#Prerequisites" title="Prerequisites">Prerequisites</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-2" href="#Step-1-Update-the-System" title="Step 1. Update the System">Step 1. Update the System</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-3" href="#Step-2-Install-Docker-Container" title="Step 2. Install Docker Container">Step 2. Install Docker Container</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-4" href="#Step-3-Download-and-Install-Discourse" title="Step 3. Download and Install Discourse">Step 3. Download and Install Discourse</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-5" href="#Step-4-Access-The-Web-Interface" title="Step 4. Access The Web Interface">Step 4. Access The Web Interface</a></li></ul></nav></div>
<h2 id="h-prerequisites"><span class="ez-toc-section" id="Prerequisites"></span>Prerequisites<span class="ez-toc-section-end"></span></h2>



<p>Before we start with the installation there are a few requirements that need to be fulfilled:</p>



<ul><li>A VPS with at least 2GB of RAM (Our SSD 2 VPS plan)</li><li>Fresh install of Ubuntu 20.04</li><li>User privileges: root or non-root user with sudo privileges</li><li>Pointed A record of domain or subdomain to your server IP address</li><li>SMTP mail server. May use some external mail services like Mailgun, Sendgrid, Gmail, Hotmail and etc, if you do not have one</li></ul>



<h2 id="h-step-1-update-the-system"><span class="ez-toc-section" id="Step-1-Update-the-System"></span>Step 1. Update the System<span class="ez-toc-section-end"></span></h2>



<p>Fresh installation of Ubuntu 20.04 requires the latest software updates. Execute the following command to update the system to its latest version:</p>



<pre class="wp-block-preformatted">sudo apt update -y &amp;&amp; sudo apt upgrade -y</pre>



<h2 id="h-step-2-install-docker-container"><span class="ez-toc-section" id="Step-2-Install-Docker-Container"></span>Step 2. Install Docker Container<span class="ez-toc-section-end"></span></h2>



<p>As we mentioned before we will install Discourse in an isolated docker environment. Docker by default is available in Ubuntu 20.04 and we just need to execute the following commands to install it:</p>



<pre class="wp-block-preformatted">sudo apt-get install docker.io -y</pre>



<p>Once, the installation is complete start the docker service:</p>



<pre class="wp-block-preformatted">sudo systemctl start docker</pre>



<p>After starting the service, you need to enable it with the following command:</p>



<pre class="wp-block-preformatted">sudo systemctl enable docker</pre>



<p>To check that the service is up and running, in the terminal execute the command below:</p>



<pre class="wp-block-preformatted">sudo systemctl status docker</pre>



<p>You should see the following output:</p>



<pre class="wp-block-preformatted">root@vps:~# systemctl status docker
● docker.service - Docker Application Container Engine
     Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
     Active: active (running) since Thu 2021-10-28 17:52:17 UTC; 1h 14min ago
TriggeredBy: ● docker.socket
       Docs: https://docs.docker.com
   Main PID: 63601 (dockerd)
      Tasks: 32
     Memory: 1.8G
     CGroup: /system.slice/docker.service
             ├─ 63601 /usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock
             ├─274057 /usr/bin/docker-proxy -proto tcp -host-ip 0.0.0.0 -host-port 443 -container-ip 172.17.0.2 -container-port 443
             └─274071 /usr/bin/docker-proxy -proto tcp -host-ip 0.0.0.0 -host-port 80 -container-ip 172.17.0.2 -container-port 80

Oct 28 19:03:56 vps.example.com dockerd[63601]: time="2021-10-28T19:03:56.213105991Z" level=info msg="ignoring event" container=1baae1c7e1acfab1fd0bc326a021964b0b02257932a70e5a6100e7ff520e318c&gt;
Oct 28 19:03:58 vps.example.com dockerd[265458]: time="2021-10-28T19:03:58Z" level=warning msg="file does not exist: /proc/sys/net/ipv6/conf/all/disable_ipv6 : stat /proc/sys/net/ipv6/conf/all&gt;
Oct 28 19:04:31 vps.example.com dockerd[63601]: time="2021-10-28T19:04:31.892373712Z" level=info msg="ignoring event" container=1baae1c7e1acfab1fd0bc326a021964b0b02257932a70e5a6100e7ff520e318c&gt;</pre>



<h2 id="h-step-3-download-and-install-discourse"><span class="ez-toc-section" id="Step-3-Download-and-Install-Discourse"></span>Step 3. Download and Install Discourse<span class="ez-toc-section-end"></span></h2>



<p>Before we download the installation file for Discourse we will make a separate director for it:</p>



<pre class="wp-block-preformatted">sudo mkdir /var/www/discourse/</pre>



<p>Clone the discourse with the command bellow:</p>



<pre class="wp-block-preformatted"> sudo git clone https://github.com/discourse/discourse_docker.git /var/www/discourse/</pre>



<p>Go into the newly created directory and execute the command for installing Discourse</p>



<pre class="wp-block-preformatted"> cd /var/www/discourse/ 

 ./discourse-setup 

</pre>



<p>After executing the command for discourse setup, there will be a couple of inputs that need to be entered such as <b>hostname</b>, email address for <b>admin</b> account, <b>SMTP server</b>, SMTP <b>username</b>, SMTP <b>password</b> and email address for <b>Let&#8217;s Encrypt</b> as shown below:</p>



<pre class="wp-block-preformatted">Checking your domain name . . .
Connection to discourse.<b>yourdomain.com</b> succeeded.
Email address for admin account(s)? [me@example.com,you@example.com]: discourse@<b>yourdomain.com</b>
SMTP server address? [smtp.example.com]: smtp.<b>yourdomain.com</b>
SMTP port? [587]: 
SMTP user name? [user@example.com]: discourse@<b>yourdomain.com</b>
SMTP password? [pa$word]: yourstrongpassword
Optional email address for Let's Encrypt warnings? (ENTER to skip) [me@example.com]: ssl-discourse@<b>yourdomain.com</b>
</pre>



<p>Once you enter these values, there will be another window to check them again.</p>



<pre class="wp-block-preformatted">Does this look right?

Hostname      : discourse.<b>yourdomain.com</b>
Email         : discourse@<b>yourdomain.com</b>
SMTP address  : smtp.<b>yourdomain.com</b>
SMTP port     : 587
SMTP username : discourse@<b>yourdomain.com</b>
SMTP password : <b>yourstrongpassword</b>
Let's Encrypt : ssl-discourse@<b>yourdomain.com</b>

ENTER to continue, 'n' to try again, Ctrl+C to exit:</pre>



<p>Hit &#8220;<b>Enter</b>&#8221; to approve them and allow some time for the installation to complete.</p>



<p>Once the installation is completed you can check that the docker container is running properly:</p>



<pre class="wp-block-preformatted"> root@vps:~# docker ps</pre>



<p>You should see the following output:</p>



<pre class="wp-block-preformatted">#root@vps:~# docker ps
CONTAINER ID   IMAGE                 COMMAND        CREATED          STATUS          PORTS                                      NAMES
1baae1c7e1ac   local_discourse/app   "/sbin/boot"   47 minutes ago   Up 16 seconds   0.0.0.0:80-&gt;80/tcp, 0.0.0.0:443-&gt;443/tcp   app
</pre>



<h2 id="h-step-4-access-the-web-interface"><span class="ez-toc-section" id="Step-4-Access-The-Web-Interface"></span>Step 4. Access The Web Interface<span class="ez-toc-section-end"></span></h2>



<p>Access the discourse in the browser: <b>https://discourse.yourdomain.com</b></p>



<figure class="wp-block-image size-full"><img width="880" height="665" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20880%20665'%3E%3C/svg%3E" alt="installing discourse on ubuntu 20.04" class="wp-image-39627" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installing-discourse-on-ubuntu-20.04.png?v=1635497572 880w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installing-discourse-on-ubuntu-20.04-300x227.png?v=1635497572 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installing-discourse-on-ubuntu-20.04-150x113.png?v=1635497572 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installing-discourse-on-ubuntu-20.04-768x580.png?v=1635497572 768w" data-lazy-sizes="(max-width: 880px) 100vw, 880px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installing-discourse-on-ubuntu-20.04.png" /><noscript><img width="880" height="665" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installing-discourse-on-ubuntu-20.04.png" alt="installing discourse on ubuntu 20.04" class="wp-image-39627" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installing-discourse-on-ubuntu-20.04.png?v=1635497572 880w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installing-discourse-on-ubuntu-20.04-300x227.png?v=1635497572 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installing-discourse-on-ubuntu-20.04-150x113.png?v=1635497572 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installing-discourse-on-ubuntu-20.04-768x580.png?v=1635497572 768w" sizes="(max-width: 880px) 100vw, 880px" /></noscript></figure>



<p>Now, you need to click on the &#8220;<b>Register</b>&#8221; button and another form will open for <b>Email</b>, <b>Username</b> and <b>Password</b>.</p>



<figure class="wp-block-image size-full"><img width="820" height="583" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20820%20583'%3E%3C/svg%3E" alt="installation of discourse on ubuntu 20.04" class="wp-image-39628" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installation-of-discourse-on-ubuntu-20.04.png?v=1635497659 820w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installation-of-discourse-on-ubuntu-20.04-300x213.png?v=1635497659 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installation-of-discourse-on-ubuntu-20.04-150x107.png?v=1635497659 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installation-of-discourse-on-ubuntu-20.04-768x546.png?v=1635497659 768w" data-lazy-sizes="(max-width: 820px) 100vw, 820px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installation-of-discourse-on-ubuntu-20.04.png" /><noscript><img width="820" height="583" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installation-of-discourse-on-ubuntu-20.04.png" alt="installation of discourse on ubuntu 20.04" class="wp-image-39628" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installation-of-discourse-on-ubuntu-20.04.png?v=1635497659 820w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installation-of-discourse-on-ubuntu-20.04-300x213.png?v=1635497659 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installation-of-discourse-on-ubuntu-20.04-150x107.png?v=1635497659 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/installation-of-discourse-on-ubuntu-20.04-768x546.png?v=1635497659 768w" sizes="(max-width: 820px) 100vw, 820px" /></noscript></figure>



<p>The final step is to check your mailbox to confirm your administrator account creation.</p>



<p>Congratulations! You successfully installed <b>Discourse on Ubuntu 20.04</b>.</p>



<p>Of course, you don’t have to install Discourse on Ubuntu 20.04. If you find it difficult, you can simply ask our expert Linux admins to install Discourse on Ubuntu 20.04 for you. They are available 24×7 and will take care of your request immediately.</p>



<p>If you liked this post on how to install Discourse on Ubuntu 20.04, please share it with your friends on the social networks using the buttons on the left or simply leave a reply below. Thanks.</p>
		</div>

				<footer class="entry-meta" aria-label="Entry meta">
			<span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://www.rosehosting.com/blog/category/tutorials/" rel="category tag">Tutorials</a>, <a href="https://www.rosehosting.com/blog/category/ubuntu/" rel="category tag">Ubuntu</a></span> 		<nav id="nav-below" class="post-navigation" aria-label="Single Post">
			<span class="screen-reader-text">Post navigation</span>

			<div class="nav-previous"><span class="prev" title="Previous"><a href="https://www.rosehosting.com/blog/how-to-install-odoo-15-on-ubuntu-20-04/" rel="prev">How to Install Odoo 15 on Ubuntu 20.04</a></span></div>		</nav>
				</footer>
			</div>
</article>

			<div class="comments-area">
				<div id="comments">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/how-to-install-discourse-on-ubuntu-20-04/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.rosehosting.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea autocomplete="new-password"  id="e42af3c480"  name="e42af3c480"   cols="45" rows="8" required></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0 !important;clip:rect(1px, 1px, 1px, 1px) !important;position:absolute !important;white-space:nowrap !important;height:1px !important;width:1px !important;overflow:hidden !important;" tabindex="-1"></textarea><script type="rocketlazyloadscript" data-noptimize data-rocket-type="text/javascript">document.getElementById("comment").setAttribute( "id", "ac80f9ca616b4bdcfe0c3e710c562898" );document.getElementById("e42af3c480").setAttribute( "id", "comment" );</script></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" required />
<label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" required />

<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="cptch_block"><span class="cptch_title cptch_to_remove">To prove you are human please solve the following<span class="required"> *</span></span><span class="cptch_wrap cptch_math_actions">
				<label class="cptch_label" for="cptch_input_41"><span class="cptch_span">4</span>
					<span class="cptch_span">&nbsp;&#43;&nbsp;</span>
					<span class="cptch_span"><input id="cptch_input_41" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span>
					<span class="cptch_span">&nbsp;=&nbsp;</span>
					<span class="cptch_span">&#101;l&#101;v&#101;n</span>
					<input type="hidden" name="cptch_result" value="KhQ=" /><input type="hidden" name="cptch_time" value="1637694334" />
					<input type="hidden" name="cptch_form" value="wp_comments" />
				</label><span class="cptch_reload_button_wrap hide-if-no-js">
					<noscript>
						<style type="text/css">
							.hide-if-no-js {
								display: none !important;
							}
						</style>
					</noscript>
					<span class="cptch_reload_button dashicons dashicons-update"></span>
				</span></span></p><p class="comment-form-mailpoet">
      <label for="mailpoet_subscribe_on_comment">
        <input
          type="checkbox"
          id="mailpoet_subscribe_on_comment"
          value="1"
          name="mailpoet[subscribe_on_comment]"
        />&nbsp;Yes, add me to your new blog post notifications list
      </label>
    </p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='39599' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
			</div>

					</main>
	</div>

	<div class="widget-area sidebar is-right-sidebar grid-30 tablet-grid-30 grid-parent" id="right-sidebar">
	<div class="inside-right-sidebar">
		<aside id="categories-3" class="widget inner-padding widget_categories"><h2 class="widget-title">Categories</h2><form action="https://www.rosehosting.com/blog" method="get"><label class="screen-reader-text" for="cat">Categories</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="1709">Caching&nbsp;&nbsp;(23)</option>
	<option class="level-0" value="1699">CentOS&nbsp;&nbsp;(303)</option>
	<option class="level-0" value="1710">CMS, CRM, ERP&nbsp;&nbsp;(230)</option>
	<option class="level-0" value="1708">Control Panels&nbsp;&nbsp;(47)</option>
	<option class="level-0" value="1702">Databases&nbsp;&nbsp;(107)</option>
	<option class="level-0" value="1700">Debian&nbsp;&nbsp;(151)</option>
	<option class="level-0" value="1711">E-Commerce&nbsp;&nbsp;(63)</option>
	<option class="level-0" value="1706">Email Servers&nbsp;&nbsp;(36)</option>
	<option class="level-0" value="1236">Guides&nbsp;&nbsp;(58)</option>
	<option class="level-0" value="1705">Load Balancing&nbsp;&nbsp;(5)</option>
	<option class="level-0" value="1">Miscellaneous&nbsp;&nbsp;(51)</option>
	<option class="level-0" value="1701">Networking and Domains&nbsp;&nbsp;(42)</option>
	<option class="level-0" value="3">News&nbsp;&nbsp;(12)</option>
	<option class="level-0" value="1704">Optimization&nbsp;&nbsp;(21)</option>
	<option class="level-0" value="1713">Other&nbsp;&nbsp;(6)</option>
	<option class="level-0" value="4">RoseHosting Platform&nbsp;&nbsp;(46)</option>
	<option class="level-0" value="5">Scripts&nbsp;&nbsp;(11)</option>
	<option class="level-0" value="1703">Security&nbsp;&nbsp;(104)</option>
	<option class="level-0" value="606">SEO&nbsp;&nbsp;(2)</option>
	<option class="level-0" value="21">Tips and Tricks&nbsp;&nbsp;(74)</option>
	<option class="level-0" value="13">Tutorials&nbsp;&nbsp;(806)</option>
	<option class="level-0" value="1698">Ubuntu&nbsp;&nbsp;(390)</option>
	<option class="level-0" value="1712">Web Frameworks&nbsp;&nbsp;(112)</option>
	<option class="level-0" value="1707">Web Servers&nbsp;&nbsp;(141)</option>
</select>
</form>
<script type="rocketlazyloadscript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</aside><aside class="widget inner-padding rhad-widget"><div  class="rhad-fb517577a1e5c09700a53e241ba07fe0 rhad-sidebar-ad-group" id="rhad-fb517577a1e5c09700a53e241ba07fe0"></div></aside><aside id="custom_html-8" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a target="_blank" href="https://www.rosehosting.com/about-us.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">About RoseHosting</a><br>
<a target="_blank" href="https://www.rosehosting.com/linux-vps-hosting/" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Buy a Managed VPS - 25% OFF</a><br>
<a target="_blank" href="https://www.rosehosting.com/reviews.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">RoseHosting Customer Reviews</a><br>
<a target="_blank" href="https://www.rosehosting.com/nvme-hosting.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Managed NVMe VPSes</a><br>
	<a target="_blank" href="https://www.rosehosting.com/dedicated-servers.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Managed NVMe Dedicated Servers</a>
</div></aside><aside id="zoom-social-icons-widget-2" class="widget inner-padding zoom-social-icons-widget">
		
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--align-center zoom-social-icons-list--no-labels">

		
				<li class="zoom-social_icons-list__item">
		<a class="zoom-social_icons-list__link" href="https://www.facebook.com/RoseHosting" target="_blank" >
									
						<span class="screen-reader-text">facebook</span>
			
						<span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #3b5998; font-size: 30px; padding:10px" ></span>
			
					</a>
	</li>

	
				<li class="zoom-social_icons-list__item">
		<a class="zoom-social_icons-list__link" href="https://twitter.com/rosehosting" target="_blank" >
									
						<span class="screen-reader-text">twitter</span>
			
						<span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#1da1f2" style="background-color : #1da1f2; font-size: 30px; padding:10px" ></span>
			
					</a>
	</li>

	
				<li class="zoom-social_icons-list__item">
		<a class="zoom-social_icons-list__link" href="https://www.linkedin.com/company/rose-web-services-l-l-c-" target="_blank" >
									
						<span class="screen-reader-text">linkedin</span>
			
						<span class="zoom-social_icons-list-span social-icon socicon socicon-linkedin" data-hover-rule="background-color" data-hover-color="#0077B5" style="background-color : #0077B5; font-size: 30px; padding:10px" ></span>
			
					</a>
	</li>

	
</ul>

		</aside><aside id="search-3" class="widget inner-padding widget_search"><form method="get" class="search-form" action="https://www.rosehosting.com/blog/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:">
	</label>
	<input type="submit" class="search-submit" value="Search"></form>
</aside><aside id="recent-posts-widget-with-thumbnails-2" class="widget inner-padding recent-posts-widget-with-thumbnails">
<div id="rpwwt-recent-posts-widget-with-thumbnails-2" class="rpwwt-widget">
	<ul>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/" aria-current="page"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to install discourse on ubuntu 20.04" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04-150x75.jpg?v=1635497255 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04-300x150.jpg?v=1635497255 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04.jpg?v=1635497255 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04-150x75.jpg?v=1635497255" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04-150x75.jpg?v=1635497255" class="attachment-75x75 size-75x75" alt="how to install discourse on ubuntu 20.04" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04-150x75.jpg?v=1635497255 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04-300x150.jpg?v=1635497255 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04.jpg?v=1635497255 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How To Install Discourse on Ubuntu 20.04</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-odoo-15-on-ubuntu-20-04/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to install Odoo 15 on Ubuntu 20.04" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-odoo-15-ubuntu-20.04-150x75.jpg?v=1635520134 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-odoo-15-ubuntu-20.04-300x150.jpg?v=1635520134 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-odoo-15-ubuntu-20.04.jpg?v=1635520134 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-odoo-15-ubuntu-20.04-150x75.jpg?v=1635520134" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-odoo-15-ubuntu-20.04-150x75.jpg?v=1635520134" class="attachment-75x75 size-75x75" alt="how to install Odoo 15 on Ubuntu 20.04" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-odoo-15-ubuntu-20.04-150x75.jpg?v=1635520134 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-odoo-15-ubuntu-20.04-300x150.jpg?v=1635520134 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-odoo-15-ubuntu-20.04.jpg?v=1635520134 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Install Odoo 15 on Ubuntu 20.04</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-magento-2-4-3-on-ubuntu-20-04/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to install magento 2.4.3 on ubuntu 20.04" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-magento-2.4.3-on-ubuntu-20.04-150x75.jpg?v=1634289765 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-magento-2.4.3-on-ubuntu-20.04-300x150.jpg?v=1634289765 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-magento-2.4.3-on-ubuntu-20.04.jpg?v=1634289765 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-magento-2.4.3-on-ubuntu-20.04-150x75.jpg?v=1634289765" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-magento-2.4.3-on-ubuntu-20.04-150x75.jpg?v=1634289765" class="attachment-75x75 size-75x75" alt="how to install magento 2.4.3 on ubuntu 20.04" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-magento-2.4.3-on-ubuntu-20.04-150x75.jpg?v=1634289765 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-magento-2.4.3-on-ubuntu-20.04-300x150.jpg?v=1634289765 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-magento-2.4.3-on-ubuntu-20.04.jpg?v=1634289765 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How To Install Magento 2.4.3 on Ubuntu 20.04</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-prometheus-on-ubuntu-20-04/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to install prometheus on ubuntu 20.04" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-prometheus-on-ubuntu-20.04-150x75.jpg?v=1635430902 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-prometheus-on-ubuntu-20.04-300x150.jpg?v=1635430902 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-prometheus-on-ubuntu-20.04.jpg?v=1635430902 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-prometheus-on-ubuntu-20.04-150x75.jpg?v=1635430902" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-prometheus-on-ubuntu-20.04-150x75.jpg?v=1635430902" class="attachment-75x75 size-75x75" alt="how to install prometheus on ubuntu 20.04" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-prometheus-on-ubuntu-20.04-150x75.jpg?v=1635430902 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-prometheus-on-ubuntu-20.04-300x150.jpg?v=1635430902 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-prometheus-on-ubuntu-20.04.jpg?v=1635430902 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How To Install Prometheus on Ubuntu 20.04</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-contao-on-ubuntu-20-04/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-contao-on-ubuntu-20.04-1-150x75.jpg?v=1635420676 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-contao-on-ubuntu-20.04-1-300x150.jpg?v=1635420676 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-contao-on-ubuntu-20.04-1.jpg?v=1635420676 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-contao-on-ubuntu-20.04-1-150x75.jpg?v=1635420676" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-contao-on-ubuntu-20.04-1-150x75.jpg?v=1635420676" class="attachment-75x75 size-75x75" alt="" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-contao-on-ubuntu-20.04-1-150x75.jpg?v=1635420676 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-contao-on-ubuntu-20.04-1-300x150.jpg?v=1635420676 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-contao-on-ubuntu-20.04-1.jpg?v=1635420676 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Install Contao on Ubuntu 20.04</span></a></li>
	</ul>
</div><!-- .rpwwt-widget -->
</aside>      <aside id="mailpoet_form-2" class="widget inner-padding widget_mailpoet_form">
  
  
  <div class="
    mailpoet_form_popup_overlay
      "></div>
  <div
    id="mailpoet_form_2"
    class="
      mailpoet_form
      mailpoet_form_widget
      mailpoet_form_position_
      mailpoet_form_animation_
    "
      >
    
    <style type="text/css">
     .mailpoet_hp_email_label{display:none!important;}#mailpoet_form_2 .mailpoet_form {  }
#mailpoet_form_2 form { margin-bottom: 0; }
#mailpoet_form_2 p.mailpoet_form_paragraph { margin-bottom: 10px; }
#mailpoet_form_2 .mailpoet_column_with_background { padding: 10px; }
#mailpoet_form_2 .mailpoet_form_column:not(:first-child) { margin-left: 20px; }
#mailpoet_form_2 .mailpoet_paragraph { line-height: 20px; margin-bottom: 20px; }
#mailpoet_form_2 .mailpoet_segment_label, #mailpoet_form_2 .mailpoet_text_label, #mailpoet_form_2 .mailpoet_textarea_label, #mailpoet_form_2 .mailpoet_select_label, #mailpoet_form_2 .mailpoet_radio_label, #mailpoet_form_2 .mailpoet_checkbox_label, #mailpoet_form_2 .mailpoet_list_label, #mailpoet_form_2 .mailpoet_date_label { display: block; font-weight: normal; }
#mailpoet_form_2 .mailpoet_text, #mailpoet_form_2 .mailpoet_textarea, #mailpoet_form_2 .mailpoet_select, #mailpoet_form_2 .mailpoet_date_month, #mailpoet_form_2 .mailpoet_date_day, #mailpoet_form_2 .mailpoet_date_year, #mailpoet_form_2 .mailpoet_date { display: block; }
#mailpoet_form_2 .mailpoet_text, #mailpoet_form_2 .mailpoet_textarea { width: 200px; }
#mailpoet_form_2 .mailpoet_checkbox {  }
#mailpoet_form_2 .mailpoet_submit {  }
#mailpoet_form_2 .mailpoet_divider {  }
#mailpoet_form_2 .mailpoet_message {  }
#mailpoet_form_2 .mailpoet_form_loading { width: 30px; text-align: center; line-height: normal; }
#mailpoet_form_2 .mailpoet_form_loading > span { width: 5px; height: 5px; background-color: #5b5b5b; }#mailpoet_form_2{border-radius: 0px;background: #ffffff;text-align: left;}#mailpoet_form_2 form.mailpoet_form {padding: 10px;}#mailpoet_form_2{width: 100%;}#mailpoet_form_2 .mailpoet_message {margin: 0; padding: 0 20px;}
        #mailpoet_form_2 .mailpoet_validate_success {color: #00d084}
        #mailpoet_form_2 input.parsley-success {color: #00d084}
        #mailpoet_form_2 select.parsley-success {color: #00d084}
        #mailpoet_form_2 textarea.parsley-success {color: #00d084}
      
        #mailpoet_form_2 .mailpoet_validate_error {color: #cf2e2e}
        #mailpoet_form_2 input.parsley-error {color: #cf2e2e}
        #mailpoet_form_2 select.parsley-error {color: #cf2e2e}
        #mailpoet_form_2 textarea.textarea.parsley-error {color: #cf2e2e}
        #mailpoet_form_2 .parsley-errors-list {color: #cf2e2e}
        #mailpoet_form_2 .parsley-required {color: #cf2e2e}
        #mailpoet_form_2 .parsley-custom-error-message {color: #cf2e2e}
      #mailpoet_form_2 .mailpoet_paragraph.last {margin-bottom: 0} @media (max-width: 500px) {#mailpoet_form_2 {background: #ffffff;}} @media (min-width: 500px) {#mailpoet_form_2 .last .mailpoet_paragraph:last-child {margin-bottom: 0}}  @media (max-width: 500px) {#mailpoet_form_2 .mailpoet_form_column:last-child .mailpoet_paragraph:last-child {margin-bottom: 0}} 
    </style>

    <form
      target="_self"
      method="post"
      action="https://www.rosehosting.com/blog/wp-admin/admin-post.php?action=mailpoet_subscription_form"
      class="mailpoet_form mailpoet_form_form mailpoet_form_widget"
      novalidate
      data-delay=""
      data-exit-intent-enabled=""
      data-font-family=""
    >
      <input type="hidden" name="data[form_id]" value="2" />
      <input type="hidden" name="token" value="87daa7c417" />
      <input type="hidden" name="api_version" value="v1" />
      <input type="hidden" name="endpoint" value="subscribers" />
      <input type="hidden" name="mailpoet_method" value="subscribe" />

      <label class="mailpoet_hp_email_label">Please leave this field empty<input type="email" name="data[email]"/></label><h2 class="mailpoet-heading  mailpoet-has-font-size" id="" style="text-align: center; color: #0081ff; font-size: 20px; line-height: 1.5"><span style="font-family: Montserrat" data-font="Montserrat" class="mailpoet-has-font"><strong><span class="has-inline-color has-black-color">Join our Blog</span></strong></span></h2>
<p class="mailpoet_form_paragraph  mailpoet-has-font-size" style="text-align: center; color: #000000; font-size: 14px; line-height: 1.5"><strong><span style="font-family: Montserrat" data-font="Montserrat" class="mailpoet-has-font">Sign up and receive notifications as soon as new content is posted.</span></strong></p>
<div class="mailpoet_paragraph "><input type="email" class="mailpoet_text" name="data[form_field_ZTVlY2IyMzIyMzFkX2VtYWls]" title="Enter your e-mail" value="" style="width:100%;padding:12px;margin: 0 auto 0 0;font-size:15px;line-height:1.5;height:auto;" data-automation-id="form_email"  placeholder="Enter your e-mail *" data-parsley-required="true" data-parsley-minlength="6" data-parsley-maxlength="150" data-parsley-error-message="Please specify a valid email address." data-parsley-required-message="This field is required."/></div>
<div class="mailpoet_paragraph "><input type="submit" class="mailpoet_submit" value="Subscribe" data-automation-id="subscribe-submit-button" style="width:100%;padding:12px;margin: 0 auto 0 0;font-size:15px;line-height:1.5;height:auto;border-color:transparent;" /><span class="mailpoet_form_loading"><span class="mailpoet_bounce1"></span><span class="mailpoet_bounce2"></span><span class="mailpoet_bounce3"></span></span></div>

      <div class="mailpoet_message">
        <p class="mailpoet_validate_success"
                style="display:none;"
                >Check your inbox or spam folder to confirm your subscription.
        </p>
        <p class="mailpoet_validate_error"
                style="display:none;"
                >        </p>
      </div>
    </form>
  </div>

      </aside>
  	</div>
</div>
</div>

  <!-- footer-big-menu.html -->
  <footer class="footer-big-menu">
    <div class="container" style="max-width: 1100px;">

      <div class="row menu">

        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title mb-2">Company</h3>
            <a class="menu-link" href="https://www.rosehosting.com/about-us.html">About us</a>
            <a class="menu-link" href="https://www.rosehosting.com/policies.html">Our Policies</a>
            <a class="menu-link" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
            <a class="menu-link" href="https://www.rosehosting.com/blog/">Blog</a>
            <a class="menu-link" href="https://www.rosehosting.com/why-rosehosting.html">Why RoseHosting</a>
            <a class="menu-link" href="https://www.rosehosting.com/compare-to-competition.html">Compare Us</a>
            <a class="menu-link" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
            <a class="menu-link" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
            <a class="menu-link" href="/recommended-tools-and-services.html">Recommended Services</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Support</h3>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Helpdesk System</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>

          <h3 class="menu-title  mb-2 mt-4">Other Services</h3>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Domain Registration</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Domain Transfer</a>
          <a class="menu-link" href="https://www.rosehosting.com/ssl-certificates.html">SSL Certificates</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/linux-vps-hosting/">Linux VPS Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/managed-cloud-hosting.html">Cloud Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom SSD VPS</a>
          <a class="menu-link" href="https://www.rosehosting.com/dedicated-servers.html">Dedicated Servers</a>
          <a class="menu-link" href="https://www.rosehosting.com/hosting-solutions.html">Hosting Solutions</a>
          <a class="menu-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Recurr. Affiliate Program</a>
          <a class="menu-link" href="https://www.rosehosting.com/cpa-hosting-affiliate-program.html">CPA Affiliate Program</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Linux VPS Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/centos-hosting.html">CentOS Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/ubuntu-hosting.html">Ubuntu Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/debian-hosting.html">Debian Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/opensuse-hosting.html">OpenSUSE Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/arch-linux-hosting.html">Arch-Linux Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/scientific-linux-hosting.html">Scientific Linux Hosting</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Apps Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/wordpress-hosting.html">WordPress Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/magento-hosting.html">Magento Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/odoo-hosting.html">Odoo Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/joomla-hosting.html">Joomla Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/drupal-hosting.html">Drupal Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/laravel-hosting.html">Laravel Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/nextcloud-hosting.html">NextCloud Hosting</a>

          <a class="menu-link" href="https://www.rosehosting.com/prestashop-hosting.html">PrestaShop Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/ghost-hosting.html">Ghost Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/mediawiki-hosting.html">MediaWiki Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/tomcat-hosting.html">Tomcat Hosting</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title mb-2">Contact Us</h3>
          <a class="menu-link" href="tel:+18887673467">(888) ROSE-HOST</a>
          <a class="menu-link" href="tel:+18887673467">(888) 767-3467</a>
          <a class="menu-link" href="tel:+13142750414">(314) 275-0414</a>
          <a class="menu-link" href="mailto:%73%75%70%70%6f%72%74%40%72%6f%73%65%68%6f%73%74%69%6e%67%2e%63%6f%6d">Email us</a>

          <h3 class="menu-title mb-2 mt-4">Connect</h3>
          <a class="menu-link" href="https://twitter.com/rosehosting" target="_blank"><i class="fa fa-twitter fa-fw"></i> Twitter</a>
          <a class="menu-link" href="https://www.facebook.com/RoseHosting" target="_blank"><i class="fa fa-facebook fa-fw"></i> Facebook</a>
          <a class="menu-link" href="https://www.linkedin.com/in/rosehosting/" target="_blank"><i class="fa fa-linkedin fa-fw"></i> LinkedIn</a>
          <a class="menu-link" href="https://www.rosehosting.com/blog/feed/" target="_blank"><i class="fa fa-rss fa-fw"></i> RSS Feed</a>

        </div>

      </div>

    </div>

<br>
    <div class="bottom">
      <div class="container" style="max-width: 1100px;">
        <div class="row">

          <div class="col-md-12 col-lg-6">
              <p class="text-sm-left"><a class="inline-link footer-policy" href="/tos.html">Terms of Service</a> and <a class="inline-link footer-policy" href="/policies.html">other policies</a></p>
          </div>
          <div class="col-md-12 col-lg-6">
            <p class="text-sm-right">&copy; 2001-2021 <a class="inline-link footer-policy" href="https://www.rosewebservices.com/">Rose Web Services LLC</a>.</p>
          </div>
         </div>
      </div>
    </div>

<!-- livezilla.net code
<script type="rocketlazyloadscript" data-rocket-type="text/javascript" id="aff1f81b02f303eea5f87a3a065f153a" src="https://linuxhostsupport.com/chat//script.php?id=aff1f81b02f303eea5f87a3a065f153a"></script>
http://www.livezilla.net -->

<script type="rocketlazyloadscript" id="generate-a11y">!function(){"use strict";if("querySelector"in document&&"addEventListener"in window){var e=document.body;e.addEventListener("mousedown",function(){e.classList.add("using-mouse")}),e.addEventListener("keydown",function(){e.classList.remove("using-mouse")})}}();</script>



<script id='advanced-ads-pro/cache_busting-js-extra'>
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":"","wp_timezone_offset":"-21600"};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/advanced-ads-pro/assets/js/base.min.js' id='advanced-ads-pro/cache_busting-js' defer></script>
<script id='advanced-ads-layer-footer-js-js-extra'>
var advanced_ads_layer_settings = {"layer_class":"rhad-layer","placements":["20th-anniversary-sale-popup"]};
</script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/advanced-ads-layer/public/assets/js/layer.js?ver=1635278974' id='advanced-ads-layer-footer-js-js' defer></script>
<script type="rocketlazyloadscript" id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script id='rocket-preload-links-js-extra'>
var RocketPreloadLinksConfig = {"excludeUris":"\/blog(\/quiz\/github\/|\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$))|\/wp-admin\/|\/logout\/|\/wp-login.php","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/www.rosehosting.com\/blog","onHoverDelay":"100","rateThrottle":"3"};
</script>
<script type="rocketlazyloadscript" id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/advanced-ads-pro/assets/js/advanced-ads-pro.min.js' id='advanced-ads-pro/front-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/themes/rh2020/js/theme.js?ver=1635278974' id='theme-js' defer></script>
<!--[if lte IE 11]>
<script src='https://www.rosehosting.com/blog/wp-content/themes/generatepress/assets/js/classList.min.js' id='generate-classlist-js'></script>
<![endif]-->
<script id='generate-menu-js-extra'>
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/themes/generatepress/assets/js/menu.min.js' id='generate-menu-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-includes/js/comment-reply.min.js' id='comment-reply-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/js/social-icons-widget-frontend.js?ver=1635278974' id='zoom-social-icons-widget-frontend-js' defer></script>
<script src='https://www.rosehosting.com/blog/wp-includes/js/wp-embed.min.js' id='wp-embed-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/smooth-scroll/jquery.smooth-scroll.min.js' id='jquery-smooth-scroll-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/js-cookie/js.cookie.min.js' id='js-cookie-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/sticky-kit/jquery.sticky-kit.min.js' id='jquery-sticky-kit-js' defer></script>
<script id='ez-toc-js-js-extra'>
var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"","width":"95%","scroll_offset":"30"};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/assets/js/front.min.js' id='ez-toc-js-js' defer></script>
<script id='mailpoet_public-js-extra'>
var MailPoetForm = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","is_rtl":""};
</script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/mailpoet/assets/dist/js/public.0968942a.js?ver=1637306714' id='mailpoet_public-js' defer></script>
<script type="rocketlazyloadscript" id='mailpoet_public-js-after'>
function initMailpoetTranslation() {
  if (typeof MailPoet !== 'undefined') {
    MailPoet.I18n.add('ajaxFailedErrorMessage', 'An error has happened while performing a request, please try again later.')
  } else {
    setTimeout(initMailpoetTranslation, 250);
  }
}
setTimeout(initMailpoetTranslation, 250);
</script>
<script id='cptch_front_end_script-js-extra'>
var cptch_vars = {"nonce":"e3430e9d4d","ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","enlarge":"","time_limit":"120"};
</script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/captcha-bws/js/front_end_script.js?ver=1635278974' id='cptch_front_end_script-js' defer></script>
<!--noptimize--><script type="rocketlazyloadscript">window.advads_passive_placements = {"sidebar-ad-group_2":{"type":"group","id":1744,"elementid":["rhad-fb517577a1e5c09700a53e241ba07fe0"],"ads":{"26322":{"id":26322,"title":"after-first-image-300x250-rh-orange","expiry_date":0,"visitors":[],"content":"<div style=\"margin-left: auto; margin-right: auto; text-align: center; \" id=\"rhad-1335803157\"><center><a target=\"_blank\" href=\"https:\/\/www.rosehosting.com\/cloud-vps-hosting.html\"><img src=\"https:\/\/media.rosehosting.com\/images\/blogads\/orange.jpg\" alt=\"Cloud VPS Hosting\"><\/a><\/center>\r\n<\/div>","once_per_page":0,"debugmode":false,"blog_id":1,"type":"plain","position":"center","privacy":{"ignore":false,"needs_consent":false}},"34996":{"id":34996,"title":"Dedicated Server Hosting","expiry_date":0,"visitors":[],"content":"<a href=\"https:\/\/www.rosehosting.com\/dedicated-servers.html\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2020\/12\/Dedicated-Server-Hosting.jpg\" alt=\"Dedicated Server Hosting\"  width=\"300\" height=\"250\"   \/><\/a>","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}},"34829":{"id":34829,"title":"Managed VPS Hosting 300x250","expiry_date":0,"visitors":[],"content":"<a href=\"https:\/\/www.rosehosting.com\/linux-vps-hosting\/\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2020\/11\/Managed-VPS-Hosting.jpg\" alt=\"Managed VPS Hosting\"  width=\"300\" height=\"250\"   \/><\/a>","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}},"34897":{"id":34897,"title":"Linux Server Management Services LHS 300x250","expiry_date":0,"visitors":[],"content":"<a href=\"https:\/\/linuxhostsupport.com\/\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2020\/11\/Linux-Server-Management-Service.jpg\" alt=\"Linux Server Management Service\"  width=\"300\" height=\"250\"   \/><\/a>","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}},"34828":{"id":34828,"title":"Managed NVME Hosting 300x250","expiry_date":0,"visitors":[],"content":"<a href=\"https:\/\/www.rosehosting.com\/nvme-hosting.html\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2020\/11\/Managed-NVMe-VPS-Hosting.jpg\" alt=\"Managed NVMe VPS Hosting\"  width=\"300\" height=\"250\"   \/><\/a>","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}}},"group_info":{"id":1744,"name":"RH and LHS","weights":{"34996":10,"34994":10,"34993":10,"34897":10,"34870":10,"34868":10,"34829":10,"34828":10,"34827":10,"34821":10,"34786":10,"26322":10},"type":"default","ordered_ad_ids":[26322,34993,34827,34786,34868,34996,34994,34829,34897,34821,34828,34870],"ad_count":1,"refresh_enabled":true,"refresh_interval_for_ads":{"34994":15000,"26322":15000,"34829":15000,"34996":15000,"34870":15000,"34897":15000,"34868":15000,"34827":15000,"34828":15000,"34786":15000,"34821":15000,"34993":15000}},"placement_info":{"type":"sidebar_widget","name":"sidebar ad group","item":"group_1744","id":"sidebar-ad-group"},"test_id":null,"group_wrap":[{"before":"<div class=\"rhad-sidebar-ad-group\" id=\"rhad-270811260\">","after":"<\/div>"}],"inject_before":[""]}};
window.advads_ajax_queries = [{"id":"before-content","method":"placement","params":{"placement_position":"center","previous_method":"placement","previous_id":"before-content","post":"r0","url_parameter":"\/blog\/how-to-install-discourse-on-ubuntu-20-04\/","placement_type":"post_top","output":{"class":["rhad-before-content"],"placement_id":"before-content"}},"elementid":"rhad-b757c1f118f702f322aa9ff657d560b1","blog_id":1}];
window.advads_ajax_queries_args = {"r0":{"id":39599,"author":"4","post_type":"post"}};
( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( !window.advanced_ads_pro ) {console.log("Advanced Ads Pro: cache-busting can not be initialized");} });</script><!--/noptimize--><!--noptimize--><script type="rocketlazyloadscript">!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><!--/noptimize--><script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.rosehosting.com/blog/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script>
</body>
</html>

<!-- Cached for great performance -->