<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />


	<link rel="pingback" href="https://www.rosehosting.com/blog/xmlrpc.php" />


		<!--[if lt IE 9]>
	<script src="https://www.rosehosting.com/blog/wp-content/themes/generatepress/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->

<!--<script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script>-->

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KVJ4PJ');</script>
<!-- End Google Tag Manager -->

	

	
	<!-- This site is optimized with the Yoast SEO Premium plugin v15.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>How To Install ERPNext on CentOS | RoseHosting Blog</title><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2Cregular%2Citalic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CAbril%20FatFace%3A400%2C400i%2C700%2C700i%7CAlegreya%3A400%2C400i%2C700%2C700i%7CAlegreya%20Sans%3A400%2C400i%2C700%2C700i%7CAmatic%20SC%3A400%2C400i%2C700%2C700i%7CAnonymous%20Pro%3A400%2C400i%2C700%2C700i%7CArchitects%20Daughter%3A400%2C400i%2C700%2C700i%7CArchivo%3A400%2C400i%2C700%2C700i%7CArchivo%20Narrow%3A400%2C400i%2C700%2C700i%7CAsap%3A400%2C400i%2C700%2C700i%7CBarlow%3A400%2C400i%2C700%2C700i%7CBioRhyme%3A400%2C400i%2C700%2C700i%7CBonbon%3A400%2C400i%2C700%2C700i%7CCabin%3A400%2C400i%2C700%2C700i%7CCairo%3A400%2C400i%2C700%2C700i%7CCardo%3A400%2C400i%2C700%2C700i%7CChivo%3A400%2C400i%2C700%2C700i%7CConcert%20One%3A400%2C400i%2C700%2C700i%7CCormorant%3A400%2C400i%2C700%2C700i%7CCrimson%20Text%3A400%2C400i%2C700%2C700i%7CEczar%3A400%2C400i%2C700%2C700i%7CExo%202%3A400%2C400i%2C700%2C700i%7CFira%20Sans%3A400%2C400i%2C700%2C700i%7CFjalla%20One%3A400%2C400i%2C700%2C700i%7CFrank%20Ruhl%20Libre%3A400%2C400i%2C700%2C700i%7CGreat%20Vibes%3A400%2C400i%2C700%2C700i%7CHeebo%3A400%2C400i%2C700%2C700i%7CIBM%20Plex%3A400%2C400i%2C700%2C700i%7CInconsolata%3A400%2C400i%2C700%2C700i%7CIndie%20Flower%3A400%2C400i%2C700%2C700i%7CInknut%20Antiqua%3A400%2C400i%2C700%2C700i%7CInter%3A400%2C400i%2C700%2C700i%7CKarla%3A400%2C400i%2C700%2C700i%7CLibre%20Baskerville%3A400%2C400i%2C700%2C700i%7CLibre%20Franklin%3A400%2C400i%2C700%2C700i%7CMontserrat%3A400%2C400i%2C700%2C700i%7CNeuton%3A400%2C400i%2C700%2C700i%7CNotable%3A400%2C400i%2C700%2C700i%7CNothing%20You%20Could%20Do%3A400%2C400i%2C700%2C700i%7CNoto%20Sans%3A400%2C400i%2C700%2C700i%7CNunito%3A400%2C400i%2C700%2C700i%7COld%20Standard%20TT%3A400%2C400i%2C700%2C700i%7COxygen%3A400%2C400i%2C700%2C700i%7CPacifico%3A400%2C400i%2C700%2C700i%7CPoppins%3A400%2C400i%2C700%2C700i%7CProza%20Libre%3A400%2C400i%2C700%2C700i%7CPT%20Sans%3A400%2C400i%2C700%2C700i%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CRakkas%3A400%2C400i%2C700%2C700i%7CReenie%20Beanie%3A400%2C400i%2C700%2C700i%7CRoboto%20Slab%3A400%2C400i%2C700%2C700i%7CRopa%20Sans%3A400%2C400i%2C700%2C700i%7CRubik%3A400%2C400i%2C700%2C700i%7CShadows%20Into%20Light%3A400%2C400i%2C700%2C700i%7CSpace%20Mono%3A400%2C400i%2C700%2C700i%7CSpectral%3A400%2C400i%2C700%2C700i%7CSue%20Ellen%20Francisco%3A400%2C400i%2C700%2C700i%7CTitillium%20Web%3A400%2C400i%2C700%2C700i%7CUbuntu%3A400%2C400i%2C700%2C700i%7CVarela%3A400%2C400i%2C700%2C700i%7CVollkorn%3A400%2C400i%2C700%2C700i%7CWork%20Sans%3A400%2C400i%2C700%2C700i%7CYatra%20One%3A400%2C400i%2C700%2C700i&#038;display=swap" /><link rel="stylesheet" href="https://www.rosehosting.com/blog/wp-content/cache/min/1/1fac20ef9c3b0165b4207b86181492dd.css" media="all" data-minify="1" />
	<meta name="description" content="ERPNext is a completely robust ERP framework intended for small and medium-sized businesses. It covers an extensive variety of features." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="How To Install ERPNext on CentOS | RoseHosting Blog" />
	<meta property="og:description" content="ERPNext is a completely robust ERP framework intended for small and medium-sized businesses. It covers an extensive variety of features, including accounting, CRM, inventory" />
	<meta property="og:url" content="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/" />
	<meta property="og:site_name" content="RoseHosting" />
	<meta property="article:publisher" content="https://www.facebook.com/RoseHosting" />
	<meta property="article:author" content="https://www.facebook.com/rosehosting.helpdesk" />
	<meta property="article:published_time" content="2021-02-24T17:52:00+00:00" />
	<meta property="article:modified_time" content="2021-02-09T18:01:04+00:00" />
	<meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8.jpg" />
	<meta property="og:image:width" content="742" />
	<meta property="og:image:height" content="372" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:title" content="How To Install ERPNext on CentOS | RoseHosting Blog" />
	<meta name="twitter:description" content="ERPNext is a completely robust ERP framework intended for small and medium-sized businesses. It covers an extensive variety of features, including accounting, CRM, inventory" />
	<meta name="twitter:creator" content="@rosehosting" />
	<meta name="twitter:site" content="@rosehosting" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Jeff Wilson">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="7 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.rosehosting.com/blog/#organization","name":"RoseHosting","url":"https://www.rosehosting.com/blog/","sameAs":["https://www.facebook.com/RoseHosting","https://www.linkedin.com/in/rosehosting/","https://twitter.com/rosehosting"],"logo":{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/#logo","inLanguage":"en-US","url":"https://www.rosehosting.com/blog/wp-content/uploads/2016/02/rhlogo-final-500x500.png","width":500,"height":500,"caption":"RoseHosting"},"image":{"@id":"https://www.rosehosting.com/blog/#logo"}},{"@type":"WebSite","@id":"https://www.rosehosting.com/blog/#website","url":"https://www.rosehosting.com/blog/","name":"RoseHosting","description":"Premium Linux Tutorials Since 2001","publisher":{"@id":"https://www.rosehosting.com/blog/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.rosehosting.com/blog/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/#primaryimage","inLanguage":"en-US","url":"https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8.jpg","width":742,"height":372,"caption":"how to Install erpnext on centos 8"},{"@type":"WebPage","@id":"https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/#webpage","url":"https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/","name":"How To Install ERPNext on CentOS | RoseHosting Blog","isPartOf":{"@id":"https://www.rosehosting.com/blog/#website"},"primaryImageOfPage":{"@id":"https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/#primaryimage"},"datePublished":"2021-02-24T17:52:00+00:00","dateModified":"2021-02-09T18:01:04+00:00","description":"ERPNext is a completely robust ERP framework intended for small and medium-sized businesses. It covers an extensive variety of features.","breadcrumb":{"@id":"https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/"]}]},{"@type":"BreadcrumbList","@id":"https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.rosehosting.com/blog/","url":"https://www.rosehosting.com/blog/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/","url":"https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/","name":"How To Install ERPNext on CentOS 8"}}]},{"@type":"Article","@id":"https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/#article","isPartOf":{"@id":"https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/#webpage"},"author":{"@id":"https://www.rosehosting.com/blog/#/schema/person/7ce77a842fa6a9a7f8efa186f2353713"},"headline":"How To Install ERPNext on CentOS 8","datePublished":"2021-02-24T17:52:00+00:00","dateModified":"2021-02-09T18:01:04+00:00","mainEntityOfPage":{"@id":"https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/#webpage"},"commentCount":0,"publisher":{"@id":"https://www.rosehosting.com/blog/#organization"},"image":{"@id":"https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/#primaryimage"},"keywords":"ERPNext","articleSection":"CentOS,CMS, CRM, ERP,Tutorials","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/#respond"]}]},{"@type":"Person","@id":"https://www.rosehosting.com/blog/#/schema/person/7ce77a842fa6a9a7f8efa186f2353713","name":"Jeff Wilson","image":{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/09271207587f897ab46faaed9b355252?s=96&r=g","caption":"Jeff Wilson"},"description":"An experienced Linux veteran with many years of experience. Helping other Linux admins with frequent Linux and business-related blog posts on the RoseHosting blog. Techie by choice. Loving nature and travel. Happily married and father of two lovely children.","sameAs":["https://www.rosehosting.com","https://www.facebook.com/rosehosting.helpdesk"]}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Feed" href="https://www.rosehosting.com/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Comments Feed" href="https://www.rosehosting.com/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; How To Install ERPNext on CentOS 8 Comments Feed" href="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/feed/" />
<!-- rosehosting.com/blog is managing ads with Advanced Ads --><!--noptimize--><script>
						advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
						</script>
		<!--/noptimize--><style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	







<style id='ez-toc-inline-css'>
div#ez-toc-container p.ez-toc-title {font-size: 22px;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}div#ez-toc-container {width: 95%;}
</style>






<style id='generate-style-inline-css'>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</style>









<link rel="preload" as="font"  id='wpzoom-social-icons-font-academicons-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.ttf?v=1.8.6' type="font/ttf" crossorigin />
<link rel="preload" as="font"  id='wpzoom-social-icons-font-academicons-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.woff?v=1.8.6' type="font/woff" crossorigin />
<link rel="preload" as="font"  id='wpzoom-social-icons-font-fontawesome-3-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.ttf?v=4.7.0' type="font/ttf" crossorigin />
<link rel="preload" as="font"  id='wpzoom-social-icons-font-fontawesome-3-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff?v=4.7.0' type="font/woff" crossorigin />
<link rel="preload" as="font"  id='wpzoom-social-icons-font-fontawesome-3-woff2-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff2?v=4.7.0' type="font/woff2" crossorigin />
<link rel="preload" as="font"  id='wpzoom-social-icons-font-genericons-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type="font/ttf" crossorigin />
<link rel="preload" as="font"  id='wpzoom-social-icons-font-genericons-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type="font/woff" crossorigin />
<link rel="preload" as="font"  id='wpzoom-social-icons-font-socicon-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.ttf' type="font/ttf" crossorigin />
<link rel="preload" as="font"  id='wpzoom-social-icons-font-socicon-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.woff' type="font/woff" crossorigin />
<script src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>




<link rel="https://api.w.org/" href="https://www.rosehosting.com/blog/wp-json/" /><link rel="alternate" type="application/json" href="https://www.rosehosting.com/blog/wp-json/wp/v2/posts/32528" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rosehosting.com/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rosehosting.com/blog/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6.2" />
<link rel='shortlink' href='https://www.rosehosting.com/blog/?p=32528' />
<link rel="alternate" type="application/json+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-install-erpnext-on-centos-8%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-install-erpnext-on-centos-8%2F&#038;format=xml" />
<meta name="viewport" content="width=device-width, initial-scale=1"><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-270x270.png" />
		<style id="wp-custom-css">
			/* Change background color and font of pre-formatted text */
.entry-content pre {
font-family: monospace;
color: #3a3a3a;
border: none;
overflow-wrap: break-word;
}
.inside-article,
.sidebar .widget {
    border: 1px solid #e3e3e3;
}
.page-container {
    max-width: 1100px;
		align-items: center;
		justify-content: space-between;
		margin-left: auto;
		margin-right: auto;
}
.footer-big-menu {
		max-width: 1100px;
		margin-left: auto;
		margin-right: auto;
}
.col6, .col-md-3, .col-lg-2 {
		padding-left: 10px;
		padding-right: 10px;
}
.masonry-load-more {
		padding-left: 20px;
}
@media (max-width:576px) {
	.nav-item {
  	margin-top: 10px;
	}
	.menu-link, .menu-title {
  	margin-top: 10px;
	}
	.comment-content {
		overflow-wrap: break-word;
	}
}		</style>
		<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script type="text/javascript">
  var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.rosehosting.com/";
    _paq.push(['setTrackerUrl', u+'rosea.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.src='https://www.rosehosting.com/dist/rosea.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
</head>
<body class="post-template-default single single-post postid-32528 single-format-standard wp-embed-responsive post-image-above-header post-image-aligned-center sticky-menu-fade right-sidebar nav-below-header separate-containers contained-header active-footer-widgets-1 nav-aligned-left header-aligned-left dropdown-hover featured-image-active aa-prefix-roseh-">



<nav class="navbar yamm navbar-expand-lg navbar-dark" role="navigation">
  <div class="container no-override navbar-dark">

    <a class="navbar-brand" href="https://www.rosehosting.com/">
      <img alt="RoseHosting.com" width="186" height="37"  class="d-lg-inline mr-2" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20186%2037'%3E%3C/svg%3E" data-lazy-src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/rh-logo.svg" /><noscript><img alt="RoseHosting.com" width="186" height="37"  class="d-lg-inline mr-2" src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/rh-logo.svg" /></noscript>
    </a>

    <button class="navbar-toggler" data-toggle="collapse" data-target="#navbar-collapse">
      <span class="navbar-toggler-icon"></span>
    </button>

    <div class="collapse navbar-collapse justify-content-end" id="navbar-collapse">
      <ul class="navbar-nav">

        <li class="nav-item active dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Hosting Solutions
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">

            <div class="yamm-content">
              <div class="row">
                <div class="col-sm-6">
                   <span class="text-primary  dropdown-header"><strong>Managed SSD Hosting</strong></span>
                   <div class="dropdown-divider"></div>
                   <a class="dropdown-item" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/linux-vps-hosting/">Linux VPS Hosting</a>
                   <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom VPS</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/dedicated-servers.html">Cloud Dedicated Servers</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting <span class="ml-2 badge badge-success">new</span></a>
                </div>
                <div class="col-sm-6">
                  <span class="text-primary dropdown-header"><strong>Managed Solutions</strong></span>
                  <div class="dropdown-divider"></div>
                  <a class="dropdown-item" href="https://www.rosehosting.com/wordpress-hosting.html">
                    Wordpress Hosting
                    <small class="d-block text-muted"><i>The best blogging platform</i></small>
                  </a>
                  <a class="dropdown-item" href="https://www.rosehosting.com/magento-hosting.html">
                    Magento Hosting
                    <small class="d-block text-muted"><i>The best e-commerce platform</i></small>
                  </a>
                  <a class="dropdown-item" href="https://www.rosehosting.com/odoo-hosting.html">
                    Odoo Hosting
                    <small class="d-block text-muted"><i>The best CRM/ERP platform</i></small>
                  </a>
                  <span class="dropdown-item"><a class="btn-shadow btn-shadow-primary btn-shadow-sm" target="_blank" href="https://www.rosehosting.com/hosting-solutions.html">Other Solutions</a></span>

                </div>
              </div>
            </div>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            SSL / Domains
            <i class="fa fa-chevron-down"></i>
          </a>

          <div class="dropdown-menu" role="menu">

            <div class="yamm-content">
              <div class="row">
                <div class="col-sm-3">
                    <span class="text-primary  dropdown-header"><strong>SSL by brand</strong></span>
                    <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#geotrust">GeoTrust</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#comodo">Comodo</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#rapidssl">RapidSSL</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#thawte">Thawte</a>
                </div>
                <div class="col-sm-4">

                    <span class="text-primary  dropdown-header"><strong>SSL by Type</strong></span>
                    <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#domain_validation">Domain Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#organization_validation">Organization Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#extended_validation">Extended Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#wildcard_ssl">Wildcard SSL</a>
                </div>
                <div class="col-sm-3">
                  <span class="text-primary dropdown-header"><strong>Domains</strong></span>
                  <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Register Domains</a>
                    <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Transfer Domains</a>
                </div>
              </div>
            </div>
          </div>


        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Support
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
              <a class="dropdown-item" href="https://www.rosehosting.com/support.html">24/7 Managed Support</a>
              <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Open a Support Ticket</a>
              <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>
	      <a class="dropdown-item" rel=”nofollow” href="https://status.rosehosting.net">Systems Status</a>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            About Us
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
            <a class="dropdown-item" href="https://www.rosehosting.com/about-us.html">Our Company</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/policies.html">Our Policies</a>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Affiliates
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
            <a class="dropdown-item" href="https://www.rosehosting.com/cpa-hosting-affiliate-program.html">Flat-Rate CPA Affiliate Plan</a>
            <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Flat-Rate CPA Affiliate Login</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/vps-affiliate-program.html">Recurring Affiliate Plan</a>
            <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/aff/">Recurring Affiliate Login</a>
          </div>
        </li>

        <li class="nav-item">
          <a class="nav-link" href="https://www.rosehosting.com/blog/">Blog</a>
        </li>

        <li class="nav-item">
          <a class="nav-link nav-link--rounded" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Login</a>
        </li>

      </ul>
    </div>

  </div>
</nav>


<!--
<nav class="navbar navbar-expand-lg navbar-light bg-faded navbar-blog">
   <div class="container no-override">
    <a href="https://www.rosehosting.com/blog/" class="navbar-brand">Blog Home</a>
    <div class="navbar-collapse collapse d-flex justify-content-between" id="navbar5-blog">
        <ul class="navbar-nav categories">
            <li class="nav-item dropdown">
              <a class="nav-link dropdown-toggle" data-toggle="dropdown" href="#" role="button" aria-haspopup="true" aria-expanded="false">
                Categories
                <i class="fa fa-chevron-down"></i>
              </a>
              <div class="dropdown-menu" style="z-index:0;">
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/caching/">Caching</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/centos/">CentOS</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/cms-crm-erp/">CMS, CRM, ERP</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/control-panels/">Control Panels</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/databases/">Databases</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/debian/">Debian</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/e-commerce/">E-Commerce</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/email-servers/">Email Servers</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/guides/">Guides</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/load-balancing/">Load Balancing</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/miscellaneous/">Miscellaneous</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/networking-and-domains/">Networking and Domains</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/news/">News</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/optimization/">Optimization</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/other/">Other</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/rosehosting/">RoseHosting Platform</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/scripts/">Scripts</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/security/">Security</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/seo/">SEO</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tips-and-tricks/">Tips and Tricks</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tutorials/">Tutorials</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/ubuntu/">Ubuntu</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-frameworks/">Web Frameworks</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-servers/">Web Servers</a>
                              </div>
            </li>
        </ul>
        <form class="mx-2 my-auto d-inline" method="get" id="searchform" action="https://www.rosehosting.com/blog/">
            <div class="input-group">
                <input type="search" class="field" name="s" id="s" class="form-control border border-right-0" placeholder="Search...">
                <span class="input-group-append">
                <button name="submit" id="searchsubmit" class="btn btn-outline-secondary border border-left-0" type="submit">
                    <i class="fa fa-search"></i>
                </button>
              </span>
            </div>
        </form>
    </div>
  </div>
</nav> -->

	<div id="page-container" class="page-container">

	<div id="primary" class="content-area grid-parent mobile-grid-100 grid-70 tablet-grid-70">
		<main id="main" class="site-main">
			
<article id="post-32528" class="post-32528 post type-post status-publish format-standard has-post-thumbnail hentry category-centos category-cms-crm-erp category-tutorials tag-erpnext" itemtype="https://schema.org/CreativeWork" itemscope>
	<div class="inside-article">
					<header class="entry-header">
				<h1 class="entry-title" itemprop="headline">How To Install ERPNext on CentOS 8</h1>		<div class="entry-meta">
			<span class="posted-on"><time class="entry-date published" datetime="2021-02-24T11:52:00-06:00" itemprop="datePublished">February 24, 2021</time></span> <span class="byline">by <span class="author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope><a class="url fn n" href="https://www.rosehosting.com/blog/author/jwilson/" title="View all posts by Jeff Wilson" rel="author" itemprop="url"><span class="author-name" itemprop="name">Jeff Wilson</span></a></span></span> 		</div>
					</header>
			
		<div class="entry-content" itemprop="text">
			
<figure class="wp-block-image size-large"><img width="742" height="372" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20742%20372'%3E%3C/svg%3E" alt="how to Install erpnext on centos 8" class="wp-image-35469" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8.jpg 742w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8-150x75.jpg 150w" data-lazy-sizes="(max-width: 742px) 100vw, 742px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8.jpg" /><noscript><img width="742" height="372" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8.jpg" alt="how to Install erpnext on centos 8" class="wp-image-35469" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8.jpg 742w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8-150x75.jpg 150w" sizes="(max-width: 742px) 100vw, 742px" /></noscript></figure>



<div class="wp-block-image"><figure class="alignright size-large"><img width="200" height="76" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20200%2076'%3E%3C/svg%3E" alt="install erpnext on centos 8" class="wp-image-35466" title="Installing PHP 8 on Ubuntu 20.04" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/install-erpnext-on-centos-8.jpg 200w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/install-erpnext-on-centos-8-150x57.jpg 150w" data-lazy-sizes="(max-width: 200px) 100vw, 200px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/install-erpnext-on-centos-8.jpg" /><noscript><img width="200" height="76" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/install-erpnext-on-centos-8.jpg" alt="install erpnext on centos 8" class="wp-image-35466" title="Installing PHP 8 on Ubuntu 20.04" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/install-erpnext-on-centos-8.jpg 200w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/install-erpnext-on-centos-8-150x57.jpg 150w" sizes="(max-width: 200px) 100vw, 200px" /></noscript></figure></div>



<p><strong>ERPNext</strong> is a completely robust ERP framework intended for small and medium-sized businesses. It covers an extensive variety of features, including accounting, CRM, inventory, selling, purchasing, manufacturing, projects, HR and payroll, website, e-commerce, and more &#8211; all of which make it profoundly adaptable and extendable.</p>



<p>ERPNext is developed in Python and depends on the Frappe Framework. It utilizes Node.js for the front end, Nginx for the web server, Redis for caching, and MariaDB for the database.</p>



<p>ERPNext is Open Source under the GNU General Public License v3.</p>



<span id="more-32528"></span>



<p>In this article, we will show you <strong>how to install ERPNext on CentOS 8</strong> on one of our optimized <a href="https://www.rosehosting.com/crm-hosting.html">ERPNext hosting</a> servers.</p>



<div id="ez-toc-container" class="ez-toc-v2_0_16 counter-hierarchy ez-toc-transparent">
<div class="ez-toc-title-container">
<p class="ez-toc-title">Table of Contents</p>
<span class="ez-toc-title-toggle"><a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle" style="display: none;"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a></span></div>
<nav><ul class="ez-toc-list ez-toc-list-level-1"><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-1" href="#Prerequisites" title="Prerequisites:">Prerequisites:</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-2" href="#Prepare-and-Update-the-System-and-Install-the-Dependencies" title="Prepare and Update the System and Install the Dependencies">Prepare and Update the System and Install the Dependencies</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-3" href="#Disable-SELinux" title="Disable SELinux">Disable SELinux</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-4" href="#Install-ERPNext" title="Install ERPNext">Install ERPNext</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-5" href="#Configure-MariaDB-MySQL-fork-for-ERPNext" title="Configure MariaDB (MySQL fork) for ERPNext">Configure MariaDB (MySQL fork) for ERPNext</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-6" href="#Install-ERPNext-2" title="Install ERPNext">Install ERPNext</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-7" href="#Starting-ERPNext" title="Starting ERPNext">Starting ERPNext</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-8" href="#Development" title="Development">Development</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-9" href="#Production" title="Production">Production</a></li></ul></nav></div>
<h2 id="h-prerequisites"><span class="ez-toc-section" id="Prerequisites"></span>Prerequisites:<span class="ez-toc-section-end"></span></h2>



<p>Make sure your server meets the following requirements.</p>



<ul><li>2GB of RAM or higher</li><li>2 or more CPU cores</li><li>Fresh CentOS 8 Installation</li><li>Full root access</li></ul>



<h2 id="h-prepare-and-update-the-system-and-install-the-dependencies"><span class="ez-toc-section" id="Prepare-and-Update-the-System-and-Install-the-Dependencies"></span>Prepare and Update the System and Install the Dependencies<span class="ez-toc-section-end"></span></h2>



<p>Log in to your server via SSH:</p>



<pre class="wp-block-preformatted">ssh username@server_ip</pre>



<p>Before starting with the ERPNext installation, it is a good idea to update the system packages to their latest versions.</p>



<pre class="wp-block-preformatted">sudo yum update -y</pre>



<p>Install the extra packages repository:</p>



<pre class="wp-block-preformatted">sudo yum install -y epel-release

</pre>



<p>We can set up ERPNext on two environments, development and production. For the development environment, there will be <code>no Nginx installed</code> and you need to start ERPNext manually. For a production environment, &nbsp;<code>Nginx is installed</code> and the process will be managed by <code>supervisor</code>. You will learn more about supervisor later on in this tutorial.</p>



<p>When installing under a production environment, we need to make sure that we <code>uninstall Apache</code>&nbsp;first as the installer script will set up Nginx. It is also recommended to <code>uninstall MariaDB</code>&nbsp;to avoid conflicts during installation for both production and development. For a development environment, it is safe to leave Apache installed and running as Nginx will not be installed.</p>



<p>To stop and uninstall Apache <code>(required for production set up only)</code>:</p>



<pre class="wp-block-preformatted">sudo systemctl stop httpd
sudo yum remove -y httpd httpd-tools apr apr-util</pre>



<p>To stop and uninstall MariaDB <code>(recommended for both development and production setup)</code>:</p>



<pre class="wp-block-preformatted">sudo systemctl stop mariadb
sudo yum remove -y mariadb mariadb-server
sudo rm -rf /var/lib/mysql /etc/my.cnf</pre>



<p>Install the required packages along with MariaDB, Nginx, NodeJS, redis:</p>



<pre class="wp-block-preformatted">sudo yum install -y gcc make git mariadb mariadb-server nginx supervisor python3 python3-devel python2 python2-devel redis nodejs</pre>



<p>Install Yarn Package Manager:</p>



<pre class="wp-block-preformatted">sudo npm install -g yarn</pre>



<h2 id="h-disable-selinux"><span class="ez-toc-section" id="Disable-SELinux"></span>Disable SELinux<span class="ez-toc-section-end"></span></h2>



<p>In order to avoid setting up complex SELinux rule-set we would need to disable it. Disabling SELinux on CentOS 7 is fairly easy task. You can do that with one command:</p>



<pre class="wp-block-preformatted">echo 0 &gt; /selinux/enforce</pre>



<p>As an alternative you can use the following command:</p>



<pre class="wp-block-preformatted">setenforce 0</pre>



<p>Now, check the status again and make sure it is disabled.</p>



<p>Please note, this will disable SELinux only temporarily. If you want to disable it permanently, you will need to perform the following steps:</p>



<p>Open the <code>/etc/sysconfig/selinux</code> file for editing with a text editor of your choice. We will be using <code>vim</code> in the example below.</p>



<pre class="wp-block-preformatted">vim /etc/sysconfig/selinux</pre>



<p>Once you open the file change the following line:</p>



<pre class="wp-block-preformatted">SELINUX=enforcing</pre>



<p>to</p>



<pre class="wp-block-preformatted">SELINUX=disabled</pre>



<p>Then save and close the file.</p>



<h2 id="h-install-erpnext"><span class="ez-toc-section" id="Install-ERPNext"></span>Install ERPNext<span class="ez-toc-section-end"></span></h2>



<h3 id="h-creating-erpnext-user">Creating ERPNext user</h3>



<p>Once we have installed the required packages we can start with the installation of ERPNext.</p>



<p>We would need an user that will be dedicated to the ERPNext instance and it will have sudo access:</p>



<pre class="wp-block-preformatted">sudo useradd -m erp -G wheel</pre>



<p>The default sudo settings require us to enter the password when we issue the command. You can avoid that with:</p>



<pre class="wp-block-preformatted">sudo sed -i 's/^#\s*\(%wheel\s\+ALL=(ALL)\s\+NOPASSWD:\s\+ALL\)/\1/' /etc/sudoers</pre>



<p>We need to set additional kernel parameters:</p>



<pre class="wp-block-preformatted">echo "vm.overcommit_memory = 1" | sudo tee -a /etc/sysctl.conf
echo "echo never &gt; /sys/kernel/mm/transparent_hugepage/enabled" | sudo tee -a /etc/rc.d/rc.local
sudo chmod 755 /etc/rc.d/rc.local</pre>



<p>We need to do a reboot so the kernel settings can take an effect.</p>



<h2 id="h-configure-mariadb-mysql-fork-for-erpnext"><span class="ez-toc-section" id="Configure-MariaDB-MySQL-fork-for-ERPNext"></span>Configure MariaDB (MySQL fork) for ERPNext<span class="ez-toc-section-end"></span></h2>



<p>Unlike other <a href="https://www.rosehosting.com/blog/how-to-install-odoo-13-on-centos-8/">ERP applications</a> , ERPNext supports MariaDB in order to store the persistent part of the data. Previously we installed the latest available version of MariaDB for CentOS 8 and now we need to configure it for ERPNext.</p>



<p>Create a config file for ERPNext for MariaDB:</p>



<pre class="wp-block-preformatted">cat &lt;&lt;EOF &gt;/etc/my.cnf.d/erpnext.cnf
</pre>


<p>[mysqld]</p>



<p>
innodb-file-format=barracuda
innodb-file-per-table=1
innodb-large-prefix=1
character-set-client-handshake = FALSE
character-set-server = utf8mb4
collation-server = utf8mb4_unicode_ci

</p>


<p>[mysql]</p>



<p>
default-character-set = utf8mb4
EOF
</p>



<p>Enable and start the MariaDB service:</p>



<pre class="wp-block-preformatted">sudo systemctl enable mariadb
sudo systemctl start mariadb</pre>



<p>Start the MariaDB secure installation script (make sure you remember the MariaDB root password). Also, always use a strong passwords if asked:</p>



<pre class="wp-block-preformatted">sudo mysql_secure_installation</pre>



<h2 id="h-install-erpnext-1"><span class="ez-toc-section" id="Install-ERPNext-2"></span>Install ERPNext<span class="ez-toc-section-end"></span></h2>



<p>We will install ERPNext under the new user that we have created, erp.</p>



<p>Change to the ERPNext user and change the working directory to its home directory:</p>



<pre class="wp-block-preformatted">su - erp</pre>



<p>Install frappe-bench with pip3 and initialize version-12:</p>



<pre class="wp-block-preformatted">pip3 install --user frappe-bench
bench init frappe-bench --frappe-branch version-12</pre>



<p>When the initialization is done, you will get the following message:</p>



<pre class="wp-block-preformatted">SUCCESS: Bench frappe-bench initialized</pre>



<p>With the initialized frappe-bench we can create new frappe site for our ERPNext instance.</p>



<p>We need to start the frappe development server:</p>



<pre class="wp-block-preformatted">cd frappe-bench
sed -i '/web:/ s/$/ --noreload/' Procfile
bench start &gt;/tmp/bench_log &amp;</pre>



<p>We need to create a new site with our domain/subdomain name:</p>



<pre class="wp-block-preformatted">bench new-site erp.rosehosting.com</pre>



<p>We will receive a prompt for the MySQL password that we have entered earlier. Enter the MySQL root password.</p>



<p>Now we are ready to download and install ERPNext via bench.</p>



<p>First download the latest ERPNext version with bench:</p>



<pre class="wp-block-preformatted">bench get-app erpnext --branch version-12</pre>



<p>Once downloaded install it:</p>



<pre class="wp-block-preformatted">bench install-app erpnext</pre>



<p>Now we are ready to start and to use ERPNext</p>



<h2 id="h-starting-erpnext"><span class="ez-toc-section" id="Starting-ERPNext"></span>Starting ERPNext<span class="ez-toc-section-end"></span></h2>



<p>On a development environment setup, it is required to start the ERPNext application manually. The ERPNext application listens on port 8000.</p>



<h2 id="h-development"><span class="ez-toc-section" id="Development"></span>Development<span class="ez-toc-section-end"></span></h2>



<pre class="wp-block-preformatted">su - erp
cd frappe-bench
bench start &gt;/tmp/bench_log &amp;</pre>



<p>You can now access your setup at:</p>



<pre class="wp-block-preformatted">http://[domain]:8000
Login: Administrator
Password: The one that you input during installation</pre>



<h2 id="h-production"><span class="ez-toc-section" id="Production"></span>Production<span class="ez-toc-section-end"></span></h2>



<p>At some point of time we would want ERPNext in production mode.</p>



<p>For that we would need to create production files for supervisor and nginx:</p>



<pre class="wp-block-preformatted">su - erp
cd frappe-bench
bench setup supervisor
bench setup nginx</pre>



<p>Add a link of the newly created configuration files to their respective services:</p>



<pre class="wp-block-preformatted">sudo ln -s `pwd`/config/supervisor.conf /etc/supervisord.d/frappe-bench.ini
sudo ln -s `pwd`/config/nginx.conf /etc/nginx/conf.d/frappe-bench.conf</pre>



<p>Change the nginx process owner to be erp by editing <code>/etc/nginx/conf/nginx.conf</code> and changing the user directive to:</p>



<pre class="wp-block-preformatted">user erp erp;</pre>



<p>Supervisor is a process control system that enables you to monitor and control processes on systems running Linux. When supervisor is running, it will automatically start the application at boot and will handle process failures. The installer script automatically configured supervisor for your ERPNext application. You can learn more about supervisor <a href="http://supervisord.org/" target="_blank" rel="noopener noreferrer">here</a>.</p>



<p>Now you can enable and start both supervisor and Nginx:</p>



<pre class="wp-block-preformatted">sudo systemctl enable supervisord
sudo systemctl start supervisord
sudo systemctl enable nginx
sudo systemctl start nginx</pre>



<p>You can now log in to your production website <code>without using port 8000</code> as the Nginx web server is already configured as a reverse proxy for port 8000.</p>



<p>After logging in, you should now be able to finalize the initial setup of your ERPNext application.</p>



<hr class="wp-block-separator"/>



<div class="wp-block-image"><figure class="alignright size-large"><img width="200" height="76" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20200%2076'%3E%3C/svg%3E" alt="install erpnext on centos 8" class="wp-image-35466" title="Installing PHP 8 on Ubuntu 20.04" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/install-erpnext-on-centos-8.jpg 200w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/install-erpnext-on-centos-8-150x57.jpg 150w" data-lazy-sizes="(max-width: 200px) 100vw, 200px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/install-erpnext-on-centos-8.jpg" /><noscript><img width="200" height="76" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/install-erpnext-on-centos-8.jpg" alt="install erpnext on centos 8" class="wp-image-35466" title="Installing PHP 8 on Ubuntu 20.04" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/install-erpnext-on-centos-8.jpg 200w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/install-erpnext-on-centos-8-150x57.jpg 150w" sizes="(max-width: 200px) 100vw, 200px" /></noscript></figure></div>



<p>Of course, you don’t have to <strong>install ERPNext on CentOS 8</strong> if you have a <a href="https://www.rosehosting.com/erpnext-hosting.html">ERPNext VPS</a> with us. You can simply ask our support team to install ERPNext on CentOS 8 for you. They are available 24/7 and will be able to help you with the installation.</p>



<p><span style="color: #ff0000;"><strong>PS</strong></span>. If you enjoyed reading this blog post on How to Install ERPNext on CentOS 8, feel free to share it on social networks using the shortcuts below, or simply leave a comment. Thanks.</p>
		</div>

				<footer class="entry-meta">
			<span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://www.rosehosting.com/blog/category/centos/" rel="category tag">CentOS</a>, <a href="https://www.rosehosting.com/blog/category/cms-crm-erp/" rel="category tag">CMS, CRM, ERP</a>, <a href="https://www.rosehosting.com/blog/category/tutorials/" rel="category tag">Tutorials</a></span> 		<nav id="nav-below" class="post-navigation">
			<span class="screen-reader-text">Post navigation</span>

			<div class="nav-previous"><span class="prev" title="Previous"><a href="https://www.rosehosting.com/blog/how-to-select-the-right-erp-system-for-your-business/" rel="prev">How to Select the Right ERP System for your Business?</a></span></div>		</nav>
				</footer>
			</div>
</article>

			<div class="comments-area">
				<div id="comments">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/how-to-install-erpnext-on-centos-8/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.rosehosting.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea autocomplete="new-password"  id="b365ca0f0b"  name="b365ca0f0b"   cols="45" rows="8" aria-required="true" required></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0 !important;clip:rect(1px, 1px, 1px, 1px) !important;position:absolute !important;white-space:nowrap !important;height:1px !important;width:1px !important;overflow:hidden !important;" tabindex="-1"></textarea><script data-noptimize type="text/javascript">document.getElementById("comment").setAttribute( "id", "a2e27f7a2257ce74fb1b03f6ec7b871a" );document.getElementById("b365ca0f0b").setAttribute( "id", "comment" );</script></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" />
<label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" />

<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="cptch_block"><span class="cptch_title cptch_to_remove">To prove you are human please solve the following<span class="required"> *</span></span><span class="cptch_wrap cptch_math_actions">
				<label class="cptch_label" for="cptch_input_59"><span class="cptch_span">s&#105;x</span>
					<span class="cptch_span">&nbsp;&times;&nbsp;</span>
					<span class="cptch_span">6</span>
					<span class="cptch_span">&nbsp;=&nbsp;</span>
					<span class="cptch_span"><input id="cptch_input_59" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span>
					<input type="hidden" name="cptch_result" value="6TDF" /><input type="hidden" name="cptch_time" value="1614438022" />
					<input type="hidden" name="cptch_form" value="wp_comments" />
				</label><span class="cptch_reload_button_wrap hide-if-no-js">
					<noscript>
						<style type="text/css">
							.hide-if-no-js {
								display: none !important;
							}
						</style>
					</noscript>
					<span class="cptch_reload_button dashicons dashicons-update"></span>
				</span></span></p><p class="comment-form-mailpoet">
      <label for="mailpoet_subscribe_on_comment">
        <input
          type="checkbox"
          id="mailpoet_subscribe_on_comment"
          value="1"
          name="mailpoet[subscribe_on_comment]"
        />&nbsp;Yes, add me to your new blog post notifications list
      </label>
    </p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='32528' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
			</div>

					</main>
	</div>

	<div id="right-sidebar" class="widget-area sidebar is-right-sidebar grid-30 tablet-grid-30 grid-parent" itemtype="https://schema.org/WPSideBar" itemscope>
	<div class="inside-right-sidebar">
		<aside class="widget inner-padding roseh-widget"><a href="https://www.rosehosting.com/erpnext-hosting.html"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20250'%3E%3C/svg%3E" alt="ERPNext Hosting"  width="300" height="250"   data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/12/ERPNext-Hosting.png" /><noscript><img src="https://www.rosehosting.com/blog/wp-content/uploads/2020/12/ERPNext-Hosting.png" alt="ERPNext Hosting"  width="300" height="250"   /></noscript></a></aside><aside id="categories-3" class="widget inner-padding widget_categories"><h2 class="widget-title">Categories</h2><form action="https://www.rosehosting.com/blog" method="get"><label class="screen-reader-text" for="cat">Categories</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="1709">Caching&nbsp;&nbsp;(20)</option>
	<option class="level-0" value="1699">CentOS&nbsp;&nbsp;(301)</option>
	<option class="level-0" value="1710">CMS, CRM, ERP&nbsp;&nbsp;(225)</option>
	<option class="level-0" value="1708">Control Panels&nbsp;&nbsp;(47)</option>
	<option class="level-0" value="1702">Databases&nbsp;&nbsp;(102)</option>
	<option class="level-0" value="1700">Debian&nbsp;&nbsp;(145)</option>
	<option class="level-0" value="1711">E-Commerce&nbsp;&nbsp;(60)</option>
	<option class="level-0" value="1706">Email Servers&nbsp;&nbsp;(36)</option>
	<option class="level-0" value="1236">Guides&nbsp;&nbsp;(48)</option>
	<option class="level-0" value="1705">Load Balancing&nbsp;&nbsp;(1)</option>
	<option class="level-0" value="1">Miscellaneous&nbsp;&nbsp;(45)</option>
	<option class="level-0" value="1701">Networking and Domains&nbsp;&nbsp;(39)</option>
	<option class="level-0" value="3">News&nbsp;&nbsp;(12)</option>
	<option class="level-0" value="1704">Optimization&nbsp;&nbsp;(20)</option>
	<option class="level-0" value="1713">Other&nbsp;&nbsp;(5)</option>
	<option class="level-0" value="4">RoseHosting Platform&nbsp;&nbsp;(16)</option>
	<option class="level-0" value="5">Scripts&nbsp;&nbsp;(11)</option>
	<option class="level-0" value="1703">Security&nbsp;&nbsp;(100)</option>
	<option class="level-0" value="606">SEO&nbsp;&nbsp;(2)</option>
	<option class="level-0" value="21">Tips and Tricks&nbsp;&nbsp;(67)</option>
	<option class="level-0" value="13">Tutorials&nbsp;&nbsp;(758)</option>
	<option class="level-0" value="1698">Ubuntu&nbsp;&nbsp;(358)</option>
	<option class="level-0" value="1712">Web Frameworks&nbsp;&nbsp;(106)</option>
	<option class="level-0" value="1707">Web Servers&nbsp;&nbsp;(133)</option>
</select>
</form>


			</aside><aside class="widget inner-padding roseh-widget"><a href="https://www.rosehosting.com/nvme-hosting.html"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20250'%3E%3C/svg%3E" alt="Managed NVMe VPS Hosting"  width="300" height="250"   data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/11/Managed-NVMe-VPS-Hosting-.png" /><noscript><img src="https://www.rosehosting.com/blog/wp-content/uploads/2020/11/Managed-NVMe-VPS-Hosting-.png" alt="Managed NVMe VPS Hosting"  width="300" height="250"   /></noscript></a></aside><aside id="custom_html-8" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a target="_blank" href="https://www.rosehosting.com/about-us.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">About RoseHosting</a><br>
<a target="_blank" href="https://www.rosehosting.com/linux-vps-hosting/" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Buy a Managed VPS - 25% OFF</a><br>
<a target="_blank" href="https://www.rosehosting.com/reviews.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">RoseHosting Customer Reviews</a><br>
<a target="_blank" href="https://www.rosehosting.com/nvme-hosting.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Managed NVMe VPSes</a><br>
	<a target="_blank" href="https://www.rosehosting.com/dedicated-servers.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Managed NVMe Dedicated Servers</a>
</div></aside><aside id="zoom-social-icons-widget-2" class="widget inner-padding zoom-social-icons-widget">
        
        <ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--align-center zoom-social-icons-list--no-labels">

            
                                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://www.facebook.com/RoseHosting" target="_blank" >
                                                                        
                                                    <span class="screen-reader-text">facebook</span>
                        
                        <span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #3b5998; font-size: 30px; padding:10px" ></span>

                                            </a>
                </li>

            
                                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://twitter.com/rosehosting" target="_blank" >
                                                                        
                                                    <span class="screen-reader-text">twitter</span>
                        
                        <span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#1da1f2" style="background-color : #1da1f2; font-size: 30px; padding:10px" ></span>

                                            </a>
                </li>

            
                                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://www.linkedin.com/company/rose-web-services-l-l-c-" target="_blank" >
                                                                        
                                                    <span class="screen-reader-text">linkedin</span>
                        
                        <span class="zoom-social_icons-list-span social-icon socicon socicon-linkedin" data-hover-rule="background-color" data-hover-color="#0077B5" style="background-color : #0077B5; font-size: 30px; padding:10px" ></span>

                                            </a>
                </li>

            
        </ul>

        </aside><aside id="search-3" class="widget inner-padding widget_search"><form method="get" class="search-form" action="https://www.rosehosting.com/blog/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:">
	</label>
	<input type="submit" class="search-submit" value="Search"></form>
</aside><aside id="recent-posts-widget-with-thumbnails-2" class="widget inner-padding recent-posts-widget-with-thumbnails">
<div id="rpwwt-recent-posts-widget-with-thumbnails-2" class="rpwwt-widget">
	<ul>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-8/" aria-current="page"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to Install erpnext on centos 8" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8.jpg 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8-150x75.jpg" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8-150x75.jpg" class="attachment-75x75 size-75x75" alt="how to Install erpnext on centos 8" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-Install-erpnext-on-centos-8.jpg 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How To Install ERPNext on CentOS 8</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-select-the-right-erp-system-for-your-business/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to select the right erp system for your business?" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-select-the-right-erp-system-for-your-business-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-select-the-right-erp-system-for-your-business-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-select-the-right-erp-system-for-your-business.jpg 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-select-the-right-erp-system-for-your-business-150x75.jpg" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-select-the-right-erp-system-for-your-business-150x75.jpg" class="attachment-75x75 size-75x75" alt="how to select the right erp system for your business?" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-select-the-right-erp-system-for-your-business-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-select-the-right-erp-system-for-your-business-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-select-the-right-erp-system-for-your-business.jpg 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Select the Right ERP System for your Business?</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-odoo-12-on-ubuntu-18-04-with-nginx-as-a-reverse-proxy/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to install odoo 12 on ubuntu 18.04 with nginx as a reverse proxy" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-install-odoo-12-on-ubuntu-18.04-with-nginx-as-a-reverse-proxy-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-install-odoo-12-on-ubuntu-18.04-with-nginx-as-a-reverse-proxy-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-install-odoo-12-on-ubuntu-18.04-with-nginx-as-a-reverse-proxy.jpg 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-install-odoo-12-on-ubuntu-18.04-with-nginx-as-a-reverse-proxy-150x75.jpg" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-install-odoo-12-on-ubuntu-18.04-with-nginx-as-a-reverse-proxy-150x75.jpg" class="attachment-75x75 size-75x75" alt="how to install odoo 12 on ubuntu 18.04 with nginx as a reverse proxy" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-install-odoo-12-on-ubuntu-18.04-with-nginx-as-a-reverse-proxy-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-install-odoo-12-on-ubuntu-18.04-with-nginx-as-a-reverse-proxy-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/05/how-to-install-odoo-12-on-ubuntu-18.04-with-nginx-as-a-reverse-proxy.jpg 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Install Odoo 12 on Ubuntu 18.04 with Nginx as a Reverse Proxy</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-mongodb-on-ubuntu-20-04-and-centos-8/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to install mongodb on ubuntu 20.04 and centos 8" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/01/how-to-install-mongodb-on-ubuntu-20.04-and-centos-8-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/01/how-to-install-mongodb-on-ubuntu-20.04-and-centos-8-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/01/how-to-install-mongodb-on-ubuntu-20.04-and-centos-8.jpg 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/01/how-to-install-mongodb-on-ubuntu-20.04-and-centos-8-150x75.jpg" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/01/how-to-install-mongodb-on-ubuntu-20.04-and-centos-8-150x75.jpg" class="attachment-75x75 size-75x75" alt="how to install mongodb on ubuntu 20.04 and centos 8" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/01/how-to-install-mongodb-on-ubuntu-20.04-and-centos-8-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/01/how-to-install-mongodb-on-ubuntu-20.04-and-centos-8-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/01/how-to-install-mongodb-on-ubuntu-20.04-and-centos-8.jpg 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Install MongoDB on Ubuntu 20.04 and CentOS 8</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-ethercalc-on-centos-8/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to install ethercalc on centos 8" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/01/how-to-install-ethercalc-on-centos-8-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/01/how-to-install-ethercalc-on-centos-8-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/01/how-to-install-ethercalc-on-centos-8.jpg 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/01/how-to-install-ethercalc-on-centos-8-150x75.jpg" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/01/how-to-install-ethercalc-on-centos-8-150x75.jpg" class="attachment-75x75 size-75x75" alt="how to install ethercalc on centos 8" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/01/how-to-install-ethercalc-on-centos-8-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/01/how-to-install-ethercalc-on-centos-8-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/01/how-to-install-ethercalc-on-centos-8.jpg 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Install EtherCalc on CentOS 8</span></a></li>
	</ul>
</div><!-- .rpwwt-widget -->
</aside>      <aside id="mailpoet_form-2" class="widget inner-padding widget_mailpoet_form">
  
  
  <div class="
    mailpoet_form_popup_overlay
      "></div>
  <div
    id="mailpoet_form_2"
    class="
      mailpoet_form
      mailpoet_form_widget
      mailpoet_form_position_
      mailpoet_form_animation_
    "
      >
    
    <style type="text/css">
     .mailpoet_hp_email_label{display:none!important;}#mailpoet_form_2 .mailpoet_form {  }
#mailpoet_form_2 form { margin-bottom: 0; }
#mailpoet_form_2 p.mailpoet_form_paragraph { margin-bottom: 10px; }
#mailpoet_form_2 .mailpoet_column_with_background { padding: 10px; }
#mailpoet_form_2 .mailpoet_form_column:not(:first-child) { margin-left: 20px; }
#mailpoet_form_2 .mailpoet_paragraph { line-height: 20px; margin-bottom: 20px; }
#mailpoet_form_2 .mailpoet_segment_label, #mailpoet_form_2 .mailpoet_text_label, #mailpoet_form_2 .mailpoet_textarea_label, #mailpoet_form_2 .mailpoet_select_label, #mailpoet_form_2 .mailpoet_radio_label, #mailpoet_form_2 .mailpoet_checkbox_label, #mailpoet_form_2 .mailpoet_list_label, #mailpoet_form_2 .mailpoet_date_label { display: block; font-weight: normal; }
#mailpoet_form_2 .mailpoet_text, #mailpoet_form_2 .mailpoet_textarea, #mailpoet_form_2 .mailpoet_select, #mailpoet_form_2 .mailpoet_date_month, #mailpoet_form_2 .mailpoet_date_day, #mailpoet_form_2 .mailpoet_date_year, #mailpoet_form_2 .mailpoet_date { display: block; }
#mailpoet_form_2 .mailpoet_text, #mailpoet_form_2 .mailpoet_textarea { width: 200px; }
#mailpoet_form_2 .mailpoet_checkbox {  }
#mailpoet_form_2 .mailpoet_submit {  }
#mailpoet_form_2 .mailpoet_divider {  }
#mailpoet_form_2 .mailpoet_message {  }
#mailpoet_form_2 .mailpoet_form_loading { width: 30px; text-align: center; line-height: normal; }
#mailpoet_form_2 .mailpoet_form_loading &gt; span { width: 5px; height: 5px; background-color: #5b5b5b; }#mailpoet_form_2{border-radius: 0px;background: #ffffff;text-align: left;}#mailpoet_form_2 form.mailpoet_form {padding: 10px;}#mailpoet_form_2{width: 100%;}#mailpoet_form_2 .mailpoet_message {margin: 0; padding: 0 20px;}
        #mailpoet_form_2 .mailpoet_validate_success {color: #00d084}
        #mailpoet_form_2 input.parsley-success {color: #00d084}
        #mailpoet_form_2 select.parsley-success {color: #00d084}
        #mailpoet_form_2 textarea.parsley-success {color: #00d084}
      
        #mailpoet_form_2 .mailpoet_validate_error {color: #cf2e2e}
        #mailpoet_form_2 input.parsley-error {color: #cf2e2e}
        #mailpoet_form_2 select.parsley-error {color: #cf2e2e}
        #mailpoet_form_2 textarea.textarea.parsley-error {color: #cf2e2e}
        #mailpoet_form_2 .parsley-errors-list {color: #cf2e2e}
        #mailpoet_form_2 .parsley-required {color: #cf2e2e}
        #mailpoet_form_2 .parsley-custom-error-message {color: #cf2e2e}
      #mailpoet_form_2 .mailpoet_paragraph.last {margin-bottom: 0} @media (max-width: 500px) {#mailpoet_form_2 {background: #ffffff;}} @media (min-width: 500px) {#mailpoet_form_2 .last .mailpoet_paragraph:last-child {margin-bottom: 0}}  @media (max-width: 500px) {#mailpoet_form_2 .mailpoet_form_column:last-child .mailpoet_paragraph:last-child {margin-bottom: 0}} 
    </style>

    <form
      target="_self"
      method="post"
      action="https://www.rosehosting.com/blog/wp-admin/admin-post.php?action=mailpoet_subscription_form"
      class="mailpoet_form mailpoet_form_form mailpoet_form_widget"
      novalidate
      data-delay=""
      data-exit-intent-enabled=""
      data-font-family=""
    >
      <input type="hidden" name="data[form_id]" value="2" />
      <input type="hidden" name="token" value="7b0a7c0179" />
      <input type="hidden" name="api_version" value="v1" />
      <input type="hidden" name="endpoint" value="subscribers" />
      <input type="hidden" name="mailpoet_method" value="subscribe" />

      <label class="mailpoet_hp_email_label">Please leave this field empty<input type="email" name="data[email]"/></label><h2 class="mailpoet-heading  mailpoet-has-font-size" id="" style="text-align: center; color: #0081ff; font-size: 20px; line-height: 1.5"><span style="font-family: Montserrat" data-font="Montserrat" class="mailpoet-has-font"><strong><span class="has-inline-color has-black-color">Join our Blog</span></strong></span></h2>
<p class="mailpoet_form_paragraph  mailpoet-has-font-size" style="text-align: center; color: #000000; font-size: 14px; line-height: 1.5"><strong><span style="font-family: Montserrat" data-font="Montserrat" class="mailpoet-has-font">Sign up and receive notifications as soon as new content is posted.</span></strong></p>
<div class="mailpoet_paragraph "><input type="email" class="mailpoet_text" name="data[form_field_ZTVlY2IyMzIyMzFkX2VtYWls]" title="Enter your e-mail" value="" style="width:100%;padding:12px;margin: 0 auto 0 0;font-size:15px;line-height:1.5;height:auto;" data-automation-id="form_email"  placeholder="Enter your e-mail *" data-parsley-required="true" data-parsley-minlength="6" data-parsley-maxlength="150" data-parsley-error-message="Please specify a valid email address." data-parsley-required-message="This field is required."/></div>
<div class="mailpoet_paragraph "><input type="submit" class="mailpoet_submit" value="Subscribe" data-automation-id="subscribe-submit-button" style="width:100%;padding:12px;margin: 0 auto 0 0;font-size:15px;line-height:1.5;height:auto;border-color:transparent;" /><span class="mailpoet_form_loading"><span class="mailpoet_bounce1"></span><span class="mailpoet_bounce2"></span><span class="mailpoet_bounce3"></span></span></div>

      <div class="mailpoet_message">
        <p class="mailpoet_validate_success"
                style="display:none;"
                >Check your inbox or spam folder to confirm your subscription.
        </p>
        <p class="mailpoet_validate_error"
                style="display:none;"
                >        </p>
      </div>
    </form>
  </div>

      </aside>
  	</div>
</div>
</div>

  <!-- footer-big-menu.html -->
  <footer class="footer-big-menu">
    <div class="container" style="max-width: 1100px;">

      <div class="row menu">

        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title mb-2">Company</h3>
            <a class="menu-link" href="https://www.rosehosting.com/about-us.html">About us</a>
            <a class="menu-link" href="https://www.rosehosting.com/policies.html">Our Policies</a>
            <a class="menu-link" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
            <a class="menu-link" href="https://www.rosehosting.com/blog/">Blog</a>
            <a class="menu-link" href="https://www.rosehosting.com/why-rosehosting.html">Why RoseHosting</a>
            <a class="menu-link" href="https://www.rosehosting.com/compare-to-competition.html">Compare Us</a>
            <a class="menu-link" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
            <a class="menu-link" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Support</h3>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Helpdesk System</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>

          <h3 class="menu-title  mb-2 mt-4">Other Services</h3>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Domain Registration</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Domain Transfer</a>
          <a class="menu-link" href="https://www.rosehosting.com/ssl-certificates.html">SSL Certificates</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/linux-vps-hosting/">Linux VPS Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom SSD VPS</a>
          <a class="menu-link" href="https://www.rosehosting.com/dedicated-servers.html">Cloud Dedicated Servers</a>
          <a class="menu-link" href="https://www.rosehosting.com/hosting-solutions.html">Hosting Solutions</a>
          <a class="menu-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Recurr. Affiliate Program</a>
          <a class="menu-link" href="https://www.rosehosting.com/cpa-hosting-affiliate-program.html">CPA Affiliate Program</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Linux VPS Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/centos-hosting.html">CentOS Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/ubuntu-hosting.html">Ubuntu Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/debian-hosting.html">Debian Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/opensuse-hosting.html">OpenSUSE Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/arch-linux-hosting.html">Arch-Linux Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/scientific-linux-hosting.html">Scientific Linux Hosting</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Apps Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/wordpress-hosting.html">WordPress Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/magento-hosting.html">Magento Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/odoo-hosting.html">Odoo Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/joomla-hosting.html">Joomla Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/drupal-hosting.html">Drupal Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/laravel-hosting.html">Laravel Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/nextcloud-hosting.html">NextCloud Hosting</a>

          <a class="menu-link" href="https://www.rosehosting.com/prestashop-hosting.html">PrestaShop Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/ghost-hosting.html">Ghost Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/mediawiki-hosting.html">MediaWiki Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/tomcat-hosting.html">Tomcat Hosting</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title mb-2">Contact Us</h3>
          <a class="menu-link" href="tel:+18887673467">(888) ROSE-HOST</a>
          <a class="menu-link" href="tel:+18887673467">(888) 767-3467</a>
          <a class="menu-link" href="tel:+13142750414">(314) 275-0414</a>
          <a class="menu-link" href="mailto:%73%75%70%70%6f%72%74%40%72%6f%73%65%68%6f%73%74%69%6e%67%2e%63%6f%6d">Email us</a>

          <h3 class="menu-title mb-2 mt-4">Connect</h3>
          <a class="menu-link" href="https://twitter.com/rosehosting" target="_blank"><i class="fa fa-twitter fa-fw"></i> Twitter</a>
          <a class="menu-link" href="https://www.facebook.com/RoseHosting" target="_blank"><i class="fa fa-facebook fa-fw"></i> Facebook</a>
          <a class="menu-link" href="https://www.linkedin.com/in/rosehosting/" target="_blank"><i class="fa fa-linkedin fa-fw"></i> LinkedIn</a>
          <a class="menu-link" href="https://www.rosehosting.com/blog/feed/" target="_blank"><i class="fa fa-rss fa-fw"></i> RSS Feed</a>

        </div>

      </div>

    </div>

<br>
    <div class="bottom">
      <div class="container" style="max-width: 1100px;">
        <div class="row">

          <div class="col-md-12 col-lg-6">
              <p class="text-sm-left"><a class="inline-link footer-policy" href="/tos.html">Terms of Service</a> and <a class="inline-link footer-policy" href="/policies.html">other policies</a></p>
          </div>
          <div class="col-md-12 col-lg-6">
            <p class="text-sm-right">&copy; 2001-2021 <a class="inline-link footer-policy" href="https://www.rosewebservices.com/">Rose Web Services LLC</a>.</p>
          </div>
         </div>
      </div>
    </div>

<!-- livezilla.net code
<script type="text/javascript" id="aff1f81b02f303eea5f87a3a065f153a" src="https://linuxhostsupport.com/chat//script.php?id=aff1f81b02f303eea5f87a3a065f153a"></script>
http://www.livezilla.net -->




<!--[if lte IE 11]>
<script src='https://www.rosehosting.com/blog/wp-content/themes/generatepress/assets/js/classList.min.js' id='generate-classlist-js'></script>
<![endif]-->
<script id='generate-main-js-extra'>
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>







<script id='ez-toc-js-js-extra'>
var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"","width":"95%","scroll_offset":"30"};
</script>

<script id='mailpoet_public-js-extra'>
var MailPoetForm = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","is_rtl":""};
</script>


<script id='cptch_front_end_script-js-extra'>
var cptch_vars = {"nonce":"54f7e831cc","ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","enlarge":"","time_limit":"120"};
</script>

<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.rosehosting.com/blog/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>
<script src="https://www.rosehosting.com/blog/wp-content/cache/min/1/c8c859261ea05cdf41d1661938068288.js" data-minify="1" defer></script></body>
</html>

<!-- Cached for great performance - Debug: cached@1614438022 -->