<!DOCTYPE html> <!--[if IE 6]><html id="ie6" lang="en-US"> <![endif]--> <!--[if IE 7]><html id="ie7" lang="en-US"> <![endif]--> <!--[if IE 8]><html id="ie8" lang="en-US"> <![endif]--> <!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!--><html lang="en-US"> <!--<![endif]--><head><link rel="stylesheet" type="text/css" href="https://www.rosehosting.com/blog/?x70227&amp;w3tc_minify=0b22d.css" media="all" /><meta charset="UTF-8" /><meta http-equiv="X-UA-Compatible" content="IE=edge"><link rel="pingback" href="https://www.rosehosting.com/blog/xmlrpc.php" /><!--[if lt IE 9]> <script src="https://www.rosehosting.com/blog/wp-content/themes/Extra/scripts/ext/html5.js?x70227" defer " type="text/javascript"></script> <![endif]--> <script>/*<![CDATA[*/(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-P4FHJW');/*]]>*/</script>  <script type="text/javascript">document.documentElement.className='js';</script> <script>/*<![CDATA[*/var et_site_url='https://www.rosehosting.com/blog';var et_post_id='27916';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}/*]]>*/</script><title>How to Install Invoice Ninja on CentOS 7 | RoseHosting</title><link rel="author" href="https://plus.google.com/+RoseHosting" /><meta name="description"  content="This tutorial covers the installation of Invoice Ninja onto Centos 7 VPS with Apache, PHP and MariaDB. Invoice Ninja is free and self-hosted platform for" /><link rel="canonical" href="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/" /><meta property="og:title" content="How to Install Invoice Ninja on CentOS 7" /><meta property="og:type" content="article" /><meta property="og:url" content="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/" /><meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2018/08/How-to-Install-Invoice-Ninja-on-CentOS-7.jpg" /><meta property="og:site_name" content="RoseHosting.com Blog" /><meta property="og:description" content="This tutorial covers the installation of Invoice Ninja onto Centos 7 VPS with Apache, PHP and MariaDB. Invoice Ninja is free and self-hosted platform for invoicing, billing and payment management based on Laravel. It is very easy to use and it can be integrated with most of the popular payment gateways, including PayPal, 2CheckOut, Stripe, WePay, and many more... which makes it a perfect solution for freelancers and small or medium sized businesses. - Create invoices and quotations in no time - Easy time tracking &amp; task creation. - Send invoices and accept online payments - Integrate with 30+ gateways including: Stripe, PayPal, Authorize and Dwolla - Easily create quotes and invoices online - Custom invoice URL&#039;s Company.InvoiceNinja.com - iOS and Android apps Prerequisites - CentOS 7 VPS with 2GB of RAM - SSH access with root privileges - PHP version 5.5.9 or newer - MySQL/MariaDB database server - Apache/Nginx web server Login via SSH and update the server We will install Invoice" /><meta property="article:tag" content="centos" /><meta property="article:tag" content="tutorials" /><meta property="article:tag" content="invoice ninja" /><meta property="article:publisher" content="https://www.facebook.com/RoseHosting/" /><meta property="article:author" content="https://www.facebook.com/RoseHosting/" /><meta property="article:published_time" content="2018-08-29T09:14:03Z" /><meta property="article:modified_time" content="2018-08-29T09:17:00Z" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@RoseHosting" /><meta name="twitter:creator" content="@rosehosting" /><meta name="twitter:title" content="How to Install Invoice Ninja on CentOS 7" /><meta name="twitter:description" content="This tutorial covers the installation of Invoice Ninja onto Centos 7 VPS with Apache, PHP and MariaDB. Invoice Ninja is free and self-hosted platform for invoicing, billing and payment management based on Laravel. It is very easy to use and it can be integrated with most of the popular payment gateways, including PayPal, 2CheckOut, Stripe, WePay, and many more... which makes it a perfect solution for freelancers and small or medium sized businesses. - Create invoices and quotations in no time - Easy time tracking &amp; task creation. - Send invoices and accept online payments - Integrate with 30+ gateways including: Stripe, PayPal, Authorize and Dwolla - Easily create quotes and invoices online - Custom invoice URL&#039;s Company.InvoiceNinja.com - iOS and Android apps Prerequisites - CentOS 7 VPS with 2GB of RAM - SSH access with root privileges - PHP version 5.5.9 or newer - MySQL/MariaDB database server - Apache/Nginx web server Login via SSH and update the server We will install Invoice" /><meta name="twitter:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2018/08/How-to-Install-Invoice-Ninja-on-CentOS-7.jpg" /><link rel="amphtml" href="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/amp/" /><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Feed" href="https://www.rosehosting.com/blog/feed/" /><link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Comments Feed" href="https://www.rosehosting.com/blog/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; How to Install Invoice Ninja on CentOS 7 Comments Feed" href="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/feed/" /> <script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.rosehosting.com\/blog\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script> <script>/*<![CDATA[*/advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();/*]]>*/</script><meta content="rh2018 v.1.0.0" name="generator"/><style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0 .07em !important;vertical-align:-0.1em !important;background:none !important;padding:0 !important}</style><link rel='stylesheet' id='font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.9.8' type='text/css' media='all' /><link rel='stylesheet' id='et-builder-googlefonts-cached-css'  href='https://fonts.googleapis.com/css?family=Cabin%3Aregular%2Citalic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic&#038;ver=4.9.8#038;subset=latin,latin-ext' type='text/css' media='all' /> <script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery.js?x70227&amp;ver=1.12.4'></script> <script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery-migrate.min.js?x70227&amp;ver=1.4.1' defer '></script> <script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/popper.js/1.11.0/umd/popper.min.js?ver=1.11' defer '></script> <script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2018/js/bootstrap.js?x70227&amp;ver=4' defer '></script> <script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2018/js/cookieconsent.min.js?x70227&amp;ver=1' defer '></script> <link rel='https://api.w.org/' href='https://www.rosehosting.com/blog/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rosehosting.com/blog/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rosehosting.com/blog/wp-includes/wlwmanifest.xml" /><link rel='prev' title='How to Enforce Password Quality in Linux' href='https://www.rosehosting.com/blog/how-to-enforce-password-quality-in-linux/' /><link rel='next' title='How to Install Invoice Ninja on Debian 9' href='https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-debian-9/' /><meta name="generator" content="WordPress 4.9.8" /><link rel='shortlink' href='https://www.rosehosting.com/blog/?p=27916' /><link rel="alternate" type="application/json+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-install-invoice-ninja-on-centos-7%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-install-invoice-ninja-on-centos-7%2F&#038;format=xml" /><meta property="fb:pages" content="195648843783690" /><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /> <script type="text/javascript">/*<![CDATA[*/var essb_settings={"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","essb3_nonce":"17ab3c7bfb","essb3_plugin_url":"https:\/\/www.rosehosting.com\/blog\/wp-content\/plugins\/easy-social-share-buttons3","essb3_stats":false,"essb3_ga":false,"essb3_ga_mode":"simple","blog_url":"https:\/\/www.rosehosting.com\/blog\/","essb3_postfloat_stay":false,"post_id":27916};var essb_buttons_exist=!!document.getElementsByClassName("essb_links");if(essb_buttons_exist==true){document.addEventListener("DOMContentLoaded",function(event){var ESSB_CACHE_URL="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/";if(ESSB_CACHE_URL.indexOf("?")>-1){ESSB_CACHE_URL+="&essb_counter_cache=rebuild";}else{ESSB_CACHE_URL+="?essb_counter_cache=rebuild";};var xhr=new XMLHttpRequest();xhr.open("GET",ESSB_CACHE_URL,true);xhr.send();});}/*]]>*/</script><style type="text/css">.broken_link,a.broken_link{text-decoration:line-through}</style><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-192x192.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-180x180.png" /><meta name="msapplication-TileImage" content="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-270x270.png" /></head><body class="post-template-default single single-post postid-27916 single-format-standard et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et_minified_js et_minified_css"><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-P4FHJW" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="page-container" class="page-container"><nav class="navbar yamm navbar-expand-lg navbar-dark" role="navigation"><div class="container no-override"><a class="navbar-brand" href="https://www.rosehosting.com/"> <img alt="RoseHosting.com" width="186" height="37"  class="d-lg-inline mr-2" src="https://www.rosehosting.com/blog/wp-content/themes/rh2018/img/rh-logo.svg" /> </a><button class="navbar-toggler" data-toggle="collapse" data-target="#navbar-collapse"> <span class="navbar-toggler-icon"></span> </button><div class="collapse navbar-collapse justify-content-end" id="navbar-collapse"><ul class="navbar-nav"><li class="nav-item active dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> Hosting Solutions <i class="fa fa-chevron-down"></i> </a><div class="dropdown-menu" role="menu"><div class="yamm-content"><div class="row"><div class="col-sm-6"> <span class="text-primary  dropdown-header"><strong>Managed SSD Hosting</strong></span><div class="dropdown-divider"></div> <a class="dropdown-item" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a> <a class="dropdown-item" href="https://www.rosehosting.com/vps-hosting.html">VPS Hosting</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom VPS</a> <a class="dropdown-item" href="https://www.rosehosting.com/cloud-hosting.html">Cloud Hosting</a> <a class="dropdown-item" href="https://www.rosehosting.com/dedicated-servers.html">Cloud Dedicated Servers</a></div><div class="col-sm-6"> <span class="text-primary dropdown-header"><strong>Managed Solutions</strong></span><div class="dropdown-divider"></div> <a class="dropdown-item" href="https://www.rosehosting.com/wordpress-hosting.html"> Wordpress Hosting <small class="d-block text-muted"><i>The best blogging platform</i></small> </a> <a class="dropdown-item" href="https://www.rosehosting.com/magento-hosting.html"> Magento Hosting <small class="d-block text-muted"><i>The best e-commerce platform</i></small> </a> <a class="dropdown-item" href="https://www.rosehosting.com/odoo-hosting.html"> Odoo Hosting <small class="d-block text-muted"><i>The best CRM/ERP platform</i></small> </a> <span class="dropdown-item"><a class="btn-shadow btn-shadow-primary btn-shadow-sm" target="_blank" href="#">Other Solutions</a></span></div></div></div></div></li><li class="nav-item dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> SSL / Domains <i class="fa fa-chevron-down"></i> </a><div class="dropdown-menu" role="menu"><div class="yamm-content"><div class="row"><div class="col-sm-3"> <span class="text-primary  dropdown-header"><strong>SSL by brand</strong></span><div class="dropdown-divider"></div> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#geotrust">GeoTrust</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#comodo">Comodo</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#rapidssl">RapidSSL</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#thawte">Thawte</a></div><div class="col-sm-4"><span class="text-primary  dropdown-header"><strong>SSL by Type</strong></span><div class="dropdown-divider"></div> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#domain_validation">Domain Validation</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#organization_validation">Organization Validation</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#extended_validation">Extended Validation</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#wildcard_ssl">Wildcard SSL</a></div><div class="col-sm-3"> <span class="text-primary dropdown-header"><strong>Domains</strong></span><div class="dropdown-divider"></div> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Register Domains</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Transfer Domains</a></div></div></div></div><li class="nav-item dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> Support <i class="fa fa-chevron-down"></i> </a><div class="dropdown-menu" role="menu"> <a class="dropdown-item" href="https://www.rosehosting.com/support.html">24/7 Managed Support</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Open a Support Ticket</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a> <a class="dropdown-item" href="https://status.rosehosting.com">Systems Status</a></div></li><li class="nav-item dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> About Us <i class="fa fa-chevron-down"></i> </a><div class="dropdown-menu" role="menu"> <a class="dropdown-item" href="https://www.rosehosting.com/about-us.html">Our Company</a> <a class="dropdown-item" href="https://www.rosehosting.com/contact-us.html">Contact Us</a> <a class="dropdown-item" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a> <a class="dropdown-item" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a> <a class="dropdown-item" href="https://www.rosehosting.com/policies.html">Our Policies</a></div></li><li class="nav-item"> <a class="nav-link" href="https://www.rosehosting.com/blog/">Blog</a></li><li class="nav-item"> <a class="nav-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Affiliates</a></li><li class="nav-item"> <a class="nav-link nav-link--rounded" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Login</a></li></ul></div></div> </nav><nav class="navbar navbar-expand-md navbar-light bg-faded navbar-blog"><div class="container no-override"> <a href="https://www.rosehosting.com/blog/" class="navbar-brand">Blog Home</a><div class="navbar-collapse collapse d-flex justify-content-between" id="navbar5-blog"><ul class="navbar-nav categories"><li class="nav-item dropdown"> <a class="nav-link dropdown-toggle" data-toggle="dropdown" href="#" role="button" aria-haspopup="true" aria-expanded="false"> Categories <i class="fa fa-chevron-down"></i> </a><div class="dropdown-menu"> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/caching/">Caching</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/centos/">CentOS</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/cms-crm-erp/">CMS, CRM, ERP</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/control-panels/">Control Panels</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/databases/">Databases</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/debian/">Debian</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/e-commerce/">E-Commerce</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/email-servers/">Email Servers</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/guides/">Guides</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/miscellaneous/">Miscellaneous</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/networking-and-domains/">Networking and Domains</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/news/">News</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/optimization/">Optimization</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/rosehosting/">RoseHosting Platform</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/scripts/">Scripts</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/security/">Security</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/seo/">SEO</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tips-and-tricks/">Tips and Tricks</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tutorials/">Tutorials</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/ubuntu/">Ubuntu</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-frameworks/">Web Frameworks</a> <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-servers/">Web Servers</a></div></li></ul><form class="mx-2 my-auto d-inline" method="get" id="searchform" action="https://www.rosehosting.com/blog/"><div class="input-group"> <input type="search" class="field" name="s" id="s" class="form-control border border-right-0" placeholder="Search..."> <span class="input-group-append"> <button name="submit" id="searchsubmit" class="btn btn-outline-secondary border border-left-0" type="submit"> <i class="fa fa-search"></i> </button> </span></div></form></div></div> </nav><div id="main-content"><div class="container"><div id="content-area" class="clearfix"><div class="et_pb_extra_column_main"> <article id="post-27916" class="module single-post-module post-27916 post type-post status-publish format-standard has-post-thumbnail hentry category-centos category-tutorials tag-centos tag-invoice-ninja et-has-post-format-content et_post_format-et-post-format-standard"><div class="post-header"><h1 class="entry-title">How to Install Invoice Ninja on CentOS 7</h1><div class="post-meta vcard"><p><span class="updated">Aug 29, 2018</span> | <a href="https://www.rosehosting.com/blog/category/centos/" rel="tag">CentOS</a>, <a href="https://www.rosehosting.com/blog/category/tutorials/" rel="tag">Tutorials</a> | <a class="comments-link" href="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a></p></div></div><div class="post-thumbnail header"> <img src="https://www.rosehosting.com/blog/wp-content/uploads/2018/08/How-to-Install-Invoice-Ninja-on-CentOS-7.jpg" alt="How to Install Invoice Ninja on CentOS 7" /></div><div class="post-wrap"><div class="post-content entry-content"><p><img class="alignnone size-full wp-image-27930" src="https://www.rosehosting.com/blog/wp-content/uploads/2018/08/How-to-Install-Invoice-Ninja-on-CentOS-7.jpg" alt="How to Install Invoice Ninja on CentOS 7" width="742" height="372" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2018/08/How-to-Install-Invoice-Ninja-on-CentOS-7.jpg 742w, https://www.rosehosting.com/blog/wp-content/uploads/2018/08/How-to-Install-Invoice-Ninja-on-CentOS-7-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2018/08/How-to-Install-Invoice-Ninja-on-CentOS-7-300x150.jpg 300w" sizes="(max-width: 742px) 100vw, 742px"></p><div class="roseh-after-first-image" style="float: right; " id="roseh-833675901"><div style="float: right; margin-left: 10px; " id="roseh-1188685236"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="2385735863"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><p>This tutorial covers the installation of Invoice Ninja onto <a href="https://www.rosehosting.com/centos-hosting.html" target="_blank" rel="noopener">Centos 7 VPS</a> with Apache, PHP and MariaDB. Invoice Ninja is free and self-hosted platform for invoicing, billing and payment management based on Laravel. It is very easy to use and it can be integrated with most of the popular payment gateways, including PayPal, 2CheckOut, Stripe, WePay, and many more… which makes it a perfect solution for freelancers and small or medium sized businesses.<span id="more-27916"></span></p><p>– Create invoices and quotations in no time<br> – Easy time tracking &amp; task creation.<br> – Send invoices and accept online payments<br> – Integrate with 30+ gateways including: Stripe, PayPal, Authorize and Dwolla<br> – Easily create quotes and invoices online<br> – Custom invoice URL’s Company.InvoiceNinja.com<br> – iOS and Android apps</p><h3><strong>Prerequisites</strong></h3><p>– CentOS 7 VPS with 2GB of RAM<br> – SSH access with root privileges<br> – PHP version 5.5.9 or newer<br> – MySQL/MariaDB database server<br> – Apache/Nginx web server</p><h3><strong>Login via SSH and update the server</strong></h3><p>We will install Invoice Ninja through the command line interface, so first we need to login to the CentOS 7 VPS via SSH as user root</p><pre>ssh root@IP_Address -p Port_Number</pre><p>Once you are logged in, don’t forget to update all packages installed on the server</p><pre>yum -y update</pre><h3><strong>Install Apache web server</strong></h3><p>Apache can be easily installed from the official CentoOS 7 repositories using the following command</p><pre>yum -y install httpd</pre><p>After the installation manager complete the installation, start the web server and enable it to start automatically after a restart</p><pre>systemctl start httpd
systemctl enable httpd</pre><h3><strong>Install PHP 7</strong></h3><p>CentOS 7 by default comes with PHP 5.4 which has reached the end of life and it is no longer supported. So, in this tutorial we will install PHP 7 instead. For this purpose we have to add the Webtatic EL yum repository.</p><pre>yum -y install epel-release
rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm</pre><p>Once the repository is added, we can proceed to install PHP and several PHP modules</p><pre>yum install php70w php70w-common php70w-curl php70w-mysql php70w-mbstring php70w-mcrypt php70w-xml php70w-cli php70w</pre><p>verify that PHP 7 is installed</p><pre>php -v
PHP 7.0.31 (cli) (built: Jul 20 2018 08:55:22) ( NTS )
Copyright (c) 1997-2017 The PHP Group</pre><h3><strong>Install MariaDB database server</strong></h3><p>Invoice Ninja stores its information in a database. So, we will install MariaDB database server and create a new database along with a user able to access it. Run the following command to install MariaDB server</p><pre>yum -y install mariadb</pre><p>Start the server and enable it to start upon reboot</p><pre>systemctl start mariadb
systemctl enable mariadb</pre><p>Run the ‘mysql_secure_installation’ post installation script to secure your MariaDB server and set a password for the MySQL ‘root’ user.</p><p>Next, login to the database server as user root,</p><pre>mysql -u root -p

MariaDB [(none)]&gt; CREATE DATABASE ninja;
MariaDB [(none)]&gt; CREATE USER 'user'@'localhost' IDENTIFIED BY 'PASSWORD';
MariaDB [(none)]&gt; GRANT ALL PRIVILEGES ON ninja.* TO 'user'@'localhost';
MariaDB [(none)]&gt; FLUSH PRIVILEGES
MariaDB [(none)]&gt; exit</pre><p>Replace ‘PASSWORD’ with an actual strong password.</p><h3><strong>Install and Configure Invoice Ninja</strong></h3><p>Download the latest stable of Invoice Ninja to your server. At the moment of writing this article it is version 4.5.3</p><pre>curl -L https://download.invoiceninja.com/ -o invoiceninja.zip</pre><p>unpack the downloaded ZIP file to the document root the directory of your server. The ZIP file includes all necessary third party libraries.</p><pre>unzip invoiceninja.zip -d /var/www/html</pre><p>The content of Invoice Ninja will be stored in a new ‘ninja’ directory.</p><p>Configure Invoice Ninja to use the newly created MariaDB database</p><pre>cd /var/www/html/ninja/
cp -v .env.example .env</pre><p>Open the .env file and find and modify the following lines</p><pre>DB_DATABASE=ninja
DB_USERNAME=user
DB_PASSWORD=PASSWORD</pre><p>Save the changes and run the following commands necessary to prepare the MariaDB database</p><pre>php artisan migrate
php artisan db:seed</pre><p>Set the correct ownership to the Invoice Ninja directory</p><pre>chown -R apache:apache /var/www/html/ninja</pre><h3><strong>Create Apache virtual host</strong></h3><p>In order to be able to access Invoice Ninja with your domain name, we will create Apche virtual host for the domain.</p><p>Create a new virtual host directive with the following content</p><pre>vi /etc/httpd/conf.d/invoiceninja.conf

ServerAdmin admin@your-domain.com
DocumentRoot /var/www/html/ninja/public
ServerName your-domain.com
ServerAlias www.your-domain.com

Options +FollowSymlinks
AllowOverride Al

ErrorLog /var/log/httpd/invoiceninja-error_log
CustomLog /var/log/httpd/invoiceninja-access_log common
</pre><p>Save the file and restart the web server for the changes to take effect</p><pre>systemctl restart httpd</pre><p>If you closely followed the tutorial, with this step the installation of Invoice Ninja is completed and you can start using it. Open your web browser and navigate it to http://your-domain.com and follow the web-based installation wizard to finalize the installation.</p><hr><p><img class="alignleft size-full wp-image-27931" src="https://www.rosehosting.com/blog/wp-content/uploads/2018/08/Install-Invoice-Ninja-centos-7.jpg" alt="Install Invoice Ninja centos 7" width="200" height="109" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2018/08/Install-Invoice-Ninja-centos-7.jpg 200w, https://www.rosehosting.com/blog/wp-content/uploads/2018/08/Install-Invoice-Ninja-centos-7-150x82.jpg 150w" sizes="(max-width: 200px) 100vw, 200px">Of course, you don’t have to install Invoice Ninja on CentOS 7 if you use one of our <a href="https://www.rosehosting.com/centos-hosting.html">Managed CentOS Hosting</a> plans, in which case you can simply ask our expert Linux admins to install Invoice Ninja on CentOS 7 for you. They are available 24×7 and will take care of your request immediately.</p><p><span style="color: #ff0000;"><strong>PS.</strong> </span>If you liked this post on how to install Invoice Ninja on CentOS 7, please share it with your friends on the social networks using the buttons on the left or simply leave a reply below. Thanks</p><div class="essb_links essb_counters essb_displayed_followme essb_share essb_template_metro-bold-retina essb_1172614609 essb_links_center essb_nospace print-no" id="essb_displayed_followme_1172614609" data-essb-postid="27916" data-essb-position="followme" data-essb-button-style="button_name" data-essb-template="metro-bold-retina" data-essb-counter-pos="insidename" data-essb-url="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/" data-essb-twitter-url="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/" data-essb-instance="1172614609"><ul class="essb_links_list essb_hide_icon"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-counter-pos="insidename"><span class="essb_totalcount essb_t_l" title="Total: "><span class="essb_total_text">Total: </span><span class="essb_t_nb">13</span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/&amp;t=How+to+Install+Invoice+Ninja+on+CentOS+7" title="" onclick="essb.window('https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/&amp;t=How+to+Install+Invoice+Ninja+on+CentOS+7','facebook','1172614609'); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook<span class="essb_counter_insidename" data-cnt="13" data-cnt-short="13">13</span></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window('https://twitter.com/intent/tweet?text=How+to+Install+Invoice+Ninja+on+CentOS+7&amp;url=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/&amp;counturl=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/','twitter','1172614609'); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_google nolightbox"> <a href="https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/" title="" onclick="essb.window('https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/','google','1172614609'); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_google"></span><span class="essb_network_name">Google+<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+to+Install+Invoice+Ninja+on+CentOS+7&amp;url=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/" title="" onclick="essb.window('https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+to+Install+Invoice+Ninja+on+CentOS+7&amp;url=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/','linkedin','1172614609'); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li></ul></div></div></div><div class="post-footer"><div class="social-icons ed-social-share-icons"><p class="share-title">Share:</p> <a href="http://www.facebook.com/sharer.php?u=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/&#038;t=How%20to%20Install%20Invoice%20Ninja%20on%20CentOS%207" class="social-share-link" title="Share &quot;How to Install Invoice Ninja on CentOS 7&quot; via Facebook" data-network-name="facebook" data-share-title="How to Install Invoice Ninja on CentOS 7" data-share-url="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/"> <span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover" ></span> </a><a href="http://twitter.com/home?status=How%20to%20Install%20Invoice%20Ninja%20on%20CentOS%207%20https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/" class="social-share-link" title="Share &quot;How to Install Invoice Ninja on CentOS 7&quot; via Twitter" data-network-name="twitter" data-share-title="How to Install Invoice Ninja on CentOS 7" data-share-url="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/"> <span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover" ></span> </a><a href="https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/&#038;t=How%20to%20Install%20Invoice%20Ninja%20on%20CentOS%207" class="social-share-link" title="Share &quot;How to Install Invoice Ninja on CentOS 7&quot; via Google +" data-network-name="googleplus" data-share-title="How to Install Invoice Ninja on CentOS 7" data-share-url="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/"> <span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover" ></span> </a><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/&#038;title=How%20to%20Install%20Invoice%20Ninja%20on%20CentOS%207" class="social-share-link" title="Share &quot;How to Install Invoice Ninja on CentOS 7&quot; via LinkedIn" data-network-name="linkedin" data-share-title="How to Install Invoice Ninja on CentOS 7" data-share-url="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/"> <span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover" ></span> </a><a href="#" class="social-share-link" title="Share &quot;How to Install Invoice Ninja on CentOS 7&quot; via Email" data-network-name="basic_email" data-share-title="How to Install Invoice Ninja on CentOS 7" data-share-url="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/"> <span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover" ></span> </a><a href="#" class="social-share-link" title="Share &quot;How to Install Invoice Ninja on CentOS 7&quot; via Print" data-network-name="basic_print" data-share-title="How to Install Invoice Ninja on CentOS 7" data-share-url="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/"> <span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover" ></span> </a></div><style type="text/css" id="rating-stars">.post-footer .rating-stars #rated-stars img.star-on, .post-footer .rating-stars #rating-stars img.star-on{background-color:#932279}</style></div></article><nav class="post-nav"><div class="nav-links clearfix"><div class="nav-link nav-link-prev"> <a href="https://www.rosehosting.com/blog/how-to-enforce-password-quality-in-linux/" rel="prev"><span class="button">Previous</span><span class="title">How to Enforce Password Quality in Linux</span></a></div><div class="nav-link nav-link-next"> <a href="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-debian-9/" rel="next"><span class="button">Next</span><span class="title">How to Install Invoice Ninja on Debian 9</span></a></div></div> </nav><div class="et_extra_other_module related-posts"><div class="related-posts-header"><h3>Related Posts</h3></div><div class="related-posts-content clearfix"><div class="related-post"><div class="featured-image"><a href="https://www.rosehosting.com/blog/how-to-install-lamp-and-run-orangehrm-in-ubuntu-12-04-lts/" title="How to install LAMP and run OrangeHRM in Ubuntu 12.04 LTS" class="post-thumbnail"> <img src="https://www.rosehosting.com/blog/wp-content/uploads/2014/03/how-to-install-lamp-and-run-orangehrm-in-ubuntu-12-04-lts.png" alt="How to install LAMP and run OrangeHRM in Ubuntu 12.04 LTS" /><span class="et_pb_extra_overlay"></span> </a></div><h4 class="title"><a href="https://www.rosehosting.com/blog/how-to-install-lamp-and-run-orangehrm-in-ubuntu-12-04-lts/">How to install LAMP and run OrangeHRM in Ubuntu 12.04 LTS</a></h4><p class="date"><span class="updated">March 24, 2014</span></p></div><div class="related-post"><div class="featured-image"><a href="https://www.rosehosting.com/blog/install-nextcloud-on-ubuntu-16-04/" title="Install Nextcloud 9 on Ubuntu 16.04" class="post-thumbnail"> <img src="https://www.rosehosting.com/blog/wp-content/uploads/2016/07/Install-Nextcloud-on-Ubuntu-16.04.jpg" alt="Install Nextcloud 9 on Ubuntu 16.04" /><span class="et_pb_extra_overlay"></span> </a></div><h4 class="title"><a href="https://www.rosehosting.com/blog/install-nextcloud-on-ubuntu-16-04/">Install Nextcloud 9 on Ubuntu 16.04</a></h4><p class="date"><span class="updated">July 11, 2016</span></p></div><div class="related-post"><div class="featured-image"><a href="https://www.rosehosting.com/blog/how-to-install-nodejs-bower-and-gulp-on-a-centos-7-vps/" title="How to install NodeJS, Bower and Gulp on a CentOS 7 VPS" class="post-thumbnail"> <img src="https://www.rosehosting.com/blog/wp-content/uploads/2013/12/node.js-bower.png" alt="How to install NodeJS, Bower and Gulp on a CentOS 7 VPS" /><span class="et_pb_extra_overlay"></span> </a></div><h4 class="title"><a href="https://www.rosehosting.com/blog/how-to-install-nodejs-bower-and-gulp-on-a-centos-7-vps/">How to install NodeJS, Bower and Gulp on a CentOS 7 VPS</a></h4><p class="date"><span class="updated">August 19, 2014</span></p></div><div class="related-post"><div class="featured-image"><a href="https://www.rosehosting.com/blog/how-to-install-projectpier-on-a-centos-7-vps/" title="How to Install ProjectPier on a CentOS 7 VPS" class="post-thumbnail"> <img src="https://www.rosehosting.com/blog/wp-content/uploads/2015/05/projectpier-vps.png" alt="How to Install ProjectPier on a CentOS 7 VPS" /><span class="et_pb_extra_overlay"></span> </a></div><h4 class="title"><a href="https://www.rosehosting.com/blog/how-to-install-projectpier-on-a-centos-7-vps/">How to Install ProjectPier on a CentOS 7 VPS</a></h4><p class="date"><span class="updated">May 26, 2015</span></p></div></div></div><section id="comment-wrap"><div id="comments" class="nocomments"></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/how-to-install-invoice-ninja-on-centos-7/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.rosehosting.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea autocomplete="nope"  id="41808d3784"  name="87dbfa77f2"   cols="45" rows="8" aria-required="true"></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="nope" style="padding:0;clip:rect(1px, 1px, 1px, 1px);position:absolute !important;white-space:nowrap;height:1px;width:1px;overflow:hidden;" tabindex="-1"></textarea><script type="text/javascript">document.getElementById("comment").setAttribute("id","862ade15f656ecb066002d5628492e65");document.getElementById("41808d3784").setAttribute("id","comment");</script></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='27916' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><div class="g-recaptcha" data-sitekey="6LfY7_4SAAAAAE2DEhMo9U4ZS1XLXf1qGXL9uzZC" data-theme="standard"></div><script type="text/javascript"src="https://www.google.com/recaptcha/api.js?hl=en"></script> <div id="recaptcha-submit-btn-area">&nbsp;</div> <noscript><style type='text/css'>#submit{display:none}</style><input name="submit" type="submit" id="submit-alt" tabindex="6" value="Submit Comment"/> </noscript></form></div> </section></div><div class="et_pb_extra_column_sidebar"><div class="et_pb_widget roseh-widget"><h4 class="widgettitle"></h4><div style="text-align: center; " id="roseh-464864704"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="6446601501"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> </div></div><div class="et_pb_widget roseh-widget"><h4 class="widgettitle"></h4><div style="text-align: center; " id="roseh-1820064863"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="2385735863"></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><div id="text-31" class="et_pb_widget widget_text"><h4 class="widgettitle"></h4><div class="textwidget"><p><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <br /> <ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="8927217199"></ins><br /> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></center></p></div></div></div></div></div></div> <footer class="footer-big-menu"><div class="container"><div class="row menu"><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title mb-2">Company</h3> <a class="menu-link" href="https://www.rosehosting.com/about-us.html">About us</a> <a class="menu-link" href="https://www.rosehosting.com/policies.html">Our Policies</a> <a class="menu-link" href="https://www.rosehosting.com/contact-us.html">Contact Us</a> <a class="menu-link" href="https://www.rosehosting.com/blog/">Blog</a> <a class="menu-link" href="https://www.rosehosting.com/why-rosehosting.html">Why RoseHosting</a> <a class="menu-link" href="https://www.rosehosting.com/compare-to-competition.html">Compare Us</a> <a class="menu-link" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a> <a class="menu-link" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a></div><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title  mb-2">Support</h3> <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Helpdesk System</a> <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a> <a class="menu-link" href="https://status.rosehosting.com">Systems Status</a><h3 class="menu-title  mb-2 mt-4">Other Services</h3> <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Domain Registration</a> <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Domain Transfer</a> <a class="menu-link" href="https://www.rosehosting.com/ssl-certificates.html">SSL Certificates</a></div><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title  mb-2">Hosting</h3> <a class="menu-link" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/vps-hosting.html">VPS Hosting</a> <a class="menu-link" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom SSD VPS</a> <a class="menu-link" href="https://www.rosehosting.com/cloud-hosting.html">Cloud Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/dedicated-servers.html">Cloud Dedicated Servers</a> <a class="menu-link" href="https://www.rosehosting.com/hosting-solutions.html">Hosting Solutions</a> <a class="menu-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Affiliate Program</a></div><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title  mb-2">Linux VPS Hosting</h3> <a class="menu-link" href="https://www.rosehosting.com/centos-hosting.html">CentOS Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/ubuntu-hosting.html">Ubuntu Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/debian-hosting.html">Debian Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/opensuse-hosting.html">OpenSUSE Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/arch-linux-hosting.html">Arch-Linux Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/scientific-linux-hosting.html">Scientific Linux Hosting</a></div><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title  mb-2">Apps Hosting</h3> <a class="menu-link" href="https://www.rosehosting.com/wordpress-hosting.html">WordPress Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/magento-hosting.html">Magento Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/odoo-hosting.html">Odoo Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/joomla-hosting.html">Joomla Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/drupal-hosting.html">Drupal Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/laravel-hosting.html">Laravel Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/nextcloud-hosting.html">NextCloud Hosting</a><a class="menu-link" href="https://www.rosehosting.com/prestashop-hosting.html">PrestaShop Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/ghost-hosting.html">Ghost Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/mediawiki-hosting.html">MediaWiki Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/tomcat-hosting.html">Tomcat Hosting</a></div><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title mb-2">Contact Us</h3> <a class="menu-link" href="tel:+18887673467">(888) ROSE-HOST</a> <a class="menu-link" href="tel:+18887673467">(888) 767-3467</a> <a class="menu-link" href="tel:+16465197201">(314) 275-0414</a> <a class="menu-link" href="mailto:%73%75%70%70%6f%72%74%40%72%6f%73%65%68%6f%73%74%69%6e%67%2e%63%6f%6d">Email us</a><h3 class="menu-title mb-2 mt-4">Connect</h3> <a class="menu-link" href="https://twitter.com/rosehosting" target="_blank"><i class="fa fa-twitter fa-fw"></i> Twitter</a> <a class="menu-link" href="https://www.facebook.com/RoseHosting" target="_blank"><i class="fa fa-facebook fa-fw"></i> Facebook</a> <a class="menu-link" href="https://plus.google.com/+Rosehosting" target="_blank"><i class="fa fa-google-plus fa-fw"></i> Google+</a> <a class="menu-link" href="https://www.linkedin.com/company/rose-web-services-l-l-c-" target="_blank"><i class="fa fa-linkedin fa-fw"></i> LinkedIn</a> <a class="menu-link" href="https://www.rosehosting.com/blog/feed/" target="_blank"><i class="fa fa-rss fa-fw"></i> RSS Feed</a></div></div></div><div class="bottom"><div class="container"><div class="row"><div class="col col-md-12"> <img class="privacy-shield d-block mb-4" width="175" src="https://www.rosehosting.com/blog/wp-content/themes/rh2018/img/privacy_shield.png" alt="privacy shield"></div><div class="col-md-12 col-lg-6"><p class="text-sm-left"><a class="inline-link footer-policy" href="/tos.html">Terms of Service</a> and <a class="inline-link footer-policy" href="/policies.html">other policies</a></p></div><div class="col-md-12 col-lg-6"><p class="text-sm-right">&copy; 2001-2018 <a class="inline-link footer-policy" href="https://www.rosewebservices.com/">Rose Web Services LLC</a>.</p></div></div></div></div> <script type="text/javascript" id="aff1f81b02f303eea5f87a3a065f153a" src="https://linuxhostsupport.com/chat//script.php?id=aff1f81b02f303eea5f87a3a065f153a"></script> <div class="essb-followme essb-followme-bottom" data-full="" data-top="" data-background="rgba(255,255,255,0)" data-position="" data-avoid-left="true" data-hide="1"><div class="essb_links essb_counters essb_displayed_followme essb_share essb_template_metro-bold-retina essb_333949269 essb_links_center essb_nospace print-no" id="essb_displayed_followme_333949269" data-essb-postid="27916" data-essb-position="followme" data-essb-button-style="button_name" data-essb-template="metro-bold-retina" data-essb-counter-pos="insidename" data-essb-url="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/" data-essb-twitter-url="https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/" data-essb-instance="333949269"><ul class="essb_links_list essb_hide_icon"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-counter-pos="insidename"><span class="essb_totalcount essb_t_l" title="Total: "><span class="essb_total_text">Total: </span><span class="essb_t_nb">13</span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/&t=How+to+Install+Invoice+Ninja+on+CentOS+7" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/&t=How+to+Install+Invoice+Ninja+on+CentOS+7&#39;,&#39;facebook&#39;,&#39;333949269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook<span class="essb_counter_insidename" data-cnt="13" data-cnt-short="13">13</span></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=How+to+Install+Invoice+Ninja+on+CentOS+7&amp;url=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/&amp;counturl=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/&#39;,&#39;twitter&#39;,&#39;333949269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_google nolightbox"> <a href="https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/" title="" onclick="essb.window(&#39;https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/&#39;,&#39;google&#39;,&#39;333949269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_google"></span><span class="essb_network_name">Google+<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+to+Install+Invoice+Ninja+on+CentOS+7&amp;url=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+to+Install+Invoice+Ninja+on+CentOS+7&amp;url=https://www.rosehosting.com/blog/how-to-install-invoice-ninja-on-centos-7/&#39;,&#39;linkedin&#39;,&#39;333949269&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li></ul></div></div>  <script type="application/ld+json">{"@context":"http://schema.org","@type":"Organization","additionalType":"WebHosting","name":"RoseHosting","logo":"https://www.rosehosting.com/blog/wp-content/uploads/2018/03/RoseHosting-Logo.png","url":"https://www.rosehosting.com/blog/","sameAs":["https://twitter.com/rosehosting","https://www.facebook.com/RoseHosting","https://www.google.com/+Rosehosting","https://www.linkedin.com/in/rosehosting"],"contactPoint":{"@type":"ContactPoint","telephone":"+1-888-767-3467","contactType":"Customer Service","email":"support@rosehosting.com","contactOption":"TollFree","areaServed":"Canada,Mexico,United States","availableLanguage":"English"},"address":{"@type":"PostalAddress","addressCountry":"United States","addressLocality":"Saint Louis","addressRegion":"MO","postalCode":"63368","streetAddress":"2977 Hwy K #252"}}</script>  <script>/*<![CDATA[*/var advanced_ads_ga_UID='';var advanced_ads_ga_anonymIP=true;advanced_ads_check_adblocker=function(t){function e(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}var n=[],a=null;return e(function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),e(function(){var e=window.getComputedStyle&&window.getComputedStyle(t),o=e&&e.getPropertyValue("-moz-binding");a=e&&"none"===e.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0;i<n.length;i++)n[i](a);n=[]})}),function(t){if(null===a)return void n.push(t);t(a)}}(),function(){var t=function(t,e){this.name=t,this.UID=e,this.analyticsObject=null;var n=this,a={hitType:"event",eventCategory:"Advanced Ads",eventAction:"AdBlock",eventLabel:"Yes",nonInteraction:!0,transport:"beacon"};this.analyticsObject="string"==typeof GoogleAnalyticsObject&&"function"==typeof window[GoogleAnalyticsObject]&&window[GoogleAnalyticsObject],!1===this.analyticsObject?(!function(t,e,n,a,o,i,d){t.GoogleAnalyticsObject=o,t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)},t[o].l=1*new Date,i=e.createElement(n),d=e.getElementsByTagName(n)[0],i.async=1,i.src="https://www.google-analytics.com/analytics.js",d.parentNode.insertBefore(i,d)}(window,document,"script",0,"_advads_ga"),_advads_ga("create",n.UID,"auto",this.name),advanced_ads_ga_anonymIP&&_advads_ga("set","anonymizeIp",!0),_advads_ga(n.name+".send",a)):(window.console&&window.console.log("Advanced Ads Analytics >> using other's variable named `"+GoogleAnalyticsObject+"`"),window[GoogleAnalyticsObject]("create",n.UID,"auto",this.name),window[GoogleAnalyticsObject]("set","anonymizeIp",!0),window[GoogleAnalyticsObject](n.name+".send",a))};advanced_ads_check_adblocker(function(e){e&&"string"==typeof advanced_ads_ga_UID&&advanced_ads_ga_UID&&new t("advadsTracker",advanced_ads_ga_UID)})}();/*]]>*/</script> <script type="text/javascript">var et_animation_data=[];</script> <script type="text/javascript">var sub=document.getElementById('submit');document.getElementById('recaptcha-submit-btn-area').appendChild(sub);document.getElementById('submit').tabIndex=6;if(typeof _recaptcha_wordpress_savedcomment!='undefined'){document.getElementById('comment').value=_recaptcha_wordpress_savedcomment;}</script><script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2018/js/theme.js?x70227&amp;ver=1' defer '></script> <script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/masonry.min.js?x70227&amp;ver=3.3.2' defer '></script> <script type='text/javascript'>var EXTRA={"images_uri":"https:\/\/www.rosehosting.com\/blog\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"083a5930f0","timeline_nonce":"faefc9d70f","blog_feed_nonce":"cdc2a5c13e","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};var et_shortcodes_strings={"previous":"Previous","next":"Next"};var et_pb_custom={"ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/www.rosehosting.com\/blog\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/www.rosehosting.com\/blog\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"bf1de3124f","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"482096d114","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","is_builder_plugin_used":"","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"27916","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":""};var et_pb_box_shadow_elements=[];</script> <script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/Extra/scripts/scripts.min.js?x70227&amp;ver=2.9' defer '></script> <script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/comment-reply.min.js?x70227&amp;ver=4.9.8' defer '></script> <script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/Extra/core/admin/js/common.js?x70227&amp;ver=3.9' defer '></script> <script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/wp-embed.min.js?x70227&amp;ver=4.9.8' defer '></script> <script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/easysocialsharebuttons-assets/compiled/2566c291e59e185c12a331fef1e235f3.js?x70227' async></script></body></html>