<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta property="fb:pages" content="195648843783690" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.rosehosting.com/blog/xmlrpc.php" />
<script src="https://use.typekit.net/qcm5sfg.js"></script>
<script>try{Typekit.load({ async: true });}catch(e){}</script>
<title>How to install ownCloud 10 on Ubuntu 16.04 &#8211; RoseHosting Blog</title>

<link rel="author" href="https://plus.google.com/+RoseHosting" />
<meta name="description" content="ownCloud is a popular open source enterprise web application used for data synchronization and file sharing. It allows users to easily manage their files, contacts, calendars, to-do lists, and more, making it a great alternative to to the popular Google Drive, Dropbox, iCloud, etc. cloud platforms. ownCloud is a cross" />
<meta name="keywords" content="owncloud 10,ubuntu" />
<link rel="canonical" href="https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/" />
<meta property="og:title" content="How to install ownCloud 10 on Ubuntu 16.04" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/" />
<meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04-1024x512.jpg" />
<meta property="og:site_name" content="RoseHosting.com Blog" />
<meta property="og:description" content="ownCloud is a popular open source enterprise web application used for data synchronization and file sharing. It allows users to easily manage their files, contacts, calendars, to-do lists, and more, making it a great alternative to to the popular Google Drive, Dropbox, iCloud, etc. cloud platforms. ownCloud is a cross-platform application and supports all popular operating systems, but this tutorial was written especially for Ubuntu 16.04. At the time of writing the latest ownCloud version is 10.0.7. 1. Prerequisites PHP &gt;= 5.6 (PHP 7.0 or above is recommended), with the following PHP extensions enabled: XML (Expat), curl, PDO, Phar, GD Graphics Library version 2.0.x+, DOM, ctype, JSON, iconv, intl, mcrypt, openssl, bz2, Zlib and Zip. Apache Web Server &gt;= 2.0 compiled with mod_rewrite module MySQL &gt;= 5.x (MySQL 5.5 or later is recommended), MariaDB 5.5+, PostgreSQL, or SQLite installed on your Linux virtual server. 2. Update the system As usual before installing any system" />
<meta property="article:tag" content="owncloud 10" />
<meta property="article:tag" content="ubuntu" />
<meta property="article:tag" content="tutorials" />
<meta property="article:publisher" content="https://www.facebook.com/RoseHosting/" />
<meta property="article:author" content="https://www.facebook.com/RoseHosting/" />
<meta property="article:published_time" content="2018-04-12T02:11:44Z" />
<meta property="article:modified_time" content="2018-04-12T02:11:44Z" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@RoseHosting" />
<meta name="twitter:creator" content="@rosehosting" />
<meta name="twitter:title" content="How to install ownCloud 10 on Ubuntu 16.04" />
<meta name="twitter:description" content="ownCloud is a popular open source enterprise web application used for data synchronization and file sharing. It allows users to easily manage their files, contacts, calendars, to-do lists, and more, making it a great alternative to to the popular Google Drive, Dropbox, iCloud, etc. cloud platforms. ownCloud is a cross-platform application and supports all popular operating systems, but this tutorial was written especially for Ubuntu 16.04. At the time of writing the latest ownCloud version is 10.0.7. 1. Prerequisites PHP &gt;= 5.6 (PHP 7.0 or above is recommended), with the following PHP extensions enabled: XML (Expat), curl, PDO, Phar, GD Graphics Library version 2.0.x+, DOM, ctype, JSON, iconv, intl, mcrypt, openssl, bz2, Zlib and Zip. Apache Web Server &gt;= 2.0 compiled with mod_rewrite module MySQL &gt;= 5.x (MySQL 5.5 or later is recommended), MariaDB 5.5+, PostgreSQL, or SQLite installed on your Linux virtual server. 2. Update the system As usual before installing any system" />
<meta name="twitter:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04-1024x512.jpg" />

<link rel="amphtml" href="https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/amp/" /><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="RoseHosting Blog &raquo; Feed" href="https://www.rosehosting.com/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting Blog &raquo; Comments Feed" href="https://www.rosehosting.com/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting Blog &raquo; How to install ownCloud 10 on Ubuntu 16.04 Comments Feed" href="https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.rosehosting.com\/blog\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ecko_plugin_css-css' href='https://www.rosehosting.com/blog/wp-content/plugins/eckoplugin/assets/css/eckoplugin.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='ecko_css-css' href='https://www.rosehosting.com/blog/wp-content/themes/rh2016/style.css?ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='ecko-fonts-css' href='//fonts.googleapis.com/css?family=Muli%3A400%2C700%7CVarela+Round%3A400%7CBitter%3A400%7CMontserrat%3A400%7C&#038;ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='easy-social-share-buttons-css' href='https://www.rosehosting.com/blog/wp-content/plugins/easy-social-share-buttons3/assets/css/easy-social-share-buttons.css?ver=5.4' type='text/css' media='all' />
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://www.rosehosting.com/blog/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rosehosting.com/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rosehosting.com/blog/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Install Apache Maven 3.5 on CentOS 7' href='https://www.rosehosting.com/blog/install-apache-maven-3-5-on-centos-7/' />
<link rel='next' title='How to Install Joomla 3 on CentOS 7' href='https://www.rosehosting.com/blog/how-to-install-joomla-3-on-centos-7/' />
<meta name="generator" content="WordPress 4.9.5" />
<link rel='shortlink' href='https://www.rosehosting.com/blog/?p=26217' />
<link rel="alternate" type="application/json+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-install-owncloud-10-on-ubuntu-16-04%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-install-owncloud-10-on-ubuntu-16-04%2F&#038;format=xml" />
<meta property="fb:pages" content="195648843783690" />
<meta property="ia:markup_url" content="https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/?ia_markup=1" />
<link rel="amphtml" href="https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/?amp_markup=1">
<style>
				.socialdark.pinterest{
    display: none !important;
}			</style>
<meta property="fb:app_id" content="" />
<meta property="fb:admins" content="" />
<meta property="og:url" content="https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/" />
<meta property="og:title" content="How to install ownCloud 10 on Ubuntu 16.04" />
<meta property="og:description" content="ownCloud is a popular open source enterprise web application used for data synchronization and file sharing. It allows users to easily manage their files, contacts, calendars, to-do lists, and more, making it a great alternative to to the popular Google Drive, Dropbox, iCloud, etc. cloud platforms. ownCloud is a cross-platform application and supports all popular operating systems, but this tutorial was written especially for Ubuntu 16.04. At the time of writing the latest ownCloud version is 10.0.7. 1. Prerequisites PHP &gt;= 5.6 (PHP 7.0 or above is recommended), with the following PHP extensions enabled: XML (Expat), curl, PDO, Phar, GD [&hellip;]" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04-680x340.jpg" />
<style type="text/css">

								
																				
																				
																								
																													.post-list .post .author{ display:none !important; }
												
												
																					body.single .post-title .author{ display:none; }
																																	body.single .post-author-profile{ display:none; }
												
																												
																				
													.disclaimer{ display:none !important; }
													.disclaimer .wordpress{ display:none !important; }
													.disclaimer .ecko{ display:none !important; }
				
								
			 </style>
<script type="text/javascript">var essb_settings = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","essb3_nonce":"02e60f95eb","essb3_plugin_url":"https:\/\/www.rosehosting.com\/blog\/wp-content\/plugins\/easy-social-share-buttons3","essb3_stats":false,"essb3_ga":false,"essb3_ga_mode":"simple","blog_url":"https:\/\/www.rosehosting.com\/blog\/","essb3_postfloat_stay":false,"post_id":26217};var essb_buttons_exist = !!document.getElementsByClassName("essb_links"); if(essb_buttons_exist == true) { document.addEventListener("DOMContentLoaded", function(event) { var ESSB_CACHE_URL = "https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/"; if(ESSB_CACHE_URL.indexOf("?") > -1) { ESSB_CACHE_URL += "&essb_counter_cache=rebuild"; } else { ESSB_CACHE_URL += "?essb_counter_cache=rebuild"; }; var xhr = new XMLHttpRequest(); xhr.open("GET",ESSB_CACHE_URL,true); xhr.send(); });}</script><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-270x270.png" />
<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/


.post-contents ol, .post-contents p, .post-contents ul, .post-content p {
    font-size: 20px;
    line-height: 32px;
}

.post-contents pre {
    font-size: 16px;
}

.post-contents h2 {
    margin-top: 48px;
}

.post-contents h6 {
    font-size: 20px;
}
		</style>
</head>
<body class="post-template-default single single-post postid-26217 single-format-standard top-bar-visible page-layout-right-sidebar" itemscope="itemscope" itemtype="http://schema.org/TechArticle">
<div class="backtotop"><i class="fa fa-angle-double-up"></i></div>

<script type="text/javascript">
(function(){
  var bsa = document.createElement('script');
     bsa.type = 'text/javascript';
     bsa.async = true;
     bsa.src = '//s3.buysellads.com/ac/bsa.js';
  (document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(bsa);
})();
</script>

<header class="rh">

<nav class="navbar navbar-inverse" role="navigation">
<div class="container">
<div class="navbar-header">
<a href="https://www.rosehosting.com" class="navbar-brand">
<img alt="RoseHosting.com" width="201" height="40" src="https://media.rosehosting.com/img/rh-logo.svg">
</a>
<button data-target="#navbar-main" data-toggle="collapse" type="button" class="navbar-toggle">
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</div>
<div id="navbar-main" class="navbar-collapse collapse">
<ul class="nav navbar-nav navbar-right">
<li class="dropdown"><a href="#" data-toggle="dropdown" class="dropdown-toggle">Hosting <span class="caret"></span></a>
<ul class="dropdown-menu">
<li><a href="https://www.rosehosting.com/linux-shared-hosting.html">Shared Hosting</a></li>
<li><a href="https://www.rosehosting.com/linux-vps-hosting.html">Linux VPS Hosting</a></li>
<li><a href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom SSD VPS</a></li>
<li><a href="https://www.rosehosting.com/cloud-server-oci-hosting.html">OneClick Install Cloud</a></li>
<li><a href="https://www.rosehosting.com/dedicated-servers.html">Dedicated Servers</a></li>
<li><a href="https://www.rosehosting.com/vps-affiliate-program.html">Affiliate Program</a></li>
<li><a href="https://www.rosehosting.com/hosting-services.html">Hosting Services</a></li>
<li><a href="https://www.rosehosting.com/other-services.html">Other Services</a></li>
</ul>
</li>
<li class="dropdown"><a href="#" data-toggle="dropdown" class="dropdown-toggle">SSL Certificates <span class="caret"></span></a>
<ul class="dropdown-menu">
<li class="dropdown-header"><span></span>By brand</li>
<li><a href="https://www.rosehosting.com/ssl-certificates.html">GeoTrust</a></li>
<li><a href="https://www.rosehosting.com/ssl-certificates.html#comodo">Comodo</a></li>
<li><a href="https://www.rosehosting.com/ssl-certificates.html#rapidssl">RapidSSL</a></li>
<li><a href="https://www.rosehosting.com/ssl-certificates.html#symantec">Symantec</a></li>
<li><a href="https://www.rosehosting.com/ssl-certificates.html#thawte">Thawte</a></li>
<li class="dropdown-header">By Type</li>
<li><a href="https://www.rosehosting.com/ssl-certificates-by-type.html">Domain Validation</a></li>
<li><a href="https://www.rosehosting.com/ssl-certificates-by-type.html#organization">Organization Validation</a></li>
<li><a href="https://www.rosehosting.com/ssl-certificates-by-type.html#extended">Extended Validation</a></li>
<li><a href="https://www.rosehosting.com/ssl-certificates-by-type.html#wildcard">Wildcard SSL</a></li>
<li><a href="https://www.rosehosting.com/ssl-certificates-by-type.html#codesigning">Code Signing SSL</a></li>
</ul>
</li>
<li class="dropdown"><a href="#" data-toggle="dropdown" class="dropdown-toggle">Domains <span class="caret"></span></a>
<ul class="dropdown-menu">
<li><a href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Register Domains</a></li>
<li><a href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Transfer Domains</a></li>
</ul>
</li>
<li class="dropdown"><a href="#" data-toggle="dropdown" class="dropdown-toggle js-activated">Help <span class="caret"></span></a>
<ul class="dropdown-menu">
<li><a href="https://www.rosehosting.com/support.html">Support</a></li>
<li><a href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Open a Support Ticket</a></li>
<li><a href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a></li>

</ul>
</li>
<li class="dropdown">
<a href="#" data-toggle="dropdown" class="dropdown-toggle js-activated">About Us <span class="caret"></span></a>
<ul class="dropdown-menu">
<li><a href="https://www.rosehosting.com/about-us.html">Our Company</a></li>
<li><a href="https://www.rosehosting.com/contact-us.html">Contact Us</a></li>
<li><a href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a><li>
<li><a href="https://www.rosehosting.com/reviews.html">Customer Reviews</a></li>
<li><a href="https://www.rosehosting.com/policies.html">Our Policies</a></li>
</ul>
</li>
<li><a href="https://www.rosehosting.com/blog/">Blog</a></li>
<li class="login-btn"><a href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Login</a></li>
<li class="visible-sm visible-md"><a href="https://secure.rosehosting.com/clientarea/index.php?/signup/">Sign Up</a></li>
<li class="hidden-md"><div><a href="https://secure.rosehosting.com/clientarea/index.php?/signup/" class="btn btn-border-nav navbar-btn hidden-xs" id="btn-signup-top">Sign Up</a></div></li>
</ul>
</div>
</div>
</nav>
</header>
<section class="page-content">
<div class="wrapper-body">
<div id="post-26217" class="page-main post-26217 post type-post status-publish format-standard has-post-thumbnail hentry category-tutorials tag-owncloud-10 tag-ubuntu">
<section class="post-title post-title-standard">
<h1 itemprop="name headline">How to install ownCloud 10 on Ubuntu 16.04</h1>
<ul class="meta">
<li class="author"><a href="https://www.rosehosting.com/blog/author/r0s3admin/"><i class="fa fa-user"></i>admin</a></li>
<li class="date"><a href="https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/"><i class="fa fa-clock-o"></i><time datetime="2018-04-12">April 12, 2018</time></a></li>
<li class="comments"><a href="https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/#comments"><i class="fa fa-comments-o"></i>0</a></li>
<li class="category-rh"><a class="category" style="background:#7fbb00;" href="https://www.rosehosting.com/blog/category/tutorials/">Tutorials</a></li>
</ul>
<hr>
</section>
<section class="post-contents">
<div class="roseh-before-content" style="text-align: center; " id="roseh-1837667082"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="1066282313"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><p><img class="alignnone wp-image-26336 size-full" src="https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04.jpg" alt="How to install ownCloud 10 on Ubuntu 16.04 " width="1200" height="600" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04.jpg 1200w, https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04-768x384.jpg 768w, https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04-1024x512.jpg 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04-860x430.jpg 860w, https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04-680x340.jpg 680w, https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04-500x250.jpg 500w, https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04-400x200.jpg 400w, https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04-200x100.jpg 200w, https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04-50x25.jpg 50w" sizes="(max-width: 1200px) 100vw, 1200px"></p>
<div class="roseh-after-first-image" style="float: right; " id="roseh-160124084"><div style="float: right; margin-left: 10px; " id="roseh-1084423494"><center><a target="_blank" href="https://www.rosehosting.com/cloud-vps-hosting.html"><img src="https://media.rosehosting.com/img/blogads/dark.png"></a></center>
</div></div><p>ownCloud is a popular open source enterprise web application used for data synchronization and file sharing. It allows users to easily manage their files, contacts, calendars, to-do lists, and more, making it a great alternative to to the popular Google Drive, Dropbox, iCloud, etc. cloud platforms. ownCloud is a cross-platform application and supports all popular operating systems, but this tutorial was written especially for Ubuntu 16.04. At the time of writing the latest ownCloud version is 10.0.7.</p>
<p><span id="more-26217"></span></p>
<h2>1. Prerequisites</h2>
<ul><li>PHP &gt;= 5.6 (PHP 7.0 or above is recommended), with the following PHP extensions enabled: XML (Expat), curl, PDO, Phar, GD Graphics Library version 2.0.x+, DOM, ctype, JSON, iconv, intl, mcrypt, openssl, bz2, Zlib and Zip.</li>
<li>Apache Web Server &gt;= 2.0 compiled with mod_rewrite module</li>
<li>MySQL &gt;= 5.x (MySQL 5.5 or later is recommended), MariaDB 5.5+, PostgreSQL, or SQLite installed on your <a href="https://www.rosehosting.com/linux-vps-hosting.html" target="_blank" rel="noopener">Linux virtual server</a>.</li>
</ul><h2>2. Update the system</h2>
<p>As usual before installing any system packages on your server, update the system first:</p>
<pre># sudo apt-get update &amp;&amp; apt-get upgrade</pre>
<h2>3. Install ownCloud</h2>
<p>Download the repository key using the wget command and import it with the apt-key command:</p>
<pre># wget -qO- https://download.owncloud.org/download/repositories/stable/Ubuntu_16.04/Release.key | sudo apt-key add -
OK
</pre>
<p>Make sure apt-transport-https is installed as we are going to need it for the next step:</p>
<pre># sudo apt-get install apt-transport-https
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  aspell aspell-en dictionaries-common emacsen-common libaspell15 libexttextcat-2.0-0 libexttextcat-data liblua5.1-0 libyajl2
Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
  apt-transport-https
0 upgraded, 1 newly installed, 0 to remove and 54 not upgraded.
Need to get 26.1 kB of archives.
After this operation, 215 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 apt-transport-https amd64 1.2.26 [26.1 kB]
Fetched 26.1 kB in 0s (60.8 kB/s)
Selecting previously unselected package apt-transport-https.
(Reading database ... 35616 files and directories currently installed.)
Preparing to unpack .../apt-transport-https_1.2.26_amd64.deb ...
Unpacking apt-transport-https (1.2.26) ...
Setting up apt-transport-https (1.2.26) ...
</pre>
<p>Create a owncloud.list file in /etc/apt/sources.list.d so we can add the ownCloud repository to the server:</p>
<pre># echo 'deb https://download.owncloud.org/download/repositories/stable/Ubuntu_16.04/ /' | sudo tee /etc/apt/sources.list.d/owncloud.list
deb https://download.owncloud.org/download/repositories/stable/Ubuntu_16.04/ /
</pre>
<p>Now update the system packages again so we can install the ownCloud packages:</p>
<pre># sudo apt-get update
Hit:1 http://archive.ubuntu.com/ubuntu xenial InRelease
Hit:2 http://archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:3 http://archive.canonical.com/ubuntu xenial InRelease
Hit:4 http://security.ubuntu.com/ubuntu xenial-security InRelease
Ign:5 https://download.owncloud.org/download/repositories/stable/Ubuntu_16.04  InRelease
Get:6 https://download.owncloud.org/download/repositories/stable/Ubuntu_16.04  Release [986 B]
Get:7 https://download.owncloud.org/download/repositories/stable/Ubuntu_16.04  Release.gpg [481 B]
Get:8 https://download.owncloud.org/download/repositories/stable/Ubuntu_16.04  Packages [736 B]
Fetched 2203 B in 2s (1030 B/s)
Reading package lists... Done
</pre>
<p>Install ownCloud by executing the following command:</p>
<pre># sudo apt-get install owncloud-files
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  owncloud-files
0 upgraded, 1 newly installed, 0 to remove and 51 not upgraded.
Need to get 0 B/35.1 MB of archives.
After this operation, 118 MB of additional disk space will be used.
Selecting previously unselected package owncloud-files.
(Reading database ... 35869 files and directories currently installed.)
Preparing to unpack .../owncloud-files_10.0.7-1.1_all.deb ...
Unpacking owncloud-files (10.0.7-1.1) ...
Setting up owncloud-files (10.0.7-1.1) ...
</pre>
<p>We can proceed to the next step now.</p><div class="roseh-in-content" style="text-align: center; " id="roseh-1736901053"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="1066282313"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<h2>4. Create a MySQL database for ownCloud</h2>
<p>Log into MySQL with the root account:</p>
<pre># mysql -u root -p</pre>
<p>Now we will create a MySQL database for ownCloud using the following query:</p>
<pre>mysql&gt; CREATE DATABASE owncloud;</pre>
<p>Then execute the following query to add a separate user for ownCloud that will interact with the database:</p>
<pre>mysql&gt; GRANT ALL PRIVILEGES ON owncloud.* to 'owncloud'@'localhost' IDENTIFIED BY 'enter_username_password_here';</pre>
<p>Execute the following command to apply the privileges we set:</p>
<pre>mysql&gt; FLUSH PRIVILEGES;</pre>
<p>Now we can exit the MySQL session:</p>
<pre>mysql&gt; exit;</pre>
<h2>5. Configure ownCloud</h2>
<p>First make sure the following packages are installed as they are needed by ownCloud:</p>
<pre># sudo apt-get install libapache2-mod-php7.0 \
    openssl php-imagick php7.0-common php7.0-curl php7.0-gd \
    php7.0-imap php7.0-intl php7.0-json php7.0-ldap php7.0-mbstring \
    php7.0-mcrypt php7.0-mysql php7.0-pgsql php-smbclient php-ssh2 \
    php7.0-sqlite3 php7.0-xml php7.0-zip
</pre>
<h2>6. Configure Apache to server ownCloud</h2>
<p>Now we will have to setup the Apache configuration so it can serve the ownCloud directory, add the following contents below to the /etc/apache2/sites-available/owncloud.conf file with nano or your favorite editor:</p>
<pre># sudo nano /etc/apache2/sites-available/owncloud.conf

Alias /owncloud "/var/www/owncloud/"

&lt;Directory /var/www/owncloud/&gt;
Options +FollowSymlinks
AllowOverride All

&lt;IfModule mod_dav.c&gt;
Dav off
&lt;/IfModule&gt;

SetEnv HOME /var/www/owncloud
SetEnv HTTP_HOME /var/www/owncloud

&lt;/Directory&gt;
</pre>
<p>Enable the following Apache modules:</p>
<pre># sudo a2enmod rewrite
# sudo a2enmod headers
# sudo a2enmod env
# sudo a2enmod dir
# sudo a2enmod mime
</pre>
<p>Enable the Apache ownCloud configuration:</p>
<pre># sudo a2ensite owncloud.conf</pre>
<p>Now restart the Apache web server:</p>
<pre># sudo systemctl restart apache2</pre>
<p>Open your web browser and type in the following URL to access the ownCloud web interface:</p>
<pre>http://your_server_ip_address_or_domain_name/owncloud</pre>
<p>From here you can finish the setup by following the steps below:</p>
<ul><li>Enter a username and password for the admin account.</li>
<li>Click on the Storage &amp; database link.</li>
<li>Leave the default data folder setting.</li>
<li>Click the MySQL/MariaDB button.</li>
<li>Populate the fields with the database information we set above.</li>
<li>Click Finish Setup.</li>
</ul><p>That’s it, now you should have successfully installed ownCloud 10 on your server.</p>
<p><img class="alignleft size-full wp-image-26337" src="https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04.png" alt="How to install ownCloud 10 on Ubuntu 16.04 " width="250" height="119" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04.png 250w, https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04-150x71.png 150w, https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04-200x95.png 200w, https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-ownCloud-10-on-Ubuntu-16.04-50x24.png 50w" sizes="(max-width: 250px) 100vw, 250px">Of course, you don’t have to install and configure ownCloud 10 on a Ubuntu 16.04 VPS, if you use one of our <a href="https://www.rosehosting.com/owncloud-hosting.html">ownCloud VPS Hosting solutions</a>, in which case you can simply ask our expert Linux admins to install and configure ownCloud 10 on Ubuntu 16.04 for you. They are available 24×7 and will take care of your request immediately.</p>
<p><span style="color: #ff0000;"><strong>PS</strong></span>. If you liked this post on how to install and configure ownCloud 10 on a Ubuntu 16.04 VPS, please share it with your friends on the social networks using the buttons on the left or simply leave a reply below. Thanks.</p>
<div class="essb_links essb_counters essb_displayed_followme essb_share essb_template_metro-bold-retina essb_1251300072 essb_links_center essb_nospace print-no" id="essb_displayed_followme_1251300072" data-essb-postid="26217" data-essb-position="followme" data-essb-button-style="button_name" data-essb-template="metro-bold-retina" data-essb-counter-pos="insidename" data-essb-url="https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/" data-essb-twitter-url="https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/" data-essb-instance="1251300072"><ul class="essb_links_list essb_hide_icon"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-counter-pos="insidename"><span class="essb_totalcount essb_t_l" title="Total: "><span class="essb_total_text">Total: </span><span class="essb_t_nb">2</span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/&amp;t=How+to+install+ownCloud+10+on+Ubuntu+16.04&amp;redirect_uri=https://www.rosehosting.com/blog?sharing-thankyou=yes" title="" onclick="essb.window('https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/&amp;t=How+to+install+ownCloud+10+on+Ubuntu+16.04&amp;redirect_uri=https://www.rosehosting.com/blog?sharing-thankyou=yes','facebook','1251300072'); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook<span class="essb_counter_insidename" data-cnt="2" data-cnt-short="2">2</span></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window('https://twitter.com/intent/tweet?text=How+to+install+ownCloud+10+on+Ubuntu+16.04&amp;url=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/&amp;counturl=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/','twitter','1251300072'); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_google nolightbox"> <a href="https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/" title="" onclick="essb.window('https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/','google','1251300072'); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_google"></span><span class="essb_network_name">Google+<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+to+install+ownCloud+10+on+Ubuntu+16.04&amp;url=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/" title="" onclick="essb.window('https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+to+install+ownCloud+10+on+Ubuntu+16.04&amp;url=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/','linkedin','1251300072'); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li></ul></div><div class="roseh-after-content" style="text-align: center; " id="roseh-183133195"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="1066282313"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<div class="post-numbers">
</div>
<div class="post-footer">
<div class="post-tags">
<a href="https://www.rosehosting.com/blog/tag/owncloud-10/" rel="tag">ownCloud 10</a><a href="https://www.rosehosting.com/blog/tag/ubuntu/" rel="tag">ubuntu</a> </div>
<ul class="post-social-share">
<li class="title">Share:</li>
<li><a href="https://twitter.com/share?text=How+to+install+ownCloud+10+on+Ubuntu+16.04&amp;url=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/" onclick="window.open(this.href, 'twitter-share', 'width=550,height=235');return false;" title="Twitter" class="socialdark twitter"><i class="fa fa-twitter"></i></a></li>
<li><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/" onclick="window.open(this.href, 'facebook-share','width=580,height=296');return false;" title="Facebook" class="socialdark facebook"><i class="fa fa-facebook"></i></a></li>
<li><a href="https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/" onclick="window.open(this.href, 'google-plus-share', 'width=490,height=530');return false;" title="Google Plus" class="socialdark google"><i class="fa fa-google-plus"></i></a></li>
<li><a href="https://www.reddit.com/submit?url=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/&amp;title=How+to+install+ownCloud+10+on+Ubuntu+16.04" onclick="window.open(this.href, 'reddit-share', 'width=490,height=530');return false;" title="Reddit" class="socialdark reddit"><i class="fa fa-reddit"></i></a></li>
<li><a href="https://pinterest.com/pin/create/button/?url=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/&description=How+to+install+ownCloud+10+on+Ubuntu+16.04" onclick="window.open(this.href, 'pinterest-share', 'width=490,height=530');return false;" title="Pinterest" class="socialdark pinterest"></a></li>
<li><a href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/&title=How+to+install+ownCloud+10+on+Ubuntu+16.04" onclick="window.open(this.href, 'linkedin-share', 'width=490,height=530');return false;" title="LinkedIn" class="socialdark linkedin"><i class="fa fa-linkedin"></i></a></li> </ul>
</div>
</section>
<section class="post-author-profile">
<div class="inner">
<div class="info" itemprop="author" itemscope="" itemtype="http://schema.org/Person">
<a href="https://www.rosehosting.com/blog/author/r0s3admin/" class="profile gravatar"><img src="//0.gravatar.com/avatar/234567a4255f33b77eb9fffd943c2381?s=80" itemprop="image" alt="admin"></a>
<div class="meta">
<span class="title">Author</span>
<h3 itemprop="name">
<a href="https://www.rosehosting.com/blog/author/r0s3admin/" itemprop="url" rel="author">admin</a>
</h3>
</div>
</div>
<hr>
<p></p>
<ul class="authorsocial">
<li><a href="https://twitter.com/rosehosting" target="_blank" class="socialminimal twitter" title="Twitter"><i class="fa fa-twitter"></i></a></li>
<li><a href="https://www.facebook.com/RoseHosting/" target="_blank" class="socialminimal facebook" title="Facebook"><i class="fa fa-facebook"></i></a></li>
</ul>
</div>
</section>
<section class="post-related post-related-count-3">
<div class="post-footer-header">
<h3><i class="fa fa-newspaper-o"></i>Related Articles</h3>
</div>
<a href="https://www.rosehosting.com/blog/how-to-install-dolibarr-erp-crm-on-a-centos-7-vps/" class="post-related-post">
<div class="background" style="background-image:url('https://www.rosehosting.com/blog/wp-content/uploads/2015/10/dolibarr-vps.png');"></div>
<div class="info">
<span class="category" style="background:#7fbb00;">Tutorials</span> <h5>How to Install Dolibarr ERP CRM on a CentOS 7 VPS</h5>
</div>
</a>
<a href="https://www.rosehosting.com/blog/install-glassfish-4-on-a-debian-8-vps/" class="post-related-post">
<div class="background" style="background-image:url('https://www.rosehosting.com/blog/wp-content/uploads/2015/08/glassfish.png');"></div>
<div class="info">
<span class="category" style="background:#7fbb00;">Tutorials</span> <h5>Install Glassfish 4 on a Debian 8 VPS</h5>
</div>
</a>
<a href="https://www.rosehosting.com/blog/how-to-reset-your-mariadb-root-password/" class="post-related-post">
<div class="background" style="background-image:url('https://www.rosehosting.com/blog/wp-content/uploads/2013/11/How-to-Reset-MariaDB-Root-Password.png');"></div>
<div class="info">
<span class="category" style="background:#7fbb00;">Tutorials</span> <h5>How to Reset MariaDB Root Password</h5>
</div>
</a>
</section>
<section class="post-comments">
<a class="commentanchor" id="comments"></a>
<div class="post-footer-header">
<h3><i class="fa fa-comment-o"></i>Comments</h3>
</div>
<div class="comments-main">
<div class="commentwrap">
<div class="notification nocomments"><i class="fa fa-info"></i> There are currently no comments.</div>
</div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/how-to-install-owncloud-10-on-ubuntu-16-04/#respond" style="display:none;">Cancel Reply</a></small></h3> <form action="https://www.rosehosting.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form">
<textarea autocomplete="nope" placeholder="Add your comment here..." id="97dcc49ebd" name="30534ffcf7" class="commentbody" rows="5" tabindex="4"></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="nope" style="clip:rect(1px, 1px, 1px, 1px);position:absolute !important;white-space:nowrap;height:1px;width:1px;overflow:hidden;" tabindex="-1"></textarea><script type="text/javascript">document.getElementById("comment").setAttribute( "id", "91a52b9ae30d2b34a6d8de155a247e5d" );document.getElementById("97dcc49ebd").setAttribute( "id", "comment" );</script><input type="text" placeholder="Name (Required)" name="author" id="author" value="" size="22" tabindex="1" aria-required='true' />
<input type="text" placeholder="Email (Required)" name="email" id="email" value="" size="22" tabindex="1" aria-required='true' />
<input type="text" placeholder="Website URL" name="url" id="url" value="" size="22" tabindex="1" />
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='26217' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><div class="g-recaptcha" data-sitekey="6LfY7_4SAAAAAE2DEhMo9U4ZS1XLXf1qGXL9uzZC" data-theme="standard"></div><script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en"></script> <div id="recaptcha-submit-btn-area">&nbsp;</div>
<noscript>
            <style type='text/css'>#submit {display:none;}</style>
            <input name="submit" type="submit" id="submit-alt" tabindex="6"
                value="Submit Comment"/> 
            </noscript> </form>
</div>
</div>
</section>
</div>
<aside class="sidebar sidebar-page">
<section class="widget widget_search" id="search-2">
<form role="search" method="get" class="searchform" action="https://www.rosehosting.com/blog/">
<input type="text" value="" name="s" class="query" placeholder="Search the Blog...">
<i class="fa fa-search submit"></i>
</form>
</section><section class="widget roseh-widget"><div style="text-align: center; " id="roseh-535928404"><center><a target="_blank" href="https://linuxhostsupport.com/"><img src="https://media.rosehosting.com/img/blogads/24.jpg"></a></center></div></section><section class="widget roseh-widget"><div style="text-align: center; " id="roseh-63681789"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="6446601501"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></section><section class="widget roseh-widget"><div style="text-align: center; " id="roseh-1501951371"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="2385735863"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></section><section class="widget roseh-widget"><div style="text-align: center; " id="roseh-1062648025"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="2385735863"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></section><section class="widget widget_text" id="text-30"> <div class="textwidget"><p><center><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<br />
<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="8927217199"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></center></p>
</div>
</section>
</aside>
</div>
</section>
<footer class="page-footer">
<div class="notification noresults"><i class="fa fa-info"></i> No More Results</div>
<section class="nextprev">
<div class="wrapper-body">
<a href="https://www.rosehosting.com/blog/install-apache-maven-3-5-on-centos-7/" class="nextprev-post previous">
<div class="post-thumbnail">
<div class="background" style="background-image:url('https://www.rosehosting.com/blog/wp-content/uploads/2018/04/Install-Apache-Maven-3.5-on-CentOS-7.jpg');"></div>
</div>
<div class="info">
<span>Previous Post</span>
<h4>Install Apache Maven 3.5 on CentOS 7</h4>
</div>
</a>
<a href="https://www.rosehosting.com/blog/how-to-install-joomla-3-on-centos-7/" class="nextprev-post next">
<div class="post-thumbnail">
<div class="background" style="background-image:url('https://www.rosehosting.com/blog/wp-content/uploads/2018/04/How-to-install-Joomla-3-on-CentOS-7.jpg');"></div>
</div>
<div class="info">
<span>Next Post</span>
<h4>How to Install Joomla 3 on CentOS 7</h4>
</div>
</a>
</div>
</section>
<section id="before-footer" data-type="background" data-speed="10">
<div class="before-footer">
<div class="container">
<div class="row">
<div class="col-sm-12">
<h2 class="color-grey">Get started with RoseHosting Today.
<a href="https://secure.rosehosting.com/clientarea/index.php?/signup/" class="btn btn-lg btn-blue-belize no-margin" id="btn-signup-bottom" style="color:#fff;">Create Account</a>
</h2>
</div>
</div>
</div>
</div>
</section>
<footer class="main-footer">
<div class="container">
<div class="row">
<div class="foottab">
<div class="col-md-2 col-sm-6">
<ul class="list-unstyled">
<li class="title">Company</li>
<li><a href="https://www.rosehosting.com/about-us.html">About us</a></li>
<li><a href="https://www.rosehosting.com/policies.html">Our Policies</a></li>
<li><a href="https://www.rosehosting.com/contact-us.html">Contact Us</a></li>
<li><a href="https://www.rosehosting.com/blog">Blog</a></li>
<li><a href="https://www.rosehosting.com/why-rosehosting.html">Why Rosehosting</a></li>
<li><a href="https://www.rosehosting.com/compare-to-competition.html">Compare Us</a></li>
<li><a href="/reviews.html">Customer Reviews</a></li>
<li><a href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a><li>
</ul>
</div>
<div class="col-md-2 col-sm-6">
<ul class="list-unstyled">
<li class="title">Support</li>
<li><a href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Helpdesk System</a></li>
<li><a href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a></li>
<li><a href="https://status.rosehosting.com">Systems Status</a></li>
</ul>
</div>
</div>
<div class="foottab">
<div class="col-md-2 col-sm-6">
<ul class="list-unstyled">
<li class="title">Hosting Solutions</li>
<li><a href="https://www.rosehosting.com/linux-shared-hosting.html">Linux Shared Hosting</a></li>
<li><a href="https://www.rosehosting.com/linux-vps-hosting.html">Linux VPS Hosting</a></li>
<li><a href="https://www.rosehosting.com/vps-hosting-stacks.html">VPS Hosting Stacks</a></li>
 <li><a href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=54">Custom VPS</a></li>
<li><a href="https://www.rosehosting.com/cloud-server-oci-hosting.html">OneClick Install Cloud</a></li>
<li><a href="https://www.rosehosting.com/dedicated-servers.html">Dedicated Servers</a></li>
<li><a href="https://www.rosehosting.com/vps-affiliate-program.html">Affiliate Program</a></li>
</ul>
</div>
<div class="col-md-2 col-sm-6">
<ul class="list-unstyled">
<li class="title">Linux VPS Hosting</li>
<li><a href="https://www.rosehosting.com/centos-vps.html">CentOS VPS</a></li>
<li><a href="https://www.rosehosting.com/ubuntu-vps.html">Ubuntu VPS</a></li>
<li><a href="https://www.rosehosting.com/debian-vps.html">Debian VPS</a></li>
<li><a href="https://www.rosehosting.com/opensuse-vps.html">OpenSUSE VPS</a></li>
<li><a href="https://www.rosehosting.com/arch-linux-vps.html">Arch-Linux VPS</a></li>
<li><a href="https://www.rosehosting.com/scientific-linux-vps.html">Scientific Linux VPS</a></li>
</ul>
</div>
</div>
<div class="foottab">
<div class="col-md-2 col-sm-6">
<ul class="list-unstyled">
<li class="title">Other Services</li>
<li><a href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Domain Registration</a></li>
<li><a href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Domain Transfer</a></li>
<li><a href="https://www.rosehosting.com/ssl-certificates.html">SSL Certificates</a></li>
</ul>
</div>
<div class="col-md-2 col-sm-6">
<ul class="social-links list-unstyled">
<li class="title">Contact Us</li>
<li><a href="tel:+18887673467">(888) ROSE-HOST</a></li>
<li><a href="tel:+18887673467">(888) 767-3467</a></li>
<li><a href="tel:+16465197201">(314) 275-0414</a></li>
<li><a href="/cdn-cgi/l/email-protection#cfbcbabfbfa0bdbb8fbda0bcaaa7a0bcbba6a1a8e1aca0a2">Email us</a></li>
<li class="title social-title">Connect</li>
<li><a href="https://twitter.com/rosehosting" target="_blank"><i class="fa fa-twitter fa-fw"></i> Twitter</a></li>
<li><a href="https://www.facebook.com/RoseHosting" target="_blank"><i class="fa fa-facebook fa-fw"></i> Facebook</a></li>
<li><a href="https://plus.google.com/+Rosehosting" target="_blank"><i class="fa fa-google-plus fa-fw"></i> Google+</a></li>
<li><a href="https://www.linkedin.com/in/rosehosting" target="_blank"><i class="fa fa-linkedin fa-fw"></i> LinkedIn</a></li>
<li><a href="https://www.rosehosting.com/blog/feed/" target="_blank"><i class="fa fa-rss fa-fw"></i> RSS Feed</a></li>
</ul>
</div>
</div>
</div> 
<hr>
<div class="row">
<div class="col-sm-6 tos-links">
<a class="inline-link footer-policy" href="https://www.rosehosting.com/tos.html">Terms of Service</a> and <a class="inline-link footer-policy" href="https://www.rosehosting.com/policies.html">other policies</a>
</div>
<div class="col-sm-6 tos-links">
<p class="muted pull-right">&copy; 2001-2018 <a class="inline-link footer-policy" href="https://www.rosewebservices.com/">Rose Web Services LLC</a>.</p>
</div>
</div> 
</div> 
</footer>

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-P4FHJW"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script data-cfasync="false" src="/cdn-cgi/scripts/d07b1474/cloudflare-static/email-decode.min.js"></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P4FHJW');</script>


<script type="text/javascript" id="aff1f81b02f303eea5f87a3a065f153a" src="https://linuxhostsupport.com/chat//script.php?id=aff1f81b02f303eea5f87a3a065f153a"></script>

<div class="backtotop"><i class="fa fa-angle-double-up"></i></div>
</footer>
<div class="essb-followme essb-followme-bottom" data-full="" data-top="" data-background="rgba(255,255,255,0)" data-position="" data-avoid-left="false" data-hide="1"><div class="essb_links essb_counters essb_displayed_followme essb_share essb_template_metro-bold-retina essb_358749758 essb_links_center essb_nospace print-no" id="essb_displayed_followme_358749758" data-essb-postid="26217" data-essb-position="followme" data-essb-button-style="button_name" data-essb-template="metro-bold-retina" data-essb-counter-pos="insidename" data-essb-url="https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/" data-essb-twitter-url="https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/" data-essb-instance="358749758"><ul class="essb_links_list essb_hide_icon"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-counter-pos="insidename"><span class="essb_totalcount essb_t_l" title="Total: "><span class="essb_total_text">Total: </span><span class="essb_t_nb">2</span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/&t=How+to+install+ownCloud+10+on+Ubuntu+16.04&redirect_uri=https://www.rosehosting.com/blog?sharing-thankyou=yes" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/&t=How+to+install+ownCloud+10+on+Ubuntu+16.04&redirect_uri=https://www.rosehosting.com/blog?sharing-thankyou=yes&#39;,&#39;facebook&#39;,&#39;358749758&#39;); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook<span class="essb_counter_insidename" data-cnt="2" data-cnt-short="2">2</span></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=How+to+install+ownCloud+10+on+Ubuntu+16.04&amp;url=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/&amp;counturl=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/&#39;,&#39;twitter&#39;,&#39;358749758&#39;); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_google nolightbox"> <a href="https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/" title="" onclick="essb.window(&#39;https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/&#39;,&#39;google&#39;,&#39;358749758&#39;); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_google"></span><span class="essb_network_name">Google+<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+to+install+ownCloud+10+on+Ubuntu+16.04&amp;url=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+to+install+ownCloud+10+on+Ubuntu+16.04&amp;url=https://www.rosehosting.com/blog/how-to-install-owncloud-10-on-ubuntu-16-04/&#39;,&#39;linkedin&#39;,&#39;358749758&#39;); return false;" target="_blank" rel="nofollow"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li></ul></div></div>

<script type="application/ld+json">{
    "@context": "http://schema.org",
    "@type": "Organization",
    "additionalType": "WebHosting",
    "name": "RoseHosting.com",
    "logo": "https://www.rosehosting.com/blog/wp-content/uploads/2018/03/RoseHosting-Logo.png",
    "url": "https://www.rosehosting.com/blog",
    "sameAs": [
        "https://twitter.com/rosehosting",
        "https://www.facebook.com/RoseHosting",
        "https://www.google.com/+Rosehosting",
        "https://www.linkedin.com/in/rosehosting"
    ],
    "contactPoint": {
        "@type": "ContactPoint",
        "telephone": "+1-888-767-3467",
        "contactType": "Customer Service",
        "email": "support@rosehosting.com",
        "contactOption": "TollFree",
        "areaServed": "Canada,Mexico,United States",
        "availableLanguage": "English"
    },
    "address": {
        "@type": "PostalAddress",
        "addressCountry": "United States",
        "addressLocality": "Saint Louis",
        "addressRegion": "MO",
        "postalCode": "63368",
        "streetAddress": "2977 Hwy K #252"
    }
}</script>

<script>
		var advanced_ads_ga_UID = false;
		advanced_ads_check_adblocker=function(t){function e(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}var n=[],a=null;return e(function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),e(function(){var e=window.getComputedStyle&&window.getComputedStyle(t),o=e&&e.getPropertyValue("-moz-binding");a=e&&"none"===e.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0;i<n.length;i++)n[i](a);n=[]})}),function(t){if(null===a)return void n.push(t);t(a)}}(),function(){var t=function(t,e){this.name=t,this.UID=e,this.analyticsObject=null;var n=this,a={hitType:"event",eventCategory:"Advanced Ads",eventAction:"AdBlock",eventLabel:"Yes",nonInteraction:!0,transport:"beacon"};this.analyticsObject="string"==typeof GoogleAnalyticsObject&&"function"==typeof window[GoogleAnalyticsObject]&&window[GoogleAnalyticsObject],!1===this.analyticsObject?(!function(t,e,n,a,o,i,d){t.GoogleAnalyticsObject=o,t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)},t[o].l=1*new Date,i=e.createElement(n),d=e.getElementsByTagName(n)[0],i.async=1,i.src="https://www.google-analytics.com/analytics.js",d.parentNode.insertBefore(i,d)}(window,document,"script",0,"_advads_ga"),_advads_ga("create",n.UID,"auto",this.name),_advads_ga(n.name+".send",a)):(window.console&&window.console.log("Advanced Ads Analytics >> using other's variable named `"+GoogleAnalyticsObject+"`"),window[GoogleAnalyticsObject]("create",n.UID,"auto",this.name),window[GoogleAnalyticsObject](n.name+".send",a))};advanced_ads_check_adblocker(function(e){e&&"string"==typeof advanced_ads_ga_UID&&advanced_ads_ga_UID&&new t("advadsTracker",advanced_ads_ga_UID)})}();
		
		</script> <script type="text/javascript">
            var sub = document.getElementById('submit');
            document.getElementById('recaptcha-submit-btn-area').appendChild (sub);
            document.getElementById('submit').tabIndex = 6;
            if ( typeof _recaptcha_wordpress_savedcomment != 'undefined') {
                document.getElementById('comment').value = 
                    _recaptcha_wordpress_savedcomment;
            }
            </script><script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/eckoplugin/assets/js/eckoplugin.js?ver=2.6.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ecko_theme_vars = {"general_hidecomments":"false","general_disable_syntax_highlighter":"false","topbar_disable_sticky":"","postpage_enable_cover_fade":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2016/assets/js/theme.min.js?ver=2.2.1'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/comment-reply.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/easy-social-share-buttons3/assets/js/essb-core.js?ver=5.4'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.1.4'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/wp-embed.min.js?ver=4.9.5'></script>
<link rel="stylesheet" id="essb-cct-style" href="https://www.rosehosting.com/blog/wp-content/plugins/easy-social-share-buttons3/lib/modules/click-to-tweet/assets/css/styles.css" type="text/css" media="all" /><script type="text/javascript"></script>
<script>
// jQuery('#awardsModal').appendTo("body");
</script>
</body>
</html>
