<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US"
	prefix="og: http://ogp.me/ns#" >
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US"
	prefix="og: http://ogp.me/ns#" >
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US"
	prefix="og: http://ogp.me/ns#" >
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="pingback" href="https://www.rosehosting.com/blog/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://www.rosehosting.com/blog/wp-content/themes/Extra/scripts/ext/html5.js?x68100&amp;x68100" defer='defer" type="text/javascript"></script>
	<![endif]-->
<script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KVJ4PJ');</script>

<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<script>var et_site_url='https://www.rosehosting.com/blog';var et_post_id='31434';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>Install Cockpit on Debian 9 | RoseHosting</title>

<meta name="description" content="In this tutorial, we will guide you through the steps of installing Cockpit on a Debian 9 VPS as well as configure the Apache web server as a reverse proxy," />
<link rel="canonical" href="https://www.rosehosting.com/blog/install-cockpit-on-debian-9/" />
<meta property="og:title" content="Install Cockpit on Debian 9 | RoseHosting" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.rosehosting.com/blog/install-cockpit-on-debian-9/" />
<meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2019/07/how-to-install-cockpit-on-debian9.jpg" />
<meta property="og:site_name" content="RoseHosting.com Blog" />
<meta property="og:description" content="In this tutorial, we will guide you through the steps of installing Cockpit on a Debian 9 VPS as well as configure the Apache web server as a reverse proxy, that way you can access Cockpit with your" />
<meta property="article:tag" content="debian" />
<meta property="article:tag" content="tutorials" />
<meta property="article:tag" content="cockpit" />
<meta property="article:publisher" content="https://www.facebook.com/RoseHosting/" />
<meta property="article:author" content="https://www.facebook.com/RoseHosting/" />
<meta property="article:published_time" content="2019-07-20T02:53:50Z" />
<meta property="article:modified_time" content="2019-07-20T02:53:50Z" />
<meta property="og:image:secure_url" content="https://www.rosehosting.com/blog/wp-content/uploads/2019/07/how-to-install-cockpit-on-debian9.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@RoseHosting" />
<meta name="twitter:creator" content="@rosehosting" />
<meta name="twitter:title" content="Install Cockpit on Debian 9 | RoseHosting" />
<meta name="twitter:description" content="In this tutorial, we will guide you through the steps of installing Cockpit on a Debian 9 VPS as well as configure the Apache web server as a reverse proxy, that way you can access Cockpit with your" />
<meta name="twitter:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2019/07/how-to-install-cockpit-on-debian9.jpg" />

<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Feed" href="https://www.rosehosting.com/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Comments Feed" href="https://www.rosehosting.com/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Install Cockpit on Debian 9 Comments Feed" href="https://www.rosehosting.com/blog/install-cockpit-on-debian-9/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.rosehosting.com\/blog\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><meta content="rh2018 Template:       Extra Version:        1.0.0 v." name="generator" /><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.rosehosting.com/blog/wp-includes/css/dist/block-library/style.min.css?x68100&amp;x68100' type='text/css' media='all' />
<link rel='stylesheet' id='ez-icomoon-css' href='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/icomoon/style.min.css?x68100&amp;x68100' type='text/css' media='all' />
<link rel='stylesheet' id='ez-toc-css' href='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/assets/css/screen.min.css?x68100&amp;x68100' type='text/css' media='all' />
<style id='ez-toc-inline-css' type='text/css'>
div#ez-toc-container p.ez-toc-title {font-size: 22px;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}div#ez-toc-container {width: 100%;}
</style>
<link rel='stylesheet' id='parent-style-css' href='https://www.rosehosting.com/blog/wp-content/themes/Extra/style.css?x68100&amp;x68100' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css' href='https://www.rosehosting.com/blog/wp-content/themes/rh2018/css/bootstrap.css?x68100&amp;x68100' type='text/css' media='all' />
<link rel='stylesheet' id='theme-style-css' href='https://www.rosehosting.com/blog/wp-content/themes/rh2018/css/theme.css?x68100&amp;x68100' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css' href='https://www.rosehosting.com/blog/wp-content/themes/rh2018/style.css?x68100&amp;x68100' type='text/css' media='all' />
<link rel='stylesheet' id='et-builder-googlefonts-cached-css' href='https://fonts.googleapis.com/css?family=Cabin%3Aregular%2Citalic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://www.rosehosting.com/blog/wp-includes/css/dashicons.min.css?x68100&amp;x68100' type='text/css' media='all' />
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery.js?x68100&amp;x68100'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery-migrate.min.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/popper.js/1.11.0/umd/popper.min.js' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2018/js/bootstrap.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2018/js/cookieconsent.min.js?x68100&amp;x68100' defer='defer'></script>
<link rel='https://api.w.org/' href='https://www.rosehosting.com/blog/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rosehosting.com/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rosehosting.com/blog/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='How to Install Lighttpd on CentOS 7' href='https://www.rosehosting.com/blog/how-to-install-lighttpd-on-centos-7/' />
<link rel='next' title='How to Configure a Firewall with UFW on Ubuntu 18.04' href='https://www.rosehosting.com/blog/how-to-configure-a-firewall-with-ufw-on-ubuntu-18-04/' />
<meta name="generator" content="WordPress 5.2.2" />
<link rel='shortlink' href='https://www.rosehosting.com/blog/?p=31434' />
<link rel="alternate" type="application/json+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Finstall-cockpit-on-debian-9%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Finstall-cockpit-on-debian-9%2F&#038;format=xml" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" />
<script type="text/javascript">var essb_settings = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","essb3_nonce":"aebf62c7e9","essb3_plugin_url":"https:\/\/www.rosehosting.com\/blog\/wp-content\/plugins\/easy-social-share-buttons3","essb3_stats":false,"essb3_ga":false,"essb3_ga_mode":"simple","blog_url":"https:\/\/www.rosehosting.com\/blog\/","essb3_postfloat_stay":false,"post_id":31434};var essb_buttons_exist = !!document.getElementsByClassName("essb_links"); if(essb_buttons_exist == true) { document.addEventListener("DOMContentLoaded", function(event) { var ESSB_CACHE_URL = "https://www.rosehosting.com/blog/install-cockpit-on-debian-9/"; if(ESSB_CACHE_URL.indexOf("?") > -1) { ESSB_CACHE_URL += "&essb_counter_cache=rebuild"; } else { ESSB_CACHE_URL += "?essb_counter_cache=rebuild"; }; var xhr = new XMLHttpRequest(); xhr.open("GET",ESSB_CACHE_URL,true); xhr.send(); });}</script><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-270x270.png" />
<link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://www.rosehosting.com/blog/wp-content/cache/et/global/et-extra-customizer-global-15637696710618.min.css?x68100" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /></head>
<body class="post-template-default single single-post postid-31434 single-format-standard et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
<div id="page-container" class="page-container">
<nav class="navbar yamm navbar-expand-lg navbar-dark" role="navigation">
<div class="container no-override">
<a class="navbar-brand" href="https://www.rosehosting.com/">
<img alt="RoseHosting.com" width="186" height="37" class="d-lg-inline mr-2" src="https://www.rosehosting.com/blog/wp-content/themes/rh2018/img/rh-logo.svg" />
</a>
<button class="navbar-toggler" data-toggle="collapse" data-target="#navbar-collapse">
<span class="navbar-toggler-icon"></span>
</button>
<div class="collapse navbar-collapse justify-content-end" id="navbar-collapse">
<ul class="navbar-nav">
<li class="nav-item active dropdown">
<a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
Hosting Solutions
<i class="fa fa-chevron-down"></i>
</a>
<div class="dropdown-menu" role="menu">
<div class="yamm-content">
<div class="row">
<div class="col-sm-6">
<span class="text-primary  dropdown-header"><strong>Managed SSD Hosting</strong></span>
<div class="dropdown-divider"></div>
<a class="dropdown-item" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
<a class="dropdown-item" href="https://www.rosehosting.com/linux-vps-hosting.html">Linux VPS Hosting</a>
<a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom VPS</a>
<a class="dropdown-item" href="https://www.rosehosting.com/dedicated-servers.html">Cloud Dedicated Servers</a>
<a class="dropdown-item" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting <span class="ml-2 badge badge-success">new</span></a>
</div>
<div class="col-sm-6">
 <span class="text-primary dropdown-header"><strong>Managed Solutions</strong></span>
<div class="dropdown-divider"></div>
<a class="dropdown-item" href="https://www.rosehosting.com/wordpress-hosting.html">
Wordpress Hosting
<small class="d-block text-muted"><i>The best blogging platform</i></small>
</a>
<a class="dropdown-item" href="https://www.rosehosting.com/magento-hosting.html">
Magento Hosting
<small class="d-block text-muted"><i>The best e-commerce platform</i></small>
</a>
<a class="dropdown-item" href="https://www.rosehosting.com/odoo-hosting.html">
Odoo Hosting
<small class="d-block text-muted"><i>The best CRM/ERP platform</i></small>
</a>
<span class="dropdown-item"><a class="btn-shadow btn-shadow-primary btn-shadow-sm" target="_blank" href="https://www.rosehosting.com/hosting-solutions.html">Other Solutions</a></span>
</div>
</div>
</div>
</div>
</li>
<li class="nav-item dropdown">
<a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
SSL / Domains
<i class="fa fa-chevron-down"></i>
</a>
<div class="dropdown-menu" role="menu">
<div class="yamm-content">
<div class="row">
<div class="col-sm-3">
<span class="text-primary  dropdown-header"><strong>SSL by brand</strong></span>
<div class="dropdown-divider"></div>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#geotrust">GeoTrust</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#comodo">Comodo</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#rapidssl">RapidSSL</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#thawte">Thawte</a>
</div>
<div class="col-sm-4">
<span class="text-primary  dropdown-header"><strong>SSL by Type</strong></span>
<div class="dropdown-divider"></div>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#domain_validation">Domain Validation</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#organization_validation">Organization Validation</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#extended_validation">Extended Validation</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#wildcard_ssl">Wildcard SSL</a>
</div>
<div class="col-sm-3">
<span class="text-primary dropdown-header"><strong>Domains</strong></span>
<div class="dropdown-divider"></div>
<a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Register Domains</a>
<a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Transfer Domains</a>
</div>
</div>
</div>
</div>
<li class="nav-item dropdown">
<a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
Support
<i class="fa fa-chevron-down"></i>
</a>
<div class="dropdown-menu" role="menu">
<a class="dropdown-item" href="https://www.rosehosting.com/support.html">24/7 Managed Support</a>
<a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Open a Support Ticket</a>
<a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>
<a class="dropdown-item" href="https://status.rosehosting.com">Systems Status</a>
</div>
</li>
<li class="nav-item dropdown">
<a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
About Us
<i class="fa fa-chevron-down"></i>
</a>
<div class="dropdown-menu" role="menu">
<a class="dropdown-item" href="https://www.rosehosting.com/about-us.html">Our Company</a>
<a class="dropdown-item" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
<a class="dropdown-item" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
<a class="dropdown-item" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
<a class="dropdown-item" href="https://www.rosehosting.com/policies.html">Our Policies</a>
</div>
</li>
<li class="nav-item">
<a class="nav-link" href="https://www.rosehosting.com/blog/">Blog</a>
</li>
<li class="nav-item">
<a class="nav-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Affiliates</a>
</li>
<li class="nav-item">
<a class="nav-link nav-link--rounded" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Login</a>
</li>
</ul>
</div>
</div>
</nav>
<nav class="navbar navbar-expand-md navbar-light bg-faded navbar-blog" style="z-index:1029;">
<div class="container no-override">
<a href="https://www.rosehosting.com/blog/" class="navbar-brand">Blog Home</a>
<div class="navbar-collapse collapse d-flex justify-content-between" id="navbar5-blog">
<ul class="navbar-nav categories">
<li class="nav-item dropdown">
<a class="nav-link dropdown-toggle" data-toggle="dropdown" href="#" role="button" aria-haspopup="true" aria-expanded="false">
Categories
<i class="fa fa-chevron-down"></i>
</a>
<div class="dropdown-menu">
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/caching/">Caching</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/centos/">CentOS</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/cms-crm-erp/">CMS, CRM, ERP</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/control-panels/">Control Panels</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/databases/">Databases</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/debian/">Debian</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/e-commerce/">E-Commerce</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/email-servers/">Email Servers</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/guides/">Guides</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/load-balancing/">Load Balancing</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/miscellaneous/">Miscellaneous</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/networking-and-domains/">Networking and Domains</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/news/">News</a>
 <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/optimization/">Optimization</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/other/">Other</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/rosehosting/">RoseHosting Platform</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/scripts/">Scripts</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/security/">Security</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/seo/">SEO</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tips-and-tricks/">Tips and Tricks</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tutorials/">Tutorials</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/ubuntu/">Ubuntu</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-frameworks/">Web Frameworks</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-servers/">Web Servers</a>
</div>
</li>
</ul>
<form class="mx-2 my-auto d-inline" method="get" id="searchform" action="https://www.rosehosting.com/blog/">
<div class="input-group">
<input type="search" class="field" name="s" id="s" class="form-control border border-right-0" placeholder="Search...">
<span class="input-group-append">
<button name="submit" id="searchsubmit" class="btn btn-outline-secondary border border-left-0" type="submit">
<i class="fa fa-search"></i>
</button>
</span>
</div>
</form>
</div>
</div>
</nav>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<article id="post-31434" class="module single-post-module post-31434 post type-post status-publish format-standard has-post-thumbnail hentry category-debian category-tutorials tag-cockpit tag-debian et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">Install Cockpit on Debian 9</h1>
<div class="post-meta vcard">
<p>Posted by <a href="https://www.rosehosting.com/blog/author/r0s3admin/" class="url fn" title="Posts by admin" rel="author">admin</a> | <span class="updated">Jul 19, 2019</span> | <a href="https://www.rosehosting.com/blog/category/debian/" rel="tag">Debian</a>, <a href="https://www.rosehosting.com/blog/category/tutorials/" rel="tag">Tutorials</a> | <a class="comments-link" href="https://www.rosehosting.com/blog/install-cockpit-on-debian-9/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a></p>
</div>
</div>
<div class="post-thumbnail header">
<img src="https://www.rosehosting.com/blog/wp-content/uploads/2019/07/how-to-install-cockpit-on-debian9.jpg" alt="Install Cockpit on Debian 9" /> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<p><img class="alignnone size-full wp-image-31449" src="https://www.rosehosting.com/blog/wp-content/uploads/2019/07/how-to-install-cockpit-on-debian9.jpg" alt="" width="742" height="372" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2019/07/how-to-install-cockpit-on-debian9.jpg 742w, https://www.rosehosting.com/blog/wp-content/uploads/2019/07/how-to-install-cockpit-on-debian9-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2019/07/how-to-install-cockpit-on-debian9-300x150.jpg 300w" sizes="(max-width: 742px) 100vw, 742px" /></p>
<p>In this tutorial, we will guide you through the steps of installing Cockpit on a <a href="https://www.rosehosting.com/debian-hosting.html">Debian 9 VPS</a> as well as configure the Apache web server as a reverse proxy, that way you can access Cockpit with your domain name.</p>
<p><img class="size-full wp-image-31450 alignright" src="https://www.rosehosting.com/blog/wp-content/uploads/2019/07/set-up-cockpit-project-easily-with-reverse-proxy-on-debian9-vps.jpg" alt="" width="150" height="150" />Cockpit is a free and open-source lightweight and powerful remote manager for GNU/Linux servers. Cockpit allows you to easily and quickly manage and administer your Linux servers through an intuitive web interface &#8211; it even allows you to use the server&#8217;s command line inside of the browser itself! Let&#8217;s begin with the installation.<span id="more-31434"></span></p>
<div id="ez-toc-container" class="counter-hierarchy ez-toc-transparent">
<div class="ez-toc-title-container">
<p class="ez-toc-title">Table of Contents</p>
<span class="ez-toc-title-toggle"><a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a></span></div>
<nav><ul class="ez-toc-list"><li><a href="#Prerequisites" title="Prerequisites">Prerequisites</a></li><li><a href="#Step-1-Log-in-and-Update-the-Server" title="Step 1: Log in and Update the Server">Step 1: Log in and Update the Server</a></li><li><a href="#Step-2-Install-Cockpit" title="Step 2: Install Cockpit">Step 2: Install Cockpit</a></li><li><a href="#Step-3-Install-and-Configure-Apache-as-a-Reverse-Proxy" title="Step 3: Install and Configure Apache as a Reverse Proxy">Step 3: Install and Configure Apache as a Reverse Proxy</a></li></ul></nav></div>
<h2><span class="ez-toc-section" id="Prerequisites"><strong>Prerequisites</strong></span></h2>
<ul>
<li>A <a href="https://www.rosehosting.com/debian-hosting.html">Debian 9 VPS</a>. For the purposes of this tutorial we will use our SSD 1 VPS hosting plan.</li>
<li> system user with root privileges.</li>
</ul>
<h2><span class="ez-toc-section" id="Step-1-Log-in-and-Update-the-Server"><strong>Step 1: Log in and Update the Server</strong></span></h2>
<p>Log into your Debian 9 VPS via SSH as the root user, or as another user with root privileges:</p>
<pre>ssh <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="d8aab7b7ac98">[email&#160;protected]</a><span style="color: #ff0000;">IP_Address</span> -p <span style="color: #ff0000;">Port_number</span></pre>
<p>where &#8216;<span style="color: #ff0000;">IP_Address</span>&#8216; and &#8216;<span style="color: #ff0000;">Port_number</span>&#8216; are the actual IP address of your server and the SSH port number.</p>
<p>Once you are logged in, make sure that all installed packages on the server are updated to the latest available version by running the following commands</p>
<pre>apt update &amp;&amp; apt upgrade</pre>
<p>You can also <a href="https://www.rosehosting.com/blog/how-to-enable-automatic-updates-on-a-linux-vps/" target="_blank" rel="noopener noreferrer">enable automatic updates</a> on your Debian 9 VPS by following one of our previous tutorials.</p>
<h2><span class="ez-toc-section" id="Step-2-Install-Cockpit"><strong>Step 2: Install Cockpit</strong></span></h2>
<p>Cockpit is included in the Debian 9 &#8216;backports&#8217; repositories, therefore it can be easily installed using the apt package manager. In order to do that, we have to enable the Debian &#8216;backports&#8217; repository:</p>
<pre>echo 'deb http://deb.debian.org/debian stretch-backports main' &gt; \
 /etc/apt/sources.list.d/backports.list</pre>
<p>Once it is enabled, update the repository list:</p>
<pre>apt update</pre>
<p>Once the repository list is updated, run the following command to install Cockpit along with all of its dependencies:</p>
<pre>apt -y install cockpit</pre>
<p>Enable the Cockpit service to automatically start after a server reboot:</p>
<pre>systemctl enable cockpit</pre>
<p>After the installation is completed, Cockpit should be automatically started. You can check its status by issuing the following command:</p>
<pre>systemctl status cockpit</pre>
<p>Output:</p>
<pre>cockpit.service - Cockpit Web Service
   Loaded: loaded (/lib/systemd/system/cockpit.service; static; vendor preset: enabled)
   Active: active (running) since Tue 2019-07-02 05:44:29 EDT; 2min 33s ago
     Docs: man:cockpit-ws(8)
  Process: 9737 ExecStartPre=/usr/sbin/remotectl certificate --ensure --user=root --group=cockpit-ws --selinux-type= (code=exited, status=0/SUCCESS)
 Main PID: 9740 (cockpit-ws)
    Tasks: 3 (limit: 4915)
   CGroup: /system.slice/cockpit.service
           ââ9740 /usr/lib/cockpit/cockpit-ws
           ââ9746 /usr/bin/ssh-agent

Jul 02 05:44:30 hostname cockpit-ws[9740]: logged in user session</pre>
<p>The status output shows that Cockpit is up and running on your Debian 9 VPS and you can already start using it. Cockpit by default is listening on port 9090 and at this point you can access it by navigating your favorite web browser to <code>http://Your_IP/9090</code> . However, you might not have a web server installed, so we&#8217;ll be showing you how to do that in the next step. On top of that, we will also show you how to configure the web server, so you can access Cockpit with a domain name instead of your server&#8217;s IP address.</p>
<h2><span class="ez-toc-section" id="Step-3-Install-and-Configure-Apache-as-a-Reverse-Proxy"><strong>Step 3: Install and Configure Apache as a Reverse Proxy</strong></span></h2>
<p>Apache is the most popular web server in the world. We will install it for the purposes of this tutorial and use it as a reverse proxy. If Apache is not already installed on your Debian 9 VPS, you can easily install it using the following command:</p>
<pre>apt -y install apache2</pre>
<p>After the installation has been completed, the web server should be automatically started and running on your server. Check its status to make sure that it&#8217;s running:</p>
<pre>systemctl status apache2</pre>
<p>Output:</p>
<pre>apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset:
  Drop-In: /lib/systemd/system/apache2.service.d
           └─apache2-systemd.conf
   Active: active (running) since Thu 2019-07-04 05:02:57 CDT; 4h 35min ago
  Process: 1766 ExecReload=/usr/sbin/apachectl graceful (code=exited, status=0/S
  Process: 692 ExecStart=/usr/sbin/apachectl start (code=exited, status=0/SUCCES
 Main PID: 790 (apache2)
    Tasks: 8 (limit: 1112)
   CGroup: /system.slice/apache2.service
           ├─  790 /usr/sbin/apache2 -k start
           ├─ 1865 /usr/sbin/apache2 -k start
           ├─ 1866 /usr/sbin/apache2 -k start
           ├─ 1867 /usr/sbin/apache2 -k start
           ├─ 1871 /usr/sbin/apache2 -k start
           ├─ 1872 /usr/sbin/apache2 -k start
           ├─13591 /usr/sbin/apache2 -k start
           └─13662 /usr/sbin/apache2 -k start
</pre>
<p>Make sure to enable the Apache web server to automatically start after a server reboot:</p>
<pre>systemctl enable apache2</pre>
<p>Next, we will create an Apache virtual host for the domain name which we will use to access Cockpit. For our example, we will use <code>domain.com</code>, so make sure to change all instances of that domain name to your unique domain name. Create an Apache configuration file with the following contents:</p>
<pre>nano /etc/apache2/sites-available/<span style="color: #ff0000;">domain.com</span>.conf

&lt;VirtualHost *:80&gt;
ServerName <span style="color: #ff0000;">domain.com</span>
ServerAlias www.<span style="color: #ff0000;">domain.com</span>

ProxyRequests Off

Order deny,allow
Allow from all


RewriteEngine On
RewriteCond %{HTTP:Upgrade} =websocket [NC]
RewriteRule /(.*) ws://127.0.0.1:9090/$1 [P,L]
RewriteCond %{HTTP:Upgrade} !=websocket [NC]
RewriteRule /(.*) http://127.0.0.1:9090/$1 [P,L]

ProxyPass / http://127.0.0.1:9090/
ProxyPassReverse / http://127.0.0.1:9090/

Order allow,deny
Allow from all
&lt;/VirtualHost&gt;</pre>
<p>Save the file and activate the virtual host with the following command:</p>
<pre>a2ensite<span style="color: #ff0000;"> domain.com</span></pre>
<p>And then restart the web server for the changes to take effect:</p>
<pre>systemctl restart apache2</pre>
<p>Finally, you should be able to access Cockpit with your domain name at http://<span style="color: #ff0000;">domain.com</span> and use one of your system users to log into the application.</p>
<p><img class="aligncenter size-full wp-image-31435" src="https://www.rosehosting.com/blog/wp-content/uploads/2019/07/cockpit.png" alt="" width="845" height="349" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2019/07/cockpit.png 845w, https://www.rosehosting.com/blog/wp-content/uploads/2019/07/cockpit-150x62.png 150w, https://www.rosehosting.com/blog/wp-content/uploads/2019/07/cockpit-300x124.png 300w, https://www.rosehosting.com/blog/wp-content/uploads/2019/07/cockpit-768x317.png 768w" sizes="(max-width: 845px) 100vw, 845px" /></p>
<p>That&#8217;s it! You now have a working setup of Cockpit on your Debian 9 VPS.</p>
<hr />
<p><img class="alignleft size-full wp-image-31451" src="https://www.rosehosting.com/blog/wp-content/uploads/2019/07/managed-cockpit-support-debian9.jpg" alt="" width="150" height="150" />Of course, you don’t have to install Cockpit on Debian 9, if you use one of our <a href="https://www.rosehosting.com/debian-hosting.html">Managed Debian Hosting</a> solutions, in which case you can simply ask our expert Linux admins to setup Cockpit on Debian 9 for you. They are available 24×7 and will take care of your request immediately.</p>
<p><span style="color: #ff0000;"><strong>PS.</strong></span> If you liked this post on how to install Cockpit on a Debian 9 VPS, please share it with your friends on the social networks using the share buttons below, or simply leave a comment down in the comments section. Thanks.</p>
<div class="essb_links essb_counters essb_displayed_followme essb_share essb_template_bold-retina essb_421565581 essb_links_center essb_mobile_hidden print-no" id="essb_displayed_followme_421565581" data-essb-postid="31434" data-essb-position="followme" data-essb-button-style="button_name" data-essb-template="bold-retina" data-essb-counter-pos="insidename" data-essb-url="https://www.rosehosting.com/blog/install-cockpit-on-debian-9/" data-essb-twitter-url="https://www.rosehosting.com/blog/install-cockpit-on-debian-9/" data-essb-instance="421565581"><ul class="essb_links_list essb_hide_icon"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-counter-pos="insidename"><span class="essb_totalcount essb_t_l" title="Total: "><span class="essb_total_text">Total: </span><span class="essb_t_nb">2</span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/install-cockpit-on-debian-9/&t=Install+Cockpit+on+Debian+9" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/install-cockpit-on-debian-9/&t=Install+Cockpit+on+Debian+9&#39;,&#39;facebook&#39;,&#39;421565581&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook<span class="essb_counter_insidename" data-cnt="2" data-cnt-short="2">2</span></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=Install+Cockpit+on+Debian+9&amp;url=https://www.rosehosting.com/blog/install-cockpit-on-debian-9/&amp;counturl=https://www.rosehosting.com/blog/install-cockpit-on-debian-9/&#39;,&#39;twitter&#39;,&#39;421565581&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Install+Cockpit+on+Debian+9&amp;url=https://www.rosehosting.com/blog/install-cockpit-on-debian-9/" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Install+Cockpit+on+Debian+9&amp;url=https://www.rosehosting.com/blog/install-cockpit-on-debian-9/&#39;,&#39;linkedin&#39;,&#39;421565581&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_print nolightbox"> <a href="#" title="" onclick="essb.print(&#39;421565581&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_print"></span><span class="essb_network_name">Print<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_mail nolightbox"> <a href="#" title="" onclick="essb_open_mailform(&#39;421565581&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_mail"></span><span class="essb_network_name">Email<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li></ul></div> </div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
</div>
<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #dc3545;
									}
								</style>
</div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="https://www.rosehosting.com/blog/how-to-install-lighttpd-on-centos-7/" rel="prev"><span class="button">Previous</span><span class="title">How to Install Lighttpd on CentOS 7</span></a> </div>
<div class="nav-link nav-link-next">
<a href="https://www.rosehosting.com/blog/how-to-configure-a-firewall-with-ufw-on-ubuntu-18-04/" rel="next"><span class="button">Next</span><span class="title">How to Configure a Firewall with UFW on Ubuntu 18.04</span></a> </div>
</div>
</nav>
<div class="et_extra_other_module related-posts">
<div class="related-posts-header">
<h3>Related Posts</h3>
</div>
<div class="related-posts-content clearfix">
<div class="related-post">
<div class="featured-image"><a href="https://www.rosehosting.com/blog/how-to-install-rocket-chat-on-ubuntu-16-04/" title="How to Install Rocket.Chat on Ubuntu 16.04" class="post-thumbnail">
<img src="https://www.rosehosting.com/blog/wp-content/uploads/2018/09/How-to-Install-Rocket.Chat-on-Ubuntu-16.04-440x264.jpg" alt="How to Install Rocket.Chat on Ubuntu 16.04" /><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="https://www.rosehosting.com/blog/how-to-install-rocket-chat-on-ubuntu-16-04/">How to Install Rocket.Chat on Ubuntu 16.04</a></h4>
<p class="date"><span class="updated">September 10, 2018</span></p>
</div>
<div class="related-post">
<div class="featured-image"><a href="https://www.rosehosting.com/blog/how-to-install-php-7-2-on-debian-9/" title="How to Install PHP 7.2 on Debian 9" class="post-thumbnail">
<img src="https://www.rosehosting.com/blog/wp-content/uploads/2018/09/How-to-Install-PHP-7.2-on-Debian-9-440x264.jpg" alt="How to Install PHP 7.2 on Debian 9" /><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="https://www.rosehosting.com/blog/how-to-install-php-7-2-on-debian-9/">How to Install PHP 7.2 on Debian 9</a></h4>
<p class="date"><span class="updated">September 6, 2018</span></p>
</div>
<div class="related-post">
<div class="featured-image"><a href="https://www.rosehosting.com/blog/virtual-users-and-domains-with-sendmail/" title="Virtual Users And Domains With Sendmail" class="post-thumbnail">
<img src="https://www.rosehosting.com/blog/wp-content/uploads/2012/05/sendmail_0_129266.jpg" alt="Virtual Users And Domains With Sendmail" /><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="https://www.rosehosting.com/blog/virtual-users-and-domains-with-sendmail/">Virtual Users And Domains With Sendmail</a></h4>
<p class="date"><span class="updated">May 2, 2012</span></p>
</div>
<div class="related-post">
<div class="featured-image"><a href="https://www.rosehosting.com/blog/how-to-install-groupoffice-an-enterprise-crm-and-collaboration-tool-on-debian-7-wheezy/" title="How to install Group Office (an enterprise CRM and collaboration tool) on Debian 7 (Wheezy)" class="post-thumbnail">
<img src="https://www.rosehosting.com/blog/wp-content/uploads/2013/10/how-to-install-groupoffice-an-enterprise-crm-and-collaboration-tool-on-debian-7-wheezy.png" alt="How to install Group Office (an enterprise CRM and collaboration tool) on Debian 7 (Wheezy)" /><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="https://www.rosehosting.com/blog/how-to-install-groupoffice-an-enterprise-crm-and-collaboration-tool-on-debian-7-wheezy/">How to install Group Office (an enterprise CRM and collaboration tool) on Debian 7 (Wheezy)</a></h4>
<p class="date"><span class="updated">October 17, 2013</span></p>
</div>
 </div>
</div>

<section id="comment-wrap">
<div id="comments" class="nocomments">

</div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/install-cockpit-on-debian-9/#respond" style="display:none;">Cancel reply</a></small></h3> <form action="https://www.rosehosting.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form">
<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea autocomplete="nope" id="c361717e43" name="c361717e43" cols="45" rows="8" aria-required="true"></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="nope" style="padding:0;clip:rect(1px, 1px, 1px, 1px);position:absolute !important;white-space:nowrap;height:1px;width:1px;overflow:hidden;" tabindex="-1"></textarea><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">document.getElementById("comment").setAttribute( "id", "abfdf69c84355d36d1fef72ce4853fd4" );document.getElementById("c361717e43").setAttribute( "id", "comment" );</script></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='31434' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><div class="g-recaptcha" data-sitekey="6LfY7_4SAAAAAE2DEhMo9U4ZS1XLXf1qGXL9uzZC" data-theme="standard"></div><script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en"></script> <div id="recaptcha-submit-btn-area">&nbsp;</div>
<noscript>
            <style type='text/css'>#submit {display:none;}</style>
            <input name="submit" type="submit" id="submit-alt" tabindex="6"
                value="Submit Comment"/> 
            </noscript> </form>
</div>
</section>
</div>
<div class="et_pb_extra_column_sidebar">
<div class="et_pb_widget roseh-widget"><h4 class="widgettitle"> </h4><div style="text-align: center; " id="roseh-1394495773"><center><a target="_blank" href="https://www.rosehosting.com/cloud-vps-hosting.html"><img src="https://media.rosehosting.com/images/blogads/dark.jpg" alt="Cloud VPS Hosting"></a></center>
</div></div> <div class="et_pb_widget roseh-widget"><h4 class="widgettitle"> </h4><div style="text-align: center; " id="roseh-1204568753"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="2385735863"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div> <div class="et_pb_widget roseh-widget"><h4 class="widgettitle"> </h4><div style="text-align: center; " id="roseh-682391664"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="8927217199"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div> <div id="custom_html-4" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"> </h4><div class="textwidget custom-html-widget">
<link href="//cdn-images.mailchimp.com/embedcode/slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://rosehosting.us9.list-manage.com/subscribe/post?u=f1868632d497b649bacf4c210&amp;id=df0b8333a5" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Get the newest Articles and Discounts before everyone else</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_f1868632d497b649bacf4c210_df0b8333a5" tabindex="-1" value=""></div>
<div class="dnmclear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
</div></div> </div>
</div> 
</div> 
</div> 

<footer class="footer-big-menu">
<div class="container">
<div class="row menu">
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title mb-2">Company</h3>
<a class="menu-link" href="https://www.rosehosting.com/about-us.html">About us</a>
<a class="menu-link" href="https://www.rosehosting.com/policies.html">Our Policies</a>
<a class="menu-link" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
<a class="menu-link" href="https://www.rosehosting.com/blog/">Blog</a>
<a class="menu-link" href="https://www.rosehosting.com/why-rosehosting.html">Why RoseHosting</a>
<a class="menu-link" href="https://www.rosehosting.com/compare-to-competition.html">Compare Us</a>
<a class="menu-link" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
<a class="menu-link" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
</div>
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title  mb-2">Support</h3>
<a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Helpdesk System</a>
<a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>
<a class="menu-link" href="https://status.rosehosting.com">Systems Status</a>
<h3 class="menu-title  mb-2 mt-4">Other Services</h3>
<a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Domain Registration</a>
<a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Domain Transfer</a>
<a class="menu-link" href="https://www.rosehosting.com/ssl-certificates.html">SSL Certificates</a>
</div>
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title  mb-2">Hosting</h3>
<a class="menu-link" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/linux-vps-hosting.html">Linux VPS Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting</a>
<a class="menu-link" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom SSD VPS</a>
<a class="menu-link" href="https://www.rosehosting.com/dedicated-servers.html">Cloud Dedicated Servers</a>
<a class="menu-link" href="https://www.rosehosting.com/hosting-solutions.html">Hosting Solutions</a>
<a class="menu-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Affiliate Program</a>
</div>
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title  mb-2">Linux VPS Hosting</h3>
<a class="menu-link" href="https://www.rosehosting.com/centos-hosting.html">CentOS Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/ubuntu-hosting.html">Ubuntu Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/debian-hosting.html">Debian Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/opensuse-hosting.html">OpenSUSE Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/arch-linux-hosting.html">Arch-Linux Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/scientific-linux-hosting.html">Scientific Linux Hosting</a>
</div>
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title  mb-2">Apps Hosting</h3>
<a class="menu-link" href="https://www.rosehosting.com/wordpress-hosting.html">WordPress Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/magento-hosting.html">Magento Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/odoo-hosting.html">Odoo Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/joomla-hosting.html">Joomla Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/drupal-hosting.html">Drupal Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/laravel-hosting.html">Laravel Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/nextcloud-hosting.html">NextCloud Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/prestashop-hosting.html">PrestaShop Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/ghost-hosting.html">Ghost Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/mediawiki-hosting.html">MediaWiki Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/tomcat-hosting.html">Tomcat Hosting</a>
</div>
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title mb-2">Contact Us</h3>
<a class="menu-link" href="tel:+18887673467">(888) ROSE-HOST</a>
<a class="menu-link" href="tel:+18887673467">(888) 767-3467</a>
<a class="menu-link" href="tel:+16465197201">(314) 275-0414</a>
<a class="menu-link" href="/cdn-cgi/l/email-protection#d2f7e5e1f7e5e7f7e5e2f7e5e2f7e4b4f7e5e0f7e5e6f7e6e2f7e5e0f7e4b4f7e5e1f7e4e7f7e4eaf7e4b4f7e5e1f7e5e6f7e4ebf7e4b7f7e4e5f7e0b7f7e4e1f7e4b4f7e4b6">Email us</a>
<h3 class="menu-title mb-2 mt-4">Connect</h3>
<a class="menu-link" href="https://twitter.com/rosehosting" target="_blank"><i class="fa fa-twitter fa-fw"></i> Twitter</a>
<a class="menu-link" href="https://www.facebook.com/RoseHosting" target="_blank"><i class="fa fa-facebook fa-fw"></i> Facebook</a>
<a class="menu-link" href="https://www.linkedin.com/company/rose-web-services-l-l-c-" target="_blank"><i class="fa fa-linkedin fa-fw"></i> LinkedIn</a>
<a class="menu-link" href="https://www.rosehosting.com/blog/feed/" target="_blank"><i class="fa fa-rss fa-fw"></i> RSS Feed</a>
</div>
</div>
</div>
<div class="bottom">
<div class="container">
<div class="row">
<div class="col col-md-12">
<img class="privacy-shield d-block mb-4" width="175" src="https://www.rosehosting.com/blog/wp-content/themes/rh2018/img/privacy_shield.png" alt="privacy shield">
</div>
<div class="col-md-12 col-lg-6">
<p class="text-sm-left"><a class="inline-link footer-policy" href="/tos.html">Terms of Service</a> and <a class="inline-link footer-policy" href="/policies.html">other policies</a></p>
</div>
<div class="col-md-12 col-lg-6">
<p class="text-sm-right">&copy; 2001-2019 <a class="inline-link footer-policy" href="https://www.rosewebservices.com/">Rose Web Services LLC</a>.</p>
</div>
</div>
</div>
</div>

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript" id="aff1f81b02f303eea5f87a3a065f153a" src="https://linuxhostsupport.com/chat//script.php?id=aff1f81b02f303eea5f87a3a065f153a"></script>

<div class="essb-followme essb-followme-bottom" data-full="" data-top="" data-background="rgba(255,255,255,0)" data-position="" data-avoid-left="true" data-hide="1"><div class="essb_links essb_counters essb_displayed_followme essb_share essb_template_bold-retina essb_1192994086 essb_links_center essb_mobile_hidden print-no" id="essb_displayed_followme_1192994086" data-essb-postid="31434" data-essb-position="followme" data-essb-button-style="button_name" data-essb-template="bold-retina" data-essb-counter-pos="insidename" data-essb-url="https://www.rosehosting.com/blog/install-cockpit-on-debian-9/" data-essb-twitter-url="https://www.rosehosting.com/blog/install-cockpit-on-debian-9/" data-essb-instance="1192994086"><ul class="essb_links_list essb_hide_icon"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-counter-pos="insidename"><span class="essb_totalcount essb_t_l" title="Total: "><span class="essb_total_text">Total: </span><span class="essb_t_nb">2</span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/install-cockpit-on-debian-9/&t=Install+Cockpit+on+Debian+9" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/install-cockpit-on-debian-9/&t=Install+Cockpit+on+Debian+9&#39;,&#39;facebook&#39;,&#39;1192994086&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook<span class="essb_counter_insidename" data-cnt="2" data-cnt-short="2">2</span></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=Install+Cockpit+on+Debian+9&amp;url=https://www.rosehosting.com/blog/install-cockpit-on-debian-9/&amp;counturl=https://www.rosehosting.com/blog/install-cockpit-on-debian-9/&#39;,&#39;twitter&#39;,&#39;1192994086&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Install+Cockpit+on+Debian+9&amp;url=https://www.rosehosting.com/blog/install-cockpit-on-debian-9/" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=Install+Cockpit+on+Debian+9&amp;url=https://www.rosehosting.com/blog/install-cockpit-on-debian-9/&#39;,&#39;linkedin&#39;,&#39;1192994086&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_print nolightbox"> <a href="#" title="" onclick="essb.print(&#39;1192994086&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_print"></span><span class="essb_network_name">Print<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_mail nolightbox"> <a href="#" title="" onclick="essb_open_mailform(&#39;1192994086&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_mail"></span><span class="essb_network_name">Email<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li></ul></div></div> <script type="text/javascript">
			</script>
<script type="text/javascript">
            var sub = document.getElementById('submit');
            document.getElementById('recaptcha-submit-btn-area').appendChild (sub);
            document.getElementById('submit').tabIndex = 6;
            if ( typeof _recaptcha_wordpress_savedcomment != 'undefined') {
                document.getElementById('comment').value = 
                    _recaptcha_wordpress_savedcomment;
            }
            </script><script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2018/js/theme.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/masonry.min.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/www.rosehosting.com\/blog\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"0c2278ea57","timeline_nonce":"69342c8285","blog_feed_nonce":"7ee6079f90","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/www.rosehosting.com\/blog\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/www.rosehosting.com\/blog\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"296cf8e99c","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"2f5449ffb5","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"31434","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/Extra/scripts/scripts.min.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/comment-reply.min.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/Extra/core/admin/js/common.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/wp-embed.min.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/smooth-scroll/jquery.smooth-scroll.min.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/js-cookie/js.cookie.min.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/sticky-kit/jquery.sticky-kit.min.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"","width":"100%","scroll_offset":"30"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/assets/js/front.min.js?x68100&amp;x68100' defer='defer'></script>
<div class="essb_mailform"><div class="essb_mailform_content"><p>Send this to a friend</p><label class="essb_mailform_content_label">Your email</label><input type="text" id="essb_mailform_from" class="essb_mailform_content_input" placeholder="Your email" /><label class="essb_mailform_content_label">Recipient email</label><input type="text" id="essb_mailform_to" class="essb_mailform_content_input" placeholder="Recipient email" /><div class="essb_mailform_content_buttons"><button id="essb_mailform_btn_submit" class="essb_mailform_content_button" onclick="essb_mailform_send();">Send</button><button id="essb_mailform_btn_cancel" class="essb_mailform_content_button" onclick="essb_close_mailform(); return false;">Cancel</button></div><input type="hidden" id="essb_mail_salt" value="712055982" /><input type="hidden" id="essb_mail_instance" value="" /><input type="hidden" id="essb_mail_post" value="" /></div></div><div class="essb_mailform_shadow"></div><link rel='stylesheet' id='essb-compiled-css' href='https://www.rosehosting.com/blog/wp-content/easysocialsharebuttons-assets/compiled/2566c291e59e185c12a331fef1e235f3.css?x68100' type='text/css' media='all' /><script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/easysocialsharebuttons-assets/compiled/2566c291e59e185c12a331fef1e235f3.js?x68100' async></script></body>
</html>
