<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head><meta charset="UTF-8" /><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
	


	<link rel="pingback" href="https://www.rosehosting.com/blog/xmlrpc.php" />


		<!--[if lt IE 9]>
	<script src="https://www.rosehosting.com/blog/wp-content/themes/generatepress/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->

<!--<script type="rocketlazyloadscript" async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script>-->

<!-- Google Tag Manager -->
<script type="rocketlazyloadscript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KVJ4PJ');</script>
<!-- End Google Tag Manager -->

	<script type="rocketlazyloadscript" data-rocket-type="text/javascript">
		document.documentElement.className = 'js';
	</script>

	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<meta name="viewport" content="width=device-width, initial-scale=1">
	<!-- This site is optimized with the Yoast SEO Premium plugin v17.0 (Yoast SEO v17.7.1) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Moodle Online Learning System Automated Installation and Upgrade - RoseHosting</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2Cregular%2Citalic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CAbril%20FatFace%3A400%2C400i%2C700%2C700i%7CAlegreya%3A400%2C400i%2C700%2C700i%7CAlegreya%20Sans%3A400%2C400i%2C700%2C700i%7CAmatic%20SC%3A400%2C400i%2C700%2C700i%7CAnonymous%20Pro%3A400%2C400i%2C700%2C700i%7CArchitects%20Daughter%3A400%2C400i%2C700%2C700i%7CArchivo%3A400%2C400i%2C700%2C700i%7CArchivo%20Narrow%3A400%2C400i%2C700%2C700i%7CAsap%3A400%2C400i%2C700%2C700i%7CBarlow%3A400%2C400i%2C700%2C700i%7CBioRhyme%3A400%2C400i%2C700%2C700i%7CBonbon%3A400%2C400i%2C700%2C700i%7CCabin%3A400%2C400i%2C700%2C700i%7CCairo%3A400%2C400i%2C700%2C700i%7CCardo%3A400%2C400i%2C700%2C700i%7CChivo%3A400%2C400i%2C700%2C700i%7CConcert%20One%3A400%2C400i%2C700%2C700i%7CCormorant%3A400%2C400i%2C700%2C700i%7CCrimson%20Text%3A400%2C400i%2C700%2C700i%7CEczar%3A400%2C400i%2C700%2C700i%7CExo%202%3A400%2C400i%2C700%2C700i%7CFira%20Sans%3A400%2C400i%2C700%2C700i%7CFjalla%20One%3A400%2C400i%2C700%2C700i%7CFrank%20Ruhl%20Libre%3A400%2C400i%2C700%2C700i%7CGreat%20Vibes%3A400%2C400i%2C700%2C700i%7CHeebo%3A400%2C400i%2C700%2C700i%7CIBM%20Plex%3A400%2C400i%2C700%2C700i%7CInconsolata%3A400%2C400i%2C700%2C700i%7CIndie%20Flower%3A400%2C400i%2C700%2C700i%7CInknut%20Antiqua%3A400%2C400i%2C700%2C700i%7CInter%3A400%2C400i%2C700%2C700i%7CKarla%3A400%2C400i%2C700%2C700i%7CLibre%20Baskerville%3A400%2C400i%2C700%2C700i%7CLibre%20Franklin%3A400%2C400i%2C700%2C700i%7CMontserrat%3A400%2C400i%2C700%2C700i%7CNeuton%3A400%2C400i%2C700%2C700i%7CNotable%3A400%2C400i%2C700%2C700i%7CNothing%20You%20Could%20Do%3A400%2C400i%2C700%2C700i%7CNoto%20Sans%3A400%2C400i%2C700%2C700i%7CNunito%3A400%2C400i%2C700%2C700i%7COld%20Standard%20TT%3A400%2C400i%2C700%2C700i%7COxygen%3A400%2C400i%2C700%2C700i%7CPacifico%3A400%2C400i%2C700%2C700i%7CPoppins%3A400%2C400i%2C700%2C700i%7CProza%20Libre%3A400%2C400i%2C700%2C700i%7CPT%20Sans%3A400%2C400i%2C700%2C700i%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CRakkas%3A400%2C400i%2C700%2C700i%7CReenie%20Beanie%3A400%2C400i%2C700%2C700i%7CRoboto%20Slab%3A400%2C400i%2C700%2C700i%7CRopa%20Sans%3A400%2C400i%2C700%2C700i%7CRubik%3A400%2C400i%2C700%2C700i%7CShadows%20Into%20Light%3A400%2C400i%2C700%2C700i%7CSpace%20Mono%3A400%2C400i%2C700%2C700i%7CSpectral%3A400%2C400i%2C700%2C700i%7CSue%20Ellen%20Francisco%3A400%2C400i%2C700%2C700i%7CTitillium%20Web%3A400%2C400i%2C700%2C700i%7CUbuntu%3A400%2C400i%2C700%2C700i%7CVarela%3A400%2C400i%2C700%2C700i%7CVollkorn%3A400%2C400i%2C700%2C700i%7CWork%20Sans%3A400%2C400i%2C700%2C700i%7CYatra%20One%3A400%2C400i%2C700%2C700i&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2Cregular%2Citalic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CAbril%20FatFace%3A400%2C400i%2C700%2C700i%7CAlegreya%3A400%2C400i%2C700%2C700i%7CAlegreya%20Sans%3A400%2C400i%2C700%2C700i%7CAmatic%20SC%3A400%2C400i%2C700%2C700i%7CAnonymous%20Pro%3A400%2C400i%2C700%2C700i%7CArchitects%20Daughter%3A400%2C400i%2C700%2C700i%7CArchivo%3A400%2C400i%2C700%2C700i%7CArchivo%20Narrow%3A400%2C400i%2C700%2C700i%7CAsap%3A400%2C400i%2C700%2C700i%7CBarlow%3A400%2C400i%2C700%2C700i%7CBioRhyme%3A400%2C400i%2C700%2C700i%7CBonbon%3A400%2C400i%2C700%2C700i%7CCabin%3A400%2C400i%2C700%2C700i%7CCairo%3A400%2C400i%2C700%2C700i%7CCardo%3A400%2C400i%2C700%2C700i%7CChivo%3A400%2C400i%2C700%2C700i%7CConcert%20One%3A400%2C400i%2C700%2C700i%7CCormorant%3A400%2C400i%2C700%2C700i%7CCrimson%20Text%3A400%2C400i%2C700%2C700i%7CEczar%3A400%2C400i%2C700%2C700i%7CExo%202%3A400%2C400i%2C700%2C700i%7CFira%20Sans%3A400%2C400i%2C700%2C700i%7CFjalla%20One%3A400%2C400i%2C700%2C700i%7CFrank%20Ruhl%20Libre%3A400%2C400i%2C700%2C700i%7CGreat%20Vibes%3A400%2C400i%2C700%2C700i%7CHeebo%3A400%2C400i%2C700%2C700i%7CIBM%20Plex%3A400%2C400i%2C700%2C700i%7CInconsolata%3A400%2C400i%2C700%2C700i%7CIndie%20Flower%3A400%2C400i%2C700%2C700i%7CInknut%20Antiqua%3A400%2C400i%2C700%2C700i%7CInter%3A400%2C400i%2C700%2C700i%7CKarla%3A400%2C400i%2C700%2C700i%7CLibre%20Baskerville%3A400%2C400i%2C700%2C700i%7CLibre%20Franklin%3A400%2C400i%2C700%2C700i%7CMontserrat%3A400%2C400i%2C700%2C700i%7CNeuton%3A400%2C400i%2C700%2C700i%7CNotable%3A400%2C400i%2C700%2C700i%7CNothing%20You%20Could%20Do%3A400%2C400i%2C700%2C700i%7CNoto%20Sans%3A400%2C400i%2C700%2C700i%7CNunito%3A400%2C400i%2C700%2C700i%7COld%20Standard%20TT%3A400%2C400i%2C700%2C700i%7COxygen%3A400%2C400i%2C700%2C700i%7CPacifico%3A400%2C400i%2C700%2C700i%7CPoppins%3A400%2C400i%2C700%2C700i%7CProza%20Libre%3A400%2C400i%2C700%2C700i%7CPT%20Sans%3A400%2C400i%2C700%2C700i%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CRakkas%3A400%2C400i%2C700%2C700i%7CReenie%20Beanie%3A400%2C400i%2C700%2C700i%7CRoboto%20Slab%3A400%2C400i%2C700%2C700i%7CRopa%20Sans%3A400%2C400i%2C700%2C700i%7CRubik%3A400%2C400i%2C700%2C700i%7CShadows%20Into%20Light%3A400%2C400i%2C700%2C700i%7CSpace%20Mono%3A400%2C400i%2C700%2C700i%7CSpectral%3A400%2C400i%2C700%2C700i%7CSue%20Ellen%20Francisco%3A400%2C400i%2C700%2C700i%7CTitillium%20Web%3A400%2C400i%2C700%2C700i%7CUbuntu%3A400%2C400i%2C700%2C700i%7CVarela%3A400%2C400i%2C700%2C700i%7CVollkorn%3A400%2C400i%2C700%2C700i%7CWork%20Sans%3A400%2C400i%2C700%2C700i%7CYatra%20One%3A400%2C400i%2C700%2C700i&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2Cregular%2Citalic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CAbril%20FatFace%3A400%2C400i%2C700%2C700i%7CAlegreya%3A400%2C400i%2C700%2C700i%7CAlegreya%20Sans%3A400%2C400i%2C700%2C700i%7CAmatic%20SC%3A400%2C400i%2C700%2C700i%7CAnonymous%20Pro%3A400%2C400i%2C700%2C700i%7CArchitects%20Daughter%3A400%2C400i%2C700%2C700i%7CArchivo%3A400%2C400i%2C700%2C700i%7CArchivo%20Narrow%3A400%2C400i%2C700%2C700i%7CAsap%3A400%2C400i%2C700%2C700i%7CBarlow%3A400%2C400i%2C700%2C700i%7CBioRhyme%3A400%2C400i%2C700%2C700i%7CBonbon%3A400%2C400i%2C700%2C700i%7CCabin%3A400%2C400i%2C700%2C700i%7CCairo%3A400%2C400i%2C700%2C700i%7CCardo%3A400%2C400i%2C700%2C700i%7CChivo%3A400%2C400i%2C700%2C700i%7CConcert%20One%3A400%2C400i%2C700%2C700i%7CCormorant%3A400%2C400i%2C700%2C700i%7CCrimson%20Text%3A400%2C400i%2C700%2C700i%7CEczar%3A400%2C400i%2C700%2C700i%7CExo%202%3A400%2C400i%2C700%2C700i%7CFira%20Sans%3A400%2C400i%2C700%2C700i%7CFjalla%20One%3A400%2C400i%2C700%2C700i%7CFrank%20Ruhl%20Libre%3A400%2C400i%2C700%2C700i%7CGreat%20Vibes%3A400%2C400i%2C700%2C700i%7CHeebo%3A400%2C400i%2C700%2C700i%7CIBM%20Plex%3A400%2C400i%2C700%2C700i%7CInconsolata%3A400%2C400i%2C700%2C700i%7CIndie%20Flower%3A400%2C400i%2C700%2C700i%7CInknut%20Antiqua%3A400%2C400i%2C700%2C700i%7CInter%3A400%2C400i%2C700%2C700i%7CKarla%3A400%2C400i%2C700%2C700i%7CLibre%20Baskerville%3A400%2C400i%2C700%2C700i%7CLibre%20Franklin%3A400%2C400i%2C700%2C700i%7CMontserrat%3A400%2C400i%2C700%2C700i%7CNeuton%3A400%2C400i%2C700%2C700i%7CNotable%3A400%2C400i%2C700%2C700i%7CNothing%20You%20Could%20Do%3A400%2C400i%2C700%2C700i%7CNoto%20Sans%3A400%2C400i%2C700%2C700i%7CNunito%3A400%2C400i%2C700%2C700i%7COld%20Standard%20TT%3A400%2C400i%2C700%2C700i%7COxygen%3A400%2C400i%2C700%2C700i%7CPacifico%3A400%2C400i%2C700%2C700i%7CPoppins%3A400%2C400i%2C700%2C700i%7CProza%20Libre%3A400%2C400i%2C700%2C700i%7CPT%20Sans%3A400%2C400i%2C700%2C700i%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CRakkas%3A400%2C400i%2C700%2C700i%7CReenie%20Beanie%3A400%2C400i%2C700%2C700i%7CRoboto%20Slab%3A400%2C400i%2C700%2C700i%7CRopa%20Sans%3A400%2C400i%2C700%2C700i%7CRubik%3A400%2C400i%2C700%2C700i%7CShadows%20Into%20Light%3A400%2C400i%2C700%2C700i%7CSpace%20Mono%3A400%2C400i%2C700%2C700i%7CSpectral%3A400%2C400i%2C700%2C700i%7CSue%20Ellen%20Francisco%3A400%2C400i%2C700%2C700i%7CTitillium%20Web%3A400%2C400i%2C700%2C700i%7CUbuntu%3A400%2C400i%2C700%2C700i%7CVarela%3A400%2C400i%2C700%2C700i%7CVollkorn%3A400%2C400i%2C700%2C700i%7CWork%20Sans%3A400%2C400i%2C700%2C700i%7CYatra%20One%3A400%2C400i%2C700%2C700i&#038;display=swap" /></noscript><link rel="stylesheet" href="https://www.rosehosting.com/blog/wp-content/cache/min/1/34a66c8c6599dc72a672b43f9d4e78c9.css" media="all" data-minify="1" />
	<meta name="description" content="Moodle is a free, open-source, and one of the most popular learning management systems around the world. Learn more about it from our guide." />
	<link rel="canonical" href="https://www.rosehosting.com/blog/moodle-online-learning-system-automated-installation-and-upgrade/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Moodle Online Learning System Automated Installation and Upgrade" />
	<meta property="og:description" content="Moodle is a free, open-source, and one of the most popular learning management systems around the world. Learn more about it from our guide." />
	<meta property="og:url" content="https://www.rosehosting.com/blog/moodle-online-learning-system-automated-installation-and-upgrade/" />
	<meta property="og:site_name" content="RoseHosting" />
	<meta property="article:publisher" content="https://www.facebook.com/RoseHosting" />
	<meta property="article:author" content="https://www.facebook.com/rosehosting.helpdesk" />
	<meta property="article:published_time" content="2021-12-01T18:30:00+00:00" />
	<meta property="article:modified_time" content="2021-09-03T08:39:33+00:00" />
	<meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade.jpg?v=1630074391" />
	<meta property="og:image:width" content="742" />
	<meta property="og:image:height" content="372" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:description" content="Moodle is a free, open-source, and one of the most popular learning management systems around the world. Learn more about it from our guide." />
	<meta name="twitter:creator" content="@rosehosting" />
	<meta name="twitter:site" content="@rosehosting" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Jeff Wilson" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="8 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Feed" href="https://www.rosehosting.com/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Comments Feed" href="https://www.rosehosting.com/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Moodle Online Learning System Automated Installation and Upgrade Comments Feed" href="https://www.rosehosting.com/blog/moodle-online-learning-system-automated-installation-and-upgrade/feed/" />
<!-- rosehosting.com/blog is managing ads with Advanced Ads --><!--noptimize--><script id="rhad-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
		<!--/noptimize--><style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	








<style id='ez-toc-inline-css'>
div#ez-toc-container p.ez-toc-title {font-size: 22px;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}div#ez-toc-container {width: 95%;}
</style>






<style id='generate-style-inline-css'>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</style>









<link rel='preload' as='font'  id='wpzoom-social-icons-font-academicons-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.ttf?v=1.8.6' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-academicons-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.woff?v=1.8.6' type='font/woff' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-fontawesome-3-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.ttf?v=4.7.0' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-fontawesome-3-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff?v=4.7.0' type='font/woff' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-fontawesome-3-woff2-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff2?v=4.7.0' type='font/woff2' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-genericons-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-genericons-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type='font/woff' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-socicon-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.ttf?v=4.2.2' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-socicon-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.woff?v=4.2.2' type='font/woff' crossorigin />
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js' defer></script>
<script id='topbar_frontjs-js-extra'>
var tpbr_settings = {"fixed":"fixed","user_who":"notloggedin","guests_or_users":"all","message":"20th Anniversary Sale!!! 20% OFF on all hosting services. Use coupon RH20YEARS     *new customers only, while supplies last","status":"inactive","yn_button":"button","color":"#ba004a","button_text":"GET THE DEAL","button_url":"https:\/\/www.rosehosting.com\/20th-anniversary-sale.html","button_behavior":"newwindow","is_admin_bar":"no","detect_sticky":"0"};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/top-bar/inc/../js/tpbr_front.min.js' id='topbar_frontjs-js' defer></script>
<script id='advanced-ads-advanced-js-js-extra'>
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js' id='advanced-ads-advanced-js-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/ajax/libs/popper.js/1.11.0/umd/popper.min.js?ver=1635278974' id='popper-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/themes/rh2020/js/bootstrap.js?ver=1635278974' id='bootstrap-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/themes/rh2020/js/cookieconsent.min.js' id='cookieconsent-js' defer></script>
<link rel="https://api.w.org/" href="https://www.rosehosting.com/blog/wp-json/" /><link rel="alternate" type="application/json" href="https://www.rosehosting.com/blog/wp-json/wp/v2/posts/38805" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rosehosting.com/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rosehosting.com/blog/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.2" />
<link rel='shortlink' href='https://www.rosehosting.com/blog/?p=38805' />
<link rel="alternate" type="application/json+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fmoodle-online-learning-system-automated-installation-and-upgrade%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fmoodle-online-learning-system-automated-installation-and-upgrade%2F&#038;format=xml" />
<script type="rocketlazyloadscript">advads_items = { conditions: {}, display_callbacks: {}, display_effect_callbacks: {}, hide_callbacks: {}, backgrounds: {}, effect_durations: {}, close_functions: {}, showed: [] };</script><style type="text/css" id="rhad-layer-custom-css"></style><script type="rocketlazyloadscript" data-rocket-type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
		<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-270x270.png" />
		<style id="wp-custom-css">
			/* Change background color and font of pre-formatted text */
.entry-content pre {
font-family: monospace;
color: #3a3a3a;
border: none;
overflow-wrap: break-word;
}
.inside-article,
.sidebar .widget {
    border: 1px solid #e3e3e3;
}
.page-container {
    max-width: 1100px;
		align-items: center;
		justify-content: space-between;
		margin-left: auto;
		margin-right: auto;
}
.footer-big-menu {
		max-width: 1100px;
		margin-left: auto;
		margin-right: auto;
}
.col6, .col-md-3, .col-lg-2 {
		padding-left: 10px;
		padding-right: 10px;
}
.masonry-load-more {
		padding-left: 20px;
}
@media (max-width:576px) {
	.nav-item {
  	margin-top: 10px;
	}
	.menu-link, .menu-title {
  	margin-top: 10px;
	}
	.comment-content {
		overflow-wrap: break-word;
	}
}		</style>
		<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script type="rocketlazyloadscript" data-rocket-type="text/javascript">
  var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(["setCookieDomain", "*.rosehosting.com"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.rosehosting.com/";
    _paq.push(['setTrackerUrl', u+'rosea.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.src='https://www.rosehosting.com/dist/rosea.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
</head>
<body class="post-template-default single single-post postid-38805 single-format-standard wp-embed-responsive post-image-above-header post-image-aligned-center sticky-menu-fade right-sidebar nav-below-header separate-containers contained-header active-footer-widgets-1 nav-aligned-left header-aligned-left dropdown-hover featured-image-active aa-prefix-rhad-">



<nav class="navbar yamm navbar-expand-lg navbar-dark" role="navigation">
  <div class="container no-override navbar-dark">

    <a class="navbar-brand" href="https://www.rosehosting.com/">
      <img alt="RoseHosting.com" width="186" height="37"  class="d-lg-inline mr-2" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20186%2037'%3E%3C/svg%3E" data-lazy-src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/rh-logo.svg" /><noscript><img alt="RoseHosting.com" width="186" height="37"  class="d-lg-inline mr-2" src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/rh-logo.svg" /></noscript>
    </a>

    <button class="navbar-toggler" data-toggle="collapse" data-target="#navbar-collapse">
      <span class="navbar-toggler-icon"></span>
    </button>

    <div class="collapse navbar-collapse justify-content-end" id="navbar-collapse">
      <ul class="navbar-nav">

        <li class="nav-item active dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Hosting Solutions
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">

            <div class="yamm-content">
              <div class="row">
                <div class="col-sm-6">
                   <span class="text-primary  dropdown-header"><strong>Managed SSD Hosting</strong></span>
                   <div class="dropdown-divider"></div>
                   <a class="dropdown-item" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/linux-vps-hosting/">Linux VPS Hosting</a>
                   <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom VPS</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/managed-cloud-hosting.html">Cloud Hosting</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/dedicated-servers.html">Dedicated Servers</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting <span class="ml-2 badge badge-success">new</span></a>
                </div>
                <div class="col-sm-6">
                  <span class="text-primary dropdown-header"><strong>Managed Solutions</strong></span>
                  <div class="dropdown-divider"></div>
                  <a class="dropdown-item" href="https://www.rosehosting.com/wordpress-hosting.html">
                    Wordpress Hosting
                    <small class="d-block text-muted"><i>The best blogging platform</i></small>
                  </a>
                  <a class="dropdown-item" href="https://www.rosehosting.com/magento-hosting.html">
                    Magento Hosting
                    <small class="d-block text-muted"><i>The best e-commerce platform</i></small>
                  </a>
                  <a class="dropdown-item" href="https://www.rosehosting.com/odoo-hosting.html">
                    Odoo Hosting
                    <small class="d-block text-muted"><i>The best CRM/ERP platform</i></small>
                  </a>
                  <span class="dropdown-item"><a class="btn-shadow btn-shadow-primary btn-shadow-sm" target="_blank" href="https://www.rosehosting.com/hosting-solutions.html">Other Solutions</a></span>

                </div>
              </div>
            </div>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            SSL / Domains
            <i class="fa fa-chevron-down"></i>
          </a>

          <div class="dropdown-menu" role="menu">

            <div class="yamm-content">
              <div class="row">
                <div class="col-sm-3">
                    <span class="text-primary  dropdown-header"><strong>SSL by brand</strong></span>
                    <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#geotrust">GeoTrust</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#comodo">Comodo</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#rapidssl">RapidSSL</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#thawte">Thawte</a>
                </div>
                <div class="col-sm-4">

                    <span class="text-primary  dropdown-header"><strong>SSL by Type</strong></span>
                    <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#domain_validation">Domain Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#organization_validation">Organization Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#extended_validation">Extended Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#wildcard_ssl">Wildcard SSL</a>
                </div>
                <div class="col-sm-3">
                  <span class="text-primary dropdown-header"><strong>Domains</strong></span>
                  <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Register Domains</a>
                    <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Transfer Domains</a>
                </div>
              </div>
            </div>
          </div>


        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Support
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
              <a class="dropdown-item" href="https://www.rosehosting.com/support.html">24/7 Managed Support</a>
              <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Open a Support Ticket</a>
              <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>
	      <a class="dropdown-item" rel=”nofollow” href="https://status.rosehosting.net">Systems Status</a>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            About Us
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
            <a class="dropdown-item" href="https://www.rosehosting.com/about-us.html">Our Company</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/policies.html">Our Policies</a>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Affiliates
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
            <a class="dropdown-item" href="https://www.rosehosting.com/cpa-hosting-affiliate-program.html">Flat-Rate CPA Affiliate Plan</a>
            <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Flat-Rate CPA Affiliate Login</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/vps-affiliate-program.html">Recurring Affiliate Plan</a>
            <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/aff/">Recurring Affiliate Login</a>
          </div>
        </li>

        <li class="nav-item">
          <a class="nav-link" href="https://www.rosehosting.com/blog/">Blog</a>
        </li>

        <li class="nav-item">
          <a class="nav-link nav-link--rounded" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Login</a>
        </li>

      </ul>
    </div>

  </div>
</nav>


<!--
<nav class="navbar navbar-expand-lg navbar-light bg-faded navbar-blog">
   <div class="container no-override">
    <a href="https://www.rosehosting.com/blog/" class="navbar-brand">Blog Home</a>
    <div class="navbar-collapse collapse d-flex justify-content-between" id="navbar5-blog">
        <ul class="navbar-nav categories">
            <li class="nav-item dropdown">
              <a class="nav-link dropdown-toggle" data-toggle="dropdown" href="#" role="button" aria-haspopup="true" aria-expanded="false">
                Categories
                <i class="fa fa-chevron-down"></i>
              </a>
              <div class="dropdown-menu" style="z-index:0;">
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/caching/">Caching</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/centos/">CentOS</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/cms-crm-erp/">CMS, CRM, ERP</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/control-panels/">Control Panels</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/databases/">Databases</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/debian/">Debian</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/e-commerce/">E-Commerce</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/email-servers/">Email Servers</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/guides/">Guides</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/load-balancing/">Load Balancing</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/miscellaneous/">Miscellaneous</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/networking-and-domains/">Networking and Domains</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/news/">News</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/optimization/">Optimization</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/other/">Other</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/rosehosting/">RoseHosting Platform</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/scripts/">Scripts</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/security/">Security</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/seo/">SEO</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tips-and-tricks/">Tips and Tricks</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tutorials/">Tutorials</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/ubuntu/">Ubuntu</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-frameworks/">Web Frameworks</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-servers/">Web Servers</a>
                              </div>
            </li>
        </ul>
        <form class="mx-2 my-auto d-inline" method="get" id="searchform" action="https://www.rosehosting.com/blog/">
            <div class="input-group">
                <input type="search" class="field" name="s" id="s" class="form-control border border-right-0" placeholder="Search...">
                <span class="input-group-append">
                <button name="submit" id="searchsubmit" class="btn btn-outline-secondary border border-left-0" type="submit">
                    <i class="fa fa-search"></i>
                </button>
              </span>
            </div>
        </form>
    </div>
  </div>
</nav> -->

	<div id="page-container" class="page-container">

	<div class="content-area grid-parent mobile-grid-100 grid-70 tablet-grid-70" id="primary">
		<main class="site-main" id="main">
			
<article id="post-38805" class="post-38805 post type-post status-publish format-standard has-post-thumbnail hentry category-guides tag-install tag-moodle tag-online-learning-system" itemtype="https://schema.org/CreativeWork" itemscope>
	<div class="inside-article">
					<header class="entry-header" aria-label="Content">
				<h1 class="entry-title" itemprop="headline">Moodle Online Learning System Automated Installation and Upgrade</h1>		<div class="entry-meta">
			<span class="posted-on"><time class="entry-date published" datetime="2021-12-01T12:30:00-06:00" itemprop="datePublished">December 1, 2021</time></span> <span class="byline">by <span class="author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope><a class="url fn n" href="https://www.rosehosting.com/blog/author/jwilson/" title="View all posts by Jeff Wilson" rel="author" itemprop="url"><span class="author-name" itemprop="name">Jeff Wilson</span></a></span></span> 		</div>
					</header>
			
		<div class="entry-content" itemprop="text">
			<div  class="rhad-26bccf60ed875ab62fc396eb8133e6e5 rhad-before-content" id="rhad-26bccf60ed875ab62fc396eb8133e6e5"></div>
<figure class="wp-block-image size-full"><img width="742" height="372" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20742%20372'%3E%3C/svg%3E" alt="Moodle Online Learning System Automated Installation and Upgrade" class="wp-image-38820" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade.jpg?v=1630074391 742w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade-300x150.jpg?v=1630074391 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade-150x75.jpg?v=1630074391 150w" data-lazy-sizes="(max-width: 742px) 100vw, 742px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade.jpg" /><noscript><img width="742" height="372" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade.jpg" alt="Moodle Online Learning System Automated Installation and Upgrade" class="wp-image-38820" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade.jpg?v=1630074391 742w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade-300x150.jpg?v=1630074391 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade-150x75.jpg?v=1630074391 150w" sizes="(max-width: 742px) 100vw, 742px" /></noscript></figure>



<p>Moodle is a free, open-source, and one of the most popular learning management systems around the world. It helps you to create your online learning site in minutes. It allows both teachers and students to choose a time and place for training. It is customizable, user-friendly, and allows you to extend learning environments using plugins. Currently, it is used in many places including, schools, universities, workplaces, and other sectors.</p>



<p><a href="https://www.rosehosting.com/managed-cloud-hosting.html">RoseHosting Cloud PaaS</a> provides a one-click Moodle installer to automate the Moodle installation process on the cloud environment. You can set up Moodle, securely manage it through SSH, import/export any files, and perform other management operations from a single control panel.</p>



<p>In this guide, we will explain how to install Moodle E-Learning System on the RoseHosting Cloud PaaS.</p>



<div id="ez-toc-container" class="ez-toc-v2_0_17 counter-hierarchy ez-toc-transparent">
<div class="ez-toc-title-container">
<p class="ez-toc-title">Table of Contents</p>
<span class="ez-toc-title-toggle"><a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle" style="display: none;"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a></span></div>
<nav><ul class="ez-toc-list ez-toc-list-level-1"><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-1" href="#Install-Moodle-E-Learning-System" title="Install Moodle E-Learning System">Install Moodle E-Learning System</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-2" href="#Access-Moodle-Control-Panel" title="Access Moodle Control Panel">Access Moodle Control Panel</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-3" href="#How-to-Upgrade-Moodle-E-Learning-System" title="How to Upgrade Moodle E-Learning System">How to Upgrade Moodle E-Learning System</a></li></ul></nav></div>
<h2 id="h-install-moodle-e-learning-system"><span class="ez-toc-section" id="Install-Moodle-E-Learning-System"></span>Install Moodle E-Learning System<span class="ez-toc-section-end"></span></h2>



<p>First, login to RoseHosting Cloud at <a rel="noreferrer noopener" href="http://app.rosehosting.cloud" target="_blank">http://app.rosehosting.cloud</a>.</p>



<p></p>



<figure class="wp-block-image size-full"><img width="1024" height="460" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20460'%3E%3C/svg%3E" alt="" class="wp-image-38833" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-login-rosehosting-cloud.png?v=1630324202 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-login-rosehosting-cloud-300x135.png?v=1630324202 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-login-rosehosting-cloud-150x67.png?v=1630324202 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-login-rosehosting-cloud-768x345.png?v=1630324202 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-login-rosehosting-cloud.png" /><noscript><img width="1024" height="460" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-login-rosehosting-cloud.png" alt="" class="wp-image-38833" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-login-rosehosting-cloud.png?v=1630324202 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-login-rosehosting-cloud-300x135.png?v=1630324202 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-login-rosehosting-cloud-150x67.png?v=1630324202 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-login-rosehosting-cloud-768x345.png?v=1630324202 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p>Click on the <strong>MARKETPLACE</strong> button. You should see the following screen:</p>



<figure class="wp-block-image size-full"><img width="1024" height="529" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20529'%3E%3C/svg%3E" alt="" class="wp-image-38834" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-marketplace.png?v=1630324225 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-marketplace-300x155.png?v=1630324225 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-marketplace-150x77.png?v=1630324225 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-marketplace-768x397.png?v=1630324225 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-marketplace.png" /><noscript><img width="1024" height="529" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-marketplace.png" alt="" class="wp-image-38834" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-marketplace.png?v=1630324225 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-marketplace-300x155.png?v=1630324225 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-marketplace-150x77.png?v=1630324225 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-marketplace-768x397.png?v=1630324225 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p></p>



<p>Now, click on the <strong>Content Management , </strong>select <strong>Moodle</strong> and click on the <strong>Install</strong> button. You will be asked to define your environment name as shown below:</p>



<p></p>



<figure class="wp-block-image size-full"><img width="716" height="329" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20716%20329'%3E%3C/svg%3E" alt="" class="wp-image-38836" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-install.png?v=1630324244 716w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-install-300x138.png?v=1630324244 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-install-150x69.png?v=1630324244 150w" data-lazy-sizes="(max-width: 716px) 100vw, 716px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-install.png" /><noscript><img width="716" height="329" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-install.png" alt="" class="wp-image-38836" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-install.png?v=1630324244 716w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-install-300x138.png?v=1630324244 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-install-150x69.png?v=1630324244 150w" sizes="(max-width: 716px) 100vw, 716px" /></noscript></figure>



<p>Provide your environment name and click on the <strong>Install</strong> button. Once Moodle is installed, you should see the Moodle access credentials on the following screen.</p>



<p></p>



<figure class="wp-block-image size-full"><img width="471" height="260" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20471%20260'%3E%3C/svg%3E" alt="" class="wp-image-38837" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-credentials.png?v=1630324264 471w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-credentials-300x166.png?v=1630324264 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-credentials-150x83.png?v=1630324264 150w" data-lazy-sizes="(max-width: 471px) 100vw, 471px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-credentials.png" /><noscript><img width="471" height="260" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-credentials.png" alt="" class="wp-image-38837" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-credentials.png?v=1630324264 471w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-credentials-300x166.png?v=1630324264 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-credentials-150x83.png?v=1630324264 150w" sizes="(max-width: 471px) 100vw, 471px" /></noscript></figure>



<p>Now, click on the <strong>Close</strong> button. You should see the Moodle environment on the following screen.</p>



<p></p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1024" height="362" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20362'%3E%3C/svg%3E" alt="" class="wp-image-38838" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-moodle-environment.png?v=1630324280 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-moodle-environment-300x106.png?v=1630324280 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-moodle-environment-150x53.png?v=1630324280 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-moodle-environment-768x272.png?v=1630324280 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-moodle-environment.png" /><noscript><img width="1024" height="362" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-moodle-environment.png" alt="" class="wp-image-38838" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-moodle-environment.png?v=1630324280 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-moodle-environment-300x106.png?v=1630324280 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-moodle-environment-150x53.png?v=1630324280 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-moodle-environment-768x272.png?v=1630324280 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<h2 id="h-access-moodle-control-panel"><span class="ez-toc-section" id="Access-Moodle-Control-Panel"></span>Access Moodle Control Panel<span class="ez-toc-section-end"></span></h2>



<p>You should also receive an email with all access credentials. Copy the Moodle admin panel link and access it through the web browser. You should see the Moodle login screen:</p>



<p></p>



<figure class="wp-block-image size-full"><img width="1024" height="440" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20440'%3E%3C/svg%3E" alt="" class="wp-image-38839" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-control-panel.png?v=1630324297 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-control-panel-300x129.png?v=1630324297 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-control-panel-150x64.png?v=1630324297 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-control-panel-768x330.png?v=1630324297 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-control-panel.png" /><noscript><img width="1024" height="440" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-control-panel.png" alt="" class="wp-image-38839" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-control-panel.png?v=1630324297 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-control-panel-300x129.png?v=1630324297 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-control-panel-150x64.png?v=1630324297 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-control-panel-768x330.png?v=1630324297 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p>Provide Moodle admin username, password and click on the <strong>Login</strong> button. You should see the Moodle dashboard:</p>



<figure class="wp-block-image size-full"><img width="1024" height="540" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20540'%3E%3C/svg%3E" alt="" class="wp-image-38840" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-dashboard.png?v=1630324313 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-dashboard-300x158.png?v=1630324313 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-dashboard-150x79.png?v=1630324313 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-dashboard-768x405.png?v=1630324313 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-dashboard.png" /><noscript><img width="1024" height="540" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-dashboard.png" alt="" class="wp-image-38840" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-dashboard.png?v=1630324313 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-dashboard-300x158.png?v=1630324313 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-dashboard-150x79.png?v=1630324313 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-dashboard-768x405.png?v=1630324313 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p></p>



<p>By default, debugging is disabled in Moodle. It is always a good idea to enable debug level to debug any issues.</p>



<p>To enable debug level, click on the <strong>Site administration</strong> and search for <strong>debug</strong> as shown below:</p>



<p></p>



<figure class="wp-block-image size-full"><img width="1024" height="515" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20515'%3E%3C/svg%3E" alt="" class="wp-image-38841" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-debug.png?v=1630324327 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-debug-300x151.png?v=1630324327 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-debug-150x75.png?v=1630324327 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-debug-768x386.png?v=1630324327 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-debug.png" /><noscript><img width="1024" height="515" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-debug.png" alt="" class="wp-image-38841" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-debug.png?v=1630324327 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-debug-300x151.png?v=1630324327 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-debug-150x75.png?v=1630324327 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-debug-768x386.png?v=1630324327 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p>Now, scroll down and select &#8220;<strong>MINIMAL: Show only fatal errors</strong>&#8221; as shown below:</p>



<p></p>



<figure class="wp-block-image size-full"><img width="1024" height="380" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20380'%3E%3C/svg%3E" alt="" class="wp-image-38842" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-show-fatal-errors.png?v=1630324345 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-show-fatal-errors-300x111.png?v=1630324345 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-show-fatal-errors-150x56.png?v=1630324345 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-show-fatal-errors-768x285.png?v=1630324345 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-show-fatal-errors.png" /><noscript><img width="1024" height="380" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-show-fatal-errors.png" alt="" class="wp-image-38842" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-show-fatal-errors.png?v=1630324345 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-show-fatal-errors-300x111.png?v=1630324345 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-show-fatal-errors-150x56.png?v=1630324345 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-show-fatal-errors-768x285.png?v=1630324345 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p>Now, click on the <strong>Save change</strong> to apply the changes.</p>



<h2 id="h-how-to-upgrade-moodle-e-learning-system"><span class="ez-toc-section" id="How-to-Upgrade-Moodle-E-Learning-System"></span>How to Upgrade Moodle E-Learning System<span class="ez-toc-section-end"></span></h2>



<p>If you are using an older version of Moodle then you can upgrade your Moodle version to the latest version. It is recommended to backup Moodle before performing any upgrade. You should backup three components of Moodle:</p>



<ul><li><strong>Moodle software</strong> (/var/www/webroot/ROOT)</li><li><strong>Moodle static assets</strong> (/var/www/webroot/moodledata)</li><li><strong>Moodle dynamic content</strong> (database dump)</li></ul>



<p>Follow the below steps to upgrade your Moodle to the latest version.</p>



<p><strong>Step 1</strong> &#8211; On the Moodle environment dashboard, hover your mouse on Application Servers. You should see the following screen:</p>



<figure class="wp-block-image size-full"><img width="1024" height="281" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20281'%3E%3C/svg%3E" alt="" class="wp-image-38843" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-application-servers.png?v=1630324358 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-application-servers-300x82.png?v=1630324358 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-application-servers-150x41.png?v=1630324358 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-application-servers-768x211.png?v=1630324358 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-application-servers.png" /><noscript><img width="1024" height="281" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-application-servers.png" alt="" class="wp-image-38843" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-application-servers.png?v=1630324358 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-application-servers-300x82.png?v=1630324358 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-application-servers-150x41.png?v=1630324358 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-application-servers-768x211.png?v=1630324358 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p></p>



<p><strong>Step 2</strong> &#8211; Click on the <strong>Web SSH</strong> to connect to the application server node as shown below.</p>



<figure class="wp-block-image size-full"><img width="1024" height="439" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20439'%3E%3C/svg%3E" alt="" class="wp-image-38844" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-web-ssh.png?v=1630324369 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-web-ssh-300x129.png?v=1630324369 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-web-ssh-150x64.png?v=1630324369 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-web-ssh-768x329.png?v=1630324369 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-web-ssh.png" /><noscript><img width="1024" height="439" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-web-ssh.png" alt="" class="wp-image-38844" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-web-ssh.png?v=1630324369 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-web-ssh-300x129.png?v=1630324369 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-web-ssh-150x64.png?v=1630324369 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-web-ssh-768x329.png?v=1630324369 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p></p>



<p>Now, run the following commands to backup three Moodle components:</p>



<pre class="wp-block-preformatted">cd /var/www/webroot
tar -czvf moodledata_root.tar.gz ROOT/, 
tar -czvf moodledata.tar.gz moodledata/
mysqldump -h node1789-moodleapp.rosehosting.us -u root -p moodle --column-statistics=0 &gt; moodle_dump.sql</pre>



<p><strong>Step 3</strong> &#8211; Before performing an upgrade, you will need to enable Maintenance Mode in Moodle. Click on the <strong>Administration</strong> =&gt;<strong> Site administration</strong> =&gt; <strong>Server</strong> =&gt; <strong>Maintenance</strong> <strong>mode</strong> =&gt; <strong>Enable</strong> and click on the <strong>Save changes</strong> as shown below:</p>



<p></p>



<figure class="wp-block-image size-full"><img width="1024" height="502" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20502'%3E%3C/svg%3E" alt="" class="wp-image-38845" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-mode.png?v=1630324410 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-mode-300x147.png?v=1630324410 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-mode-150x74.png?v=1630324410 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-mode-768x377.png?v=1630324410 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-mode.png" /><noscript><img width="1024" height="502" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-mode.png" alt="" class="wp-image-38845" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-mode.png?v=1630324410 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-mode-300x147.png?v=1630324410 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-mode-150x74.png?v=1630324410 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-mode-768x377.png?v=1630324410 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p><strong>Step 4</strong> &#8211; Now, log out from the Moodle admin panel and access it again. You should see the Moodle maintenance window on the following screen:</p>



<p></p>



<figure class="wp-block-image size-full"><img width="1024" height="507" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20507'%3E%3C/svg%3E" alt="" class="wp-image-38846" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-window.png?v=1630324423 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-window-300x149.png?v=1630324423 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-window-150x74.png?v=1630324423 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-window-768x380.png?v=1630324423 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-window.png" /><noscript><img width="1024" height="507" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-window.png" alt="" class="wp-image-38846" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-window.png?v=1630324423 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-window-300x149.png?v=1630324423 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-window-150x74.png?v=1630324423 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-maintenance-window-768x380.png?v=1630324423 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p><strong>Step 5</strong> &#8211; Now, connect to the Moodle application through Web SSH and download the latest version of Moodle using the following command:</p>



<pre class="wp-block-preformatted">cd /var/www/webroot
wget https://download.moodle.org/stable311/moodle-latest-311.tgz</pre>



<p>Now, rename the Moodle software directory to another name:</p>



<pre class="wp-block-preformatted">mv ROOT ROOT.backup</pre>



<p>Next, extract the downloaded file with the following command:</p>



<pre class="wp-block-preformatted">tar -xzf moodle-latest-311.tgz</pre>



<p>Next, rename the extracted moodle directory to ROOT directory:</p>



<pre class="wp-block-preformatted">mv moodle ROOT</pre>



<p>Next, copy the configuration file from the backup directory to the new Moodle ROOT directory:</p>



<pre class="wp-block-preformatted">cp ROOT.backup/config.php ROOT</pre>



<p>You can also copy any themes and modules from the backup directory:</p>



<pre class="wp-block-preformatted">cp -pr ROOT.backup/theme/* ROOT/theme/
cp -pr ROOT.backup/mod/* ROOT/mod/ </pre>



<figure class="wp-block-image size-full"><img width="1024" height="495" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20495'%3E%3C/svg%3E" alt="" class="wp-image-38847" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-backup-directory.png?v=1630324437 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-backup-directory-300x145.png?v=1630324437 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-backup-directory-150x73.png?v=1630324437 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-backup-directory-768x371.png?v=1630324437 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-backup-directory.png" /><noscript><img width="1024" height="495" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-backup-directory.png" alt="" class="wp-image-38847" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-backup-directory.png?v=1630324437 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-backup-directory-300x145.png?v=1630324437 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-backup-directory-150x73.png?v=1630324437 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-backup-directory-768x371.png?v=1630324437 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p><strong>Step 6 </strong>&#8211; Now, access your Moodle admin URL at <strong>http://moodleapp.rosehosting.us/admin</strong>. You should see the following screen:</p>



<p></p>



<figure class="wp-block-image size-full"><img width="1024" height="453" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20453'%3E%3C/svg%3E" alt="" class="wp-image-38848" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-admin-url.png?v=1630324450 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-admin-url-300x133.png?v=1630324450 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-admin-url-150x66.png?v=1630324450 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-admin-url-768x340.png?v=1630324450 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-admin-url.png" /><noscript><img width="1024" height="453" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-admin-url.png" alt="" class="wp-image-38848" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-admin-url.png?v=1630324450 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-admin-url-300x133.png?v=1630324450 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-admin-url-150x66.png?v=1630324450 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-access-admin-url-768x340.png?v=1630324450 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p><strong>Step 7</strong> &#8211; Click on the <strong>Continue</strong> button to upgrade Moodle to the latest version. You should see the following screen:</p>



<p></p>



<figure class="wp-block-image size-full"><img width="1024" height="529" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20529'%3E%3C/svg%3E" alt="" class="wp-image-38849" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version.png?v=1630324465 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version-300x155.png?v=1630324465 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version-150x77.png?v=1630324465 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version-768x397.png?v=1630324465 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version.png" /><noscript><img width="1024" height="529" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version.png" alt="" class="wp-image-38849" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version.png?v=1630324465 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version-300x155.png?v=1630324465 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version-150x77.png?v=1630324465 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version-768x397.png?v=1630324465 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<figure class="wp-block-image size-full"><img width="1024" height="525" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20525'%3E%3C/svg%3E" alt="" class="wp-image-38850" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version-2.png?v=1630324476 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version-2-300x154.png?v=1630324476 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version-2-150x77.png?v=1630324476 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version-2-768x394.png?v=1630324476 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version-2.png" /><noscript><img width="1024" height="525" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version-2.png" alt="" class="wp-image-38850" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version-2.png?v=1630324476 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version-2-300x154.png?v=1630324476 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version-2-150x77.png?v=1630324476 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-moodle-to-latest-version-2-768x394.png?v=1630324476 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p></p>



<p><strong>Step 8 </strong>&#8211; Review newer version information, scroll down and click on the <strong>Continue</strong> button. You should see the plugins check page:</p>



<figure class="wp-block-image size-full"><img width="1024" height="329" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20329'%3E%3C/svg%3E" alt="" class="wp-image-38851" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-plugins-check.png?v=1630324489 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-plugins-check-300x96.png?v=1630324489 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-plugins-check-150x48.png?v=1630324489 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-plugins-check-768x247.png?v=1630324489 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-plugins-check.png" /><noscript><img width="1024" height="329" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-plugins-check.png" alt="" class="wp-image-38851" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-plugins-check.png?v=1630324489 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-plugins-check-300x96.png?v=1630324489 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-plugins-check-150x48.png?v=1630324489 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-plugins-check-768x247.png?v=1630324489 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p></p>



<p><strong>Step 9</strong> &#8211; Click on <strong>Upgrade Moodle database now</strong>. Once the upgrade process is completed, you should see the Success message in the following screen:</p>



<figure class="wp-block-image size-full"><img width="1024" height="282" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20282'%3E%3C/svg%3E" alt="" class="wp-image-38852" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-completed.png?v=1630324503 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-completed-300x83.png?v=1630324503 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-completed-150x41.png?v=1630324503 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-completed-768x212.png?v=1630324503 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-completed.png" /><noscript><img width="1024" height="282" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-completed.png" alt="" class="wp-image-38852" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-completed.png?v=1630324503 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-completed-300x83.png?v=1630324503 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-completed-150x41.png?v=1630324503 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-upgrade-completed-768x212.png?v=1630324503 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p></p>



<p>You can now click on the <strong>Continue</strong> button to log in to the latest Moodle version.</p>



<p>Congratulations! You have successfully installed Moodle E-Learning system on the <a href="https://www.rosehosting.com/managed-cloud-hosting.html">RoseHosting Cloud PaaS platform</a>.  As always, if you face any problems or need any assistance, you can always contact us. We are available 24/7 to help you. </p>



<p>If this post on Moodle Online Learning System Automated Installation and Upgrade helped you in any way, you can share it with your friends on the social networks using the buttons on the left, or simply comment your appreciation in the comments below. Thanks. </p>
		</div>

				<footer class="entry-meta" aria-label="Entry meta">
			<span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://www.rosehosting.com/blog/category/guides/" rel="category tag">Guides</a></span> 		<nav id="nav-below" class="post-navigation" aria-label="Single Post">
			<span class="screen-reader-text">Post navigation</span>

			<div class="nav-previous"><span class="prev" title="Previous"><a href="https://www.rosehosting.com/blog/how-to-install-mysql-database-on-ubuntu-20-04/" rel="prev">How to Install MySQL Database on Ubuntu 20.04</a></span></div>		</nav>
				</footer>
			</div>
</article>

			<div class="comments-area">
				<div id="comments">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/moodle-online-learning-system-automated-installation-and-upgrade/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.rosehosting.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea autocomplete="new-password"  id="e42af3c480"  name="e42af3c480"   cols="45" rows="8" required></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0 !important;clip:rect(1px, 1px, 1px, 1px) !important;position:absolute !important;white-space:nowrap !important;height:1px !important;width:1px !important;overflow:hidden !important;" tabindex="-1"></textarea><script type="rocketlazyloadscript" data-noptimize data-rocket-type="text/javascript">document.getElementById("comment").setAttribute( "id", "acb5341790394688fd2defd1be29a8b6" );document.getElementById("e42af3c480").setAttribute( "id", "comment" );</script></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" required />
<label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" required />

<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="cptch_block"><span class="cptch_title cptch_to_remove">To prove you are human please solve the following<span class="required"> *</span></span><span class="cptch_wrap cptch_math_actions">
				<label class="cptch_label" for="cptch_input_84"><span class="cptch_span"><input id="cptch_input_84" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span>
					<span class="cptch_span">&nbsp;&#43;&nbsp;</span>
					<span class="cptch_span">8</span>
					<span class="cptch_span">&nbsp;=&nbsp;</span>
					<span class="cptch_span">f&#105;fte&#101;n</span>
					<input type="hidden" name="cptch_result" value="in4=" /><input type="hidden" name="cptch_time" value="1638561554" />
					<input type="hidden" name="cptch_form" value="wp_comments" />
				</label><span class="cptch_reload_button_wrap hide-if-no-js">
					<noscript>
						<style type="text/css">
							.hide-if-no-js {
								display: none !important;
							}
						</style>
					</noscript>
					<span class="cptch_reload_button dashicons dashicons-update"></span>
				</span></span></p><p class="comment-form-mailpoet">
      <label for="mailpoet_subscribe_on_comment">
        <input
          type="checkbox"
          id="mailpoet_subscribe_on_comment"
          value="1"
          name="mailpoet[subscribe_on_comment]"
        />&nbsp;Yes, add me to your new blog post notifications list
      </label>
    </p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='38805' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
			</div>

					</main>
	</div>

	<div class="widget-area sidebar is-right-sidebar grid-30 tablet-grid-30 grid-parent" id="right-sidebar">
	<div class="inside-right-sidebar">
		<aside id="categories-3" class="widget inner-padding widget_categories"><h2 class="widget-title">Categories</h2><form action="https://www.rosehosting.com/blog" method="get"><label class="screen-reader-text" for="cat">Categories</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="1709">Caching&nbsp;&nbsp;(23)</option>
	<option class="level-0" value="1699">CentOS&nbsp;&nbsp;(303)</option>
	<option class="level-0" value="1710">CMS, CRM, ERP&nbsp;&nbsp;(230)</option>
	<option class="level-0" value="1708">Control Panels&nbsp;&nbsp;(47)</option>
	<option class="level-0" value="1702">Databases&nbsp;&nbsp;(107)</option>
	<option class="level-0" value="1700">Debian&nbsp;&nbsp;(151)</option>
	<option class="level-0" value="1711">E-Commerce&nbsp;&nbsp;(63)</option>
	<option class="level-0" value="1706">Email Servers&nbsp;&nbsp;(36)</option>
	<option class="level-0" value="1236">Guides&nbsp;&nbsp;(59)</option>
	<option class="level-0" value="1705">Load Balancing&nbsp;&nbsp;(5)</option>
	<option class="level-0" value="1">Miscellaneous&nbsp;&nbsp;(51)</option>
	<option class="level-0" value="1701">Networking and Domains&nbsp;&nbsp;(42)</option>
	<option class="level-0" value="3">News&nbsp;&nbsp;(12)</option>
	<option class="level-0" value="1704">Optimization&nbsp;&nbsp;(21)</option>
	<option class="level-0" value="1713">Other&nbsp;&nbsp;(6)</option>
	<option class="level-0" value="4">RoseHosting Platform&nbsp;&nbsp;(46)</option>
	<option class="level-0" value="5">Scripts&nbsp;&nbsp;(11)</option>
	<option class="level-0" value="1703">Security&nbsp;&nbsp;(104)</option>
	<option class="level-0" value="606">SEO&nbsp;&nbsp;(2)</option>
	<option class="level-0" value="21">Tips and Tricks&nbsp;&nbsp;(74)</option>
	<option class="level-0" value="13">Tutorials&nbsp;&nbsp;(808)</option>
	<option class="level-0" value="1698">Ubuntu&nbsp;&nbsp;(392)</option>
	<option class="level-0" value="1712">Web Frameworks&nbsp;&nbsp;(112)</option>
	<option class="level-0" value="1707">Web Servers&nbsp;&nbsp;(141)</option>
</select>
</form>
<script type="rocketlazyloadscript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</aside><aside class="widget inner-padding rhad-widget"><div  class="rhad-419d2e8eeeef51bacc09f4933aa3cca7 rhad-sidebar-ad-group" id="rhad-419d2e8eeeef51bacc09f4933aa3cca7"></div></aside><aside id="custom_html-8" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a target="_blank" href="https://www.rosehosting.com/about-us.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">About RoseHosting</a><br>
<a target="_blank" href="https://www.rosehosting.com/linux-vps-hosting/" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Buy a Managed VPS - 25% OFF</a><br>
<a target="_blank" href="https://www.rosehosting.com/reviews.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">RoseHosting Customer Reviews</a><br>
<a target="_blank" href="https://www.rosehosting.com/nvme-hosting.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Managed NVMe VPSes</a><br>
	<a target="_blank" href="https://www.rosehosting.com/dedicated-servers.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Managed NVMe Dedicated Servers</a>
</div></aside><aside id="zoom-social-icons-widget-2" class="widget inner-padding zoom-social-icons-widget">
		
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--align-center zoom-social-icons-list--no-labels">

		
				<li class="zoom-social_icons-list__item">
		<a class="zoom-social_icons-list__link" href="https://www.facebook.com/RoseHosting" target="_blank" >
									
						<span class="screen-reader-text">facebook</span>
			
						<span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #3b5998; font-size: 30px; padding:10px" ></span>
			
					</a>
	</li>

	
				<li class="zoom-social_icons-list__item">
		<a class="zoom-social_icons-list__link" href="https://twitter.com/rosehosting" target="_blank" >
									
						<span class="screen-reader-text">twitter</span>
			
						<span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#1da1f2" style="background-color : #1da1f2; font-size: 30px; padding:10px" ></span>
			
					</a>
	</li>

	
				<li class="zoom-social_icons-list__item">
		<a class="zoom-social_icons-list__link" href="https://www.linkedin.com/company/rose-web-services-l-l-c-" target="_blank" >
									
						<span class="screen-reader-text">linkedin</span>
			
						<span class="zoom-social_icons-list-span social-icon socicon socicon-linkedin" data-hover-rule="background-color" data-hover-color="#0077B5" style="background-color : #0077B5; font-size: 30px; padding:10px" ></span>
			
					</a>
	</li>

	
</ul>

		</aside><aside id="search-3" class="widget inner-padding widget_search"><form method="get" class="search-form" action="https://www.rosehosting.com/blog/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:">
	</label>
	<input type="submit" class="search-submit" value="Search"></form>
</aside><aside id="recent-posts-widget-with-thumbnails-2" class="widget inner-padding recent-posts-widget-with-thumbnails">
<div id="rpwwt-recent-posts-widget-with-thumbnails-2" class="rpwwt-widget">
	<ul>
		<li><a href="https://www.rosehosting.com/blog/moodle-online-learning-system-automated-installation-and-upgrade/" aria-current="page"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="Moodle Online Learning System Automated Installation and Upgrade" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade-150x75.jpg?v=1630074391 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade-300x150.jpg?v=1630074391 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade.jpg?v=1630074391 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade-150x75.jpg?v=1630074391" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade-150x75.jpg?v=1630074391" class="attachment-75x75 size-75x75" alt="Moodle Online Learning System Automated Installation and Upgrade" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade-150x75.jpg?v=1630074391 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade-300x150.jpg?v=1630074391 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/moodle-online-learning-system-automated-installation-and-upgrade.jpg?v=1630074391 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">Moodle Online Learning System Automated Installation and Upgrade</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-mysql-database-on-ubuntu-20-04/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to install mysql database on ubuntu 20.04" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/11/how-to-install-mysql-database-on-ubuntu-20.04-150x75.jpg?v=1635752781 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/11/how-to-install-mysql-database-on-ubuntu-20.04-300x150.jpg?v=1635752781 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/11/how-to-install-mysql-database-on-ubuntu-20.04.jpg?v=1635752781 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/11/how-to-install-mysql-database-on-ubuntu-20.04-150x75.jpg?v=1635752781" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/11/how-to-install-mysql-database-on-ubuntu-20.04-150x75.jpg?v=1635752781" class="attachment-75x75 size-75x75" alt="how to install mysql database on ubuntu 20.04" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/11/how-to-install-mysql-database-on-ubuntu-20.04-150x75.jpg?v=1635752781 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/11/how-to-install-mysql-database-on-ubuntu-20.04-300x150.jpg?v=1635752781 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/11/how-to-install-mysql-database-on-ubuntu-20.04.jpg?v=1635752781 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Install MySQL Database on Ubuntu 20.04</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-icinga-2-on-ubuntu-20-04/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to install icinga 2 on ubuntu 20.04" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-icinga-2-on-ubuntu-20.04-150x75.jpg?v=1635506546 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-icinga-2-on-ubuntu-20.04-300x150.jpg?v=1635506546 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-icinga-2-on-ubuntu-20.04.jpg?v=1635506546 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-icinga-2-on-ubuntu-20.04-150x75.jpg?v=1635506546" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-icinga-2-on-ubuntu-20.04-150x75.jpg?v=1635506546" class="attachment-75x75 size-75x75" alt="how to install icinga 2 on ubuntu 20.04" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-icinga-2-on-ubuntu-20.04-150x75.jpg?v=1635506546 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-icinga-2-on-ubuntu-20.04-300x150.jpg?v=1635506546 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-icinga-2-on-ubuntu-20.04.jpg?v=1635506546 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How To Install Icinga 2 on Ubuntu 20.04</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-discourse-on-ubuntu-20-04/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to install discourse on ubuntu 20.04" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04-150x75.jpg?v=1635497255 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04-300x150.jpg?v=1635497255 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04.jpg?v=1635497255 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04-150x75.jpg?v=1635497255" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04-150x75.jpg?v=1635497255" class="attachment-75x75 size-75x75" alt="how to install discourse on ubuntu 20.04" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04-150x75.jpg?v=1635497255 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04-300x150.jpg?v=1635497255 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-discourse-on-ubuntu-20.04.jpg?v=1635497255 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How To Install Discourse on Ubuntu 20.04</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-odoo-15-on-ubuntu-20-04/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to install Odoo 15 on Ubuntu 20.04" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-odoo-15-ubuntu-20.04-150x75.jpg?v=1635520134 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-odoo-15-ubuntu-20.04-300x150.jpg?v=1635520134 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-odoo-15-ubuntu-20.04.jpg?v=1635520134 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-odoo-15-ubuntu-20.04-150x75.jpg?v=1635520134" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-odoo-15-ubuntu-20.04-150x75.jpg?v=1635520134" class="attachment-75x75 size-75x75" alt="how to install Odoo 15 on Ubuntu 20.04" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-odoo-15-ubuntu-20.04-150x75.jpg?v=1635520134 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-odoo-15-ubuntu-20.04-300x150.jpg?v=1635520134 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/10/how-to-install-odoo-15-ubuntu-20.04.jpg?v=1635520134 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Install Odoo 15 on Ubuntu 20.04</span></a></li>
	</ul>
</div><!-- .rpwwt-widget -->
</aside>      <aside id="mailpoet_form-2" class="widget inner-padding widget_mailpoet_form">
  
  
  <div class="
    mailpoet_form_popup_overlay
      "></div>
  <div
    id="mailpoet_form_2"
    class="
      mailpoet_form
      mailpoet_form_widget
      mailpoet_form_position_
      mailpoet_form_animation_
    "
      >
    
    <style type="text/css">
     .mailpoet_hp_email_label{display:none!important;}#mailpoet_form_2 .mailpoet_form {  }
#mailpoet_form_2 form { margin-bottom: 0; }
#mailpoet_form_2 p.mailpoet_form_paragraph { margin-bottom: 10px; }
#mailpoet_form_2 .mailpoet_column_with_background { padding: 10px; }
#mailpoet_form_2 .mailpoet_form_column:not(:first-child) { margin-left: 20px; }
#mailpoet_form_2 .mailpoet_paragraph { line-height: 20px; margin-bottom: 20px; }
#mailpoet_form_2 .mailpoet_segment_label, #mailpoet_form_2 .mailpoet_text_label, #mailpoet_form_2 .mailpoet_textarea_label, #mailpoet_form_2 .mailpoet_select_label, #mailpoet_form_2 .mailpoet_radio_label, #mailpoet_form_2 .mailpoet_checkbox_label, #mailpoet_form_2 .mailpoet_list_label, #mailpoet_form_2 .mailpoet_date_label { display: block; font-weight: normal; }
#mailpoet_form_2 .mailpoet_text, #mailpoet_form_2 .mailpoet_textarea, #mailpoet_form_2 .mailpoet_select, #mailpoet_form_2 .mailpoet_date_month, #mailpoet_form_2 .mailpoet_date_day, #mailpoet_form_2 .mailpoet_date_year, #mailpoet_form_2 .mailpoet_date { display: block; }
#mailpoet_form_2 .mailpoet_text, #mailpoet_form_2 .mailpoet_textarea { width: 200px; }
#mailpoet_form_2 .mailpoet_checkbox {  }
#mailpoet_form_2 .mailpoet_submit {  }
#mailpoet_form_2 .mailpoet_divider {  }
#mailpoet_form_2 .mailpoet_message {  }
#mailpoet_form_2 .mailpoet_form_loading { width: 30px; text-align: center; line-height: normal; }
#mailpoet_form_2 .mailpoet_form_loading > span { width: 5px; height: 5px; background-color: #5b5b5b; }#mailpoet_form_2{border-radius: 0px;background: #ffffff;text-align: left;}#mailpoet_form_2 form.mailpoet_form {padding: 10px;}#mailpoet_form_2{width: 100%;}#mailpoet_form_2 .mailpoet_message {margin: 0; padding: 0 20px;}
        #mailpoet_form_2 .mailpoet_validate_success {color: #00d084}
        #mailpoet_form_2 input.parsley-success {color: #00d084}
        #mailpoet_form_2 select.parsley-success {color: #00d084}
        #mailpoet_form_2 textarea.parsley-success {color: #00d084}
      
        #mailpoet_form_2 .mailpoet_validate_error {color: #cf2e2e}
        #mailpoet_form_2 input.parsley-error {color: #cf2e2e}
        #mailpoet_form_2 select.parsley-error {color: #cf2e2e}
        #mailpoet_form_2 textarea.textarea.parsley-error {color: #cf2e2e}
        #mailpoet_form_2 .parsley-errors-list {color: #cf2e2e}
        #mailpoet_form_2 .parsley-required {color: #cf2e2e}
        #mailpoet_form_2 .parsley-custom-error-message {color: #cf2e2e}
      #mailpoet_form_2 .mailpoet_paragraph.last {margin-bottom: 0} @media (max-width: 500px) {#mailpoet_form_2 {background: #ffffff;}} @media (min-width: 500px) {#mailpoet_form_2 .last .mailpoet_paragraph:last-child {margin-bottom: 0}}  @media (max-width: 500px) {#mailpoet_form_2 .mailpoet_form_column:last-child .mailpoet_paragraph:last-child {margin-bottom: 0}} 
    </style>

    <form
      target="_self"
      method="post"
      action="https://www.rosehosting.com/blog/wp-admin/admin-post.php?action=mailpoet_subscription_form"
      class="mailpoet_form mailpoet_form_form mailpoet_form_widget"
      novalidate
      data-delay=""
      data-exit-intent-enabled=""
      data-font-family=""
    >
      <input type="hidden" name="data[form_id]" value="2" />
      <input type="hidden" name="token" value="3eb5b82180" />
      <input type="hidden" name="api_version" value="v1" />
      <input type="hidden" name="endpoint" value="subscribers" />
      <input type="hidden" name="mailpoet_method" value="subscribe" />

      <label class="mailpoet_hp_email_label">Please leave this field empty<input type="email" name="data[email]"/></label><h2 class="mailpoet-heading  mailpoet-has-font-size" id="" style="text-align: center; color: #0081ff; font-size: 20px; line-height: 1.5"><span style="font-family: Montserrat" data-font="Montserrat" class="mailpoet-has-font"><strong><span class="has-inline-color has-black-color">Join our Blog</span></strong></span></h2>
<p class="mailpoet_form_paragraph  mailpoet-has-font-size" style="text-align: center; color: #000000; font-size: 14px; line-height: 1.5"><strong><span style="font-family: Montserrat" data-font="Montserrat" class="mailpoet-has-font">Sign up and receive notifications as soon as new content is posted.</span></strong></p>
<div class="mailpoet_paragraph "><input type="email" class="mailpoet_text" name="data[form_field_ZTVlY2IyMzIyMzFkX2VtYWls]" title="Enter your e-mail" value="" style="width:100%;padding:12px;margin: 0 auto 0 0;font-size:15px;line-height:1.5;height:auto;" data-automation-id="form_email"  placeholder="Enter your e-mail *" data-parsley-required="true" data-parsley-minlength="6" data-parsley-maxlength="150" data-parsley-error-message="Please specify a valid email address." data-parsley-required-message="This field is required."/></div>
<div class="mailpoet_paragraph "><input type="submit" class="mailpoet_submit" value="Subscribe" data-automation-id="subscribe-submit-button" style="width:100%;padding:12px;margin: 0 auto 0 0;font-size:15px;line-height:1.5;height:auto;border-color:transparent;" /><span class="mailpoet_form_loading"><span class="mailpoet_bounce1"></span><span class="mailpoet_bounce2"></span><span class="mailpoet_bounce3"></span></span></div>

      <div class="mailpoet_message">
        <p class="mailpoet_validate_success"
                style="display:none;"
                >Check your inbox or spam folder to confirm your subscription.
        </p>
        <p class="mailpoet_validate_error"
                style="display:none;"
                >        </p>
      </div>
    </form>
  </div>

      </aside>
  	</div>
</div>
</div>

  <!-- footer-big-menu.html -->
  <footer class="footer-big-menu">
    <div class="container" style="max-width: 1100px;">

      <div class="row menu">

        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title mb-2">Company</h3>
            <a class="menu-link" href="https://www.rosehosting.com/about-us.html">About us</a>
            <a class="menu-link" href="https://www.rosehosting.com/policies.html">Our Policies</a>
            <a class="menu-link" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
            <a class="menu-link" href="https://www.rosehosting.com/blog/">Blog</a>
            <a class="menu-link" href="https://www.rosehosting.com/why-rosehosting.html">Why RoseHosting</a>
            <a class="menu-link" href="https://www.rosehosting.com/compare-to-competition.html">Compare Us</a>
            <a class="menu-link" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
            <a class="menu-link" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
            <a class="menu-link" href="/recommended-tools-and-services.html">Recommended Services</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Support</h3>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Helpdesk System</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>

          <h3 class="menu-title  mb-2 mt-4">Other Services</h3>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Domain Registration</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Domain Transfer</a>
          <a class="menu-link" href="https://www.rosehosting.com/ssl-certificates.html">SSL Certificates</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/linux-vps-hosting/">Linux VPS Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/managed-cloud-hosting.html">Cloud Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom SSD VPS</a>
          <a class="menu-link" href="https://www.rosehosting.com/dedicated-servers.html">Dedicated Servers</a>
          <a class="menu-link" href="https://www.rosehosting.com/hosting-solutions.html">Hosting Solutions</a>
          <a class="menu-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Recurr. Affiliate Program</a>
          <a class="menu-link" href="https://www.rosehosting.com/cpa-hosting-affiliate-program.html">CPA Affiliate Program</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Linux VPS Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/centos-hosting.html">CentOS Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/ubuntu-hosting.html">Ubuntu Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/debian-hosting.html">Debian Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/opensuse-hosting.html">OpenSUSE Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/arch-linux-hosting.html">Arch-Linux Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/scientific-linux-hosting.html">Scientific Linux Hosting</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Apps Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/wordpress-hosting.html">WordPress Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/magento-hosting.html">Magento Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/odoo-hosting.html">Odoo Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/joomla-hosting.html">Joomla Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/drupal-hosting.html">Drupal Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/laravel-hosting.html">Laravel Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/nextcloud-hosting.html">NextCloud Hosting</a>

          <a class="menu-link" href="https://www.rosehosting.com/prestashop-hosting.html">PrestaShop Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/ghost-hosting.html">Ghost Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/mediawiki-hosting.html">MediaWiki Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/tomcat-hosting.html">Tomcat Hosting</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title mb-2">Contact Us</h3>
          <a class="menu-link" href="tel:+18887673467">(888) ROSE-HOST</a>
          <a class="menu-link" href="tel:+18887673467">(888) 767-3467</a>
          <a class="menu-link" href="tel:+13142750414">(314) 275-0414</a>
          <a class="menu-link" href="mailto:%73%75%70%70%6f%72%74%40%72%6f%73%65%68%6f%73%74%69%6e%67%2e%63%6f%6d">Email us</a>

          <h3 class="menu-title mb-2 mt-4">Connect</h3>
          <a class="menu-link" href="https://twitter.com/rosehosting" target="_blank"><i class="fa fa-twitter fa-fw"></i> Twitter</a>
          <a class="menu-link" href="https://www.facebook.com/RoseHosting" target="_blank"><i class="fa fa-facebook fa-fw"></i> Facebook</a>
          <a class="menu-link" href="https://www.linkedin.com/in/rosehosting/" target="_blank"><i class="fa fa-linkedin fa-fw"></i> LinkedIn</a>
          <a class="menu-link" href="https://www.rosehosting.com/blog/feed/" target="_blank"><i class="fa fa-rss fa-fw"></i> RSS Feed</a>

        </div>

      </div>

    </div>

<br>
    <div class="bottom">
      <div class="container" style="max-width: 1100px;">
        <div class="row">

          <div class="col-md-12 col-lg-6">
              <p class="text-sm-left"><a class="inline-link footer-policy" href="/tos.html">Terms of Service</a> and <a class="inline-link footer-policy" href="/policies.html">other policies</a></p>
          </div>
          <div class="col-md-12 col-lg-6">
            <p class="text-sm-right">&copy; 2001-2021 <a class="inline-link footer-policy" href="https://www.rosewebservices.com/">Rose Web Services LLC</a>.</p>
          </div>
         </div>
      </div>
    </div>

<!-- livezilla.net code
<script type="rocketlazyloadscript" data-rocket-type="text/javascript" id="aff1f81b02f303eea5f87a3a065f153a" src="https://linuxhostsupport.com/chat//script.php?id=aff1f81b02f303eea5f87a3a065f153a"></script>
http://www.livezilla.net -->

<script type="rocketlazyloadscript" id="generate-a11y">!function(){"use strict";if("querySelector"in document&&"addEventListener"in window){var e=document.body;e.addEventListener("mousedown",function(){e.classList.add("using-mouse")}),e.addEventListener("keydown",function(){e.classList.remove("using-mouse")})}}();</script>



<script id='advanced-ads-pro/cache_busting-js-extra'>
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":"","wp_timezone_offset":"-21600"};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/advanced-ads-pro/assets/js/base.min.js' id='advanced-ads-pro/cache_busting-js' defer></script>
<script id='advanced-ads-layer-footer-js-js-extra'>
var advanced_ads_layer_settings = {"layer_class":"rhad-layer","placements":["20th-anniversary-sale-popup"]};
</script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/advanced-ads-layer/public/assets/js/layer.js?ver=1635278974' id='advanced-ads-layer-footer-js-js' defer></script>
<script type="rocketlazyloadscript" id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script id='rocket-preload-links-js-extra'>
var RocketPreloadLinksConfig = {"excludeUris":"\/blog(\/quiz\/github\/|\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$))|\/wp-admin\/|\/logout\/|\/wp-login.php","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/www.rosehosting.com\/blog","onHoverDelay":"100","rateThrottle":"3"};
</script>
<script type="rocketlazyloadscript" id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/advanced-ads-pro/assets/js/advanced-ads-pro.min.js' id='advanced-ads-pro/front-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/themes/rh2020/js/theme.js?ver=1635278974' id='theme-js' defer></script>
<!--[if lte IE 11]>
<script src='https://www.rosehosting.com/blog/wp-content/themes/generatepress/assets/js/classList.min.js' id='generate-classlist-js'></script>
<![endif]-->
<script id='generate-menu-js-extra'>
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/themes/generatepress/assets/js/menu.min.js' id='generate-menu-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-includes/js/comment-reply.min.js' id='comment-reply-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/js/social-icons-widget-frontend.js?ver=1635278974' id='zoom-social-icons-widget-frontend-js' defer></script>
<script src='https://www.rosehosting.com/blog/wp-includes/js/wp-embed.min.js' id='wp-embed-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/smooth-scroll/jquery.smooth-scroll.min.js' id='jquery-smooth-scroll-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/js-cookie/js.cookie.min.js' id='js-cookie-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/sticky-kit/jquery.sticky-kit.min.js' id='jquery-sticky-kit-js' defer></script>
<script id='ez-toc-js-js-extra'>
var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"","width":"95%","scroll_offset":"30"};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/assets/js/front.min.js' id='ez-toc-js-js' defer></script>
<script id='mailpoet_public-js-extra'>
var MailPoetForm = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","is_rtl":""};
</script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/mailpoet/assets/dist/js/public.0968942a.js?ver=1637306714' id='mailpoet_public-js' defer></script>
<script type="rocketlazyloadscript" id='mailpoet_public-js-after'>
function initMailpoetTranslation() {
  if (typeof MailPoet !== 'undefined') {
    MailPoet.I18n.add('ajaxFailedErrorMessage', 'An error has happened while performing a request, please try again later.')
  } else {
    setTimeout(initMailpoetTranslation, 250);
  }
}
setTimeout(initMailpoetTranslation, 250);
</script>
<script id='cptch_front_end_script-js-extra'>
var cptch_vars = {"nonce":"bd9f896fdf","ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","enlarge":"","time_limit":"120"};
</script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/captcha-bws/js/front_end_script.js?ver=1635278974' id='cptch_front_end_script-js' defer></script>
<!--noptimize--><script type="rocketlazyloadscript">window.advads_admin_bar_items = [{"title":"20th anniversary sale popup","type":"placement"}];</script><!--/noptimize--><!--noptimize--><script type="rocketlazyloadscript">window.advads_passive_placements = {"sidebar-ad-group_2":{"type":"group","id":1744,"elementid":["rhad-419d2e8eeeef51bacc09f4933aa3cca7"],"ads":{"26322":{"id":26322,"title":"after-first-image-300x250-rh-orange","expiry_date":0,"visitors":[],"content":"<div style=\"margin-left: auto; margin-right: auto; text-align: center; \" id=\"rhad-143867436\"><center><a target=\"_blank\" href=\"https:\/\/www.rosehosting.com\/cloud-vps-hosting.html\"><img src=\"https:\/\/media.rosehosting.com\/images\/blogads\/orange.jpg\" alt=\"Cloud VPS Hosting\"><\/a><\/center>\r\n<\/div>","once_per_page":0,"debugmode":false,"blog_id":1,"type":"plain","position":"center","privacy":{"ignore":false,"needs_consent":false}},"34828":{"id":34828,"title":"Managed NVME Hosting 300x250","expiry_date":0,"visitors":[],"content":"<a href=\"https:\/\/www.rosehosting.com\/nvme-hosting.html\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2020\/11\/Managed-NVMe-VPS-Hosting.jpg\" alt=\"Managed NVMe VPS Hosting\"  width=\"300\" height=\"250\"   \/><\/a>","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}},"34897":{"id":34897,"title":"Linux Server Management Services LHS 300x250","expiry_date":0,"visitors":[],"content":"<a href=\"https:\/\/linuxhostsupport.com\/\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2020\/11\/Linux-Server-Management-Service.jpg\" alt=\"Linux Server Management Service\"  width=\"300\" height=\"250\"   \/><\/a>","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}},"34996":{"id":34996,"title":"Dedicated Server Hosting","expiry_date":0,"visitors":[],"content":"<a href=\"https:\/\/www.rosehosting.com\/dedicated-servers.html\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2020\/12\/Dedicated-Server-Hosting.jpg\" alt=\"Dedicated Server Hosting\"  width=\"300\" height=\"250\"   \/><\/a>","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}},"34829":{"id":34829,"title":"Managed VPS Hosting 300x250","expiry_date":0,"visitors":[],"content":"<a href=\"https:\/\/www.rosehosting.com\/linux-vps-hosting\/\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2020\/11\/Managed-VPS-Hosting.jpg\" alt=\"Managed VPS Hosting\"  width=\"300\" height=\"250\"   \/><\/a>","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}}},"group_info":{"id":1744,"name":"RH and LHS","weights":{"34996":10,"34994":10,"34993":10,"34897":10,"34870":10,"34868":10,"34829":10,"34828":10,"34827":10,"34821":10,"34786":10,"26322":10},"type":"default","ordered_ad_ids":[34786,34994,26322,34828,34897,34996,34868,34829,34870,34827,34993,34821],"ad_count":1,"refresh_enabled":true,"refresh_interval_for_ads":{"34827":15000,"34828":15000,"26322":15000,"34786":15000,"34996":15000,"34993":15000,"34868":15000,"34897":15000,"34994":15000,"34829":15000,"34821":15000,"34870":15000}},"placement_info":{"type":"sidebar_widget","name":"sidebar ad group","item":"group_1744","id":"sidebar-ad-group"},"test_id":null,"group_wrap":[{"before":"<div class=\"rhad-sidebar-ad-group\" id=\"rhad-174755722\">","after":"<\/div>"}],"inject_before":[""]}};
window.advads_ajax_queries = [{"id":"before-content","method":"placement","params":{"placement_position":"center","previous_method":"placement","previous_id":"before-content","post":"r0","url_parameter":"\/blog\/moodle-online-learning-system-automated-installation-and-upgrade\/","placement_type":"post_top","output":{"class":["rhad-before-content"],"placement_id":"before-content"}},"elementid":"rhad-26bccf60ed875ab62fc396eb8133e6e5","blog_id":1}];
window.advads_ajax_queries_args = {"r0":{"id":38805,"author":"4","post_type":"post"}};
( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( !window.advanced_ads_pro ) {console.log("Advanced Ads Pro: cache-busting can not be initialized");} });</script><!--/noptimize--><!--noptimize--><script type="rocketlazyloadscript">!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><!--/noptimize--><script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.rosehosting.com/blog/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script>
</body>
</html>

<!-- Cached for great performance - Debug: cached@1638561554 -->