<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />


	<link rel="pingback" href="https://www.rosehosting.com/blog/xmlrpc.php" />


		<!--[if lt IE 9]>
	<script src="https://www.rosehosting.com/blog/wp-content/themes/generatepress/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->

<!--<script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script>-->

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KVJ4PJ');</script>
<!-- End Google Tag Manager -->

	

	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO Premium plugin v16.5 (Yoast SEO v16.5) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Setting Up Environment with RoseHosting Cloud PaaS - RoseHosting</title><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2Cregular%2Citalic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CAbril%20FatFace%3A400%2C400i%2C700%2C700i%7CAlegreya%3A400%2C400i%2C700%2C700i%7CAlegreya%20Sans%3A400%2C400i%2C700%2C700i%7CAmatic%20SC%3A400%2C400i%2C700%2C700i%7CAnonymous%20Pro%3A400%2C400i%2C700%2C700i%7CArchitects%20Daughter%3A400%2C400i%2C700%2C700i%7CArchivo%3A400%2C400i%2C700%2C700i%7CArchivo%20Narrow%3A400%2C400i%2C700%2C700i%7CAsap%3A400%2C400i%2C700%2C700i%7CBarlow%3A400%2C400i%2C700%2C700i%7CBioRhyme%3A400%2C400i%2C700%2C700i%7CBonbon%3A400%2C400i%2C700%2C700i%7CCabin%3A400%2C400i%2C700%2C700i%7CCairo%3A400%2C400i%2C700%2C700i%7CCardo%3A400%2C400i%2C700%2C700i%7CChivo%3A400%2C400i%2C700%2C700i%7CConcert%20One%3A400%2C400i%2C700%2C700i%7CCormorant%3A400%2C400i%2C700%2C700i%7CCrimson%20Text%3A400%2C400i%2C700%2C700i%7CEczar%3A400%2C400i%2C700%2C700i%7CExo%202%3A400%2C400i%2C700%2C700i%7CFira%20Sans%3A400%2C400i%2C700%2C700i%7CFjalla%20One%3A400%2C400i%2C700%2C700i%7CFrank%20Ruhl%20Libre%3A400%2C400i%2C700%2C700i%7CGreat%20Vibes%3A400%2C400i%2C700%2C700i%7CHeebo%3A400%2C400i%2C700%2C700i%7CIBM%20Plex%3A400%2C400i%2C700%2C700i%7CInconsolata%3A400%2C400i%2C700%2C700i%7CIndie%20Flower%3A400%2C400i%2C700%2C700i%7CInknut%20Antiqua%3A400%2C400i%2C700%2C700i%7CInter%3A400%2C400i%2C700%2C700i%7CKarla%3A400%2C400i%2C700%2C700i%7CLibre%20Baskerville%3A400%2C400i%2C700%2C700i%7CLibre%20Franklin%3A400%2C400i%2C700%2C700i%7CMontserrat%3A400%2C400i%2C700%2C700i%7CNeuton%3A400%2C400i%2C700%2C700i%7CNotable%3A400%2C400i%2C700%2C700i%7CNothing%20You%20Could%20Do%3A400%2C400i%2C700%2C700i%7CNoto%20Sans%3A400%2C400i%2C700%2C700i%7CNunito%3A400%2C400i%2C700%2C700i%7COld%20Standard%20TT%3A400%2C400i%2C700%2C700i%7COxygen%3A400%2C400i%2C700%2C700i%7CPacifico%3A400%2C400i%2C700%2C700i%7CPoppins%3A400%2C400i%2C700%2C700i%7CProza%20Libre%3A400%2C400i%2C700%2C700i%7CPT%20Sans%3A400%2C400i%2C700%2C700i%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CRakkas%3A400%2C400i%2C700%2C700i%7CReenie%20Beanie%3A400%2C400i%2C700%2C700i%7CRoboto%20Slab%3A400%2C400i%2C700%2C700i%7CRopa%20Sans%3A400%2C400i%2C700%2C700i%7CRubik%3A400%2C400i%2C700%2C700i%7CShadows%20Into%20Light%3A400%2C400i%2C700%2C700i%7CSpace%20Mono%3A400%2C400i%2C700%2C700i%7CSpectral%3A400%2C400i%2C700%2C700i%7CSue%20Ellen%20Francisco%3A400%2C400i%2C700%2C700i%7CTitillium%20Web%3A400%2C400i%2C700%2C700i%7CUbuntu%3A400%2C400i%2C700%2C700i%7CVarela%3A400%2C400i%2C700%2C700i%7CVollkorn%3A400%2C400i%2C700%2C700i%7CWork%20Sans%3A400%2C400i%2C700%2C700i%7CYatra%20One%3A400%2C400i%2C700%2C700i&#038;display=swap" /><link rel="stylesheet" href="https://www.rosehosting.com/blog/wp-content/cache/min/1/1866cdb41180ed564d290afd4802889c.css" media="all" data-minify="1" />
	<meta name="description" content="Interested in learning how to set up environment with RoseHosting Cloud PaaS? Read on and learn how to do it." />
	<link rel="canonical" href="https://www.rosehosting.com/blog/setting-up-environment-with-rosehosting-cloud-paas/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Setting Up Environment with RoseHosting Cloud PaaS" />
	<meta property="og:description" content="Interested in learning how to set up environment with RoseHosting Cloud PaaS? Read on and learn how to do it." />
	<meta property="og:url" content="https://www.rosehosting.com/blog/setting-up-environment-with-rosehosting-cloud-paas/" />
	<meta property="og:site_name" content="RoseHosting" />
	<meta property="article:publisher" content="https://www.facebook.com/RoseHosting" />
	<meta property="article:author" content="https://www.facebook.com/rosehosting.helpdesk" />
	<meta property="article:published_time" content="2021-06-14T17:30:00+00:00" />
	<meta property="article:modified_time" content="2021-06-03T07:49:50+00:00" />
	<meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS.jpg?v=1622206011" />
	<meta property="og:image:width" content="742" />
	<meta property="og:image:height" content="372" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:title" content="Setting Up Environment with RoseHosting Cloud PaaS" />
	<meta name="twitter:description" content="Interested in learning how to set up environment with RoseHosting Cloud PaaS? Read on and learn how to do it." />
	<meta name="twitter:creator" content="@rosehosting" />
	<meta name="twitter:site" content="@rosehosting" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Jeff Wilson" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="9 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Feed" href="https://www.rosehosting.com/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Comments Feed" href="https://www.rosehosting.com/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Setting Up Environment with RoseHosting Cloud PaaS Comments Feed" href="https://www.rosehosting.com/blog/setting-up-environment-with-rosehosting-cloud-paas/feed/" />
<!-- rosehosting.com/blog is managing ads with Advanced Ads --><!--noptimize--><script>
			advanced_ads_ready=function(){var e,t=[],n="object"==typeof document&&document,d=n&&n.documentElement.doScroll,o="DOMContentLoaded",a=n&&(d?/^loaded|^c/:/^loaded|^i|^c/).test(n.readyState);return!a&&n&&(e=function(){for(n.removeEventListener(o,e),window.removeEventListener("load",e),a=1;e=t.shift();)e()},n.addEventListener(o,e),window.addEventListener("load",e)),function(e){a?setTimeout(e,0):t.push(e)}}();		</script>
		<!--/noptimize--><style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	








<style id='ez-toc-inline-css'>
div#ez-toc-container p.ez-toc-title {font-size: 22px;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}div#ez-toc-container {width: 95%;}
</style>






<style id='generate-style-inline-css'>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</style>









<link rel='preload' as='font'  id='wpzoom-social-icons-font-academicons-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.ttf?v=1.8.6' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-academicons-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.woff?v=1.8.6' type='font/woff' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-fontawesome-3-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.ttf?v=4.7.0' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-fontawesome-3-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff?v=4.7.0' type='font/woff' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-fontawesome-3-woff2-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff2?v=4.7.0' type='font/woff2' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-genericons-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-genericons-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type='font/woff' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-socicon-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.ttf?v=4.1.3' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-socicon-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.woff?v=4.1.3' type='font/woff' crossorigin />
<script src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>

<script id='topbar_frontjs-js-extra'>
var tpbr_settings = {"fixed":"fixed","user_who":"notloggedin","guests_or_users":"all","message":"20th Anniversary Sale!!! 20% OFF on all hosting services. Use coupon RH20YEARS     *new customers only, while supplies last","status":"active","yn_button":"button","color":"#ba004a","button_text":"GET THE DEAL","button_url":"https:\/\/www.rosehosting.com\/20th-anniversary-sale.html","button_behavior":"newwindow","is_admin_bar":"no","detect_sticky":"0"};
</script>

<script id='advanced-ads-pro/cache_busting-js-extra'>
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":"","wp_timezone_offset":"-18000"};
</script>

<script id='advanced-ads-advanced-js-js-extra'>
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
</script>





<link rel="https://api.w.org/" href="https://www.rosehosting.com/blog/wp-json/" /><link rel="alternate" type="application/json" href="https://www.rosehosting.com/blog/wp-json/wp/v2/posts/37255" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rosehosting.com/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rosehosting.com/blog/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://www.rosehosting.com/blog/?p=37255' />
<link rel="alternate" type="application/json+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fsetting-up-environment-with-rosehosting-cloud-paas%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fsetting-up-environment-with-rosehosting-cloud-paas%2F&#038;format=xml" />
<style type="text/css" id="rhad-layer-custom-css"></style>
		<meta name="viewport" content="width=device-width, initial-scale=1"><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-270x270.png" />
		<style id="wp-custom-css">
			/* Change background color and font of pre-formatted text */
.entry-content pre {
font-family: monospace;
color: #3a3a3a;
border: none;
overflow-wrap: break-word;
}
.inside-article,
.sidebar .widget {
    border: 1px solid #e3e3e3;
}
.page-container {
    max-width: 1100px;
		align-items: center;
		justify-content: space-between;
		margin-left: auto;
		margin-right: auto;
}
.footer-big-menu {
		max-width: 1100px;
		margin-left: auto;
		margin-right: auto;
}
.col6, .col-md-3, .col-lg-2 {
		padding-left: 10px;
		padding-right: 10px;
}
.masonry-load-more {
		padding-left: 20px;
}
@media (max-width:576px) {
	.nav-item {
  	margin-top: 10px;
	}
	.menu-link, .menu-title {
  	margin-top: 10px;
	}
	.comment-content {
		overflow-wrap: break-word;
	}
}		</style>
		<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script type="text/javascript">
  var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(["setCookieDomain", "*.rosehosting.com"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.rosehosting.com/";
    _paq.push(['setTrackerUrl', u+'rosea.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.src='https://www.rosehosting.com/dist/rosea.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
</head>
<body class="post-template-default single single-post postid-37255 single-format-standard wp-embed-responsive post-image-above-header post-image-aligned-center sticky-menu-fade right-sidebar nav-below-header separate-containers contained-header active-footer-widgets-1 nav-aligned-left header-aligned-left dropdown-hover featured-image-active aa-prefix-rhad-">



<nav class="navbar yamm navbar-expand-lg navbar-dark" role="navigation">
  <div class="container no-override navbar-dark">

    <a class="navbar-brand" href="https://www.rosehosting.com/">
      <img alt="RoseHosting.com" width="186" height="37"  class="d-lg-inline mr-2" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20186%2037'%3E%3C/svg%3E" data-lazy-src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/rh-logo.svg" /><noscript><img alt="RoseHosting.com" width="186" height="37"  class="d-lg-inline mr-2" src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/rh-logo.svg" /></noscript>
    </a>

    <button class="navbar-toggler" data-toggle="collapse" data-target="#navbar-collapse">
      <span class="navbar-toggler-icon"></span>
    </button>

    <div class="collapse navbar-collapse justify-content-end" id="navbar-collapse">
      <ul class="navbar-nav">

        <li class="nav-item active dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Hosting Solutions
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">

            <div class="yamm-content">
              <div class="row">
                <div class="col-sm-6">
                   <span class="text-primary  dropdown-header"><strong>Managed SSD Hosting</strong></span>
                   <div class="dropdown-divider"></div>
                   <a class="dropdown-item" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/linux-vps-hosting/">Linux VPS Hosting</a>
                   <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom VPS</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/managed-cloud-hosting.html">Cloud Hosting</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/dedicated-servers.html">Dedicated Servers</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting <span class="ml-2 badge badge-success">new</span></a>
                </div>
                <div class="col-sm-6">
                  <span class="text-primary dropdown-header"><strong>Managed Solutions</strong></span>
                  <div class="dropdown-divider"></div>
                  <a class="dropdown-item" href="https://www.rosehosting.com/wordpress-hosting.html">
                    Wordpress Hosting
                    <small class="d-block text-muted"><i>The best blogging platform</i></small>
                  </a>
                  <a class="dropdown-item" href="https://www.rosehosting.com/magento-hosting.html">
                    Magento Hosting
                    <small class="d-block text-muted"><i>The best e-commerce platform</i></small>
                  </a>
                  <a class="dropdown-item" href="https://www.rosehosting.com/odoo-hosting.html">
                    Odoo Hosting
                    <small class="d-block text-muted"><i>The best CRM/ERP platform</i></small>
                  </a>
                  <span class="dropdown-item"><a class="btn-shadow btn-shadow-primary btn-shadow-sm" target="_blank" href="https://www.rosehosting.com/hosting-solutions.html">Other Solutions</a></span>

                </div>
              </div>
            </div>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            SSL / Domains
            <i class="fa fa-chevron-down"></i>
          </a>

          <div class="dropdown-menu" role="menu">

            <div class="yamm-content">
              <div class="row">
                <div class="col-sm-3">
                    <span class="text-primary  dropdown-header"><strong>SSL by brand</strong></span>
                    <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#geotrust">GeoTrust</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#comodo">Comodo</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#rapidssl">RapidSSL</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#thawte">Thawte</a>
                </div>
                <div class="col-sm-4">

                    <span class="text-primary  dropdown-header"><strong>SSL by Type</strong></span>
                    <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#domain_validation">Domain Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#organization_validation">Organization Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#extended_validation">Extended Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#wildcard_ssl">Wildcard SSL</a>
                </div>
                <div class="col-sm-3">
                  <span class="text-primary dropdown-header"><strong>Domains</strong></span>
                  <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Register Domains</a>
                    <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Transfer Domains</a>
                </div>
              </div>
            </div>
          </div>


        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Support
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
              <a class="dropdown-item" href="https://www.rosehosting.com/support.html">24/7 Managed Support</a>
              <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Open a Support Ticket</a>
              <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>
	      <a class="dropdown-item" rel=”nofollow” href="https://status.rosehosting.net">Systems Status</a>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            About Us
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
            <a class="dropdown-item" href="https://www.rosehosting.com/about-us.html">Our Company</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/policies.html">Our Policies</a>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Affiliates
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
            <a class="dropdown-item" href="https://www.rosehosting.com/cpa-hosting-affiliate-program.html">Flat-Rate CPA Affiliate Plan</a>
            <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Flat-Rate CPA Affiliate Login</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/vps-affiliate-program.html">Recurring Affiliate Plan</a>
            <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/aff/">Recurring Affiliate Login</a>
          </div>
        </li>

        <li class="nav-item">
          <a class="nav-link" href="https://www.rosehosting.com/blog/">Blog</a>
        </li>

        <li class="nav-item">
          <a class="nav-link nav-link--rounded" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Login</a>
        </li>

      </ul>
    </div>

  </div>
</nav>


<!--
<nav class="navbar navbar-expand-lg navbar-light bg-faded navbar-blog">
   <div class="container no-override">
    <a href="https://www.rosehosting.com/blog/" class="navbar-brand">Blog Home</a>
    <div class="navbar-collapse collapse d-flex justify-content-between" id="navbar5-blog">
        <ul class="navbar-nav categories">
            <li class="nav-item dropdown">
              <a class="nav-link dropdown-toggle" data-toggle="dropdown" href="#" role="button" aria-haspopup="true" aria-expanded="false">
                Categories
                <i class="fa fa-chevron-down"></i>
              </a>
              <div class="dropdown-menu" style="z-index:0;">
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/caching/">Caching</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/centos/">CentOS</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/cms-crm-erp/">CMS, CRM, ERP</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/control-panels/">Control Panels</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/databases/">Databases</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/debian/">Debian</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/e-commerce/">E-Commerce</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/email-servers/">Email Servers</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/guides/">Guides</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/load-balancing/">Load Balancing</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/miscellaneous/">Miscellaneous</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/networking-and-domains/">Networking and Domains</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/news/">News</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/optimization/">Optimization</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/other/">Other</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/rosehosting/">RoseHosting Platform</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/scripts/">Scripts</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/security/">Security</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/seo/">SEO</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tips-and-tricks/">Tips and Tricks</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tutorials/">Tutorials</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/ubuntu/">Ubuntu</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-frameworks/">Web Frameworks</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-servers/">Web Servers</a>
                              </div>
            </li>
        </ul>
        <form class="mx-2 my-auto d-inline" method="get" id="searchform" action="https://www.rosehosting.com/blog/">
            <div class="input-group">
                <input type="search" class="field" name="s" id="s" class="form-control border border-right-0" placeholder="Search...">
                <span class="input-group-append">
                <button name="submit" id="searchsubmit" class="btn btn-outline-secondary border border-left-0" type="submit">
                    <i class="fa fa-search"></i>
                </button>
              </span>
            </div>
        </form>
    </div>
  </div>
</nav> -->

	<div id="page-container" class="page-container">

	<div id="primary" class="content-area grid-parent mobile-grid-100 grid-70 tablet-grid-70">
		<main id="main" class="site-main">
			
<article id="post-37255" class="post-37255 post type-post status-publish format-standard has-post-thumbnail hentry category-rosehosting tag-cloud tag-cloud-hosting tag-paas" itemtype="https://schema.org/CreativeWork" itemscope>
	<div class="inside-article">
					<header class="entry-header">
				<h1 class="entry-title" itemprop="headline">Setting Up Environment with RoseHosting Cloud PaaS</h1>		<div class="entry-meta">
			<span class="posted-on"><time class="entry-date published" datetime="2021-06-14T12:30:00-05:00" itemprop="datePublished">June 14, 2021</time></span> <span class="byline">by <span class="author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope><a class="url fn n" href="https://www.rosehosting.com/blog/author/jwilson/" title="View all posts by Jeff Wilson" rel="author" itemprop="url"><span class="author-name" itemprop="name">Jeff Wilson</span></a></span></span> 		</div>
					</header>
			
		<div class="entry-content" itemprop="text">
			<div  class="rhad-3d81d910b66e7202f1749e7a7ee80560 rhad-before-content" id="rhad-3d81d910b66e7202f1749e7a7ee80560"></div>
<figure class="wp-block-image size-large"><img width="742" height="372" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20742%20372'%3E%3C/svg%3E" alt="Setting Up Environment with RoseHosting Cloud PaaS" class="wp-image-37287" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS.jpg?v=1622206011 742w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS-300x150.jpg?v=1622206011 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS-150x75.jpg?v=1622206011 150w" data-lazy-sizes="(max-width: 742px) 100vw, 742px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS.jpg" /><noscript><img width="742" height="372" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS.jpg" alt="Setting Up Environment with RoseHosting Cloud PaaS" class="wp-image-37287" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS.jpg?v=1622206011 742w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS-300x150.jpg?v=1622206011 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS-150x75.jpg?v=1622206011 150w" sizes="(max-width: 742px) 100vw, 742px" /></noscript></figure>



<p>Before hosting any application on the RoseHosting Cloud platform, you will need to create an environment with the required isolated containers. RoseHosting PaaS comes with a simple and user-friendly web UI that helps you to create and configure an environment based on your specific needs.</p>



<p>In this guide, we will explain how to create and configure an environment on the RoseHosting PaaS Platform. We will also give an explanation of each feature.</p>



<span id="more-37255"></span>



<div id="ez-toc-container" class="ez-toc-v2_0_17 counter-hierarchy ez-toc-transparent">
<div class="ez-toc-title-container">
<p class="ez-toc-title">Table of Contents</p>
<span class="ez-toc-title-toggle"><a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle" style="display: none;"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a></span></div>
<nav><ul class="ez-toc-list ez-toc-list-level-1"><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-1" href="#Create-an-Environment-on-RoseHosting-PaaS" title="Create an Environment on RoseHosting PaaS">Create an Environment on RoseHosting PaaS</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-2" href="#Select-Programming-Language-or-Specific-Deployment-Option" title="Select Programming Language or Specific Deployment Option">Select Programming Language or Specific Deployment Option</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-3" href="#Configure-Topology" title="Configure Topology">Configure Topology</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-4" href="#Configure-Nodes-Resources-and-Specifics" title="Configure Nodes Resources and Specifics">Configure Nodes Resources and Specifics</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-5" href="#Review-and-Confirm-Environment-Creation" title="Review and Confirm Environment Creation">Review and Confirm Environment Creation</a></li></ul></nav></div>
<h2 id="h-create-an-environment-on-rosehosting-paas"><span class="ez-toc-section" id="Create-an-Environment-on-RoseHosting-PaaS"></span>Create an Environment on RoseHosting PaaS<span class="ez-toc-section-end"></span></h2>



<p>First, log in to the RoseHosting Cloud Platform as shown below:</p>



<figure class="wp-block-image size-large"><img width="822" height="77" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20822%2077'%3E%3C/svg%3E" alt="setting up environment with rosehosting cloud paas" class="wp-image-37264" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-rosehosting-cloud-paas.png?v=1622204765 822w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-rosehosting-cloud-paas-300x28.png?v=1622204765 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-rosehosting-cloud-paas-150x14.png?v=1622204765 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-rosehosting-cloud-paas-768x72.png?v=1622204765 768w" data-lazy-sizes="(max-width: 822px) 100vw, 822px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-rosehosting-cloud-paas.png" /><noscript><img width="822" height="77" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-rosehosting-cloud-paas.png" alt="setting up environment with rosehosting cloud paas" class="wp-image-37264" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-rosehosting-cloud-paas.png?v=1622204765 822w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-rosehosting-cloud-paas-300x28.png?v=1622204765 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-rosehosting-cloud-paas-150x14.png?v=1622204765 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-rosehosting-cloud-paas-768x72.png?v=1622204765 768w" sizes="(max-width: 822px) 100vw, 822px" /></noscript></figure>



<p></p>



<p>Now, click on the <strong>New Environment</strong> button to create a new environment for your application. This will open the Topology wizard as shown below:</p>



<figure class="wp-block-image size-large"><img width="1024" height="592" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20592'%3E%3C/svg%3E" alt="rosehosting cloud paas" class="wp-image-37267" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas.png?v=1622204847 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-300x173.png?v=1622204847 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-150x87.png?v=1622204847 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-768x444.png?v=1622204847 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas.png" /><noscript><img width="1024" height="592" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas.png" alt="rosehosting cloud paas" class="wp-image-37267" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas.png?v=1622204847 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-300x173.png?v=1622204847 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-150x87.png?v=1622204847 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-768x444.png?v=1622204847 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p></p>



<p>From here, you can set up and customize your environment based on your application needs. I would recommend customizing the environment in the following order:</p>



<ul><li>Select the programming language or other deployment solution based on your application needs.</li><li>Add the required software stacks.</li><li>Configure nodes, resources, and scaling limit.</li><li>Specify environment name, review all settings and click on the Create button to create an environment.</li></ul>



<p>Now, we will give you a brief explanation of each point with all available possibilities.</p>



<h2 id="h-select-programming-language-or-specific-deployment-option"><span class="ez-toc-section" id="Select-Programming-Language-or-Specific-Deployment-Option"></span>Select Programming Language or Specific Deployment Option<span class="ez-toc-section-end"></span></h2>



<p>Before creating an environment, you will need to select the programming language or deployment solution for your project. RoseHosting PaaS provides several options to host and deploy an application that is suitable for all clients&#8217; needs.</p>



<ol><li>One of the best and recommended options for deploying an application is certified containers. These application stacks are configured and managed by RoseHosting. They provide all major features including, scaling, automated deployment, redeploy, and SSL for easy and smooth hosting and development.</li></ol>



<p></p>



<figure class="wp-block-image size-large"><img width="680" height="52" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20680%2052'%3E%3C/svg%3E" alt="set up environment with rosehosting cloud paas" class="wp-image-37268" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/set-up-environment-with-rosehosting-cloud-paas.png?v=1622204890 680w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/set-up-environment-with-rosehosting-cloud-paas-300x23.png?v=1622204890 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/set-up-environment-with-rosehosting-cloud-paas-150x11.png?v=1622204890 150w" data-lazy-sizes="(max-width: 680px) 100vw, 680px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/set-up-environment-with-rosehosting-cloud-paas.png" /><noscript><img width="680" height="52" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/set-up-environment-with-rosehosting-cloud-paas.png" alt="set up environment with rosehosting cloud paas" class="wp-image-37268" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/set-up-environment-with-rosehosting-cloud-paas.png?v=1622204890 680w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/set-up-environment-with-rosehosting-cloud-paas-300x23.png?v=1622204890 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/set-up-environment-with-rosehosting-cloud-paas-150x11.png?v=1622204890 150w" sizes="(max-width: 680px) 100vw, 680px" /></noscript></figure>



<p>You can click on the specific tab based on your required programming language like, Java, PHP, Node.js, Python, Ruby, .NET, or Go.</p>



<ol start="2"><li>You can click on the <strong>Docker</strong> tab to list the other deployment options as shown below:</li></ol>



<p></p>



<figure class="wp-block-image size-large"><img width="1024" height="640" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20640'%3E%3C/svg%3E" alt="setting up environment rosehosting cloud paas" class="wp-image-37269" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-rosehosting-cloud-paas.png?v=1622204938 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-rosehosting-cloud-paas-300x188.png?v=1622204938 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-rosehosting-cloud-paas-150x94.png?v=1622204938 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-rosehosting-cloud-paas-768x480.png?v=1622204938 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-rosehosting-cloud-paas.png" /><noscript><img width="1024" height="640" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-rosehosting-cloud-paas.png" alt="setting up environment rosehosting cloud paas" class="wp-image-37269" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-rosehosting-cloud-paas.png?v=1622204938 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-rosehosting-cloud-paas-300x188.png?v=1622204938 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-rosehosting-cloud-paas-150x94.png?v=1622204938 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-rosehosting-cloud-paas-768x480.png?v=1622204938 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p>Here, you can utilize the basic RoseHosting OS container. Which will helps you to make them compatible with most of the platforms.</p>



<ul><li><strong>Custom Docker Images:</strong> Docker image is used to create an application container. This option will allow you to search a specific image from the Docker Hub registry or your own private registry. However, the content is managed by respective image maintainers so it cannot give a guarantee for compatibility and platform support. It is always recommended to build a custom Docker image using the FROM instruction.</li><li><strong>Docker Engine:</strong> It is a containerization technology for building applications into the system container. It allows you to access Docker&#8217;s native functionality, including deployment, scaling, and managing application containers.</li><li><strong>Kubernetes Cluster:</strong> It provides pre-configured master and worker nodes based on the system containers. Where the Kubernetes control unit will handle the deployment, scaling, and orchestration of the microservices. While scaling and management of master and worker nodes are handled by RoseHosting.</li></ul>



<h2 id="h-configure-topology"><span class="ez-toc-section" id="Configure-Topology"></span>Configure Topology<span class="ez-toc-section-end"></span></h2>



<p>On the RoseHosting Cloud dashboard, you can configure environment topology in the left side pane. You will need to understand the following blocks before configuring topology.</p>



<ul><li><strong>Load Balancer:</strong> Used to distribute the load of all incoming requests among multiple nodes.</li><li><strong>Application Servers:</strong> You can choose your preferred web servers to run your application.</li><li><strong>Databases:</strong> Choose specific database software to store and manage data.</li><li><strong>Cache Node:</strong> Choose a Memcached caching system to reduce the application load by storing data objects in dynamic memory.</li><li><strong>Shared Storage:</strong> Storage node with NFSv4 support.</li><li><strong>Elastic VPS:</strong> Select VPS servers on the top of the Ubuntu, CentOS, Debian, and Windows OS.</li><li><strong>Build Node:</strong> Used to automate your Java-based applications.</li></ul>



<div class="wp-block-image"><figure class="aligncenter size-large"><img width="315" height="552" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20315%20552'%3E%3C/svg%3E" alt="setting environment with rosehosting cloud paas" class="wp-image-37270" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-environment-with-rosehosting-cloud-paas.png?v=1622204985 315w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-environment-with-rosehosting-cloud-paas-171x300.png?v=1622204985 171w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-environment-with-rosehosting-cloud-paas-86x150.png?v=1622204985 86w" data-lazy-sizes="(max-width: 315px) 100vw, 315px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-environment-with-rosehosting-cloud-paas.png" /><noscript><img width="315" height="552" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-environment-with-rosehosting-cloud-paas.png" alt="setting environment with rosehosting cloud paas" class="wp-image-37270" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-environment-with-rosehosting-cloud-paas.png?v=1622204985 315w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-environment-with-rosehosting-cloud-paas-171x300.png?v=1622204985 171w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-environment-with-rosehosting-cloud-paas-86x150.png?v=1622204985 86w" sizes="(max-width: 315px) 100vw, 315px" /></noscript></figure></div>



<ol><li>RoseHosting PaaS provides all popular options for each section. You can enable any blocks required for your environment and choose a suitable stack for the role.</li></ol>



<p></p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img width="309" height="547" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20309%20547'%3E%3C/svg%3E" alt="set up environment rosehosting cloud paas" class="wp-image-37271" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/set-up-environment-rosehosting-cloud-paas.png?v=1622205041 309w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/set-up-environment-rosehosting-cloud-paas-169x300.png?v=1622205041 169w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/set-up-environment-rosehosting-cloud-paas-85x150.png?v=1622205041 85w" data-lazy-sizes="(max-width: 309px) 100vw, 309px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/set-up-environment-rosehosting-cloud-paas.png" /><noscript><img width="309" height="547" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/set-up-environment-rosehosting-cloud-paas.png" alt="set up environment rosehosting cloud paas" class="wp-image-37271" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/set-up-environment-rosehosting-cloud-paas.png?v=1622205041 309w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/set-up-environment-rosehosting-cloud-paas-169x300.png?v=1622205041 169w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/set-up-environment-rosehosting-cloud-paas-85x150.png?v=1622205041 85w" sizes="(max-width: 309px) 100vw, 309px" /></noscript></figure></div>



<ol><li>You can also configure the SSL protection for your environment using the same section. There are two options available for SSL:</li></ol>



<div class="wp-block-image"><figure class="aligncenter size-large"><img width="612" height="309" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20612%20309'%3E%3C/svg%3E" alt="environment with rosehosting cloud paas" class="wp-image-37272" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/environment-with-rosehosting-cloud-paas.png?v=1622205097 612w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/environment-with-rosehosting-cloud-paas-300x151.png?v=1622205097 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/environment-with-rosehosting-cloud-paas-150x76.png?v=1622205097 150w" data-lazy-sizes="(max-width: 612px) 100vw, 612px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/environment-with-rosehosting-cloud-paas.png" /><noscript><img width="612" height="309" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/environment-with-rosehosting-cloud-paas.png" alt="environment with rosehosting cloud paas" class="wp-image-37272" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/environment-with-rosehosting-cloud-paas.png?v=1622205097 612w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/environment-with-rosehosting-cloud-paas-300x151.png?v=1622205097 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/environment-with-rosehosting-cloud-paas-150x76.png?v=1622205097 150w" sizes="(max-width: 612px) 100vw, 612px" /></noscript></figure></div>



<ul><li><strong>Built-In SSL:</strong> This will use an already trusted SSL certificate and save your time. But it is only configured with the environment default domain name. It does not work if the public IP is attached to the server.</li><li><strong>Custom SSL:</strong> This allows you to configure your custom SSL certificates for the environment. You can also install the Let&#8217;s Encrypt SSL add-on to issue and integrate a free SSL certificate automatically.</li></ul>



<h2 id="h-configure-nodes-resources-and-specifics"><span class="ez-toc-section" id="Configure-Nodes-Resources-and-Specifics"></span>Configure Nodes Resources and Specifics<span class="ez-toc-section-end"></span></h2>



<p>After configuring the topology for your environment, you will need to configure each layer from the central part of the wizard.</p>



<p>Enable or disable the application layer or provide a custom name.</p>



<p></p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img width="584" height="71" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20584%2071'%3E%3C/svg%3E" alt="environment rosehosting cloud paas" class="wp-image-37273" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/environment-rosehosting-cloud-paas.png?v=1622205145 584w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/environment-rosehosting-cloud-paas-300x36.png?v=1622205145 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/environment-rosehosting-cloud-paas-150x18.png?v=1622205145 150w" data-lazy-sizes="(max-width: 584px) 100vw, 584px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/environment-rosehosting-cloud-paas.png" /><noscript><img width="584" height="71" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/environment-rosehosting-cloud-paas.png" alt="environment rosehosting cloud paas" class="wp-image-37273" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/environment-rosehosting-cloud-paas.png?v=1622205145 584w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/environment-rosehosting-cloud-paas-300x36.png?v=1622205145 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/environment-rosehosting-cloud-paas-150x18.png?v=1622205145 150w" sizes="(max-width: 584px) 100vw, 584px" /></noscript></figure></div>



<p>You can configure the vertical scaling by setting up a number of reserved cloudlets and defining the scaling limit.</p>



<p></p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img width="578" height="265" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20578%20265'%3E%3C/svg%3E" alt="setting up environment with cloud paas rosehosting" class="wp-image-37274" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-cloud-paas-rosehosting.png?v=1622205201 578w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-cloud-paas-rosehosting-300x138.png?v=1622205201 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-cloud-paas-rosehosting-150x69.png?v=1622205201 150w" data-lazy-sizes="(max-width: 578px) 100vw, 578px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-cloud-paas-rosehosting.png" /><noscript><img width="578" height="265" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-cloud-paas-rosehosting.png" alt="setting up environment with cloud paas rosehosting" class="wp-image-37274" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-cloud-paas-rosehosting.png?v=1622205201 578w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-cloud-paas-rosehosting-300x138.png?v=1622205201 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/setting-up-environment-with-cloud-paas-rosehosting-150x69.png?v=1622205201 150w" sizes="(max-width: 578px) 100vw, 578px" /></noscript></figure></div>



<p>You don&#8217;t need to worry about charges. Because you only need to pay for consumed resources.</p>



<p>The Horizontal Scaling section will allow you to choose a number of nodes and select your preferred scaling mode.</p>



<p></p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img width="591" height="171" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20591%20171'%3E%3C/svg%3E" alt="rosehosting cloud paas environment" class="wp-image-37275" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-environment.png?v=1622205253 591w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-environment-300x87.png?v=1622205253 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-environment-150x43.png?v=1622205253 150w" data-lazy-sizes="(max-width: 591px) 100vw, 591px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-environment.png" /><noscript><img width="591" height="171" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-environment.png" alt="rosehosting cloud paas environment" class="wp-image-37275" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-environment.png?v=1622205253 591w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-environment-300x87.png?v=1622205253 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-environment-150x43.png?v=1622205253 150w" sizes="(max-width: 591px) 100vw, 591px" /></noscript></figure></div>



<p>You will also need to configure additional settings using the following section:</p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img width="424" height="175" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20424%20175'%3E%3C/svg%3E" alt="rosehosting cloud paas setting environment" class="wp-image-37276" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-setting-environment.png?v=1622205298 424w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-setting-environment-300x124.png?v=1622205298 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-setting-environment-150x62.png?v=1622205298 150w" data-lazy-sizes="(max-width: 424px) 100vw, 424px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-setting-environment.png" /><noscript><img width="424" height="175" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-setting-environment.png" alt="rosehosting cloud paas setting environment" class="wp-image-37276" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-setting-environment.png?v=1622205298 424w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-setting-environment-300x124.png?v=1622205298 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-setting-environment-150x62.png?v=1622205298 150w" sizes="(max-width: 424px) 100vw, 424px" /></noscript></figure></div>



<p></p>



<ul><li><strong>Auto-Clustering:</strong> This allows you to enable auto clustering on specific application templates. After enabling this option, you will see other options like master-slave, master-master, or galera.</li><li><strong>Disk Limit:</strong> You can define the amount of space reserved per node.</li><li><strong>Sequential restart delay:</strong> This option is used to avoid downtime. You can specify a delay between the restart operation completion on one node and the start on the other. If you want to simultaneously restart all nodes then you will need to set it to -1.</li><li><strong>Public IPv4/IPv6:</strong> You can attach additional IPv4 and IPv6 public IP to each node.</li></ul>



<p>This section will provide the container configuration tools.</p>



<p></p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img width="421" height="50" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20421%2050'%3E%3C/svg%3E" alt="rosehosting cloud paas setting up environment" class="wp-image-37277" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-setting-up-environment.png?v=1622205349 421w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-setting-up-environment-300x36.png?v=1622205349 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-setting-up-environment-150x18.png?v=1622205349 150w" data-lazy-sizes="(max-width: 421px) 100vw, 421px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-setting-up-environment.png" /><noscript><img width="421" height="50" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-setting-up-environment.png" alt="rosehosting cloud paas setting up environment" class="wp-image-37277" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-setting-up-environment.png?v=1622205349 421w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-setting-up-environment-300x36.png?v=1622205349 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/rosehosting-cloud-paas-setting-up-environment-150x18.png?v=1622205349 150w" sizes="(max-width: 421px) 100vw, 421px" /></noscript></figure></div>



<ul><li><strong>Variables:</strong> You can review and manage all environment variables within this layer.</li><li><strong>Links:</strong> Used to interconnect layers inside the environment.</li><li><strong>Volumes:</strong> used to manage all data volumes.</li><li><strong>Ports:</strong> You can see the information of all container ports.</li><li><strong>CMD / Entry Point:</strong> You can configure the container&#8217;s Entry Point and Run Command.</li></ul>



<h2 id="h-review-and-confirm-environment-creation"><span class="ez-toc-section" id="Review-and-Confirm-Environment-Creation"></span>Review and Confirm Environment Creation<span class="ez-toc-section-end"></span></h2>



<p>After configuring all the sections, you can review the allocated resources and estimate the cost of the environment.</p>



<p>The main units for measuring resources are cloudlets. You can see the number of reserved cloudlets and the scaling limit for the environment.</p>



<p></p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img width="370" height="159" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20370%20159'%3E%3C/svg%3E" alt="cloud paas setting up environment rosehosting" class="wp-image-37278" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-setting-up-environment-rosehosting.png?v=1622205444 370w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-setting-up-environment-rosehosting-300x129.png?v=1622205444 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-setting-up-environment-rosehosting-150x64.png?v=1622205444 150w" data-lazy-sizes="(max-width: 370px) 100vw, 370px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-setting-up-environment-rosehosting.png" /><noscript><img width="370" height="159" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-setting-up-environment-rosehosting.png" alt="cloud paas setting up environment rosehosting" class="wp-image-37278" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-setting-up-environment-rosehosting.png?v=1622205444 370w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-setting-up-environment-rosehosting-300x129.png?v=1622205444 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-setting-up-environment-rosehosting-150x64.png?v=1622205444 150w" sizes="(max-width: 370px) 100vw, 370px" /></noscript></figure></div>



<p>You can understand the scaling limit based on the color code as shown below:</p>



<ul><li><strong>green:</strong> load balancers</li><li><strong>blue:</strong> application servers</li><li><strong>orange:</strong> databases and cache nodes</li><li><strong>gray:</strong> all other stacks</li></ul>



<p>You can view the estimated cost of your environment in the following section.</p>



<p></p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img width="372" height="290" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20372%20290'%3E%3C/svg%3E" alt="cloud paas environment setting up rosehosting" class="wp-image-37279" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-setting-up-rosehosting.png?v=1622205495 372w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-setting-up-rosehosting-300x234.png?v=1622205495 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-setting-up-rosehosting-150x117.png?v=1622205495 150w" data-lazy-sizes="(max-width: 372px) 100vw, 372px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-setting-up-rosehosting.png" /><noscript><img width="372" height="290" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-setting-up-rosehosting.png" alt="cloud paas environment setting up rosehosting" class="wp-image-37279" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-setting-up-rosehosting.png?v=1622205495 372w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-setting-up-rosehosting-300x234.png?v=1622205495 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-setting-up-rosehosting-150x117.png?v=1622205495 150w" sizes="(max-width: 372px) 100vw, 372px" /></noscript></figure></div>



<p>The FROM tab shows the full price and also covers reserved resources. The TO tab shows the maximum possible price if all nodes are fully consumed with all resources.</p>



<p>You can hover your mouse over the pricing widget to see more information on the estimated cost calculation:</p>



<p></p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img width="648" height="463" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20648%20463'%3E%3C/svg%3E" alt="cloud paas environment rosehosting" class="wp-image-37280" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-rosehosting.png?v=1622205552 648w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-rosehosting-300x214.png?v=1622205552 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-rosehosting-150x107.png?v=1622205552 150w" data-lazy-sizes="(max-width: 648px) 100vw, 648px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-rosehosting.png" /><noscript><img width="648" height="463" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-rosehosting.png" alt="cloud paas environment rosehosting" class="wp-image-37280" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-rosehosting.png?v=1622205552 648w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-rosehosting-300x214.png?v=1622205552 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-rosehosting-150x107.png?v=1622205552 150w" sizes="(max-width: 648px) 100vw, 648px" /></noscript></figure></div>



<p>Finally, provide a name for your environment and click on the <strong>Create</strong> button.</p>



<p></p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img width="373" height="220" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20373%20220'%3E%3C/svg%3E" alt="cloud paas rosehosting" class="wp-image-37281" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-rosehosting.png?v=1622205589 373w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-rosehosting-300x177.png?v=1622205589 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-rosehosting-150x88.png?v=1622205589 150w" data-lazy-sizes="(max-width: 373px) 100vw, 373px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-rosehosting.png" /><noscript><img width="373" height="220" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-rosehosting.png" alt="cloud paas rosehosting" class="wp-image-37281" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-rosehosting.png?v=1622205589 373w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-rosehosting-300x177.png?v=1622205589 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-rosehosting-150x88.png?v=1622205589 150w" sizes="(max-width: 373px) 100vw, 373px" /></noscript></figure></div>



<p>Once the environment has been created. You should see the following page:</p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img width="1024" height="290" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20290'%3E%3C/svg%3E" alt="cloud paas environment set up rosehosting" class="wp-image-37282" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-set-up-rosehosting.png?v=1622205623 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-set-up-rosehosting-300x85.png?v=1622205623 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-set-up-rosehosting-150x42.png?v=1622205623 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-set-up-rosehosting-768x218.png?v=1622205623 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-set-up-rosehosting.png" /><noscript><img width="1024" height="290" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-set-up-rosehosting.png" alt="cloud paas environment set up rosehosting" class="wp-image-37282" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-set-up-rosehosting.png?v=1622205623 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-set-up-rosehosting-300x85.png?v=1622205623 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-set-up-rosehosting-150x42.png?v=1622205623 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/cloud-paas-environment-set-up-rosehosting-768x218.png?v=1622205623 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<p></p>



<p>You can now proceed to deploy your application on the <a href="https://www.rosehosting.com/managed-cloud-hosting.html">RoseHosting PaaS</a>.</p>



<p>You don’t have to Set Up an Environment with RoseHosting Cloud PaaS if you use one of our <a href="https://www.rosehosting.com/managed-cloud-hosting.html">Managed Cloud Paas Hosting</a>, in which case you can ask one of our expert system admins to install and configure it for you. They are available 24/7, 365 days a year, ready to assist with any configuration.</p>



<p>If you liked this post, don’t forget to show us support by sharing it with your friends on social media. Thanks!</p>
		</div>

				<footer class="entry-meta">
			<span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://www.rosehosting.com/blog/category/rosehosting/" rel="category tag">RoseHosting Platform</a></span> 		<nav id="nav-below" class="post-navigation">
			<span class="screen-reader-text">Post navigation</span>

			<div class="nav-previous"><span class="prev" title="Previous"><a href="https://www.rosehosting.com/blog/how-to-install-django-on-centos-7/" rel="prev">How to Install Django on CentOS 7</a></span></div><div class="nav-next"><span class="next" title="Next"><a href="https://www.rosehosting.com/blog/how-to-install-python-3-9-on-debian-10/" rel="next">How to Install Python 3.9 on Debian 10</a></span></div>		</nav>
				</footer>
			</div>
</article>

			<div class="comments-area">
				<div id="comments">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/setting-up-environment-with-rosehosting-cloud-paas/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.rosehosting.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea autocomplete="new-password"  id="dbe2cae398"  name="dbe2cae398"   cols="45" rows="8" aria-required="true" required></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0 !important;clip:rect(1px, 1px, 1px, 1px) !important;position:absolute !important;white-space:nowrap !important;height:1px !important;width:1px !important;overflow:hidden !important;" tabindex="-1"></textarea><script data-noptimize type="text/javascript">document.getElementById("comment").setAttribute( "id", "a8efa575a5b756da511141eeea25580a" );document.getElementById("dbe2cae398").setAttribute( "id", "comment" );</script></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" />
<label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" />

<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="cptch_block"><span class="cptch_title cptch_to_remove">To prove you are human please solve the following<span class="required"> *</span></span><span class="cptch_wrap cptch_math_actions">
				<label class="cptch_label" for="cptch_input_93"><span class="cptch_span">9</span>
					<span class="cptch_span">&nbsp;&minus;&nbsp;</span>
					<span class="cptch_span">9</span>
					<span class="cptch_span">&nbsp;=&nbsp;</span>
					<span class="cptch_span"><input id="cptch_input_93" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span>
					<input type="hidden" name="cptch_result" value="33o=" /><input type="hidden" name="cptch_time" value="1624004352" />
					<input type="hidden" name="cptch_form" value="wp_comments" />
				</label><span class="cptch_reload_button_wrap hide-if-no-js">
					<noscript>
						<style type="text/css">
							.hide-if-no-js {
								display: none !important;
							}
						</style>
					</noscript>
					<span class="cptch_reload_button dashicons dashicons-update"></span>
				</span></span></p><p class="comment-form-mailpoet">
      <label for="mailpoet_subscribe_on_comment">
        <input
          type="checkbox"
          id="mailpoet_subscribe_on_comment"
          value="1"
          name="mailpoet[subscribe_on_comment]"
        />&nbsp;Yes, add me to your new blog post notifications list
      </label>
    </p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='37255' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
			</div>

					</main>
	</div>

	<div id="right-sidebar" class="widget-area sidebar is-right-sidebar grid-30 tablet-grid-30 grid-parent" itemtype="https://schema.org/WPSideBar" itemscope>
	<div class="inside-right-sidebar">
		<aside id="categories-3" class="widget inner-padding widget_categories"><h2 class="widget-title">Categories</h2><form action="https://www.rosehosting.com/blog" method="get"><label class="screen-reader-text" for="cat">Categories</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="1709">Caching&nbsp;&nbsp;(23)</option>
	<option class="level-0" value="1699">CentOS&nbsp;&nbsp;(303)</option>
	<option class="level-0" value="1710">CMS, CRM, ERP&nbsp;&nbsp;(230)</option>
	<option class="level-0" value="1708">Control Panels&nbsp;&nbsp;(47)</option>
	<option class="level-0" value="1702">Databases&nbsp;&nbsp;(104)</option>
	<option class="level-0" value="1700">Debian&nbsp;&nbsp;(149)</option>
	<option class="level-0" value="1711">E-Commerce&nbsp;&nbsp;(60)</option>
	<option class="level-0" value="1706">Email Servers&nbsp;&nbsp;(36)</option>
	<option class="level-0" value="1236">Guides&nbsp;&nbsp;(54)</option>
	<option class="level-0" value="1705">Load Balancing&nbsp;&nbsp;(4)</option>
	<option class="level-0" value="1">Miscellaneous&nbsp;&nbsp;(48)</option>
	<option class="level-0" value="1701">Networking and Domains&nbsp;&nbsp;(41)</option>
	<option class="level-0" value="3">News&nbsp;&nbsp;(12)</option>
	<option class="level-0" value="1704">Optimization&nbsp;&nbsp;(20)</option>
	<option class="level-0" value="1713">Other&nbsp;&nbsp;(5)</option>
	<option class="level-0" value="4">RoseHosting Platform&nbsp;&nbsp;(32)</option>
	<option class="level-0" value="5">Scripts&nbsp;&nbsp;(11)</option>
	<option class="level-0" value="1703">Security&nbsp;&nbsp;(104)</option>
	<option class="level-0" value="606">SEO&nbsp;&nbsp;(2)</option>
	<option class="level-0" value="21">Tips and Tricks&nbsp;&nbsp;(72)</option>
	<option class="level-0" value="13">Tutorials&nbsp;&nbsp;(764)</option>
	<option class="level-0" value="1698">Ubuntu&nbsp;&nbsp;(367)</option>
	<option class="level-0" value="1712">Web Frameworks&nbsp;&nbsp;(111)</option>
	<option class="level-0" value="1707">Web Servers&nbsp;&nbsp;(136)</option>
</select>
</form>


			</aside><aside class="widget inner-padding rhad-widget"><div  class="rhad-e709d487b343c27ad5667c85ce721c36 rhad-sidebar-ad-group" id="rhad-e709d487b343c27ad5667c85ce721c36"></div></aside><aside id="custom_html-8" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a target="_blank" href="https://www.rosehosting.com/about-us.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">About RoseHosting</a><br>
<a target="_blank" href="https://www.rosehosting.com/linux-vps-hosting/" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Buy a Managed VPS - 25% OFF</a><br>
<a target="_blank" href="https://www.rosehosting.com/reviews.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">RoseHosting Customer Reviews</a><br>
<a target="_blank" href="https://www.rosehosting.com/nvme-hosting.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Managed NVMe VPSes</a><br>
	<a target="_blank" href="https://www.rosehosting.com/dedicated-servers.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Managed NVMe Dedicated Servers</a>
</div></aside><aside id="zoom-social-icons-widget-2" class="widget inner-padding zoom-social-icons-widget">
        
        <ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--align-center zoom-social-icons-list--no-labels">

            
                                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://www.facebook.com/RoseHosting" target="_blank" >
                                                                        
                                                    <span class="screen-reader-text">facebook</span>
                        
                        <span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #3b5998; font-size: 30px; padding:10px" ></span>

                                            </a>
                </li>

            
                                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://twitter.com/rosehosting" target="_blank" >
                                                                        
                                                    <span class="screen-reader-text">twitter</span>
                        
                        <span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#1da1f2" style="background-color : #1da1f2; font-size: 30px; padding:10px" ></span>

                                            </a>
                </li>

            
                                <li class="zoom-social_icons-list__item">
                    <a class="zoom-social_icons-list__link"
                       href="https://www.linkedin.com/company/rose-web-services-l-l-c-" target="_blank" >
                                                                        
                                                    <span class="screen-reader-text">linkedin</span>
                        
                        <span class="zoom-social_icons-list-span social-icon socicon socicon-linkedin" data-hover-rule="background-color" data-hover-color="#0077B5" style="background-color : #0077B5; font-size: 30px; padding:10px" ></span>

                                            </a>
                </li>

            
        </ul>

        </aside><aside id="search-3" class="widget inner-padding widget_search"><form method="get" class="search-form" action="https://www.rosehosting.com/blog/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:">
	</label>
	<input type="submit" class="search-submit" value="Search"></form>
</aside><aside id="recent-posts-widget-with-thumbnails-2" class="widget inner-padding recent-posts-widget-with-thumbnails">
<div id="rpwwt-recent-posts-widget-with-thumbnails-2" class="rpwwt-widget">
	<ul>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-python-3-9-on-debian-10/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to install python 3.9 on debian 10" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/how-to-install-python-3.9-on-debian-10-150x75.jpg?v=1621436278 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/how-to-install-python-3.9-on-debian-10-300x150.jpg?v=1621436278 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/how-to-install-python-3.9-on-debian-10.jpg?v=1621436278 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/how-to-install-python-3.9-on-debian-10-150x75.jpg?v=1621436278" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/how-to-install-python-3.9-on-debian-10-150x75.jpg?v=1621436278" class="attachment-75x75 size-75x75" alt="how to install python 3.9 on debian 10" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/how-to-install-python-3.9-on-debian-10-150x75.jpg?v=1621436278 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/how-to-install-python-3.9-on-debian-10-300x150.jpg?v=1621436278 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/how-to-install-python-3.9-on-debian-10.jpg?v=1621436278 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Install Python 3.9 on Debian 10</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/setting-up-environment-with-rosehosting-cloud-paas/" aria-current="page"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="Setting Up Environment with RoseHosting Cloud PaaS" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS-150x75.jpg?v=1622206011 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS-300x150.jpg?v=1622206011 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS.jpg?v=1622206011 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS-150x75.jpg?v=1622206011" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS-150x75.jpg?v=1622206011" class="attachment-75x75 size-75x75" alt="Setting Up Environment with RoseHosting Cloud PaaS" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS-150x75.jpg?v=1622206011 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS-300x150.jpg?v=1622206011 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/Setting-Up-Environment-with-RoseHosting-Cloud-PaaS.jpg?v=1622206011 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">Setting Up Environment with RoseHosting Cloud PaaS</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-django-on-centos-7/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to install django on centos 7" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2018/08/how-to-install-django-on-centos-7-150x75.jpg?v=1622098021 150w, https://www.rosehosting.com/blog/wp-content/uploads/2018/08/how-to-install-django-on-centos-7-300x150.jpg?v=1622098021 300w, https://www.rosehosting.com/blog/wp-content/uploads/2018/08/how-to-install-django-on-centos-7.jpg?v=1622098021 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2018/08/how-to-install-django-on-centos-7-150x75.jpg?v=1622098021" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2018/08/how-to-install-django-on-centos-7-150x75.jpg?v=1622098021" class="attachment-75x75 size-75x75" alt="how to install django on centos 7" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2018/08/how-to-install-django-on-centos-7-150x75.jpg?v=1622098021 150w, https://www.rosehosting.com/blog/wp-content/uploads/2018/08/how-to-install-django-on-centos-7-300x150.jpg?v=1622098021 300w, https://www.rosehosting.com/blog/wp-content/uploads/2018/08/how-to-install-django-on-centos-7.jpg?v=1622098021 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Install Django on CentOS 7</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/jenkins-cluster-hosting-for-continuous-integration-delivery-ci-cd/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="jenkins cluster hosting for continuous integration and delivery (ci cd)" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/jenkins-cluster-hosting-for-continuous-integration-and-delivery-ci-cd-150x75.jpg?v=1622198227 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/jenkins-cluster-hosting-for-continuous-integration-and-delivery-ci-cd-300x150.jpg?v=1622198227 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/jenkins-cluster-hosting-for-continuous-integration-and-delivery-ci-cd.jpg?v=1622198227 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/jenkins-cluster-hosting-for-continuous-integration-and-delivery-ci-cd-150x75.jpg?v=1622198227" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/jenkins-cluster-hosting-for-continuous-integration-and-delivery-ci-cd-150x75.jpg?v=1622198227" class="attachment-75x75 size-75x75" alt="jenkins cluster hosting for continuous integration and delivery (ci cd)" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/jenkins-cluster-hosting-for-continuous-integration-and-delivery-ci-cd-150x75.jpg?v=1622198227 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/jenkins-cluster-hosting-for-continuous-integration-and-delivery-ci-cd-300x150.jpg?v=1622198227 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/jenkins-cluster-hosting-for-continuous-integration-and-delivery-ci-cd.jpg?v=1622198227 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">Jenkins Cluster Hosting for Continuous Integration and Delivery (CI/CD)</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-jupyter-notebook-on-ubuntu-20-04/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to install jupyter notebook on ubuntu 20.04" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/how-to-install-jupyter-notebook-on-ubuntu-20.04-150x75.jpg?v=1621503411 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/how-to-install-jupyter-notebook-on-ubuntu-20.04-300x150.jpg?v=1621503411 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/how-to-install-jupyter-notebook-on-ubuntu-20.04.jpg?v=1621503411 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/how-to-install-jupyter-notebook-on-ubuntu-20.04-150x75.jpg?v=1621503411" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/how-to-install-jupyter-notebook-on-ubuntu-20.04-150x75.jpg?v=1621503411" class="attachment-75x75 size-75x75" alt="how to install jupyter notebook on ubuntu 20.04" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/05/how-to-install-jupyter-notebook-on-ubuntu-20.04-150x75.jpg?v=1621503411 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/how-to-install-jupyter-notebook-on-ubuntu-20.04-300x150.jpg?v=1621503411 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/05/how-to-install-jupyter-notebook-on-ubuntu-20.04.jpg?v=1621503411 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Install Jupyter Notebook on Ubuntu 20.04</span></a></li>
	</ul>
</div><!-- .rpwwt-widget -->
</aside>      <aside id="mailpoet_form-2" class="widget inner-padding widget_mailpoet_form">
  
  
  <div class="
    mailpoet_form_popup_overlay
      "></div>
  <div
    id="mailpoet_form_2"
    class="
      mailpoet_form
      mailpoet_form_widget
      mailpoet_form_position_
      mailpoet_form_animation_
    "
      >
    
    <style type="text/css">
     .mailpoet_hp_email_label{display:none!important;}#mailpoet_form_2 .mailpoet_form {  }
#mailpoet_form_2 form { margin-bottom: 0; }
#mailpoet_form_2 p.mailpoet_form_paragraph { margin-bottom: 10px; }
#mailpoet_form_2 .mailpoet_column_with_background { padding: 10px; }
#mailpoet_form_2 .mailpoet_form_column:not(:first-child) { margin-left: 20px; }
#mailpoet_form_2 .mailpoet_paragraph { line-height: 20px; margin-bottom: 20px; }
#mailpoet_form_2 .mailpoet_segment_label, #mailpoet_form_2 .mailpoet_text_label, #mailpoet_form_2 .mailpoet_textarea_label, #mailpoet_form_2 .mailpoet_select_label, #mailpoet_form_2 .mailpoet_radio_label, #mailpoet_form_2 .mailpoet_checkbox_label, #mailpoet_form_2 .mailpoet_list_label, #mailpoet_form_2 .mailpoet_date_label { display: block; font-weight: normal; }
#mailpoet_form_2 .mailpoet_text, #mailpoet_form_2 .mailpoet_textarea, #mailpoet_form_2 .mailpoet_select, #mailpoet_form_2 .mailpoet_date_month, #mailpoet_form_2 .mailpoet_date_day, #mailpoet_form_2 .mailpoet_date_year, #mailpoet_form_2 .mailpoet_date { display: block; }
#mailpoet_form_2 .mailpoet_text, #mailpoet_form_2 .mailpoet_textarea { width: 200px; }
#mailpoet_form_2 .mailpoet_checkbox {  }
#mailpoet_form_2 .mailpoet_submit {  }
#mailpoet_form_2 .mailpoet_divider {  }
#mailpoet_form_2 .mailpoet_message {  }
#mailpoet_form_2 .mailpoet_form_loading { width: 30px; text-align: center; line-height: normal; }
#mailpoet_form_2 .mailpoet_form_loading > span { width: 5px; height: 5px; background-color: #5b5b5b; }#mailpoet_form_2{border-radius: 0px;background: #ffffff;text-align: left;}#mailpoet_form_2 form.mailpoet_form {padding: 10px;}#mailpoet_form_2{width: 100%;}#mailpoet_form_2 .mailpoet_message {margin: 0; padding: 0 20px;}
        #mailpoet_form_2 .mailpoet_validate_success {color: #00d084}
        #mailpoet_form_2 input.parsley-success {color: #00d084}
        #mailpoet_form_2 select.parsley-success {color: #00d084}
        #mailpoet_form_2 textarea.parsley-success {color: #00d084}
      
        #mailpoet_form_2 .mailpoet_validate_error {color: #cf2e2e}
        #mailpoet_form_2 input.parsley-error {color: #cf2e2e}
        #mailpoet_form_2 select.parsley-error {color: #cf2e2e}
        #mailpoet_form_2 textarea.textarea.parsley-error {color: #cf2e2e}
        #mailpoet_form_2 .parsley-errors-list {color: #cf2e2e}
        #mailpoet_form_2 .parsley-required {color: #cf2e2e}
        #mailpoet_form_2 .parsley-custom-error-message {color: #cf2e2e}
      #mailpoet_form_2 .mailpoet_paragraph.last {margin-bottom: 0} @media (max-width: 500px) {#mailpoet_form_2 {background: #ffffff;}} @media (min-width: 500px) {#mailpoet_form_2 .last .mailpoet_paragraph:last-child {margin-bottom: 0}}  @media (max-width: 500px) {#mailpoet_form_2 .mailpoet_form_column:last-child .mailpoet_paragraph:last-child {margin-bottom: 0}} 
    </style>

    <form
      target="_self"
      method="post"
      action="https://www.rosehosting.com/blog/wp-admin/admin-post.php?action=mailpoet_subscription_form"
      class="mailpoet_form mailpoet_form_form mailpoet_form_widget"
      novalidate
      data-delay=""
      data-exit-intent-enabled=""
      data-font-family=""
    >
      <input type="hidden" name="data[form_id]" value="2" />
      <input type="hidden" name="token" value="24a649d367" />
      <input type="hidden" name="api_version" value="v1" />
      <input type="hidden" name="endpoint" value="subscribers" />
      <input type="hidden" name="mailpoet_method" value="subscribe" />

      <label class="mailpoet_hp_email_label">Please leave this field empty<input type="email" name="data[email]"/></label><h2 class="mailpoet-heading  mailpoet-has-font-size" id="" style="text-align: center; color: #0081ff; font-size: 20px; line-height: 1.5"><span style="font-family: Montserrat" data-font="Montserrat" class="mailpoet-has-font"><strong><span class="has-inline-color has-black-color">Join our Blog</span></strong></span></h2>
<p class="mailpoet_form_paragraph  mailpoet-has-font-size" style="text-align: center; color: #000000; font-size: 14px; line-height: 1.5"><strong><span style="font-family: Montserrat" data-font="Montserrat" class="mailpoet-has-font">Sign up and receive notifications as soon as new content is posted.</span></strong></p>
<div class="mailpoet_paragraph "><input type="email" class="mailpoet_text" name="data[form_field_ZTVlY2IyMzIyMzFkX2VtYWls]" title="Enter your e-mail" value="" style="width:100%;padding:12px;margin: 0 auto 0 0;font-size:15px;line-height:1.5;height:auto;" data-automation-id="form_email"  placeholder="Enter your e-mail *" data-parsley-required="true" data-parsley-minlength="6" data-parsley-maxlength="150" data-parsley-error-message="Please specify a valid email address." data-parsley-required-message="This field is required."/></div>
<div class="mailpoet_paragraph "><input type="submit" class="mailpoet_submit" value="Subscribe" data-automation-id="subscribe-submit-button" style="width:100%;padding:12px;margin: 0 auto 0 0;font-size:15px;line-height:1.5;height:auto;border-color:transparent;" /><span class="mailpoet_form_loading"><span class="mailpoet_bounce1"></span><span class="mailpoet_bounce2"></span><span class="mailpoet_bounce3"></span></span></div>

      <div class="mailpoet_message">
        <p class="mailpoet_validate_success"
                style="display:none;"
                >Check your inbox or spam folder to confirm your subscription.
        </p>
        <p class="mailpoet_validate_error"
                style="display:none;"
                >        </p>
      </div>
    </form>
  </div>

      </aside>
  	</div>
</div>
</div>

  <!-- footer-big-menu.html -->
  <footer class="footer-big-menu">
    <div class="container" style="max-width: 1100px;">

      <div class="row menu">

        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title mb-2">Company</h3>
            <a class="menu-link" href="https://www.rosehosting.com/about-us.html">About us</a>
            <a class="menu-link" href="https://www.rosehosting.com/policies.html">Our Policies</a>
            <a class="menu-link" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
            <a class="menu-link" href="https://www.rosehosting.com/blog/">Blog</a>
            <a class="menu-link" href="https://www.rosehosting.com/why-rosehosting.html">Why RoseHosting</a>
            <a class="menu-link" href="https://www.rosehosting.com/compare-to-competition.html">Compare Us</a>
            <a class="menu-link" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
            <a class="menu-link" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
            <a class="menu-link" href="/recommended-tools-and-services.html">Recommended Services</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Support</h3>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Helpdesk System</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>

          <h3 class="menu-title  mb-2 mt-4">Other Services</h3>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Domain Registration</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Domain Transfer</a>
          <a class="menu-link" href="https://www.rosehosting.com/ssl-certificates.html">SSL Certificates</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/linux-vps-hosting/">Linux VPS Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/managed-cloud-hosting.html">Cloud Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom SSD VPS</a>
          <a class="menu-link" href="https://www.rosehosting.com/dedicated-servers.html">Dedicated Servers</a>
          <a class="menu-link" href="https://www.rosehosting.com/hosting-solutions.html">Hosting Solutions</a>
          <a class="menu-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Recurr. Affiliate Program</a>
          <a class="menu-link" href="https://www.rosehosting.com/cpa-hosting-affiliate-program.html">CPA Affiliate Program</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Linux VPS Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/centos-hosting.html">CentOS Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/ubuntu-hosting.html">Ubuntu Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/debian-hosting.html">Debian Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/opensuse-hosting.html">OpenSUSE Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/arch-linux-hosting.html">Arch-Linux Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/scientific-linux-hosting.html">Scientific Linux Hosting</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Apps Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/wordpress-hosting.html">WordPress Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/magento-hosting.html">Magento Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/odoo-hosting.html">Odoo Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/joomla-hosting.html">Joomla Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/drupal-hosting.html">Drupal Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/laravel-hosting.html">Laravel Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/nextcloud-hosting.html">NextCloud Hosting</a>

          <a class="menu-link" href="https://www.rosehosting.com/prestashop-hosting.html">PrestaShop Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/ghost-hosting.html">Ghost Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/mediawiki-hosting.html">MediaWiki Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/tomcat-hosting.html">Tomcat Hosting</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title mb-2">Contact Us</h3>
          <a class="menu-link" href="tel:+18887673467">(888) ROSE-HOST</a>
          <a class="menu-link" href="tel:+18887673467">(888) 767-3467</a>
          <a class="menu-link" href="tel:+13142750414">(314) 275-0414</a>
          <a class="menu-link" href="mailto:%73%75%70%70%6f%72%74%40%72%6f%73%65%68%6f%73%74%69%6e%67%2e%63%6f%6d">Email us</a>

          <h3 class="menu-title mb-2 mt-4">Connect</h3>
          <a class="menu-link" href="https://twitter.com/rosehosting" target="_blank"><i class="fa fa-twitter fa-fw"></i> Twitter</a>
          <a class="menu-link" href="https://www.facebook.com/RoseHosting" target="_blank"><i class="fa fa-facebook fa-fw"></i> Facebook</a>
          <a class="menu-link" href="https://www.linkedin.com/in/rosehosting/" target="_blank"><i class="fa fa-linkedin fa-fw"></i> LinkedIn</a>
          <a class="menu-link" href="https://www.rosehosting.com/blog/feed/" target="_blank"><i class="fa fa-rss fa-fw"></i> RSS Feed</a>

        </div>

      </div>

    </div>

<br>
    <div class="bottom">
      <div class="container" style="max-width: 1100px;">
        <div class="row">

          <div class="col-md-12 col-lg-6">
              <p class="text-sm-left"><a class="inline-link footer-policy" href="/tos.html">Terms of Service</a> and <a class="inline-link footer-policy" href="/policies.html">other policies</a></p>
          </div>
          <div class="col-md-12 col-lg-6">
            <p class="text-sm-right">&copy; 2001-2021 <a class="inline-link footer-policy" href="https://www.rosewebservices.com/">Rose Web Services LLC</a>.</p>
          </div>
         </div>
      </div>
    </div>

<!-- livezilla.net code
<script type="text/javascript" id="aff1f81b02f303eea5f87a3a065f153a" src="https://linuxhostsupport.com/chat//script.php?id=aff1f81b02f303eea5f87a3a065f153a"></script>
http://www.livezilla.net -->

<div class="rhad-20th-anniversary-sale-popup rhad-layer rhad-layer-exit advads-has-background advads-background-click-close advads-close is-sticky" id="rhad-341132776" data-width="600" data-height="600" data-position="center" style="display: none; z-index: 9999; position: fixed; margin-left: -300px; margin-bottom: -300px; bottom: 50%; left: 50%; "><span class="advads-close-button" title="close" style="width: 15px; height: 15px; background: #fff; position: relative; line-height: 15px; text-align: center; cursor: pointer; z-index: 10000; right:0;float: right; margin-left: -15px;">×</span><!--noptimize--><a href="https://www.rosehosting.com/20th-anniversary-sale.html" target="_blank"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20600%20600'%3E%3C/svg%3E" alt=""  width="600" height="600"   data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/06/20th-Anniversay-Pop-Up-Banner-361.jpg" /><noscript><img src="https://www.rosehosting.com/blog/wp-content/uploads/2021/06/20th-Anniversay-Pop-Up-Banner-361.jpg" alt=""  width="600" height="600"   /></noscript></a><!--/noptimize--></div><script>( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {advads_items.close_functions[ 'rhad-341132776' ] = function() {advads.close( '#rhad-341132776' ); if ( can_remove_background ( 'rhad-341132776' ) ) { jQuery( ".advads-background" ).remove(); }; };jQuery( '#rhad-341132776' ).on( 'click', '.advads-close-button', function() { var close_function = advads_items.close_functions[ 'rhad-341132776' ];if ( typeof close_function === 'function' ) {close_function(); }});});</script>

<script id='advanced-ads-layer-footer-js-js-extra'>
var advanced_ads_layer_settings = {"layer_class":"rhad-layer","placements":["20th-anniversary-sale-popup"]};
</script>


<!--[if lte IE 11]>
<script src='https://www.rosehosting.com/blog/wp-content/themes/generatepress/assets/js/classList.min.js' id='generate-classlist-js'></script>
<![endif]-->
<script id='generate-main-js-extra'>
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>







<script id='ez-toc-js-js-extra'>
var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"","width":"95%","scroll_offset":"30"};
</script>

<script id='mailpoet_public-js-extra'>
var MailPoetForm = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","is_rtl":""};
</script>


<script id='cptch_front_end_script-js-extra'>
var cptch_vars = {"nonce":"a217172452","ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","enlarge":"","time_limit":"120"};
</script>

<!--noptimize--><script>window.advads_passive_placements = {"sidebar-ad-group_2":{"type":"group","id":1744,"elementid":["rhad-e709d487b343c27ad5667c85ce721c36"],"ads":{"34829":{"id":34829,"title":"Managed VPS Hosting 300x250","expiry_date":0,"visitors":[],"content":"<!--noptimize--><a href=\"https:\/\/www.rosehosting.com\/linux-vps-hosting\/\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2020\/11\/Managed-VPS-Hosting.jpg\" alt=\"Managed VPS Hosting\"  width=\"300\" height=\"250\"   \/><\/a><!--\/noptimize-->","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}},"34996":{"id":34996,"title":"Dedicated Server Hosting","expiry_date":0,"visitors":[],"content":"<!--noptimize--><a href=\"https:\/\/www.rosehosting.com\/dedicated-servers.html\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2020\/12\/Dedicated-Server-Hosting.jpg\" alt=\"Dedicated Server Hosting\"  width=\"300\" height=\"250\"   \/><\/a><!--\/noptimize-->","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}},"26322":{"id":26322,"title":"after-first-image-300x250-rh-orange","expiry_date":0,"visitors":[],"content":"<div style=\"margin-left: auto; margin-right: auto; text-align: center; \" id=\"rhad-1282154049\"><!--noptimize--><center><a target=\"_blank\" href=\"https:\/\/www.rosehosting.com\/cloud-vps-hosting.html\"><img src=\"https:\/\/media.rosehosting.com\/images\/blogads\/orange.jpg\" alt=\"Cloud VPS Hosting\"><\/a><\/center>\r\n<!--\/noptimize--><\/div>","once_per_page":0,"debugmode":false,"blog_id":1,"type":"plain","position":"center","privacy":{"ignore":false,"needs_consent":false}},"37433":{"id":37433,"title":"20th Anniversary Sale","expiry_date":0,"visitors":[],"content":"<!--noptimize--><a href=\"https:\/\/www.rosehosting.com\/20th-anniversary-sale.html\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2021\/06\/20th-Anniversay-Banner-214.jpg\" alt=\"\"  width=\"300\" height=\"250\"   \/><\/a><!--\/noptimize-->","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}},"34897":{"id":34897,"title":"Linux Server Management Services LHS 300x250","expiry_date":0,"visitors":[],"content":"<!--noptimize--><a href=\"https:\/\/linuxhostsupport.com\/\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2020\/11\/Linux-Server-Management-Service.jpg\" alt=\"Linux Server Management Service\"  width=\"300\" height=\"250\"   \/><\/a><!--\/noptimize-->","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}},"34828":{"id":34828,"title":"Managed NVME Hosting 300x250","expiry_date":0,"visitors":[],"content":"<!--noptimize--><a href=\"https:\/\/www.rosehosting.com\/nvme-hosting.html\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2020\/11\/Managed-NVMe-VPS-Hosting.jpg\" alt=\"Managed NVMe VPS Hosting\"  width=\"300\" height=\"250\"   \/><\/a><!--\/noptimize-->","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}}},"group_info":{"id":1744,"name":"RH and LHS","weights":{"37433":10,"34996":10,"34994":10,"34993":10,"34897":10,"34870":10,"34868":10,"34829":10,"34828":10,"34827":10,"34821":10,"34786":10,"26322":10},"type":"default","ordered_ad_ids":[34994,34829,34786,34996,26322,34993,34868,34870,34821,34827,37433,34897,34828],"ad_count":1,"refresh_enabled":true,"refresh_interval_for_ads":{"37433":15000,"34828":15000,"26322":15000,"34897":15000,"34786":15000,"34994":15000,"34993":15000,"34870":15000,"34829":15000,"34868":15000,"34821":15000,"34996":15000,"34827":15000}},"placement_info":{"type":"sidebar_widget","name":"sidebar ad group","item":"group_1744","id":"sidebar-ad-group"},"test_id":null,"group_wrap":[{"before":"<div class=\"rhad-sidebar-ad-group\" id=\"rhad-1565490884\">","after":"<\/div>"}],"inject_before":[""]}};
window.advads_ajax_queries = [{"id":"before-content","method":"placement","params":{"placement_position":"center","previous_method":"placement","previous_id":"before-content","post":"r0","url_parameter":"\/blog\/setting-up-environment-with-rosehosting-cloud-paas\/","placement_type":"post_top","output":{"class":["rhad-before-content"],"placement_id":"before-content"}},"elementid":"rhad-3d81d910b66e7202f1749e7a7ee80560","blog_id":1}];
window.advads_has_ads = [["37438","ad",null]];
window.advads_ajax_queries_args = {"r0":{"id":37255,"author":"4","post_type":"post"}};
( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( !window.advanced_ads_pro ) {console.log("Advanced Ads Pro: cache-busting can not be initialized");} });</script><!--/noptimize--><script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.rosehosting.com/blog/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>
<script src="https://www.rosehosting.com/blog/wp-content/cache/min/1/092932085782a55ee84ce201ba997c13.js" data-minify="1" defer></script></body>
</html>

<!-- Cached for great performance - Debug: cached@1624004352 -->