<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />
			
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<link rel="pingback" href="https://www.rosehosting.com/blog/xmlrpc.php" />


		<!--[if lt IE 9]>
	<script src="https://www.rosehosting.com/blog/wp-content/themes/Extra/scripts/ext/html5.js?x60951" defer " type="text/javascript"></script>
	<![endif]-->

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KVJ4PJ');</script>
<!-- End Google Tag Manager -->

	<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>

	<script>var et_site_url='https://www.rosehosting.com/blog';var et_post_id='29171';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>How To Install ERPNext on CentOS 7 | RoseHosting</title>

<!-- All in One SEO Pack 2.11 by Michael Torbert of Semper Fi Web Design[-1,-1] -->
<link rel="author" href="https://plus.google.com/+RoseHosting" />
<meta name="description"  content="ERPNext is a completely robust ERP framework intended for small and medium-sized businesses. It covers an extensive variety of features, including accounting," />

<link rel="canonical" href="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/" />
<meta property="og:title" content="How To Install ERPNext on CentOS 7" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/" />
<meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2019/01/install-erpnext-centos.jpg" />
<meta property="og:site_name" content="RoseHosting.com Blog" />
<meta property="og:description" content="ERPNext is a completely robust ERP framework intended for small and medium-sized businesses. It covers an extensive variety of features, including accounting, CRM, inventory, selling, purchasing, manufacturing, projects, HR and payroll, website, e-commerce, and more - all of which make it profoundly adaptable and extendable. ERPNext is developed in Python and depends on the Frappe Framework. It utilizes Node.js for the front end, Nginx for the web server, Redis for caching, and MariaDB for the database. ERPNext is Open Source under the GNU General Public License v3. In this article, we will show you how to install ERPNext on CentOS 7 on one of our optimized ERPNext hosting servers. Prerequisites: Make sure your server met the following requirements. 2GB of RAM or higher 2 or more CPU cores Fresh CentOS 7 Installation Full root access Update the System and Install the Dependencies Log in to your server via SSH: ssh username@server_ip Before starting with the ERPNext installation, it" />
<meta property="article:tag" content="centos" />
<meta property="article:tag" content="cms, crm, erp" />
<meta property="article:tag" content="tutorials" />
<meta property="article:tag" content="bench" />
<meta property="article:tag" content="centos7" />
<meta property="article:tag" content="erp" />
<meta property="article:tag" content="erpnext" />
<meta property="article:tag" content="frappe" />
<meta property="article:publisher" content="https://www.facebook.com/RoseHosting/" />
<meta property="article:author" content="https://www.facebook.com/RoseHosting/" />
<meta property="article:published_time" content="2019-01-25T15:16:08Z" />
<meta property="article:modified_time" content="2019-01-25T15:16:08Z" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@RoseHosting" />
<meta name="twitter:creator" content="@rosehosting" />
<meta name="twitter:title" content="How To Install ERPNext on CentOS 7" />
<meta name="twitter:description" content="ERPNext is a completely robust ERP framework intended for small and medium-sized businesses. It covers an extensive variety of features, including accounting, CRM, inventory, selling, purchasing, manufacturing, projects, HR and payroll, website, e-commerce, and more - all of which make it profoundly adaptable and extendable. ERPNext is developed in Python and depends on the Frappe Framework. It utilizes Node.js for the front end, Nginx for the web server, Redis for caching, and MariaDB for the database. ERPNext is Open Source under the GNU General Public License v3. In this article, we will show you how to install ERPNext on CentOS 7 on one of our optimized ERPNext hosting servers. Prerequisites: Make sure your server met the following requirements. 2GB of RAM or higher 2 or more CPU cores Fresh CentOS 7 Installation Full root access Update the System and Install the Dependencies Log in to your server via SSH: ssh username@server_ip Before starting with the ERPNext installation, it" />
<meta name="twitter:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2019/01/install-erpnext-centos.jpg" />
<!-- /all in one seo pack -->
<link rel="amphtml" href="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/amp/" /><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Feed" href="https://www.rosehosting.com/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Comments Feed" href="https://www.rosehosting.com/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; How To Install ERPNext on CentOS 7 Comments Feed" href="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.rosehosting.com\/blog\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ --><script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><meta content="rh2018 v.1.0.0" name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='parent-style-css'  href='https://www.rosehosting.com/blog/wp-content/themes/Extra/style.css?x60951&amp;ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://www.rosehosting.com/blog/wp-content/themes/rh2018/css/bootstrap.css?x60951&amp;ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='theme-style-css'  href='https://www.rosehosting.com/blog/wp-content/themes/rh2018/css/theme.css?x60951&amp;ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css'  href='https://www.rosehosting.com/blog/wp-content/themes/rh2018/style.css?x60951&amp;ver=2.19.4' type='text/css' media='all' />
<link rel='stylesheet' id='et-builder-googlefonts-cached-css'  href='https://fonts.googleapis.com/css?family=Cabin%3Aregular%2Citalic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic&#038;ver=4.9.8#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.rosehosting.com/blog/wp-includes/css/dashicons.min.css?x60951&amp;ver=4.9.8' type='text/css' media='all' />
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery.js?x60951&amp;ver=1.12.4'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery-migrate.min.js?x60951&amp;ver=1.4.1' defer '></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/popper.js/1.11.0/umd/popper.min.js?ver=1.11' defer '></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2018/js/bootstrap.js?x60951&amp;ver=4' defer '></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2018/js/cookieconsent.min.js?x60951&amp;ver=1' defer '></script>
<link rel='https://api.w.org/' href='https://www.rosehosting.com/blog/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rosehosting.com/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rosehosting.com/blog/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='How to Install Joomla on Ubuntu 18.04' href='https://www.rosehosting.com/blog/how-to-install-joomla-on-ubuntu-18-04/' />
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://www.rosehosting.com/blog/?p=29171' />
<link rel="alternate" type="application/json+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-install-erpnext-on-centos-7%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-install-erpnext-on-centos-7%2F&#038;format=xml" />
			<meta property="fb:pages" content="195648843783690" />
			<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" />
<script type="text/javascript">var essb_settings = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","essb3_nonce":"6392eaf494","essb3_plugin_url":"https:\/\/www.rosehosting.com\/blog\/wp-content\/plugins\/easy-social-share-buttons3","essb3_stats":false,"essb3_ga":false,"essb3_ga_mode":"simple","blog_url":"https:\/\/www.rosehosting.com\/blog\/","essb3_postfloat_stay":false,"post_id":29171};var essb_buttons_exist = !!document.getElementsByClassName("essb_links"); if(essb_buttons_exist == true) { document.addEventListener("DOMContentLoaded", function(event) { var ESSB_CACHE_URL = "https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/"; if(ESSB_CACHE_URL.indexOf("?") > -1) { ESSB_CACHE_URL += "&essb_counter_cache=rebuild"; } else { ESSB_CACHE_URL += "?essb_counter_cache=rebuild"; }; var xhr = new XMLHttpRequest(); xhr.open("GET",ESSB_CACHE_URL,true); xhr.send(); });}</script><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-270x270.png" />
<link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://www.rosehosting.com/blog/wp-content/cache/et/global/et-extra-customizer-global-1548575286604.min.css?x60951" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /></head>
<body class="post-template-default single single-post postid-29171 single-format-standard et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
	<div id="page-container" class="page-container">
		


<nav class="navbar yamm navbar-expand-lg navbar-dark" role="navigation">
  <div class="container no-override">

    <a class="navbar-brand" href="https://www.rosehosting.com/">
      <img alt="RoseHosting.com" width="186" height="37"  class="d-lg-inline mr-2" src="https://www.rosehosting.com/blog/wp-content/themes/rh2018/img/rh-logo.svg" />
    </a>

    <button class="navbar-toggler" data-toggle="collapse" data-target="#navbar-collapse">
      <span class="navbar-toggler-icon"></span>
    </button>

    <div class="collapse navbar-collapse justify-content-end" id="navbar-collapse">
      <ul class="navbar-nav">

        <li class="nav-item active dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Hosting Solutions
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">

            <div class="yamm-content">
              <div class="row">
                <div class="col-sm-6">
                   <span class="text-primary  dropdown-header"><strong>Managed SSD Hosting</strong></span>
                   <div class="dropdown-divider"></div>
                   <a class="dropdown-item" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/vps-hosting.html">VPS Hosting</a>
                   <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom VPS</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/dedicated-servers.html">Cloud Dedicated Servers</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting <span class="ml-2 badge badge-success">new</span></a>
                </div>
                <div class="col-sm-6">
                  <span class="text-primary dropdown-header"><strong>Managed Solutions</strong></span>
                  <div class="dropdown-divider"></div>
                  <a class="dropdown-item" href="https://www.rosehosting.com/wordpress-hosting.html">
                    Wordpress Hosting
                    <small class="d-block text-muted"><i>The best blogging platform</i></small>
                  </a>
                  <a class="dropdown-item" href="https://www.rosehosting.com/magento-hosting.html">
                    Magento Hosting
                    <small class="d-block text-muted"><i>The best e-commerce platform</i></small>
                  </a>
                  <a class="dropdown-item" href="https://www.rosehosting.com/odoo-hosting.html">
                    Odoo Hosting
                    <small class="d-block text-muted"><i>The best CRM/ERP platform</i></small>
                  </a>
                  <span class="dropdown-item"><a class="btn-shadow btn-shadow-primary btn-shadow-sm" target="_blank" href="https://www.rosehosting.com/hosting-solutions.html">Other Solutions</a></span>

                </div>
              </div>
            </div>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            SSL / Domains
            <i class="fa fa-chevron-down"></i>
          </a>

          <div class="dropdown-menu" role="menu">

            <div class="yamm-content">
              <div class="row">
                <div class="col-sm-3">
                    <span class="text-primary  dropdown-header"><strong>SSL by brand</strong></span>
                    <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#geotrust">GeoTrust</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#comodo">Comodo</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#rapidssl">RapidSSL</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#thawte">Thawte</a>
                </div>
                <div class="col-sm-4">

                    <span class="text-primary  dropdown-header"><strong>SSL by Type</strong></span>
                    <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#domain_validation">Domain Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#organization_validation">Organization Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#extended_validation">Extended Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#wildcard_ssl">Wildcard SSL</a>
                </div>
                <div class="col-sm-3">
                  <span class="text-primary dropdown-header"><strong>Domains</strong></span>
                  <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Register Domains</a>
                    <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Transfer Domains</a>
                </div>
              </div>
            </div>
          </div>


        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Support
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
              <a class="dropdown-item" href="https://www.rosehosting.com/support.html">24/7 Managed Support</a>
              <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Open a Support Ticket</a>
              <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>
              <a class="dropdown-item" href="https://status.rosehosting.com">Systems Status</a>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            About Us
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
            <a class="dropdown-item" href="https://www.rosehosting.com/about-us.html">Our Company</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/policies.html">Our Policies</a>
          </div>
        </li>

        <li class="nav-item">
          <a class="nav-link" href="https://www.rosehosting.com/blog/">Blog</a>
        </li>
        <li class="nav-item">
          <a class="nav-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Affiliates</a>
        </li>
        <li class="nav-item">
          <a class="nav-link nav-link--rounded" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Login</a>
        </li>

      </ul>
    </div>

  </div>
</nav>



<nav class="navbar navbar-expand-md navbar-light bg-faded navbar-blog">
   <div class="container no-override">
    <a href="https://www.rosehosting.com/blog/" class="navbar-brand">Blog Home</a>
    <div class="navbar-collapse collapse d-flex justify-content-between" id="navbar5-blog">
        <ul class="navbar-nav categories">
            <li class="nav-item dropdown">
              <a class="nav-link dropdown-toggle" data-toggle="dropdown" href="#" role="button" aria-haspopup="true" aria-expanded="false">
                Categories
                <i class="fa fa-chevron-down"></i>
              </a>
              <div class="dropdown-menu">
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/caching/">Caching</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/centos/">CentOS</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/cms-crm-erp/">CMS, CRM, ERP</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/control-panels/">Control Panels</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/databases/">Databases</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/debian/">Debian</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/e-commerce/">E-Commerce</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/email-servers/">Email Servers</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/guides/">Guides</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/miscellaneous/">Miscellaneous</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/networking-and-domains/">Networking and Domains</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/news/">News</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/optimization/">Optimization</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/rosehosting/">RoseHosting Platform</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/scripts/">Scripts</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/security/">Security</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/seo/">SEO</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tips-and-tricks/">Tips and Tricks</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tutorials/">Tutorials</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/ubuntu/">Ubuntu</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-frameworks/">Web Frameworks</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-servers/">Web Servers</a>
                              </div>
            </li>
        </ul>
        <form class="mx-2 my-auto d-inline" method="get" id="searchform" action="https://www.rosehosting.com/blog/">
            <div class="input-group">
                <input type="search" class="field" name="s" id="s" class="form-control border border-right-0" placeholder="Search...">
                <span class="input-group-append">
                <button name="submit" id="searchsubmit" class="btn btn-outline-secondary border border-left-0" type="submit">
                    <i class="fa fa-search"></i>
                </button>
              </span>
            </div>
        </form>
    </div>
  </div>
</nav>

<div id="main-content">
		<div class="container">
		<div id="content-area" class="clearfix">
			<div class="et_pb_extra_column_main">
																<article id="post-29171" class="module single-post-module post-29171 post type-post status-publish format-standard has-post-thumbnail hentry category-centos category-cms-crm-erp category-tutorials tag-bench tag-centos7 tag-erp tag-erpnext tag-frappe et-has-post-format-content et_post_format-et-post-format-standard">
														<div class="post-header">
								<h1 class="entry-title">How To Install ERPNext on CentOS 7</h1>
								<div class="post-meta vcard">
									<p><span class="updated">Jan 25, 2019</span> | <a href="https://www.rosehosting.com/blog/category/centos/" rel="tag">CentOS</a>, <a href="https://www.rosehosting.com/blog/category/cms-crm-erp/" rel="tag">CMS, CRM, ERP</a>, <a href="https://www.rosehosting.com/blog/category/tutorials/" rel="tag">Tutorials</a> | <a class="comments-link" href="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a></p>
								</div>
							</div>
							
														<div class="post-thumbnail header">
								<img src="https://www.rosehosting.com/blog/wp-content/uploads/2019/01/install-erpnext-centos.jpg" alt="How To Install ERPNext on CentOS 7" />							</div>
							
														
							<div class="post-wrap">
															<div class="post-content entry-content">
									<p><a href="https://www.rosehosting.com/blog/wp-content/uploads/2019/01/install-erpnext-centos.jpg"><img class="alignnone size-full wp-image-29530" src="https://www.rosehosting.com/blog/wp-content/uploads/2019/01/install-erpnext-centos.jpg" alt="Install ERPNext on CentOS" width="742" height="372" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2019/01/install-erpnext-centos.jpg 742w, https://www.rosehosting.com/blog/wp-content/uploads/2019/01/install-erpnext-centos-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2019/01/install-erpnext-centos-300x150.jpg 300w" sizes="(max-width: 742px) 100vw, 742px" /></a></p>
<p><strong>ERPNext</strong> is a completely robust ERP framework intended for small and medium-sized businesses. It covers an extensive variety of features, including accounting, CRM, inventory, selling, purchasing, manufacturing, projects, HR and payroll, website, e-commerce, and more &#8211; all of which make it profoundly adaptable and extendable.</p>
<p>ERPNext is developed in Python and depends on the Frappe Framework. It utilizes Node.js for the front end, Nginx for the web server, Redis for caching, and MariaDB for the database.</p>
<p>ERPNext is Open Source under the GNU General Public License v3.</p>
<p><span id="more-29171"></span></p>
<p>In this article, we will show you <strong>how to install ERPNext on CentOS 7</strong> on one of our optimized <a href="https://www.rosehosting.com/crm-hosting.html">ERPNext hosting</a> servers.</p>
<h2>Prerequisites:</h2>
<p>Make sure your server met the following requirements.</p>
<ul>
<li>2GB of RAM or higher</li>
<li>2 or more CPU cores</li>
<li>Fresh CentOS 7 Installation</li>
<li>Full root access</li>
</ul>
<h2>Update the System and Install the Dependencies</h2>
<p>Log in to your server via SSH:</p>
<pre>ssh username@server_ip</pre>
<p>Before starting with the ERPNext installation, it is a good idea to update the system packages to their latest versions.</p>
<pre>sudo yum update -y</pre>
<p>Install the development tool dependencies by running the following command:</p>
<pre>sudo yum groupinstall -y "Development Tools"
</pre>
<h2>Install ERPNext</h2>
<h3>Installing Node JS</h3>
<p>Since ERPNext uses Node JS for its front end, we first need to set up the latest version of Node JS. As of writing, the current LTS version of Node.js is version 10.x.</p>
<p>To install, first, we need to run the following command to add NodeJS&#8217; official repository to the system.</p>
<pre>sudo curl -sL https://rpm.nodesource.com/setup_10.x | sudo bash -</pre>
<p>Once the repository is added, run the following command:</p>
<pre>sudo yum install -y nodejs</pre>
<p>To verify, run the following to check node version, must be 10.x.x:</p>
<pre>node --version</pre>
<h3>Installing ERPNext using a script</h3>
<p>Fortunately, ERPNext developers have created an easy install script to save time and avoid any problems with configuring your ERPNext server. This python script will install the prerequisites &amp; bench, as well as set up the ERPNext site.</p>
<p>We can set up ERPNext on two environments, development and production. For the development environment, there will be <code>no Nginx installed</code> and you need to start ERPNext manually. For a production environment,  <code>Nginx is installed</code> and the process will be managed by <code>supervisor</code>. You will learn more about supervisor later on in this tutorial.</p>
<p>When installing under a production environment, we need to make sure that we <code>uninstall Apache</code> first as the installer script will set up Nginx. It is also recommended to <code>uninstall MariaDB</code> to avoid conflicts during installation for both production and development. For a development environment, it is safe to leave Apache installed and running as Nginx will not be installed.</p>
<p>To stop and uninstall Apache <code>(required for production set up only)</code>:</p>
<pre>sudo systemctl stop httpd
sudo yum remove -y httpd httpd-tools apr apr-util</pre>
<p>To stop and uninstall MariaDB <code>(recommended for both development and production setup)</code>:</p>
<pre>sudo systemctl stop mariadb
sudo yum remove -y mariadb mariadb-server
sudo rm -rf /var/lib/mysql /etc/my.cnf
<!--more--></pre>
<p>To start with the installation, we first need to download the official script using wget:</p>
<pre>wget https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py</pre>
<p>The script will require three parameters:</p>
<p><code>domain = your development/production domain</code><br />
<code>erp_user = preferred local ERPNext user</code><br />
<code>bench_name = preferred bench name</code></p>
<p>For development installation, supply the following command.</p>
<pre>sudo python install.py --develop --site [domain] --user [erp_user]--bench-name [bench_name] --verbose</pre>
<p>For production installation, use the following command:</p>
<pre>sudo python install.py --production --site [domain] --user [erp_user] --bench-name [bench_name] --verbose</pre>
<p>An example would be:</p>
<pre>sudo python install.py --develop --site erp-dev.rosehosting.com --user erpnext --bench-name erpnext-dev --verbose</pre>
<p>The following is the process that will be done by the script:<br />
* Install all the pre-requisites<br />
* Install the command line based bench<br />
* Set up a new bench &#8211; contains ERPNext files<br />
* Finally, set up a new ERPNext site on the bench</p>
<p>During the installation, the script will ask for the database and Administrator password. Always remember to use a strong password. Passwords will be located at <code>~/passwords.txt</code> after installation.</p>
<h2>Starting ERPNext</h2>
<p>On a development environment setup, it is required to start the ERPNext application manually. The ERPNext application listens on port 8000.</p>
<h3>Development</h3>
<pre>su - [erp_user]
cd [bench_name]
bench start</pre>
<p>You can now access your setup at:</p>
<pre>http://[domain]:8000
Login: Administrator
Password: The one that you input during installation</pre>
<h3>Production</h3>
<p>There&#8217;s no need to do anything, processes will be managed by the supervisor.</p>
<p>Supervisor is a process control system that enables you to monitor and control processes on systems running Linux. When supervisor is running, it will automatically start the application at boot and will handle process failures. The installer script automatically configured supervisor for your ERPNext application. You can learn more about supervisors <a href="http://supervisord.org/" target="_blank" rel="noopener">here</a>.</p>
<p>You can check processes handled by supervisor by using the command:</p>
<pre>sudo supervisorctl status all</pre>
<p>You can now log in to your production website <code>without using port 8000</code> as the Nginx web server is already configured as a reverse proxy for port 8000.</p>
<p>After logging in, you should now be able to finalize the initial setup of your ERPNext application.</p>
<hr />
<p>Of course, you don’t have to <strong>install ERPNext on CentOS 7</strong> if you have a <a href="https://www.rosehosting.com/centos-hosting.html">CentOS VPS</a> with us. You can simply ask our support team to install ERPNext on CentOS 7 for you. They are available 24/7 and will be able to help you with the installation.</p>
<p><span style="color: #ff0000;"><strong>PS</strong></span>. If you enjoyed reading this blog post on How to Install ERPNext on CentOS 7, feel free to share it on social networks using the shortcuts below, or simply leave a comment. Thanks.</p>
<div class="essb_links essb_counters essb_displayed_followme essb_share essb_template_metro-bold-retina essb_1874862471 essb_links_center essb_nospace print-no" id="essb_displayed_followme_1874862471" data-essb-postid="29171" data-essb-position="followme" data-essb-button-style="button_name" data-essb-template="metro-bold-retina" data-essb-counter-pos="insidename" data-essb-url="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/" data-essb-twitter-url="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/" data-essb-instance="1874862471"><ul class="essb_links_list essb_hide_icon"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-counter-pos="insidename"><span class="essb_totalcount essb_t_l" title="Total: "><span class="essb_total_text">Total: </span><span class="essb_t_nb">1</span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/&t=How+To+Install+ERPNext+on+CentOS+7" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/&t=How+To+Install+ERPNext+on+CentOS+7&#39;,&#39;facebook&#39;,&#39;1874862471&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook<span class="essb_counter_insidename" data-cnt="1" style="display: none;" data-cnt-short="1">1</span></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=How+To+Install+ERPNext+on+CentOS+7&amp;url=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/&amp;counturl=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/&#39;,&#39;twitter&#39;,&#39;1874862471&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_google nolightbox"> <a href="https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/" title="" onclick="essb.window(&#39;https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/&#39;,&#39;google&#39;,&#39;1874862471&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_google"></span><span class="essb_network_name">Google+<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+To+Install+ERPNext+on+CentOS+7&amp;url=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+To+Install+ERPNext+on+CentOS+7&amp;url=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/&#39;,&#39;linkedin&#39;,&#39;1874862471&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li></ul></div>																	</div>
														</div>
														<div class="post-footer">
								<div class="social-icons ed-social-share-icons">
									<p class="share-title">Share:</p>
									
		
		
		
		
		
		<a href="http://www.facebook.com/sharer.php?u=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/&#038;t=How%20To%20Install%20ERPNext%20on%20CentOS%207" class="social-share-link" title="Share &quot;How To Install ERPNext on CentOS 7&quot; via Facebook" data-network-name="facebook" data-share-title="How To Install ERPNext on CentOS 7" data-share-url="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/">
				<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover" ></span>
			</a><a href="http://twitter.com/intent/tweet?text=How%20To%20Install%20ERPNext%20on%20CentOS%207%20https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/" class="social-share-link" title="Share &quot;How To Install ERPNext on CentOS 7&quot; via Twitter" data-network-name="twitter" data-share-title="How To Install ERPNext on CentOS 7" data-share-url="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/">
				<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover" ></span>
			</a><a href="https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/&#038;t=How%20To%20Install%20ERPNext%20on%20CentOS%207" class="social-share-link" title="Share &quot;How To Install ERPNext on CentOS 7&quot; via Google +" data-network-name="googleplus" data-share-title="How To Install ERPNext on CentOS 7" data-share-url="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/">
				<span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover" ></span>
			</a><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/&#038;title=How%20To%20Install%20ERPNext%20on%20CentOS%207" class="social-share-link" title="Share &quot;How To Install ERPNext on CentOS 7&quot; via LinkedIn" data-network-name="linkedin" data-share-title="How To Install ERPNext on CentOS 7" data-share-url="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/">
				<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;How To Install ERPNext on CentOS 7&quot; via Email" data-network-name="basic_email" data-share-title="How To Install ERPNext on CentOS 7" data-share-url="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/">
				<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;How To Install ERPNext on CentOS 7&quot; via Print" data-network-name="basic_print" data-share-title="How To Install ERPNext on CentOS 7" data-share-url="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/">
				<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover" ></span>
			</a>								</div>
																<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #932279;
									}
								</style>
							</div>

																				</article>

						<nav class="post-nav">
							<div class="nav-links clearfix">
								<div class="nav-link nav-link-prev">
									<a href="https://www.rosehosting.com/blog/how-to-install-joomla-on-ubuntu-18-04/" rel="prev"><span class="button">Previous</span><span class="title">How to Install Joomla on Ubuntu 18.04</span></a>								</div>
								<div class="nav-link nav-link-next">
																	</div>
							</div>
						</nav>
						
												<div class="et_extra_other_module related-posts">
							<div class="related-posts-header">
								<h3>Related Posts</h3>
							</div>
							<div class="related-posts-content clearfix">
																<div class="related-post">
									<div class="featured-image"><a href="https://www.rosehosting.com/blog/list-all-installed-packages-with-yum-on-centos-7/" title="List All Installed Packages with yum on CentOS 7" class="post-thumbnail">
				<img src="https://www.rosehosting.com/blog/wp-content/uploads/2018/03/List-All-Installed-Packages-with-yum-on-CentOS-7.jpg" alt="List All Installed Packages with yum on CentOS 7" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://www.rosehosting.com/blog/list-all-installed-packages-with-yum-on-centos-7/">List All Installed Packages with yum on CentOS 7</a></h4>
									<p class="date"><span class="updated">March 30, 2018</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="https://www.rosehosting.com/blog/how-to-fix-the-leverage-browser-caching-warning-in-wordpress/" title="How to Fix the &#8220;Leverage Browser Caching&#8221; Warning in WordPress" class="post-thumbnail">
				<img src="https://www.rosehosting.com/blog/wp-content/uploads/2018/05/How-to-Fix-the-Leverage-Browser-Caching-Warning-in-WordPress.jpg" alt="How to Fix the &#8220;Leverage Browser Caching&#8221; Warning in WordPress" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://www.rosehosting.com/blog/how-to-fix-the-leverage-browser-caching-warning-in-wordpress/">How to Fix the &#8220;Leverage Browser Caching&#8221; Warning in WordPress</a></h4>
									<p class="date"><span class="updated">May 4, 2018</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="https://www.rosehosting.com/blog/how-to-install-and-integrate-spamassassin-with-postfix-on-a-centos-6-vps/" title="How to install and integrate SpamAssassin with Postfix on a CentOS 6 VPS" class="post-thumbnail">
				<img src="https://www.rosehosting.com/blog/wp-content/uploads/2012/11/spamassassin.png" alt="How to install and integrate SpamAssassin with Postfix on a CentOS 6 VPS" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://www.rosehosting.com/blog/how-to-install-and-integrate-spamassassin-with-postfix-on-a-centos-6-vps/">How to install and integrate SpamAssassin with Postfix on a CentOS 6 VPS</a></h4>
									<p class="date"><span class="updated">December 11, 2013</span></p>
								</div>
																<div class="related-post">
									<div class="featured-image"><a href="https://www.rosehosting.com/blog/install-symphony-cms-on-an-ubuntu-vps/" title="Install Symphony CMS on an Ubuntu VPS" class="post-thumbnail">
				<img src="https://www.rosehosting.com/blog/wp-content/uploads/2015/05/install-symphony-cms-on-an-ubuntu-vps.jpg" alt="Install Symphony CMS on an Ubuntu VPS" /><span class="et_pb_extra_overlay"></span>
			</a></div>
									<h4 class="title"><a href="https://www.rosehosting.com/blog/install-symphony-cms-on-an-ubuntu-vps/">Install Symphony CMS on an Ubuntu VPS</a></h4>
									<p class="date"><span class="updated">June 11, 2015</span></p>
								</div>
																							</div>
						</div>
										
				<!-- You can start editing here. -->

<section id="comment-wrap">
			<div id="comments" class="nocomments">
			 <!-- If comments are open, but there are no comments. -->

					</div>
					<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/how-to-install-erpnext-on-centos-7/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.rosehosting.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea autocomplete="nope"  id="54f0982fe6"  name="54f0982fe6"   cols="45" rows="8" aria-required="true"></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="nope" style="padding:0;clip:rect(1px, 1px, 1px, 1px);position:absolute !important;white-space:nowrap;height:1px;width:1px;overflow:hidden;" tabindex="-1"></textarea><script type="text/javascript">document.getElementById("comment").setAttribute( "id", "0373aead056411989f90c73a2ba32149" );document.getElementById("54f0982fe6").setAttribute( "id", "comment" );</script></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='29171' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><div class="g-recaptcha" data-sitekey="6LfY7_4SAAAAAE2DEhMo9U4ZS1XLXf1qGXL9uzZC" data-theme="standard"></div><script type="text/javascript"src="https://www.google.com/recaptcha/api.js?hl=en"></script>            <div id="recaptcha-submit-btn-area">&nbsp;</div>
            <noscript>
            <style type='text/css'>#submit {display:none;}</style>
            <input name="submit" type="submit" id="submit-alt" tabindex="6"
                value="Submit Comment"/> 
            </noscript>			</form>
			</div><!-- #respond -->
		</section>
			</div><!-- /.et_pb_extra_column.et_pb_extra_column_main -->

			<div class="et_pb_extra_column_sidebar">
	<div class="et_pb_widget roseh-widget"><h4 class="widgettitle"> </h4><div style="text-align: center; margin-left: 10px; " id="roseh-1016682776"><center><a target="_blank" href="https://linuxhostsupport.com/"><img src="https://media.rosehosting.com/img/blogads/24.jpg" alt="Server Management Services"></a></center>
</div></div> <!-- end .et_pb_widget --><div class="et_pb_widget roseh-widget"><h4 class="widgettitle"> </h4><div style="text-align: center; margin-left: 10px; " id="roseh-879899875"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- rh-blog-under-top-image-320x250 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5301323036263712"
     data-ad-slot="2385735863"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div> <!-- end .et_pb_widget --><div class="et_pb_widget roseh-widget"><h4 class="widgettitle"> </h4><div style="text-align: center; " id="roseh-122257837"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- rh-blog-sidebar-300x600 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-5301323036263712"
     data-ad-slot="8927217199"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div> <!-- end .et_pb_widget --></div>

		</div> <!-- #content-area -->
	</div> <!-- .container -->
	</div> <!-- #main-content -->

	
	

  <!-- footer-big-menu.html -->
  <footer class="footer-big-menu">
    <div class="container">

      <div class="row menu">

        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title mb-2">Company</h3>
            <a class="menu-link" href="https://www.rosehosting.com/about-us.html">About us</a>
            <a class="menu-link" href="https://www.rosehosting.com/policies.html">Our Policies</a>
            <a class="menu-link" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
            <a class="menu-link" href="https://www.rosehosting.com/blog/">Blog</a>
            <a class="menu-link" href="https://www.rosehosting.com/why-rosehosting.html">Why RoseHosting</a>
            <a class="menu-link" href="https://www.rosehosting.com/compare-to-competition.html">Compare Us</a>
            <a class="menu-link" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
            <a class="menu-link" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Support</h3>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Helpdesk System</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>
          <a class="menu-link" href="https://status.rosehosting.com">Systems Status</a>

          <h3 class="menu-title  mb-2 mt-4">Other Services</h3>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Domain Registration</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Domain Transfer</a>
          <a class="menu-link" href="https://www.rosehosting.com/ssl-certificates.html">SSL Certificates</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/vps-hosting.html">VPS Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom SSD VPS</a>
          <a class="menu-link" href="https://www.rosehosting.com/dedicated-servers.html">Cloud Dedicated Servers</a>
          <a class="menu-link" href="https://www.rosehosting.com/hosting-solutions.html">Hosting Solutions</a>
          <a class="menu-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Affiliate Program</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Linux VPS Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/centos-hosting.html">CentOS Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/ubuntu-hosting.html">Ubuntu Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/debian-hosting.html">Debian Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/opensuse-hosting.html">OpenSUSE Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/arch-linux-hosting.html">Arch-Linux Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/scientific-linux-hosting.html">Scientific Linux Hosting</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Apps Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/wordpress-hosting.html">WordPress Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/magento-hosting.html">Magento Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/odoo-hosting.html">Odoo Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/joomla-hosting.html">Joomla Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/drupal-hosting.html">Drupal Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/laravel-hosting.html">Laravel Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/nextcloud-hosting.html">NextCloud Hosting</a>

          <a class="menu-link" href="https://www.rosehosting.com/prestashop-hosting.html">PrestaShop Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/ghost-hosting.html">Ghost Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/mediawiki-hosting.html">MediaWiki Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/tomcat-hosting.html">Tomcat Hosting</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title mb-2">Contact Us</h3>
          <a class="menu-link" href="tel:+18887673467">(888) ROSE-HOST</a>
          <a class="menu-link" href="tel:+18887673467">(888) 767-3467</a>
          <a class="menu-link" href="tel:+16465197201">(314) 275-0414</a>
          <a class="menu-link" href="mailto:%73%75%70%70%6f%72%74%40%72%6f%73%65%68%6f%73%74%69%6e%67%2e%63%6f%6d">Email us</a>

          <h3 class="menu-title mb-2 mt-4">Connect</h3>
          <a class="menu-link" href="https://twitter.com/rosehosting" target="_blank"><i class="fa fa-twitter fa-fw"></i> Twitter</a>
          <a class="menu-link" href="https://www.facebook.com/RoseHosting" target="_blank"><i class="fa fa-facebook fa-fw"></i> Facebook</a>
          <a class="menu-link" href="https://plus.google.com/+Rosehosting" target="_blank"><i class="fa fa-google-plus fa-fw"></i> Google+</a>
          <a class="menu-link" href="https://www.linkedin.com/company/rose-web-services-l-l-c-" target="_blank"><i class="fa fa-linkedin fa-fw"></i> LinkedIn</a>
          <a class="menu-link" href="https://www.rosehosting.com/blog/feed/" target="_blank"><i class="fa fa-rss fa-fw"></i> RSS Feed</a>

        </div>

      </div>

    </div>


    <div class="bottom">
      <div class="container">
        <div class="row">

          <div class="col col-md-12">
            <img class="privacy-shield d-block mb-4" width="175" src="https://www.rosehosting.com/blog/wp-content/themes/rh2018/img/privacy_shield.png" alt="privacy shield">
          </div>

          <div class="col-md-12 col-lg-6">
              <p class="text-sm-left"><a class="inline-link footer-policy" href="/tos.html">Terms of Service</a> and <a class="inline-link footer-policy" href="/policies.html">other policies</a></p>
          </div>
          <div class="col-md-12 col-lg-6">
            <p class="text-sm-right">&copy; 2001-2019 <a class="inline-link footer-policy" href="https://www.rosewebservices.com/">Rose Web Services LLC</a>.</p>
          </div>
         </div>
      </div>
    </div>

<!-- livezilla.net code -->
<script type="text/javascript" id="aff1f81b02f303eea5f87a3a065f153a" src="https://linuxhostsupport.com/chat//script.php?id=aff1f81b02f303eea5f87a3a065f153a"></script>
<!-- http://www.livezilla.net -->

	<div class="essb-followme essb-followme-bottom" data-full="" data-top="" data-background="rgba(255,255,255,0)" data-position="" data-avoid-left="true" data-hide="1"><div class="essb_links essb_counters essb_displayed_followme essb_share essb_template_metro-bold-retina essb_106448875 essb_links_center essb_nospace print-no" id="essb_displayed_followme_106448875" data-essb-postid="29171" data-essb-position="followme" data-essb-button-style="button_name" data-essb-template="metro-bold-retina" data-essb-counter-pos="insidename" data-essb-url="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/" data-essb-twitter-url="https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/" data-essb-instance="106448875"><ul class="essb_links_list essb_hide_icon"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-counter-pos="insidename"><span class="essb_totalcount essb_t_l" title="Total: "><span class="essb_total_text">Total: </span><span class="essb_t_nb">1</span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/&t=How+To+Install+ERPNext+on+CentOS+7" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/&t=How+To+Install+ERPNext+on+CentOS+7&#39;,&#39;facebook&#39;,&#39;106448875&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook<span class="essb_counter_insidename" data-cnt="1" style="display: none;" data-cnt-short="1">1</span></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=How+To+Install+ERPNext+on+CentOS+7&amp;url=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/&amp;counturl=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/&#39;,&#39;twitter&#39;,&#39;106448875&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_google nolightbox"> <a href="https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/" title="" onclick="essb.window(&#39;https://plus.google.com/share?url=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/&#39;,&#39;google&#39;,&#39;106448875&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_google"></span><span class="essb_network_name">Google+<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+To+Install+ERPNext+on+CentOS+7&amp;url=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+To+Install+ERPNext+on+CentOS+7&amp;url=https://www.rosehosting.com/blog/how-to-install-erpnext-on-centos-7/&#39;,&#39;linkedin&#39;,&#39;106448875&#39;); return false;" target="_blank" rel="nofollow" ><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li></ul></div></div>
<!-- This site is optimized with Phil Singleton's WP SEO Structured Data Plugin v2.5.5 - https://kcseopro.com/wordpress-seo-structured-data-schema-plugin/ -->
<script type="application/ld+json">{
    "@context": "http://schema.org",
    "@type": "Organization",
    "additionalType": "WebHosting",
    "name": "RoseHosting",
    "logo": "https://www.rosehosting.com/blog/wp-content/uploads/2018/03/RoseHosting-Logo.png",
    "url": "https://www.rosehosting.com/blog/",
    "sameAs": [
        "https://twitter.com/rosehosting",
        "https://www.facebook.com/RoseHosting",
        "https://www.google.com/+Rosehosting",
        "https://www.linkedin.com/in/rosehosting"
    ],
    "contactPoint": {
        "@type": "ContactPoint",
        "telephone": "+1-888-767-3467",
        "contactType": "Customer Service",
        "email": "support@rosehosting.com",
        "contactOption": "TollFree",
        "areaServed": "Canada,Mexico,United States",
        "availableLanguage": "English"
    },
    "address": {
        "@type": "PostalAddress",
        "addressCountry": "United States",
        "addressLocality": "Saint Louis",
        "addressRegion": "MO",
        "postalCode": "63368",
        "streetAddress": "2977 Hwy K #252"
    }
}</script>
<!-- / WP SEO Structured Data Plugin. -->

	<script type="text/javascript">
			</script>
	            <script type="text/javascript">
            var sub = document.getElementById('submit');
            document.getElementById('recaptcha-submit-btn-area').appendChild (sub);
            document.getElementById('submit').tabIndex = 6;
            if ( typeof _recaptcha_wordpress_savedcomment != 'undefined') {
                document.getElementById('comment').value = 
                    _recaptcha_wordpress_savedcomment;
            }
            </script><script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2018/js/theme.js?x60951&amp;ver=1' defer '></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/masonry.min.js?x60951&amp;ver=3.3.2' defer '></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/www.rosehosting.com\/blog\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"1c2f7bee4c","timeline_nonce":"ef28c1ff34","blog_feed_nonce":"df5face0fe","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/www.rosehosting.com\/blog\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/www.rosehosting.com\/blog\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"6ea44a0241","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"e4d13c1347","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"29171","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/Extra/scripts/scripts.min.js?x60951&amp;ver=2.19.4' defer '></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/comment-reply.min.js?x60951&amp;ver=4.9.8' defer '></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/Extra/core/admin/js/common.js?x60951&amp;ver=3.19.4' defer '></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/wp-embed.min.js?x60951&amp;ver=4.9.8' defer '></script>
<link rel='stylesheet' id='essb-compiled-css'  href='https://www.rosehosting.com/blog/wp-content/easysocialsharebuttons-assets/compiled/2566c291e59e185c12a331fef1e235f3.css?x60951' type='text/css' media='all' /><script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/easysocialsharebuttons-assets/compiled/2566c291e59e185c12a331fef1e235f3.js?x60951' async></script></body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 109/191 objects using memcached
Page Caching using memcached 

Served from: www.rosehosting.com @ 2019-01-27 05:22:43 by W3 Total Cache
-->