<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head><meta charset="UTF-8" /><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
	


	<link rel="pingback" href="https://www.rosehosting.com/blog/xmlrpc.php" />


		<!--[if lt IE 9]>
	<script src="https://www.rosehosting.com/blog/wp-content/themes/generatepress/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->

<!--<script type="rocketlazyloadscript" async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script>-->

<!-- Google Tag Manager -->
<script type="rocketlazyloadscript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KVJ4PJ');</script>
<!-- End Google Tag Manager -->

	<script type="rocketlazyloadscript" data-rocket-type="text/javascript">
		document.documentElement.className = 'js';
	</script>

	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<meta name="viewport" content="width=device-width, initial-scale=1">
	<!-- This site is optimized with the Yoast SEO Premium plugin v17.0 (Yoast SEO v18.1) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>How to Set Up WordPress Multisite with OpenLiteSpeed on Ubuntu 20.04 - RoseHosting</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2Cregular%2Citalic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2Cregular%2Citalic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2Cregular%2Citalic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic&#038;display=swap" /></noscript><link rel="stylesheet" href="https://www.rosehosting.com/blog/wp-content/cache/min/1/8907a79666ea112a96fd4ea2cfbd98bd.css" media="all" data-minify="1" />
	<link rel="canonical" href="https://www.rosehosting.com/blog/how-to-install-wordpress-multisite-with-openlitespeed-on-ubuntu-20-04/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="How to Set Up WordPress Multisite with OpenLiteSpeed on Ubuntu 20.04" />
	<meta property="og:description" content="WordPress is a free, open-source, and one of the best content management systems around the world. It is based on ... Read more" />
	<meta property="og:url" content="https://www.rosehosting.com/blog/how-to-install-wordpress-multisite-with-openlitespeed-on-ubuntu-20-04/" />
	<meta property="og:site_name" content="RoseHosting" />
	<meta property="article:publisher" content="https://www.facebook.com/RoseHosting" />
	<meta property="article:author" content="https://www.facebook.com/rosehosting.helpdesk" />
	<meta property="article:published_time" content="2022-02-14T18:30:00+00:00" />
	<meta property="article:modified_time" content="2022-01-26T14:57:16+00:00" />
	<meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/how-to-install-wordpress-multisite-with-openlitespeed-on-ubuntu-20.04.jpg?v=1643188029" />
	<meta property="og:image:width" content="742" />
	<meta property="og:image:height" content="372" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@rosehosting" />
	<meta name="twitter:site" content="@rosehosting" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Jeff Wilson" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="10 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Feed" href="https://www.rosehosting.com/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Comments Feed" href="https://www.rosehosting.com/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; How to Set Up WordPress Multisite with OpenLiteSpeed on Ubuntu 20.04 Comments Feed" href="https://www.rosehosting.com/blog/how-to-install-wordpress-multisite-with-openlitespeed-on-ubuntu-20-04/feed/" />
<!-- rosehosting.com/blog is managing ads with Advanced Ads --><!--noptimize--><script id="rhad-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
		<!--/noptimize--><style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	


<style id='global-styles-inline-css'>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</style>






<style id='ez-toc-inline-css'>
div#ez-toc-container p.ez-toc-title {font-size: 22px;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}div#ez-toc-container {width: 95%;}
</style>






<style id='generate-style-inline-css'>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</style>









<link rel='preload' as='font'  id='wpzoom-social-icons-font-academicons-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.ttf?v=1.8.6' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-academicons-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.woff?v=1.8.6' type='font/woff' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-fontawesome-3-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.ttf?v=4.7.0' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-fontawesome-3-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff?v=4.7.0' type='font/woff' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-fontawesome-3-woff2-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff2?v=4.7.0' type='font/woff2' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-genericons-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-genericons-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type='font/woff' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-socicon-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.ttf?v=4.2.4' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-socicon-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.woff?v=4.2.4' type='font/woff' crossorigin />
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js' defer></script>
<script id='topbar_frontjs-js-extra'>
var tpbr_settings = {"fixed":"fixed","user_who":"notloggedin","guests_or_users":"all","message":"20th Anniversary Sale!!! 20% OFF on all hosting services. Use coupon RH20YEARS     *new customers only, while supplies last","status":"inactive","yn_button":"button","color":"#ba004a","button_text":"GET THE DEAL","button_url":"https:\/\/www.rosehosting.com\/20th-anniversary-sale.html","button_behavior":"newwindow","is_admin_bar":"no","detect_sticky":"0"};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/top-bar/inc/../js/tpbr_front.min.js?ver=5.9' id='topbar_frontjs-js' defer></script>
<script id='advanced-ads-advanced-js-js-extra'>
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js?ver=1.31.1' id='advanced-ads-advanced-js-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/ajax/libs/popper.js/1.11.0/umd/popper.min.js?ver=1644445278' id='popper-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/themes/rh2022/js/bootstrap.js?ver=1644445278' id='bootstrap-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/themes/rh2022/js/cookieconsent.min.js?ver=1' id='cookieconsent-js' defer></script>
<link rel="https://api.w.org/" href="https://www.rosehosting.com/blog/wp-json/" /><link rel="alternate" type="application/json" href="https://www.rosehosting.com/blog/wp-json/wp/v2/posts/40200" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rosehosting.com/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rosehosting.com/blog/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9" />
<link rel='shortlink' href='https://www.rosehosting.com/blog/?p=40200' />
<link rel="alternate" type="application/json+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-install-wordpress-multisite-with-openlitespeed-on-ubuntu-20-04%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-install-wordpress-multisite-with-openlitespeed-on-ubuntu-20-04%2F&#038;format=xml" />
<script type="rocketlazyloadscript">advads_items = { conditions: {}, display_callbacks: {}, display_effect_callbacks: {}, hide_callbacks: {}, backgrounds: {}, effect_durations: {}, close_functions: {}, showed: [] };</script><style type="text/css" id="rhad-layer-custom-css"></style><script type="rocketlazyloadscript" data-rocket-type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
		<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-270x270.png" />
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script type="rocketlazyloadscript" data-rocket-type="text/javascript">
  var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(["setCookieDomain", "*.rosehosting.com"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.rosehosting.com/";
    _paq.push(['setTrackerUrl', u+'rosea.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.src='https://www.rosehosting.com/dist/rosea.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
</head>
<body class="post-template-default single single-post postid-40200 single-format-standard wp-embed-responsive post-image-above-header post-image-aligned-center sticky-menu-fade right-sidebar nav-below-header separate-containers contained-header active-footer-widgets-1 nav-aligned-left header-aligned-left dropdown-hover aa-prefix-rhad-">



<nav class="navbar yamm navbar-expand-lg navbar-dark" role="navigation">
  <div class="container no-override navbar-dark">

    <a class="navbar-brand" href="https://www.rosehosting.com/">
      <img alt="RoseHosting.com" width="186" height="37"  class="d-lg-inline mr-2" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20186%2037'%3E%3C/svg%3E" data-lazy-src="https://www.rosehosting.com/blog/wp-content/themes/rh2022/img/rh-logo.svg" /><noscript><img alt="RoseHosting.com" width="186" height="37"  class="d-lg-inline mr-2" src="https://www.rosehosting.com/blog/wp-content/themes/rh2022/img/rh-logo.svg" /></noscript>
    </a>

    <button class="navbar-toggler" data-toggle="collapse" data-target="#navbar-collapse">
      <span class="navbar-toggler-icon"></span>
    </button>

    <div class="collapse navbar-collapse justify-content-end" id="navbar-collapse">
      <ul class="navbar-nav">

        <li class="nav-item active dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Hosting Solutions
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">

            <div class="yamm-content">
              <div class="row">
                <div class="col-sm-6">
                   <span class="text-primary  dropdown-header"><strong>Managed SSD Hosting</strong></span>
                   <div class="dropdown-divider"></div>
                   <a class="dropdown-item" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/linux-vps-hosting/">Linux VPS Hosting</a>
                   <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom VPS</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/managed-cloud-hosting.html">Cloud Hosting</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/dedicated-servers.html">Dedicated Servers</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting <span class="ml-2 badge badge-success">new</span></a>
                </div>
                <div class="col-sm-6">
                  <span class="text-primary dropdown-header"><strong>Managed Solutions</strong></span>
                  <div class="dropdown-divider"></div>
                  <a class="dropdown-item" href="https://www.rosehosting.com/wordpress-hosting.html">
                    Wordpress Hosting
                    <small class="d-block text-muted"><i>The best blogging platform</i></small>
                  </a>
                  <a class="dropdown-item" href="https://www.rosehosting.com/magento-hosting.html">
                    Magento Hosting
                    <small class="d-block text-muted"><i>The best e-commerce platform</i></small>
                  </a>
                  <a class="dropdown-item" href="https://www.rosehosting.com/odoo-hosting.html">
                    Odoo Hosting
                    <small class="d-block text-muted"><i>The best CRM/ERP platform</i></small>
                  </a>
                  <span class="dropdown-item"><a class="btn-shadow btn-shadow-primary btn-shadow-sm" target="_blank" href="https://www.rosehosting.com/hosting-solutions.html">Other Solutions</a></span>

                </div>
              </div>
            </div>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            SSL / Domains
            <i class="fa fa-chevron-down"></i>
          </a>

          <div class="dropdown-menu" role="menu">

            <div class="yamm-content">
              <div class="row">
                <div class="col-sm-3">
                    <span class="text-primary  dropdown-header"><strong>SSL by brand</strong></span>
                    <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#geotrust">GeoTrust</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#comodo">Comodo</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#rapidssl">RapidSSL</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#thawte">Thawte</a>
                </div>
                <div class="col-sm-4">

                    <span class="text-primary  dropdown-header"><strong>SSL by Type</strong></span>
                    <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#domain_validation">Domain Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#organization_validation">Organization Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#extended_validation">Extended Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#wildcard_ssl">Wildcard SSL</a>
                </div>
                <div class="col-sm-3">
                  <span class="text-primary dropdown-header"><strong>Domains</strong></span>
                  <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Register Domains</a>
                    <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Transfer Domains</a>
                </div>
              </div>
            </div>
          </div>


        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Support
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
              <a class="dropdown-item" href="https://www.rosehosting.com/support.html">24/7 Managed Support</a>
              <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Open a Support Ticket</a>
              <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>
	      <a class="dropdown-item" rel=”nofollow” href="https://status.rosehosting.net">Systems Status</a>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            About Us
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
            <a class="dropdown-item" href="https://www.rosehosting.com/about-us.html">Our Company</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/policies.html">Our Policies</a>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Affiliates
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
            <a class="dropdown-item" href="https://www.rosehosting.com/cpa-hosting-affiliate-program.html">Flat-Rate CPA Affiliate Plan</a>
            <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Flat-Rate CPA Affiliate Login</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/vps-affiliate-program.html">Recurring Affiliate Plan</a>
            <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/aff/">Recurring Affiliate Login</a>
          </div>
        </li>

        <li class="nav-item">
          <a class="nav-link" href="https://www.rosehosting.com/blog/">Blog</a>
        </li>

        <li class="nav-item">
          <a class="nav-link nav-link--rounded" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Login</a>
        </li>

      </ul>
    </div>

  </div>
</nav>


<!--
<nav class="navbar navbar-expand-lg navbar-light bg-faded navbar-blog">
   <div class="container no-override">
    <a href="https://www.rosehosting.com/blog/" class="navbar-brand">Blog Home</a>
    <div class="navbar-collapse collapse d-flex justify-content-between" id="navbar5-blog">
        <ul class="navbar-nav categories">
            <li class="nav-item dropdown">
              <a class="nav-link dropdown-toggle" data-toggle="dropdown" href="#" role="button" aria-haspopup="true" aria-expanded="false">
                Categories
                <i class="fa fa-chevron-down"></i>
              </a>
              <div class="dropdown-menu" style="z-index:0;">
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/caching/">Caching</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/centos/">CentOS</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/cms-crm-erp/">CMS, CRM, ERP</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/control-panels/">Control Panels</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/databases/">Databases</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/debian/">Debian</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/e-commerce/">E-Commerce</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/email-servers/">Email Servers</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/guides/">Guides</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/load-balancing/">Load Balancing</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/miscellaneous/">Miscellaneous</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/networking-and-domains/">Networking and Domains</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/news/">News</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/optimization/">Optimization</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/other/">Other</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/rosehosting/">RoseHosting Platform</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/scripts/">Scripts</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/security/">Security</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/seo/">SEO</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tips-and-tricks/">Tips and Tricks</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tutorials/">Tutorials</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/ubuntu/">Ubuntu</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-frameworks/">Web Frameworks</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-servers/">Web Servers</a>
                              </div>
            </li>
        </ul>
        <form class="mx-2 my-auto d-inline" method="get" id="searchform" action="https://www.rosehosting.com/blog/">
            <div class="input-group">
                <input type="search" class="field" name="s" id="s" class="form-control border border-right-0" placeholder="Search...">
                <span class="input-group-append">
                <button name="submit" id="searchsubmit" class="btn btn-outline-secondary border border-left-0" type="submit">
                    <i class="fa fa-search"></i>
                </button>
              </span>
            </div>
        </form>
    </div>
  </div>
</nav> -->

	<div id="page-container" class="page-container">

	<div class="site grid-container container hfeed grid-parent" id="page">
				<div class="site-content" id="content">
			
	<div class="content-area grid-parent mobile-grid-100 grid-70 tablet-grid-70" id="primary">
		<main class="site-main" id="main">
			
<article id="post-40200" class="post-40200 post type-post status-publish format-standard has-post-thumbnail hentry category-cms-crm-erp category-tutorials tag-multisite tag-openlitespeed tag-ubuntu-20-04 tag-wordpress" itemtype="https://schema.org/CreativeWork" itemscope>
	<div class="inside-article">
					<header class="entry-header" aria-label="Content">
				<h1 class="entry-title" itemprop="headline">How to Set Up WordPress Multisite with OpenLiteSpeed on Ubuntu 20.04</h1>		<div class="entry-meta">
			<span class="posted-on"><time class="entry-date published" datetime="2022-02-14T12:30:00-06:00" itemprop="datePublished">February 14, 2022</time></span> <span class="byline">by <span class="author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope><a class="url fn n" href="https://www.rosehosting.com/blog/author/jwilson/" title="View all posts by Jeff Wilson" rel="author" itemprop="url"><span class="author-name" itemprop="name">Jeff Wilson</span></a></span></span> 		</div>
					</header>
			
		<div class="entry-content" itemprop="text">
			<div  class="rhad-cd6b16339d04548c2e7964d5d495916d rhad-before-content" id="rhad-cd6b16339d04548c2e7964d5d495916d"></div>
<figure class="wp-block-image size-full"><img width="742" height="372" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20742%20372'%3E%3C/svg%3E" alt="how to install wordpress multisite with openlitespeed on ubuntu 20.04" class="wp-image-40257" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/how-to-install-wordpress-multisite-with-openlitespeed-on-ubuntu-20.04.jpg?v=1643188029 742w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/how-to-install-wordpress-multisite-with-openlitespeed-on-ubuntu-20.04-300x150.jpg?v=1643188029 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/how-to-install-wordpress-multisite-with-openlitespeed-on-ubuntu-20.04-150x75.jpg?v=1643188029 150w" data-lazy-sizes="(max-width: 742px) 100vw, 742px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/how-to-install-wordpress-multisite-with-openlitespeed-on-ubuntu-20.04.jpg" /><noscript><img width="742" height="372" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/how-to-install-wordpress-multisite-with-openlitespeed-on-ubuntu-20.04.jpg" alt="how to install wordpress multisite with openlitespeed on ubuntu 20.04" class="wp-image-40257" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/how-to-install-wordpress-multisite-with-openlitespeed-on-ubuntu-20.04.jpg?v=1643188029 742w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/how-to-install-wordpress-multisite-with-openlitespeed-on-ubuntu-20.04-300x150.jpg?v=1643188029 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/how-to-install-wordpress-multisite-with-openlitespeed-on-ubuntu-20.04-150x75.jpg?v=1643188029 150w" sizes="(max-width: 742px) 100vw, 742px" /></noscript></figure>



<p>WordPress is a free, open-source, and one of the best content management systems around the world. It is based on PHP and uses MySQL/MariaDB as a database backend. It provides a simple and easier way to create a simple to advanced blog or website. It provides a web-based frontend to create and manage a website.</p>



<p>OpenLiteSpeed is a high-performance, lightweight, open-source HTTP server edition of LiteSpeed Web Server Enterprise.</p>



<p>In this guide, we will show you how to install WordPress multisite with OpenLiteSpeed on Ubuntu 20.04 server. A multisite network is a group of sites sharing the same WordPress installation and could also have the same plugins and themes.</p>



<span id="more-40200"></span>



<div id="ez-toc-container" class="ez-toc-v2_0_17 counter-hierarchy ez-toc-transparent">
<div class="ez-toc-title-container">
<p class="ez-toc-title">Table of Contents</p>
<span class="ez-toc-title-toggle"><a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle" style="display: none;"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a></span></div>
<nav><ul class="ez-toc-list ez-toc-list-level-1"><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-1" href="#Prerequisites" title="Prerequisites">Prerequisites</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-2" href="#Step-1-Connect-to-Your-Server" title="Step 1: Connect to Your Server">Step 1: Connect to Your Server</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-3" href="#Step-2-Download-and-Install-OpenLiteSpeed" title="Step 2: Download and Install OpenLiteSpeed">Step 2: Download and Install OpenLiteSpeed</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-4" href="#Step-3-Create-OpenLiteSpeed-Admin-User" title="Step 3: Create OpenLiteSpeed Admin User">Step 3: Create OpenLiteSpeed Admin User</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-5" href="#Step-4-Install-and-Configure-MariaDB-Server" title="Step 4: Install and Configure MariaDB Server">Step 4: Install and Configure MariaDB Server</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-6" href="#Step-5-Create-MariaDB-Database-and-User" title="Step 5: Create MariaDB Database and User">Step 5: Create MariaDB Database and User</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-7" href="#Step-6-Install-PHP-and-Modules" title="Step 6: Install PHP and Modules">Step 6: Install PHP and Modules</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-8" href="#Step-7-Install-WordPress" title="Step 7: Install WordPress">Step 7: Install WordPress</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-9" href="#Step-8-Configure-OpenLiteSpeed" title="Step 8: Configure OpenLiteSpeed">Step 8: Configure OpenLiteSpeed</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-10" href="#Step-9-Enable-WordPress-Multisite" title="Step 9: Enable WordPress Multisite">Step 9: Enable WordPress Multisite</a></li></ul></nav></div>
<h2 id="h-prerequisites"><span class="ez-toc-section" id="Prerequisites"></span>Prerequisites<span class="ez-toc-section-end"></span></h2>



<ul><li>For the purposes of this tutorial, we will be using an <a href="https://www.rosehosting.com/ubuntu-hosting.html" target="_blank" rel="noreferrer noopener">Ubuntu 20.04 VPS</a>.</li><li>root SSH access or a regular user with sudo privileges</li></ul>



<h2 id="h-step-1-connect-to-your-server"><span class="ez-toc-section" id="Step-1-Connect-to-Your-Server"></span>Step 1: Connect to Your Server<span class="ez-toc-section-end"></span></h2>



<p>Log in to your Ubuntu 20.04 VPS with SSH as a root user or as a regular user with sudo privileges:</p>



<pre class="wp-block-preformatted">ssh root@IP_Address -p Port_Number</pre>



<p>Of course, you will need to replace <code>IP_Address</code> and <code>Port_Number</code> with your actual server IP address and SSH port number.</p>



<p>Then, run the following command to make sure that all installed packages on the server are updated to the latest available version:</p>



<pre class="wp-block-preformatted">apt update &amp;&amp; sudo apt upgrade</pre>



<h2 id="h-step-2-download-and-install-openlitespeed"><span class="ez-toc-section" id="Step-2-Download-and-Install-OpenLiteSpeed"></span>Step 2: Download and Install OpenLiteSpeed<span class="ez-toc-section-end"></span></h2>



<p>The following command will add the necessary repository to your server for the OpenLiteSpeed server installation.</p>



<pre class="wp-block-preformatted">wget -O - http://rpms.litespeedtech.com/debian/enable_lst_debain_repo.sh | bash</pre>



<p>Run the following command to install the latest version of the OpenLiteSpeed server.</p>



<pre class="wp-block-preformatted">apt install openlitespeed</pre>



<p>Once the installation is complete, you can start the OpenLiteSpeed service with the following command:</p>



<pre class="wp-block-preformatted">systemctl start lshttpd</pre>



<p>To verify if the OpenLiteSpeed service is up and running, run the following command:</p>



<pre class="wp-block-preformatted">systemctl status lshttpd</pre>



<p>Output:</p>



<pre class="wp-block-preformatted">● lshttpd.service - OpenLiteSpeed HTTP Server
Loaded: loaded (/etc/systemd/system/lshttpd.service; enabled; vendor preset: enabled)
Active: active (running)
Process: 4124 ExecStart=/usr/local/lsws/bin/lswsctrl start (code=exited, status=0/SUCCESS)
Main PID: 4157 (litespeed)
CGroup: /system.slice/lshttpd.service
├─4157 openlitespeed (lshttpd - main)
├─4166 openlitespeed (lscgid)
├─4195 openlitespeed (lshttpd - #01)
└─4196 lsphp</pre>



<p>We also recommend enabling OpenLiteSpeed to start on server boot:</p>



<pre class="wp-block-preformatted">systemctl enable lshttpd
</pre>



<p>By default, OpenLiteSpeed listens on port <code>8088</code>. It is recommended that you change the default port to 80. To do so, edit the OpenLiteSpeed default configuration file:</p>



<pre class="wp-block-preformatted">nano /usr/local/lsws/conf/httpd_config.conf</pre>



<p>Find the following lines:</p>



<pre class="wp-block-preformatted">listener Default{
address *:8088
secure 0
map Example *
}
</pre>



<p>And, replace the port<code> 8088</code> to <code>80</code>:</p>



<pre class="wp-block-preformatted">listener Default{
address *:80
secure 0
map Example *
}
</pre>



<p>Save and close the file, then restart the OpenLiteSpeed service to apply the changes:</p>



<pre class="wp-block-preformatted">systemctl restart lshttpd</pre>



<p>Open your browser and type the server IP address <code>http://your-ip-address</code> You should see the OpenLiteSpeed default page:</p>



<h2 id="h-"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20790%20333'%3E%3C/svg%3E" alt="" width="790" height="333" data-lazy-src="http://162.246.248.69/wp-content/uploads/2022/01/OpenLiteSpeed-1024x432.jpg"><noscript><img src="http://162.246.248.69/wp-content/uploads/2022/01/OpenLiteSpeed-1024x432.jpg" alt="" width="790" height="333"></noscript></h2>



<h2 id="h-step-3-create-openlitespeed-admin-user"><span class="ez-toc-section" id="Step-3-Create-OpenLiteSpeed-Admin-User"></span>Step 3: Create OpenLiteSpeed Admin User<span class="ez-toc-section-end"></span></h2>



<p>The OpenLiteSpeed server has an admin dashboard. To access it securely, you need to create an admin account and set a password:</p>



<pre class="wp-block-preformatted">/usr/local/lsws/admin/misc/admpass.sh</pre>



<p>Set your admin username and password as shown below:</p>



<pre class="wp-block-preformatted">Please specify the user name of administrator.
This is the user name required to login the administration Web interface.

User name [admin]: admin

Please specify the administrator's password.
This is the password required to login the administration Web interface.

Password: 
Retype password: 
Administrator's username/password is updated successfully!</pre>



<h2 id="h-step-4-install-and-configure-mariadb-server"><span class="ez-toc-section" id="Step-4-Install-and-Configure-MariaDB-Server"></span>Step 4: Install and Configure MariaDB Server<span class="ez-toc-section-end"></span></h2>



<p>Run the following command to install the latest MariaDB server from the official Ubuntu repositories:</p>



<pre class="wp-block-preformatted">apt install mariadb-server</pre>



<p>Once it is installed, start the MariaDB service and enable it to automatically start up after the server boots up:</p>



<pre class="wp-block-preformatted">systemctl start mariadb
systemctl enable mariadb</pre>



<p>After the installation is completed, you can improve the security of your MySQL server, by running the mysql_secure_installation script:</p>



<pre class="wp-block-preformatted">mysql_secure_installation</pre>



<p>To start the process, the command will ask you to enter the current MySQL root password. Just press the [Enter] key once, as there is no default password for MySQL.</p>



<h2 id="h-step-5-create-mariadb-database-and-user"><span class="ez-toc-section" id="Step-5-Create-MariaDB-Database-and-User"></span>Step 5: Create MariaDB Database and User<span class="ez-toc-section-end"></span></h2>



<p>Next, we need to create a database and user for the WordPress installation.</p>



<p>First, log in to MariaDB with the following command:</p>



<pre class="wp-block-preformatted">mysql -u root -p</pre>



<p>Once login, create a database and user with the following command:</p>



<pre class="wp-block-preformatted">MariaDB [(none)]&gt; CREATE DATABASE wpdb;
MariaDB [(none)]&gt; CREATE USER 'wpuser'@'localhost' IDENTIFIED BY 'PASSWORD';</pre>



<p><strong>Note:</strong> Don’t forget to replace ‘PASSWORD‘ with an actual, strong password.</p>



<p>Grant all the privileges to the WordPress database:</p>



<pre class="wp-block-preformatted">MariaDB [(none)]&gt; GRANT ALL ON wpdb.* TO 'wpuser'@'localhost' WITH GRANT OPTION;</pre>



<p>Flush the privileges and exit from the MariaDB with the following command:</p>



<pre class="wp-block-preformatted">MariaDB [(none)]&gt; FLUSH PRIVILEGES;
MariaDB [(none)]&gt; EXIT;</pre>



<h2 id="h-step-6-install-php-and-modules"><span class="ez-toc-section" id="Step-6-Install-PHP-and-Modules"></span>Step 6: Install PHP and Modules<span class="ez-toc-section-end"></span></h2>



<p>By default, OpenLiteSpeed is configured to use PHP&nbsp; 7.3. To install a newer PHP version along with all the necessary modules for WordPress, run the following command:</p>



<pre class="wp-block-preformatted">apt install lsphp80 lsphp80-mysql lsphp80-common lsphp80-curl lsphp80-imagick</pre>



<p>Next, you will need to configure OpenLiteSpeed to use PHP version 8.0 instead of 7.3. You can do it by editing the <strong>httpd_config.conf</strong> file:</p>



<pre class="wp-block-preformatted">nano /usr/local/lsws/conf/httpd_config.conf</pre>



<p>Find the following path <code>lsphp73/bin/lsphp</code>&nbsp; and replace it with the following path <code>lsphp80/bin/lsphp</code></p>



<p>Save and close the file, then restart the LiteSpeed service to apply the changes:</p>



<pre class="wp-block-preformatted">systemctl restart lshttpd</pre>



<h2 id="h-step-7-install-wordpress"><span class="ez-toc-section" id="Step-7-Install-WordPress"></span>Step 7: Install WordPress<span class="ez-toc-section-end"></span></h2>



<p>Let’s download the latest WordPress version from the official WordPress site:</p>



<pre class="wp-block-preformatted">wget -c http://wordpress.org/latest.tar.gz</pre>



<p>After downloading WordPress, extract it in the <strong><code>/usr/local/lsws/Example/html/</code></strong> directory with the following command:</p>



<pre class="wp-block-preformatted">tar xvzf latest.tar.gz -C /usr/local/lsws/Example/html/</pre>



<p>The WordPress files will be now placed in the <strong>wordpress</strong> directory at <strong>/usr/local/lsws/Example/html/wordpress</strong></p>



<p>We also need to set the correct permissions of this directory so our OpenLiteSpeed server can access the files in it:</p>



<pre class="wp-block-preformatted">chown -R nobody:nogroup /usr/local/lsws/Example/html/wordpress</pre>



<p>Next, run the following command to create a WordPress configuration file&nbsp; <strong><code>wp-config.php</code></strong> .</p>



<pre class="wp-block-preformatted">cd /usr/local/lsws/Example/html/wordpress
mv wp-config-sample.php wp-config.php</pre>



<p>Now open the <strong><code>wp-config.php</code></strong> file:</p>



<pre class="wp-block-preformatted">nano wp-config.php</pre>



<p>Then update the database settings, replacing <strong><code>database_name_here</code></strong>, <strong><code>username_here</code></strong> and <strong><code>password_here</code></strong> with your own details:</p>



<pre class="wp-block-preformatted">/** The name of the database for WordPress */
define('DB_NAME', 'database_name_here');

/** MySQL database username */
define('DB_USER', 'username_here');

/** MySQL database password */
define('DB_PASSWORD', 'password_here');

/** MySQL hostname */
define('DB_HOST', 'localhost');</pre>



<p>Go to the bottom section and you’ll see&nbsp; <code>/* That's all, stop editing! Happy blogging. */</code>. &nbsp;Add the following line below that line.</p>



<pre class="wp-block-preformatted">define('WP_ALLOW_MULTISITE', true);</pre>



<p>Save and exit the file.</p>



<h2 id="h-step-8-configure-openlitespeed"><span class="ez-toc-section" id="Step-8-Configure-OpenLiteSpeed"></span>Step 8: Configure OpenLiteSpeed<span class="ez-toc-section-end"></span></h2>



<p>First, open your favorite browser and browse to OpenLiteSpeed admin panel at: <code>https://your-ip-address:7080</code></p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1024" height="604" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20604'%3E%3C/svg%3E" alt="" class="wp-image-40201" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-login.jpg?v=1642412795 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-login-300x177.jpg?v=1642412795 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-login-150x88.jpg?v=1642412795 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-login-768x453.jpg?v=1642412795 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-login.jpg" /><noscript><img width="1024" height="604" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-login.jpg" alt="" class="wp-image-40201" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-login.jpg?v=1642412795 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-login-300x177.jpg?v=1642412795 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-login-150x88.jpg?v=1642412795 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-login-768x453.jpg?v=1642412795 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<p>Enter your admin username and password and click on the <strong>Login</strong> button. You should see the OpenLiteSpeed dashboard on the following page:</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1024" height="482" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20482'%3E%3C/svg%3E" alt="" class="wp-image-40202" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-dashboard.jpg?v=1642412854 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-dashboard-300x141.jpg?v=1642412854 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-dashboard-150x71.jpg?v=1642412854 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-dashboard-768x362.jpg?v=1642412854 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-dashboard.jpg" /><noscript><img width="1024" height="482" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-dashboard.jpg" alt="" class="wp-image-40202" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-dashboard.jpg?v=1642412854 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-dashboard-300x141.jpg?v=1642412854 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-dashboard-150x71.jpg?v=1642412854 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-dashboard-768x362.jpg?v=1642412854 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<p>Navigate to&nbsp;<strong>Virtual Hosts &gt; Example &gt; General</strong> and modify:</p>



<p><strong>Document Root</strong>:<code>$VH_ROOT/html/wordpress/</code><br><strong>Index Files</strong>: <code>index.html, index.php</code></p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1024" height="494" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20494'%3E%3C/svg%3E" alt="" class="wp-image-40203" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-virtualhost.jpg?v=1642412889 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-virtualhost-300x145.jpg?v=1642412889 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-virtualhost-150x72.jpg?v=1642412889 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-virtualhost-768x371.jpg?v=1642412889 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-virtualhost.jpg" /><noscript><img width="1024" height="494" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-virtualhost.jpg" alt="" class="wp-image-40203" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-virtualhost.jpg?v=1642412889 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-virtualhost-300x145.jpg?v=1642412889 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-virtualhost-150x72.jpg?v=1642412889 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-virtualhost-768x371.jpg?v=1642412889 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<p>Navigate to&nbsp;<strong> Virtual Hosts &gt; Example &gt; Rewrite </strong>and modify:</p>



<p><strong>Enable Rewrite</strong>:<code>Yes</code><br><strong>Auto Load from .htaccess</strong>: <code>Yes</code></p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1024" height="245" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20245'%3E%3C/svg%3E" alt="" class="wp-image-40204" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-rewrite.jpg?v=1642412920 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-rewrite-300x72.jpg?v=1642412920 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-rewrite-150x36.jpg?v=1642412920 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-rewrite-768x184.jpg?v=1642412920 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-rewrite.jpg" /><noscript><img width="1024" height="245" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-rewrite.jpg" alt="" class="wp-image-40204" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-rewrite.jpg?v=1642412920 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-rewrite-300x72.jpg?v=1642412920 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-rewrite-150x36.jpg?v=1642412920 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/OpenLiteSpeed-rewrite-768x184.jpg?v=1642412920 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<h2 id="h-step-9-enable-wordpress-multisite"><span class="ez-toc-section" id="Step-9-Enable-WordPress-Multisite"></span>Step 9: Enable WordPress Multisite<span class="ez-toc-section-end"></span></h2>



<p>To finish the WordPress installation, open your browser, navigate to: <code>https://your-ip-address</code> :</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1024" height="594" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20594'%3E%3C/svg%3E" alt="" class="wp-image-40205" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_1.jpg?v=1642412956 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_1-300x174.jpg?v=1642412956 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_1-150x87.jpg?v=1642412956 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_1-768x446.jpg?v=1642412956 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_1.jpg" /><noscript><img width="1024" height="594" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_1.jpg" alt="" class="wp-image-40205" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_1.jpg?v=1642412956 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_1-300x174.jpg?v=1642412956 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_1-150x87.jpg?v=1642412956 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_1-768x446.jpg?v=1642412956 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<p>Select your Language and click on the <strong>Continue</strong> button. You should see the following page:</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1024" height="657" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20657'%3E%3C/svg%3E" alt="" class="wp-image-40206" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_2.jpg?v=1642412988 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_2-300x192.jpg?v=1642412988 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_2-150x96.jpg?v=1642412988 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_2-768x493.jpg?v=1642412988 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_2.jpg" /><noscript><img width="1024" height="657" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_2.jpg" alt="" class="wp-image-40206" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_2.jpg?v=1642412988 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_2-300x192.jpg?v=1642412988 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_2-150x96.jpg?v=1642412988 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_2-768x493.jpg?v=1642412988 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<p>Provide your Site name, admin username, password, and click on the <strong>Install</strong> <strong>WordPress</strong> button. You should see the following page:</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1013" height="452" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201013%20452'%3E%3C/svg%3E" alt="" class="wp-image-40207" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_3.jpg?v=1642413019 1013w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_3-300x134.jpg?v=1642413019 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_3-150x67.jpg?v=1642413019 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_3-768x343.jpg?v=1642413019 768w" data-lazy-sizes="(max-width: 1013px) 100vw, 1013px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_3.jpg" /><noscript><img width="1013" height="452" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_3.jpg" alt="" class="wp-image-40207" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_3.jpg?v=1642413019 1013w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_3-300x134.jpg?v=1642413019 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_3-150x67.jpg?v=1642413019 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_3-768x343.jpg?v=1642413019 768w" sizes="(max-width: 1013px) 100vw, 1013px" /></noscript></figure></div>



<p>Click on the <strong>Login</strong> button. You will be redirected to the WordPress admin login page:</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1017" height="539" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201017%20539'%3E%3C/svg%3E" alt="" class="wp-image-40208" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_4.jpg?v=1642413052 1017w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_4-300x159.jpg?v=1642413052 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_4-150x79.jpg?v=1642413052 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_4-768x407.jpg?v=1642413052 768w" data-lazy-sizes="(max-width: 1017px) 100vw, 1017px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_4.jpg" /><noscript><img width="1017" height="539" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_4.jpg" alt="" class="wp-image-40208" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_4.jpg?v=1642413052 1017w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_4-300x159.jpg?v=1642413052 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_4-150x79.jpg?v=1642413052 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_4-768x407.jpg?v=1642413052 768w" sizes="(max-width: 1017px) 100vw, 1017px" /></noscript></figure></div>



<p>Once you log in, you will be taken to the WordPress administration dashboard:</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1024" height="557" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20557'%3E%3C/svg%3E" alt="" class="wp-image-40209" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_5.jpg?v=1642413081 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_5-300x163.jpg?v=1642413081 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_5-150x82.jpg?v=1642413081 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_5-768x418.jpg?v=1642413081 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_5.jpg" /><noscript><img width="1024" height="557" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_5.jpg" alt="" class="wp-image-40209" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_5.jpg?v=1642413081 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_5-300x163.jpg?v=1642413081 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_5-150x82.jpg?v=1642413081 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_5-768x418.jpg?v=1642413081 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<p>So you can enable WordPress multisite feature you should see an item, labeled <strong>Network Setup</strong>, under the <strong>Tools</strong> menu. Enter the required details, then Click <strong>Install.</strong></p>



<figure class="wp-block-image size-large"><img width="1024" height="561" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20561'%3E%3C/svg%3E" alt="" class="wp-image-40210" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_6-1024x561.jpg?v=1642413114 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_6-300x164.jpg?v=1642413114 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_6-150x82.jpg?v=1642413114 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_6-768x421.jpg?v=1642413114 768w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_6.jpg?v=1642413114 1228w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_6-1024x561.jpg?v=1642413114" /><noscript><img width="1024" height="561" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_6-1024x561.jpg?v=1642413114" alt="" class="wp-image-40210" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_6-1024x561.jpg?v=1642413114 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_6-300x164.jpg?v=1642413114 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_6-150x82.jpg?v=1642413114 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_6-768x421.jpg?v=1642413114 768w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_6.jpg?v=1642413114 1228w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p>The next page appears as shown below:</p>



<figure class="wp-block-image size-large"><img width="1024" height="483" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20483'%3E%3C/svg%3E" alt="" class="wp-image-40211" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_7-1024x483.jpg?v=1642413142 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_7-300x141.jpg?v=1642413142 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_7-150x71.jpg?v=1642413142 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_7-768x362.jpg?v=1642413142 768w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_7-1536x724.jpg?v=1642413142 1536w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_7-1320x622.jpg?v=1642413142 1320w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_7.jpg?v=1642413142 1895w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_7-1024x483.jpg?v=1642413142" /><noscript><img width="1024" height="483" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_7-1024x483.jpg?v=1642413142" alt="" class="wp-image-40211" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_7-1024x483.jpg?v=1642413142 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_7-300x141.jpg?v=1642413142 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_7-150x71.jpg?v=1642413142 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_7-768x362.jpg?v=1642413142 768w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_7-1536x724.jpg?v=1642413142 1536w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_7-1320x622.jpg?v=1642413142 1320w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_7.jpg?v=1642413142 1895w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure>



<p>Add the following to your <code>wp-config.php</code> file in <code>/usr/local/lsws/Example/html/wordpress/</code> <strong>above</strong> the line reading <code>/* That’s all, stop editing! Happy publishing. */</code>:</p>



<pre class="wp-block-preformatted">define( 'MULTISITE', true );
define( 'SUBDOMAIN_INSTALL', false );
define( 'DOMAIN_CURRENT_SITE', '192.168.2.131' );
define( 'PATH_CURRENT_SITE', '/' );
define( 'SITE_ID_CURRENT_SITE', 1 );
define( 'BLOG_ID_CURRENT_SITE', 1 );</pre>



<p>Replace all the lines to your <code>.htaccess</code> file in the <code>/usr/local/lsws/Example/html/wordpress/</code> directory:</p>



<pre class="wp-block-preformatted">RewriteEngine On
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]</pre>



<p>Log into your WordPress Admin Dashboard once again.</p>



<p>Go to <strong>My</strong> <strong>Sites</strong> &gt; <strong>Network</strong> <strong>Admin</strong> &gt; Click <strong>Dashboard</strong> as shown below:</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="854" height="445" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20854%20445'%3E%3C/svg%3E" alt="" class="wp-image-40212" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_8.jpg?v=1642413174 854w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_8-300x156.jpg?v=1642413174 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_8-150x78.jpg?v=1642413174 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_8-768x400.jpg?v=1642413174 768w" data-lazy-sizes="(max-width: 854px) 100vw, 854px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_8.jpg" /><noscript><img width="854" height="445" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_8.jpg" alt="" class="wp-image-40212" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_8.jpg?v=1642413174 854w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_8-300x156.jpg?v=1642413174 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_8-150x78.jpg?v=1642413174 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_8-768x400.jpg?v=1642413174 768w" sizes="(max-width: 854px) 100vw, 854px" /></noscript></figure></div>



<p>At the network multisite dashboard, Click <strong>Create New Site</strong> to start creating your new site:</p>



<div class="wp-block-image"><figure class="aligncenter size-large"><img width="1024" height="514" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20514'%3E%3C/svg%3E" alt="" class="wp-image-40213" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_9-1024x514.jpg?v=1642413214 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_9-300x151.jpg?v=1642413214 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_9-150x75.jpg?v=1642413214 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_9-768x386.jpg?v=1642413214 768w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_9.jpg?v=1642413214 1067w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_9-1024x514.jpg?v=1642413214" /><noscript><img width="1024" height="514" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_9-1024x514.jpg?v=1642413214" alt="" class="wp-image-40213" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_9-1024x514.jpg?v=1642413214 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_9-300x151.jpg?v=1642413214 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_9-150x75.jpg?v=1642413214 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_9-768x386.jpg?v=1642413214 768w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_9.jpg?v=1642413214 1067w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<p>Then enter details of your new site:</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="971" height="546" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20971%20546'%3E%3C/svg%3E" alt="" class="wp-image-40214" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_10.jpg?v=1642413243 971w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_10-300x169.jpg?v=1642413243 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_10-150x84.jpg?v=1642413243 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_10-768x432.jpg?v=1642413243 768w" data-lazy-sizes="(max-width: 971px) 100vw, 971px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_10.jpg" /><noscript><img width="971" height="546" src="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_10.jpg" alt="" class="wp-image-40214" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_10.jpg?v=1642413243 971w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_10-300x169.jpg?v=1642413243 300w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_10-150x84.jpg?v=1642413243 150w, https://www.rosehosting.com/blog/wp-content/uploads/2022/01/wordpress_10-768x432.jpg?v=1642413243 768w" sizes="(max-width: 971px) 100vw, 971px" /></noscript></figure></div>



<p>Congratulations! WordPress multisite has been successfully installed on your server. Now, you can create as many sites as you want.</p>



<p>Of course, you don’t have to install WordPress multisite with OpenLiteSpeed server on Ubuntu 20.04, if you use one of our <a href="https://www.rosehosting.com/wordpress-hosting.html">Optimized WordPress Hosting</a> services, in which case you can simply ask our expert system administrators to install WordPress multisite with OpenLiteSpeed server on Ubuntu 20.04 for you. They are available 24×7 and will take care of your request immediately.</p>



<p><strong>PS</strong>. If you liked this post on <strong>how to install WordPress multisite with OpenLiteSpeed server on Ubuntu 20.04</strong>, please share it with your friends on the social networks using the share shortcuts below, or simply leave a comment in the comments section. Thanks.</p>
		</div>

				<footer class="entry-meta" aria-label="Entry meta">
			<span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://www.rosehosting.com/blog/category/cms-crm-erp/" rel="category tag">CMS, CRM, ERP</a>, <a href="https://www.rosehosting.com/blog/category/tutorials/" rel="category tag">Tutorials</a></span> 		<nav id="nav-below" class="post-navigation" aria-label="Single Post">
			<span class="screen-reader-text">Post navigation</span>

			<div class="nav-previous"><span class="prev" title="Previous"><a href="https://www.rosehosting.com/blog/how-to-install-nginx-on-whm-cpanel-with-engintron/" rel="prev">How to Install Nginx on WHM/cPanel With Engintron</a></span></div>		</nav>
				</footer>
			</div>
</article>

			<div class="comments-area">
				<div id="comments">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/how-to-install-wordpress-multisite-with-openlitespeed-on-ubuntu-20-04/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.rosehosting.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea autocomplete="new-password"  id="e42af3c480"  name="e42af3c480"   cols="45" rows="8" required></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0 !important;clip:rect(1px, 1px, 1px, 1px) !important;position:absolute !important;white-space:nowrap !important;height:1px !important;width:1px !important;overflow:hidden !important;" tabindex="-1"></textarea><script type="rocketlazyloadscript" data-noptimize data-rocket-type="text/javascript">document.getElementById("comment").setAttribute( "id", "a2880232904a64a026ac594af1a97351" );document.getElementById("e42af3c480").setAttribute( "id", "comment" );</script></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" required />
<label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" required />
<label for="url" class="screen-reader-text">Website</label><input placeholder="Website" id="url" name="url" type="url" value="" size="30" />
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="cptch_block"><span class="cptch_title cptch_to_remove">To prove you are human please solve the following<span class="required"> *</span></span><span class="cptch_wrap cptch_math_actions">
				<label class="cptch_label" for="cptch_input_41"><span class="cptch_span"><input id="cptch_input_41" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span>
					<span class="cptch_span">&nbsp;&#43;&nbsp;</span>
					<span class="cptch_span">&#110;&#105;&#110;e</span>
					<span class="cptch_span">&nbsp;=&nbsp;</span>
					<span class="cptch_span">&#116;en</span>
					<input type="hidden" name="cptch_result" value="IQ8=" /><input type="hidden" name="cptch_time" value="1644952244" />
					<input type="hidden" name="cptch_form" value="wp_comments" />
				</label><span class="cptch_reload_button_wrap hide-if-no-js">
					<noscript>
						<style type="text/css">
							.hide-if-no-js {
								display: none !important;
							}
						</style>
					</noscript>
					<span class="cptch_reload_button dashicons dashicons-update"></span>
				</span></span></p><p class="comment-form-mailpoet">
      <label for="mailpoet_subscribe_on_comment">
        <input
          type="checkbox"
          id="mailpoet_subscribe_on_comment"
          value="1"
          name="mailpoet[subscribe_on_comment]"
        />&nbsp;Yes, add me to your new blog post notifications list
      </label>
    </p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='40200' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
			</div>

					</main>
	</div>

	<div class="widget-area sidebar is-right-sidebar grid-30 tablet-grid-30 grid-parent" id="right-sidebar">
	<div class="inside-right-sidebar">
		<aside id="categories-3" class="widget inner-padding widget_categories"><h2 class="widget-title">Categories</h2><form action="https://www.rosehosting.com/blog" method="get"><label class="screen-reader-text" for="cat">Categories</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="1709">Caching&nbsp;&nbsp;(23)</option>
	<option class="level-0" value="1699">CentOS&nbsp;&nbsp;(303)</option>
	<option class="level-0" value="1710">CMS, CRM, ERP&nbsp;&nbsp;(233)</option>
	<option class="level-0" value="1708">Control Panels&nbsp;&nbsp;(48)</option>
	<option class="level-0" value="1702">Databases&nbsp;&nbsp;(107)</option>
	<option class="level-0" value="1700">Debian&nbsp;&nbsp;(160)</option>
	<option class="level-0" value="1711">E-Commerce&nbsp;&nbsp;(63)</option>
	<option class="level-0" value="1706">Email Servers&nbsp;&nbsp;(37)</option>
	<option class="level-0" value="1236">Guides&nbsp;&nbsp;(59)</option>
	<option class="level-0" value="1705">Load Balancing&nbsp;&nbsp;(5)</option>
	<option class="level-0" value="1">Miscellaneous&nbsp;&nbsp;(52)</option>
	<option class="level-0" value="1701">Networking and Domains&nbsp;&nbsp;(42)</option>
	<option class="level-0" value="3">News&nbsp;&nbsp;(12)</option>
	<option class="level-0" value="1704">Optimization&nbsp;&nbsp;(21)</option>
	<option class="level-0" value="1713">Other&nbsp;&nbsp;(6)</option>
	<option class="level-0" value="4">RoseHosting Platform&nbsp;&nbsp;(47)</option>
	<option class="level-0" value="5">Scripts&nbsp;&nbsp;(11)</option>
	<option class="level-0" value="1703">Security&nbsp;&nbsp;(105)</option>
	<option class="level-0" value="606">SEO&nbsp;&nbsp;(2)</option>
	<option class="level-0" value="21">Tips and Tricks&nbsp;&nbsp;(77)</option>
	<option class="level-0" value="13">Tutorials&nbsp;&nbsp;(826)</option>
	<option class="level-0" value="1698">Ubuntu&nbsp;&nbsp;(396)</option>
	<option class="level-0" value="1712">Web Frameworks&nbsp;&nbsp;(113)</option>
	<option class="level-0" value="1707">Web Servers&nbsp;&nbsp;(141)</option>
</select>
</form>
<script type="rocketlazyloadscript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</aside><aside id="custom_html-8" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a target="_blank" href="https://www.rosehosting.com/about-us.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">About RoseHosting</a><br>
<a target="_blank" href="https://www.rosehosting.com/linux-vps-hosting/" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Buy a Managed VPS - 25% OFF</a><br>
<a target="_blank" href="https://www.rosehosting.com/reviews.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">RoseHosting Customer Reviews</a><br>
<a target="_blank" href="https://www.rosehosting.com/nvme-hosting.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Managed NVMe VPSes</a><br>
	<a target="_blank" href="https://www.rosehosting.com/dedicated-servers.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Managed NVMe Dedicated Servers</a>
</div></aside><aside id="search-3" class="widget inner-padding widget_search"><form method="get" class="search-form" action="https://www.rosehosting.com/blog/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:">
	</label>
	<input type="submit" class="search-submit" value="Search"></form>
</aside>	</div>
</div>
</div>

  <!-- footer-big-menu.html -->
  <footer class="footer-big-menu">
    <div class="container" style="max-width: 1100px;">

      <div class="row menu">

        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title mb-2">Company</h3>
            <a class="menu-link" href="https://www.rosehosting.com/about-us.html">About us</a>
            <a class="menu-link" href="https://www.rosehosting.com/policies.html">Our Policies</a>
            <a class="menu-link" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
            <a class="menu-link" href="https://www.rosehosting.com/blog/">Blog</a>
            <a class="menu-link" href="https://www.rosehosting.com/why-rosehosting.html">Why RoseHosting</a>
            <a class="menu-link" href="https://www.rosehosting.com/compare-to-competition.html">Compare Us</a>
            <a class="menu-link" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
            <a class="menu-link" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
            <a class="menu-link" href="/recommended-tools-and-services.html">Recommended Services</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Support</h3>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Helpdesk System</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>

          <h3 class="menu-title  mb-2 mt-4">Other Services</h3>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Domain Registration</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Domain Transfer</a>
          <a class="menu-link" href="https://www.rosehosting.com/ssl-certificates.html">SSL Certificates</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/linux-vps-hosting/">Linux VPS Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/managed-cloud-hosting.html">Cloud Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom SSD VPS</a>
          <a class="menu-link" href="https://www.rosehosting.com/dedicated-servers.html">Dedicated Servers</a>
          <a class="menu-link" href="https://www.rosehosting.com/hosting-solutions.html">Hosting Solutions</a>
          <a class="menu-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Recurr. Affiliate Program</a>
          <a class="menu-link" href="https://www.rosehosting.com/cpa-hosting-affiliate-program.html">CPA Affiliate Program</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Linux VPS Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/centos-hosting.html">CentOS Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/ubuntu-hosting.html">Ubuntu Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/debian-hosting.html">Debian Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/opensuse-hosting.html">OpenSUSE Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/arch-linux-hosting.html">Arch-Linux Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/scientific-linux-hosting.html">Scientific Linux Hosting</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Apps Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/wordpress-hosting.html">WordPress Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/magento-hosting.html">Magento Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/odoo-hosting.html">Odoo Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/joomla-hosting.html">Joomla Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/drupal-hosting.html">Drupal Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/laravel-hosting.html">Laravel Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/nextcloud-hosting.html">NextCloud Hosting</a>

          <a class="menu-link" href="https://www.rosehosting.com/prestashop-hosting.html">PrestaShop Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/ghost-hosting.html">Ghost Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/mediawiki-hosting.html">MediaWiki Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/tomcat-hosting.html">Tomcat Hosting</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title mb-2">Contact Us</h3>
          <a class="menu-link" href="tel:+18887673467">(888) ROSE-HOST</a>
          <a class="menu-link" href="tel:+18887673467">(888) 767-3467</a>
          <a class="menu-link" href="tel:+13142750414">(314) 275-0414</a>
          <a class="menu-link" href="mailto:%73%75%70%70%6f%72%74%40%72%6f%73%65%68%6f%73%74%69%6e%67%2e%63%6f%6d">Email us</a>

          <h3 class="menu-title mb-2 mt-4">Connect</h3>
          <a class="menu-link" href="https://twitter.com/rosehosting" target="_blank"><i class="fa fa-twitter fa-fw"></i> Twitter</a>
          <a class="menu-link" href="https://www.facebook.com/RoseHosting" target="_blank"><i class="fa fa-facebook fa-fw"></i> Facebook</a>
          <a class="menu-link" href="https://www.linkedin.com/in/rosehosting/" target="_blank"><i class="fa fa-linkedin fa-fw"></i> LinkedIn</a>
          <a class="menu-link" href="https://www.rosehosting.com/blog/feed/" target="_blank"><i class="fa fa-rss fa-fw"></i> RSS Feed</a>

        </div>

      </div>

    </div>

<br>
    <div class="bottom">
      <div class="container" style="max-width: 1100px;">
        <div class="row">

          <div class="col-md-12 col-lg-6">
              <p class="text-sm-left"><a class="inline-link footer-policy" href="/tos.html">Terms of Service</a> and <a class="inline-link footer-policy" href="/policies.html">other policies</a></p>
          </div>
          <div class="col-md-12 col-lg-6">
            <p class="text-sm-right">&copy; 2001-2022 <a class="inline-link footer-policy" href="https://www.rosewebservices.com/">Rose Web Services LLC</a>.</p>
          </div>
         </div>
      </div>
    </div>

<!-- livezilla.net code
<script type="rocketlazyloadscript" data-rocket-type="text/javascript" id="aff1f81b02f303eea5f87a3a065f153a" src="https://linuxhostsupport.com/chat//script.php?id=aff1f81b02f303eea5f87a3a065f153a"></script>
http://www.livezilla.net -->

<script type="rocketlazyloadscript" id="generate-a11y">!function(){"use strict";if("querySelector"in document&&"addEventListener"in window){var e=document.body;e.addEventListener("mousedown",function(){e.classList.add("using-mouse")}),e.addEventListener("keydown",function(){e.classList.remove("using-mouse")})}}();</script><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><script id='advanced-ads-pro/cache_busting-js-extra'>
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":"","wp_timezone_offset":"-21600"};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/advanced-ads-pro/assets/js/base.min.js?ver=2.16.0' id='advanced-ads-pro/cache_busting-js' defer></script>
<script id='advanced-ads-layer-footer-js-js-extra'>
var advanced_ads_layer_settings = {"layer_class":"rhad-layer","placements":["20th-anniversary-sale-popup"]};
</script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/advanced-ads-layer/public/assets/js/layer.js?ver=1644445278' id='advanced-ads-layer-footer-js-js' defer></script>
<script type="rocketlazyloadscript" id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script id='rocket-preload-links-js-extra'>
var RocketPreloadLinksConfig = {"excludeUris":"\/blog(\/quiz\/github\/|\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$))|\/wp-admin\/|\/logout\/|\/wp-login.php","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/www.rosehosting.com\/blog","onHoverDelay":"100","rateThrottle":"3"};
</script>
<script type="rocketlazyloadscript" id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/advanced-ads-pro/assets/js/advanced-ads-pro.min.js?ver=2.16.0' id='advanced-ads-pro/front-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/themes/rh2022/js/theme.js?ver=1644445278' id='theme-js' defer></script>
<!--[if lte IE 11]>
<script src='https://www.rosehosting.com/blog/wp-content/themes/generatepress/assets/js/classList.min.js?ver=3.1.3' id='generate-classlist-js'></script>
<![endif]-->
<script id='generate-menu-js-extra'>
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/themes/generatepress/assets/js/menu.min.js?ver=3.1.3' id='generate-menu-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-includes/js/comment-reply.min.js?ver=5.9' id='comment-reply-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/js/social-icons-widget-frontend.js?ver=1644445278' id='zoom-social-icons-widget-frontend-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/smooth-scroll/jquery.smooth-scroll.min.js?ver=2.2.0' id='jquery-smooth-scroll-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/js-cookie/js.cookie.min.js?ver=2.2.1' id='js-cookie-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/sticky-kit/jquery.sticky-kit.min.js?ver=1.9.2' id='jquery-sticky-kit-js' defer></script>
<script id='ez-toc-js-js-extra'>
var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"","width":"95%","scroll_offset":"30"};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/assets/js/front.min.js?ver=2.0.17-1616779681' id='ez-toc-js-js' defer></script>
<script id='cptch_front_end_script-js-extra'>
var cptch_vars = {"nonce":"79f30f9b50","ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","enlarge":"","time_limit":"120"};
</script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/captcha-bws/js/front_end_script.js?ver=1644445278' id='cptch_front_end_script-js' defer></script>
<!--noptimize--><script type="rocketlazyloadscript">window.advads_admin_bar_items = [{"title":"20th anniversary sale popup","type":"placement"}];</script><!--/noptimize--><!--noptimize--><script type="rocketlazyloadscript">window.advads_ajax_queries = [{"id":"before-content","method":"placement","params":{"placement_position":"center","previous_method":"placement","previous_id":"before-content","post":"r0","url_parameter":"\/blog\/how-to-install-wordpress-multisite-with-openlitespeed-on-ubuntu-20-04\/","placement_type":"post_top","output":{"class":["rhad-before-content"],"placement_id":"before-content"}},"elementid":"rhad-cd6b16339d04548c2e7964d5d495916d","blog_id":1}];
window.advads_ajax_queries_args = {"r0":{"id":40200,"author":"4","post_type":"post"}};
( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( !window.advanced_ads_pro ) {console.log("Advanced Ads Pro: cache-busting can not be initialized");} });</script><!--/noptimize--><!--noptimize--><script type="rocketlazyloadscript">!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><!--/noptimize--><script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.rosehosting.com/blog/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script>
</body>
</html>

<!-- Cached for great performance - Debug: cached@1644952244 -->