<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US"
	prefix="og: http://ogp.me/ns#" >
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US"
	prefix="og: http://ogp.me/ns#" >
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US"
	prefix="og: http://ogp.me/ns#" >
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="pingback" href="https://www.rosehosting.com/blog/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://www.rosehosting.com/blog/wp-content/themes/Extra/scripts/ext/html5.js?x68100&amp;x68100" defer='defer" type="text/javascript"></script>
	<![endif]-->
<script async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KVJ4PJ');</script>

<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<script>var et_site_url='https://www.rosehosting.com/blog';var et_post_id='29935';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>How to Use a Private Key and PuTTY to Log into Your Server Securely | RoseHosting</title>

<meta name="description" content="With security becoming increasingly important in today&#039;s modern world of information theft and privacy concerns, keeping your server safe and secure has almost" />
<link rel="canonical" href="https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/" />
<meta property="og:title" content="How to Use a Private Key and PuTTY to Log into Your Server Securely | RoseHosting" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/" />
<meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2019/02/putty-login-security.jpg" />
<meta property="og:site_name" content="RoseHosting.com Blog" />
<meta property="og:description" content="With security becoming increasingly important in today&#039;s modern world of information theft and privacy concerns, keeping your server safe and secure has almost become a necessity. While several" />
<meta property="article:tag" content="security" />
<meta property="article:tag" content="tutorials" />
<meta property="article:tag" content="private key" />
<meta property="article:tag" content="putty" />
<meta property="article:tag" content="ssh" />
<meta property="article:publisher" content="https://www.facebook.com/RoseHosting/" />
<meta property="article:author" content="https://www.facebook.com/RoseHosting/" />
<meta property="article:published_time" content="2019-06-10T18:25:45Z" />
<meta property="article:modified_time" content="2019-06-10T18:25:45Z" />
<meta property="og:image:secure_url" content="https://www.rosehosting.com/blog/wp-content/uploads/2019/02/putty-login-security.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@RoseHosting" />
<meta name="twitter:creator" content="@rosehosting" />
<meta name="twitter:title" content="How to Use a Private Key and PuTTY to Log into Your Server Securely |" />
<meta name="twitter:description" content="With security becoming increasingly important in today&#039;s modern world of information theft and privacy concerns, keeping your server safe and secure has almost become a necessity. While several" />
<meta name="twitter:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2019/02/putty-login-security.jpg" />

<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Feed" href="https://www.rosehosting.com/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Comments Feed" href="https://www.rosehosting.com/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; How to Use a Private Key and PuTTY to Log into Your Server Securely Comments Feed" href="https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.rosehosting.com\/blog\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><meta content="rh2018 Template:       Extra Version:        1.0.0 v." name="generator" /><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.rosehosting.com/blog/wp-includes/css/dist/block-library/style.min.css?x68100&amp;x68100' type='text/css' media='all' />
<link rel='stylesheet' id='ez-icomoon-css' href='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/icomoon/style.min.css?x68100&amp;x68100' type='text/css' media='all' />
<link rel='stylesheet' id='ez-toc-css' href='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/assets/css/screen.min.css?x68100&amp;x68100' type='text/css' media='all' />
<style id='ez-toc-inline-css' type='text/css'>
div#ez-toc-container p.ez-toc-title {font-size: 22px;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}div#ez-toc-container {width: 100%;}
</style>
<link rel='stylesheet' id='parent-style-css' href='https://www.rosehosting.com/blog/wp-content/themes/Extra/style.css?x68100&amp;x68100' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css' href='https://www.rosehosting.com/blog/wp-content/themes/rh2018/css/bootstrap.css?x68100&amp;x68100' type='text/css' media='all' />
<link rel='stylesheet' id='theme-style-css' href='https://www.rosehosting.com/blog/wp-content/themes/rh2018/css/theme.css?x68100&amp;x68100' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css' href='https://www.rosehosting.com/blog/wp-content/themes/rh2018/style.css?x68100&amp;x68100' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://www.rosehosting.com/blog/wp-includes/css/dashicons.min.css?x68100&amp;x68100' type='text/css' media='all' />
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery.js?x68100&amp;x68100'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery-migrate.min.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/popper.js/1.11.0/umd/popper.min.js' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2018/js/bootstrap.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2018/js/cookieconsent.min.js?x68100&amp;x68100' defer='defer'></script>
<link rel='https://api.w.org/' href='https://www.rosehosting.com/blog/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rosehosting.com/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rosehosting.com/blog/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='How to Install WildFly on Ubuntu 18.04' href='https://www.rosehosting.com/blog/how-to-install-wildfly-on-ubuntu-18-04/' />
<meta name="generator" content="WordPress 5.2.1" />
<link rel='shortlink' href='https://www.rosehosting.com/blog/?p=29935' />
<link rel="alternate" type="application/json+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-use-a-private-key-and-putty-to-log-into-your-server-securely%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-use-a-private-key-and-putty-to-log-into-your-server-securely%2F&#038;format=xml" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" />
<script type="text/javascript">var essb_settings = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","essb3_nonce":"0ed63e6ab6","essb3_plugin_url":"https:\/\/www.rosehosting.com\/blog\/wp-content\/plugins\/easy-social-share-buttons3","essb3_stats":false,"essb3_ga":false,"essb3_ga_mode":"simple","blog_url":"https:\/\/www.rosehosting.com\/blog\/","essb3_postfloat_stay":false,"post_id":29935};var essb_buttons_exist = !!document.getElementsByClassName("essb_links"); if(essb_buttons_exist == true) { document.addEventListener("DOMContentLoaded", function(event) { var ESSB_CACHE_URL = "https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/"; if(ESSB_CACHE_URL.indexOf("?") > -1) { ESSB_CACHE_URL += "&essb_counter_cache=rebuild"; } else { ESSB_CACHE_URL += "?essb_counter_cache=rebuild"; }; var xhr = new XMLHttpRequest(); xhr.open("GET",ESSB_CACHE_URL,true); xhr.send(); });}</script><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-270x270.png" />
<link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://www.rosehosting.com/blog/wp-content/cache/et/global/et-extra-customizer-global-15602705388448.min.css?x68100" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /></head>
<body class="post-template-default single single-post postid-29935 single-format-standard et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
<div id="page-container" class="page-container">
<nav class="navbar yamm navbar-expand-lg navbar-dark" role="navigation">
<div class="container no-override">
<a class="navbar-brand" href="https://www.rosehosting.com/">
<img alt="RoseHosting.com" width="186" height="37" class="d-lg-inline mr-2" src="https://www.rosehosting.com/blog/wp-content/themes/rh2018/img/rh-logo.svg" />
</a>
<button class="navbar-toggler" data-toggle="collapse" data-target="#navbar-collapse">
<span class="navbar-toggler-icon"></span>
</button>
<div class="collapse navbar-collapse justify-content-end" id="navbar-collapse">
<ul class="navbar-nav">
<li class="nav-item active dropdown">
<a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
Hosting Solutions
<i class="fa fa-chevron-down"></i>
</a>
<div class="dropdown-menu" role="menu">
<div class="yamm-content">
<div class="row">
<div class="col-sm-6">
<span class="text-primary  dropdown-header"><strong>Managed SSD Hosting</strong></span>
<div class="dropdown-divider"></div>
<a class="dropdown-item" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
<a class="dropdown-item" href="https://www.rosehosting.com/linux-vps-hosting.html">Linux VPS Hosting</a>
<a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom VPS</a>
<a class="dropdown-item" href="https://www.rosehosting.com/dedicated-servers.html">Cloud Dedicated Servers</a>
<a class="dropdown-item" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting <span class="ml-2 badge badge-success">new</span></a>
</div>
<div class="col-sm-6">
<span class="text-primary dropdown-header"><strong>Managed Solutions</strong></span>
<div class="dropdown-divider"></div>
<a class="dropdown-item" href="https://www.rosehosting.com/wordpress-hosting.html">
Wordpress Hosting
<small class="d-block text-muted"><i>The best blogging platform</i></small>
</a>
<a class="dropdown-item" href="https://www.rosehosting.com/magento-hosting.html">
Magento Hosting
<small class="d-block text-muted"><i>The best e-commerce platform</i></small>
</a>
<a class="dropdown-item" href="https://www.rosehosting.com/odoo-hosting.html">
Odoo Hosting
<small class="d-block text-muted"><i>The best CRM/ERP platform</i></small>
</a>
<span class="dropdown-item"><a class="btn-shadow btn-shadow-primary btn-shadow-sm" target="_blank" href="https://www.rosehosting.com/hosting-solutions.html">Other Solutions</a></span>
</div>
</div>
</div>
</div>
</li>
<li class="nav-item dropdown">
<a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
SSL / Domains
<i class="fa fa-chevron-down"></i>
</a>
<div class="dropdown-menu" role="menu">
<div class="yamm-content">
<div class="row">
<div class="col-sm-3">
<span class="text-primary  dropdown-header"><strong>SSL by brand</strong></span>
<div class="dropdown-divider"></div>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#geotrust">GeoTrust</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#comodo">Comodo</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#rapidssl">RapidSSL</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#thawte">Thawte</a>
</div>
<div class="col-sm-4">
<span class="text-primary  dropdown-header"><strong>SSL by Type</strong></span>
<div class="dropdown-divider"></div>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#domain_validation">Domain Validation</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#organization_validation">Organization Validation</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#extended_validation">Extended Validation</a>
<a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#wildcard_ssl">Wildcard SSL</a>
</div>
<div class="col-sm-3">
<span class="text-primary dropdown-header"><strong>Domains</strong></span>
<div class="dropdown-divider"></div>
<a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Register Domains</a>
<a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Transfer Domains</a>
</div>
</div>
</div>
</div>
<li class="nav-item dropdown">
<a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
Support
<i class="fa fa-chevron-down"></i>
</a>
<div class="dropdown-menu" role="menu">
<a class="dropdown-item" href="https://www.rosehosting.com/support.html">24/7 Managed Support</a>
<a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Open a Support Ticket</a>
<a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>
<a class="dropdown-item" href="https://status.rosehosting.com">Systems Status</a>
</div>
</li>
<li class="nav-item dropdown">
<a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
About Us
<i class="fa fa-chevron-down"></i>
</a>
<div class="dropdown-menu" role="menu">
<a class="dropdown-item" href="https://www.rosehosting.com/about-us.html">Our Company</a>
<a class="dropdown-item" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
<a class="dropdown-item" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
<a class="dropdown-item" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
<a class="dropdown-item" href="https://www.rosehosting.com/policies.html">Our Policies</a>
</div>
</li>
<li class="nav-item">
<a class="nav-link" href="https://www.rosehosting.com/blog/">Blog</a>
</li>
<li class="nav-item">
<a class="nav-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Affiliates</a>
</li>
<li class="nav-item">
<a class="nav-link nav-link--rounded" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Login</a>
</li>
</ul>
</div>
</div>
</nav>
<nav class="navbar navbar-expand-md navbar-light bg-faded navbar-blog" style="z-index:1029;">
<div class="container no-override">
<a href="https://www.rosehosting.com/blog/" class="navbar-brand">Blog Home</a>
<div class="navbar-collapse collapse d-flex justify-content-between" id="navbar5-blog">
<ul class="navbar-nav categories">
<li class="nav-item dropdown">
<a class="nav-link dropdown-toggle" data-toggle="dropdown" href="#" role="button" aria-haspopup="true" aria-expanded="false">
Categories
<i class="fa fa-chevron-down"></i>
</a>
<div class="dropdown-menu">
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/caching/">Caching</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/centos/">CentOS</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/cms-crm-erp/">CMS, CRM, ERP</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/control-panels/">Control Panels</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/databases/">Databases</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/debian/">Debian</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/e-commerce/">E-Commerce</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/email-servers/">Email Servers</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/guides/">Guides</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/load-balancing/">Load Balancing</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/miscellaneous/">Miscellaneous</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/networking-and-domains/">Networking and Domains</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/news/">News</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/optimization/">Optimization</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/other/">Other</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/rosehosting/">RoseHosting Platform</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/scripts/">Scripts</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/security/">Security</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/seo/">SEO</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tips-and-tricks/">Tips and Tricks</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tutorials/">Tutorials</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/ubuntu/">Ubuntu</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-frameworks/">Web Frameworks</a>
<a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-servers/">Web Servers</a>
</div>
</li>
</ul>
<form class="mx-2 my-auto d-inline" method="get" id="searchform" action="https://www.rosehosting.com/blog/">
<div class="input-group">
<input type="search" class="field" name="s" id="s" class="form-control border border-right-0" placeholder="Search...">
<span class="input-group-append">
<button name="submit" id="searchsubmit" class="btn btn-outline-secondary border border-left-0" type="submit">
<i class="fa fa-search"></i>
</button>
</span>
</div>
</form>
</div>
</div>
</nav>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<article id="post-29935" class="module single-post-module post-29935 post type-post status-publish format-standard has-post-thumbnail hentry category-security category-tutorials tag-private-key tag-putty tag-security tag-ssh et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">How to Use a Private Key and PuTTY to Log into Your Server Securely</h1>
<div class="post-meta vcard">
<p>Posted by <a href="https://www.rosehosting.com/blog/author/r0s3admin/" class="url fn" title="Posts by admin" rel="author">admin</a> | <span class="updated">Jun 10, 2019</span> | <a href="https://www.rosehosting.com/blog/category/security/" rel="tag">Security</a>, <a href="https://www.rosehosting.com/blog/category/tutorials/" rel="tag">Tutorials</a> | <a class="comments-link" href="https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a></p>
</div>
</div>
<div class="post-thumbnail header">
<img src="https://www.rosehosting.com/blog/wp-content/uploads/2019/02/putty-login-security.jpg" alt="How to Use a Private Key and PuTTY to Log into Your Server Securely" /> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<p><a href="https://www.rosehosting.com/blog/wp-content/uploads/2019/02/putty-login-security.jpg"><img class="alignnone size-full wp-image-29937" src="https://www.rosehosting.com/blog/wp-content/uploads/2019/02/putty-login-security.jpg" alt="Improve Login Security Using Private Keys and PuTTY" width="742" height="372" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2019/02/putty-login-security.jpg 742w, https://www.rosehosting.com/blog/wp-content/uploads/2019/02/putty-login-security-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2019/02/putty-login-security-300x150.jpg 300w" sizes="(max-width: 742px) 100vw, 742px" /></a></p>
<p>With security becoming increasingly important in today&#8217;s modern world of information theft and privacy concerns, keeping your server safe and secure has almost become a necessity. While several methods exist to properly secure your server, from using a long password to two-factor authentication, they can be quite a hassle to set up and use on a day-to-day basis. However, private keys offer a good balance between convenience and security.</p>
<p><span id="more-29935"></span></p>
<p class="p1"><span class="s1">In an earlier article, we saw how to <a href="https://www.rosehosting.com/blog/how-to-set-up-ssh-keys-on-ubuntu-16-04/">generate a private/public key pair</a></span><span class="s1">. We also saw that we need to use the &#8220;puttygen&#8221; tool to convert it into a format that&#8217;s accepted by a lot of software programs like WinSCP for SFTP access, and so on.</span></p>
<p class="p1"><span class="s1">In this article, we&#8217;ll show you how to use a private key to allow you to log into a server without the need for typing in a password. This comes with several benefits. In order to set up logging in using a private key on your server, you will have to have done the following first in order for this to work:</span></p>
<ol class="ol1">
<li class="li1"><span class="s1">Generated a private/public key pair on your server</span></li>
<li class="li1"><span class="s1">If via the command line, you&#8217;ve put your private key into the &#8220;authorized_keys&#8221; file</span></li>
<li class="li1"><span class="s1">You&#8217;ve downloaded your private key</span></li>
<li class="li1"><span class="s1">You&#8217;ve converted it to the &#8220;PPK&#8221; format</span></li>
</ol>
<p>This tutorial will be done on a <a href="https://www.rosehosting.com/vps-hosting.html">Linux VPS</a>.</p>
<div id="ez-toc-container" class="counter-hierarchy ez-toc-transparent">
<div class="ez-toc-title-container">
<p class="ez-toc-title">Table of Contents</p>
<span class="ez-toc-title-toggle"><a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a></span></div>
<nav><ul class="ez-toc-list"><li><a href="#Why-Not-Use-a-Password-Instead" title="Why Not Use a Password Instead?">Why Not Use a Password Instead?</a></li><li><a href="#Step-1-Downloading-PuTTY" title="Step 1: Downloading PuTTY">Step 1: Downloading PuTTY</a></li><li><a href="#Step-2-Configuring-Your-Credentials-with-PuTTY" title="Step 2: Configuring Your Credentials with PuTTY">Step 2: Configuring Your Credentials with PuTTY</a></li><li><a href="#Step-3-Specify-the-Private-Key" title="Step 3: Specify the Private Key">Step 3: Specify the Private Key</a></li></ul></nav></div>
<h2 class="p2"><span class="ez-toc-section" id="Why-Not-Use-a-Password-Instead"><span class="s1">Why Not Use a Password Instead?</span></span></h2>
<p class="p1"><span class="s1">When logging in via SSH, you can choose to use a password or a key file. Authentication usually hinges on one or more of three things:</span></p>
<ol class="ol1">
<li class="li1"><span class="s1">Something you <i>know</i></span></li>
<li class="li1"><span class="s1">Something you <i>have</i></span></li>
<li class="li1"><span class="s1">Something you <i>are</i></span></li>
</ol>
<p class="p1"><span class="s1">A password belongs to the first category &#8211; something you know. And something you know can also be known by other people. Something you know can also be guessed. In general, passwords are slowly being phased out for serious security applications &#8211; or at the very least, they&#8217;re being combined with other forms of authentication.</span></p>
<p class="p1"><span class="s1">Something you <i>have,</i> on the other hand, is a lot more difficult to fake. A private key on your local computer isn&#8217;t as vulnerable as a password. Passwords are also susceptible to &#8220;man-in-the-middle&#8221; attacks, where a hacker can intercept your password in plain text when you connect to the server and then use it whenever they want.</span></p>
<p class="p1"><span class="s1">A private key connection, however, <i>doesn&#8217;t</i> allow man-in-the-middle attacks. Your private key is never sent over the public network. By working through a complex sequence of cryptographic algorithms, SSH key authentication is completely safe from snooping.</span></p>
<p class="p1"><span class="s1">For these reasons, you want to use private key authentication whenever you can.</span></p>
<h2 class="p2"><span class="ez-toc-section" id="Step-1-Downloading-PuTTY"><span class="s1">Step 1: Downloading PuTTY</span></span></h2>
<p class="p1"><span class="s1">A prerequisite to using private keys to log in would be that you need to convert the private key you downloaded from your server into a &#8220;PPK&#8221; file for use with 3rd party programs. One such program is called PuTTY, and it&#8217;s something of a standard connection tool in the server world. You can <a href="https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html"><span class="s2">download it from here</span></a>, and grab the version that suits you best, like this:</span></p>
<div id="attachment_814" style="width: 636px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-814" class="size-full wp-image-814" src="https://linuxhostsupport.com/blog/wp-content/uploads/2019/02/Download-PuTTY.jpg" alt="Download PuTTY" width="626" height="369" /><p id="caption-attachment-814" class="wp-caption-text">Download PuTTY From their Website</p></div>
<p class="p1"><span class="s1">It&#8217;s a standalone program and doesn&#8217;t require any installation process. So once you download it, you can just run it and get started right away.</span></p>
<h2 class="p2"><span class="ez-toc-section" id="Step-2-Configuring-Your-Credentials-with-PuTTY"><span class="s1">Step 2: Configuring Your Credentials with PuTTY</span></span></h2>
<p class="p1"><span class="s1">To set up PuTTY, run the executable file and after the interface opens, click the &#8220;Sessions&#8221; tab on the left (it should be selected by default). Now enter your hostname and the port number. Normally the port number for SSH is 2222, but our test server is set to use a custom port to make it difficult for attackers to randomly make attempts to log in. Just replace 7022 from the screenshot below with the port number used by your server:</span></p>
<div id="attachment_815" style="width: 627px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-815" class="size-full wp-image-815" src="https://linuxhostsupport.com/blog/wp-content/uploads/2019/02/PuTTY-Initial-Configuration.jpg" alt="PuTTY Initial Configuration" width="617" height="524" /><p id="caption-attachment-815" class="wp-caption-text">Initial Setup of PuTTY</p></div>
<p class="p1"><span class="s1">If you&#8217;re hosting with a hosting provider that has a custom SSH port, make sure you check with them as to what their port is.</span></p>
<h2 class="p2"><span class="ez-toc-section" id="Step-3-Specify-the-Private-Key"><span class="s1">Step 3: Specify the Private Key</span></span></h2>
<p class="p1"><span class="s1">Now expand &#8220;SSH&#8221; on the left-hand side, and click &#8220;Auth&#8221;, as shown here:</span></p>
<div id="attachment_816" style="width: 637px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-816" class="size-full wp-image-816" src="https://linuxhostsupport.com/blog/wp-content/uploads/2019/02/Select-Private-Key.jpg" alt="Select Private Key" width="627" height="308" /><p id="caption-attachment-816" class="wp-caption-text">Select the Private Key from its Location</p></div>
<p class="p1"><span class="s1">Click &#8220;Browse&#8221; and navigate to the location of your private key. Select it (it should be in the .PPK format) and you&#8217;re done! Click &#8220;Open&#8221; and an SSH window should open up. Enter the user</span><span class="s1">name with which you generated your private key and if all goes well, it should log in like this:</span></p>
<div id="attachment_817" style="width: 1444px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-817" class="size-full wp-image-817" src="https://linuxhostsupport.com/blog/wp-content/uploads/2019/02/Logging-in-with-Private-Key.jpg" alt="Logging in With Private Key" width="1434" height="336" /><p id="caption-attachment-817" class="wp-caption-text">Logging in With Your Private Key</p></div>
<p class="p1"><span class="s1">And that&#8217;s it &#8211; you&#8217;ve successfully opened an SSH session with private key authentication using PuTTY.</span></p>
<hr />
<p>Of course, you don’t have to create and set up your private and public key pair on your Ubuntu 16.04 VPS if you use one of our <a href="https://www.rosehosting.com/vps-hosting.html">Linux VPS Hosting</a> services, in which case you can simply ask our expert Linux admins to set up the SSH keys for you. They are available 24&#215;7 and will take care of your request immediately.</p>
<p><span style="color: #ff0000;"><strong>PS</strong>.</span> If you liked this post, please share it with your friends on the social networks using the share shortcuts below, or simply leave a comment in the comments section. Thanks.</p>
<div class="essb_links essb_counters essb_displayed_followme essb_share essb_template_bold-retina essb_79793206 essb_links_center essb_mobile_hidden print-no" id="essb_displayed_followme_79793206" data-essb-postid="29935" data-essb-position="followme" data-essb-button-style="button_name" data-essb-template="bold-retina" data-essb-counter-pos="insidename" data-essb-url="https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/" data-essb-twitter-url="https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/" data-essb-instance="79793206"><ul class="essb_links_list essb_hide_icon"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-counter-pos="insidename"><span class="essb_totalcount essb_t_l" title="Total: "><span class="essb_total_text">Total: </span><span class="essb_t_nb">2</span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/&t=How+to+Use+a+Private+Key+and+PuTTY+to+Log+into+Your+Server+Securely" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/&t=How+to+Use+a+Private+Key+and+PuTTY+to+Log+into+Your+Server+Securely&#39;,&#39;facebook&#39;,&#39;79793206&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook<span class="essb_counter_insidename" data-cnt="2" data-cnt-short="2">2</span></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=How+to+Use+a+Private+Key+and+PuTTY+to+Log+into+Your+Server+Securely&amp;url=https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/&amp;counturl=https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/&#39;,&#39;twitter&#39;,&#39;79793206&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+to+Use+a+Private+Key+and+PuTTY+to+Log+into+Your+Server+Securely&amp;url=https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+to+Use+a+Private+Key+and+PuTTY+to+Log+into+Your+Server+Securely&amp;url=https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/&#39;,&#39;linkedin&#39;,&#39;79793206&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_print nolightbox"> <a href="#" title="" onclick="essb.print(&#39;79793206&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_print"></span><span class="essb_network_name">Print<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_mail nolightbox"> <a href="#" title="" onclick="essb_open_mailform(&#39;79793206&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_mail"></span><span class="essb_network_name">Email<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li></ul></div> </div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
</div>
<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #00a8ff;
									}
								</style>
</div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="https://www.rosehosting.com/blog/how-to-install-wildfly-on-ubuntu-18-04/" rel="prev"><span class="button">Previous</span><span class="title">How to Install WildFly on Ubuntu 18.04</span></a> </div>
<div class="nav-link nav-link-next">
</div>
</div>
</nav>
<div class="et_extra_other_module related-posts">
<div class="related-posts-header">
<h3>Related Posts</h3>
</div>
<div class="related-posts-content clearfix">
<div class="related-post">
<div class="featured-image"><a href="https://www.rosehosting.com/blog/configure-odoo-8-subdomain-filtering-on-a-linux-vps/" title="Configure Odoo 8 subdomain filtering on a Linux VPS" class="post-thumbnail">
<img src="https://www.rosehosting.com/blog/wp-content/uploads/2015/05/odoo.png" alt="Configure Odoo 8 subdomain filtering on a Linux VPS" /><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="https://www.rosehosting.com/blog/configure-odoo-8-subdomain-filtering-on-a-linux-vps/">Configure Odoo 8 subdomain filtering on a Linux VPS</a></h4>
<p class="date"><span class="updated">May 30, 2015</span></p>
</div>
<div class="related-post">
<div class="featured-image"><a href="https://www.rosehosting.com/blog/how-to-install-rainloop-webmail-on-centos-7/" title="How to Install RainLoop Webmail on CentOS 7" class="post-thumbnail">
<img src="https://www.rosehosting.com/blog/wp-content/uploads/2019/04/install-rainmail-centos7-440x264.jpg" alt="How to Install RainLoop Webmail on CentOS 7" /><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="https://www.rosehosting.com/blog/how-to-install-rainloop-webmail-on-centos-7/">How to Install RainLoop Webmail on CentOS 7</a></h4>
<p class="date"><span class="updated">April 15, 2019</span></p>
</div>
<div class="related-post">
<div class="featured-image"><a href="https://www.rosehosting.com/blog/deploy-civicrm-in-conjunction-with-drupal-on-an-ubuntu-14-04-vps/" title="Deploy CiviCRM in conjunction with Drupal on an Ubuntu 14.04 VPS" class="post-thumbnail">
<img src="https://www.rosehosting.com/blog/wp-content/uploads/2015/11/civi-logo.png" alt="Deploy CiviCRM in conjunction with Drupal on an Ubuntu 14.04 VPS" /><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="https://www.rosehosting.com/blog/deploy-civicrm-in-conjunction-with-drupal-on-an-ubuntu-14-04-vps/">Deploy CiviCRM in conjunction with Drupal on an Ubuntu 14.04 VPS</a></h4>
<p class="date"><span class="updated">December 6, 2015</span></p>
</div>
<div class="related-post">
<div class="featured-image"><a href="https://www.rosehosting.com/blog/how-to-install-shopware-ce-on-debian-9/" title="How to Install Shopware CE on Debian 9" class="post-thumbnail">
<img src="https://www.rosehosting.com/blog/wp-content/uploads/2019/04/how-to-install-shopware-ce-on-debian9-440x264.jpg" alt="How to Install Shopware CE on Debian 9" /><span class="et_pb_extra_overlay"></span>
</a></div>
<h4 class="title"><a href="https://www.rosehosting.com/blog/how-to-install-shopware-ce-on-debian-9/">How to Install Shopware CE on Debian 9</a></h4>
<p class="date"><span class="updated">April 22, 2019</span></p>
</div>
</div>
</div>

<section id="comment-wrap">
<div id="comments" class="nocomments">

</div>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/#respond" style="display:none;">Cancel reply</a></small></h3> <form action="https://www.rosehosting.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form">
<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea autocomplete="nope" id="ga72ed6d74" name="ga72ed6d74" cols="45" rows="8" aria-required="true"></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="nope" style="padding:0;clip:rect(1px, 1px, 1px, 1px);position:absolute !important;white-space:nowrap;height:1px;width:1px;overflow:hidden;" tabindex="-1"></textarea><script type="text/javascript">document.getElementById("comment").setAttribute( "id", "a6f608ab18e1cb41052a1454734fdad5" );document.getElementById("ga72ed6d74").setAttribute( "id", "comment" );</script></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='29935' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><div class="g-recaptcha" data-sitekey="6LfY7_4SAAAAAE2DEhMo9U4ZS1XLXf1qGXL9uzZC" data-theme="standard"></div><script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en"></script> <div id="recaptcha-submit-btn-area">&nbsp;</div>
<noscript>
            <style type='text/css'>#submit {display:none;}</style>
            <input name="submit" type="submit" id="submit-alt" tabindex="6"
                value="Submit Comment"/> 
            </noscript> </form>
</div>
</section>
</div>
<div class="et_pb_extra_column_sidebar">
<div class="et_pb_widget roseh-widget"><h4 class="widgettitle"> </h4><div style="text-align: center; " id="roseh-1183564298"><center><a target="_blank" href="https://linuxhostsupport.com/"><img src="https://media.rosehosting.com/img/blogads/24.jpg" alt="Server Management Services"></a></center>
</div></div> <div class="et_pb_widget roseh-widget"><h4 class="widgettitle"> </h4><div style="text-align: center; " id="roseh-1157880647"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="2385735863"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div> <div class="et_pb_widget roseh-widget"><h4 class="widgettitle"> </h4><div style="text-align: center; " id="roseh-1991260782"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-5301323036263712" data-ad-slot="8927217199"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div> <div id="custom_html-4" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"> </h4><div class="textwidget custom-html-widget">
<link href="//cdn-images.mailchimp.com/embedcode/slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://rosehosting.us9.list-manage.com/subscribe/post?u=f1868632d497b649bacf4c210&amp;id=df0b8333a5" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Get the newest Articles and Discounts before everyone else</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_f1868632d497b649bacf4c210_df0b8333a5" tabindex="-1" value=""></div>
<div class="dnmclear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>
</div></div> </div>
</div> 
</div> 
</div> 

<footer class="footer-big-menu">
<div class="container">
<div class="row menu">
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title mb-2">Company</h3>
<a class="menu-link" href="https://www.rosehosting.com/about-us.html">About us</a>
<a class="menu-link" href="https://www.rosehosting.com/policies.html">Our Policies</a>
<a class="menu-link" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
<a class="menu-link" href="https://www.rosehosting.com/blog/">Blog</a>
<a class="menu-link" href="https://www.rosehosting.com/why-rosehosting.html">Why RoseHosting</a>
<a class="menu-link" href="https://www.rosehosting.com/compare-to-competition.html">Compare Us</a>
<a class="menu-link" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
<a class="menu-link" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
</div>
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title  mb-2">Support</h3>
<a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Helpdesk System</a>
<a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>
<a class="menu-link" href="https://status.rosehosting.com">Systems Status</a>
<h3 class="menu-title  mb-2 mt-4">Other Services</h3>
<a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Domain Registration</a>
<a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Domain Transfer</a>
<a class="menu-link" href="https://www.rosehosting.com/ssl-certificates.html">SSL Certificates</a>
</div>
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title  mb-2">Hosting</h3>
<a class="menu-link" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/linux-vps-hosting.html">Linux VPS Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting</a>
<a class="menu-link" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom SSD VPS</a>
<a class="menu-link" href="https://www.rosehosting.com/dedicated-servers.html">Cloud Dedicated Servers</a>
<a class="menu-link" href="https://www.rosehosting.com/hosting-solutions.html">Hosting Solutions</a>
<a class="menu-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Affiliate Program</a>
</div>
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title  mb-2">Linux VPS Hosting</h3>
<a class="menu-link" href="https://www.rosehosting.com/centos-hosting.html">CentOS Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/ubuntu-hosting.html">Ubuntu Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/debian-hosting.html">Debian Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/opensuse-hosting.html">OpenSUSE Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/arch-linux-hosting.html">Arch-Linux Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/scientific-linux-hosting.html">Scientific Linux Hosting</a>
</div>
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title  mb-2">Apps Hosting</h3>
<a class="menu-link" href="https://www.rosehosting.com/wordpress-hosting.html">WordPress Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/magento-hosting.html">Magento Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/odoo-hosting.html">Odoo Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/joomla-hosting.html">Joomla Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/drupal-hosting.html">Drupal Hosting</a>
 <a class="menu-link" href="https://www.rosehosting.com/laravel-hosting.html">Laravel Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/nextcloud-hosting.html">NextCloud Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/prestashop-hosting.html">PrestaShop Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/ghost-hosting.html">Ghost Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/mediawiki-hosting.html">MediaWiki Hosting</a>
<a class="menu-link" href="https://www.rosehosting.com/tomcat-hosting.html">Tomcat Hosting</a>
</div>
<div class="col-6 col-md-3 col-lg-2">
<h3 class="menu-title mb-2">Contact Us</h3>
<a class="menu-link" href="tel:+18887673467">(888) ROSE-HOST</a>
<a class="menu-link" href="tel:+18887673467">(888) 767-3467</a>
<a class="menu-link" href="tel:+16465197201">(314) 275-0414</a>
<a class="menu-link" href="/cdn-cgi/l/email-protection#d9fceeeafceeecfceee9fceee9fcefbffceeebfceeedfcede9fceeebfcefbffceeeafcefecfcefe1fcefbffceeeafceeedfcefe0fcefbcfcefeefcebbcfcefeafcefbffcefbd">Email us</a>
<h3 class="menu-title mb-2 mt-4">Connect</h3>
<a class="menu-link" href="https://twitter.com/rosehosting" target="_blank"><i class="fa fa-twitter fa-fw"></i> Twitter</a>
<a class="menu-link" href="https://www.facebook.com/RoseHosting" target="_blank"><i class="fa fa-facebook fa-fw"></i> Facebook</a>
<a class="menu-link" href="https://www.linkedin.com/company/rose-web-services-l-l-c-" target="_blank"><i class="fa fa-linkedin fa-fw"></i> LinkedIn</a>
<a class="menu-link" href="https://www.rosehosting.com/blog/feed/" target="_blank"><i class="fa fa-rss fa-fw"></i> RSS Feed</a>
</div>
</div>
</div>
<div class="bottom">
<div class="container">
<div class="row">
<div class="col col-md-12">
<img class="privacy-shield d-block mb-4" width="175" src="https://www.rosehosting.com/blog/wp-content/themes/rh2018/img/privacy_shield.png" alt="privacy shield">
</div>
<div class="col-md-12 col-lg-6">
<p class="text-sm-left"><a class="inline-link footer-policy" href="/tos.html">Terms of Service</a> and <a class="inline-link footer-policy" href="/policies.html">other policies</a></p>
</div>
<div class="col-md-12 col-lg-6">
<p class="text-sm-right">&copy; 2001-2019 <a class="inline-link footer-policy" href="https://www.rosewebservices.com/">Rose Web Services LLC</a>.</p>
</div>
</div>
</div>
</div>

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript" id="aff1f81b02f303eea5f87a3a065f153a" src="https://linuxhostsupport.com/chat//script.php?id=aff1f81b02f303eea5f87a3a065f153a"></script>

<div class="essb-followme essb-followme-bottom" data-full="" data-top="" data-background="rgba(255,255,255,0)" data-position="" data-avoid-left="true" data-hide="1"><div class="essb_links essb_counters essb_displayed_followme essb_share essb_template_bold-retina essb_797044702 essb_links_center essb_mobile_hidden print-no" id="essb_displayed_followme_797044702" data-essb-postid="29935" data-essb-position="followme" data-essb-button-style="button_name" data-essb-template="bold-retina" data-essb-counter-pos="insidename" data-essb-url="https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/" data-essb-twitter-url="https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/" data-essb-instance="797044702"><ul class="essb_links_list essb_hide_icon"><li class="essb_item essb_totalcount_item" style="display: none !important;" data-counter-pos="insidename"><span class="essb_totalcount essb_t_l" title="Total: "><span class="essb_total_text">Total: </span><span class="essb_t_nb">2</span></span></li><li class="essb_item essb_link_facebook nolightbox"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/&t=How+to+Use+a+Private+Key+and+PuTTY+to+Log+into+Your+Server+Securely" title="" onclick="essb.window(&#39;https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/&t=How+to+Use+a+Private+Key+and+PuTTY+to+Log+into+Your+Server+Securely&#39;,&#39;facebook&#39;,&#39;797044702&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_facebook"></span><span class="essb_network_name">Facebook<span class="essb_counter_insidename" data-cnt="2" data-cnt-short="2">2</span></span></a></li><li class="essb_item essb_link_twitter nolightbox"> <a href="#" title="" onclick="essb.window(&#39;https://twitter.com/intent/tweet?text=How+to+Use+a+Private+Key+and+PuTTY+to+Log+into+Your+Server+Securely&amp;url=https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/&amp;counturl=https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/&#39;,&#39;twitter&#39;,&#39;797044702&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_twitter"></span><span class="essb_network_name">Twitter<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_linkedin nolightbox"> <a href="https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+to+Use+a+Private+Key+and+PuTTY+to+Log+into+Your+Server+Securely&amp;url=https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/" title="" onclick="essb.window(&#39;https://www.linkedin.com/shareArticle?mini=true&amp;ro=true&amp;trk=EasySocialShareButtons&amp;title=How+to+Use+a+Private+Key+and+PuTTY+to+Log+into+Your+Server+Securely&amp;url=https://www.rosehosting.com/blog/how-to-use-a-private-key-and-putty-to-log-into-your-server-securely/&#39;,&#39;linkedin&#39;,&#39;797044702&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_linkedin"></span><span class="essb_network_name">LinkedIn<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_print nolightbox"> <a href="#" title="" onclick="essb.print(&#39;797044702&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_print"></span><span class="essb_network_name">Print<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li><li class="essb_item essb_link_mail nolightbox"> <a href="#" title="" onclick="essb_open_mailform(&#39;797044702&#39;); return false;" target="_blank" rel="nofollow" class="nolightbox"><span class="essb_icon essb_icon_mail"></span><span class="essb_network_name">Email<span class="essb_counter_insidename" data-cnt="" style="display: none;" data-cnt-short="0">0</span></span></a></li></ul></div></div> <script type="text/javascript">
			</script>
<script type="text/javascript">
            var sub = document.getElementById('submit');
            document.getElementById('recaptcha-submit-btn-area').appendChild (sub);
            document.getElementById('submit').tabIndex = 6;
            if ( typeof _recaptcha_wordpress_savedcomment != 'undefined') {
                document.getElementById('comment').value = 
                    _recaptcha_wordpress_savedcomment;
            }
            </script><script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2018/js/theme.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/masonry.min.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/www.rosehosting.com\/blog\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"400fab1afe","timeline_nonce":"fe22c217f6","blog_feed_nonce":"68068e8dad","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/www.rosehosting.com\/blog\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/www.rosehosting.com\/blog\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"c23c6b68d4","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"d024a4d0ca","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"29935","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/Extra/scripts/scripts.min.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/comment-reply.min.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/Extra/core/admin/js/common.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/wp-embed.min.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/smooth-scroll/jquery.smooth-scroll.min.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/js-cookie/js.cookie.min.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/sticky-kit/jquery.sticky-kit.min.js?x68100&amp;x68100' defer='defer'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"","width":"100%","scroll_offset":"30"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/assets/js/front.min.js?x68100&amp;x68100' defer='defer'></script>
<div class="essb_mailform"><div class="essb_mailform_content"><p>Send this to a friend</p><label class="essb_mailform_content_label">Your email</label><input type="text" id="essb_mailform_from" class="essb_mailform_content_input" placeholder="Your email" /><label class="essb_mailform_content_label">Recipient email</label><input type="text" id="essb_mailform_to" class="essb_mailform_content_input" placeholder="Recipient email" /><div class="essb_mailform_content_buttons"><button id="essb_mailform_btn_submit" class="essb_mailform_content_button" onclick="essb_mailform_send();">Send</button><button id="essb_mailform_btn_cancel" class="essb_mailform_content_button" onclick="essb_close_mailform(); return false;">Cancel</button></div><input type="hidden" id="essb_mail_salt" value="712055982" /><input type="hidden" id="essb_mail_instance" value="" /><input type="hidden" id="essb_mail_post" value="" /></div></div><div class="essb_mailform_shadow"></div><link rel='stylesheet' id='essb-compiled-css' href='https://www.rosehosting.com/blog/wp-content/easysocialsharebuttons-assets/compiled/2566c291e59e185c12a331fef1e235f3.css?x68100' type='text/css' media='all' /><script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/easysocialsharebuttons-assets/compiled/2566c291e59e185c12a331fef1e235f3.js?x68100' async></script></body>
</html>
