<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head><meta charset="UTF-8" /><script>if(navigator.userAgent.match(/MSIE|Internet Explorer/i)||navigator.userAgent.match(/Trident\/7\..*?rv:11/i)){var href=document.location.href;if(!href.match(/[?&]nowprocket/)){if(href.indexOf("?")==-1){if(href.indexOf("#")==-1){document.location.href=href+"?nowprocket=1"}else{document.location.href=href.replace("#","?nowprocket=1#")}}else{if(href.indexOf("#")==-1){document.location.href=href+"&nowprocket=1"}else{document.location.href=href.replace("#","&nowprocket=1#")}}}}</script><script>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</script>
	


	<link rel="pingback" href="https://www.rosehosting.com/blog/xmlrpc.php" />


		<!--[if lt IE 9]>
	<script src="https://www.rosehosting.com/blog/wp-content/themes/generatepress/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->

<!--<script type="rocketlazyloadscript" async custom-element="amp-ad" src="https://cdn.ampproject.org/v0/amp-ad-0.1.js"></script>-->

<!-- Google Tag Manager -->
<script type="rocketlazyloadscript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KVJ4PJ');</script>
<!-- End Google Tag Manager -->

	<script type="rocketlazyloadscript" data-rocket-type="text/javascript">
		document.documentElement.className = 'js';
	</script>

	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO Premium plugin v17.0 (Yoast SEO v17.3) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Tomcat and Tomee Clustering Automation | RoseHosting</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2Cregular%2Citalic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CAbril%20FatFace%3A400%2C400i%2C700%2C700i%7CAlegreya%3A400%2C400i%2C700%2C700i%7CAlegreya%20Sans%3A400%2C400i%2C700%2C700i%7CAmatic%20SC%3A400%2C400i%2C700%2C700i%7CAnonymous%20Pro%3A400%2C400i%2C700%2C700i%7CArchitects%20Daughter%3A400%2C400i%2C700%2C700i%7CArchivo%3A400%2C400i%2C700%2C700i%7CArchivo%20Narrow%3A400%2C400i%2C700%2C700i%7CAsap%3A400%2C400i%2C700%2C700i%7CBarlow%3A400%2C400i%2C700%2C700i%7CBioRhyme%3A400%2C400i%2C700%2C700i%7CBonbon%3A400%2C400i%2C700%2C700i%7CCabin%3A400%2C400i%2C700%2C700i%7CCairo%3A400%2C400i%2C700%2C700i%7CCardo%3A400%2C400i%2C700%2C700i%7CChivo%3A400%2C400i%2C700%2C700i%7CConcert%20One%3A400%2C400i%2C700%2C700i%7CCormorant%3A400%2C400i%2C700%2C700i%7CCrimson%20Text%3A400%2C400i%2C700%2C700i%7CEczar%3A400%2C400i%2C700%2C700i%7CExo%202%3A400%2C400i%2C700%2C700i%7CFira%20Sans%3A400%2C400i%2C700%2C700i%7CFjalla%20One%3A400%2C400i%2C700%2C700i%7CFrank%20Ruhl%20Libre%3A400%2C400i%2C700%2C700i%7CGreat%20Vibes%3A400%2C400i%2C700%2C700i%7CHeebo%3A400%2C400i%2C700%2C700i%7CIBM%20Plex%3A400%2C400i%2C700%2C700i%7CInconsolata%3A400%2C400i%2C700%2C700i%7CIndie%20Flower%3A400%2C400i%2C700%2C700i%7CInknut%20Antiqua%3A400%2C400i%2C700%2C700i%7CInter%3A400%2C400i%2C700%2C700i%7CKarla%3A400%2C400i%2C700%2C700i%7CLibre%20Baskerville%3A400%2C400i%2C700%2C700i%7CLibre%20Franklin%3A400%2C400i%2C700%2C700i%7CMontserrat%3A400%2C400i%2C700%2C700i%7CNeuton%3A400%2C400i%2C700%2C700i%7CNotable%3A400%2C400i%2C700%2C700i%7CNothing%20You%20Could%20Do%3A400%2C400i%2C700%2C700i%7CNoto%20Sans%3A400%2C400i%2C700%2C700i%7CNunito%3A400%2C400i%2C700%2C700i%7COld%20Standard%20TT%3A400%2C400i%2C700%2C700i%7COxygen%3A400%2C400i%2C700%2C700i%7CPacifico%3A400%2C400i%2C700%2C700i%7CPoppins%3A400%2C400i%2C700%2C700i%7CProza%20Libre%3A400%2C400i%2C700%2C700i%7CPT%20Sans%3A400%2C400i%2C700%2C700i%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CRakkas%3A400%2C400i%2C700%2C700i%7CReenie%20Beanie%3A400%2C400i%2C700%2C700i%7CRoboto%20Slab%3A400%2C400i%2C700%2C700i%7CRopa%20Sans%3A400%2C400i%2C700%2C700i%7CRubik%3A400%2C400i%2C700%2C700i%7CShadows%20Into%20Light%3A400%2C400i%2C700%2C700i%7CSpace%20Mono%3A400%2C400i%2C700%2C700i%7CSpectral%3A400%2C400i%2C700%2C700i%7CSue%20Ellen%20Francisco%3A400%2C400i%2C700%2C700i%7CTitillium%20Web%3A400%2C400i%2C700%2C700i%7CUbuntu%3A400%2C400i%2C700%2C700i%7CVarela%3A400%2C400i%2C700%2C700i%7CVollkorn%3A400%2C400i%2C700%2C700i%7CWork%20Sans%3A400%2C400i%2C700%2C700i%7CYatra%20One%3A400%2C400i%2C700%2C700i&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2Cregular%2Citalic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CAbril%20FatFace%3A400%2C400i%2C700%2C700i%7CAlegreya%3A400%2C400i%2C700%2C700i%7CAlegreya%20Sans%3A400%2C400i%2C700%2C700i%7CAmatic%20SC%3A400%2C400i%2C700%2C700i%7CAnonymous%20Pro%3A400%2C400i%2C700%2C700i%7CArchitects%20Daughter%3A400%2C400i%2C700%2C700i%7CArchivo%3A400%2C400i%2C700%2C700i%7CArchivo%20Narrow%3A400%2C400i%2C700%2C700i%7CAsap%3A400%2C400i%2C700%2C700i%7CBarlow%3A400%2C400i%2C700%2C700i%7CBioRhyme%3A400%2C400i%2C700%2C700i%7CBonbon%3A400%2C400i%2C700%2C700i%7CCabin%3A400%2C400i%2C700%2C700i%7CCairo%3A400%2C400i%2C700%2C700i%7CCardo%3A400%2C400i%2C700%2C700i%7CChivo%3A400%2C400i%2C700%2C700i%7CConcert%20One%3A400%2C400i%2C700%2C700i%7CCormorant%3A400%2C400i%2C700%2C700i%7CCrimson%20Text%3A400%2C400i%2C700%2C700i%7CEczar%3A400%2C400i%2C700%2C700i%7CExo%202%3A400%2C400i%2C700%2C700i%7CFira%20Sans%3A400%2C400i%2C700%2C700i%7CFjalla%20One%3A400%2C400i%2C700%2C700i%7CFrank%20Ruhl%20Libre%3A400%2C400i%2C700%2C700i%7CGreat%20Vibes%3A400%2C400i%2C700%2C700i%7CHeebo%3A400%2C400i%2C700%2C700i%7CIBM%20Plex%3A400%2C400i%2C700%2C700i%7CInconsolata%3A400%2C400i%2C700%2C700i%7CIndie%20Flower%3A400%2C400i%2C700%2C700i%7CInknut%20Antiqua%3A400%2C400i%2C700%2C700i%7CInter%3A400%2C400i%2C700%2C700i%7CKarla%3A400%2C400i%2C700%2C700i%7CLibre%20Baskerville%3A400%2C400i%2C700%2C700i%7CLibre%20Franklin%3A400%2C400i%2C700%2C700i%7CMontserrat%3A400%2C400i%2C700%2C700i%7CNeuton%3A400%2C400i%2C700%2C700i%7CNotable%3A400%2C400i%2C700%2C700i%7CNothing%20You%20Could%20Do%3A400%2C400i%2C700%2C700i%7CNoto%20Sans%3A400%2C400i%2C700%2C700i%7CNunito%3A400%2C400i%2C700%2C700i%7COld%20Standard%20TT%3A400%2C400i%2C700%2C700i%7COxygen%3A400%2C400i%2C700%2C700i%7CPacifico%3A400%2C400i%2C700%2C700i%7CPoppins%3A400%2C400i%2C700%2C700i%7CProza%20Libre%3A400%2C400i%2C700%2C700i%7CPT%20Sans%3A400%2C400i%2C700%2C700i%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CRakkas%3A400%2C400i%2C700%2C700i%7CReenie%20Beanie%3A400%2C400i%2C700%2C700i%7CRoboto%20Slab%3A400%2C400i%2C700%2C700i%7CRopa%20Sans%3A400%2C400i%2C700%2C700i%7CRubik%3A400%2C400i%2C700%2C700i%7CShadows%20Into%20Light%3A400%2C400i%2C700%2C700i%7CSpace%20Mono%3A400%2C400i%2C700%2C700i%7CSpectral%3A400%2C400i%2C700%2C700i%7CSue%20Ellen%20Francisco%3A400%2C400i%2C700%2C700i%7CTitillium%20Web%3A400%2C400i%2C700%2C700i%7CUbuntu%3A400%2C400i%2C700%2C700i%7CVarela%3A400%2C400i%2C700%2C700i%7CVollkorn%3A400%2C400i%2C700%2C700i%7CWork%20Sans%3A400%2C400i%2C700%2C700i%7CYatra%20One%3A400%2C400i%2C700%2C700i&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A300%2C300italic%2Cregular%2Citalic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%7CAbril%20FatFace%3A400%2C400i%2C700%2C700i%7CAlegreya%3A400%2C400i%2C700%2C700i%7CAlegreya%20Sans%3A400%2C400i%2C700%2C700i%7CAmatic%20SC%3A400%2C400i%2C700%2C700i%7CAnonymous%20Pro%3A400%2C400i%2C700%2C700i%7CArchitects%20Daughter%3A400%2C400i%2C700%2C700i%7CArchivo%3A400%2C400i%2C700%2C700i%7CArchivo%20Narrow%3A400%2C400i%2C700%2C700i%7CAsap%3A400%2C400i%2C700%2C700i%7CBarlow%3A400%2C400i%2C700%2C700i%7CBioRhyme%3A400%2C400i%2C700%2C700i%7CBonbon%3A400%2C400i%2C700%2C700i%7CCabin%3A400%2C400i%2C700%2C700i%7CCairo%3A400%2C400i%2C700%2C700i%7CCardo%3A400%2C400i%2C700%2C700i%7CChivo%3A400%2C400i%2C700%2C700i%7CConcert%20One%3A400%2C400i%2C700%2C700i%7CCormorant%3A400%2C400i%2C700%2C700i%7CCrimson%20Text%3A400%2C400i%2C700%2C700i%7CEczar%3A400%2C400i%2C700%2C700i%7CExo%202%3A400%2C400i%2C700%2C700i%7CFira%20Sans%3A400%2C400i%2C700%2C700i%7CFjalla%20One%3A400%2C400i%2C700%2C700i%7CFrank%20Ruhl%20Libre%3A400%2C400i%2C700%2C700i%7CGreat%20Vibes%3A400%2C400i%2C700%2C700i%7CHeebo%3A400%2C400i%2C700%2C700i%7CIBM%20Plex%3A400%2C400i%2C700%2C700i%7CInconsolata%3A400%2C400i%2C700%2C700i%7CIndie%20Flower%3A400%2C400i%2C700%2C700i%7CInknut%20Antiqua%3A400%2C400i%2C700%2C700i%7CInter%3A400%2C400i%2C700%2C700i%7CKarla%3A400%2C400i%2C700%2C700i%7CLibre%20Baskerville%3A400%2C400i%2C700%2C700i%7CLibre%20Franklin%3A400%2C400i%2C700%2C700i%7CMontserrat%3A400%2C400i%2C700%2C700i%7CNeuton%3A400%2C400i%2C700%2C700i%7CNotable%3A400%2C400i%2C700%2C700i%7CNothing%20You%20Could%20Do%3A400%2C400i%2C700%2C700i%7CNoto%20Sans%3A400%2C400i%2C700%2C700i%7CNunito%3A400%2C400i%2C700%2C700i%7COld%20Standard%20TT%3A400%2C400i%2C700%2C700i%7COxygen%3A400%2C400i%2C700%2C700i%7CPacifico%3A400%2C400i%2C700%2C700i%7CPoppins%3A400%2C400i%2C700%2C700i%7CProza%20Libre%3A400%2C400i%2C700%2C700i%7CPT%20Sans%3A400%2C400i%2C700%2C700i%7CPT%20Serif%3A400%2C400i%2C700%2C700i%7CRakkas%3A400%2C400i%2C700%2C700i%7CReenie%20Beanie%3A400%2C400i%2C700%2C700i%7CRoboto%20Slab%3A400%2C400i%2C700%2C700i%7CRopa%20Sans%3A400%2C400i%2C700%2C700i%7CRubik%3A400%2C400i%2C700%2C700i%7CShadows%20Into%20Light%3A400%2C400i%2C700%2C700i%7CSpace%20Mono%3A400%2C400i%2C700%2C700i%7CSpectral%3A400%2C400i%2C700%2C700i%7CSue%20Ellen%20Francisco%3A400%2C400i%2C700%2C700i%7CTitillium%20Web%3A400%2C400i%2C700%2C700i%7CUbuntu%3A400%2C400i%2C700%2C700i%7CVarela%3A400%2C400i%2C700%2C700i%7CVollkorn%3A400%2C400i%2C700%2C700i%7CWork%20Sans%3A400%2C400i%2C700%2C700i%7CYatra%20One%3A400%2C400i%2C700%2C700i&#038;display=swap" /></noscript><link rel="stylesheet" href="https://www.rosehosting.com/blog/wp-content/cache/min/1/291e4d0fed181ab369eb9431048c028a.css" media="all" data-minify="1" />
	<meta name="description" content="Learn how to automate clustering for Tomcat and Tomee in RoseHosting cloud PaaS in a few easy steps, using this tutorial." />
	<link rel="canonical" href="https://www.rosehosting.com/blog/tomcat-and-tomee-clustering-automation/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Tomcat and Tomee Clustering Automation | RoseHosting" />
	<meta property="og:description" content="Learn how to automate clustering for Tomcat and Tomee in RoseHosting cloud PaaS in a few easy steps, using this tutorial." />
	<meta property="og:url" content="https://www.rosehosting.com/blog/tomcat-and-tomee-clustering-automation/" />
	<meta property="og:site_name" content="RoseHosting" />
	<meta property="article:publisher" content="https://www.facebook.com/RoseHosting" />
	<meta property="article:author" content="https://www.facebook.com/rosehosting.helpdesk" />
	<meta property="article:published_time" content="2021-10-04T17:30:00+00:00" />
	<meta property="article:modified_time" content="2021-09-24T08:29:35+00:00" />
	<meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation.jpg?v=1632385978" />
	<meta property="og:image:width" content="742" />
	<meta property="og:image:height" content="372" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:title" content="Tomcat and Tomee Clustering Automation | RoseHosting" />
	<meta name="twitter:description" content="Learn how to automate clustering for Tomcat and Tomee in RoseHosting cloud PaaS in a few easy steps, using this tutorial." />
	<meta name="twitter:creator" content="@rosehosting" />
	<meta name="twitter:site" content="@rosehosting" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Jeff Wilson" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="7 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.rosehosting.com/blog/#organization","name":"RoseHosting","url":"https://www.rosehosting.com/blog/","sameAs":["https://www.facebook.com/RoseHosting","https://www.linkedin.com/in/rosehosting/","https://twitter.com/rosehosting"],"logo":{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/#logo","inLanguage":"en-US","url":"https://www.rosehosting.com/blog/wp-content/uploads/2016/02/rhlogo-final-500x500.png","contentUrl":"https://www.rosehosting.com/blog/wp-content/uploads/2016/02/rhlogo-final-500x500.png","width":500,"height":500,"caption":"RoseHosting"},"image":{"@id":"https://www.rosehosting.com/blog/#logo"}},{"@type":"WebSite","@id":"https://www.rosehosting.com/blog/#website","url":"https://www.rosehosting.com/blog/","name":"RoseHosting","description":"Premium Linux Tutorials Since 2001","publisher":{"@id":"https://www.rosehosting.com/blog/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.rosehosting.com/blog/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/tomcat-and-tomee-clustering-automation/#primaryimage","inLanguage":"en-US","url":"https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation.jpg?v=1632385978","contentUrl":"https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation.jpg?v=1632385978","width":742,"height":372,"caption":"tomcat and tomee clustering automation"},{"@type":"WebPage","@id":"https://www.rosehosting.com/blog/tomcat-and-tomee-clustering-automation/#webpage","url":"https://www.rosehosting.com/blog/tomcat-and-tomee-clustering-automation/","name":"Tomcat and Tomee Clustering Automation | RoseHosting","isPartOf":{"@id":"https://www.rosehosting.com/blog/#website"},"primaryImageOfPage":{"@id":"https://www.rosehosting.com/blog/tomcat-and-tomee-clustering-automation/#primaryimage"},"datePublished":"2021-10-04T17:30:00+00:00","dateModified":"2021-09-24T08:29:35+00:00","description":"Learn how to automate clustering for Tomcat and Tomee in RoseHosting cloud PaaS in a few easy steps, using this tutorial.","breadcrumb":{"@id":"https://www.rosehosting.com/blog/tomcat-and-tomee-clustering-automation/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.rosehosting.com/blog/tomcat-and-tomee-clustering-automation/"]}]},{"@type":"BreadcrumbList","@id":"https://www.rosehosting.com/blog/tomcat-and-tomee-clustering-automation/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.rosehosting.com/blog/"},{"@type":"ListItem","position":2,"name":"Tomcat and TomEE Clustering Automation"}]},{"@type":"Article","@id":"https://www.rosehosting.com/blog/tomcat-and-tomee-clustering-automation/#article","isPartOf":{"@id":"https://www.rosehosting.com/blog/tomcat-and-tomee-clustering-automation/#webpage"},"author":{"@id":"https://www.rosehosting.com/blog/#/schema/person/7ce77a842fa6a9a7f8efa186f2353713"},"headline":"Tomcat and TomEE Clustering Automation","datePublished":"2021-10-04T17:30:00+00:00","dateModified":"2021-09-24T08:29:35+00:00","mainEntityOfPage":{"@id":"https://www.rosehosting.com/blog/tomcat-and-tomee-clustering-automation/#webpage"},"wordCount":880,"commentCount":0,"publisher":{"@id":"https://www.rosehosting.com/blog/#organization"},"image":{"@id":"https://www.rosehosting.com/blog/tomcat-and-tomee-clustering-automation/#primaryimage"},"thumbnailUrl":"https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation.jpg?v=1632385978","keywords":["automation","clustering","tomcat","tomee"],"articleSection":["Guides","Load Balancing","Web Frameworks","Web Servers"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.rosehosting.com/blog/tomcat-and-tomee-clustering-automation/#respond"]}]},{"@type":"Person","@id":"https://www.rosehosting.com/blog/#/schema/person/7ce77a842fa6a9a7f8efa186f2353713","name":"Jeff Wilson","image":{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/09271207587f897ab46faaed9b355252?s=96&r=g","contentUrl":"https://secure.gravatar.com/avatar/09271207587f897ab46faaed9b355252?s=96&r=g","caption":"Jeff Wilson"},"description":"An experienced Linux veteran with many years of experience. Helping other Linux admins with frequent Linux and business-related blog posts on the RoseHosting blog. Techie by choice. Loving nature and travel. Happily married and father of two lovely children.","sameAs":["https://www.rosehosting.com","https://www.facebook.com/rosehosting.helpdesk"]}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.gstatic.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Feed" href="https://www.rosehosting.com/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Comments Feed" href="https://www.rosehosting.com/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Tomcat and TomEE Clustering Automation Comments Feed" href="https://www.rosehosting.com/blog/tomcat-and-tomee-clustering-automation/feed/" />
<!-- rosehosting.com/blog is managing ads with Advanced Ads --><!--noptimize--><script id="rhad-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
		<!--/noptimize--><style>
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	








<style id='ez-toc-inline-css'>
div#ez-toc-container p.ez-toc-title {font-size: 22px;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}div#ez-toc-container {width: 95%;}
</style>






<style id='generate-style-inline-css'>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</style>









<link rel='preload' as='font'  id='wpzoom-social-icons-font-academicons-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.ttf?v=1.8.6' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-academicons-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.woff?v=1.8.6' type='font/woff' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-fontawesome-3-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.ttf?v=4.7.0' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-fontawesome-3-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff?v=4.7.0' type='font/woff' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-fontawesome-3-woff2-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff2?v=4.7.0' type='font/woff2' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-genericons-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-genericons-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type='font/woff' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-socicon-ttf-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.ttf?v=4.2.2' type='font/ttf' crossorigin />
<link rel='preload' as='font'  id='wpzoom-social-icons-font-socicon-woff-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.woff?v=4.2.2' type='font/woff' crossorigin />
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js' defer></script>
<script id='topbar_frontjs-js-extra'>
var tpbr_settings = {"fixed":"fixed","user_who":"notloggedin","guests_or_users":"all","message":"20th Anniversary Sale!!! 20% OFF on all hosting services. Use coupon RH20YEARS     *new customers only, while supplies last","status":"inactive","yn_button":"button","color":"#ba004a","button_text":"GET THE DEAL","button_url":"https:\/\/www.rosehosting.com\/20th-anniversary-sale.html","button_behavior":"newwindow","is_admin_bar":"no","detect_sticky":"0"};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/top-bar/inc/../js/tpbr_front.min.js' id='topbar_frontjs-js' defer></script>
<script id='advanced-ads-advanced-js-js-extra'>
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js' id='advanced-ads-advanced-js-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/ajax/libs/popper.js/1.11.0/umd/popper.min.js?ver=1628863129' id='popper-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/themes/rh2020/js/bootstrap.js?ver=1628863129' id='bootstrap-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/themes/rh2020/js/cookieconsent.min.js' id='cookieconsent-js' defer></script>
<link rel="https://api.w.org/" href="https://www.rosehosting.com/blog/wp-json/" /><link rel="alternate" type="application/json" href="https://www.rosehosting.com/blog/wp-json/wp/v2/posts/38913" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rosehosting.com/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rosehosting.com/blog/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.1" />
<link rel='shortlink' href='https://www.rosehosting.com/blog/?p=38913' />
<link rel="alternate" type="application/json+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Ftomcat-and-tomee-clustering-automation%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Ftomcat-and-tomee-clustering-automation%2F&#038;format=xml" />
<script type="rocketlazyloadscript">advads_items = { conditions: {}, display_callbacks: {}, display_effect_callbacks: {}, hide_callbacks: {}, backgrounds: {}, effect_durations: {}, close_functions: {}, showed: [] };</script><style type="text/css" id="rhad-layer-custom-css"></style><script type="rocketlazyloadscript" data-rocket-type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
		<meta name="viewport" content="width=device-width, initial-scale=1"><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-270x270.png" />
		<style id="wp-custom-css">
			/* Change background color and font of pre-formatted text */
.entry-content pre {
font-family: monospace;
color: #3a3a3a;
border: none;
overflow-wrap: break-word;
}
.inside-article,
.sidebar .widget {
    border: 1px solid #e3e3e3;
}
.page-container {
    max-width: 1100px;
		align-items: center;
		justify-content: space-between;
		margin-left: auto;
		margin-right: auto;
}
.footer-big-menu {
		max-width: 1100px;
		margin-left: auto;
		margin-right: auto;
}
.col6, .col-md-3, .col-lg-2 {
		padding-left: 10px;
		padding-right: 10px;
}
.masonry-load-more {
		padding-left: 20px;
}
@media (max-width:576px) {
	.nav-item {
  	margin-top: 10px;
	}
	.menu-link, .menu-title {
  	margin-top: 10px;
	}
	.comment-content {
		overflow-wrap: break-word;
	}
}		</style>
		<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script type="rocketlazyloadscript" data-rocket-type="text/javascript">
  var _paq = window._paq = window._paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(["setCookieDomain", "*.rosehosting.com"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//analytics.rosehosting.com/";
    _paq.push(['setTrackerUrl', u+'rosea.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.src='https://www.rosehosting.com/dist/rosea.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
</head>
<body class="post-template-default single single-post postid-38913 single-format-standard wp-embed-responsive post-image-above-header post-image-aligned-center sticky-menu-fade right-sidebar nav-below-header separate-containers contained-header active-footer-widgets-1 nav-aligned-left header-aligned-left dropdown-hover featured-image-active aa-prefix-rhad-">



<nav class="navbar yamm navbar-expand-lg navbar-dark" role="navigation">
  <div class="container no-override navbar-dark">

    <a class="navbar-brand" href="https://www.rosehosting.com/">
      <img alt="RoseHosting.com" width="186" height="37"  class="d-lg-inline mr-2" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20186%2037'%3E%3C/svg%3E" data-lazy-src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/rh-logo.svg" /><noscript><img alt="RoseHosting.com" width="186" height="37"  class="d-lg-inline mr-2" src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/rh-logo.svg" /></noscript>
    </a>

    <button class="navbar-toggler" data-toggle="collapse" data-target="#navbar-collapse">
      <span class="navbar-toggler-icon"></span>
    </button>

    <div class="collapse navbar-collapse justify-content-end" id="navbar-collapse">
      <ul class="navbar-nav">

        <li class="nav-item active dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Hosting Solutions
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">

            <div class="yamm-content">
              <div class="row">
                <div class="col-sm-6">
                   <span class="text-primary  dropdown-header"><strong>Managed SSD Hosting</strong></span>
                   <div class="dropdown-divider"></div>
                   <a class="dropdown-item" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/linux-vps-hosting/">Linux VPS Hosting</a>
                   <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom VPS</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/managed-cloud-hosting.html">Cloud Hosting</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/dedicated-servers.html">Dedicated Servers</a>
                   <a class="dropdown-item" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting <span class="ml-2 badge badge-success">new</span></a>
                </div>
                <div class="col-sm-6">
                  <span class="text-primary dropdown-header"><strong>Managed Solutions</strong></span>
                  <div class="dropdown-divider"></div>
                  <a class="dropdown-item" href="https://www.rosehosting.com/wordpress-hosting.html">
                    Wordpress Hosting
                    <small class="d-block text-muted"><i>The best blogging platform</i></small>
                  </a>
                  <a class="dropdown-item" href="https://www.rosehosting.com/magento-hosting.html">
                    Magento Hosting
                    <small class="d-block text-muted"><i>The best e-commerce platform</i></small>
                  </a>
                  <a class="dropdown-item" href="https://www.rosehosting.com/odoo-hosting.html">
                    Odoo Hosting
                    <small class="d-block text-muted"><i>The best CRM/ERP platform</i></small>
                  </a>
                  <span class="dropdown-item"><a class="btn-shadow btn-shadow-primary btn-shadow-sm" target="_blank" href="https://www.rosehosting.com/hosting-solutions.html">Other Solutions</a></span>

                </div>
              </div>
            </div>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            SSL / Domains
            <i class="fa fa-chevron-down"></i>
          </a>

          <div class="dropdown-menu" role="menu">

            <div class="yamm-content">
              <div class="row">
                <div class="col-sm-3">
                    <span class="text-primary  dropdown-header"><strong>SSL by brand</strong></span>
                    <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#geotrust">GeoTrust</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#comodo">Comodo</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#rapidssl">RapidSSL</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#thawte">Thawte</a>
                </div>
                <div class="col-sm-4">

                    <span class="text-primary  dropdown-header"><strong>SSL by Type</strong></span>
                    <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#domain_validation">Domain Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#organization_validation">Organization Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#extended_validation">Extended Validation</a>
                    <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#wildcard_ssl">Wildcard SSL</a>
                </div>
                <div class="col-sm-3">
                  <span class="text-primary dropdown-header"><strong>Domains</strong></span>
                  <div class="dropdown-divider"></div>
                    <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Register Domains</a>
                    <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Transfer Domains</a>
                </div>
              </div>
            </div>
          </div>


        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Support
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
              <a class="dropdown-item" href="https://www.rosehosting.com/support.html">24/7 Managed Support</a>
              <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Open a Support Ticket</a>
              <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>
	      <a class="dropdown-item" rel=”nofollow” href="https://status.rosehosting.net">Systems Status</a>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            About Us
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
            <a class="dropdown-item" href="https://www.rosehosting.com/about-us.html">Our Company</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/policies.html">Our Policies</a>
          </div>
        </li>

        <li class="nav-item dropdown">
          <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">
            Affiliates
            <i class="fa fa-chevron-down"></i>
          </a>
          <div class="dropdown-menu" role="menu">
            <a class="dropdown-item" href="https://www.rosehosting.com/cpa-hosting-affiliate-program.html">Flat-Rate CPA Affiliate Plan</a>
            <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Flat-Rate CPA Affiliate Login</a>
            <a class="dropdown-item" href="https://www.rosehosting.com/vps-affiliate-program.html">Recurring Affiliate Plan</a>
            <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/aff/">Recurring Affiliate Login</a>
          </div>
        </li>

        <li class="nav-item">
          <a class="nav-link" href="https://www.rosehosting.com/blog/">Blog</a>
        </li>

        <li class="nav-item">
          <a class="nav-link nav-link--rounded" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Login</a>
        </li>

      </ul>
    </div>

  </div>
</nav>


<!--
<nav class="navbar navbar-expand-lg navbar-light bg-faded navbar-blog">
   <div class="container no-override">
    <a href="https://www.rosehosting.com/blog/" class="navbar-brand">Blog Home</a>
    <div class="navbar-collapse collapse d-flex justify-content-between" id="navbar5-blog">
        <ul class="navbar-nav categories">
            <li class="nav-item dropdown">
              <a class="nav-link dropdown-toggle" data-toggle="dropdown" href="#" role="button" aria-haspopup="true" aria-expanded="false">
                Categories
                <i class="fa fa-chevron-down"></i>
              </a>
              <div class="dropdown-menu" style="z-index:0;">
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/caching/">Caching</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/centos/">CentOS</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/cms-crm-erp/">CMS, CRM, ERP</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/control-panels/">Control Panels</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/databases/">Databases</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/debian/">Debian</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/e-commerce/">E-Commerce</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/email-servers/">Email Servers</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/guides/">Guides</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/load-balancing/">Load Balancing</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/miscellaneous/">Miscellaneous</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/networking-and-domains/">Networking and Domains</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/news/">News</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/optimization/">Optimization</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/other/">Other</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/rosehosting/">RoseHosting Platform</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/scripts/">Scripts</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/security/">Security</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/seo/">SEO</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tips-and-tricks/">Tips and Tricks</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/tutorials/">Tutorials</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/ubuntu/">Ubuntu</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-frameworks/">Web Frameworks</a>
                                  <a class="dropdown-item" href="https://www.rosehosting.com/blog/category/web-servers/">Web Servers</a>
                              </div>
            </li>
        </ul>
        <form class="mx-2 my-auto d-inline" method="get" id="searchform" action="https://www.rosehosting.com/blog/">
            <div class="input-group">
                <input type="search" class="field" name="s" id="s" class="form-control border border-right-0" placeholder="Search...">
                <span class="input-group-append">
                <button name="submit" id="searchsubmit" class="btn btn-outline-secondary border border-left-0" type="submit">
                    <i class="fa fa-search"></i>
                </button>
              </span>
            </div>
        </form>
    </div>
  </div>
</nav> -->

	<div id="page-container" class="page-container">

	<div id="primary" class="content-area grid-parent mobile-grid-100 grid-70 tablet-grid-70">
		<main id="main" class="site-main">
			
<article id="post-38913" class="post-38913 post type-post status-publish format-standard has-post-thumbnail hentry category-guides category-load-balancing category-web-frameworks category-web-servers tag-automation tag-clustering tag-tomcat tag-tomee" itemtype="https://schema.org/CreativeWork" itemscope>
	<div class="inside-article">
					<header class="entry-header">
				<h1 class="entry-title" itemprop="headline">Tomcat and TomEE Clustering Automation</h1>		<div class="entry-meta">
			<span class="posted-on"><time class="entry-date published" datetime="2021-10-04T12:30:00-05:00" itemprop="datePublished">October 4, 2021</time></span> <span class="byline">by <span class="author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope><a class="url fn n" href="https://www.rosehosting.com/blog/author/jwilson/" title="View all posts by Jeff Wilson" rel="author" itemprop="url"><span class="author-name" itemprop="name">Jeff Wilson</span></a></span></span> 		</div>
					</header>
			
		<div class="entry-content" itemprop="text">
			<div  class="rhad-ad1d775129b8b3f5f329f5eeab5b517b rhad-before-content" id="rhad-ad1d775129b8b3f5f329f5eeab5b517b"></div>
<figure class="wp-block-image size-full"><img width="742" height="372" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20742%20372'%3E%3C/svg%3E" alt="tomcat and tomee clustering automation" class="wp-image-38934" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation.jpg?v=1632385978 742w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation-300x150.jpg?v=1632385978 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation-150x75.jpg?v=1632385978 150w" data-lazy-sizes="(max-width: 742px) 100vw, 742px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation.jpg" /><noscript><img width="742" height="372" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation.jpg" alt="tomcat and tomee clustering automation" class="wp-image-38934" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation.jpg?v=1632385978 742w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation-300x150.jpg?v=1632385978 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation-150x75.jpg?v=1632385978 150w" sizes="(max-width: 742px) 100vw, 742px" /></noscript></figure>



<p>Tomcat is an open-source web server and servlet container developed by the Apache Software Foundation, it was initially known as Jakarta Tomcat or Tomcat. If you want to deploy and execute Java applications that are written in Java technologies including Java Servlet, Java Server Pages (JSP), etc, then you require Tomcat. TomEE is built on top of Tomcat. It is the Java Enterprise Edition of Apache Tomcat (Tomcat + Java EE = TomEE).</p>



<div class="wp-block-image"><figure class="alignright size-large is-resized"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20134%2095'%3E%3C/svg%3E" alt="tomcat tomee autoclustering" class="wp-image-38949" width="134" height="95" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-tomee-autoclustering-1024x724.png?v=1632388727 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-tomee-autoclustering-300x212.png?v=1632388727 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-tomee-autoclustering-150x106.png?v=1632388727 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-tomee-autoclustering-768x543.png?v=1632388727 768w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-tomee-autoclustering.png?v=1632388727 1200w" data-lazy-sizes="(max-width: 134px) 100vw, 134px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-tomee-autoclustering-1024x724.png?v=1632388727" /><noscript><img src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-tomee-autoclustering-1024x724.png?v=1632388727" alt="tomcat tomee autoclustering" class="wp-image-38949" width="134" height="95" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-tomee-autoclustering-1024x724.png?v=1632388727 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-tomee-autoclustering-300x212.png?v=1632388727 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-tomee-autoclustering-150x106.png?v=1632388727 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-tomee-autoclustering-768x543.png?v=1632388727 768w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-tomee-autoclustering.png?v=1632388727 1200w" sizes="(max-width: 134px) 100vw, 134px" /></noscript></figure></div>



<p>If you have a website running on a production server with a Tomcat environment, your website might get thousands of web requests per minute. At this point, you most likely feel that the memory resources usage in one Tomcat JVM become overwhelmed. To prevent your server from going down or unresponsive, you can configure a Tomcat cluster by placing two or more Tomcat servers. A cluster is a group of servers that communicate with one another, and the Tomcat instance in a Tomcat cluster is often referred to as a node. Clustering instances of Tomcat make them interconnected.</p>



<span id="more-38913"></span>



<p>Implementing Tomcat and TomEE auto clustering in RoseHosting Cloud PaaS is fairly easy. In this guide, we will show you how to configure Tomcat and TomEE clustering automation on RoseHosting Cloud PaaS in a few steps.</p>



<div id="ez-toc-container" class="ez-toc-v2_0_17 counter-hierarchy ez-toc-transparent">
<div class="ez-toc-title-container">
<p class="ez-toc-title">Table of Contents</p>
<span class="ez-toc-title-toggle"><a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle" style="display: none;"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a></span></div>
<nav><ul class="ez-toc-list ez-toc-list-level-1"><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-1" href="#TomcatTomEE-Auto-Cluster-Installation" title="Tomcat/TomEE Auto-Cluster Installation">Tomcat/TomEE Auto-Cluster Installation</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-2" href="#Tomcat-TomEE-Cluster-Topology" title="Tomcat / TomEE Cluster Topology">Tomcat / TomEE Cluster Topology</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-3" href="#Tomcat-TomEE-Cluster-Horizontal-Scaling" title="Tomcat / TomEE Cluster Horizontal Scaling">Tomcat / TomEE Cluster Horizontal Scaling</a></li></ul></nav></div>
<h2 id="h-tomcat-tomee-auto-cluster-installation"><span class="ez-toc-section" id="TomcatTomEE-Auto-Cluster-Installation"></span>Tomcat/TomEE Auto-Cluster Installation<span class="ez-toc-section-end"></span></h2>



<p>In this article, we are not going to compare Tomcat and TomEE functionality, however, you can see the comparison table below.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="532" height="503" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20532%20503'%3E%3C/svg%3E" alt="tomee and tomcat clustering automation" class="wp-image-38935" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-clustering-automation.png?v=1632387069 532w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-clustering-automation-300x284.png?v=1632387069 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-clustering-automation-150x142.png?v=1632387069 150w" data-lazy-sizes="(max-width: 532px) 100vw, 532px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-clustering-automation.png" /><noscript><img width="532" height="503" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-clustering-automation.png" alt="tomee and tomcat clustering automation" class="wp-image-38935" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-clustering-automation.png?v=1632387069 532w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-clustering-automation-300x284.png?v=1632387069 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-clustering-automation-150x142.png?v=1632387069 150w" sizes="(max-width: 532px) 100vw, 532px" /></noscript></figure></div>



<p>There are many tutorials on how to configure Tomcat/TomEE cluster you can find on the internet, but for some users, they found it complicated and not user-friendly. With RoseHosting Cloud PaaS, we can complete Tomcat or TomEE clustering automation in a few steps.</p>



<ol><li>Log in to your RoseHosting Cloud PaaS account at https://app.rosehosting.cloud and click on New Environment</li></ol>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="692" height="111" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20692%20111'%3E%3C/svg%3E" alt="clustering automation for tomee and tomcat" class="wp-image-38936" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomee-and-tomcat.png?v=1632387124 692w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomee-and-tomcat-300x48.png?v=1632387124 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomee-and-tomcat-150x24.png?v=1632387124 150w" data-lazy-sizes="(max-width: 692px) 100vw, 692px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomee-and-tomcat.png" /><noscript><img width="692" height="111" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomee-and-tomcat.png" alt="clustering automation for tomee and tomcat" class="wp-image-38936" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomee-and-tomcat.png?v=1632387124 692w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomee-and-tomcat-300x48.png?v=1632387124 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomee-and-tomcat-150x24.png?v=1632387124 150w" sizes="(max-width: 692px) 100vw, 692px" /></noscript></figure></div>



<ol start="2"><li>In the topology wizard, choose Tomcat or TomEE among Java application servers and switch on the Auto-Clustering slider. You can adjust anything you want, like the disk limit, scaling limit, etc then click on Create button at bottom right.</li></ol>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="976" height="608" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20976%20608'%3E%3C/svg%3E" alt="clustering automation for tomcat and tomee" class="wp-image-38937" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomcat-and-tomee.png?v=1632387193 976w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomcat-and-tomee-300x187.png?v=1632387193 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomcat-and-tomee-150x93.png?v=1632387193 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomcat-and-tomee-768x478.png?v=1632387193 768w" data-lazy-sizes="(max-width: 976px) 100vw, 976px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomcat-and-tomee.png" /><noscript><img width="976" height="608" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomcat-and-tomee.png" alt="clustering automation for tomcat and tomee" class="wp-image-38937" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomcat-and-tomee.png?v=1632387193 976w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomcat-and-tomee-300x187.png?v=1632387193 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomcat-and-tomee-150x93.png?v=1632387193 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/clustering-automation-for-tomcat-and-tomee-768x478.png?v=1632387193 768w" sizes="(max-width: 976px) 100vw, 976px" /></noscript></figure></div>



<ol start="3"><li>Wait for a few minutes and you will get a notification on your dashboard and an email telling you that the environment has been successfully created.</li></ol>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="305" height="246" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20305%20246'%3E%3C/svg%3E" alt="auto clustering for tomcat and tomee" class="wp-image-38938" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomcat-and-tomee.png?v=1632387258 305w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomcat-and-tomee-300x242.png?v=1632387258 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomcat-and-tomee-150x121.png?v=1632387258 150w" data-lazy-sizes="(max-width: 305px) 100vw, 305px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomcat-and-tomee.png" /><noscript><img width="305" height="246" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomcat-and-tomee.png" alt="auto clustering for tomcat and tomee" class="wp-image-38938" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomcat-and-tomee.png?v=1632387258 305w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomcat-and-tomee-300x242.png?v=1632387258 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomcat-and-tomee-150x121.png?v=1632387258 150w" sizes="(max-width: 305px) 100vw, 305px" /></noscript></figure></div>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1024" height="240" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20240'%3E%3C/svg%3E" alt="auto clustering for tomee and tomcat" class="wp-image-38939" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomee-and-tomcat.png?v=1632387331 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomee-and-tomcat-300x70.png?v=1632387331 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomee-and-tomcat-150x35.png?v=1632387331 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomee-and-tomcat-768x180.png?v=1632387331 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomee-and-tomcat.png" /><noscript><img width="1024" height="240" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomee-and-tomcat.png" alt="auto clustering for tomee and tomcat" class="wp-image-38939" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomee-and-tomcat.png?v=1632387331 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomee-and-tomcat-300x70.png?v=1632387331 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomee-and-tomcat-150x35.png?v=1632387331 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/auto-clustering-for-tomee-and-tomcat-768x180.png?v=1632387331 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<p>The new environment is already running. You can see load balancer and application servers in the new environment.</p>



<h2><span class="ez-toc-section" id="Tomcat-TomEE-Cluster-Topology"></span>Tomcat / TomEE Cluster Topology<span class="ez-toc-section-end"></span></h2>



<p>The picture below shows the default cluster topology:</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="768" height="927" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20768%20927'%3E%3C/svg%3E" alt="automatic clustering of tomcat and tomee" class="wp-image-38940" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automatic-clustering-of-tomcat-and-tomee.png?v=1632387383 768w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automatic-clustering-of-tomcat-and-tomee-249x300.png?v=1632387383 249w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automatic-clustering-of-tomcat-and-tomee-124x150.png?v=1632387383 124w" data-lazy-sizes="(max-width: 768px) 100vw, 768px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automatic-clustering-of-tomcat-and-tomee.png" /><noscript><img width="768" height="927" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automatic-clustering-of-tomcat-and-tomee.png" alt="automatic clustering of tomcat and tomee" class="wp-image-38940" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automatic-clustering-of-tomcat-and-tomee.png?v=1632387383 768w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automatic-clustering-of-tomcat-and-tomee-249x300.png?v=1632387383 249w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automatic-clustering-of-tomcat-and-tomee-124x150.png?v=1632387383 124w" sizes="(max-width: 768px) 100vw, 768px" /></noscript></figure></div>



<p>Using the topology as shown in the picture above will ensure that it meets the performance and fault tolerance requirements. NGINX acts as the load balancer in front of the cluster that handles the workload distribution.</p>



<p>Once completed, you can click on the &#8216;Config&#8217; button under the Application servers</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="622" height="240" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20622%20240'%3E%3C/svg%3E" alt="automatic clustering of tomee and tomcat" class="wp-image-38941" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automatic-clustering-of-tomee-and-tomcat.png?v=1632387542 622w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automatic-clustering-of-tomee-and-tomcat-300x116.png?v=1632387542 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automatic-clustering-of-tomee-and-tomcat-150x58.png?v=1632387542 150w" data-lazy-sizes="(max-width: 622px) 100vw, 622px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automatic-clustering-of-tomee-and-tomcat.png" /><noscript><img width="622" height="240" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automatic-clustering-of-tomee-and-tomcat.png" alt="automatic clustering of tomee and tomcat" class="wp-image-38941" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automatic-clustering-of-tomee-and-tomcat.png?v=1632387542 622w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automatic-clustering-of-tomee-and-tomcat-300x116.png?v=1632387542 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automatic-clustering-of-tomee-and-tomcat-150x58.png?v=1632387542 150w" sizes="(max-width: 622px) 100vw, 622px" /></noscript></figure></div>



<p>Then navigate to /opt/tomcat/conf/ in directory three on the left and you will find that the &#8220;Cluster&#8221; element is added to the <code>/opt/tomcat/conf/tomcat-cluster.xml</code> configuration file:</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1024" height="325" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20325'%3E%3C/svg%3E" alt="tomcat and tomee automated clustering" class="wp-image-38942" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-automated-clustering.png?v=1632387599 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-automated-clustering-300x95.png?v=1632387599 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-automated-clustering-150x48.png?v=1632387599 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-automated-clustering-768x244.png?v=1632387599 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-automated-clustering.png" /><noscript><img width="1024" height="325" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-automated-clustering.png" alt="tomcat and tomee automated clustering" class="wp-image-38942" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-automated-clustering.png?v=1632387599 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-automated-clustering-300x95.png?v=1632387599 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-automated-clustering-150x48.png?v=1632387599 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-automated-clustering-768x244.png?v=1632387599 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<p>If you want to check or modify something, you can do it at <a href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase/article/188/configuration-file-manager/" target="_blank" rel="noreferrer noopener">Configuration File Manager</a>.</p>



<p>Let&#8217;s look through this in more detail:</p>



<p>The Tomcat instance is added to the configuration as LocalMember. Other Tomcat nodes in the layer are added by their IPs and unique ID, which are generated using the containers&#8217; IP addresses and IDs.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1024" height="325" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20325'%3E%3C/svg%3E" alt="tomee and tomcat automated clustering" class="wp-image-38944" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-automated-clustering-1.png?v=1632387690 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-automated-clustering-1-300x95.png?v=1632387690 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-automated-clustering-1-150x48.png?v=1632387690 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-automated-clustering-1-768x244.png?v=1632387690 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-automated-clustering-1.png" /><noscript><img width="1024" height="325" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-automated-clustering-1.png" alt="tomee and tomcat automated clustering" class="wp-image-38944" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-automated-clustering-1.png?v=1632387690 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-automated-clustering-1-300x95.png?v=1632387690 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-automated-clustering-1-150x48.png?v=1632387690 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomee-and-tomcat-automated-clustering-1-768x244.png?v=1632387690 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<p>For relocating sessions, we use the DeltaManager. The session data is spread across all the layer nodes.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1024" height="450" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20450'%3E%3C/svg%3E" alt="automated clustering for tomcat and tomee" class="wp-image-38945" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomcat-and-tomee.png?v=1632387763 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomcat-and-tomee-300x132.png?v=1632387763 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomcat-and-tomee-150x66.png?v=1632387763 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomcat-and-tomee-768x338.png?v=1632387763 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomcat-and-tomee.png" /><noscript><img width="1024" height="450" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomcat-and-tomee.png" alt="automated clustering for tomcat and tomee" class="wp-image-38945" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomcat-and-tomee.png?v=1632387763 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomcat-and-tomee-300x132.png?v=1632387763 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomcat-and-tomee-150x66.png?v=1632387763 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomcat-and-tomee-768x338.png?v=1632387763 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<p>For discovering the cluster peers we use the Static membership and the server.xml file on every node also a list of all the cluster members.</p>



<p>The cluster uses TCP protocol on port 4004 to create an interconnection between the nodes &#8211; the cluster creation process also adds the firewall rule.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1024" height="325" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20325'%3E%3C/svg%3E" alt="automated clustering for tomee and tomcat" class="wp-image-38946" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomee-and-tomcat.png?v=1632387845 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomee-and-tomcat-300x95.png?v=1632387845 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomee-and-tomcat-150x48.png?v=1632387845 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomee-and-tomcat-768x244.png?v=1632387845 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomee-and-tomcat.png" /><noscript><img width="1024" height="325" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomee-and-tomcat.png" alt="automated clustering for tomee and tomcat" class="wp-image-38946" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomee-and-tomcat.png?v=1632387845 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomee-and-tomcat-300x95.png?v=1632387845 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomee-and-tomcat-150x48.png?v=1632387845 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/automated-clustering-for-tomee-and-tomcat-768x244.png?v=1632387845 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<p>In the<code> /opt/tomcat/conf/context.xml </code>configuration file, the &#8220;<strong>org.apache.catalina.ha.context.ReplicatedContext</strong>&#8221; class is used for the context implementation to allow replication.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1024" height="450" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20450'%3E%3C/svg%3E" alt="how to automatically cluster tomcat and tomee" class="wp-image-38947" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-automatically-cluster-tomcat-and-tomee.png?v=1632387933 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-automatically-cluster-tomcat-and-tomee-300x132.png?v=1632387933 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-automatically-cluster-tomcat-and-tomee-150x66.png?v=1632387933 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-automatically-cluster-tomcat-and-tomee-768x338.png?v=1632387933 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-automatically-cluster-tomcat-and-tomee.png" /><noscript><img width="1024" height="450" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-automatically-cluster-tomcat-and-tomee.png" alt="how to automatically cluster tomcat and tomee" class="wp-image-38947" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-automatically-cluster-tomcat-and-tomee.png?v=1632387933 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-automatically-cluster-tomcat-and-tomee-300x132.png?v=1632387933 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-automatically-cluster-tomcat-and-tomee-150x66.png?v=1632387933 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-automatically-cluster-tomcat-and-tomee-768x338.png?v=1632387933 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<p>The instance creation process generated all these configurations automatically and does not require manual modification.</p>



<h2><span class="ez-toc-section" id="Tomcat-TomEE-Cluster-Horizontal-Scaling"></span>Tomcat / TomEE Cluster Horizontal Scaling<span class="ez-toc-section-end"></span></h2>



<p>In RoseHosting Cloud PaaS, enabling Tomcat/TomEE Cluster Horizontal Scaling is fairly easy.</p>



<ol><li>Click on your Tomcat/TomEE cluster environment then go to Settings &gt; Auto Horizontal Scaling</li></ol>



<div class="wp-block-image"><figure class="aligncenter size-full"><img width="1024" height="340" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20340'%3E%3C/svg%3E" alt="how to auto cluster tomcat and tomee" class="wp-image-38948" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-auto-cluster-tomcat-and-tomee.png?v=1632388003 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-auto-cluster-tomcat-and-tomee-300x100.png?v=1632388003 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-auto-cluster-tomcat-and-tomee-150x50.png?v=1632388003 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-auto-cluster-tomcat-and-tomee-768x255.png?v=1632388003 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-auto-cluster-tomcat-and-tomee.png" /><noscript><img width="1024" height="340" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-auto-cluster-tomcat-and-tomee.png" alt="how to auto cluster tomcat and tomee" class="wp-image-38948" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-auto-cluster-tomcat-and-tomee.png?v=1632388003 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-auto-cluster-tomcat-and-tomee-300x100.png?v=1632388003 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-auto-cluster-tomcat-and-tomee-150x50.png?v=1632388003 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-auto-cluster-tomcat-and-tomee-768x255.png?v=1632388003 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure></div>



<ol start="2"><li>Set up scaling triggers for the required resources</li></ol>



<p>In this section, you can configure the scaling limit according to your liking. You can configure the triggers for specific stacks and resources (CPU, RAM, Network, Disk) within your environment separately. Just specify the conditions of scaling and then click on the Apply button to apply the changes.</p>



<p>Please note that the minimum number of worker nodes to run horizontal clustering is 2, you can set up the Scale in limit respectively as in the picture above.</p>



<p>That&#8217;s it! You have successfully configured Tomcat/TomEE Auto-Clustering on <a href="https://www.rosehosting.com/managed-cloud-hosting.html" target="_blank" rel="noreferrer noopener"><strong>RoseHosting Cloud PaaS</strong></a>.</p>



<p>Of course, you don’t have to do Tomcat/TomEE Auto-Cluster Installation if you have an account at RoseHosting Cloud PaaS, in which case you can simply ask our expert Linux admins to do Tomcat/TomEE Auto-Cluster Installation for you. They are available 24×7 and will take care of your request immediately. If you do not have an account at RoseHosting Cloud PaaS and are looking for a reliable <strong><a href="https://www.rosehosting.com/tomcat-hosting.html" target="_blank" rel="noreferrer noopener">Tomcat web hosting</a></strong> that offers scalability and high availability, RoseHosting Cloud PaaS auto-clustering is an excellent solution to consider.</p>



<p>PS. If you liked this post, on how to do Tomcat/TomEE Auto-Cluster Installation, please share it with your friends on the social networks using the buttons on the left or simply leave a reply below. Thanks.</p>
		</div>

				<footer class="entry-meta">
			<span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://www.rosehosting.com/blog/category/guides/" rel="category tag">Guides</a>, <a href="https://www.rosehosting.com/blog/category/load-balancing/" rel="category tag">Load Balancing</a>, <a href="https://www.rosehosting.com/blog/category/web-frameworks/" rel="category tag">Web Frameworks</a>, <a href="https://www.rosehosting.com/blog/category/web-servers/" rel="category tag">Web Servers</a></span> 		<nav id="nav-below" class="post-navigation">
			<span class="screen-reader-text">Post navigation</span>

			<div class="nav-previous"><span class="prev" title="Previous"><a href="https://www.rosehosting.com/blog/how-to-install-mern-stack-for-js-based-applications-on-ubuntu-20-04/" rel="prev">How to Install MERN Stack for JS Based Applications on Ubuntu 20.04</a></span></div><div class="nav-next"><span class="next" title="Next"><a href="https://www.rosehosting.com/blog/how-to-configure-static-ip-address-on-ubuntu-20-04/" rel="next">How to Configure Static IP Address on Ubuntu 20.04</a></span></div>		</nav>
				</footer>
			</div>
</article>

			<div class="comments-area">
				<div id="comments">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/tomcat-and-tomee-clustering-automation/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.rosehosting.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea autocomplete="new-password"  id="e42af3c480"  name="e42af3c480"   cols="45" rows="8" aria-required="true" required></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0 !important;clip:rect(1px, 1px, 1px, 1px) !important;position:absolute !important;white-space:nowrap !important;height:1px !important;width:1px !important;overflow:hidden !important;" tabindex="-1"></textarea><script type="rocketlazyloadscript" data-noptimize data-rocket-type="text/javascript">document.getElementById("comment").setAttribute( "id", "a7e6bd102f44a30f6ccfbd3367ffd213" );document.getElementById("e42af3c480").setAttribute( "id", "comment" );</script></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" />
<label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" />

<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="cptch_block"><span class="cptch_title cptch_to_remove">To prove you are human please solve the following<span class="required"> *</span></span><span class="cptch_wrap cptch_math_actions">
				<label class="cptch_label" for="cptch_input_14"><span class="cptch_span"><input id="cptch_input_14" class="cptch_input cptch_wp_comments" type="text" autocomplete="off" name="cptch_number" value="" maxlength="2" size="2" aria-required="true" required="required" style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /></span>
					<span class="cptch_span">&nbsp;&times;&nbsp;</span>
					<span class="cptch_span">4</span>
					<span class="cptch_span">&nbsp;=&nbsp;</span>
					<span class="cptch_span">28</span>
					<input type="hidden" name="cptch_result" value="vL8=" /><input type="hidden" name="cptch_time" value="1633543154" />
					<input type="hidden" name="cptch_form" value="wp_comments" />
				</label><span class="cptch_reload_button_wrap hide-if-no-js">
					<noscript>
						<style type="text/css">
							.hide-if-no-js {
								display: none !important;
							}
						</style>
					</noscript>
					<span class="cptch_reload_button dashicons dashicons-update"></span>
				</span></span></p><p class="comment-form-mailpoet">
      <label for="mailpoet_subscribe_on_comment">
        <input
          type="checkbox"
          id="mailpoet_subscribe_on_comment"
          value="1"
          name="mailpoet[subscribe_on_comment]"
        />&nbsp;Yes, add me to your new blog post notifications list
      </label>
    </p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='38913' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->
			</div>

					</main>
	</div>

	<div id="right-sidebar" class="widget-area sidebar is-right-sidebar grid-30 tablet-grid-30 grid-parent" itemtype="https://schema.org/WPSideBar" itemscope>
	<div class="inside-right-sidebar">
		<aside id="categories-3" class="widget inner-padding widget_categories"><h2 class="widget-title">Categories</h2><form action="https://www.rosehosting.com/blog" method="get"><label class="screen-reader-text" for="cat">Categories</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="1709">Caching&nbsp;&nbsp;(23)</option>
	<option class="level-0" value="1699">CentOS&nbsp;&nbsp;(303)</option>
	<option class="level-0" value="1710">CMS, CRM, ERP&nbsp;&nbsp;(230)</option>
	<option class="level-0" value="1708">Control Panels&nbsp;&nbsp;(47)</option>
	<option class="level-0" value="1702">Databases&nbsp;&nbsp;(106)</option>
	<option class="level-0" value="1700">Debian&nbsp;&nbsp;(151)</option>
	<option class="level-0" value="1711">E-Commerce&nbsp;&nbsp;(62)</option>
	<option class="level-0" value="1706">Email Servers&nbsp;&nbsp;(36)</option>
	<option class="level-0" value="1236">Guides&nbsp;&nbsp;(58)</option>
	<option class="level-0" value="1705">Load Balancing&nbsp;&nbsp;(5)</option>
	<option class="level-0" value="1">Miscellaneous&nbsp;&nbsp;(51)</option>
	<option class="level-0" value="1701">Networking and Domains&nbsp;&nbsp;(42)</option>
	<option class="level-0" value="3">News&nbsp;&nbsp;(12)</option>
	<option class="level-0" value="1704">Optimization&nbsp;&nbsp;(21)</option>
	<option class="level-0" value="1713">Other&nbsp;&nbsp;(6)</option>
	<option class="level-0" value="4">RoseHosting Platform&nbsp;&nbsp;(43)</option>
	<option class="level-0" value="5">Scripts&nbsp;&nbsp;(11)</option>
	<option class="level-0" value="1703">Security&nbsp;&nbsp;(104)</option>
	<option class="level-0" value="606">SEO&nbsp;&nbsp;(2)</option>
	<option class="level-0" value="21">Tips and Tricks&nbsp;&nbsp;(74)</option>
	<option class="level-0" value="13">Tutorials&nbsp;&nbsp;(795)</option>
	<option class="level-0" value="1698">Ubuntu&nbsp;&nbsp;(383)</option>
	<option class="level-0" value="1712">Web Frameworks&nbsp;&nbsp;(112)</option>
	<option class="level-0" value="1707">Web Servers&nbsp;&nbsp;(140)</option>
</select>
</form>
<script type="rocketlazyloadscript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</aside><aside class="widget inner-padding rhad-widget"><div  class="rhad-6f1ff3cdeb62f198cd5650cbe6e98065 rhad-sidebar-ad-group" id="rhad-6f1ff3cdeb62f198cd5650cbe6e98065"></div></aside><aside id="custom_html-8" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a target="_blank" href="https://www.rosehosting.com/about-us.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">About RoseHosting</a><br>
<a target="_blank" href="https://www.rosehosting.com/linux-vps-hosting/" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Buy a Managed VPS - 25% OFF</a><br>
<a target="_blank" href="https://www.rosehosting.com/reviews.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">RoseHosting Customer Reviews</a><br>
<a target="_blank" href="https://www.rosehosting.com/nvme-hosting.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Managed NVMe VPSes</a><br>
	<a target="_blank" href="https://www.rosehosting.com/dedicated-servers.html" style="margin-bottom:6px; color: #fff;
background-color: #374657 !important;
width: 100%;
border: 1px solid #e8d5d5;
font-size: 16px;
display: inline-block;
padding: 10px;
border-radius: 5px;
box-shadow: rgba(26,43,99,.4) 3px 3px 1px;
text-align: center;
" rel="noopener">Managed NVMe Dedicated Servers</a>
</div></aside><aside id="zoom-social-icons-widget-2" class="widget inner-padding zoom-social-icons-widget">
		
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--align-center zoom-social-icons-list--no-labels">

		
				<li class="zoom-social_icons-list__item">
		<a class="zoom-social_icons-list__link" href="https://www.facebook.com/RoseHosting" target="_blank" >
									
						<span class="screen-reader-text">facebook</span>
			
						<span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #3b5998; font-size: 30px; padding:10px" ></span>
			
					</a>
	</li>

	
				<li class="zoom-social_icons-list__item">
		<a class="zoom-social_icons-list__link" href="https://twitter.com/rosehosting" target="_blank" >
									
						<span class="screen-reader-text">twitter</span>
			
						<span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#1da1f2" style="background-color : #1da1f2; font-size: 30px; padding:10px" ></span>
			
					</a>
	</li>

	
				<li class="zoom-social_icons-list__item">
		<a class="zoom-social_icons-list__link" href="https://www.linkedin.com/company/rose-web-services-l-l-c-" target="_blank" >
									
						<span class="screen-reader-text">linkedin</span>
			
						<span class="zoom-social_icons-list-span social-icon socicon socicon-linkedin" data-hover-rule="background-color" data-hover-color="#0077B5" style="background-color : #0077B5; font-size: 30px; padding:10px" ></span>
			
					</a>
	</li>

	
</ul>

		</aside><aside id="search-3" class="widget inner-padding widget_search"><form method="get" class="search-form" action="https://www.rosehosting.com/blog/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:">
	</label>
	<input type="submit" class="search-submit" value="Search"></form>
</aside><aside id="recent-posts-widget-with-thumbnails-2" class="widget inner-padding recent-posts-widget-with-thumbnails">
<div id="rpwwt-recent-posts-widget-with-thumbnails-2" class="rpwwt-widget">
	<ul>
		<li><a href="https://www.rosehosting.com/blog/how-to-configure-static-ip-address-on-ubuntu-20-04/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="how to configure static ip address on ubuntu 20.04" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-configure-static-ip-address-on-ubuntu-20.04-150x75.jpg?v=1632395129 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-configure-static-ip-address-on-ubuntu-20.04-300x150.jpg?v=1632395129 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-configure-static-ip-address-on-ubuntu-20.04.jpg?v=1632395129 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-configure-static-ip-address-on-ubuntu-20.04-150x75.jpg?v=1632395129" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-configure-static-ip-address-on-ubuntu-20.04-150x75.jpg?v=1632395129" class="attachment-75x75 size-75x75" alt="how to configure static ip address on ubuntu 20.04" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-configure-static-ip-address-on-ubuntu-20.04-150x75.jpg?v=1632395129 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-configure-static-ip-address-on-ubuntu-20.04-300x150.jpg?v=1632395129 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/how-to-configure-static-ip-address-on-ubuntu-20.04.jpg?v=1632395129 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Configure Static IP Address on Ubuntu 20.04</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/tomcat-and-tomee-clustering-automation/" aria-current="page"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="tomcat and tomee clustering automation" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation-150x75.jpg?v=1632385978 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation-300x150.jpg?v=1632385978 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation.jpg?v=1632385978 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation-150x75.jpg?v=1632385978" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation-150x75.jpg?v=1632385978" class="attachment-75x75 size-75x75" alt="tomcat and tomee clustering automation" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation-150x75.jpg?v=1632385978 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation-300x150.jpg?v=1632385978 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/09/tomcat-and-tomee-clustering-automation.jpg?v=1632385978 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">Tomcat and TomEE Clustering Automation</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-mern-stack-for-js-based-applications-on-ubuntu-20-04/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="How to Install MERN Stack for JS based applications on Ubuntu 20.04" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-install-mern-stack-for-js-based-applications-on-ubuntu-20.04-150x75.jpg?v=1630330649 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-install-mern-stack-for-js-based-applications-on-ubuntu-20.04-300x150.jpg?v=1630330649 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-install-mern-stack-for-js-based-applications-on-ubuntu-20.04.jpg?v=1630330649 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-install-mern-stack-for-js-based-applications-on-ubuntu-20.04-150x75.jpg?v=1630330649" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-install-mern-stack-for-js-based-applications-on-ubuntu-20.04-150x75.jpg?v=1630330649" class="attachment-75x75 size-75x75" alt="How to Install MERN Stack for JS based applications on Ubuntu 20.04" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-install-mern-stack-for-js-based-applications-on-ubuntu-20.04-150x75.jpg?v=1630330649 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-install-mern-stack-for-js-based-applications-on-ubuntu-20.04-300x150.jpg?v=1630330649 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-install-mern-stack-for-js-based-applications-on-ubuntu-20.04.jpg?v=1630330649 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Install MERN Stack for JS Based Applications on Ubuntu 20.04</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-enable-https-protocol-with-apache-2-on-ubuntu-20-04/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="How to Enable HTTPS protocol with Apache 2 on Ubuntu 20.04" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-enable-https-protocol-with-apache2-on-ubuntu-20.04-150x75.jpg?v=1629793089 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-enable-https-protocol-with-apache2-on-ubuntu-20.04-300x150.jpg?v=1629793089 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-enable-https-protocol-with-apache2-on-ubuntu-20.04.jpg?v=1629793089 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-enable-https-protocol-with-apache2-on-ubuntu-20.04-150x75.jpg?v=1629793089" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-enable-https-protocol-with-apache2-on-ubuntu-20.04-150x75.jpg?v=1629793089" class="attachment-75x75 size-75x75" alt="How to Enable HTTPS protocol with Apache 2 on Ubuntu 20.04" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-enable-https-protocol-with-apache2-on-ubuntu-20.04-150x75.jpg?v=1629793089 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-enable-https-protocol-with-apache2-on-ubuntu-20.04-300x150.jpg?v=1629793089 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-enable-https-protocol-with-apache2-on-ubuntu-20.04.jpg?v=1629793089 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How To Enable HTTPS Protocol with Apache 2 on Ubuntu 20.04</span></a></li>
		<li><a href="https://www.rosehosting.com/blog/how-to-install-postgresql-9-6-on-ubuntu-20-04/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="How to Install PostgreSQL 9.6 on Ubuntu 20.04" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-install-postgreSQL-9.6-on-ubuntu-20.04-150x75.jpg?v=1629790782 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-install-postgreSQL-9.6-on-ubuntu-20.04-300x150.jpg?v=1629790782 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-install-postgreSQL-9.6-on-ubuntu-20.04.jpg?v=1629790782 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-install-postgreSQL-9.6-on-ubuntu-20.04-150x75.jpg?v=1629790782" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-install-postgreSQL-9.6-on-ubuntu-20.04-150x75.jpg?v=1629790782" class="attachment-75x75 size-75x75" alt="How to Install PostgreSQL 9.6 on Ubuntu 20.04" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-install-postgreSQL-9.6-on-ubuntu-20.04-150x75.jpg?v=1629790782 150w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-install-postgreSQL-9.6-on-ubuntu-20.04-300x150.jpg?v=1629790782 300w, https://www.rosehosting.com/blog/wp-content/uploads/2021/08/how-to-install-postgreSQL-9.6-on-ubuntu-20.04.jpg?v=1629790782 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Install PostgreSQL 9.6 on Ubuntu 20.04</span></a></li>
	</ul>
</div><!-- .rpwwt-widget -->
</aside>      <aside id="mailpoet_form-2" class="widget inner-padding widget_mailpoet_form">
  
  
  <div class="
    mailpoet_form_popup_overlay
      "></div>
  <div
    id="mailpoet_form_2"
    class="
      mailpoet_form
      mailpoet_form_widget
      mailpoet_form_position_
      mailpoet_form_animation_
    "
      >
    
    <style type="text/css">
     .mailpoet_hp_email_label{display:none!important;}#mailpoet_form_2 .mailpoet_form {  }
#mailpoet_form_2 form { margin-bottom: 0; }
#mailpoet_form_2 p.mailpoet_form_paragraph { margin-bottom: 10px; }
#mailpoet_form_2 .mailpoet_column_with_background { padding: 10px; }
#mailpoet_form_2 .mailpoet_form_column:not(:first-child) { margin-left: 20px; }
#mailpoet_form_2 .mailpoet_paragraph { line-height: 20px; margin-bottom: 20px; }
#mailpoet_form_2 .mailpoet_segment_label, #mailpoet_form_2 .mailpoet_text_label, #mailpoet_form_2 .mailpoet_textarea_label, #mailpoet_form_2 .mailpoet_select_label, #mailpoet_form_2 .mailpoet_radio_label, #mailpoet_form_2 .mailpoet_checkbox_label, #mailpoet_form_2 .mailpoet_list_label, #mailpoet_form_2 .mailpoet_date_label { display: block; font-weight: normal; }
#mailpoet_form_2 .mailpoet_text, #mailpoet_form_2 .mailpoet_textarea, #mailpoet_form_2 .mailpoet_select, #mailpoet_form_2 .mailpoet_date_month, #mailpoet_form_2 .mailpoet_date_day, #mailpoet_form_2 .mailpoet_date_year, #mailpoet_form_2 .mailpoet_date { display: block; }
#mailpoet_form_2 .mailpoet_text, #mailpoet_form_2 .mailpoet_textarea { width: 200px; }
#mailpoet_form_2 .mailpoet_checkbox {  }
#mailpoet_form_2 .mailpoet_submit {  }
#mailpoet_form_2 .mailpoet_divider {  }
#mailpoet_form_2 .mailpoet_message {  }
#mailpoet_form_2 .mailpoet_form_loading { width: 30px; text-align: center; line-height: normal; }
#mailpoet_form_2 .mailpoet_form_loading > span { width: 5px; height: 5px; background-color: #5b5b5b; }#mailpoet_form_2{border-radius: 0px;background: #ffffff;text-align: left;}#mailpoet_form_2 form.mailpoet_form {padding: 10px;}#mailpoet_form_2{width: 100%;}#mailpoet_form_2 .mailpoet_message {margin: 0; padding: 0 20px;}
        #mailpoet_form_2 .mailpoet_validate_success {color: #00d084}
        #mailpoet_form_2 input.parsley-success {color: #00d084}
        #mailpoet_form_2 select.parsley-success {color: #00d084}
        #mailpoet_form_2 textarea.parsley-success {color: #00d084}
      
        #mailpoet_form_2 .mailpoet_validate_error {color: #cf2e2e}
        #mailpoet_form_2 input.parsley-error {color: #cf2e2e}
        #mailpoet_form_2 select.parsley-error {color: #cf2e2e}
        #mailpoet_form_2 textarea.textarea.parsley-error {color: #cf2e2e}
        #mailpoet_form_2 .parsley-errors-list {color: #cf2e2e}
        #mailpoet_form_2 .parsley-required {color: #cf2e2e}
        #mailpoet_form_2 .parsley-custom-error-message {color: #cf2e2e}
      #mailpoet_form_2 .mailpoet_paragraph.last {margin-bottom: 0} @media (max-width: 500px) {#mailpoet_form_2 {background: #ffffff;}} @media (min-width: 500px) {#mailpoet_form_2 .last .mailpoet_paragraph:last-child {margin-bottom: 0}}  @media (max-width: 500px) {#mailpoet_form_2 .mailpoet_form_column:last-child .mailpoet_paragraph:last-child {margin-bottom: 0}} 
    </style>

    <form
      target="_self"
      method="post"
      action="https://www.rosehosting.com/blog/wp-admin/admin-post.php?action=mailpoet_subscription_form"
      class="mailpoet_form mailpoet_form_form mailpoet_form_widget"
      novalidate
      data-delay=""
      data-exit-intent-enabled=""
      data-font-family=""
    >
      <input type="hidden" name="data[form_id]" value="2" />
      <input type="hidden" name="token" value="3c9d590c6b" />
      <input type="hidden" name="api_version" value="v1" />
      <input type="hidden" name="endpoint" value="subscribers" />
      <input type="hidden" name="mailpoet_method" value="subscribe" />

      <label class="mailpoet_hp_email_label">Please leave this field empty<input type="email" name="data[email]"/></label><h2 class="mailpoet-heading  mailpoet-has-font-size" id="" style="text-align: center; color: #0081ff; font-size: 20px; line-height: 1.5"><span style="font-family: Montserrat" data-font="Montserrat" class="mailpoet-has-font"><strong><span class="has-inline-color has-black-color">Join our Blog</span></strong></span></h2>
<p class="mailpoet_form_paragraph  mailpoet-has-font-size" style="text-align: center; color: #000000; font-size: 14px; line-height: 1.5"><strong><span style="font-family: Montserrat" data-font="Montserrat" class="mailpoet-has-font">Sign up and receive notifications as soon as new content is posted.</span></strong></p>
<div class="mailpoet_paragraph "><input type="email" class="mailpoet_text" name="data[form_field_ZTVlY2IyMzIyMzFkX2VtYWls]" title="Enter your e-mail" value="" style="width:100%;padding:12px;margin: 0 auto 0 0;font-size:15px;line-height:1.5;height:auto;" data-automation-id="form_email"  placeholder="Enter your e-mail *" data-parsley-required="true" data-parsley-minlength="6" data-parsley-maxlength="150" data-parsley-error-message="Please specify a valid email address." data-parsley-required-message="This field is required."/></div>
<div class="mailpoet_paragraph "><input type="submit" class="mailpoet_submit" value="Subscribe" data-automation-id="subscribe-submit-button" style="width:100%;padding:12px;margin: 0 auto 0 0;font-size:15px;line-height:1.5;height:auto;border-color:transparent;" /><span class="mailpoet_form_loading"><span class="mailpoet_bounce1"></span><span class="mailpoet_bounce2"></span><span class="mailpoet_bounce3"></span></span></div>

      <div class="mailpoet_message">
        <p class="mailpoet_validate_success"
                style="display:none;"
                >Check your inbox or spam folder to confirm your subscription.
        </p>
        <p class="mailpoet_validate_error"
                style="display:none;"
                >        </p>
      </div>
    </form>
  </div>

      </aside>
  	</div>
</div>
</div>

  <!-- footer-big-menu.html -->
  <footer class="footer-big-menu">
    <div class="container" style="max-width: 1100px;">

      <div class="row menu">

        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title mb-2">Company</h3>
            <a class="menu-link" href="https://www.rosehosting.com/about-us.html">About us</a>
            <a class="menu-link" href="https://www.rosehosting.com/policies.html">Our Policies</a>
            <a class="menu-link" href="https://www.rosehosting.com/contact-us.html">Contact Us</a>
            <a class="menu-link" href="https://www.rosehosting.com/blog/">Blog</a>
            <a class="menu-link" href="https://www.rosehosting.com/why-rosehosting.html">Why RoseHosting</a>
            <a class="menu-link" href="https://www.rosehosting.com/compare-to-competition.html">Compare Us</a>
            <a class="menu-link" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a>
            <a class="menu-link" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a>
            <a class="menu-link" href="/recommended-tools-and-services.html">Recommended Services</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Support</h3>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Helpdesk System</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a>

          <h3 class="menu-title  mb-2 mt-4">Other Services</h3>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Domain Registration</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Domain Transfer</a>
          <a class="menu-link" href="https://www.rosehosting.com/ssl-certificates.html">SSL Certificates</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/linux-vps-hosting/">Linux VPS Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/managed-cloud-hosting.html">Cloud Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting</a>
          <a class="menu-link" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom SSD VPS</a>
          <a class="menu-link" href="https://www.rosehosting.com/dedicated-servers.html">Dedicated Servers</a>
          <a class="menu-link" href="https://www.rosehosting.com/hosting-solutions.html">Hosting Solutions</a>
          <a class="menu-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Recurr. Affiliate Program</a>
          <a class="menu-link" href="https://www.rosehosting.com/cpa-hosting-affiliate-program.html">CPA Affiliate Program</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Linux VPS Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/centos-hosting.html">CentOS Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/ubuntu-hosting.html">Ubuntu Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/debian-hosting.html">Debian Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/opensuse-hosting.html">OpenSUSE Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/arch-linux-hosting.html">Arch-Linux Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/scientific-linux-hosting.html">Scientific Linux Hosting</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title  mb-2">Apps Hosting</h3>
          <a class="menu-link" href="https://www.rosehosting.com/wordpress-hosting.html">WordPress Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/magento-hosting.html">Magento Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/odoo-hosting.html">Odoo Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/joomla-hosting.html">Joomla Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/drupal-hosting.html">Drupal Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/laravel-hosting.html">Laravel Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/nextcloud-hosting.html">NextCloud Hosting</a>

          <a class="menu-link" href="https://www.rosehosting.com/prestashop-hosting.html">PrestaShop Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/ghost-hosting.html">Ghost Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/mediawiki-hosting.html">MediaWiki Hosting</a>
          <a class="menu-link" href="https://www.rosehosting.com/tomcat-hosting.html">Tomcat Hosting</a>
        </div>


        <div class="col-6 col-md-3 col-lg-2">
          <h3 class="menu-title mb-2">Contact Us</h3>
          <a class="menu-link" href="tel:+18887673467">(888) ROSE-HOST</a>
          <a class="menu-link" href="tel:+18887673467">(888) 767-3467</a>
          <a class="menu-link" href="tel:+13142750414">(314) 275-0414</a>
          <a class="menu-link" href="mailto:%73%75%70%70%6f%72%74%40%72%6f%73%65%68%6f%73%74%69%6e%67%2e%63%6f%6d">Email us</a>

          <h3 class="menu-title mb-2 mt-4">Connect</h3>
          <a class="menu-link" href="https://twitter.com/rosehosting" target="_blank"><i class="fa fa-twitter fa-fw"></i> Twitter</a>
          <a class="menu-link" href="https://www.facebook.com/RoseHosting" target="_blank"><i class="fa fa-facebook fa-fw"></i> Facebook</a>
          <a class="menu-link" href="https://www.linkedin.com/in/rosehosting/" target="_blank"><i class="fa fa-linkedin fa-fw"></i> LinkedIn</a>
          <a class="menu-link" href="https://www.rosehosting.com/blog/feed/" target="_blank"><i class="fa fa-rss fa-fw"></i> RSS Feed</a>

        </div>

      </div>

    </div>

<br>
    <div class="bottom">
      <div class="container" style="max-width: 1100px;">
        <div class="row">

          <div class="col-md-12 col-lg-6">
              <p class="text-sm-left"><a class="inline-link footer-policy" href="/tos.html">Terms of Service</a> and <a class="inline-link footer-policy" href="/policies.html">other policies</a></p>
          </div>
          <div class="col-md-12 col-lg-6">
            <p class="text-sm-right">&copy; 2001-2021 <a class="inline-link footer-policy" href="https://www.rosewebservices.com/">Rose Web Services LLC</a>.</p>
          </div>
         </div>
      </div>
    </div>

<!-- livezilla.net code
<script type="rocketlazyloadscript" data-rocket-type="text/javascript" id="aff1f81b02f303eea5f87a3a065f153a" src="https://linuxhostsupport.com/chat//script.php?id=aff1f81b02f303eea5f87a3a065f153a"></script>
http://www.livezilla.net -->





<script id='advanced-ads-pro/cache_busting-js-extra'>
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":"","wp_timezone_offset":"-18000"};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/advanced-ads-pro/assets/js/base.min.js' id='advanced-ads-pro/cache_busting-js' defer></script>
<script id='advanced-ads-layer-footer-js-js-extra'>
var advanced_ads_layer_settings = {"layer_class":"rhad-layer","placements":["20th-anniversary-sale-popup"]};
</script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/advanced-ads-layer/public/assets/js/layer.js?ver=1628863129' id='advanced-ads-layer-footer-js-js' defer></script>
<script type="rocketlazyloadscript" id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script id='rocket-preload-links-js-extra'>
var RocketPreloadLinksConfig = {"excludeUris":"\/blog(\/quiz\/github\/|\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$))|\/wp-admin\/|\/logout\/|\/wp-login.php","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/www.rosehosting.com\/blog","onHoverDelay":"100","rateThrottle":"3"};
</script>
<script type="rocketlazyloadscript" id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/advanced-ads-pro/assets/js/advanced-ads-pro.min.js' id='advanced-ads-pro/front-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/themes/rh2020/js/theme.js?ver=1628863129' id='theme-js' defer></script>
<!--[if lte IE 11]>
<script src='https://www.rosehosting.com/blog/wp-content/themes/generatepress/assets/js/classList.min.js' id='generate-classlist-js'></script>
<![endif]-->
<script id='generate-main-js-extra'>
var generatepressMenu = {"toggleOpenedSubMenus":"1","openSubMenuLabel":"Open Sub-Menu","closeSubMenuLabel":"Close Sub-Menu"};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/themes/generatepress/assets/js/main.min.js' id='generate-main-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-includes/js/comment-reply.min.js' id='comment-reply-js' defer></script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/social-icons-widget-by-wpzoom/assets/js/social-icons-widget-frontend.js?ver=1628863129' id='zoom-social-icons-widget-frontend-js' defer></script>
<script src='https://www.rosehosting.com/blog/wp-includes/js/wp-embed.min.js' id='wp-embed-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/smooth-scroll/jquery.smooth-scroll.min.js' id='jquery-smooth-scroll-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/js-cookie/js.cookie.min.js' id='js-cookie-js' defer></script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/vendor/sticky-kit/jquery.sticky-kit.min.js' id='jquery-sticky-kit-js' defer></script>
<script id='ez-toc-js-js-extra'>
var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"","width":"95%","scroll_offset":"30"};
</script>
<script type="rocketlazyloadscript" src='https://www.rosehosting.com/blog/wp-content/plugins/easy-table-of-contents/assets/js/front.min.js' id='ez-toc-js-js' defer></script>
<script id='mailpoet_public-js-extra'>
var MailPoetForm = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","is_rtl":""};
</script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/mailpoet/assets/dist/js/public.3ac9223b.js?ver=1632895472' id='mailpoet_public-js' defer></script>
<script type="rocketlazyloadscript" id='mailpoet_public-js-after'>
function initMailpoetTranslation() {
  if (typeof MailPoet !== 'undefined') {
    MailPoet.I18n.add('ajaxFailedErrorMessage', 'An error has happened while performing a request, please try again later.')
  } else {
    setTimeout(initMailpoetTranslation, 250);
  }
}
setTimeout(initMailpoetTranslation, 250);
</script>
<script id='cptch_front_end_script-js-extra'>
var cptch_vars = {"nonce":"e5357b2db9","ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","enlarge":"","time_limit":"120"};
</script>
<script type="rocketlazyloadscript" data-minify="1" src='https://www.rosehosting.com/blog/wp-content/cache/min/1/blog/wp-content/plugins/captcha-bws/js/front_end_script.js?ver=1628863129' id='cptch_front_end_script-js' defer></script>
<!--noptimize--><script type="rocketlazyloadscript">window.advads_passive_placements = {"sidebar-ad-group_2":{"type":"group","id":1744,"elementid":["rhad-6f1ff3cdeb62f198cd5650cbe6e98065"],"ads":{"34829":{"id":34829,"title":"Managed VPS Hosting 300x250","expiry_date":0,"visitors":[],"content":"<a href=\"https:\/\/www.rosehosting.com\/linux-vps-hosting\/\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2020\/11\/Managed-VPS-Hosting.jpg\" alt=\"Managed VPS Hosting\"  width=\"300\" height=\"250\"   \/><\/a>","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}},"26322":{"id":26322,"title":"after-first-image-300x250-rh-orange","expiry_date":0,"visitors":[],"content":"<div style=\"margin-left: auto; margin-right: auto; text-align: center; \" id=\"rhad-742764019\"><center><a target=\"_blank\" href=\"https:\/\/www.rosehosting.com\/cloud-vps-hosting.html\"><img src=\"https:\/\/media.rosehosting.com\/images\/blogads\/orange.jpg\" alt=\"Cloud VPS Hosting\"><\/a><\/center>\r\n<\/div>","once_per_page":0,"debugmode":false,"blog_id":1,"type":"plain","position":"center","privacy":{"ignore":false,"needs_consent":false}},"34897":{"id":34897,"title":"Linux Server Management Services LHS 300x250","expiry_date":0,"visitors":[],"content":"<a href=\"https:\/\/linuxhostsupport.com\/\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2020\/11\/Linux-Server-Management-Service.jpg\" alt=\"Linux Server Management Service\"  width=\"300\" height=\"250\"   \/><\/a>","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}},"34996":{"id":34996,"title":"Dedicated Server Hosting","expiry_date":0,"visitors":[],"content":"<a href=\"https:\/\/www.rosehosting.com\/dedicated-servers.html\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2020\/12\/Dedicated-Server-Hosting.jpg\" alt=\"Dedicated Server Hosting\"  width=\"300\" height=\"250\"   \/><\/a>","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}},"34828":{"id":34828,"title":"Managed NVME Hosting 300x250","expiry_date":0,"visitors":[],"content":"<a href=\"https:\/\/www.rosehosting.com\/nvme-hosting.html\" target=\"_blank\"><img src=\"https:\/\/www.rosehosting.com\/blog\/wp-content\/uploads\/2020\/11\/Managed-NVMe-VPS-Hosting.jpg\" alt=\"Managed NVMe VPS Hosting\"  width=\"300\" height=\"250\"   \/><\/a>","once_per_page":0,"debugmode":false,"blog_id":1,"type":"image","position":"","privacy":{"ignore":false,"needs_consent":false}}},"group_info":{"id":1744,"name":"RH and LHS","weights":{"34996":10,"34994":10,"34993":10,"34897":10,"34870":10,"34868":10,"34829":10,"34828":10,"34827":10,"34821":10,"34786":10,"26322":10},"type":"default","ordered_ad_ids":[34829,34821,26322,34897,34993,34996,34868,34827,34994,34828,34786,34870],"ad_count":1,"refresh_enabled":true,"refresh_interval_for_ads":{"34828":15000,"34868":15000,"34829":15000,"34993":15000,"34994":15000,"34897":15000,"34786":15000,"34996":15000,"34827":15000,"34870":15000,"34821":15000,"26322":15000}},"placement_info":{"type":"sidebar_widget","name":"sidebar ad group","item":"group_1744","id":"sidebar-ad-group"},"test_id":null,"group_wrap":[{"before":"<div class=\"rhad-sidebar-ad-group\" id=\"rhad-1826190561\">","after":"<\/div>"}],"inject_before":[""]}};
window.advads_ajax_queries = [{"id":"before-content","method":"placement","params":{"placement_position":"center","previous_method":"placement","previous_id":"before-content","post":"r0","url_parameter":"\/blog\/tomcat-and-tomee-clustering-automation\/","placement_type":"post_top","output":{"class":["rhad-before-content"],"placement_id":"before-content"}},"elementid":"rhad-ad1d775129b8b3f5f329f5eeab5b517b","blog_id":1}];
window.advads_ajax_queries_args = {"r0":{"id":38913,"author":"4","post_type":"post"}};
( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( !window.advanced_ads_pro ) {console.log("Advanced Ads Pro: cache-busting can not be initialized");} });</script><!--/noptimize--><!--noptimize--><script type="rocketlazyloadscript">!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><!--/noptimize--><script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.rosehosting.com/blog/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script>
</body>
</html>

<!-- Cached for great performance - Debug: cached@1633543154 -->