<!DOCTYPE html> <!--[if IE 6]>
<html id="ie6" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]--> <!--[if IE 7]>
<html id="ie7" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]--> <!--[if IE 8]>
<html id="ie8" lang="en-US"
	prefix="og: https://ogp.me/ns#" >
<![endif]--> <!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<!--<![endif]--><head><meta charset="UTF-8" /><link rel="pingback" href="https://www.rosehosting.com/blog/xmlrpc.php" /> <!--[if lt IE 9]>
	<script src="https://www.rosehosting.com/blog/wp-content/themes/generatepress/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]--> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KVJ4PJ');</script> <title>How to Create a Backup of MySQL Databases Using mysqldump on Ubuntu 20.04</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://www.rosehosting.com/blog/wp-content/cache/min/1/60557ec1466eb28156079bef4ecf1249.css" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /><meta name="description" content="In this tutorial, we will show you how to create a backup of MySQL databases on an Ubuntu 20.04 VPS, and create a backup of the entire /var/lib/mysql directory." /> <script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.rosehosting.com/blog/#organization","url":"https://www.rosehosting.com/blog/","name":"RoseHosting.com","sameAs":["https://twitter.com/rosehosting","https://www.facebook.com/RoseHosting/","https://www.linkedin.com/in/rosehosting"],"logo":{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/#logo","url":"https://www.rosehosting.com/blog/wp-content/uploads/2016/02/rhlogo-final-500x500.png","caption":""},"image":{"@id":"https://www.rosehosting.com/blog/#logo"},"contactPoint":{"@type":"ContactPoint","telephone":"+888-767-3467","contactType":"sales"}},{"@type":"WebSite","@id":"https://www.rosehosting.com/blog/#website","url":"https://www.rosehosting.com/blog/","name":"RoseHosting","publisher":{"@id":"https://www.rosehosting.com/blog/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.rosehosting.com/blog/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/#webpage","url":"https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/","inLanguage":"en-US","name":"How to Create a Backup of MySQL Databases Using mysqldump on Ubuntu 20.04","isPartOf":{"@id":"https://www.rosehosting.com/blog/#website"},"breadcrumb":{"@id":"https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/#breadcrumblist"},"image":{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/#primaryimage","url":"https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04.jpg","width":742,"height":372},"primaryImageOfPage":{"@id":"https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/#primaryimage"},"datePublished":"2020-07-17T22:16:40-05:00","dateModified":"2020-07-17T22:16:40-05:00"},{"@type":"Article","@id":"https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/#article","isPartOf":{"@id":"https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/#webpage"},"author":{"@id":"https://www.rosehosting.com/blog/author/jwilson/#author"},"headline":"How to Create a Backup of MySQL Databases Using mysqldump on Ubuntu 20.04","datePublished":"2020-07-17T22:16:40-05:00","dateModified":"2020-07-17T22:16:40-05:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/#webpage"},"publisher":{"@id":"https://www.rosehosting.com/blog/#organization"},"articleSection":"Databases, Tutorials, Ubuntu, backup, mysql, Ubuntu 20.04","image":{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/#primaryimage","url":"https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04.jpg","width":742,"height":372}},{"@type":"Person","@id":"https://www.rosehosting.com/blog/author/jwilson/#author","name":"Jeff Wilson","sameAs":["https://www.facebook.com/rosehosting.helpdesk"],"image":{"@type":"ImageObject","@id":"https://www.rosehosting.com/blog/#personlogo","url":"https://secure.gravatar.com/avatar/09271207587f897ab46faaed9b355252?s=96&r=g","width":96,"height":96,"caption":"Jeff Wilson"}},{"@type":"BreadcrumbList","@id":"https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/#breadcrumblist","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.rosehosting.com/blog/","url":"https://www.rosehosting.com/blog/","name":"RoseHosting Blog"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/","url":"https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/","name":"How to Create a Backup of MySQL Databases Using mysqldump on Ubuntu 20.04"}}]}]}</script> <link rel="canonical" href="https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/" /><meta property="og:type" content="article" /><meta property="og:title" content="How to Create a Backup of MySQL Databases Using mysqldump on Ubuntu 20.04" /><meta property="og:description" content="In this tutorial, we will show you how to create a backup of MySQL databases on an Ubuntu 20.04 VPS, and create a backup of the entire /var/lib/mysql directory. We will create the backup of the" /><meta property="og:url" content="https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/" /><meta property="og:site_name" content="RoseHosting.com Blog" /><meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04.jpg" /><meta property="article:tag" content="databases" /><meta property="article:tag" content="tutorials" /><meta property="article:tag" content="ubuntu" /><meta property="article:tag" content="backup" /><meta property="article:tag" content="mysql" /><meta property="article:tag" content="ubuntu 20.04" /><meta property="article:published_time" content="2020-07-17T22:16:40Z" /><meta property="article:modified_time" content="2020-07-17T22:16:40Z" /><meta property="article:publisher" content="https://www.facebook.com/RoseHosting/" /><meta property="article:author" content="https://www.facebook.com/rosehosting.helpdesk" /><meta property="og:image:secure_url" content="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04.jpg" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@RoseHosting" /><meta name="twitter:title" content="How to Create a Backup of MySQL Databases Using mysqldump on Ubuntu 20" /><meta name="twitter:description" content="In this tutorial, we will show you how to create a backup of MySQL databases on an Ubuntu 20.04 VPS, and create a backup of the entire /var/lib/mysql directory. We will create the backup of the" /><meta name="twitter:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04.jpg" /><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' /><link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Feed" href="https://www.rosehosting.com/blog/feed/" /><link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; Comments Feed" href="https://www.rosehosting.com/blog/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="RoseHosting &raquo; How to Create a Backup of MySQL Databases Using mysqldump on Ubuntu 20.04 Comments Feed" href="https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='preload' id='generate-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans:300,300italic,regular,italic,600,600italic,700,700italic,800,800italic&#038;display=swap' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><style id='ez-toc-inline-css' type='text/css'>div#ez-toc-container p.ez-toc-title{font-size:22px}div#ez-toc-container p.ez-toc-title{font-weight:500}div#ez-toc-container ul li{font-size:95%}div#ez-toc-container{width:95%}</style><link rel='preload' id='font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><style id='generate-style-inline-css' type='text/css'>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</style> <link rel='https://api.w.org/' href='https://www.rosehosting.com/blog/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rosehosting.com/blog/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rosehosting.com/blog/wp-includes/wlwmanifest.xml" /><link rel='prev' title='How to Install Redmine on CentOS 8' href='https://www.rosehosting.com/blog/how-to-install-redmine-on-centos-8/' /><meta name="generator" content="WordPress 5.4.2" /><link rel='shortlink' href='https://www.rosehosting.com/blog/?p=33682' /><link rel="alternate" type="application/json+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Fhow-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04%2F&#038;format=xml" /><meta name="viewport" content="width=device-width, initial-scale=1"><style type="text/css">.broken_link,a.broken_link{text-decoration:line-through}</style><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-180x180.png" /><meta name="msapplication-TileImage" content="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-270x270.png" /><style type="text/css" id="wp-custom-css">.entry-content pre{font-family:monospace;color:#3a3a3a;border:none;overflow-wrap:break-word}.inside-article,.sidebar .widget{border:1px solid #e3e3e3}.page-container{max-width:1100px;align-items:center;justify-content:space-between;margin-left:auto;margin-right:auto}.footer-big-menu{max-width:1100px;margin-left:auto;margin-right:auto}.col6,.col-md-3,.col-lg-2{padding-left:10px;padding-right:10px}</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script></head><body class="post-template-default single single-post postid-33682 single-format-standard wp-embed-responsive post-image-above-header post-image-aligned-center sticky-menu-fade right-sidebar nav-below-header contained-header separate-containers active-footer-widgets-1 nav-aligned-left header-aligned-left dropdown-hover featured-image-active"><nav class="navbar yamm navbar-expand-lg navbar-dark" role="navigation"><div class="container no-override navbar-dark"> <a class="navbar-brand" href="https://www.rosehosting.com/"> <img alt="RoseHosting.com" width="186" height="37" class="d-lg-inline mr-2" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20186%2037'%3E%3C/svg%3E" data-lazy-src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/rh-logo.svg" /><noscript><img alt="RoseHosting.com" width="186" height="37" class="d-lg-inline mr-2" src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/rh-logo.svg" /></noscript> </a> <button class="navbar-toggler" data-toggle="collapse" data-target="#navbar-collapse"> <span class="navbar-toggler-icon"></span> </button><div class="collapse navbar-collapse justify-content-end" id="navbar-collapse"><ul class="navbar-nav"><li class="nav-item active dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> Hosting Solutions <i class="fa fa-chevron-down"></i> </a><div class="dropdown-menu" role="menu"><div class="yamm-content"><div class="row"><div class="col-sm-6"> <span class="text-primary dropdown-header"><strong>Managed SSD Hosting</strong></span><div class="dropdown-divider"></div> <a class="dropdown-item" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a> <a class="dropdown-item" href="https://www.rosehosting.com/linux-vps-hosting.html">Linux VPS Hosting</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom VPS</a> <a class="dropdown-item" href="https://www.rosehosting.com/dedicated-servers.html">Cloud Dedicated Servers</a> <a class="dropdown-item" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting <span class="ml-2 badge badge-success">new</span></a></div><div class="col-sm-6"> <span class="text-primary dropdown-header"><strong>Managed Solutions</strong></span><div class="dropdown-divider"></div> <a class="dropdown-item" href="https://www.rosehosting.com/wordpress-hosting.html"> Wordpress Hosting <small class="d-block text-muted"><i>The best blogging platform</i></small> </a> <a class="dropdown-item" href="https://www.rosehosting.com/magento-hosting.html"> Magento Hosting <small class="d-block text-muted"><i>The best e-commerce platform</i></small> </a> <a class="dropdown-item" href="https://www.rosehosting.com/odoo-hosting.html"> Odoo Hosting <small class="d-block text-muted"><i>The best CRM/ERP platform</i></small> </a> <span class="dropdown-item"><a class="btn-shadow btn-shadow-primary btn-shadow-sm" target="_blank" href="https://www.rosehosting.com/hosting-solutions.html">Other Solutions</a></span></div></div></div></div></li><li class="nav-item dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> SSL / Domains <i class="fa fa-chevron-down"></i> </a><div class="dropdown-menu" role="menu"><div class="yamm-content"><div class="row"><div class="col-sm-3"> <span class="text-primary dropdown-header"><strong>SSL by brand</strong></span><div class="dropdown-divider"></div> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#geotrust">GeoTrust</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#comodo">Comodo</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#rapidssl">RapidSSL</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates.html#thawte">Thawte</a></div><div class="col-sm-4"> <span class="text-primary dropdown-header"><strong>SSL by Type</strong></span><div class="dropdown-divider"></div> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#domain_validation">Domain Validation</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#organization_validation">Organization Validation</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#extended_validation">Extended Validation</a> <a class="dropdown-item" href="https://www.rosehosting.com/ssl-certificates-by-type.html#wildcard_ssl">Wildcard SSL</a></div><div class="col-sm-3"> <span class="text-primary dropdown-header"><strong>Domains</strong></span><div class="dropdown-divider"></div> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Register Domains</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Transfer Domains</a></div></div></div></div><li class="nav-item dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> Support <i class="fa fa-chevron-down"></i> </a><div class="dropdown-menu" role="menu"> <a class="dropdown-item" href="https://www.rosehosting.com/support.html">24/7 Managed Support</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Open a Support Ticket</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a> <a class="dropdown-item" href="https://status.rosehosting.com">Systems Status</a></div></li><li class="nav-item dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> About Us <i class="fa fa-chevron-down"></i> </a><div class="dropdown-menu" role="menu"> <a class="dropdown-item" href="https://www.rosehosting.com/about-us.html">Our Company</a> <a class="dropdown-item" href="https://www.rosehosting.com/contact-us.html">Contact Us</a> <a class="dropdown-item" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a> <a class="dropdown-item" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a> <a class="dropdown-item" href="https://www.rosehosting.com/policies.html">Our Policies</a></div></li><li class="nav-item dropdown"> <a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown"> Affiliates <i class="fa fa-chevron-down"></i> </a><div class="dropdown-menu" role="menu"> <a class="dropdown-item" href="https://www.rosehosting.com/cpa-hosting-affiliate-program.html">Flat-Rate CPA Affiliate Program</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Flat-Rate CPA Affiliate Program Login</a> <a class="dropdown-item" href="https://www.rosehosting.com/vps-affiliate-program.html">Recurring Commission Affiliate Program</a> <a class="dropdown-item" href="https://secure.rosehosting.com/clientarea/aff/">Recurring Commission Affiliate Program Login</a></div></li><li class="nav-item"> <a class="nav-link" href="https://www.rosehosting.com/blog/">Blog</a></li><li class="nav-item"> <a class="nav-link nav-link--rounded" href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Login</a></li></ul></div></div></nav><div id="page-container" class="page-container"><div id="primary" class="content-area grid-parent mobile-grid-100 grid-70 tablet-grid-70"><main id="main" class="site-main"><article id="post-33682" class="post-33682 post type-post status-publish format-standard has-post-thumbnail hentry category-databases category-tutorials category-ubuntu tag-backup tag-mysql tag-ubuntu-20-04" itemtype="https://schema.org/CreativeWork" itemscope><div class="inside-article"><header class="entry-header"><h1 class="entry-title" itemprop="headline">How to Create a Backup of MySQL Databases Using mysqldump on Ubuntu 20.04</h1><div class="entry-meta"> <span class="posted-on"><a href="https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/" title="17:16" rel="bookmark"><time class="entry-date published" datetime="2020-07-17T17:16:40-05:00" itemprop="datePublished">July 17, 2020</time></a></span> <span class="byline">by <span class="author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope><a class="url fn n" href="https://www.rosehosting.com/blog/author/jwilson/" title="View all posts by Jeff Wilson" rel="author" itemprop="url"><span class="author-name" itemprop="name">Jeff Wilson</span></a></span></span></div></header><div class="entry-content" itemprop="text"><p><img class="alignnone size-full wp-image-33904" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20742%20372'%3E%3C/svg%3E" alt="" width="742" height="372" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04.jpg 742w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04-150x75.jpg 150w" data-lazy-sizes="(max-width: 742px) 100vw, 742px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04.jpg" /><noscript><img class="alignnone size-full wp-image-33904" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04.jpg" alt="" width="742" height="372" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04.jpg 742w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04-150x75.jpg 150w" sizes="(max-width: 742px) 100vw, 742px" /></noscript></p><p>In this tutorial, we will show you how to create a backup of MySQL databases on an <a href="https://www.rosehosting.com/ubuntu-hosting.html">Ubuntu 20.04 VPS</a>, and create a backup of the entire <code>/var/lib/mysql</code> directory.</p><p><img class="alignright size-full wp-image-33907" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20120%2062'%3E%3C/svg%3E" alt="" width="120" height="62" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/configure-mysql-backups-with-mysqldump-for-ubuntu20.04-vps.jpg" /><noscript><img class="alignright size-full wp-image-33907" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/configure-mysql-backups-with-mysqldump-for-ubuntu20.04-vps.jpg" alt="" width="120" height="62" /></noscript>We will create the backup of the databases using MySQL&#8217;s command, aptly named <code>mysqldump</code>. After that we will then show you how to perform a backup of the <code>/var/lib/mysql</code> directory where MySQL have been located. Performing regular backups of your database and database server is vital to protecting the data that you have on your server. This way, in case something goes wrong on your Ubuntu 20.04 VPS, or if MySQL breaks for some reason (incompatibilies or otherwise), you&#8217;ll have a safe backup that you can revert to and prevent the loss of your precious data.</p><p>Once you create a backup of MySQL databases and save them on your server or on a remote location, you can then always be able to restore the databases later from this backup, if needed. Creating a backup of MySQL database is essential for any website owner, and it should be done on a regular basis. Just follow the simple steps in this tutorial and your data will be redundant in no time. Let&#8217;s begin.</p><p><span id="more-33682"></span></p><div id="ez-toc-container" class="ez-toc-v2_0_11 counter-hierarchy ez-toc-transparent"><div class="ez-toc-title-container"><p class="ez-toc-title">Table of Contents</p> <span class="ez-toc-title-toggle"><a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a></span></div><nav><ul class="ez-toc-list ez-toc-list-level-1"><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-1" href="#What-is-MySQL" title="What is MySQL?">What is MySQL?</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-2" href="#Step-1-Update-OS-packages" title="Step 1. Update OS packages">Step 1. Update OS packages</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-3" href="#Step-2-Install-the-MySQL-Database-server" title="Step 2. Install the MySQL Database server">Step 2. Install the MySQL Database server</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-4" href="#Step-3-Create-a-MySQL-Database" title="Step 3. Create a MySQL Database">Step 3. Create a MySQL Database</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-5" href="#Step-4-Create-a-Backup-using-%E2%80%98mysqldump%E2%80%99" title="Step 4. Create a Backup using &#8216;mysqldump&#8217;">Step 4. Create a Backup using &#8216;mysqldump&#8217;</a></li><li class="ez-toc-page-1 ez-toc-heading-level-2"><a class="ez-toc-link ez-toc-heading-6" href="#Step-5-Copy-the-MySQL-Database-Directory" title="Step 5. Copy the MySQL Database Directory">Step 5. Copy the MySQL Database Directory</a></li></ul></nav></div><h2><span class="ez-toc-section" id="What-is-MySQL"></span><strong>What is MySQL?</strong><span class="ez-toc-section-end"></span></h2><p>MySQL is an open-source relational database management system (RDBMS). MySQL is a component of the LAMP web application software stack (and others), which is an acronym for Linux, Apache, MySQL, and PHP. MySQL is used by many web applications, including WordPress, Drupal, Laravel, and so many more. MySQL is also used by many popular websites, including YouTube, Twitter, and Facebook.</p><p>This multi-step guide was written and tested for Ubuntu 20.04, but it should work on other Linux distributions as well. Let&#8217;s get started!</p><p>First off, we assume that you have SSH access to your server.</p><p>Log in to your server via SSH:</p><pre>ssh <span style="color: #ff0000;">root</span>@<span style="color: #ff0000;">server_ip</span> -p <span style="color: #ff0000;">port_number</span></pre><p>You can replace <span style="color: #ff0000;">root</span> with the username of an administrator account if needed (our VPSes all have root access by default). Then replace <span style="color: #ff0000;">server_ip</span> with the IP address of your server, and <span style="color: #ff0000;">port_number</span> with your SSH port, with 22 being the default value.</p><h2><span class="ez-toc-section" id="Step-1-Update-OS-packages"></span>Step 1. Update OS packages<span class="ez-toc-section-end"></span></h2><p>Let’s make sure that your operating system is up-to-date.</p><pre>apt-get update</pre><h2><span class="ez-toc-section" id="Step-2-Install-the-MySQL-Database-server"></span>Step 2. Install the MySQL Database server<span class="ez-toc-section-end"></span></h2><p>MySQL is a popular database management system and it can be installed easily on any Linux server. Thanks to its popularity, packages for MySQL exist on almost all modern Linux distributions. The latest version of MySQL is version 8.0, but a newer version may exist after this article has been written.</p><p>To install the MySQL service, run the following command:</p><pre>apt install mysql-server</pre><p>In order to verify that MySQL is installed, as well as check the status of the MySQL service, we can use the following commands:</p><pre>qpkg -l | grep -imysql

systemctl status mysql</pre><p>The output of the <code>systemctl status mysql</code> command should be similar to this one:</p><pre>● mysql.service - MySQL Community Server
     Loaded: loaded (/lib/systemd/system/mysql.service; enabled; vendor preset: enabled)
     Active: active (running) since Sun 2020-06-07 07:49:38 UTC; 52min ago
   Main PID: 17700 (mysqld)
     Status: "Server is operational"
      Tasks: 39 (limit: 2266)
     Memory: 325.7M
     CGroup: /system.slice/mysql.service
             └─17700 /usr/sbin/mysqld
</pre><p>Let&#8217;s go over managing the MySQL service. Enable the MySQL service to start on server boot with the following command:</p><pre>systemctl enable mysql</pre><p>For starting and stopping the MySQL service, we can use the following commands respectively:</p><pre>systemctl start mysql

systemctl stop mysql</pre><p>In order to check the installed MySQL version, execute the following command:</p><pre>mysql -V</pre><p>The output should look similar to this:</p><pre>mysql  Ver 8.0.20-0ubuntu0.20.04.1 for Linux on x86_64 ((Ubuntu))</pre><p>To improve the security of the MySQL server, it is a good idea to run the <strong>mysql_secure_installation</strong> script by typing the following command. It allows you to perform some extra configuration, such as setting a root password, deleting the example database, and so on:</p><pre>mysql_secure_installation</pre><h2><span class="ez-toc-section" id="Step-3-Create-a-MySQL-Database"></span>Step 3. Create a MySQL Database<span class="ez-toc-section-end"></span></h2><p>In this step, we will create a MySQL database, MySQL user, and a password for the new user, along with the required permissions for our test database. Later we will make a dump of the newly created database.</p><p>Log in to your MySQL console with the following command:</p><pre>mysql -u root -p</pre><p>Enter password:  (Enter your MySQL root password if you set it during the <strong>mysql_secure_installation</strong> process. Leave blank if you didn&#8217;t)</p><p>Once you are logged in, execute the following commands one-by-one:</p><pre>mysql&gt; CREATE DATABASE testDB;
mysql&gt; CREATE USER 'admin_user'@'localhost' IDENTIFIED BY '<span style="color: #ff0000;">StrongPassword</span>';
mysql&gt; GRANT ALL PRIVILEGES ON testDB.* TO 'admin_user'@'localhost';
mysql&gt; FLUSH PRIVILEGES;
mysql&gt; exit;</pre><p>Do not forget to replace <strong>&#8220;<span style="color: #ff0000;">StrongPassword</span>&#8220;</strong> with your own strong generated password.</p><p>Once you create a MySQL database, we can list the all the MySQL databases from within the MySQL console using the following command:</p><pre>show databases;</pre><p>The output should look like this:</p><pre>mysql&gt; show databases;
+--------------------+
| Database           |
+--------------------+
| information_schema |
| mysql              |
| performance_schema |
| sys                |
| testDB             |
+--------------------+
5 rows in set (0.00 sec)</pre><h2><span class="ez-toc-section" id="Step-4-Create-a-Backup-using-%E2%80%98mysqldump%E2%80%99"></span>Step 4. Create a Backup using &#8216;mysqldump&#8217;<span class="ez-toc-section-end"></span></h2><p>This is the main step where we will create a backup of MySQL databases using the <code>mysqldump</code> command-line utility.</p><p>Enter in a directory of your choice where you want the backup to be saved.</p><p>For the purposes of this tutorial, we will use the <code>/backup</code> directory.</p><pre>cd /backup</pre><p>Execute the following command to create a database dump of the test database that we created previously:</p><pre>mysqldump -u admin_user -p testDB &gt; backup.sql</pre><p>Enter the &#8220;admin_user&#8221; password that you set and list the files in the <code>/backup</code> directory to make sure the database backup was created successfully:</p><pre>ls -al | grep backup</pre><p>The output should look like this:</p><pre>-rw-r--r--  1 root root 1267 Jun  7 09:52 backup.sql</pre><p>If you want to create a database dump of all databases on your server use the following command using the MySQL root user credentials:</p><pre>mysqldump --all-databases -u root -p &gt; AllDatabaseBackup.sql</pre><p>Enter the MySQL root password and again, to check that backup was made successfully, run the following command:</p><pre>ls -al | grep All</pre><p>The output shoud look like this:</p><pre>-rw-r--r--  1 root root 1036456 Jun  7 10:15 AllDatabaseBackup.sql</pre><h2><span class="ez-toc-section" id="Step-5-Copy-the-MySQL-Database-Directory"></span>Step 5. Copy the MySQL Database Directory<span class="ez-toc-section-end"></span></h2><p>This step is optional. If you want to copy the entire directory where MySQL databases are located along with its data, first, you have to stop the MySQL service with the following command:</p><pre>systemctl stop mysql</pre><p>Verify that the MySQL service is stopped with this command:</p><pre>systemctl status mysql</pre><p>The output should look like this:</p><pre>● mysql.service - MySQL Community Server
     Loaded: loaded (/lib/systemd/system/mysql.service; enabled; vendor preset: enabled)
     Active: inactive (dead) since Sun 2020-06-07 10:50:19 UTC; 4s ago
    Process: 17700 ExecStart=/usr/sbin/mysqld (code=exited, status=0/SUCCESS)
   Main PID: 17700 (code=exited, status=0/SUCCESS)
     Status: "Server shutdown complete"</pre><p>Once this is done, we are ready to copy the MySQL database directory with the <strong>rsync</strong> command:</p><pre>rsync -Waq --numeric-ids /var/lib/mysql/ /backup/mysql.raw/</pre><p>Check the <code>/backup/mysql.raw</code> directory and list the files and directories inside to ensure that the backup of the <code>/var/lib/mysql</code> directory was made successfully.</p><pre>cd /backup/mysql.raw

ls -alh</pre><p>After a raw backup has been created, we can start the MySQL service using the following command:</p><pre>systemctl start mysql</pre><p>That&#8217;s it. Congratulations, you have successfully created a backup with the &#8220;<strong>mysqldump</strong>&#8221; command-line utility, and a raw backup of MySQL databases using rsync on your Ubuntu 20.04 VPS. Now you can safely store and protect your data.</p><hr /><p><img class="alignleft size-full wp-image-33908" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20120%2062'%3E%3C/svg%3E" alt="" width="120" height="62" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/mysql-security-support-fully-managed-by-experts-for-linux-ubuntu-vps.jpg" /><noscript><img class="alignleft size-full wp-image-33908" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/mysql-security-support-fully-managed-by-experts-for-linux-ubuntu-vps.jpg" alt="" width="120" height="62" /></noscript>If you are one of our <a href="https://www.rosehosting.com/ubuntu-hosting.html">Managed Ubuntu Hosting</a> customers, you don’t have to create a MySQL backup by yourself on Ubuntu 20.04 &#8211; our expert Linux admins will set up and optimize your MySQL server for you, and even implement database backups to happen automatically. They are available 24×7 and will take care of your request immediately.</p><p><span style="color: #ff0000;"><strong>PS</strong></span>. If you liked this post on how to Create a Backup of MySQL Using mysqldump on Ubuntu 20.04, please share it with your friends on the social networks using the buttons on the left or simply leave a reply below. Thanks.</p></div><footer class="entry-meta"> <span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://www.rosehosting.com/blog/category/databases/" rel="category tag">Databases</a>, <a href="https://www.rosehosting.com/blog/category/tutorials/" rel="category tag">Tutorials</a>, <a href="https://www.rosehosting.com/blog/category/ubuntu/" rel="category tag">Ubuntu</a></span><nav id="nav-below" class="post-navigation"> <span class="screen-reader-text">Post navigation</span><div class="nav-previous"><span class="prev" title="Previous"><a href="https://www.rosehosting.com/blog/how-to-install-redmine-on-centos-8/" rel="prev">How to Install Redmine on CentOS 8</a></span></div></nav></footer></div></article><div class="comments-area"><div id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.rosehosting.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-form-comment"><label for="comment" class="screen-reader-text">Comment</label><textarea autocomplete="new-password" id="a500c4f79e" name="a500c4f79e" cols="45" rows="8" aria-required="true"></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0;clip:rect(1px, 1px, 1px, 1px);position:absolute !important;white-space:nowrap;height:1px;width:1px;overflow:hidden;" tabindex="-1"></textarea><script data-noptimize type="text/javascript">document.getElementById("comment").setAttribute( "id", "a82a483c4316d88d8fc446c56f01d8fd" );document.getElementById("a500c4f79e").setAttribute( "id", "comment" );</script></p><label for="author" class="screen-reader-text">Name</label><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" /> <label for="email" class="screen-reader-text">Email</label><input placeholder="Email *" id="email" name="email" type="email" value="" size="30" /> <label for="url" class="screen-reader-text">Website</label><input placeholder="Website" id="url" name="url" type="url" value="" size="30" /><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="cptch_block"><span class="cptch_title cptch_to_remove">Move the slider all the way to the right to verify you are human.<span class="required"> *</span></span><span class="cptch_wrap cptch_slide"> <label class="cptch_label" for="cptch_input_68"><div id="cptch_slide_captcha_container"></div><input type="hidden" name="cptch_result" value="" /><input type="hidden" name="cptch_time" value="1595215836" /> <input type="hidden" name="cptch_form" value="wp_comments" /> </label></span></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='33682' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div></div></div></main></div><div id="right-sidebar" class="widget-area grid-30 tablet-grid-30 grid-parent sidebar" itemtype="https://schema.org/WPSideBar" itemscope><div class="inside-right-sidebar"><aside id="custom_html-6" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a target="_blank" href="https://www.rosehosting.com/linux-vps-hosting.html" rel="noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Cloud VPS Hosting" data-lazy-src="https://media.rosehosting.com/images/blogads/orange.jpg"><noscript><img src="https://media.rosehosting.com/images/blogads/orange.jpg" alt="Cloud VPS Hosting"></noscript></a></div></aside><aside id="custom_html-8" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a target="_blank" href="https://www.rosehosting.com/about-us.html" rel="noopener noreferrer">About RoseHosting</a><br> <a target="_blank" href="https://www.rosehosting.com/linux-vps-hosting.html" rel="noopener noreferrer">Buy a Managed VPS - 25% OFF</a><br> <a target="_blank" href="https://www.rosehosting.com/reviews.html" rel="noopener noreferrer">Customer Reviews</a><br> <a target="_blank" href="https://www.rosehosting.com/nvme-hosting.html" rel="noopener noreferrer">Managed NVMe VPSes</a><br> <a target="_blank" href="https://www.rosehosting.com/dedicated-servers.html" rel="noopener noreferrer">Managed NVMe Dedicated Servers</a></div></aside><aside id="custom_html-5" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><a target="_blank" href="https://linuxhostsupport.com/" rel="noopener noreferrer"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Server Management Services" data-lazy-src="https://media.rosehosting.com/img/blogads/24.jpg"><noscript><img src="https://media.rosehosting.com/img/blogads/24.jpg" alt="Server Management Services"></noscript></a></div></aside><aside id="recent-posts-widget-with-thumbnails-2" class="widget inner-padding recent-posts-widget-with-thumbnails"><div id="rpwwt-recent-posts-widget-with-thumbnails-2" class="rpwwt-widget"><ul><li><a href="https://www.rosehosting.com/blog/how-to-create-a-backup-of-mysql-databases-using-mysqldump-on-ubuntu-20-04/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04.jpg 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04-150x75.jpg" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04-150x75.jpg" class="attachment-75x75 size-75x75" alt="" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-create-backup-of-databases-using-mysqldump-on-ubuntu20.04.jpg 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Create a Backup of MySQL Databases Using mysqldump on Ubuntu 20.04</span></a></li><li><a href="https://www.rosehosting.com/blog/how-to-install-redmine-on-centos-8/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-redmine-on-centos8-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-redmine-on-centos8-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-redmine-on-centos8.jpg 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-redmine-on-centos8-150x75.jpg" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-redmine-on-centos8-150x75.jpg" class="attachment-75x75 size-75x75" alt="" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-redmine-on-centos8-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-redmine-on-centos8-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-redmine-on-centos8.jpg 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Install Redmine on CentOS 8</span></a></li><li><a href="https://www.rosehosting.com/blog/how-to-install-magento-2-on-centos-8/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-magento2-on-centos8-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-magento2-on-centos8-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-magento2-on-centos8.jpg 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-magento2-on-centos8-150x75.jpg" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-magento2-on-centos8-150x75.jpg" class="attachment-75x75 size-75x75" alt="" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-magento2-on-centos8-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-magento2-on-centos8-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-magento2-on-centos8.jpg 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Install Magento 2 on CentOS 8</span></a></li><li><a href="https://www.rosehosting.com/blog/how-to-install-wordpress-with-lemp-stack-on-centos-8/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-wordpress-with-lemp-stack-on-centos8-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-wordpress-with-lemp-stack-on-centos8-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-wordpress-with-lemp-stack-on-centos8.jpg 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-wordpress-with-lemp-stack-on-centos8-150x75.jpg" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-wordpress-with-lemp-stack-on-centos8-150x75.jpg" class="attachment-75x75 size-75x75" alt="" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-wordpress-with-lemp-stack-on-centos8-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-wordpress-with-lemp-stack-on-centos8-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-install-wordpress-with-lemp-stack-on-centos8.jpg 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Install WordPress with LEMP Stack on CentOS 8</span></a></li><li><a href="https://www.rosehosting.com/blog/how-to-speed-up-wordpress-and-boost-performance-on-an-ubuntu-20-04-vps/"><img width="75" height="38" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2075%2038'%3E%3C/svg%3E" class="attachment-75x75 size-75x75" alt="" data-lazy-srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-speed-up-wordpress-and-boost-performance-on-an-ubuntu20.04-vps-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-speed-up-wordpress-and-boost-performance-on-an-ubuntu20.04-vps-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-speed-up-wordpress-and-boost-performance-on-an-ubuntu20.04-vps.jpg 742w" data-lazy-sizes="(max-width: 75px) 100vw, 75px" data-lazy-src="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-speed-up-wordpress-and-boost-performance-on-an-ubuntu20.04-vps-150x75.jpg" /><noscript><img width="75" height="38" src="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-speed-up-wordpress-and-boost-performance-on-an-ubuntu20.04-vps-150x75.jpg" class="attachment-75x75 size-75x75" alt="" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-speed-up-wordpress-and-boost-performance-on-an-ubuntu20.04-vps-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-speed-up-wordpress-and-boost-performance-on-an-ubuntu20.04-vps-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2020/06/how-to-speed-up-wordpress-and-boost-performance-on-an-ubuntu20.04-vps.jpg 742w" sizes="(max-width: 75px) 100vw, 75px" /></noscript><span class="rpwwt-post-title">How to Speed Up WordPress and Boost Performance on an Ubuntu 20.04 VPS</span></a></li></ul></div></aside><aside id="zoom-social-icons-widget-2" class="widget inner-padding zoom-social-icons-widget"><ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--align-center zoom-social-icons-list--no-labels"><li class="zoom-social_icons-list__item"> <a class="zoom-social_icons-list__link" href="https://www.facebook.com/RoseHosting" target="_blank"> <span class="screen-reader-text">facebook</span> <span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #3b5998; font-size: 20px; padding:8px"></span> </a></li><li class="zoom-social_icons-list__item"> <a class="zoom-social_icons-list__link" href="https://twitter.com/rosehosting" target="_blank"> <span class="screen-reader-text">twitter</span> <span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#1da1f2" style="background-color : #1da1f2; font-size: 20px; padding:8px"></span> </a></li><li class="zoom-social_icons-list__item"> <a class="zoom-social_icons-list__link" href="https://www.linkedin.com/company/rose-web-services-l-l-c-" target="_blank"> <span class="screen-reader-text">linkedin</span> <span class="zoom-social_icons-list-span social-icon socicon socicon-linkedin" data-hover-rule="background-color" data-hover-color="#0077B5" style="background-color : #0077B5; font-size: 20px; padding:8px"></span> </a></li></ul></aside><aside id="search-3" class="widget inner-padding widget_search"><form method="get" class="search-form" action="https://www.rosehosting.com/blog/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" title="Search for:"> </label> <input type="submit" class="search-submit" value="Search"></form></aside></div></div></div><footer class="footer-big-menu"><div class="container" style="max-width: 1100px;"><div class="row menu"><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title mb-2">Company</h3> <a class="menu-link" href="https://www.rosehosting.com/about-us.html">About us</a> <a class="menu-link" href="https://www.rosehosting.com/policies.html">Our Policies</a> <a class="menu-link" href="https://www.rosehosting.com/contact-us.html">Contact Us</a> <a class="menu-link" href="https://www.rosehosting.com/blog/">Blog</a> <a class="menu-link" href="https://www.rosehosting.com/why-rosehosting.html">Why RoseHosting</a> <a class="menu-link" href="https://www.rosehosting.com/compare-to-competition.html">Compare Us</a> <a class="menu-link" href="https://www.rosehosting.com/reviews.html">Customer Reviews</a> <a class="menu-link" href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a></div><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title mb-2">Support</h3> <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Helpdesk System</a> <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a> <a class="menu-link" href="https://status.rosehosting.com">Systems Status</a><h3 class="menu-title mb-2 mt-4">Other Services</h3> <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Domain Registration</a> <a class="menu-link" href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Domain Transfer</a> <a class="menu-link" href="https://www.rosehosting.com/ssl-certificates.html">SSL Certificates</a></div><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title mb-2">Hosting</h3> <a class="menu-link" href="https://www.rosehosting.com/web-hosting.html">Web Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/linux-vps-hosting.html">Linux VPS Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/nvme-hosting.html">NVMe Hosting</a> <a class="menu-link" href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom SSD VPS</a> <a class="menu-link" href="https://www.rosehosting.com/dedicated-servers.html">Cloud Dedicated Servers</a> <a class="menu-link" href="https://www.rosehosting.com/hosting-solutions.html">Hosting Solutions</a> <a class="menu-link" href="https://www.rosehosting.com/vps-affiliate-program.html">Recurr. Affiliate Program</a> <a class="menu-link" href="https://www.rosehosting.com/cpa-hosting-affiliate-program.html">CPA Affiliate Program</a></div><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title mb-2">Linux VPS Hosting</h3> <a class="menu-link" href="https://www.rosehosting.com/centos-hosting.html">CentOS Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/ubuntu-hosting.html">Ubuntu Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/debian-hosting.html">Debian Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/opensuse-hosting.html">OpenSUSE Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/arch-linux-hosting.html">Arch-Linux Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/scientific-linux-hosting.html">Scientific Linux Hosting</a></div><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title mb-2">Apps Hosting</h3> <a class="menu-link" href="https://www.rosehosting.com/wordpress-hosting.html">WordPress Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/magento-hosting.html">Magento Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/odoo-hosting.html">Odoo Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/joomla-hosting.html">Joomla Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/drupal-hosting.html">Drupal Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/laravel-hosting.html">Laravel Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/nextcloud-hosting.html">NextCloud Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/prestashop-hosting.html">PrestaShop Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/ghost-hosting.html">Ghost Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/mediawiki-hosting.html">MediaWiki Hosting</a> <a class="menu-link" href="https://www.rosehosting.com/tomcat-hosting.html">Tomcat Hosting</a></div><div class="col-6 col-md-3 col-lg-2"><h3 class="menu-title mb-2">Contact Us</h3> <a class="menu-link" href="tel:+18887673467">(888) ROSE-HOST</a> <a class="menu-link" href="tel:+18887673467">(888) 767-3467</a> <a class="menu-link" href="tel:+16465197201">(314) 275-0414</a> <a class="menu-link" href="/cdn-cgi/l/email-protection#b69381859381839381869381869380d09381849381829382869381849380d093818593808393808e9380d093818593818293808f9380d39380819384d39380859380d09380d2">Email us</a><h3 class="menu-title mb-2 mt-4">Connect</h3> <a class="menu-link" href="https://twitter.com/rosehosting" target="_blank"><i class="fa fa-twitter fa-fw"></i> Twitter</a> <a class="menu-link" href="https://www.facebook.com/RoseHosting" target="_blank"><i class="fa fa-facebook fa-fw"></i> Facebook</a> <a class="menu-link" href="https://www.linkedin.com/company/rose-web-services-l-l-c-" target="_blank"><i class="fa fa-linkedin fa-fw"></i> LinkedIn</a> <a class="menu-link" href="https://www.rosehosting.com/blog/feed/" target="_blank"><i class="fa fa-rss fa-fw"></i> RSS Feed</a></div></div></div><div class="bottom"><div class="container" style="max-width: 1100px;"><div class="row"><div class="col col-md-12"> <img class="privacy-shield d-block mb-4" width="175" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20175%200'%3E%3C/svg%3E" alt="privacy shield" data-lazy-src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/privacy_shield.png"><noscript><img class="privacy-shield d-block mb-4" width="175" src="https://www.rosehosting.com/blog/wp-content/themes/rh2020/img/privacy_shield.png" alt="privacy shield"></noscript></div><div class="col-md-12 col-lg-6"><p class="text-sm-left"><a class="inline-link footer-policy" href="/tos.html">Terms of Service</a> and <a class="inline-link footer-policy" href="/policies.html">other policies</a></p></div><div class="col-md-12 col-lg-6"><p class="text-sm-right">&copy; 2001-2020 <a class="inline-link footer-policy" href="https://www.rosewebservices.com/">Rose Web Services LLC</a>.</p></div></div></div></div> <!--[if lte IE 11]>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/generatepress/js/classList.min.js'></script>
<![endif]--> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>/* <![CDATA[ */ var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"","width":"95%","scroll_offset":"30"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var cptch_vars = {"nonce":"65b73ef44c","ajaxurl":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","enlarge":"","time_limit":"120"}; /* ]]> */</script> <script type='text/javascript'>/* <![CDATA[ */ var wpSlideCaptcha = {"ajax_url":"https:\/\/www.rosehosting.com\/blog\/wp-admin\/admin-ajax.php","start_slide":"Slide to verify","end_slide":"Verification passed"}; /* ]]> */</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.rosehosting.com/blog/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script> <script>const wprRemoveCPCSS = () => { $elem = document.getElementById( "rocket-critical-css" ); if ( $elem ) { $elem.remove(); } }; if ( window.addEventListener ) { window.addEventListener( "load", wprRemoveCPCSS ); } else if ( window.attachEvent ) { window.attachEvent( "onload", wprRemoveCPCSS ); }</script><script src="https://www.rosehosting.com/blog/wp-content/cache/min/1/266800988385f850c8560355a1f69277.js" data-minify="1" defer></script><noscript><link rel="stylesheet" href="https://www.rosehosting.com/blog/wp-content/cache/min/1/60557ec1466eb28156079bef4ecf1249.css" data-minify="1" /></noscript><noscript><link rel='stylesheet' id='generate-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans:300,300italic,regular,italic,600,600italic,700,700italic,800,800italic&#038;display=swap' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='font-awesome-css' href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' /></noscript></body></html>
