<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US"
	itemscope 
	itemtype="http://schema.org/Article" 
	prefix="og: http://ogp.me/ns#" >
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US"
	itemscope 
	itemtype="http://schema.org/Article" 
	prefix="og: http://ogp.me/ns#" >
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US"
	itemscope 
	itemtype="http://schema.org/Article" 
	prefix="og: http://ogp.me/ns#" >
<!--<![endif]-->
<head>

	<meta charset="UTF-8" />
	<meta name="viewport" content="width=device-width, initial-scale=1">

	<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="pingback" href="https://www.rosehosting.com/blog/xmlrpc.php" />
	
	<script src="https://use.typekit.net/qcm5sfg.js"></script>
    <script>try{Typekit.load({ async: true });}catch(e){}</script>
    
	<title>First Steps After Getting an Ubuntu VPS &#8211; RoseHosting.com Blog</title>

<!-- All in One SEO Pack 2.3.12.5 by Michael Torbert of Semper Fi Web Design[-1,-1] -->
<link rel="author" href="https://plus.google.com/+RoseHosting" />
<meta name="description"  content="Got a new Ubuntu VPS? That's great. You can now start using it and experience all the advantages of a Linux VPS. If you moved from shared hosting to a VPS, even" />

<meta name="keywords"  content="ubuntu" />

<link rel="canonical" href="https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/" />
<meta property="og:title" content="First Steps After Getting an Ubuntu VPS" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/" />
<meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps-1024x512.jpg" />
<meta property="og:site_name" content="RoseHosting.com Blog" />
<meta property="og:description" content="Got a new Ubuntu VPS? That&#039;s great. You can now start using it and experience all the advantages of a Linux VPS. If you moved from shared hosting to a VPS, even better, you can now directly compare your experience with shared hosting and VPS hosting. This guide will help you get started with your Ubuntu 16.04 VPS.  This guide is targeted towards beginners, although other intermediate users can still use it and find useful tips and tricks for their server. We&#039;ve included instructions and linked to our tutorials for each step you need to take, but they still may vary depending on your setup. If you don&#039;t know what you are doing and just want to use a server, get a Managed VPS from us and leave the server work to us. We&#039;ll set up, configure and secure your server for free.  Connect to your VPS This may seem obvious, but before you can do anything, you must connect to your VPS. There are different ways of logging into your VPS, depending on which OS you use. You can check our post and" />
<meta property="article:tag" content="ubuntu" />
<meta property="article:tag" content="guides" />
<meta property="article:publisher" content="https://www.facebook.com/RoseHosting/" />
<meta property="article:author" content="https://www.facebook.com/RoseHosting/" />
<meta property="article:published_time" content="2017-05-04T07:34:21Z" />
<meta property="article:modified_time" content="2017-05-04T07:34:21Z" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@RoseHosting" />
<meta name="twitter:creator" content="@rosehosting" />
<meta name="twitter:title" content="First Steps After Getting an Ubuntu VPS" />
<meta name="twitter:description" content="Got a new Ubuntu VPS? That&#039;s great. You can now start using it and experience all the advantages of a Linux VPS. If you moved from shared hosting to a VPS, even better, you can now directly compare your experience with shared hosting and VPS hosting. This guide will help you get started with your Ubuntu 16.04 VPS.  This guide is targeted towards beginners, although other intermediate users can still use it and find useful tips and tricks for their server. We&#039;ve included instructions and linked to our tutorials for each step you need to take, but they still may vary depending on your setup. If you don&#039;t know what you are doing and just want to use a server, get a Managed VPS from us and leave the server work to us. We&#039;ll set up, configure and secure your server for free.  Connect to your VPS This may seem obvious, but before you can do anything, you must connect to your VPS. There are different ways of logging into your VPS, depending on which OS you use. You can check our post and" />
<meta name="twitter:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps-1024x512.jpg" />
<meta itemprop="image" content="https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps-1024x512.jpg" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="RoseHosting.com Blog &raquo; Feed" href="https://www.rosehosting.com/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting.com Blog &raquo; Comments Feed" href="https://www.rosehosting.com/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="RoseHosting.com Blog &raquo; First Steps After Getting an Ubuntu VPS Comments Feed" href="https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.rosehosting.com\/blog\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ecko_plugin_css-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/eckoplugin/assets/css/eckoplugin.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='isf_style-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/indeed-social-media/social_follow/files/css/style-frond_end.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='isf_pack_social_follow-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/indeed-social-media/social_follow/files/css/pack_social_follow.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='ism_font-awesome-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/indeed-social-media/files/css/font-awesome.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='ism_socicon-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/indeed-social-media/files/css/socicon.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='ism_style-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/indeed-social-media/files/css/style-front_end.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='ism_templates-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/indeed-social-media/files/css/templates.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='ism_show_effects_css-css'  href='https://www.rosehosting.com/blog/wp-content/plugins/indeed-social-media/files/css/animate.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='ecko_css-css'  href='https://www.rosehosting.com/blog/wp-content/themes/rh2016/style.css?ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='ecko-fonts-css'  href='//fonts.googleapis.com/css?family=Muli%3A400%2C700%7CVarela+Round%3A400%7CBitter%3A400%7CMontserrat%3A400%7C&#038;ver=2.2.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/indeed-social-media/files/js/front_end_header.js'></script>
<script type='text/javascript' src='https://apis.google.com/js/plusone.js'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/indeed-social-media/files/js/json2.js'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/indeed-social-media/files/js/jstorage.js'></script>
<link rel='https://api.w.org/' href='https://www.rosehosting.com/blog/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.rosehosting.com/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.rosehosting.com/blog/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='How To Install Webmin on CentOS 7' href='https://www.rosehosting.com/blog/how-to-install-webmin-on-centos-7/' />
<meta name="generator" content="WordPress 4.7.4" />
<link rel='shortlink' href='https://www.rosehosting.com/blog/?p=22112' />
<link rel="alternate" type="application/json+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Ffirst-steps-after-getting-an-ubuntu-vps%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.rosehosting.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.rosehosting.com%2Fblog%2Ffirst-steps-after-getting-an-ubuntu-vps%2F&#038;format=xml" />
<meta name="twitter:card" content="photo" />
<meta name="twitter:image:src" id="twitter_meta_img" content="https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps.jpg">
<meta name="twitter:url" content="https://www.rosehosting.com/blog" />
					<style>
				.socialdark.pinterest{
    display: none !important;
}			</style>
					<meta property="fb:app_id" content="" />
			<meta property="fb:admins" content="" />
						<meta property="og:url" content="https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/"/>
			<meta property="og:title" content="First Steps After Getting an Ubuntu VPS" />
			<meta property="og:description" content="Facebook0Twitter0Google+0Linkedin0" />
			<meta property="og:type" content="article" />
			<meta property="og:image" content="https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps-680x340.jpg" />
								<style type="text/css">

								
																				
																				
																								
																													.post-list .post .author{ display:none !important; }
												
												
																					body.single .post-title .author{ display:none; }
																																	body.single .post-author-profile{ display:none; }
												
																												
																				
													.disclaimer{ display:none !important; }
													.disclaimer .wordpress{ display:none !important; }
													.disclaimer .ecko{ display:none !important; }
				
								
			 </style>
		<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="amphtml" href="https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/amp/" /><link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.rosehosting.com/blog/wp-content/uploads/2016/02/cropped-rhlogo-final-270x270.png" />
</head>

<body class="post-template-default single single-post postid-22112 single-format-standard top-bar-visible page-layout-right-sidebar" itemscope="itemscope" itemtype="http://schema.org/TechArticle">

	<div class="backtotop"><i class="fa fa-angle-double-up"></i></div>

		
     <header class="rh">
        <!-- <nav class="navbar navbar-inverse navbar-fixed-top" role="navigation"> -->
        <nav class="navbar navbar-inverse" role="navigation">
          <div class="container">
            <div class="navbar-header">
              <a href="https://www.rosehosting.com" class="navbar-brand">
                <img alt="RoseHosting.com"  width="201" height="40" src="https://media.rosehosting.com/img/rh-logo.svg">

              </a>
              <button data-target="#navbar-main" data-toggle="collapse" type="button" class="navbar-toggle">
                <span class="icon-bar"></span>
                <span class="icon-bar"></span>
                <span class="icon-bar"></span>
              </button>
            </div>
            <div id="navbar-main" class="navbar-collapse collapse">
              <ul class="nav navbar-nav navbar-right">

                <li class="dropdown"><a href="#" data-toggle="dropdown" class="dropdown-toggle">Hosting <span class="caret"></span></a>
                    <ul class="dropdown-menu">
                        <li><a href="https://www.rosehosting.com/linux-shared-hosting.html">Shared Hosting</a></li>
                        <li><a href="https://www.rosehosting.com/linux-vps-hosting.html">Linux VPS Hosting</a></li>
                        <li><a href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=82">Custom SSD VPS</a></li>
                        <li><a href="https://www.rosehosting.com/cloud-server-oci-hosting.html">OneClick Install Cloud</a></li>
                        <li><a href="https://www.rosehosting.com/dedicated-servers.html">Dedicated Servers</a></li>
                        <li><a href="https://www.rosehosting.com/vps-affiliate-program.html">Affiliate Program</a></li>                        
                        <li><a href="https://www.rosehosting.com/hosting-services.html">Hosting Services</a></li>
                        <li><a href="https://www.rosehosting.com/other-services.html">Other Services</a></li>
                    </ul>
                </li>

                <li class="dropdown"><a href="#" data-toggle="dropdown" class="dropdown-toggle">SSL Certificates <span class="caret"></span></a>
                    <ul class="dropdown-menu">
                        <li class="dropdown-header"><span></span>By brand</li>
                        <li><a href="https://www.rosehosting.com/ssl-certificates.html">GeoTrust</a></li>
                        <li><a href="https://www.rosehosting.com/ssl-certificates.html#comodo">Comodo</a></li>
                        <li><a href="https://www.rosehosting.com/ssl-certificates.html#rapidssl">RapidSSL</a></li>
                        <li><a href="https://www.rosehosting.com/ssl-certificates.html#symantec">Symantec</a></li>
                        <li><a href="https://www.rosehosting.com/ssl-certificates.html#thawte">Thawte</a></li>
                        <li class="dropdown-header">By Type</li>
                        <li><a href="https://www.rosehosting.com/ssl-certificates-by-type.html">Domain Validation</a></li>
                        <li><a href="https://www.rosehosting.com/ssl-certificates-by-type.html#organization">Organization Validation</a></li>
                        <li><a href="https://www.rosehosting.com/ssl-certificates-by-type.html#extended">Extended Validation</a></li>
                        <li><a href="https://www.rosehosting.com/ssl-certificates-by-type.html#wildcard">Wildcard SSL</a></li>
                        <li><a href="https://www.rosehosting.com/ssl-certificates-by-type.html#multidomain">Multi-Domain (SAN)</a></li>
                        <li><a href="https://www.rosehosting.com/ssl-certificates-by-type.html#codesigning">Code Signing SSL</a></li>
                        <li><a href="https://www.rosehosting.com/ssl-certificates-by-type.html#sgs">SCG SSL</a></li>
                    </ul>
                </li>


                <li class="dropdown"><a href="#" data-toggle="dropdown" class="dropdown-toggle">Domains <span class="caret"></span></a>
                    <ul class="dropdown-menu">
                        <li><a href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Register Domains</a></li>
                        <li><a href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Transfer Domains</a></li>
                    </ul>
                </li>


                <li class="dropdown"><a href="#" data-toggle="dropdown" class="dropdown-toggle js-activated">Help <span class="caret"></span></a>
                    <ul class="dropdown-menu">
                        <li><a href="https://www.rosehosting.com/support.html">Support</a></li>
                        <li><a href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Open a Support Ticket</a></li>
                        <li><a href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a></li>
                        <!--<li><a href="#">Library</a></li>-->
                    </ul>
                </li>

                <li class="dropdown">
                    <a href="#" data-toggle="dropdown" class="dropdown-toggle js-activated">About Us <span class="caret"></span></a>
                    <ul class="dropdown-menu">
                        <li><a href="https://www.rosehosting.com/about-us.html">Our Company</a></li>
                        <li><a href="https://www.rosehosting.com/contact-us.html">Contact Us</a></li>
                        <li><a href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a><li>
                        <li><a href="https://www.rosehosting.com/reviews.html">Customer Reviews</a></li>
                        <li><a href="https://www.rosehosting.com/policies.html">Our Policies</a></li>
                    </ul>
                </li>

                <li><a href="https://www.rosehosting.com/blog/">Blog</a></li>
                <li class="login-btn"><a href="https://secure.rosehosting.com/clientarea/index.php?/clientarea/">Login</a></li>
                <li class="visible-sm visible-md"><a href="https://secure.rosehosting.com/clientarea/index.php?/signup/">Sign Up</a></li>
                <li class="hidden-md"><div><a href="https://secure.rosehosting.com/clientarea/index.php?/signup/" class="btn btn-border-nav navbar-btn hidden-xs" id="btn-signup-top">Sign Up</a></div></li>

              </ul>

            </div>
          </div>
        </nav>
    </header>
	
		
		<section class="page-content">
			<div class="wrapper-body">

				<div id="post-22112" class="page-main post-22112 post type-post status-publish format-standard has-post-thumbnail hentry category-guides tag-ubuntu">

					
	<section class="post-title post-title-standard">
		
		<h1 itemprop="name headline">First Steps After Getting an Ubuntu VPS</h1>
		<ul class="meta">
			<li class="author"><a href="https://www.rosehosting.com/blog/author/r0s3admin/"><i class="fa fa-user"></i>admin</a></li>
			<li class="date"><a href="https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/"><i class="fa fa-clock-o"></i><time datetime="2017-05-04">May 4, 2017</time></a></li>
			<li class="comments"><a href="https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/#comments"><i class="fa fa-comments-o"></i>0</a></li>
			<li class="category-rh"><a class="category" style="background:#7fbb00;" href="https://www.rosehosting.com/blog/category/guides/">Guides</a></li>
		</ul>
		<hr>
	</section>



					<section class="post-contents">

						<script>jQuery(document).ready(function(){items_str = "facebook,twitter,google,linkedin";
			items_arr = items_str.split(",");
				ism_load_counts(0, 'https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/', '#indeed_sm_wrap_1195', items_arr, 1);
				});jQuery(document).ready(function(){
					fc_items_str = "twitter";
					fc_items_arr = fc_items_str.split(",");
					ism_load_statistics_counts(fc_items_arr, 'https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/', '#indeed_sm_wrap_1195', 1);
			  });</script><style>#indeed_sm_wrap_1195{top : 20px;left : 20px;}#indeed_sm_wrap_1195 .ism_item{}#indeed_sm_wrap_1195 .ism_item_wrapper{display: inline-block;}#indeed_sm_wrap_1195{display: block;text-align: center;}</style><div class="ism_wrap ism_template_3  ism-content-display" id="indeed_sm_wrap_1195" style="" ><div id="fb_desc-880" data-ism_description="Got a new Ubuntu VPS? That\'s great. You can now start using it and experience all the advantages of a Linux VPS. If you moved from shared hosting to a VPS, even better, you can now directly compare your experience with shared hosting and VPS hosting. This guide will help ..." style="display: none;"></div><a href="javascript:void(0)" class="ism_link" onClick="shareOnFacebook( 'First%20Steps%20After%20Getting%20an%20Ubuntu%20VPS', 'https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/', 'https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps-150x75.jpg', '0', '0', '#fb_desc-880', '1' );ism_fake_increment('.facebook_share_count', 'facebook', 'https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/');"><div class="ism_item_wrapper ism-align-horizontal"><div class="ism_item ism_box_facebook"><i class="fa-ism fa-facebook-ism"></i><span class="ism_share_label">Facebook</span><span class="ism_share_counts facebook_share_count" >0</span><div class="clear"></div></div></div></a><a href="javascript:void(0)" class="ism_link" onClick="ism_fake_increment('.twitter_share_count', 'twitter', 'https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/');return !window.open('https://twitter.com/intent/tweet?text=First%20Steps%20After%20Getting%20an%20Ubuntu%20VPS https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/ %40RoseHosting', '', 'width=700,height=313');"><div class="ism_item_wrapper ism-align-horizontal"><div class="ism_item ism_box_twitter"><i class="fa-ism fa-twitter-ism"></i><span class="ism_share_label">Twitter</span><span class="ism_share_counts twitter_share_count" >0</span><div class="clear"></div></div></div></a><a href="https://plus.google.com/share?url=https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/" class="ism_link" onClick="ism_fake_increment('.google_share_count', 'google', 'https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/');return !window.open(this.href, '', 'width=700,height=313');"><div class="ism_item_wrapper ism-align-horizontal"><div class="ism_item ism_box_google"><i class="fa-ism fa-google-ism"></i><span class="ism_share_label">Google+</span><span class="ism_share_counts google_share_count" >0</span><div class="clear"></div></div></div></a><a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/&title=First%20Steps%20After%20Getting%20an%20Ubuntu%20VPS&summary=Got a new Ubuntu VPS? That\'s great. You can now start using it and experience all the advantages of a Linux VPS. If you moved from shared hosting to a VPS, even better, you can now directly compare your experience with shared hosting and VPS hosting. This guide will help ..." class="ism_link" onClick="ism_fake_increment('.linkedin_share_count', 'linkedin', 'https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/');return !window.open(this.href, '', 'width=700,height=450');"><div class="ism_item_wrapper ism-align-horizontal"><div class="ism_item ism_box_linkedin"><i class="fa-ism fa-linkedin-ism"></i><span class="ism_share_label">Linkedin</span><span class="ism_share_counts linkedin_share_count" >0</span><div class="clear"></div></div></div></a></div><p><img class="alignnone size-full wp-image-22128" src="https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps.jpg" alt="first steps after getting an ubuntu vps" width="1200" height="600" srcset="https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps.jpg 1200w, https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps-150x75.jpg 150w, https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps-300x150.jpg 300w, https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps-768x384.jpg 768w, https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps-1024x512.jpg 1024w, https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps-860x430.jpg 860w, https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps-680x340.jpg 680w, https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps-500x250.jpg 500w, https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps-400x200.jpg 400w, https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps-200x100.jpg 200w, https://www.rosehosting.com/blog/wp-content/uploads/2017/05/first-steps-after-ubuntu-vps-50x25.jpg 50w" sizes="(max-width: 1200px) 100vw, 1200px" /></p>
<p>Got a new <a href="https://www.rosehosting.com/ubuntu-vps.html">Ubuntu VPS</a>? That&#8217;s great. You can now start using it and experience all the advantages of a Linux VPS. If you moved <a href="https://www.rosehosting.com/blog/from-shared-to-vps-hosting/">from shared hosting to a VPS</a>, even better, you can now directly compare your experience with <a href="https://www.rosehosting.com/linux-shared-hosting.html">shared hosting</a> and <a href="https://www.rosehosting.com/linux-vps-hosting.html">VPS hosting</a>. This guide will help you get started with your Ubuntu 16.04 VPS.</p>
<p><span id="more-22112"></span></p>
<div class="alert gray">This guide is targeted towards <strong>beginners</strong>, although other intermediate users can still use it and find useful tips and tricks for their server. We&#8217;ve included instructions and linked to our tutorials for each step you need to take, but they still may vary depending on your setup. If you don&#8217;t know what you are doing and just want to use a server, <a href="https://www.rosehosting.com/linux-vps-hosting.html">get a Managed VPS from us</a> and leave the server work to us. We&#8217;ll set up, configure and secure your server for free. </div>
<h2>Connect to your VPS</h2>
<p>This may seem obvious, but before you can do anything, you must <a href="https://www.rosehosting.com/blog/connect-to-your-linux-vps-via-ssh/">connect to your VPS</a>. There are different ways of logging into your VPS, depending on which OS you use. You can check our post and follow the instructions for your OS, be it Windows, Mac, or Linux.</p>
<h2>Update your server</h2>
<p>First thing you always need to do &#8211; <a href="https://www.rosehosting.com/blog/update-the-software-on-linux/">update your server</a>. You can update your Ubuntu VPS with the following command:</p>
<pre>apt-get update &amp;&amp; apt-get upgrade -y</pre>
<p>This command will update all your system&#8217;s packages to their latest version. You should regularly update your VPS. You can set a reminder to do it, or you can <a href="https://www.rosehosting.com/blog/how-to-enable-automatic-updates-on-a-linux-vps/">set up automatic updates</a>.</p>
<h2>Secure your server</h2>
<p>Don&#8217;t start doing anything until you <strong>properly</strong> configure and secure your server. We can&#8217;t stress <strong>properly</strong> enough. If you&#8217;re a beginner and don&#8217;t know much about Ubuntu servers or security, get a <a href="https://www.rosehosting.com/ubuntu-vps.html">Managed Ubuntu VPS</a> from us and our expert Linux admins will properly secure your server.</p>
<h3>Enable 2FA</h3>
<p>Two-Factor Authentication essentially means you&#8217;ll need a code that&#8217;s sent to your phone in order to log in to your VPS. You can follow <a href="https://www.rosehosting.com/blog/secure-your-ssh-using-two-factor-authentication-on-ubuntu-16-04/">our tutorial</a> and set up 2FA on your Ubuntu 16.04 VPS. Enabling 2FA will prevent other unauthorized users from logging into your server.</p>
<h3>Use SSH keys</h3>
<p>Another way of securing your server by preventing unwanted access is to <a href="https://www.rosehosting.com/blog/ssh-login-without-password-using-ssh-keys/">use SSH keys</a>. This will prevent anyone from logging into your server without a unique combination of a private and public key, which you must add to your server.</p>
<h3>Use a strong password</h3>
<p>Everywhere. Not just your server. Use a strong password in the client area, use a strong password in your CMS, use a strong password in your database. You can <a href="https://www.rosehosting.com/blog/generate-password-linux-command-line/">generate a password from the command line</a> too. It is recommended that you use different passwords for each login/service.</p>
<p>The combination of a strong password along with SSH keys and 2FA ensures maximum security when it comes to unauthorized access to your VPS.</p>
<h3>Change the default SSH port</h3>
<p>The default SSH port is 22, so you should <a href="https://www.rosehosting.com/blog/change-default-ssh-port-on-linux/">change it</a> as that&#8217;s the most common port that gets attacked. Although it&#8217;s relatively easy to &#8220;sniff out&#8221; the port your server is using, you should still not use the default one as it can prevent some attacks. It will only take a few minutes and it may save you days worth of work from the attacks you&#8217;ll receive if you continue using the default port.</p>
<h3>Set up a firewall</h3>
<p>One of the security tweaks you can do on your server is to set up a firewall. There are several ways of doing it &#8211; a couple of them are <a href="https://www.rosehosting.com/blog/how-to-set-up-a-firewall-with-iptables-on-ubuntu-and-centos/">using iptables</a> and <a href="https://www.rosehosting.com/blog/set-up-firewall-with-ufw-on-ubuntu/">using UFW</a>. Follow the appropriate tutorial and configure your firewall. Make sure to closely follow the tutorial, because you can block yourself out of your server or misconfigure the firewall and block all traffic to your websites. Make sure you know what you&#8217;re doing, or, again, get a <a href="https://www.rosehosting.com/linux-vps-hosting.html">Managed VPS</a> and let professionals do it for you.</p>
<p>You can also use <a href="https://www.rosehosting.com/blog/install-fail2ban-on-an-ubuntu-14-04/">fail2ban</a> to prevent brute-force attacks on your SSH, HTTP, FTP, SMTP etc.</p>
<div class="alert blue">Using a LEMP (Linux, Nginx, MySQL, PHP) stack? Follow our tutorial on <a href="https://www.rosehosting.com/blog/how-to-secure-your-lemp-stack/">securing your whole LEMP stack</a>.</div>
<h3>Use an SSL certificate for your websites</h3>
<p>You should always use SSL (https) on your websites. Having an <a href="https://www.rosehosting.com/ssl-certificates.html">SSL certificate</a> on your website is even considered a <a href="https://webmasters.googleblog.com/2014/08/https-as-ranking-signal.html">ranking factor by Google</a>, so you&#8217;ll improve your search engine visibility, as well as your security. By using SSL, you&#8217;ll also increase your user&#8217;s trust factor.</p>
<p><em>Don&#8217;t forget to <a href="https://www.rosehosting.com/blog/how-to-redirect-http-traffic-to-https-in-nginx-and-apache/">redirect all traffic from HTTP to HTTPS</a> after you install your SSL.</em></p>
<h2>Backup your server</h2>
<p>It&#8217;s always smart, recommended, and essential to have backups. You never know when and what could go wrong, and a backup will <em>really</em> come in handy if something does go wrong. If you <a href="https://www.rosehosting.com/linux-vps-hosting.html">get a VPS from us</a>, you&#8217;ll have an automatic, full backup of your VPS on a weekly basis, for free! Sure, you can manually copy all your files and data each time you want to do a backup, but it gets really repetitive and it will take up a lot of your time. If you don&#8217;t have automatic backups, make sure to manually backup your server before doing any changes on the server or the apps running on your server.</p>
<h2>Set up monitoring</h2>
<p>You&#8217;ll want to monitor your server and know whether or not it&#8217;s up and running. You can use an app like <a href="https://www.rosehosting.com/icinga-hosting.html">Icinga</a>. You can also use <a href="https://www.rosehosting.com/server-monitoring.html">our free server monitoring service</a> and stay updated on your server&#8217;s uptime. This is where a 24/7 support team can come in handy. Misconfigured your server at 3 AM and now your website&#8217;s down? No problem. Our <a href="https://www.rosehosting.com/support.html">EPIC 24/7 Support team</a> is online and ready to help.</p>
<h2>Use a <a href="https://www.rosehosting.com/control-panel-hosting.html">control panel</a> (optional)</h2>
<p>Even though you&#8217;re using a Linux VPS, which by default is only managed by the command line interface, you can still use a control panel like <a href="https://www.rosehosting.com/cpanel-hosting.html">cPanel</a> or <a href="https://www.rosehosting.com/directadmin-hosting.html">DirectAdmin</a> and manage your VPS via a GUI. There are also some <a href="https://www.rosehosting.com/blog/best-open-source-hosting-control-panels/">open source alternatives</a>. However, if you can and know how to manage your server without a control panel, it&#8217;s recommended not to use one, as it will just cause unnecessary load on your server.</p>
<h2>Set up a mail server</h2>
<p>Be careful, though! Setting up a self-hosted mail server is a long and difficult process which requires constant monitoring and frequent configuring. We have dozens of tutorials on how to set up a mail server. If you need a mail server and don&#8217;t really know how to set it up, <a href="https://www.rosehosting.com/email-hosting.html">get a VPS from us</a> and we&#8217;ll set up a mail server for you, for free. You can <a href="https://www.rosehosting.com/blog/setup-mailinabox-on-ubuntu/">set up a mail server using Mail-in-a-Box</a> which is (relatively) easy. You can also manually <a href="https://www.rosehosting.com/blog/setup-and-configure-a-mail-server-with-postfixadmin/">set up and configure a mail server using PostfixAdmin</a>. After all, you get full root access (full control) to your <a href="https://www.rosehosting.com/managed-vps-hosting.html">Managed VPS from RoseHosting.com</a>, so you are free to install <a href="https://www.rosehosting.com/tos.html"><em>almost</em></a> any software you want.</p>
<h2>Install an (S)FTP server</h2>
<p>You most likely need an FTP server. It&#8217;s recommended to use secure FTP (SFTP). You can <a href="https://www.rosehosting.com/blog/install-vsftpd-on-ubuntu/">install VSFTPD</a>, which is free and open source, and relatively easy to set up. Don&#8217;t forget to use a strong password for the FTP users.</p>
<div class="alert green">All of this seems overwhelming? No worries, <a href="https://www.rosehosting.com/linux-vps-hosting.html">get a VPS</a> from us and our expert Linux admins will manage your server 24/7. We&#8217;ll set up, configure and secure your server along with an application of your choice. </div>
<h2>Install applications you need</h2>
<p>Install any self-hosted application that you plan on using. There are <a href="https://www.rosehosting.com/blog/self-hosted-alternatives/">hundreds of options</a>. Each application requires a different set of services and has different prerequisites, so find a tutorial for the specific app you want to use. You can check our <a href="https://www.rosehosting.com/vps-hosting-stacks.html">VPS Hosting Stacks</a> for a small portion of the apps and services we support. All our hosting plans are fully managed with free 24/7 support, so we will install, configure and optimize any application on your server, for free.</p>
<h2>Explore and have fun!</h2>
<p>There are many things that you can do on your Ubuntu VPS. You can follow us on social media and check our <a href="https://twitter.com/search?l=&amp;q=%23RoseTips%20from%3ARoseHosting&amp;src=typd&amp;lang=en">#RoseTips</a>, which are fun and useful tips and tricks for your Linux server. We also have a post on our blog for some <a href="https://www.rosehosting.com/blog/quick-linux-tips-and-tricks/">quick tips and tricks</a>.</p>
<h2>Further reading</h2>
<p>We also have some other recommended resources that you can use. Check the other resources on our blog for more information and tutorials.</p>
<article id="post-21670" class="post post-21670 type-post status-publish format-standard has-post-thumbnail hentry category-tutorials tag-basic-commands tag-network-commands">
<div class="post-content">
<p><a href="https://www.rosehosting.com/blog/what-is-linux-vps-hosting/">What is Linux VPS Hosting?</a></p>
<p><a href="https://www.rosehosting.com/blog/basic-shell-commands-after-putty-ssh-logon/">Basic shell commands after Putty SSH logon</a></p>
<p><a href="https://www.rosehosting.com/blog/6-basic-network-commands-in-linux/">6 Basic Network Commands in Linux</a></p>
<article id="post-19336" class="post post-19336 type-post status-publish format-standard has-post-thumbnail hentry category-tips-and-tricks tag-putty tag-shell-commands tag-ssh">
<div class="post-thumbnail">
<article id="post-3927" class="post post-3927 type-post status-publish format-standard has-post-thumbnail hentry category-tips-and-tricks tag-exim tag-exim-commands">
<div class="post-content">
<p><a href="https://www.rosehosting.com/blog/useful-exim-commands/">Useful Exim Commands</a></p>
</div>
</article>
<div class="post-content">
<p><a href="https://www.rosehosting.com/blog/getting-started-with-tmux/">Getting started with tmux</a></p>
<article id="post-21469" class="post post-21469 type-post status-publish format-standard has-post-thumbnail hentry category-tips-and-tricks tag-screen">
<div class="post-content">
<p><a href="https://www.rosehosting.com/blog/basic-screen-command-usage-and-examples/">Basic screen command usage and examples</a></p>
</div>
</article>
</div>
</div>
<div class="post-content">
<article id="post-21774" class="post post-21774 type-post status-publish format-standard has-post-thumbnail hentry category-tutorials tag-fg tag-jobs tag-kill tag-manage-processes tag-ps tag-pstree tag-top">
<div class="post-featured-image">
<article id="post-20592" class="post post-20592 type-post status-publish format-standard has-post-thumbnail hentry category-tips-and-tricks tag-curl">
<div class="post-content">
<p><a href="https://www.rosehosting.com/blog/curl-command-examples/">5 basic cURL command examples</a></p>
</div>
</article>
</div>
<div class="post-content">
<p><a href="https://www.rosehosting.com/blog/how-to-manage-processes-in-linux/">How to Manage Processes in Linux</a></p>
<article id="post-16606" class="post post-16606 type-post status-publish format-standard has-post-thumbnail hentry category-guides tag-linux-vps">
<div class="post-content">
<article id="post-21071" class="post post-21071 type-post status-publish format-standard has-post-thumbnail hentry category-tips-and-tricks tag-sftp">
<div class="post-content">
<p><a href="https://www.rosehosting.com/blog/7-useful-sftp-command-line-examples/">7 useful SFTP command line examples</a></p>
<article id="post-20164" class="post post-20164 type-post status-publish format-standard has-post-thumbnail hentry category-tips-and-tricks tag-files">
<div class="post-content">
<p><a href="https://www.rosehosting.com/blog/linux-find-file/">How to find a file on a Linux VPS</a></p>
<article id="post-20565" class="post post-20565 type-post status-publish format-standard has-post-thumbnail hentry category-guides tag-vim">
<div class="post-content">
<p><a href="https://www.rosehosting.com/blog/ultimate-beginners-guide-to-vim/">Ultimate Beginner’s Guide to Vim</a></p>
<article id="post-20414" class="post post-20414 type-post status-publish format-standard has-post-thumbnail hentry category-tips-and-tricks tag-vim">
<div class="post-content">
<p><a href="https://www.rosehosting.com/blog/vim-tips-and-tricks/">Vim tips and tricks that you probably never heard of</a></p>
<article id="post-19755" class="post post-19755 type-post status-publish format-standard has-post-thumbnail hentry category-tips-and-tricks category-tutorials tag-files">
<div class="post-content">
<p><a href="https://www.rosehosting.com/blog/how-to-create-and-edit-files-on-a-linux-vps/">How to create and edit files on a Linux VPS</a></p>
</div>
</article>
</div>
</article>
</div>
</article>
</div>
</article>
</div>
</article>
</div>
</article>
</div>
</article>
</div>
</article>
</div>
</article>

						<div class="post-numbers">
													</div>

						
	<div class="post-footer">
		<div class="post-tags">
			<a href="https://www.rosehosting.com/blog/tag/ubuntu/" rel="tag">ubuntu</a>		</div>
		<ul class="post-social-share">
			<li class="title">Share:</li>
			<li><a href="http://twitter.com/share?text=First+Steps+After+Getting+an+Ubuntu+VPS&amp;url=https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/" onclick="window.open(this.href, 'twitter-share', 'width=550,height=235');return false;" title="Twitter" class="socialdark twitter"><i class="fa fa-twitter"></i></a></li>
			<li><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/" onclick="window.open(this.href, 'facebook-share','width=580,height=296');return false;" title="Facebook" class="socialdark facebook"><i class="fa fa-facebook"></i></a></li>
			<li><a href="https://plus.google.com/share?url=https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/" onclick="window.open(this.href, 'google-plus-share', 'width=490,height=530');return false;" title="Google Plus" class="socialdark google"><i class="fa fa-google-plus"></i></a></li>
			<li><a href="http://www.reddit.com/submit?url=https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/&amp;title=First+Steps+After+Getting+an+Ubuntu+VPS" onclick="window.open(this.href, 'reddit-share', 'width=490,height=530');return false;" title="Reddit" class="socialdark reddit"><i class="fa fa-reddit"></i></a></li>
			<li><a href="http://pinterest.com/pin/create/button/?url=https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/&description=First+Steps+After+Getting+an+Ubuntu+VPS" onclick="window.open(this.href, 'pinterest-share', 'width=490,height=530');return false;" title="Pinterest" class="socialdark pinterest"></a></li>
			<li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https://www.rosehosting.com/blog/first-steps-after-getting-an-ubuntu-vps/&title=First+Steps+After+Getting+an+Ubuntu+VPS" onclick="window.open(this.href, 'linkedin-share', 'width=490,height=530');return false;" title="LinkedIn" class="socialdark linkedin"><i class="fa fa-linkedin"></i></a></li>		</ul>
	</div>

					</section>

					
	<section class="post-author-profile">
		<div class="inner">
			<div class="info" itemprop="author" itemscope="" itemtype="http://schema.org/Person">
				<a href="https://www.rosehosting.com/blog/author/r0s3admin/" class="profile gravatar"><img src="//0.gravatar.com/avatar/234567a4255f33b77eb9fffd943c2381?s=80" itemprop="image" alt="admin"></a>
				<div class="meta">
					<span class="title">Author</span>
						
					<h3 itemprop="name">
						<a href="https://www.rosehosting.com/blog/author/r0s3admin/" itemprop="url" rel="author">admin</a>
					</h3>						
				</div>
			</div>
			<hr>
			<p></p>
			<ul class="authorsocial">
									<li><a href="https://twitter.com/rosehosting" target="_blank" class="socialminimal twitter" title="Twitter"><i class="fa fa-twitter"></i></a></li>
													<li><a href="https://www.facebook.com/RoseHosting/" target="_blank" class="socialminimal facebook" title="Facebook"><i class="fa fa-facebook"></i></a></li>
																																																																															</ul>
		</div>
	</section>

					
	<section class="post-related post-related-count-3">
		<div class="post-footer-header">
			<h3><i class="fa fa-newspaper-o"></i>Related Articles</h3>
		</div>

		
		<a href="https://www.rosehosting.com/blog/install-zulip-on-ubuntu/" class="post-related-post">
			<div class="background" style="background-image:url('https://www.rosehosting.com/blog/wp-content/uploads/2016/07/zulip-ubuntu.jpg');"></div>
			<div class="info">
				<span class="category" style="background:#7fbb00;">Tutorials</span>				<h5>Install Zulip on Ubuntu</h5>
			</div>
		</a>
		
		<a href="https://www.rosehosting.com/blog/how-to-install-seafile-on-an-ubuntu-14-04-vps/" class="post-related-post">
			<div class="background" style="background-image:url('https://www.rosehosting.com/blog/wp-content/uploads/2015/03/seafile-logo.png');"></div>
			<div class="info">
				<span class="category" style="background:#7fbb00;">Tutorials</span>				<h5>How to install Seafile on an Ubuntu 14.04 VPS</h5>
			</div>
		</a>
		
		<a href="https://www.rosehosting.com/blog/what-is-linux-vps-hosting/" class="post-related-post">
			<div class="background" style="background-image:url('https://www.rosehosting.com/blog/wp-content/uploads/2017/03/what-is-linux-vps-hosting.jpg');"></div>
			<div class="info">
				<span class="category" style="background:#7fbb00;">Guides</span>				<h5>What is Linux VPS Hosting?</h5>
			</div>
		</a>
		
	</section>


					
	
	<section class="post-comments">

		<a class="commentanchor" id="comments"></a>

		<div class="post-footer-header">
			<h3><i class="fa fa-comment-o"></i>Comments</h3>
		</div>

		<div class="comments-main">

							
					<div class="commentwrap">
						<div class="notification nocomments"><i class="fa fa-info"></i> There are currently no comments.</div>
					</div>

							
				<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/first-steps-after-getting-an-ubuntu-vps/#respond" style="display:none;">Cancel Reply</a></small></h3>			<form action="https://www.rosehosting.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<textarea autocomplete="nope"  placeholder="Add your comment here..." id="a4cb3dcf3c"  name="6ae873f8be"  class="commentbody"  rows="5" tabindex="4"></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="nope" style="clip:rect(1px, 1px, 1px, 1px);position:absolute !important;white-space:nowrap;height:1px;width:1px;overflow:hidden;" tabindex="-1"></textarea><script type="text/javascript">document.getElementById("comment").setAttribute( "id", "9b008ff3cbb62f764fa1ffe501b51eda" );document.getElementById("a4cb3dcf3c").setAttribute( "id", "comment" );</script><input type="text" placeholder="Name (Required)" name="author" id="author" value="" size="22" tabindex="1" aria-required='true' />
<input type="text" placeholder="Email (Required)" name="email" id="email" value="" size="22" tabindex="1" aria-required='true' />
<input type="text" placeholder="Website URL" name="url" id="url" value="" size="22" tabindex="1" />
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='22112' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><div class="g-recaptcha" data-sitekey="6LfY7_4SAAAAAE2DEhMo9U4ZS1XLXf1qGXL9uzZC" data-theme="standard"></div><script type="text/javascript"src="https://www.google.com/recaptcha/api.js?hl=en"></script>            <div id="recaptcha-submit-btn-area">&nbsp;</div>
            <noscript>
            <style type='text/css'>#submit {display:none;}</style>
            <input name="submit" type="submit" id="submit-alt" tabindex="6"
                value="Submit Comment"/> 
            </noscript>			</form>
			</div><!-- #respond -->
	
		</div>

		
	</section>


				</div>

				
	<aside class="sidebar sidebar-page">

		<section class="widget widget_search" id="search-2">
	<form role="search" method="get" class="searchform" action="https://www.rosehosting.com/blog/">
		<input type="text" value="" name="s" class="query" placeholder="Search the Blog...">
		<i class="fa fa-search submit"></i>
	</form>
</section><section class="widget widget_text" id="text-26">			<div class="textwidget"><center><div style="display: block; width: 95%; height: 298px; text-align: center; background: none repeat scroll 0% 0% rgb(237, 237, 237); border-width: 0px; padding: 10px; border-style: solid;">
<div class='toptext'>
<h2 style="margin-top: 0px; color:rgb(219, 50, 50);"><strong>16th Anniversary Sale!</strong></h2>
<h2>Our Fully-Managed SSD Linux VPS, now with </br><strong>10% Discount Forever</strong>
</h2>
</div></br>
<a style="text-align: center; cursor: pointer; box-sizing: border-box; padding: 12px 30px; text-shadow: none; line-height: normal; vertical-align: top; border-width: 0px; width: 70%; background: none repeat scroll 0% 0% rgb(219, 50, 50); height: 55px; color: rgb(255, 255, 255); font-size: 23px; filter: none;" target="_blank" href="https://www.rosehosting.com/vps-hosting-anniversary-sale.html"><strong>BUY NOW</strong></a>
<div class='bottomtext'>
<strong>Hurry! Limited quantities available! </strong>
</div>
</div></center></div>
		</section><section class="widget widget_text" id="text-24">			<div class="textwidget"><center><div style="display: block; width: 95%; height: 365px; text-align: center; background: none repeat scroll 0% 0% rgb(237, 237, 237); border-width: 0px; padding: 10px; border-style: solid;">
<div class='toptext'>
<h2 style="margin-top: 0px; color:rgb(0, 100, 200);"><strong>Need Help with your Linux Server?</strong></h2>
<h2>We are here 24/7 - Linux server management and troubleshooting by LinuxHostSupport.com</strong>
</h2>
</div></br>
<a style="text-align: center; cursor: pointer; box-sizing: border-box; padding: 12px 30px; text-shadow: none; line-height: normal; vertical-align: top; border-width: 0px; width: 70%; background: none repeat scroll 0% 0% rgb(0, 100, 200); height: 55px; color: rgb(255, 255, 255); font-size: 23px; filter: none;" target="_blank" href="https://linuxhostsupport.com"><strong>START NOW</strong></a>
<div class='bottomtext'>
<strong>Get a free quote! </strong>
</div>
</div></center></div>
		</section><section class="widget widget_text" id="text-8">			<div class="textwidget"><!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/slim-081711.css" rel="stylesheet" type="text/css">
<style type="text/css">
 #mc_embed_signup{background:#fff; clear:left; font:24px Helvetica,Arial,sans-serif;  width:330px;}
 /* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
    We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="//rosehosting.us9.list-manage.com/subscribe/post?u=f1868632d497b649bacf4c210&amp;id=df0b8333a5" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank">
    <h4>Get all the newest Articles, Discounts and Coupons before everyone else</h4>
    <input style="width:100%;" type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="Enter email address" required>
    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;"><input type="text" name="b_f1868632d497b649bacf4c210_df0b8333a5" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Sign Up" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</form>
</div>
<!--End mc_embed_signup-->
</div>
		</section>
	</aside>

			</div>
		</section>

	


	<footer class="page-footer">

		
	<div class="notification noresults"><i class="fa fa-info"></i> No More Results</div>


		
	<section class="nextprev">
		<div class="wrapper-body">

						<a href="https://www.rosehosting.com/blog/how-to-install-webmin-on-centos-7/" class="nextprev-post previous">
								<div class="post-thumbnail">
					<div class="background" style="background-image:url('https://www.rosehosting.com/blog/wp-content/uploads/2017/04/install-webmin.jpg');"></div>
				</div>
								<div class="info">
					<span>Previous Post</span>
					<h4>How To Install Webmin on CentOS 7</h4>
				</div>
			</a>
			
			
		</div>
	</section>




<section id="before-footer" data-type="background" data-speed="10">
    <div class="before-footer">
        <div class="container">
            <div class="row">
                <div class="col-sm-12">

                    <h2 class="color-grey">Get started with RoseHosting Today.
                        <a href="https://secure.rosehosting.com/clientarea/index.php?/signup/" class="btn btn-lg btn-blue-belize no-margin" id="btn-signup-bottom" style="color:#fff;">Create Account</a>
                    </h2>
                </div>
            </div>
        </div>
    </div>
</section>

<footer class="main-footer">
    <div class="container">
        <div class="row">
            <div class="foottab">
                <div class="col-md-2 col-sm-6">
                    <ul class="list-unstyled">
                        <li class="title">Company</li>
                        <li><a href="https://www.rosehosting.com/about-us.html">About us</a></li>
                        <li><a href="https://www.rosehosting.com/policies.html">Our Policies</a></li>
                        <li><a href="https://www.rosehosting.com/contact-us.html">Contact Us</a></li>
                        <li><a href="https://www.rosehosting.com/blog">Blog</a></li>
                        <li><a href="https://www.rosehosting.com/why-rosehosting.html">Why Rosehosting</a></li>
                        <li><a href="https://www.rosehosting.com/compare-to-competition.html">Compare Us</a></li>
                        <li><a href="https://www.rosehosting.com/awards.html">Awards &amp; Recognition</a><li>
                    </ul>
                </div>
                <div class="col-md-2 col-sm-6">
                    <ul class="list-unstyled">
                        <li class="title">Support</li>
                        <li><a href="https://secure.rosehosting.com/clientarea/index.php?/tickets/">Helpdesk System</a></li>
                        <li><a href="https://secure.rosehosting.com/clientarea/index.php?/knowledgebase">Knowledge Base</a></li>
                        <li><a href="https://status.rosehosting.com">Systems Status</a></li>
                    </ul>
                </div>
            </div>
            <div class="foottab">
                <div class="col-md-2 col-sm-6">
                    <ul class="list-unstyled">
                        <li class="title">Hosting Solutions</li>
                        <li><a href="https://www.rosehosting.com/linux-shared-hosting.html">Linux Shared Hosting</a></li>
                        <li><a href="https://www.rosehosting.com/linux-vps-hosting.html">Linux VPS Hosting</a></li>
                        <li><a href="https://www.rosehosting.com/vps-hosting-stacks.html">VPS Hosting Stacks</a></li>
                        <li><a href="https://secure.rosehosting.com/clientarea/?cmd=cart&amp;action=add&amp;id=54">Custom VPS</a></li>
                        <li><a href="https://www.rosehosting.com/cloud-server-oci-hosting.html">OneClick Install Cloud</a></li>
                        <li><a href="https://www.rosehosting.com/dedicated-servers.html">Dedicated Servers</a></li>
                        <li><a href="https://www.rosehosting.com/vps-affiliate-program.html">Affiliate Program</a></li>
                    </ul>
                </div>
                <div class="col-md-2 col-sm-6">
                    <ul class="list-unstyled">
                        <li class="title">Linux VPS Hosting</li>
                        <li><a href="https://www.rosehosting.com/centos-vps.html">CentOS VPS</a></li>
                        <li><a href="https://www.rosehosting.com/ubuntu-vps.html">Ubuntu VPS</a></li>
                        <li><a href="https://www.rosehosting.com/debian-vps.html">Debian VPS</a></li>
                        <li><a href="https://www.rosehosting.com/opensuse-vps.html">OpenSUSE VPS</a></li>
                        <li><a href="https://www.rosehosting.com/arch-linux-vps.html">Arch-Linux VPS</a></li>
                        <li><a href="https://www.rosehosting.com/scientific-linux-vps.html">Scientific Linux VPS</a></li>
                    </ul>
                </div>
            </div>
            <div class="foottab">
                <div class="col-md-2 col-sm-6">
                    <ul class="list-unstyled">
                        <li class="title">Other Services</li>
                        <li><a href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/">Domain Registration</a></li>
                        <li><a href="https://secure.rosehosting.com/clientarea/index.php?/checkdomain/domain-registration/#transfer">Domain Transfer</a></li>
                        <li><a href="https://www.rosehosting.com/ssl-certificates.html">SSL Certificates</a></li>
                        <li><a href="https://www.e-onlinedata.com/rosehosting" target="_blank">Merchant Accounts</a></li>
                        <li><a href="http://www.rosehosting.com/server-monitoring.html">Server Monitoring</a></li>
                    </ul>
                </div>
                <div class="col-md-2 col-sm-6">
                    <ul class="social-links list-unstyled">
                        <li class="title">Contact Us</li>
                        <li><a href="tel:+18887673467">(888) ROSE-HOST</a></li>
                        <li><a href="tel:+18887673467">(888) 767-3467</a></li>
                        <li><a href="tel:+16465197201">(314) 275-0414</a></li>
                        <li><a href="mailto:support@rosehosting.com">Email us</a></li>
                        <li class="title social-title">Connect</li>
                        <li><a href="https://twitter.com/rosehosting" target="_blank"><i class="fa fa-twitter fa-fw"></i> Twitter</a></li>
                        <li><a href="https://www.facebook.com/RoseHosting" target="_blank"><i class="fa fa-facebook fa-fw"></i> Facebook</a></li>
                        <li><a href="https://www.google.com/+Rosehosting" target="_blank"><i class="fa fa-google-plus fa-fw"></i> Google+</a></li>
                        <li><a href="https://www.linkedin.com/in/rosehosting" target="_blank"><i class="fa fa-linkedin fa-fw"></i> LinkedIn</a></li>
                        <li><a href="https://www.rosehosting.com/blog/feed/" target="_blank"><i class="fa fa-rss fa-fw"></i> RSS Feed</a></li>
                    </ul>
                </div>
            </div>
        </div> <!-- END ROW -->
        <hr>
        <div class="row">
            <div class="col-sm-6 tos-links">
            
            </div>
                    <div class="col-sm-6 tos-links">
                        <p class="muted pull-right">&copy; 2001-2017 <a class="inline-link footer-policy" href="http://www.rosewebservices.com/">Rose Web Services LLC</a>.</p>
                    </div>
        </div> <!-- END ROW -->

    </div> <!-- END CONTAINER -->
</footer>

<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-P4FHJW"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P4FHJW');</script>
<!-- End Google Tag Manager -->

<!-- livezilla.net code -->
<script type="text/javascript" id="aff1f81b02f303eea5f87a3a065f153a" src="https://linuxhostsupport.com/chat//script.php?id=aff1f81b02f303eea5f87a3a065f153a"></script>
<!-- http://www.livezilla.net -->



	<div class="backtotop"><i class="fa fa-angle-double-up"></i></div>
</footer>


	<script type="application/ld+json">{
    "@context": "http://schema.org",
    "@type": "Organization",
    "additionalType": "WebHosting",
    "name": "RoseHosting.com",
    "logo": null,
    "url": "https://www.rosehosting.com/blog",
    "sameAs": [
        "https://twitter.com/rosehosting",
        "https://www.facebook.com/RoseHosting",
        "https://www.google.com/+Rosehosting",
        "https://www.linkedin.com/in/rosehosting"
    ],
    "contactPoint": {
        "@type": "ContactPoint",
        "telephone": "(888) 767-3467",
        "contactType": "Customer Service",
        "email": "",
        "contactOption": "TollFree",
        "areaServed": "Canada,Mexico,United States",
        "availableLanguage": "English"
    },
    "address": {
        "@type": "PostalAddress",
        "addressCountry": "United States",
        "addressLocality": "Saint Louis",
        "addressRegion": "MO",
        "postalCode": "63368",
        "streetAddress": "2977 Hwy K #252"
    }
}</script>            <script type="text/javascript">
            var sub = document.getElementById('submit');
            document.getElementById('recaptcha-submit-btn-area').appendChild (sub);
            document.getElementById('submit').tabIndex = 6;
            if ( typeof _recaptcha_wordpress_savedcomment != 'undefined') {
                document.getElementById('comment').value = 
                    _recaptcha_wordpress_savedcomment;
            }
            </script><script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/eckoplugin/assets/js/eckoplugin.js?ver=2.6.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ecko_theme_vars = {"general_hidecomments":"false","general_disable_syntax_highlighter":"false","topbar_disable_sticky":"","postpage_enable_cover_fade":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/themes/rh2016/assets/js/theme.min.js?ver=2.2.1'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/comment-reply.min.js?ver=4.7.4'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.0.4'></script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-includes/js/wp-embed.min.js?ver=4.7.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ism_facebook_id = "451422911728872";
var ism_base_path = "https:\/\/www.rosehosting.com\/blog";
/* ]]> */
</script>
<script type='text/javascript' src='https://www.rosehosting.com/blog/wp-content/plugins/indeed-social-media/files/js/front_end_footer.js'></script>

<script>
// jQuery('#awardsModal').appendTo("body");
</script>

</body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 2728/2777 objects using memcached
Page Caching using memcached
Content Delivery Network via www.rosehosting.com
Database Caching 2/21 queries in 0.011 seconds using memcached

 Served from: www.rosehosting.com @ 2017-05-07 08:57:54 by W3 Total Cache -->